Определение линий сгиба — стандартный режим

Краткий обзор

В этой статье рассказывается, как задавать, размещать, перемещать, удалять и настраивать линии сгиба гибких областей при работе в режиме Standard Rigid-Flex в Altium Designer. Также объясняется, чем Standard Rigid-Flex отличается от режима Advanced Rigid-Flex, как проверить, какой режим используется для вашей платы, и какие представления редактора и панели помогают точно настраивать сгибы. Если вам нужно практическое руководство по настройке положения, угла и радиуса сгиба, ширины затрагиваемой области и порядка сгибания в соответствующем режиме, эта статья поможет вам работать увереннее. Читайте дальше и применяйте эти действия в своём следующем проекте.

- Узнайте, когда можно использовать линии сгиба в режиме Standard Rigid-Flex и чем этот режим отличается от Advanced Rigid-Flex при задании областей платы.
- Ознакомьтесь с точной последовательностью действий для размещения, перемещения, удаления и точного выравнивания линий сгиба в режиме планирования платы (Board Planning Mode).
- Разберитесь, какие свойства линии сгиба можно настраивать, включая угол и радиус сгиба, ширину затрагиваемой области и последовательность сгибания для проверки сгибания платы в 3D.
Узнайте больше с ИИ:

В программном обеспечении Altium для проектирования печатных плат доступны два режима проектирования гибко-жестких плат. Исходный, или стандартный, режим Rigid-Flex поддерживает простые гибко-жесткие конструкции. Если проект предъявляет более сложные требования к гибко-жесткой плате, например предусматривает перекрывающиеся гибкие области, необходимо использовать режим Advanced Rigid-Flex (также известный как rigid-flex 2.0). Режим выбирается в меню Tools в менеджере стека слоев.

Основное различие между режимами заключается в том, что в исходном режиме форма платы делится на отдельные области с помощью линии разделения (Split Line). Эта линия остается объектом, определяющим, где заканчивается одна область платы и начинается другая. В расширенном режиме каждая область платы размещается отдельно, а при разрезании более крупной области образуются два отдельных объекта области. В расширенном режиме место стыка двух соседних областей определяется их краями, а не наличием линии разделения. Поэтому в режиме Advanced Rigid-Flex объект линии разделения отсутствует.

► Подробнее о проектировании гибко-жесткой печатной платы

В меню View доступны три режима работы редактора печатных плат с легко запоминающимися сочетаниями клавиш, позволяющими быстро переключаться между ними:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

По умолчанию при переключении между режимами 2D- и 3D-просмотра для каждого режима сохраняются отдельные настройки масштаба и ориентации. Чтобы при переключении видеть тот же участок платы в той же ориентации, нажмите Ctrl+Alt+2 или Ctrl+Alt+3 вместо 2 или 3.

Вы только что открыли печатную плату и хотите узнать, какой режим гибко-жесткого проектирования в ней используется — стандартный или расширенный?

Это можно проверить, открыв менеджер стека слоев. Другой способ — переключиться в режим планирования платы (сочетание клавиш 1) и посмотреть на панель Active Bar:

Стандартный режим Rigid-Flex
Расширенный режим Advanced Rigid-Flex

Чтобы задать, как должна изгибаться гибкая плата, разместите одну или несколько линий сгиба (Bending Line). Линия сгиба определяет место сгиба на поверхности гибкой области. Она также задает угол и радиус сгиба и ширину изгибаемой полосы поверхности платы. Линии сгиба размещаются и редактируются в редакторе печатных плат в режиме Board Planning Mode (View » Board Planning Mode или нажмите сочетание клавиш 1).

Линию сгиба можно разместить только в области, настроенной как область Flex в Layer Stack Manager.


Линия сгиба размещена на гибкой области и настроена так, чтобы плата могла сгибаться на 180 градусов. В этом видео показано размещение линии сгиба в стандартном режиме Rigid-Flex.

Размещение линии сгиба

Чтобы разместить линию сгиба:

  1. Выберите View » Board Planning Mode или нажмите сочетание клавиш 1, чтобы перейти в Board Planning Mode.

  2. Линии сгиба размещаются на слое Multi-Layer. Если вкладка Mutli-Layer не отображается в нижней части рабочей области, включите этот слой на панели View Configuration (сочетание клавиш L открывает панель).

  3. Выберите команду Design » Define Bending Line.

  4. Щелкните внутри области платы, в которой нужно разместить линию сгиба. Один конец линии прикрепится к ближайшему к месту щелчка краю области, а другой — к курсору.

  5. Переместите второй конец в нужное место и щелкните один раз, чтобы зафиксировать его.

  6. Режим размещения линий сгиба останется активным, и при необходимости вы сможете разместить еще одну линию. Чтобы выйти из этого режима, щелкните правой кнопкой мыши или нажмите Esc.

На панели PCB в режиме Layer Stack Regions отображаются данные Bending Lines. Дважды щелкните запись, чтобы открыть диалоговое окно Bending Line. 

В этой гибкой области платы размещены три линии сгиба. Ширина оранжевой полосы — это ширина затрагиваемой области.
В этой гибкой области платы размещены три линии сгиба. Ширина оранжевой полосы — это ширина затрагиваемой области.

Когда для области платы назначается гибкий стек слоев, через ее геометрический центр автоматически добавляется вертикальная линия сгиба. При необходимости удалите эту линию либо переместите и настройте ее.

Перемещение линии сгиба

Чтобы изменить положение существующей линии сгиба:

  1. Выберите View » Board Planning Mode (или нажмите сочетание клавиш  1), чтобы перейти в Board Planning Mode.
  2. Щелкните один раз, чтобы выбрать область платы, содержащую линию сгиба. Отобразятся маркеры всех линий сгиба в этой области.
  3. Чтобы переместить конец линии, нажмите и удерживайте кнопку мыши на узле и перетащите его в нужное место на периметре контура области платы. Курсор будет привязываться к текущей сетке привязки и/или существующим объектам проекта.
  4. Место сгиба будет определено заново в соответствии с новым положением линии сгиба.

Выберите и перетащите конечный узел линии сгиба, чтобы изменить положение сгиба на плате.
Выберите и перетащите конечный узел линии сгиба, чтобы изменить положение сгиба на плате.

Точное позиционирование линии сгиба

При перемещении линии сгиба ее маркер привязывается к узлам текущей сетки привязки. Во время перемещения он также может привязываться к существующим объектам проекта, например к линиям на механическом слое. На рисунке ниже показано размещение маркера линии сгиба на конце линии на слое Mechanical 2 (обозначено цифрой 1). Обратите внимание: чтобы привязка работала, механический слой должен быть активным слоем проектирования.

Цифрой 1 обозначен маркер линии сгиба, привязанный к линии на слое Mechanical 2; обратите внимание, что этот слой активен.
Цифрой 1 обозначен маркер линии сгиба, привязанный к линии на слое Mechanical 2; обратите внимание, что этот слой активен.

Чтобы подробнее показать описанный выше процесс, на следующих изображениях приведены вспомогательные линии, размещенные на слое Mechanical 2 в режиме 2D Layout Mode. Они точно задают верхнюю и нижнюю опорные точки, которые можно использовать для размещения линии сгиба под углом 45 градусов.

Плата в режиме 2D-топологии со вспомогательными линиями для точного размещения диагональных линий сгиба.Плата в режиме 2D-топологии со вспомогательными линиями для точного размещения диагональных линий сгиба.

Плата в режиме планирования платы с диагональными линиями сгиба, привязанными к вспомогательным линиям на слое Mechanical 2.Плата в режиме планирования платы с диагональными линиями сгиба, привязанными к вспомогательным линиям на слое Mechanical 2.

Удаление линии сгиба

Чтобы удалить линию сгиба:

  1. Выберите View » Board Planning Mode (или нажмите сочетание клавиш 1), чтобы перейти в Board Planning Mode.
  2. Нажмите и удерживайте кнопку мыши на одной из конечных точек линии, затем нажмите клавишу Delete. Другой способ — выбрать и удалить запись линии сгиба в разделе Bending Lines панели PCB .

Когда для области платы назначается гибкий стек слоев, через ее геометрический центр автоматически добавляется вертикальная линия сгиба. При необходимости удалите эту линию либо переместите и настройте ее.

Настройка свойств линии сгиба

Области платы, линии разделения и линии сгиба просматриваются и редактируются в Board Planning Mode (нажмите 1). Линии сгиба можно редактировать интерактивно в рабочей области или с помощью PCB панели, когда она находится в режиме Layer Stack Regions. Чтобы открыть панель, нажмите кнопку Panels в правом нижнем углу Altium Designer, затем выберите PCB в меню. В раскрывающемся списке в верхней части панели выберите Layer Stack Regions. В этом режиме на панели отображаются:

  • Доступные стеки слоев платы в области Layer Stacks.
  • Области платы, которым назначены эти стеки, в разделе Stackup Regions.
  • Линии сгиба, заданные в выбранной области платы, в разделе Bending Lines.

При переходе в Board Planning Mode панель PCB автоматически переключается в режим Layer Stack Regions.

Чтобы изменить свойства линии сгиба на панели PCB:

  1. Линии сгиба можно редактировать в 2D Layout Mode (нажмите 2) или в Board Planning Mode (нажмите 1).
  2. Установите флажок Select в верхней части панели.
  3. Выберите область платы, содержащую линию сгиба, в разделе Stackup Regions панели PCB .
  4. Выберите линию сгиба в списке раздела Bending Lines панели. Линия сгиба будет подсвечена (выделена) на плате, если на панели PCB включен параметр Select. Запись линии сгиба также можно удалить из раздела Bending Lines.
  5. Дважды щелкните запись линии сгиба в разделе Bending Lines, чтобы открыть диалоговое окно Bending Line, показанное на изображении ниже.

  6. В диалоговом окне Bending Line измените два из первых трех свойств, например Radius (расстояние от поверхности сгиба до центра сгиба) и Bending Angle (угол, на который должна изгибаться поверхность гибкой области). Третье свойство — Affected area width (ширина участка поверхности, который будет изогнут при заданных Radius и Bending Angle) — рассчитывается автоматически (подробнее об этом ниже). Обратите внимание, что Affected area width каждой линии сгиба отображается в виде области с оранжевой заливкой.
  7. В диалоговом окне Bending Line задайте нужное значение Fold Index, чтобы определить последовательность выполнения сгибов при использовании ползунка Fold State на панели PCB или команды View » Fold/Unfold, которые предназначены для сгибания платы в 3D-режиме. Первым выполняется сгиб с наименьшим значением, последним — с наибольшим.

Для одной из областей платы необходимо установить флажок 3D Locked в диалоговом окне Board Region, чтобы задать опорную плоскость для 3D-режима отображения (где Z = 0). В противном случае Affected area width для каждой заданной линии сгиба не будет отображаться.

Диалоговое окно Bending Line также можно открыть, нажав Tab при размещении или перемещении маркера линии сгиба либо дважды щелкнув этот маркер.

Краткое описание задания сгибов

Линия сгиба — это линейный объект, который размещается поперек области платы и определяет положение, радиус и угол сгиба этой гибкой области.

Задание линии сгиба:

  • Линии сгиба размещаются в режиме планирования платы (сочетание клавиш 1).
  • Чтобы разместить линию сгиба, выполните команду Design » Define Bending Line.
  • Разместите линию сгиба поперек гибкой области платы. Необязательно точно совмещать начало и конец линии сгиба с краями области: программа автоматически удлинит линию (если она слишком короткая) или укоротит ее (если она слишком длинная). Хотя бы один конец линии сгиба должен касаться края области или выходить за него.
  • Чтобы изменить свойства линии сгиба, щелкните в любом месте области — отобразятся вершины всех линий сгиба в этой области. Затем:
    • Дважды щелкните вершину линии сгиба, чтобы открыть диалоговое окно линии сгиба, или
    • Откройте панель PCB и переключите ее в режим Layer Stack Regions, в котором можно просматривать и редактировать области платы и линии сгиба.
    • Задайте необходимые значения Bending Angle и Radius сгиба.
    • Сгибы выполняются в порядке, заданном параметром Fold Index. Используйте эту возможность, когда важно проверить последовательность сгибания.
  • Чтобы переместить линию сгиба, перетащите каждую из ее вершин.
  • Чтобы удалить линию сгиба, нажмите и удерживайте кнопку мыши на одной из вершин, затем нажмите Delete на клавиатуре.
  • Линии сгиба нельзя размещать на краю выреза в плате. Если это необходимо для вашей платы, переключитесь в расширенный режим проектирования жестко-гибких плат (Rigid-Flex Advanced).
AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents