Altium Designer Documentation

Testpoint Setup

Последнее изменение: Susan Riege; 02.02.2019
Эта страница документации относится к Altium Vault – продукту, который больше не поддерживается. Altium Vault и его функциональные возможности по управлению компонентами теперь доступны в Altium Concord Pro.

     The two varations of the Testpoint Setup dialog

Summary

The Assembly/Fabrication Testpoint Setup dialog is used to configure testpoint reports. The banner of this dialog will change (either Assembly or Fabrication) depending on whether it was accessed to configure options for an Assembly or a Fabrication Testpoint report.

Testpoints are assigned manually or can be detected automatically by running the Testpoint Manager

Access

Testpoint output can be generated in one of two ways:

  • By using an Assembly or Fabrication Test Point Report output generator in an OutputJob Configuration file (*.OutJob). Output is generated when the configured output generator is run.
  • Directly from within the active PCB document using File » Fabrication Outputs » Test Point Report or File » Assembly Outputs » Test Point Report. Output will be generated immediately upon clicking OK in the dialog.
The settings defined in the Testpoint Setup dialog when generating output directly from the PCB are distinct and separate to those defined for the same output type in an Output Job Configuration file. In the former, the settings are stored in the project file; for the latter, they are stored in the Output Job Configuration file.

Options/Controls

Report Formats

  • Text - enable for standard text format in the report.
  • CSV - enable for standard comma separated value format, which can be imported into a spreadsheet application, such as Excel, for further processing.
  • IPC-D-356A - enable for an IPC netlist file which carries blind and buried via information as well as differentiating between through-hole vias and free pads. When imported into a CAM document along with image and drill data, it facilitates the recovery of original net names used in the PCB design, making the PCB easier to understand and manage within the CAM Editor.

Test Point Layers 

These selections allow you to specify a scope for the report:

  • Top layer - check to include valid testpoints assigned on the top of the board.
  • Bottom layer - check to include valid testpoints assigned on the bottom of the board.

Units

  • Imperial - check to output coordinates in inches.
  • Metric - check to output coordinates in millimeters.

Coordinate Positions

  • Reference to absolute origin - select to use the absolute origin as the reference point for testpoint coordinates.
  • Reference to relative origin - select to use the relative origin as the reference point for testpoint coordinates.

IPC-D-356A Options 

This region of the dialog becomes available only when the IPC-D-356A Report Format option is enabled.
  • Adjacency Information - check to include a list of nets that could possibly be shorted, then enter the adjacency criteria in the text box.
  • Board Outline - check to permit the description of outlines and other segment type data that are not connected to a specific net.  Use the drop down to select the desired information.
  • Conductor Traces - Refer to the IPC-D-356A spec for more detail.

Generated Files

All generated testpoint files are named first by type (Fabrication or Assembly), then by filename. For example: Fabrication Testpoint Report for BoardFileName. The following file extensions are used, depending on which of the Report Formats is enabled: .txt, .CSV, .IPC (note that this is an ASCII file).

Location of Generated Files

The output path for generated files depends on how the output was generated:

  • From an OutputJob file - the generated files are stored in a folder within the project folder. The naming and folder structure is defined in the Output Container that the Testpoint output is targeting.
  • Directly from the PCB - the output path is specified in the Project Options - Options dialog. By default, the output path is set to a sub-folder under the folder that contains the Project file and has the name: Project Outputs for ProjectName. The output path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options tab, then the Testpoint files will be written to a further sub-folder named Testpoint Output.

Automatically Opening the Generated Output

When generating Testpoint output, you can specify that the output be opened automatically in a new CAM document. The way in which this is accomplished depends on how you are generating the output:

  • From an OutputJob file - enable the IPC-D-356A Output auto-load option in the Output Job Options dialog (Tools » Output Job Options from the OutputJob Editor).
  • Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Project Options dialog (Project » Project Options).
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.