Làm việc với các khối 3D đùn, hình cầu và hình trụ
Sơ lược
- Tìm hiểu sự khác biệt giữa các đối tượng khối 3D dạng đùn, trụ và cầu, cùng cách xác định và đặt từng loại.
- Xem cách sử dụng bảng Properties và các phím tắt trong khi thực hiện lệnh để điều khiển kích thước, hình thức hiển thị và cách thức đặt hình dạng.
- Hiểu cách tạo và quản lý các khối 3D từ những hình dạng có sẵn trong footprint bằng Component Body Manager, bao gồm các tùy chọn cho từng linh kiện và cập nhật hàng loạt.
Mặc dù đặt các mô hình 3D tổng quát là cách được khuyến nghị khi sử dụng đối tượng 3D Body, vì cách này giúp biểu diễn linh kiện trên PCB một cách chính xác, chi tiết và cho phép kiểm tra va chạm 3D chính xác hơn trong trình biên tập PCB, đối tượng 3D Body cũng có thể được dùng để đặt các khối 3D dạng đùn, hình cầu và hình trụ. Có thể đặt ba kiểu đối tượng 3D Body đơn giản:
| Extruded | Trong mặt phẳng X-Y (góc nhìn từ trên xuống), đối tượng dạng đùn được xác định tương tác, tương tự như cách xác định các đối tượng đa giác khác trong trình biên tập PCB. Sau đó, đối tượng được đùn lên (hoặc xuống) theo phương Z, dựa trên các thuộc tính Overall Height và Standoff Height được xác định trong chế độ 3D Body của bảng Properties, cùng tùy chọn Body Projection. Bạn cũng có thể áp dụng tệp kết cấu, chẳng hạn như logo, lên bề mặt của đối tượng 3D Body dạng đùn. |
| Cylindrical | Các thuộc tính của hình dạng này được xác định trong chế độ 3D Body của bảng Properties. |
| Spherical | Các thuộc tính của hình dạng này được xác định trong chế độ 3D Body của bảng Properties. |
Đặt đối tượng 3D Body dạng đùn, hình cầu hoặc hình trụ
Đặt trực tiếp
Có thể đặt các đối tượng 3D Body dạng đùn, hình cầu và hình trụ trong cả trình biên tập PCB lẫn trình biên tập footprint PCB bằng cách:
- Chọn lệnh Place » Extruded 3D Body từ các menu chính.
- Tìm và sử dụng lệnh 3D Body dạng đùn trên Active Bar.
Để đặt đối tượng 3D Body dạng đùn, hình cầu hoặc hình trụ:
- Sau khi khởi chạy lệnh, con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ ở chế độ đặt mặc định để đặt đối tượng 3D Body dạng đùn.
- Nhấn Tab để tạm dừng thao tác đặt và hiển thị bảng Properties ở chế độ 3D Body. Nút tạm dừng dạng lớp phủ sẽ xuất hiện trong không gian thiết kế, cho biết bạn có thể truy cập các trường của bảng Properties.
- Trong bảng Properties, nhập tên cho 3D Body vào trường Identifier. Thao tác này là tùy chọn; mã định danh có thể hữu ích khi đặt nhiều 3D Body và cũng có thể dùng để chỉ định 3D Body này trong một quy tắc thiết kế nếu cần.
-
Chọn Board Side cần dùng; thông thường, mục này được đặt thành
Top. Trong trình biên tập thư viện PCB, footprint được tạo cho mặt trên của bo mạch; có thể lật footprint xuống mặt dưới trong quá trình thiết kế PCB nếu cần. - Chọn Layer cơ khí để đặt 3D Body. Các lớp cơ khí kiểu linh kiện nên được ghép cặp với một lớp cơ khí thứ hai để khi linh kiện được lật từ mặt trên xuống mặt dưới của bo mạch, các chi tiết cơ khí của nó, chẳng hạn như 3D Body, sẽ chuyển sang lớp cơ khí được ghép cặp. Các lớp cơ khí được ghép cặp trong tab Layers and Colors của bảng View Configuration. Tham khảo trang tài liệu về bảng này để biết thêm thông tin.
- Chọn 3D Model Type từ các hình dạng có sẵn: Extruded, Cylinder hoặc Sphere.
-
Mỗi hình dạng phải có kích thước được xác định trước khi đặt. Nếu hình dạng được chọn là:
- Extruded – thì xác định Overall Height.
- Cylinder – xác định Height và Radius.
- Sphere – xác định Radius.
- Trong vùng Display của bảng, nhấp vào nút Color để thiết lập màu sắc và điều chỉnh Opacity theo yêu cầu.
-
Sau khi chỉnh sửa xong, nhấp vào nút tạm dừng dạng lớp phủ để quay lại không gian thiết kế.
-
Nếu hình dạng là Cylinder hoặc Sphere:
- Con trỏ sẽ di chuyển trong không gian thiết kế với một hình chữ nhật đi kèm; nhấp để đặt 3D Body.
- Nhấp chuột phải hoặc nhấn Esc để kết thúc việc đặt đối tượng 3D Body.
-
Nếu hình dạng là Extruded, con trỏ sẽ xuất hiện, sẵn sàng để xác định hình đa giác làm đáy cho 3D Body dạng đùn:
- Nhấp để xác định đỉnh đầu tiên.
- Di chuyển con trỏ đến vị trí đặt đỉnh thứ hai. Theo mặc định, mỗi lần nhấp sẽ đặt hai cạnh, với hình dạng góc do người dùng xác định giữa chúng. Tham khảo phần Các chế độ đặt 3D Body dạng đùn bên dưới để tìm hiểu thêm.
- Tiếp tục di chuyển chuột và nhấp để đặt các đỉnh tiếp theo.
- Sau khi đặt đỉnh cuối cùng, nhấp chuột phải hoặc nhấn Esc để khép kín và hoàn tất việc đặt 3D Body. Không cần khép kín 3D Body theo cách thủ công vì phần mềm sẽ tự động hoàn thiện hình dạng bằng cách nối điểm bắt đầu với điểm cuối cùng đã đặt.
-
Nếu hình dạng là Cylinder hoặc Sphere:
Các chế độ đặt 3D Body dạng đùn
Khi đặt 3D Body dạng đùn, có năm chế độ góc, trong đó bốn chế độ có thêm các chế độ phụ về hướng góc. Trong quá trình đặt:
- Nhấn Shift+Spacebar để chuyển tuần tự qua năm chế độ góc có sẵn.
- Nhấn Spacebar để chuyển đổi giữa hai chế độ phụ về hướng góc.
-
Khi ở một trong các chế độ góc dạng cung, giữ phím
hoặc
để thu nhỏ hoặc mở rộng cung. Giữ phím Shift trong khi nhấn để tăng tốc độ thay đổi kích thước cung.
- Nhấn phím tắt 1 để chuyển đổi giữa việc đặt hai cạnh mỗi lần nhấp hoặc một cạnh mỗi lần nhấp. Trong chế độ thứ hai, cạnh nét đứt được gọi là look-ahead segment.
- Nhấn phím Backspace để xóa đỉnh cuối cùng.

Một đối tượng 3D Body dạng đùn; lưu ý điểm tham chiếu được hiển thị trong các góc nhìn 2D và 3D.
Tạo từ các hình dạng khép kín
Để đẩy nhanh quá trình dựng hình dạng linh kiện từ các đối tượng 3D Body, phần mềm có thể tạo một loạt đối tượng 3D Body dạng đùn dựa trên các hình khép kín được phát hiện trong footprint. Tính năng này có thể hữu ích nếu linh kiện có hình dạng khác thường và hình dạng đó đã được thể hiện trong các hình được định nghĩa trên lớp overlay của linh kiện trong footprint. Bạn cũng có thể thêm các đối tượng vào footprint trên các lớp cơ khí, rồi dùng chúng để tạo thêm các đối tượng 3D Body, ví dụ như tạo các chân linh kiện.
Các hình bên dưới minh họa footprint của một transistor TO-92. Đường bao được vẽ trên lớp Top Overlay được dùng để xác định thân transistor trên cặp lớp 3D Body đã chọn (được gọi là Registration Layer trong hộp thoại). Ngoài ra, ba hình vuông nhỏ cũng đã được tạo trên một lớp cơ khí (mỗi hình vuông được tạo từ bốn đường thẳng), dùng để xác định các chân linh kiện trên cặp lớp 3D Body đã chọn – các thiết lập được minh họa trong hình hộp thoại bên dưới.

Các đối tượng hiện có trong footprint có thể được dùng để tạo các đối tượng 3D Body mới.
Để tạo các đối tượng 3D Body từ các hình trong footprint, hãy chạy lệnh Tools » Manage 3D Bodies for Current Component; hộp thoại Component Body Manager sẽ mở ra. Dùng hộp thoại này để xem những khối 3D nào đang được sử dụng trong linh kiện và những khối nào chưa được sử dụng. Bạn có thể thêm khối vào và/hoặc loại bỏ khối khỏi linh kiện theo nhu cầu. Có ba loại khối khác nhau:
- Một đối tượng 3D Body được đặt có chủ đích (được gọi là Component Body trong phần mô tả).
- Một hình chữ nhật được phần mềm tự động tạo từ hình chữ nhật bao.
- Một hình đa giác khép kín được phần mềm tự động tạo từ các đối tượng thiết kế cơ bản.
Bạn cũng có thể thay đổi các thuộc tính khác của khối, chẳng hạn như chiều cao, hình chiếu khối, lớp tham chiếu, màu sắc và độ đục. Lưu ý rằng cột Body State cho biết có bốn hình sẽ được dùng để tạo các đối tượng 3D Body.
Sau khi các khối 3D của linh kiện đã được xác định theo yêu cầu, nhấp vào nút Close để áp dụng các thay đổi.

Phần mềm có thể tạo các đối tượng 3D Body dựa trên hình dạng của các đối tượng hiện có.
Lưu ý khi sử dụng hộp thoại này:
- Thuật toán phát hiện sẽ đề xuất một trong hai dạng: hình chữ nhật được tạo từ hình chữ nhật bao, hoặc hình đa giác bám theo đường bao của hình được tạo bởi các đối tượng cơ bản (được dò theo đường tâm của các đường mạch/cung tròn nếu các điểm cuối của chúng trùng nhau).
- Để tạo một 3D Body từ đối tượng hiện có, nhấp vào chữ màu xanh lam trong cột Body State.
- Overall Height mặc định là Height được xác định trong bảng Properties của footprint.
- Đối với chân linh kiện xuyên xuống qua bo mạch, đặt Body Projection thành Bottom Side.
- Các đối tượng 3D Body được tạo khi bạn nhấp vào nút Close trong hộp thoại. Nếu màn hình đã ở chế độ 3D, bạn có thể cần: làm mới màn hình (phím tắt End), chuyển sang 2D rồi trở lại 3D, hoặc chuyển tùy chọn Show 3D Bodies giữa Off và On trong tab View Options của bảng View Configurations để thấy các đối tượng mới.
- Để chỉnh sửa các 3D Body của tất cả linh kiện trong thư viện footprint PCB đang hoạt động và đang mở trong trình chỉnh sửa footprint PCB, chọn lệnh Tools » Manage 3D Bodies for Library từ các menu chính.
- Để chỉnh sửa các 3D Body trong trình chỉnh sửa PCB bằng hộp thoại này, bạn có thể truy cập hộp thoại bằng cách chọn lệnh Tools » Manage 3D Bodies for Components on Board từ các menu chính hoặc nhấp chuột phải vào một linh kiện và chọn Thao tác với linh kiện » Quản lý khối 3D từ menu ngữ cảnh.
-
Khi hộp thoại được mở bằng lệnh Tools » Manage 3D Bodies for Components on Board (trong trình chỉnh sửa PCB) hoặc lệnh Tools » Manage 3D Bodies for Library (trình chỉnh sửa footprint PCB), vùng Components sẽ xuất hiện ở phía trên cùng của hộp thoại. Vùng này liệt kê từng footprint linh kiện trong thư viện đang hoạt động (trong thiết kế thực tế, đây sẽ là danh sách tất cả linh kiện trên bo mạch). Với mỗi mục, thông tin được hiển thị gồm ký hiệu định danh (chỉ có ở phía thiết kế), tên footprint, chiều cao và thư viện nguồn.
Ngoài ra, sẽ có thêm một tab Batch Update. Tab này cung cấp chức năng thêm nhanh hàng loạt đối tượng 3D Body vào tất cả hoặc các linh kiện được chọn. Bạn có thể xác định tiêu chí tìm kiếm để phát hiện và tạo các khối 3D, cũng như xác định thuộc tính của chúng. Sau khi xác định tất cả tùy chọn cho quá trình xử lý hàng loạt theo yêu cầu, nhấp vào nút Execute Batch Update. Quá trình tìm kiếm sẽ được thực hiện cho từng linh kiện có trong quy trình này; khi một hình dạng khối 3D được phát hiện và tạo ra, khối đó sẽ được thêm vào linh kiện theo các tiêu chí thuộc tính đã xác định. Ở chế độ này, các thay đổi được áp dụng khi thực thi cập nhật hàng loạt.
- Hộp thoại cho phép bạn quản lý các khối 3D của linh kiện tại một nơi duy nhất, không cần mở bảng Properties cho từng 3D Body.
Các tùy chọn và điều khiển của hộp thoại Component Body Manager

Hộp thoại Component Body Manager (phía sau) và hộp thoại Quản lý khối linh kiện cho linh kiện (phía trước)
Linh kiện
Vùng trên cùng của hộp thoại liệt kê từng footprint linh kiện trong thư viện đang hoạt động (trong thiết kế thực tế, đây sẽ là danh sách tất cả linh kiện trên bo mạch). Với mỗi mục, thông tin được hiển thị gồm ký hiệu định danh (chỉ có ở phía thiết kế), tên footprint, chiều cao và thư viện nguồn.
Tab Tương tác

Tab Interactive của hộp thoại Component Body Manager
Phiên bản Component Body Manager của hộp thoại có hai tab: tab Interactive và tab Batch Update. Tab Interactive cho phép bạn dễ dàng xem thông tin về linh kiện đã chọn, bao gồm hình xem trước của các khối linh kiện và khối đã chọn.
Các khối linh kiện hiện có và có thể sử dụng
-
Existing and Potential Component Bodies - vùng này liệt kê tất cả các khối linh kiện (3D Body) hiện có đang được sử dụng hoặc có thể được sử dụng cho linh kiện. Mỗi khối linh kiện được liệt kê với các thông tin sau:
-
Description - mô tả cách khối được tạo ra. Đó có thể là một 3D Body được đặt có chủ đích (được gọi là Component Body trong phần mô tả), một hình chữ nhật được tạo từ hình chữ nhật bao, hoặc một hình đa giác khép kín được tạo từ các đối tượng thiết kế cơ bản. Phần mô tả của mỗi khối (dù được đặt hay được tạo tự động) cũng bao gồm lớp cơ khí chứa khối đó (hoặc chứa các đối tượng dùng để tạo khối) và diện tích của khối. Các khối hình chữ nhật và đa giác được phân biệt bằng
và
các biểu tượng tương ứng.
- Body State - cho biết khối có đang được sử dụng trong linh kiện (In Component <ComponentDesignator>) hay không (Not In Component <ComponentDesignator>). Nhấp vào mục này để chuyển đổi trạng thái theo yêu cầu.
- Standoff Height - khoảng cách từ bề mặt bo mạch đến mặt dưới của khối đùn. Sử dụng giá trị âm cho các khối đùn cần xuyên xuống qua PCB.
- Overall Height - khoảng cách từ bề mặt bo mạch đến mặt trên của khối đùn.
- Body Projection - phía của bo mạch mà khối 3D sẽ nhô ra. Sử dụng danh sách thả xuống của trường để chọn Top Side hoặc Bottom Side (nhô lên hoặc nhô xuống). Thiết lập này tự động thay đổi nếu đối tượng khối 3D được lật sang phía bên kia của bo mạch khi lật linh kiện.
- Registration Layer - lớp cơ khí chứa khối 3D. Sử dụng danh sách thả xuống của trường để chọn trong số tất cả các lớp cơ khí hiện đang được bật. Nếu lớp cơ khí được chọn có ghép cặp, khi khối được lật sang phía bên kia của bo mạch cùng với linh kiện, khối cũng sẽ được chuyển sang lớp cơ khí ghép cặp.
- Body 3D Color - màu hiện đang dùng cho khối 3D. Nhấp vào ô màu để mở hộp thoại Choose Color tiêu chuẩn và chọn màu khác theo yêu cầu.
- Body 3D Opacity - mức độ trong suốt hiện tại của khối 3D. Sử dụng danh sách thả xuống của trường để chọn Solid (hoàn toàn không trong suốt), Hide (làm cho khối không hiển thị), 25% Opacity, 50% Opacity và 75% Opacity.
-
Description - mô tả cách khối được tạo ra. Đó có thể là một 3D Body được đặt có chủ đích (được gọi là Component Body trong phần mô tả), một hình chữ nhật được tạo từ hình chữ nhật bao, hoặc một hình đa giác khép kín được tạo từ các đối tượng thiết kế cơ bản. Phần mô tả của mỗi khối (dù được đặt hay được tạo tự động) cũng bao gồm lớp cơ khí chứa khối đó (hoặc chứa các đối tượng dùng để tạo khối) và diện tích của khối. Các khối hình chữ nhật và đa giác được phân biệt bằng
- Component bodies in: <ComponentDesignator> - hiển thị footprint 2D của linh kiện cùng với các khối 3D được phủ lên có Body State hiện được đặt thành In Component <ComponentDesignator>. Bản xem trước thay đổi linh hoạt khi các khối được thêm vào hoặc loại bỏ.
- Selected Body - hiển thị khối hiện được chọn trong danh sách phía trên. Vùng tiêu đề của cửa sổ cũng hiển thị mô tả của khối.
Tab Cập nhật hàng loạt

Tab Batch Update của hộp thoại Component Body Manager
Tab Batch Update cung cấp chức năng thêm nhanh các đối tượng khối 3D vào tất cả hoặc các footprint được chọn trong thư viện, hoặc vào tất cả hoặc các footprint đã đặt được chọn trong thiết kế.
Vùng bảng
Sử dụng vùng này để xác định tiêu chí tìm kiếm nhằm phát hiện và tạo các khối 3D cũng như xác định các thuộc tính của khối 3D, chẳng hạn như Projection side (còn được gọi là hướng nhô của khối), Registration Layer, Standoff Height, Overall Height và 3D Body Color.
Mỗi mục trong danh sách cung cấp một phạm vi khác nhau về các lớp sẽ được tìm kiếm khi phát hiện và tạo các hình dạng khối 3D có thể có. Mỗi tìm kiếm được bật riêng bằng tùy chọn trong cột Enabled. Có thể bật nhiều tìm kiếm, tuy nhiên, hãy lưu ý rằng một khối 3D sẽ được thêm vào cho mỗi tìm kiếm thành công. Thông thường, bạn sẽ bật tìm kiếm trên một lớp cụ thể hoặc một tập hợp lớp, tùy theo nơi bạn thường đặt các đối tượng cơ bản hoặc thông tin đường bao linh kiện cho footprint. Theo mặc định, tìm kiếm trên All Layers sẽ được thực hiện.
Trường Detection Method cho phép bạn kiểm soát cách xác định hình dạng của từng khối 3D:
- Bounding Rectangle - sử dụng hình chữ nhật bao của footprint.
- Closed Shapes - sử dụng hình đa giác kín được tạo từ các đối tượng cơ bản của footprint linh kiện.
- Both (Prefer Closed Shapes) - phát hiện hình chữ nhật bao hoặc hình đa giác kín dựa trên các đối tượng cơ bản của footprint. Nếu phát hiện cả hai, sử dụng hình đa giác kín.
Cột tùy chọn Prefer component height if not 0 cho phép bạn kiểm soát việc có sử dụng thuộc tính chiều cao được xác định cho footprint linh kiện làm Overall Height của khối 3D hay không. Khi bật tùy chọn này, đối với mỗi linh kiện có thuộc tính chiều cao được xác định lớn hơn 0, chiều cao đó sẽ được đặt làm Overall Height của khối 3D được thêm vào và Standoff Height của khối sẽ được đặt bằng 0.
Body 3-D Color chỉ định màu dùng để hiển thị khối 3D. Nhấp vào màu để thay đổi trong hộp thoại Choose Color.
Tùy chọn
- Apply Only To Selected Components - bật tùy chọn này nếu bạn chỉ muốn áp dụng các tiêu chí khối 3D cho một nhóm footprint được chọn. Đảm bảo các linh kiện đó được chọn trong vùng phía trên của hộp thoại (sử dụng các thao tác Ctrl+Click và Shift+Click tiêu chuẩn để chọn nhiều mục). Nếu tắt tùy chọn này, quá trình thêm hàng loạt sẽ được áp dụng cho tất cả footprint trong thư viện (hoặc tất cả linh kiện trên bo mạch).
- Delete Existing Bodies In Components - bật tùy chọn này để xóa mọi khối 3D hiện được xác định cho các footprint thuộc phạm vi xử lý hàng loạt. Sử dụng cửa sổ xem trước ở góc dưới bên phải của tab để hình dung khối 3D được thêm vào sẽ trông như thế nào dựa trên footprint linh kiện hiện được chọn và mục tìm kiếm hiện được chọn (và bật). Sau khi xác định tất cả các tùy chọn cho quá trình xử lý hàng loạt theo yêu cầu, nhấp vào nút Execute Batch Update. Việc tìm kiếm sẽ được thực hiện cho từng footprint trong phạm vi xử lý và khi một hình dạng khối 3D được phát hiện và tạo, khối đó sẽ được thêm vào footprint theo các tiêu chí thuộc tính đã xác định.
Xem trước thao tác hàng loạt
Sử dụng để xem trước các khối 3D đã xác định trên các lớp khác nhau.
Điều khiển bổ sung
- Execute Batch Update - nhấp để tiến hành cập nhật từng footprint trong phạm vi xử lý và khi một hình dạng khối 3D được phát hiện và tạo, khối đó sẽ được thêm vào footprint theo các tiêu chí thuộc tính đã xác định.
Tạo từ các đối tượng cơ bản được chọn
Ngoài việc đặt khối 3D theo cách tương tác, bạn cũng có thể tạo khối từ một tập hợp các đối tượng đường mạch, cung tròn và vùng đặc có sẵn tạo thành một hình kín. Đây là lựa chọn rất phù hợp khi mô hình đơn giản. Để xác định một khối 3D từ hình kín có sẵn:
- Chọn tất cả các đối tượng cơ bản tạo thành hình kín.
- Nhấp vào Tools » Convert » Create 3D Body From selected primitives.
Khối 3D sẽ được tạo trên Top Layer từ đường biên kín do các đối tượng cơ bản tạo thành, bất kể các đường mạch được chọn nằm trên lớp nào. Điều này có nghĩa là bạn có thể xác định hình dạng trên một lớp cơ khí. Lưu ý rằng các đối tượng cơ bản được chọn ban đầu vẫn tồn tại sau khi vùng được tạo và vẫn ở trạng thái được chọn. Đường biên của khối 3D đi theo đường tâm của các đối tượng đường mạch bao quanh, và khối 3D không được chọn.
Vì thuật toán Create 3D Body From selected primitives sử dụng đường tâm của các đối tượng được chọn, thuật toán yêu cầu vị trí điểm cuối và điểm đầu của các đối tượng tiếp xúc nhau phải trùng khớp chính xác (cùng tọa độ X, Y). Nếu không, hộp thoại Confirm sẽ xuất hiện, cho biết vị trí thuật toán gặp lỗi đồng thời cho phép bạn yêu cầu thuật toán thử xác định khối 3D từ các cạnh của đối tượng thay thế. Miễn là các đối tượng được chọn chồng lấn nhau một chút, tùy chọn này sẽ tạo được một khối 3D có cạnh đi theo mép ngoài của các đối tượng được chọn.
Chỉnh sửa đồ họa
Phương pháp chỉnh sửa bằng đồ họa cho phép bạn chọn trực tiếp một đối tượng thân 3D đã đặt trong không gian thiết kế và thay đổi kích thước, hình dạng hoặc vị trí của đối tượng bằng thao tác đồ họa.
Đối với thân 3D dạng đùn, nhấp một lần vào đối tượng để chọn và đưa đối tượng vào chế độ chỉnh sửa. Hình dạng bên ngoài của đối tượng thân 3D được xác định bởi một chuỗi cạnh: mỗi cạnh có một đỉnh ở mỗi đầu, hiển thị dưới dạng hình vuông trắng đặc (A trong hình bên dưới); và một đỉnh ở giữa, hiển thị dưới dạng hình vuông trắng rỗng (B trong hình bên dưới). Mỗi đỉnh đầu mút biểu thị vị trí giao nhau của hai cạnh.
Bạn có thể sử dụng các kỹ thuật chỉnh sửa hình dạng đa giác tiêu chuẩn để chỉnh sửa hình dạng.
Khi chỉnh sửa đối tượng đa giác, có ba chế độ chỉnh sửa: Slide/Miter, Incurvate (cung tròn) và Move. Có thể thay đổi chế độ hiện tại while dragging a vertex or an edge bằng cách nhấn Shift+Spacebar để chuyển lần lượt qua 3 chế độ.
- Slide/Miter – nhấp và giữ một cạnh hoặc đỉnh giữa để trượt cạnh đó; nhấp và giữ một đỉnh đầu mút để vát góc.
- Incurvate – nhấp và giữ một cạnh hoặc đỉnh giữa để uốn cong cạnh đó; nhấp và giữ một đỉnh đầu mút để bo góc thành cung tròn.
- Move – nhấp và giữ một cạnh hoặc đỉnh giữa để chia cạnh đó thành hai cạnh; nhấp và giữ một đỉnh đầu mút để di chuyển góc đó tự do.
Trong khi chỉnh sửa, bạn cũng có thể:
- Ctrl+click and hold tại bất kỳ vị trí nào dọc theo một cạnh cách xa các điểm điều khiển chỉnh sửa để chèn một đỉnh mới.
- Để xóa một đỉnh, nhấp và giữ đỉnh đó rồi nhấn phím Delete.
-
Nhấp vào bất kỳ vị trí nào trên thân 3D cách xa các điểm điều khiển chỉnh sửa rồi kéo để thay đổi vị trí. Trong khi kéo, bạn có thể xoay hoặc lật đối xứng thân 3D:
- Nhấn Spacebar để xoay thân 3D ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Giá trị Rotation Step được xác định trên trang PCB Editor – General của hộp thoại Preferences.
- Nhấn phím X hoặc Y để lật đối xứng thân 3D theo trục X hoặc trục Y.
Chuyển đổi sang STEP
Có thể chuyển đổi đối tượng thân 3D dạng đùn/hình trụ/hình cầu được chọn thành mô hình STEP. Mô hình STEP được tự động nhúng vào tệp thiết kế. Để chuyển đổi một đối tượng thân 3D độc lập, hãy chọn đối tượng trong không gian thiết kế, sau đó nhấp chuột phải và chọn lệnh Convert To STEP từ menu ngữ cảnh. Lệnh này sẽ không khả dụng nếu không có đối tượng nào được chọn hoặc nếu có nhiều hơn một đối tượng được chọn. Sau khi chuyển đổi đối tượng sang STEP, bạn không thể thay đổi kích thước của đối tượng trong không gian thiết kế nữa.

Chuyển đổi hình dạng đùn sang STEP nếu bạn cần xoay nó quanh trục X hoặc Y.
Điểm tham chiếu của đối tượng thân 3D dạng đùn, hình cầu hoặc hình trụ
Đối tượng thân 3D dạng đùn, hình cầu hoặc hình trụ có một điểm tham chiếu hay gốc tọa độ.
- Đối với hình trụ và hình cầu, điểm tham chiếu là tâm của hình tròn của đối tượng trên mặt phẳng X-Y.
- Đối với đối tượng dạng đùn, điểm tham chiếu được đặt tại vị trí Chiều dài X/2, Chiều dài Y/2 khi nhìn từ trên xuống.
- Vị trí của điểm tham chiếu này trong không gian thiết kế được hiển thị trong Location X/Y trên bảng Properties.

Các đối tượng thân 3D dạng đùn, hình cầu và hình trụ đều có điểm tham chiếu, như minh họa trong các hình. Lưu ý rằng các đường biểu thị điểm tham chiếu không dài nên có thể không hiển thị bên ngoài đối tượng.
Thêm ảnh bề mặt cho thân 3D dạng đùn
Đối tượng dạng đùn cũng có thể có một hình ảnh phủ lên bề mặt trên cùng — giúp bo mạch trông chân thực hơn khi xem ở chế độ 3D. Khi thêm Texture File, ảnh sẽ tự động được kéo giãn để phủ kín toàn bộ bề mặt trên của thân 3D, như minh họa trong hình bên dưới. Lưu ý rằng tệp ảnh bề mặt được liên kết với tệp thư viện hoặc tệp bo mạch.
Các định dạng tệp ảnh bề mặt được hỗ trợ gồm: *.bmp; *.dds; *.dib; *.hdr; *.jpg; *.pfm; *.png; *.ppm; và *.tga.

Có thể thêm ảnh bề mặt hoặc logo vào đối tượng thân 3D dạng đùn.
Bạn có thể điều chỉnh ảnh bằng cách thay đổi vị trí Center, các thiết lập Size và Rotation trong chế độ 3D Body của bảng Properties.
Bạn cũng có thể thay đổi vị trí của đối tượng ảnh bề mặt gắn với mô hình 3D dạng đùn đã chọn bằng cách chọn lệnh Tools » 3D Body Placement » Move Texture Location từ các menu chính khi trình chỉnh sửa đang ở chế độ bố trí 3D. Sau khi kích hoạt lệnh, con trỏ sẽ chuyển thành các hình nón màu xanh lam (biểu thị chế độ chọn 3D) và bạn sẽ được nhắc chọn một thân 3D dạng đùn có ảnh bề mặt đi kèm. Đặt con trỏ lên thân 3D cần chọn rồi nhấp hoặc nhấn Enter. Nhấp hoặc nhấn Enter lần thứ hai để “nhấc” ảnh bề mặt lên tại góc gần nhất. Di chuyển ảnh bề mặt đến vị trí mong muốn rồi nhấp hoặc nhấn Enter để đặt ảnh. Bạn có thể thực hiện các thao tác bổ sung tiêu chuẩn khi di chuyển đối tượng (Spacebar/Shift+Spacebar để xoay, X hoặc Y để lật đối xứng, các phím mũi tên để dịch chuyển ảnh bề mặt từng chút một) trong khi ảnh vẫn đang bám theo con trỏ.
Ngoài ra, bạn có thể di chuyển ảnh bề mặt trên thân 3D dạng đùn đã chọn bằng thao tác nhấp và kéo chuột.