Trabajo con cuerpos 3D extruidos, esféricos y cilíndricos
De un vistazo
- Conozca las diferencias entre los objetos de cuerpo 3D extruidos, cilíndricos y esféricos, y cómo se define y coloca cada uno.
- Descubra cómo utilizar el panel Propiedades y los atajos disponibles durante la ejecución de comandos para controlar las dimensiones, la apariencia y el comportamiento de colocación de las formas.
- Aprenda a generar y gestionar cuerpos 3D a partir de formas existentes en las huellas mediante el Administrador de cuerpos de componentes, incluidas las opciones para componentes individuales y actualizaciones por lotes.
Aunque colocar modelos 3D genéricos es una forma recomendada de utilizar objetos de cuerpo 3D, ya que proporciona una representación precisa y detallada del componente en la PCB y permite comprobar las colisiones 3D con mayor precisión en el editor de PCB, un objeto de cuerpo 3D también se puede utilizar para colocar formas de cuerpo 3D extruidas, esféricas y cilíndricas. Se pueden colocar tres tipos de objetos de cuerpo 3D simples:
| Extruded | En el plano X-Y (vista superior), el objeto extruido se define de forma interactiva, del mismo modo que se definen otros objetos poligonales en el editor de PCB. A continuación, el objeto se extruye hacia arriba (o hacia abajo) en el plano Z, según las propiedades Overall Height y Standoff Height definidas en el modo 3D Body del panel Properties, y la opción Body Projection. También puede aplicar un archivo de textura, como un logotipo, a la superficie de un objeto de cuerpo 3D extruido. |
| Cylindrical | Las propiedades de esta forma se definen en el modo 3D Body del panel Properties. |
| Spherical | Las propiedades de esta forma se definen en el modo 3D Body del panel Properties. |
Colocación de objetos de cuerpo 3D extruidos, esféricos o cilíndricos
Colocación directa
Los objetos de cuerpo 3D extruidos, esféricos y cilíndricos se pueden colocar tanto en el editor de PCB como en el editor de huellas de PCB mediante las siguientes opciones:
- Seleccionar el comando Place » Extruded 3D Body en los menús principales.
- Localizar y utilizar el comando Cuerpo 3D extruido en Active Bar.
Para colocar un objeto de cuerpo 3D extruido, esférico o cilíndrico:
- Tras iniciar el comando, el cursor cambiará a una cruz y se activará el modo de colocación predeterminado, que permite colocar un objeto de cuerpo 3D extruido.
- Pulse Tab para pausar la colocación y mostrar el panel Properties en el modo Cuerpo 3D. El botón de pausa superpuesto aparecerá en el espacio de diseño, indicando que puede acceder a los campos del panel Properties.
- En el panel Properties, introduzca un nombre para el cuerpo 3D en el campo Identifier. Esto es opcional; el identificador puede resultar útil cuando se colocan varios cuerpos 3D y también se puede utilizar para hacer referencia a este cuerpo 3D en una regla de diseño si es necesario.
-
Seleccione el valor requerido de Board Side; normalmente se establece en
Top. En el editor de bibliotecas de PCB, la huella se crea para la cara superior de la placa; puede voltearse a la cara inferior durante el proceso de diseño de la PCB si es necesario. - Seleccione la Layer mecánica en la que se colocará el cuerpo 3D. Las capas mecánicas de tipo componente deben emparejarse con una segunda capa mecánica para que, si el componente se voltea de la cara superior de la placa a la cara inferior, sus detalles mecánicos, como el cuerpo 3D, se trasladen a la capa mecánica emparejada. Las capas mecánicas se emparejan en la pestaña Layers and Colors del panel Configuración de vista. Consulte la página del panel para obtener más información.
- Seleccione el 3D Model Type entre las formas disponibles: Extruded, Cylinder o Sphere.
-
Cada forma debe tener un tamaño definido antes de poder colocarse. Si la forma elegida es:
- Extruded – defina el Overall Height.
- Cylinder – defina el Height y la Radius.
- Sphere – defina el Radius.
- En la sección Display del panel, haga clic en el botón Color para establecer el color y ajuste la Opacity según sea necesario.
-
Una vez finalizada la edición, haga clic en el botón de pausa superpuesto para volver al espacio de diseño.
-
Si la forma es una Cylinder o un Sphere:
- El cursor se desplazará por el espacio de diseño con una forma rectangular adjunta; haga clic para colocar el cuerpo 3D.
- Haga clic con el botón derecho o pulse Esc para finalizar la colocación de objetos de cuerpo 3D.
-
Si la forma es Extruded, aparecerá el cursor, listo para definir la forma poligonal de la base del cuerpo 3D extruido:
- Haga clic para definir el primer vértice.
- Mueva el cursor para colocar el segundo vértice. El comportamiento predeterminado consiste en colocar dos aristas con cada clic, con una forma de esquina definida por el usuario entre ellas. Consulte la sección Modos de colocación de cuerpos 3D extruidos que aparece más abajo para obtener más información.
- Siga moviendo el ratón y haciendo clic para colocar más vértices.
- Después de colocar el último vértice, haga clic con el botón derecho o pulse Esc para cerrar y completar la colocación del cuerpo 3D. No es necesario cerrar manualmente el cuerpo 3D, ya que el software completará automáticamente la forma conectando el punto inicial con el último punto colocado.
-
Si la forma es una Cylinder o un Sphere:
Modos de colocación de cuerpos 3D extruidos
Al colocar un cuerpo 3D extruido, hay cinco modos de esquina disponibles, cuatro de los cuales también cuentan con submodos de dirección de esquina. Durante la colocación:
- Pulse Shift+Spacebar para recorrer los cinco modos de esquina disponibles.
- Pulse Spacebar para alternar entre los dos submodos de dirección de esquina.
-
En cualquiera de los modos de esquina en arco, mantenga pulsadas las teclas
o
para reducir o ampliar el arco. Mantenga pulsada la tecla Shift mientras pulsa estas teclas para acelerar el cambio de tamaño del arco.
- Pulse la tecla de acceso directo 1 para alternar entre colocar dos aristas por clic o una arista por clic. En el segundo modo, la arista discontinua se denomina look-ahead segment.
- Pulse la tecla Backspace para eliminar el último vértice.

Un objeto de cuerpo 3D extruido; observe el punto de referencia que se muestra en las vistas 2D y 3D.
Creación a partir de formas cerradas
Para agilizar el proceso de creación de la forma del componente a partir de cuerpos 3D, el software puede crear una serie de objetos de cuerpo 3D extruidos basados en formas cerradas detectadas en la huella. Esta función puede resultar útil si el componente tiene una forma inusual que ya se refleja en las formas definidas en la serigrafía del componente de la huella. También puede añadir objetos adicionales a la huella en capas mecánicas y utilizarlos después para crear otros objetos de cuerpo 3D, por ejemplo, para crear los pines.
Las imágenes siguientes muestran la huella de un transistor TO-92. A partir de ella, el contorno dibujado en la capa Top Overlay se utiliza para definir el cuerpo del transistor en el par de capas de cuerpo 3D elegido (denominado Registration Layer en el cuadro de diálogo). También se han creado tres cuadrados pequeños en una capa mecánica (cada cuadrado formado por cuatro líneas), que se utilizan para definir los pines del componente en el par de capas de cuerpo 3D elegido; los ajustes se muestran en la imagen del cuadro de diálogo siguiente.

Los objetos existentes en la huella pueden utilizarse para crear nuevos objetos de cuerpo 3D.
Para crear objetos de cuerpo 3D a partir de formas de la huella, ejecute el comando Tools » Manage 3D Bodies for Current Component; se abrirá el cuadro de diálogo Component Body Manager. Utilícelo para ver qué cuerpos 3D se están utilizando actualmente en el componente y cuáles no. Puede añadir cuerpos al componente o eliminarlos según sea necesario. Los cuerpos pueden ser de tres tipos distintos:
- Un cuerpo 3D colocado expresamente (denominado Component Body en su descripción).
- Una forma rectangular creada automáticamente por el software a partir de un rectángulo delimitador.
- Una forma poligonal cerrada creada automáticamente por el software a partir de primitivas de diseño.
También puede modificar otras propiedades de un cuerpo, como las alturas, la proyección del cuerpo, la capa de registro, el color y la opacidad. Observe que la columna Body State indica que se utilizarán cuatro formas para crear objetos de cuerpo 3D.
Una vez definidos los cuerpos 3D del componente según sus necesidades, haga clic en el botón Close para aplicar los cambios.

El software puede crear objetos de cuerpo 3D basados en la forma de los objetos existentes.
Notas sobre el uso de este cuadro de diálogo:
- El algoritmo de detección ofrecerá una de estas opciones: una forma rectangular creada a partir del rectángulo delimitador o una forma poligonal que sigue el contorno definido por las primitivas (trazado a lo largo de la línea central de las pistas o los arcos, si sus extremos coinciden).
- Para crear un cuerpo 3D a partir de un objeto existente, haga clic en el texto azul de la columna Body State.
- El valor predeterminado de Overall Height es el Height definido en el panel Propiedades de la huella.
- Para un pin de componente que atraviese la placa hacia abajo, establezca Body Projection en Bottom Side.
- Los objetos de cuerpo 3D se crean al hacer clic en el botón Close del cuadro de diálogo. Si la vista ya está en modo 3D, es posible que deba actualizarla (atajo End), cambiar a 2D y volver a 3D, o alternar la opción Show 3D Bodies entre Off y On en la pestaña View Options del panel Configuraciones de vista para ver los nuevos objetos.
- Para editar los cuerpos 3D de todos los componentes de la biblioteca de huellas de PCB activa que está abierta en el editor de huellas de PCB, seleccione el comando Tools » Manage 3D Bodies for Library en los menús principales.
- Para editar cuerpos 3D en el editor de PCB mediante este cuadro de diálogo, puede acceder a él seleccionando el comando Tools » Manage 3D Bodies for Components on Board en los menús principales o haciendo clic con el botón derecho en un componente y seleccionando Acciones del componente » Administrar cuerpos 3D en el menú contextual.
-
Al acceder al cuadro de diálogo mediante el comando Tools » Manage 3D Bodies for Components on Board (en el editor de PCB) o el comando Tools » Manage 3D Bodies for Library (en el editor de huellas de PCB), la sección Components estará disponible en la parte superior del cuadro de diálogo. Esta sección muestra cada huella de componente de la biblioteca activa (en el diseño real, sería una lista de todos los componentes de la placa). Para cada entrada se muestra el designador (disponible solo en el diseño), el nombre de la huella, la altura y la información de la biblioteca de origen.
Además, estará disponible una pestaña Batch Update adicional. Esta pestaña permite añadir rápidamente objetos de cuerpo 3D en bloque a todos los componentes o a los seleccionados. Puede definir criterios de búsqueda para detectar y crear cuerpos 3D, así como para definir sus propiedades. Tras definir todas las opciones del proceso por lotes según sus necesidades, haga clic en el botón Execute Batch Update. La búsqueda se realizará para cada componente incluido en el proceso y, cuando se detecte y cree una forma de cuerpo 3D, ese cuerpo se añadirá al componente utilizando los criterios de propiedades definidos. En este modo, los cambios se aplican al ejecutar la actualización por lotes.
- El cuadro de diálogo permite administrar los cuerpos 3D del componente desde un único lugar, sin necesidad de abrir el panel Properties para cada cuerpo 3D.
Opciones y controles del cuadro de diálogo del administrador de cuerpos de componentes

El cuadro de diálogo Component Body Manager (detrás) y el cuadro de diálogo Administrador de cuerpos del componente (delante)
Componentes
La sección superior del cuadro de diálogo muestra cada huella de componente de la biblioteca activa (en el diseño real, sería una lista de todos los componentes de la placa). Para cada entrada se muestra el designador (disponible solo en el diseño), el nombre de la huella, la altura y la información de la biblioteca de origen.
Pestaña Interactiva

La pestaña Interactive del cuadro de diálogo Component Body Manager
La versión Component Body Manager del cuadro de diálogo incluye dos pestañas: la pestaña Interactive y la pestaña Batch Update. La pestaña Interactive permite consultar fácilmente la información del componente seleccionado, incluidas las vistas previas de los cuerpos del componente y del cuerpo seleccionado.
Cuerpos de componente existentes y potenciales
-
Existing and Potential Component Bodies: esta sección enumera todos los cuerpos de componente existentes (cuerpos 3D) que se están utilizando o que podrían utilizarse para el componente. Cada cuerpo de componente se describe mediante los siguientes datos:
-
Description : una descripción de cómo se ha creado el cuerpo. Puede tratarse de un cuerpo 3D colocado expresamente (denominado Component Body en su descripción), una forma rectangular creada a partir de un rectángulo delimitador o una forma poligonal cerrada creada a partir de primitivas de diseño. La descripción de cada cuerpo (ya sea colocado o creado automáticamente) también incluirá la capa mecánica en la que se encuentra (o en la que se encuentran los objetos a partir de los cuales se creó) y su área. Los cuerpos rectangulares y poligonales se distinguen por
y
iconos, respectivamente.
- Body State - indica si el cuerpo se está utilizando en el componente (In Component <ComponentDesignator>) o no (Not In Component <ComponentDesignator>). Haga clic en la entrada para cambiar el estado según sea necesario.
- Standoff Height - la distancia desde la superficie de la placa hasta la cara inferior del cuerpo extruido. Utilice un valor negativo para los cuerpos extruidos que deban atravesar la PCB hacia abajo.
- Overall Height - la distancia desde la superficie de la placa hasta la cara superior del cuerpo extruido.
- Body Projection - el lado de la placa desde el que se proyectará el cuerpo 3D. Utilice la lista desplegable del campo para elegir Top Side o Bottom Side (proyectar hacia arriba o hacia abajo). Este ajuste cambia automáticamente si el objeto de cuerpo 3D se voltea al otro lado de la placa al voltear un componente.
- Registration Layer - la capa mecánica en la que se encuentra el cuerpo 3D. Utilice la lista desplegable del campo para elegir entre todas las capas mecánicas habilitadas actualmente. Si la capa mecánica elegida está emparejada, cuando el cuerpo se voltee al otro lado de la placa junto con su componente, también se moverá a la capa mecánica emparejada.
- Body 3D Color - el color actual del cuerpo 3D. Haga clic en la muestra de color para acceder al cuadro de diálogo estándar Choose Color y asignar un color diferente según sea necesario.
- Body 3D Opacity - el nivel actual de transparencia del cuerpo 3D. Utilice la lista desplegable del campo para elegir entre Solid (completamente opaco), Hide (hace que el cuerpo sea invisible), 25% Opacity, 50% Opacity y 75% Opacity.
-
Description : una descripción de cómo se ha creado el cuerpo. Puede tratarse de un cuerpo 3D colocado expresamente (denominado Component Body en su descripción), una forma rectangular creada a partir de un rectángulo delimitador o una forma poligonal cerrada creada a partir de primitivas de diseño. La descripción de cada cuerpo (ya sea colocado o creado automáticamente) también incluirá la capa mecánica en la que se encuentra (o en la que se encuentran los objetos a partir de los cuales se creó) y su área. Los cuerpos rectangulares y poligonales se distinguen por
- Component bodies in: <ComponentDesignator> - muestra la huella 2D del componente junto con los cuerpos 3D superpuestos cuyo Body State está configurado actualmente como In Component <ComponentDesignator>. La vista previa es dinámica y cambia a medida que se incluyen o excluyen cuerpos.
- Selected Body - muestra el cuerpo seleccionado actualmente en la lista anterior. El área de título de la ventana también muestra la descripción del cuerpo.
Pestaña de actualización por lotes

La pestaña Batch Update del cuadro de diálogo Component Body Manager
La pestaña Batch Update ofrece una función para añadir rápidamente objetos de cuerpo 3D a todas las huellas de una biblioteca o a las seleccionadas, o bien a todas las huellas colocadas en un diseño o a las seleccionadas.
Área de la cuadrícula
Utilice esta área para definir los criterios de búsqueda para detectar y crear cuerpos 3D y para definir las propiedades de los cuerpos 3D, como Projection side (también denominada proyección del cuerpo), Registration Layer, Standoff Height, Overall Height y 3D Body Color.
Cada entrada de la lista ofrece un ámbito diferente en cuanto a las capas en las que se buscará al detectar y crear posibles formas de cuerpos 3D. Cada búsqueda se habilita individualmente mediante la opción de la columna Enabled. Se pueden habilitar varias búsquedas; sin embargo, tenga en cuenta que se añadirá un cuerpo 3D por cada búsqueda satisfactoria. Normalmente, se habilita una búsqueda en una capa concreta —o en un conjunto de capas— en función de dónde se suelan colocar las primitivas o la información del contorno del componente para una huella. De forma predeterminada, se realizará una búsqueda de All Layers.
El campo Detection Method permite controlar cómo se define la forma de cada cuerpo 3D:
- Bounding Rectangle - utilizar el rectángulo delimitador de la huella.
- Closed Shapes - utilizar una forma poligonal cerrada creada a partir de las primitivas de la huella del componente.
- Both (Prefer Closed Shapes) - detectar un rectángulo delimitador o una forma poligonal cerrada a partir de las primitivas de la huella. Si se detectan ambos, utilizar la forma poligonal cerrada.
La columna de opción Prefer component height if not 0 permite controlar si el atributo de altura definido para la huella de un componente se utiliza como Overall Height del cuerpo 3D. Con esta opción habilitada, para cada componente cuyo atributo de altura definido sea mayor que cero, esa altura se establecerá como Overall Height del cuerpo 3D añadido y su Standoff Height se establecerá en cero.
El Body 3-D Color especifica el color con el que se representará el cuerpo 3D. Haga clic en el color para cambiarlo en el cuadro de diálogo Choose Color.
Opciones
- Apply Only To Selected Components - habilite esta opción si desea aplicar los criterios de cuerpo 3D solo a un grupo seleccionado de huellas. Asegúrese de que esos componentes estén seleccionados en el área superior del cuadro de diálogo (utilice las funciones estándar Ctrl+Click y Shift+Click para seleccionar varios elementos). Si esta opción está deshabilitada, el proceso de adición por lotes se aplicará a todas las huellas de la biblioteca (o a todos los componentes de la placa).
- Delete Existing Bodies In Components - habilite esta opción para eliminar todos los cuerpos 3D definidos actualmente para las huellas a las que se aplica el proceso por lotes. Utilice la ventana de vista previa situada en la parte inferior derecha de la pestaña para hacerse una idea del aspecto que tendrá el cuerpo 3D añadido según la huella del componente y la entrada de búsqueda seleccionadas actualmente (y habilitada, en el caso de la entrada). Tras definir todas las opciones del proceso por lotes según sea necesario, haga clic en el botón Execute Batch Update. La búsqueda se realizará para cada huella incluida en el proceso y, cuando se detecte y cree una forma de cuerpo 3D, ese cuerpo se añadirá a la huella utilizando los criterios de propiedades definidos.
Vista previa de la operación por lotes
Utilícela para previsualizar los cuerpos 3D definidos en diferentes capas.
Control adicional
- Execute Batch Update - haga clic para proceder con la actualización de cada huella incluida en el proceso y, cuando se detecte y cree una forma de cuerpo 3D, ese cuerpo se añadirá a la huella utilizando los criterios de propiedades definidos.
Creación a partir de primitivas seleccionadas
Además de colocar un cuerpo 3D de forma interactiva, también se puede crear a partir de un conjunto de objetos existentes de pista, arco y región sólida que definan una forma cerrada. Esta es una excelente opción cuando el modelo es sencillo. Para definir un cuerpo 3D a partir de una forma cerrada existente:
- Seleccione todas las primitivas que forman la figura cerrada.
- Haga clic en Tools » Convert » Create 3D Body From selected primitives.
El cuerpo 3D se creará a partir del contorno cerrado formado por las primitivas en la capa superior, independientemente de la capa en la que se encuentren las pistas seleccionadas. Esto significa que puede definir la forma en una capa mecánica. Tenga en cuenta que las primitivas seleccionadas originalmente seguirán existiendo después de crear la región y permanecerán seleccionadas. El contorno del cuerpo 3D sigue la línea central de los objetos de pista que lo delimitan y el cuerpo no queda seleccionado.
Como el algoritmo Create 3D Body From selected primitives utiliza la línea central de los objetos seleccionados, requiere que las posiciones de inicio y fin de los objetos que se tocan coincidan exactamente (en la misma posición X, Y). Si no es así, aparecerá un cuadro de diálogo Confirm que indicará la ubicación en la que falló el algoritmo y también ofrecerá la posibilidad de indicarle que intente definir el cuerpo 3D a partir de los bordes de los objetos. Siempre que los objetos seleccionados se solapen ligeramente, esta opción debería crear un cuerpo 3D cuyo contorno siga el borde exterior de los objetos seleccionados.
Edición gráfica
El método de edición gráfica permite seleccionar un objeto de cuerpo 3D colocado directamente en el espacio de diseño y cambiar gráficamente su tamaño, forma o ubicación.
Para un cuerpo 3D extruido, haga clic una vez en el objeto para seleccionarlo y activar su modo de edición. La forma exterior del objeto de cuerpo 3D está definida por una serie de aristas: cada arista tiene un vértice en cada extremo, representado por un cuadrado blanco sólido (A en la imagen siguiente), y un vértice central en el punto medio, representado por un cuadrado blanco hueco (B en la imagen siguiente). Cada vértice de extremo representa el punto donde se unen dos aristas.
Las técnicas estándar de edición de formas poligonales están disponibles para editar la forma.
Al editar un objeto poligonal, hay tres modos de edición disponibles: Slide/Miter, Incurvate (arco) y Move. El modo actual se puede cambiar while dragging a vertex or an edge pulsando Shift+Spacebar para alternar entre los tres modos.
- Slide/Miter – haga clic y mantenga pulsado sobre una arista o un vértice central para desplazar esa arista; haga clic y mantenga pulsado sobre un vértice de extremo para achaflanar la esquina.
- Incurvate – haga clic y mantenga pulsado sobre una arista o un vértice central para curvar esa arista; haga clic y mantenga pulsado sobre un vértice de extremo para redondear la esquina con un arco.
- Move – haga clic y mantenga pulsado sobre una arista o un vértice central para dividir esa arista en dos; haga clic y mantenga pulsado sobre un vértice de extremo para mover libremente esa esquina.
Durante la edición, también puede:
- Ctrl+click and hold en cualquier punto de una arista alejado de los controles de edición para insertar un nuevo vértice.
- Para eliminar un vértice, haga clic y mantenga pulsado sobre él y, a continuación, pulse la tecla Delete.
-
Haga clic en cualquier punto del cuerpo 3D alejado de los controles de edición y arrástrelo para cambiar su posición. Mientras lo arrastra, puede girar el cuerpo 3D o reflejarlo:
- Pulse Spacebar para girar el cuerpo 3D en sentido antihorario o Shift+Spacebar para girarlo en sentido horario. El valor de Rotation Step se define en la página Editor de PCB – General del cuadro de diálogo Preferences.
- Pulse las teclas X o Y para reflejar el cuerpo 3D respecto al eje X o al eje Y.
Conversión a STEP
Un objeto de cuerpo 3D extruido, cilíndrico o esférico seleccionado se puede convertir en un modelo STEP. El modelo STEP se integra automáticamente en el archivo de diseño. Para convertir un objeto de cuerpo 3D libre, selecciónelo en el espacio de diseño, haga clic con el botón derecho y elija el comando Convert To STEP en el menú contextual. El comando no estará disponible si no hay ningún objeto seleccionado o si hay más de uno. Una vez convertido un objeto a STEP, ya no se podrá cambiar su tamaño en el espacio de diseño.

Convierta una forma extruida a STEP si necesita girarla alrededor de los ejes X o Y.
Punto de referencia de un objeto de cuerpo 3D extruido, esférico o cilíndrico
Un objeto de cuerpo 3D extruido, esférico o cilíndrico tiene un punto de referencia u origen.
- En un cilindro o una esfera, la referencia es el punto central de la forma circular del objeto en el plano X-Y.
- En un objeto extruido, la referencia se establece en la ubicación longitud X/2, longitud Y/2 visto desde arriba.
- La posición de este punto de referencia en el espacio de diseño es la que se muestra en los Location X/Y del panel Properties.

Los objetos de cuerpo 3D extruidos, esféricos y cilíndricos tienen un punto de referencia, como se muestra en las imágenes. Tenga en cuenta que las líneas del punto de referencia son cortas, por lo que es posible que no sobresalgan del objeto.
Inclusión de una textura en un cuerpo 3D extruido
Los objetos extruidos también pueden incluir una imagen superpuesta sobre la superficie superior, lo que aporta mayor realismo a la placa cuando se visualiza en 3D. Al añadir una Texture File, esta se estira automáticamente para cubrir toda la superficie superior del cuerpo 3D, como se muestra en la imagen siguiente. Tenga en cuenta que el archivo de textura está vinculado al archivo de biblioteca o de placa.
Los formatos de archivo de textura compatibles son: *.bmp; *.dds; *.dib; *.hdr; *.jpg; *.pfm; *.png; *.ppm; y *.tga.

Se puede añadir una textura o un logotipo a un objeto de cuerpo 3D extruido.
Esto se puede ajustar modificando la ubicación Center y los ajustes Size y Rotation en el modo 3D Body del panel Properties.
También puede modificar la posición de un objeto de textura asociado a un modelo 3D extruido seleccionado eligiendo el comando Tools » 3D Body Placement » Move Texture Location en los menús principales cuando el editor esté configurado en el modo de diseño 3D. Tras ejecutar el comando, el cursor cambiará a conos azules (que indican el modo de selección 3D) y se le pedirá que seleccione un cuerpo 3D extruido que tenga una textura asociada. Sitúe el cursor sobre el cuerpo 3D deseado y haga clic o pulse Enter. Haga clic o pulse Enter una segunda vez para «tomar» la textura por su esquina más cercana. Mueva la textura a la posición deseada y haga clic o pulse Enter para colocarla. Las acciones adicionales habituales para mover objetos (Spacebar/Shift+Spacebar para girar, X o Y para reflejar y las teclas de flecha para desplazar ligeramente la textura) se pueden realizar durante el movimiento mientras la textura siga unida al cursor.
Como alternativa, puede mover la textura de un cuerpo 3D extruido seleccionado haciendo clic y arrastrándola con el ratón.