Asignación de puntos de prueba en la placa

De un vistazo

Este artículo explica por qué los puntos de prueba son importantes en la fabricación de PCB y cómo Altium Designer te ayuda a asignarlos tanto para las pruebas de fabricación de placas sin componentes como para las pruebas de placas ensambladas. Describe las diferencias prácticas entre las estrategias de prueba de fabricación y de ensamblaje, las restricciones de colocación que influyen en la ubicación de los puntos de prueba y cómo se pueden designar pads y vías manualmente o mediante el Testpoint Manager. Si quieres diseñar una placa más fácil de probar y comprender mejor cómo Altium Designer facilita este proceso, este artículo te proporcionará una base clara. Sigue leyendo para planificar tus puntos de prueba de forma más eficaz.

- Comprende la diferencia entre las pruebas de fabricación y las de ensamblaje, y cómo influye cada una en la colocación de los puntos de prueba.
- Conoce los principales factores y restricciones que determinan una buena estrategia de puntos de prueba, como el acceso a las caras de la placa, las separaciones mínimas, los requisitos de la cuadrícula y la accesibilidad de las sondas.
- Descubre cómo Altium Designer permite asignar puntos de prueba de forma manual y automática mediante las funciones de pads, vías y el Testpoint Manager.
Profundiza con IA:

Las pruebas son una parte importante del proceso de fabricación de placas. Tras la fabricación, la placa suele someterse a pruebas para comprobar que no haya cortocircuitos ni circuitos abiertos. Una vez montados todos sus componentes, a menudo se vuelve a probar para verificar la integridad de la señal y el funcionamiento del dispositivo. Para facilitar este proceso, resulta fundamental disponer de un conjunto de puntos en la placa - Testpoints - con los que el equipo de pruebas pueda hacer contacto y realizar las pruebas necesarias.

La ubicación de los puntos de prueba en una placa dependerá de factores como la modalidad de prueba (pruebas de fabricación de la placa sin componentes, pruebas en circuito de la placa ensamblada, etc.) y el método de prueba (pruebas automatizadas mediante sondas móviles y dispositivos de cama de clavos, pruebas manuales, etc.). Por ejemplo, al realizar pruebas de fabricación de la placa sin componentes, todos los pads y las vías están disponibles para asignarles puntos de prueba. Sin embargo, las ubicaciones utilizadas para los puntos de prueba al realizar pruebas en circuito de la placa ensamblada casi siempre serán diferentes. Al estar montados los componentes, es posible que la sonda ya no pueda acceder a sus pads y, desde luego, no tendrá acceso a los pads ni a las vías situados debajo de un componente.

Altium Designer proporciona un potente sistema para gestionar sus necesidades de puntos de prueba y mejorar la capacidad de prueba de sus placas, lo que le permite asignar por separado puntos de prueba para las pruebas de fabricación de la placa sin componentes y/o para las pruebas en circuito de la placa ensamblada, según sea necesario. Los puntos de prueba se pueden asignar manualmente o, de forma más ágil y automatizada, mediante el cuadro de diálogo Testpoint Manager.

Consideraciones sobre la estrategia de puntos de prueba

Antes de empezar a asignar pads y vías como ubicaciones de puntos de prueba, conviene detenerse a reflexionar sobre lo que se necesita. Las siguientes son solo algunas pautas que se deben tener en cuenta al definir una estrategia para incorporar puntos de prueba a un diseño:

  • Al elegir la cara de la placa en la que se permitirán los puntos de prueba, se deben tener en cuenta los procesos de prueba y los dispositivos asociados que se utilizarán. Por ejemplo, si las sondas accederán a la placa solo por la cara inferior, solo por la superior o por ambas caras.
  • Un punto de prueba situado debajo de un componente (en la misma cara de la placa que el componente) suele utilizarse en la etapa de pruebas de la placa sin componentes. Esto debe tenerse en cuenta al planificar las ubicaciones de los puntos de prueba para las pruebas de la placa ensamblada.
  • Es aconsejable ubicar todos los puntos de prueba en una sola cara de la placa, utilizando vías para conseguirlo si es necesario. Esto se debe a que un dispositivo de prueba de doble cabezal tiene un coste mayor que uno de un solo cabezal.
  • Cuanto menos convencional y más compleja sea la distribución de los puntos de prueba, más costoso será configurar un dispositivo con el que probar la placa. Lo más recomendable es desarrollar una metodología que facilite las pruebas de forma generalizada. Una política de puntos de prueba bien definida y adaptable permitirá probar distintos diseños de forma eficiente y rentable.
  • Se deben estudiar cuidadosamente los requisitos del diseño relativos al recubrimiento de vías con máscara de soldadura. Cubrir una vía designada como punto de prueba impedirá el contacto de la sonda de prueba. Incluso un recubrimiento parcial con una máscara de soldadura líquida fotoimaginable (LPI) provocará problemas de contacto, ya que el líquido de la máscara tenderá a fluir por el orificio de la vía. Se puede utilizar una máscara de soldadura pelable para cubrir temporalmente estas vías, aunque esta solución suele resultar bastante costosa.
  • Consulte estrechamente con sus proveedores de fabricación y ensamblaje para asegurarse de tener en cuenta todos los parámetros de diseño específicos al definir los puntos de prueba. Entre ellos pueden figurar las separaciones entre puntos de prueba y entre puntos de prueba y componentes, que pueden ser más estrictas que las separaciones habituales de colocación y enrutamiento.

Las siguientes secciones examinan con más detalle las pruebas de fabricación y ensamblaje, incluidas las restricciones y consideraciones específicas de los puntos de prueba asociadas a cada una.

Pruebas de fabricación

Las pruebas de fabricación son las que se realizan en una placa de circuito impreso durante la fase de fabricación previa al ensamblaje, antes de colocar los componentes en la placa. Por ello, suelen denominarse pruebas de la placa sin componentes. Este método de prueba suele utilizar un equipo de sondas móviles para realizar pruebas red por red. Básicamente, se programan dos sondas para que funcionen de forma coordinada: una envía una señal pulsada a través de una red y la otra detecta la presencia (o ausencia) de esa señal.

Dos escenarios de prueba habituales para las pruebas de fabricación de la placa sin componentes son:

  1. Comprobar que el cobre que debe ser continuo de extremo a extremo transmita una señal limpia (por debajo de un umbral de impedancia máximo permitido), sin circuitos abiertos.
  2. Comprobar que no haya cortocircuitos entre las redes.

Pruebas de ensamblaje

Las pruebas de ensamblaje son las que se realizan en una placa de circuito impreso durante la fase de fabricación posterior al ensamblaje, una vez montados todos los componentes especificados en su lista de materiales (BOM). Por ello, suelen denominarse pruebas en circuito o pruebas eléctricas. Este método de prueba suele utilizar (¡aunque no se limita en absoluto a ello!) un dispositivo de cama de clavos configurado manualmente. Según el tipo de prueba que se realice con el dispositivo, la placa puede estar alimentada o no.

Dos escenarios de prueba habituales para las pruebas en circuito de la placa ensamblada son:

  1. Hacer contacto simultáneamente con un punto de prueba dedicado para cada red (o red de interés). Para ello, se envía una señal pulsada a través de cada sonda de forma individual y se detecta la recepción de la señal en todas las demás sondas.
  2. Pruebe componentes o buses específicos para asegurarse de que el dispositivo funciona correctamente. Se trata de pruebas especializadas que pueden realizarse mediante diversos métodos. En el caso más sencillo, se puede utilizar un dispositivo de prueba de cama de clavos para realizar pruebas entre los pads de los componentes.

Compatibilidad con puntos de prueba en pads y vías

Altium Designer ofrece compatibilidad completa con los puntos de prueba, lo que permite especificar pads (de orificio pasante o SMD) y/o vías como ubicaciones de puntos de prueba para las pruebas de fabricación y/o ensamblaje. Un pad o una vía se designa como punto de prueba configurando sus propiedades de punto de prueba correspondientes y respondiendo a dos preguntas clave:

  • ¿Debe utilizarse el pad o la vía como punto de prueba de fabricación y/o ensamblaje?
  • ¿En qué cara de la placa debe utilizarse el pad o la vía como punto de prueba: superior, inferior o ambas?

Estas propiedades se encuentran en el panel Properties cuando se selecciona un objeto de pad (consulte Propiedades del pad) o de vía (consulte Propiedades de la vía) en el espacio de diseño, respectivamente.

Un pad o una vía seleccionados se designan como punto de prueba mediante las opciones correspondientes disponibles en el panel Properties.Un pad o una vía seleccionados se designan como punto de prueba mediante las opciones correspondientes disponibles en el panel Properties.

Para agilizar el proceso y evitar tener que configurar manualmente las propiedades de punto de prueba de los pads y las vías, Altium Designer proporciona un método para asignar puntos de prueba automáticamente en función de las reglas de diseño definidas y mediante el Administrador de puntos de prueba. Esta asignación automatizada establece las propiedades de punto de prueba correspondientes para el pad o la vía en cada caso. También puede especificar los puntos de prueba manualmente, es decir, definirlos individualmente para cada pad o vía, lo que le proporciona un control total sobre el esquema de puntos de prueba empleado en la placa.
Al abrir diseños de PCB creados en una versión del software anterior a Summer 09, las opciones de punto de prueba que estuvieran habilitadas pasarán a ser opciones de punto de prueba Fabrication habilitadas.

Reglas de diseño de puntos de prueba

Las restricciones de un diseño de PCB deben planificarse e implementarse como un conjunto bien definido de reglas de diseño. Para implementar correctamente un esquema de puntos de prueba, en el que todos los puntos definidos sean accesibles y puedan utilizarse como parte de las pruebas de placa desnuda y/o en circuito, es necesario establecer las restricciones que lo regulen. Para ello, se pueden definir los siguientes tipos de reglas como parte del sistema de reglas de diseño del editor de PCB:

Acceda a las reglas de estos tipos y defínalas desde el cuadro de diálogo Editor de reglas y restricciones de PCB (Design » Rules).

Defina reglas de diseño independientes para limitar qué pads y/o vías del diseño pueden utilizarse como puntos de prueba de fabricación y de ensamblaje, y qué redes requieren puntos de prueba.Defina reglas de diseño independientes para limitar qué pads y/o vías del diseño pueden utilizarse como puntos de prueba de fabricación y de ensamblaje, y qué redes requieren puntos de prueba.

Las reglas de estilo y uso de puntos de prueba son idénticas, en cuanto a restricciones, para los dos modos de prueba (fabricación y ensamblaje). La regla de estilo especifica esencialmente las restricciones que un pad o una vía deben cumplir para poder seleccionarse como ubicación de un punto de prueba. La regla de uso especifica qué redes requieren un punto de prueba.

Restricciones predeterminadas de las reglas de uso de puntos de prueba (arriba) y de estilo de puntos de prueba (abajo).Restricciones predeterminadas de las reglas de uso de puntos de prueba (arriba) y de estilo de puntos de prueba (abajo).

Al definir una regla de estilo, puede crear rápidamente su ámbito para incluir los objetos de pad y/o vía concretos que se considerarán como puntos de prueba, mediante las opciones disponibles en la sección Rule Scope Helper.

Las reglas de diseño de puntos de prueba se utilizan en el Administrador de puntos de prueba, en el enrutador automático, en los procesos de DRC en línea y por lotes, y también durante la generación de salidas.

Existen reglas predeterminadas de estilo y uso de puntos de prueba de fabricación y ensamblaje. Debe comprobar si estas reglas cumplen los requisitos de su placa y realizar los cambios necesarios. Si se requieren varias reglas del mismo tipo, utilice la prioridad de las reglas de diseño para asegurarse de que se apliquen primero las que tengan un ámbito más específico (por ejemplo, al ejecutar una DRC).

Para que el Testpoint Manager pueda asignar puntos de prueba correctamente, debe always existir al menos una regla de estilo de puntos de prueba correspondiente con un ámbito de All.
Al abrir diseños de PCB o importar reglas de diseño creados en una versión del software anterior a Summer 09, las reglas de estilo de puntos de prueba se convertirán en reglas de estilo de puntos de prueba de fabricación, y las reglas de uso de puntos de prueba se convertirán en reglas de uso de puntos de prueba de fabricación.

Gestión de puntos de prueba

Asignar puntos de prueba manualmente puede ser una tarea minuciosa y laboriosa, más aún en una placa compleja con cientos de componentes distribuidos por ambas caras. Para agilizar la gestión de los puntos de prueba en sus diseños de placas, Altium Designer incorpora al editor de PCB un Testpoint Manager. El Testpoint Manager permite asignar automáticamente puntos de prueba —para pruebas de fabricación de placas desnudas y/o pruebas en circuito del ensamblaje— según las reglas de diseño definidas. Esta asignación automática establece las propiedades de punto de prueba correspondientes para cada pad o vía.

Para acceder, seleccione el comando Tools » Testpoint Manager en los menús principales.

Gestione los requisitos de puntos de prueba de fabricación y ensamblaje de forma rápida y eficiente mediante el Testpoint Manager.Gestione los requisitos de puntos de prueba de fabricación y ensamblaje de forma rápida y eficiente mediante el Testpoint Manager.

Utilice el cuadro de diálogo para asignar y eliminar puntos de prueba automáticamente desde un único lugar. La región Testpoint Net Status incluye una lista de todas las redes del diseño, con un estado que indica la cobertura de puntos de prueba —Complete o Incomplete— tanto para las pruebas de fabricación de placas desnudas como para las pruebas en circuito del ensamblaje. Haga clic en los botones Fabrication Testpoints o Assembly Testpoints, o haga clic con el botón derecho en la tabla para acceder a los comandos que permiten asignar o eliminar ese tipo de punto de prueba. Tenga en cuenta que puede seleccionar manualmente redes en la región superior del cuadro de diálogo para asignar o eliminar puntos de prueba de forma selectiva.

Al asignar puntos de prueba a algunas o a todas las redes de un diseño, el Testpoint Manager sigue las reglas de estilo y uso definidas para los puntos de prueba de fabricación y ensamblaje. Para ver el orden en que se buscan los objetos válidos, haga clic en el botón Search Order.

Para cambiar el orden, haga clic con el botón derecho en una entrada de la lista de orden de búsqueda y utilice los comandos del menú contextual, o los atajos Shift+Up Arrow y Shift+Down Arrow, para desplazarla hacia arriba o hacia abajo en la lista.
Si una red tiene un punto de prueba asignado que infringe una regla de diseño de puntos de prueba aplicable, se indicará Illegal en la región Testpoint Net Status del cuadro de diálogo Testpoint Manager. Utilice la función de comprobación de reglas de diseño del editor de PCB para comprobar la validez de los puntos de prueba asignados.

La región Status Summaries proporciona un resumen completo del estado de los puntos de prueba de la placa para ambos modos de prueba. Esta región se actualiza con cada acción de asignación o eliminación realizada. Para obtener información más detallada, utilice la región Assignment Results. Esta proporciona, por ejemplo, detalles sobre el número de pads y vías de las caras superior e inferior que intervienen en una asignación o eliminación, junto con una indicación de los fallos.

Comprobación de la validez de los puntos de prueba

Las reglas definidas para los puntos de prueba de fabricación y ensamblaje se verifican mediante la función de comprobación de reglas de diseño (DRC) del editor de PCB. La comprobación DRC en línea y/o por lotes puede habilitarse para los distintos tipos de reglas desde el cuadro de diálogo de comprobación de reglas de diseño (Tools » Design Rule Check).

Incluya las reglas de diseño de puntos de prueba en los procesos DRC en línea o por lotes.Incluya las reglas de diseño de puntos de prueba en los procesos DRC en línea o por lotes.

Campos de consulta relacionados con los puntos de prueba

Para trabajar con los distintos puntos de prueba de fabricación y ensamblaje que pueden asignarse en un diseño, están disponibles las siguientes palabras clave para seleccionar puntos de prueba mediante expresiones de consulta lógicas. Todas ellas se encuentran en la categoría Funciones de PCB - Campos al utilizar el Asistente de consultas:

  • IsAssyTestpoint - es un punto de prueba de ensamblaje.
  • IsFabTestpoint - es un punto de prueba de fabricación.
  • IsTestpoint - es un punto de prueba de la cara superior o inferior.
  • Testpoint - ¿es un punto de prueba de la cara superior o inferior?
  • TestpointAssy - ¿es un punto de prueba de ensamblaje?
  • TestpointAssyBottom - ¿es un punto de prueba de ensamblaje de la cara inferior?
  • TestpointAssyTop - ¿es un punto de prueba de ensamblaje de la cara superior?
  • TestpointBottom - ¿es un punto de prueba de la cara inferior?
  • TestpointFab - ¿es un punto de prueba de fabricación?
  • TestpointFabBottom - ¿es un punto de prueba de fabricación de la cara inferior?
  • TestpointFabTop - ¿es un punto de prueba de fabricación de la cara superior?
  • TestpointTop - ¿es un punto de prueba de la cara superior?

Cree expresiones lógicas de consulta para seleccionar y obtener los puntos de prueba de su diseño según sus necesidades. A continuación se muestran algunos ejemplos de expresiones de consulta lógicas para seleccionar puntos de prueba de fabricación y ensamblaje:

  1. (ObjectKind = 'Pad') And (TestpointAssy = 'True')
    Selecciona todos los pads que son puntos de prueba de ensamblaje.
  2. IsPad And (TestpointAssyTop = 'True')
    Selecciona todos los pads que son puntos de prueba de ensamblaje de la cara superior.
  3. (ObjectKind = 'Pad') And (TestpointFab = 'True')
    Selecciona todos los pads que son puntos de prueba de fabricación.
  4. ((IsPad Or IsVia)) And (TestpointAssy = 'True')
    Selecciona todos los pads y vías que son puntos de prueba de ensamblaje.
  5. ((IsPad Or IsVia)) And IsFabTestpoint
    Selecciona todos los pads y vías que son puntos de prueba de fabricación.

Generación de informes de puntos de prueba

Altium Designer incluye generadores de informes específicos para crear informes de puntos de prueba de fabricación y ensamblaje, respectivamente. Estos dos generadores utilizan las propiedades de punto de prueba correspondientes de las primitivas de pad y vía de un diseño.

Un informe de puntos de prueba de fabricación solo utilizará los ajustes de puntos de prueba Fabrication de los pads y las vías. Un informe de puntos de prueba de ensamblaje solo utilizará los ajustes de puntos de prueba Assembly .

Los informes pueden generarse de dos formas:

  • Directamente desde el documento de PCB, mediante los comandos File » Fabrication Outputs » Test Point Report y File » Assembly Outputs » Test Point Report.
  • Mediante salidas configuradas adecuadamente en un archivo de configuración de trabajos de salida (*.OutJob).
Para obtener más información sobre los archivos de configuración de trabajos de salida, consulte Preparación de datos de fabricación con trabajos de salida.

Incluya y configure las salidas de informes de puntos de prueba de fabricación y ensamblaje en un archivo de configuración de trabajos de salida independiente y versátil. Una vez definidas, ¡obtenga sus informes con solo pulsar un botón!Incluya y configure las salidas de informes de puntos de prueba de fabricación y ensamblaje en un archivo de configuración de trabajos de salida independiente y versátil. Una vez definidas, ¡obtenga sus informes con solo pulsar un botón!

Independientemente del método utilizado para generar un informe, las opciones del informe se definen en el mismo cuadro de diálogo. Para un informe de puntos de prueba de fabricación, se utiliza el cuadro de diálogo de configuración de puntos de prueba de fabricación. Para un informe de puntos de prueba de ensamblaje, se utiliza el cuadro de diálogo de configuración de puntos de prueba de ensamblaje. Las opciones de informe son idénticas en ambos cuadros de diálogo.

Defina las opciones del informe, incluido el formato del archivo generado, mediante el cuadro de diálogo de configuración de informes correspondiente. 
Defina las opciones del informe, incluido el formato del archivo generado, mediante el cuadro de diálogo de configuración de informes correspondiente.

Los ajustes definidos en un cuadro de diálogo Testpoint Setup al generar una salida directamente desde la PCB son distintos e independientes de los definidos para el mismo tipo de salida en un archivo de configuración de trabajos de salida. En el primer caso, los ajustes se guardan en el archivo del proyecto; en el segundo, se guardan en el archivo de trabajos de salida.
Las opciones de la región Coordinate Positions de un cuadro de diálogo permiten exportar las ubicaciones de los puntos de prueba en todos los formatos de informe con respecto al origen absoluto de la placa o al origen actual de la placa.
Todos los tipos de informes de puntos de prueba admiten matrices de placas integradas. Al exportar desde un documento de PCB que contiene varias matrices de placas integradas, se generan varios archivos de lista de conexiones IPC-D-356A.

Función del archivo de lista de conexiones IPC-D-356A

Uno de los tres formatos de salida de informes de puntos de prueba es el archivo de lista de conexiones IPC-D-356A. Este archivo suele utilizarse para las pruebas de fabricación de placas desnudas. El archivo IPC se posprocesa para convertirlo en comandos que controlan un equipo de pruebas de sonda móvil.

Independientemente de los elementos que se identifiquen específicamente como ubicaciones de puntos de prueba en un archivo IPC-D-356A, los fabricantes de placas generalmente pueden utilizar los datos del archivo para realizar el tipo de pruebas que deseen, aunque, según las circunstancias y el contenido del archivo, puede ser necesaria cierta intervención manual.

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents