Incluyendo detalles de diseño
De un vistazo
- Descubre qué detalles de documentación de PCB se pueden añadir en el editor de PCB o en el editor de bibliotecas de PCB y cómo se utilizan las capas mecánicas para organizarlos.
- Consulta qué incluyen las tablas de apilado de capas y las tablas de taladros, dónde pueden colocarse y cómo se actualizan o reflejan el diseño actual de la placa.
- Conoce las principales opciones de colocación, movimiento, cambio de tamaño y propiedades que controlan cómo aparecen estos elementos de documentación en los archivos de salida de tu PCB.
Muchos de los archivos de salida que genere requerirán detalles adicionales. Por ejemplo, el plano de fabricación necesitará cotas, el plano de ensamblaje podría necesitar una vista ampliada de un área específica de la placa y el plano de fabricación necesitará una tabla de apilado de capas y una tabla de taladros. Estos tipos de detalles se pueden añadir en el editor de PCB o en el editor de bibliotecas de PCB.
Capas de dibujo de propósito general
En el editor de PCB, los detalles, como las cotas y las instrucciones de fabricación y ensamblaje, se añaden en capas mecánicas. El software admite un número ilimitado de capas mecánicas de propósito general, que se habilitan en el panel Configuración de vista. Estas capas pueden nombrarse según sea necesario (haga clic con el botón derecho en el nombre y, a continuación, seleccione Edit Layer), e incluirse en las impresiones y en los archivos de salida de fabricación basados en capas.
Tabla de apilado de capas

Se puede colocar una tabla de apilado de capas en un documento de PCB junto al propio diseño. Proporciona un resumen detallado de los apilados de capas de la placa y de cómo se asignan los grupos de capas.
Una tabla de apilado de capas es un objeto gráfico tabular que documenta las capas, los materiales, los espesores y las constantes dieléctricas utilizados en el diseño de PCB actual. Se coloca junto al diseño de la placa en el espacio de diseño y también incluye una leyenda gráfica y un mapa de opciones que muestra el apilado de capas utilizado en cada región de la placa. Una tabla de apilado de capas refleja las configuraciones de capas definidas mediante Layer Stack Manager y es un recurso de documentación importante para diseños con una estructura de apilado de capas compleja, como los diseños rígido-flexibles.
La tabla de apilado de capas está disponible en el editor de PCB cuando la vista del espacio de diseño está configurada en el modo 2D normal (atajo 2). Tras ejecutar el comando de colocación de la tabla de apilado de capas (Place » Layer Stack Table), el cursor cambiará a una cruz y se activará el modo de colocación de tablas de apilado de capas. Para colocarla, realice la siguiente secuencia de acciones:
- Haga clic para colocar la tabla.
- El editor permanece en el modo de colocación de tablas de apilado de capas, listo para colocar otra tabla si es necesario. De lo contrario, haga clic con el botón derecho o pulse Esc para salir del modo de colocación.
Durante la colocación, mientras la tabla de apilado de capas siga unida al cursor y antes de que se fije su punto central, se pueden realizar las siguientes acciones adicionales:
- Pulse la tecla Alt para restringir la dirección del movimiento al eje horizontal o vertical, según la dirección inicial del movimiento.
- Pulse Spacebar para girar la tabla de apilado de capas en sentido antihorario o Shift+Spacebar para girarla en sentido horario. El giro se realiza en incrementos de 90°.
Para mover una tabla de apilado de capas, haga clic en ella, mantenga pulsado el botón y arrástrela hasta la ubicación deseada.

Seleccione y arrastre una tabla de apilado de capas para cambiar su posición.
Propiedades de la tabla de apilado de capas

El modo Layer Stack Table del panel Properties.
Ubicación
-
(X/Y)
- X (primer campo): la coordenada X (horizontal) actual del punto de referencia del objeto, relativa al origen actual del espacio de diseño. Edítela para cambiar la posición X del objeto. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
- Y (segundo campo): la coordenada Y (vertical) actual del punto de referencia del objeto, relativa al origen actual. Edítela para cambiar la posición Y del objeto. El valor se puede introducir en unidades métricas o imperiales; incluya las unidades al introducir un valor cuyas unidades no sean las predeterminadas actualmente.
- Rotation : el ángulo de rotación del objeto (en grados), medido en sentido antihorario desde cero (la horizontal 3 o'clock). Edítelo para cambiar la rotación del objeto. La resolución angular mínima es de 0,001°.
Propiedades
- Layer : la capa a la que está asignada actualmente la tabla. Utilice la lista desplegable para seleccionar otra capa.
- Alignment : utilice la lista desplegable para seleccionar la alineación deseada.
-
Units : utilice la lista desplegable para seleccionar
Metric (mm)oImperial (mil). - Show Board Map : active esta opción para mostrar un contorno de la placa que indique cómo se asignan los distintos apilados de capas a las regiones de la placa. Utilice la barra deslizante para cambiar la escala del contorno de la placa mostrado.
- Show Total Board Thickness : active esta opción para mostrar el espesor total de la placa debajo de la cuadrícula de la tabla de apilado de capas.
- Line Width : especifique el ancho de trazo del texto de la tabla. Line Width afecta al grosor del trazo del texto.
- Text Height : la altura actual de los caracteres del texto. Especifique la altura del texto de la tabla. Text Height también afecta al tamaño de la tabla. Si se aumenta la altura del texto, la tabla se ampliará automáticamente.
Tipo de fuente
-
TrueType - utilice este campo para elegir la fuente TrueType deseada. La lista desplegable Font contiene las fuentes TrueType y OpenType (un superconjunto de TrueType) que se encuentran en la carpeta
\Windows\Fonts. Tenga en cuenta que la lista solo incluirá entradas de las fuentes raíz detectadas que tengan nombres únicos. Utilice las opciones B (bold) y I (Italic) para resaltar el texto. -
Stroke
-
Font - utilice este campo para elegir la fuente de trazos requerida. Las opciones disponibles son:
-
Default- una fuente vectorial sencilla compatible con el trazado con plumilla y el fototrazado vectorial. -
Serif- una fuente más compleja que ralentizará la generación de salidas vectoriales, como Gerber. -
Sans Serif- una fuente más compleja que ralentizará la generación de salidas vectoriales, como Gerber.
-
-
Font - utilice este campo para elegir la fuente de trazos requerida. Las opciones disponibles son:
-
Stroke Width - muestra el ancho de trazo actual.
Columnas
Utilice esta sección para especificar qué columnas desea mostrar en la tabla de apilado de capas, la alineación del texto en cada columna y el ancho total de la columna.
- Caption - el título de la columna que se mostrará.
- Align - haga clic en la celda de alineación del encabezado que desea alinear. Puede seguir haciendo clic para alternar entre las opciones de alineación (izquierda, centro y derecha). Cada clic en el campo de alineación cambiará la alineación del texto de esa columna en la tabla.
-
Width - haga clic en el campo para editar el ancho del encabezado seleccionado. Cuando se especifica
Auto, el sistema ajusta automáticamente el ancho de la columna según el texto introducido en ella. Si lo desea, puede introducir el ancho requerido. - Add - utilice el menú desplegable para añadir una columna a la tabla de apilado de capas a partir de las opciones disponibles. En el menú desplegable, haga clic en el encabezado que desea que aparezca en la tabla.
- Up - haga clic para desplazar el encabezado seleccionado una columna hacia la izquierda en la tabla. Utilice el botón Up repetidamente para desplazar la columna seleccionada más columnas hacia la izquierda.
- Down - haga clic para desplazar el encabezado seleccionado una columna hacia la derecha en la tabla. Utilice el botón Down repetidamente para desplazar la columna seleccionada más columnas hacia la derecha.
-
- haga clic para eliminar el encabezado seleccionado de la tabla. Aparecerá una confirmación en la tabla que le preguntará si desea eliminar el elemento seleccionado. Haga clic en Yes si desea eliminarlo; No si no desea hacerlo.
Tabla de taladros

La tabla de taladros presenta un resumen en tiempo real de todos los taladros presentes en la placa
Una tabla de taladros (también conocida como tabla del plano de taladrado o leyenda del plano de taladrado) es un elemento estándar necesario para la fabricación de una placa de circuito impreso. La tabla de taladros enumera el tamaño y el número de orificios correspondientes a cada broca utilizada en la placa. Cada tamaño de taladro puede representarse mediante un símbolo, una letra o el tamaño real del orificio. Cuando se genera un plano de taladrado para la placa, cada ubicación de taladrado se marca con un símbolo. La tabla de taladros se actualiza en tiempo real, es decir, a medida que se colocan o eliminan del diseño de PCB objetos que contienen orificios, como pads y vías, la tabla se actualiza.
Solo se puede colocar una tabla de taladros en el editor de PCB. Tras ejecutar el comando, aparecerá una tabla de taladros vinculada al cursor. Sitúe la tabla en una ubicación adecuada fuera de la placa y, a continuación, haga clic o pulse Enter para colocarla.
Durante la colocación, mientras la tabla de taladros siga vinculada al cursor y antes de que quede fijada, se pueden realizar las siguientes acciones adicionales:
- Pulse la tecla Tab para pausar la colocación y acceder al modo Tabla de taladros del panel Properties , desde donde puede modificar sus propiedades sobre la marcha. Haga clic en el botón de pausa superpuesto para reanudar la colocación.
- Pulse la tecla Alt para restringir la dirección del movimiento al eje horizontal o vertical en función de la dirección inicial del movimiento.
Mover una tabla de taladros
Haga clic y mantenga pulsado el botón en cualquier punto de la tabla de taladros y, a continuación, muévala a la ubicación deseada en el espacio de diseño del editor de PCB.
Cambiar el tamaño de una tabla de taladros de forma interactiva
El tamaño de la tabla de taladros se determina automáticamente según el ajuste Text Height especificado, así como el número de tamaños de orificio diferentes (filas) y el número de columnas definidas. Para cambiar el tamaño de la tabla de forma interactiva, haga clic una vez para seleccionarla y, a continuación, haga clic y mantenga pulsado el botón sobre un vértice de esquina y arrástrelo para ajustar el tamaño según sea necesario. Tenga en cuenta que cambiar el tamaño de la tabla de forma interactiva también aumentará o reducirá el tamaño de la fuente.
Cambiar de forma interactiva el par de capas que se previsualiza
Cuando la placa incluye pares de capas, el par de capas mostrado se controla mediante la opción Layers Pairs del modo Drill Table del panel Properties .
El par de capas elegido también se puede cambiar mediante:
-
El menú contextual del editor de PCB: haga clic con el botón derecho en la tabla de taladros y seleccione el par de capas requerido en el submenú Drill Table, como se muestra en la imagen siguiente.

Haga clic con el botón derecho en la tabla de taladros para que muestre otro par de capas -
El menú de selección de pares de capas, al que se accede mediante la pestaña de capa situada en la parte inferior del espacio de diseño, como se muestra en la imagen siguiente.
Propiedades de la tabla de taladros

El modo Drill Table del panel Properties
Acciones
Refresh – haga clic en el botón para actualizar la tabla de taladros con los datos actuales de los símbolos de taladro de la PCB.
Ubicación
-
(X/Y) – las coordenadas X e Y actuales del punto de referencia de la tabla de taladros. El punto de referencia es la esquina inferior izquierda si Alignment =
Bottom, o la esquina superior izquierda si Alignment =Top. - Rotation – ángulo en grados con el que se gira la tabla de taladros.
Propiedades
-
Layer Pairs – la tabla de taladros admite placas multicapa que utilizan taladrado por pares de capas. Utilice la lista desplegable para seleccionar un par de capas definido en la pestaña Tipos de vías del Administrador de apilado de capas o una de las siguientes opciones:
- All Layer Pairs (Composite table) – muestra información de todos los pares de capas.
-
All Layer Pairs (Separate tables) – muestra la información de cada par de capas en una tabla independiente.
- Top - Bottom – muestra solo los taladros pasantes.
- Counterhole Bottom – muestra solo los cajeados y avellanados de la cara inferior de la PCB.
- Counterhole Top – muestra solo los cajeados y avellanados de la cara superior de la PCB.
- Text Height – muestra la altura del texto.
Tipo de fuente
-
TrueType – seleccione esta opción para utilizar las fuentes disponibles en su PC (en la carpeta \Windows\Fonts). Las fuentes TrueType ofrecen compatibilidad completa con Unicode. De forma predeterminada, el software vincula las fuentes TrueType utilizadas (no se almacenan en el archivo PCB), lo que significa que la misma fuente debe estar presente en cada PC al que se transfiera el diseño. Como alternativa, puede incrustar las fuentes TrueType utilizadas en el archivo PCB mediante las opciones de la página Editor de PCB – Fuentes TrueType del cuadro de diálogo Preferences, donde también puede seleccionar una Substitution Font para utilizarla si una fuente no incrustada no está disponible.
- Font – utilice la lista desplegable para seleccionar la fuente TrueType deseada. Utilice B para aplicar negrita o I para aplicar cursiva al texto.
-
Stroke
-
Font – utilice la lista desplegable para seleccionar la fuente de trazos deseada. Las opciones son:
-
Default– una fuente vectorial sencilla diseñada para el trazado con plumilla y el fototrazado vectorial. -
Sans Serif -
Serif
-
- Stroke Width – muestra el ancho del trazo.
-
Font – utilice la lista desplegable para seleccionar la fuente de trazos deseada. Las opciones son:
- Show Footer – active o desactive esta opción para mostrar u ocultar el pie de la tabla.
- Alignment – la tabla puede construirse de abajo hacia arriba (Bottom) o de arriba hacia abajo (Top). Utilice este ajuste para permitir cambios en el tamaño de la tabla sin afectar a los objetos circundantes del espacio de diseño.
- Table Border Width – ancho de las líneas utilizadas para crear el borde de la tabla.
-
Drill Symbols – haga clic para abrir el cuadro de diálogo Drill Symbols, en el que puede asignar símbolos o letras a los tamaños de los taladros.
Opciones y controles del cuadro de diálogo Símbolos de taladro
Grid Area
El área de la cuadrícula muestra información detallada sobre la asignación de un símbolo a un tamaño de taladro. Puede personalizarla haciendo clic en un encabezado de columna y arrastrándolo para cambiar el orden de las columnas, y haciendo clic con el botón derecho en un encabezado de columna y activando o desactivando la casilla de verificación para mostrar u ocultar la columna.
Grouping
Haga clic en el botón Grouping para definir qué propiedades se utilizarán para controlar la asignación de símbolos a las operaciones de taladrado (orificios). Los orificios se agrupan inicialmente por tamaño y, después, se les asignan símbolos distintos cuando se habilita una opción de agrupación que los identifica de forma unívoca. Por ejemplo, el diseño podría incluir un pad redondo con un orificio de 1 mm y otro pad cuadrado con un orificio de 1 mm. Si Pad Shape no está habilitado en Grouping, se les asignará el mismo símbolo. Sin embargo, si Pad Shape está habilitado en Grouping, se les asignarán símbolos distintos.
Graphic Symbol
Cada ubicación de taladro puede representarse mediante un símbolo, una letra o una cadena que muestre el tamaño real del taladro. Estas opciones controlan el estilo y el tamaño de los símbolos:
-
Symbol - seleccione esta opción para utilizar un símbolo en cada ubicación de taladro. El software incluye 15 estilos de símbolos predefinidos, como se muestra en la imagen siguiente. Si hay más de 15 tamaños de taladro, se asignan automáticamente caracteres alfabéticos.
- Character - seleccione esta opción para utilizar un carácter alfabético en cada ubicación de taladro.
- Symbol Size - la altura del símbolo o la letra que se muestra en la capa de dibujo de taladros. Tenga en cuenta que este ajuste se aplica a todos los símbolos y letras utilizados en el dibujo de taladros.
Draw Symbols
Estas opciones controlan el estilo de los símbolos de taladro y cuándo deben mostrarse:
- Show Symbols - muestra un símbolo en cada ubicación de taladro.
- Show Hole Size - muestra el tamaño real del taladro en cada ubicación como un valor numérico.
- Show Drill Symbols - de forma predeterminada, no se muestran los símbolos de taladro en la capa de dibujo de taladros. Habilite esta opción para mostrar los símbolos de taladro.
-
-
– haga clic para actualizar la tabla cuando se produzcan cambios en el diseño que afecten a la tabla de taladros. Tenga en cuenta que la tabla se actualiza automáticamente durante la generación de las salidas.
Unidades
-
Primary Units – utilice la lista desplegable para establecer las unidades principales en
Metric (mm)oImperial (mil). -
Dual Units – utilice la lista desplegable para establecer las unidades secundarias en
Metric (mm)oImperial (mil). Utilice
o
para determinar si estas unidades se muestran o se ocultan (respectivamente) en el espacio de diseño.
Precisión
- Primary Precision – utilice la lista desplegable para establecer la precisión requerida (número de dígitos después del separador decimal).
- Dual Precision – utilice la lista desplegable para establecer la precisión de las unidades secundarias (número de dígitos después del separador decimal).
Columnas
- Grid – muestra todos los encabezados de columna (Caption) de la tabla de taladros, el ajuste Align, que reposiciona el contenido dentro de la cuadrícula, el Width y el Order en el que se muestra la información de cada columna. Para cambiar de orden ascendente a descendente y viceversa, haga clic en la columna Order para acceder a un menú desplegable y seleccione el orden deseado: Asc – ascendente o Dsc – descendente.
-
Edit Columns – haga clic para abrir el cuadro de diálogo Columns, que permite añadir nuevas columnas a la tabla de taladros o editar las existentes.
El cuadro de diálogo presenta todas las columnas existentes, junto con los datos asociados (de solo lectura). Utilice los siguientes botones situados debajo de la cuadrícula para seleccionar los datos que se mostrarán en la tabla:
- Add Column - permite añadir una nueva columna a la tabla de taladros. Haga clic para abrir un menú con las columnas disponibles. Las columnas que ya están en uso o que no están disponibles aparecen atenuadas en el menú. Este comando también está disponible en el menú contextual.
- Remove Column - haga clic para eliminar las columnas seleccionadas. Tenga en cuenta que no hay ningún cuadro de diálogo de confirmación; al hacer clic en el botón, la columna se elimina. Este comando también está disponible en el menú contextual.
- Change Header - haga clic para abrir el cuadro de diálogo Cambiar encabezado de columna, en el que puede cambiar el título de la columna seleccionada. Este comando (denominado Change column header) también está disponible en el menú contextual.
Los siguientes comandos adicionales están disponibles en el menú contextual que aparece al hacer clic con el botón derecho:
-
Text Alignment - permite alinear el texto de la columna seleccionada. Las opciones son:
Left,CenteryRight. -
Set column width - permite establecer el ancho de la columna seleccionada. Las opciones son:
Autosize(predeterminada) yManual. Al hacer clic enManual, se abre el cuadro de diálogo Establecer ancho de columna, en el que puede introducir el ancho deseado.
Vista de diseño

Coloque una vista de diseño para mostrar un área específica de la placa. Este ejemplo se ha escalado al 200 %.
El objeto Vista de diseño de PCB es una instantánea gráfica de cualquier región rectangular de la placa actual o de otra placa. Se puede colocar en cualquier lugar del espacio de diseño y escalar a cualquier tamaño.
Solo se puede colocar una vista de diseño en el Editor de PCB. Tras ejecutar el comando de colocación de vista de diseño (Place » Design View), aparecerá una vista de diseño unida al cursor. Sitúe la vista de diseño en una ubicación adecuada y haga clic o pulse Enter para colocarla.
Durante la colocación, mientras la vista de diseño sigue unida al cursor y antes de que quede fijada, se pueden realizar las siguientes acciones adicionales:
- Pulse la tecla Alt para restringir la dirección del movimiento al eje horizontal o vertical, según la dirección inicial del movimiento.
Después de colocar la vista de diseño, puede definir la visualización de las capas deseadas siguiendo estos pasos:
- Con la vista de diseño seleccionada en el espacio de diseño, abra el panel Propiedades haciendo doble clic o haciendo clic con el botón derecho y seleccionando Properties en el menú contextual.
- Utilice el botón Define del panel Properties para definir de forma interactiva el área de interés.
-
En la sección Layers del panel Properties , haga clic en el icono
para activar o desactivar la visualización de las capas deseadas. Cuando se active en el panel Properties , las capas deseadas mostrarán el icono
.
Las vistas de diseño se incluyen en las salidas impresas y en PDF. La vista de diseño conserva sus propios ajustes de visibilidad de capas en la salida, lo que permite que se presente según lo requerido en la salida impresa o en PDF. Tenga en cuenta que las primitivas de las capas utilizadas en la vista de diseño siguen respetando los ajustes de visualización definidos para esa capa en el cuadro de diálogo Imprimir. Por ejemplo, si la serigrafía superior se muestra en la vista de diseño y está configurada para mostrar las pistas en modo Borrador para esa salida en el trabajo de salida, las pistas de la serigrafía superior de la vista de diseño también se mostrarán en modo Borrador.
Una vez colocada una vista de diseño en el espacio de diseño, puede ajustar de forma interactiva su posición, escala, tamaño y área de visualización.
- Change the position – Click+Drag el objeto Vista de diseño a una nueva ubicación en el espacio de diseño de PCB.
- Adjusting the Scale – haga clic una vez para seleccionar la vista de diseño y, a continuación, Click+Drag en un controlador de esquina para ampliar (arrastrar hacia fuera) o reducir (arrastrar hacia dentro) la vista de diseño.
- Adjusting the View Size – haga clic una vez para seleccionar la vista de diseño y, a continuación, Ctrl+Click+Drag en un controlador de esquina para cambiar el tamaño de la vista de diseño.
- Changing the Focus – Ctrl+Click+Drag en cualquier punto dentro de la vista de diseño para desplazar el área que se muestra actualmente dentro de la ventana de la vista de diseño.

Ctrl+Click+Drag para desplazar y ajustar el área que se muestra actualmente en la vista de diseño.
Propiedades de la vista de diseño

El modo Design View del panel Properties.
Ubicación
- (X/Y) - las coordenadas X e Y actuales del punto de referencia de la vista de diseño.
Propiedades
- This document - seleccione esta opción para especificar las propiedades del documento activo actualmente.
-
Specify document - seleccione esta opción para especificar las propiedades de otro documento. Una vez seleccionada, haga clic en
en el campo Document y busque el documento deseado.
-
Document - haga clic en
para buscar y seleccionar el documento deseado cuando esté seleccionado Specify document .
- Mirrored - haga clic para activar una imagen invertida (en espejo) del área de la placa en la vista de diseño.
- Scale - haga clic para definir el tamaño del objeto como un factor multiplicador.
- Title - introduzca el título de la vista de diseño.
- Text Height - introduzca la altura del texto del título de la vista de diseño.
- Font - utilice el menú desplegable para seleccionar la fuente deseada para el título. Utilice el recuadro de color para abrir un selector de color para el texto del título. Tenga en cuenta que el color debe contrastar con el color de fondo del espacio de diseño para que el texto sea visible.
- Define - haga clic para volver al espacio de diseño con un cursor en forma de cruz y, a continuación, haga clic y arrastre para definir la región rectangular de la vista.
Capas
Esta región proporciona una lista de todas las capas de la placa que se pueden configurar para mostrar capas específicas en la vista de diseño.
-
Name - el nombre de la capa. Utilice
o
para mostrar u ocultar (respectivamente) la capa indicada en la vista de diseño.
- Type - el tipo de capa.
Objeto OLE

Una secuencia de objetos OLE colocados: una imagen, celdas de una hoja de cálculo y texto de un documento de Word (de arriba abajo)
La tecnología de vinculación e incrustación de objetos (OLE) del editor de PCB permite incrustar en un diseño de PCB datos proporcionados por aplicaciones OLE de Windows, manteniendo un vínculo activo con la aplicación de origen. En muchos casos, esto permite editar los datos incrustados en la PCB desde la aplicación que los creó.
Entre los objetos OLE habituales que pueden colocarse en un documento de PCB se incluyen documentos de Excel, documentos de Word u objetos gráficos de una aplicación de imágenes compatible con OLE. Los tipos de archivo admitidos incluyen formatos universales, como hojas de cálculo en formato CSV y XLS, documentos de texto DOC y RTF, y archivos de imagen BMP.
Los objetos OLE pueden colocarse o incrustarse en el editor de PCB. Tras ejecutar el comando Place » Object From File, seleccione el archivo deseado en el cuadro de diálogo Choose File y, a continuación, haga clic para colocar el objeto en el espacio de diseño.
La función de pegado inteligente de Altium también permite copiar una selección de una aplicación OLE y pegarla (Edit » Paste) en el documento de PCB como un objeto OLE. La opción de pegado de texto (Edit » Paste Text) puede utilizarse para extraer los elementos de texto de un objeto OLE, si es necesario. Estos se colocarán como objetos de texto de PCB.
Una vez colocados, los objetos incrustados pueden escalarse proporcionalmente haciendo clic en sus controladores de selección y arrastrándolos mientras se mantiene pulsado el botón del ratón. En los objetos basados en texto, como los documentos de Word y Excel, el tamaño y el grosor del texto incrustado se ajustan automáticamente a las nuevas dimensiones.
- Un objeto OLE también puede convertirse en un conjunto de objetos primitivos libres mediante el comando Tools » Convert » Explode OLE Object to Free Primitives. Esto descompondrá el objeto en los objetos de región o de texto correspondientes.
- También se ofrece una opción para convertir a primitivas libres si no se encuentra la aplicación OLE correspondiente al intentar editar un objeto OLE.
Propiedades del objeto OLE

El modo OLE Object del panel Properties.
Ubicación
- (X/Y) - las coordenadas actuales X (horizontal) e Y (vertical) del punto de referencia del objeto con respecto al origen actual del espacio de diseño. Edítelas para cambiar la posición del objeto.
- Rotation - el ángulo de rotación del objeto (en grados), medido en sentido antihorario desde cero (la horizontal 3 o'clock). Edítelo para cambiar la rotación del objeto. La resolución angular mínima es de 0,001°.
Propiedades
- Layer - la capa a la que está asignado actualmente el objeto. Utilice la lista desplegable para seleccionar una capa diferente.
- Edit Data - haga clic para abrir el objeto (en la aplicación asociada) y realizar las modificaciones necesarias. Tras realizar las modificaciones y cerrar la aplicación asociada, en el panel Propiedades, haga clic en Save para guardar las modificaciones o en Cancel.
Cotas
Los editores de PCB y de bibliotecas de PCB incluyen una serie de herramientas de acotación para satisfacer distintos requisitos de diseño.
| Objeto de cota | Descripción |
|---|---|
| Angular Dimension | Permite acotar distancias angulares. |
| Baseline Dimension | Permite acotar la distancia lineal de un conjunto de referencias con respecto a una única referencia base. El primer punto seleccionado es la «base». Todos los puntos posteriores se refieren a este primer punto. Por tanto, el valor de la cota en cada caso es la distancia entre cada punto de referencia y la «base», medida en las unidades predeterminadas. Las referencias pueden ser pistas, arcos, pads, vías, texto, rellenos, polígonos o componentes. |
| Center Dimension | Permite marcar el centro de un arco o un círculo. |
| Leader Dimension | Permite etiquetar un objeto, un punto o un área. Hay tres tipos de directriz disponibles: automática, redonda y cuadrada, que determinan si el texto de la etiqueta queda encerrado en un círculo, en un cuadrado o sin contorno. El puntero puede ser una flecha o un punto. |
| Linear Dimension | Permite acotar una distancia lineal. El valor de la cota es la distancia entre los marcadores inicial y final (puntos de referencia seleccionados por el usuario), medida en las unidades predeterminadas. Las referencias pueden ser objetos (pistas, arcos, pads, vías, texto, rellenos, polígonos o componentes) o puntos en el espacio libre. |
| Linear Diameter Dimension | Permite acotar un arco o un círculo con respecto al diámetro, en lugar del radio. La cota puede colocarse en el interior o en el exterior. |
| Ordinate Dimension | Permite acotar la distancia lineal de un conjunto de objetos con respecto a un único objeto de referencia. El primer objeto seleccionado es la «base». Todos los objetos posteriores se refieren a este primer objeto. Por tanto, el valor de la cota en cada caso es la distancia entre cada objeto de referencia y la «base», medida en las unidades predeterminadas. Las referencias pueden ser pistas, arcos, pads, vías, texto, rellenos, polígonos o componentes. |
| Radial Dimension | Permite acotar el radio de un arco o un círculo. La cota puede colocarse en el interior o en el exterior. |
| Radial Diameter Dimension | Permite acotar un arco o un círculo con respecto al diámetro, en lugar del radio. La cota puede colocarse en el interior o en el exterior con respecto a la circunferencia del arco o círculo. |
| Standard Dimension | Coloca información de acotación en la capa actual de la PCB. El valor de la cota es la distancia entre los marcadores inicial y final, medida en las unidades predeterminadas. |
Los objetos de cota están disponibles en el submenú Place » Dimension de los menús principales. Al acotar un objeto, aparecen puntos de anclaje que resaltan dónde puede fijarse la cota. La barra de estado muestra información sobre las acciones necesarias en cada paso del proceso. El punto más cercano al cursor será el que se utilice y donde se fijará la cota si hace clic o pulsa Enter.
En el siguiente vídeo se muestran ejemplos de colocación de algunas cotas.
Durante la colocación pueden realizarse las siguientes acciones adicionales:
- Pulse las teclas + y - (del teclado numérico) para recorrer hacia delante y hacia atrás, respectivamente, todas las capas visibles del diseño y cambiar rápidamente la capa de colocación.
- Al colocar una cota de línea base, de centro, de diámetro lineal, lineal o de ordenadas, pulse Spacebar para girar la cota en sentido antihorario o Shift+Spacebar para girarla en sentido horario. El giro se realiza según el valor de Rotation Step definido en la página PCB Editor – General del cuadro de diálogo Preferences.
- Al colocar una cota estándar, pulse la tecla L para voltear la cota al otro lado de la placa; tenga en cuenta que esto solo es posible antes de anclar el punto inicial de la cota.
El valor de una cota (cuando corresponda) se actualiza automáticamente al mover sus puntos inicial o final. Asimismo, si cambia la posición de un objeto al que está anclado un punto de referencia de la cota, esta se actualizará y se ampliará o contraerá para reflejar el cambio. En el caso de una cota basada en un radio o diámetro, el valor se actualiza automáticamente cuando cambia el diámetro del arco o círculo de referencia.
Cuando se eliminan las referencias a las que está asociado un objeto de cota, se abre un cuadro de diálogo que pregunta si también debe eliminarse la cota. Si no se elimina, permanece en el espacio de diseño, pero sin referencia.
Un objeto de cota se puede mover de las siguientes maneras:
- Selecting both the dimension object and the dimensioned object(s). El conjunto se puede arrastrar a una nueva ubicación según sea necesario.
- Selecting a dimensioned object only. El texto de la cota seguirá al objeto únicamente en su plano de alineación. Las líneas auxiliares de cota (o, en una cota de diámetro radial o de radio, su puntero y su cola) se ampliarán o contraerán para mantener la relación entre la cota y el objeto acotado. En el caso de una cota de centro o con directriz, se moverá con el objeto. El segmento de la cota con directriz (entre la flecha o el punto y el primer codo definido) se ampliará o contraerá para mantener la relación entre la cota y el objeto acotado.
- Selecting the dimension object only. Es importante tener en cuenta que la cota no se puede mover por separado si está vinculada a un objeto de diseño. Para mover solo la cota, primero debe desvincularse de los objetos que está acotando.
Al seleccionar un objeto de cota, aparecen controles de edición que permiten editarlo directamente en el espacio de diseño, modificando gráficamente propiedades como la posición de su texto y sus puntos de referencia. A continuación se muestran ejemplos de controles de edición para algunas cotas.
|
Al seleccionar un objeto de cota lineal, están disponibles los siguientes controles de edición:
Al seleccionar un objeto de cota angular, están disponibles los siguientes controles de edición:
Al seleccionar un objeto de cota radial, están disponibles los siguientes controles de edición:
Al seleccionar un objeto de cota de ordenadas, están disponibles los siguientes controles de edición.
|
Los controles situados en los objetos acotados (o más próximos a ellos) (por ejemplo, C y D para una cota lineal o C & E y D & F para una cota angular, como se muestra arriba) permiten redefinir las referencias – una vez que la cota se desvincula de un objeto de referencia, queda sin referencia y puede moverse para vincularla a otro punto u objeto de referencia. Al arrastrar cualquiera de los controles de edición de una cota lineal, de ordenadas o de línea base sin referencia, es posible girarla.
Propiedades de los objetos de cota
Las cotas disponen de diversas opciones de configuración que ofrecen un alto grado de personalización de las flechas y el texto. Abra el panel Properties para uno o varios objetos de cota seleccionados y edite sus propiedades.
| Propiedad | Objetos a los que se aplica | Descripción |
|---|---|---|
Estilo |
||
| Width | Todos, excepto las cotas de centro y de ordenadas | El grosor actual de la línea de cota. |
| Width (en la sección Extension Line) | Cota angular Cota de línea base Cota lineal Cota de diámetro lineal Cota de ordenadas |
El grosor actual de las líneas auxiliares de cota. |
| Gap | Cota angular Cota de línea base Cota con directriz Cota lineal Cota de diámetro lineal Cota de ordenadas |
|
| Offset | Cota angular Cota de línea base Cota lineal Cota de diámetro lineal |
El desplazamiento actual de la línea de flecha con respecto a la línea auxiliar de cota. |
| Text Gap | Todos, excepto las cotas de centro y estándar |
|
| Leader Shape | Cota con directriz | Utilice el menú desplegable para determinar qué figura se utiliza para englobar el texto de la cota. Las opciones disponibles son Automatic, Round y Square. Si se selecciona Round o Square, introduzca el valor deseado de Size. |
| Arrow Style | Cota con directriz | Utilice el menú desplegable para seleccionar el estilo de directriz deseado. Las opciones son Arrow o Dot. Introduzca el valor deseado de Size. |
| Height | Cota estándar | La altura actual de la línea auxiliar de cota. |
| Arrow Size | Cota angular Cota desde línea base Cota lineal Cota de diámetro lineal Cota radial Cota de diámetro radial |
El tamaño actual de la punta de flecha. El tamaño se mide como la distancia entre la punta de la flecha y el extremo de sus «ramas». |
| Arrow Length | Cota angular Cota desde línea base Cota lineal Cota de diámetro lineal Cota radial Cota de diámetro radial |
La longitud actual de la flecha. Tenga en cuenta que el valor introducido en este campo solo se aplica cuando Arrow Position (en la región Properties ) está configurado en Outside. |
Propiedades |
||
| Text | Cota con directriz | Introduzca el texto deseado. |
| Layer | Todas | La capa a la que está asignada actualmente la cota. Utilice el menú desplegable para seleccionar la capa deseada. Las cotas se pueden asignar a cualquier capa disponible. |
| Text Position | Todas, excepto las cotas de centro y estándar | La posición actual del texto de la cota. Utilice la lista desplegable asociada para elegir una de las siguientes opciones (las opciones disponibles dependen del tipo de objeto de cota):
|
| Arrow Position | Cota angular Cota desde línea base Cota lineal Cota de diámetro lineal Cota radial Cota de diámetro radial |
La posición actual de las flechas de la cota. Las opciones disponibles son:
|
| Angular Step | Cota de diámetro radial | El ajuste actual del incremento angular de la cota. Este es el incremento de rotación que se utiliza al colocar la parte de la cota correspondiente a la flecha. Al mover la flecha alrededor del círculo o arco durante la colocación de la cota, el número y la posición de los posibles puntos de anclaje de la cota vienen determinados por este valor de incremento angular. |
| Text Height | Todas, excepto la cota de centro | La altura actual de los caracteres del texto de la cota. El ancho de los caracteres utilizado para mostrar o imprimir el texto se ajusta automáticamente en proporción a esta altura. Una altura mínima de 36mil (0.9mm) permitirá que el texto se fototrace de forma legible. |
| Rotation | Cota de centro Cota lineal Cota de diámetro lineal Cota por coordenadas |
El ángulo de alineación de la cota, medido en grados en sentido antihorario desde la horizontal. |
| Size | Cota de centro | La longitud actual de las líneas de la cruz de la cota (o el diámetro del círculo que la engloba). |
| Font Type | Todas, excepto la cota de centro |
|
Unidades |
||
| Primary Units | Cota angular Cota de línea base Cota lineal Cota de diámetro lineal Cota por coordenadas Cota radial Cota de diámetro radial |
La unidad seleccionada actualmente para el cálculo y la visualización del valor de la cota.
|
| Value Precision | Cota angular Cota de línea base Cota lineal Cota de diámetro lineal Cota por coordenadas Cota radial Cota de diámetro radial |
El ajuste actual del número de decimales a la derecha del separador decimal con el que se mostrará la cota. |
Valor |
||
| Format | Todas, excepto las cotas de centro y de directriz |
El ajuste actual del formato del texto de la cota. Utilice el desplegable asociado para cambiar el formato según sea necesario. Las opciones enumeradas dependerán de la Unit seleccionada y se mostrarán en función del valor real de la cota actual. En términos generales, las opciones disponibles son (el conjunto de opciones disponibles depende del tipo de objeto de cota):
|
| Prefix | Cota angular Cota de línea base Cota lineal Cota de diámetro lineal Cota por coordenadas Cota radial Cota de diámetro radial |
El prefijo del valor de la cota. Para una cota de diámetro lineal o de diámetro radial, este campo contiene de forma fija el carácter ø. |
| Suffix | Cota angular Cota de línea base Cota lineal Cota de diámetro lineal Cota por coordenadas Cota radial Cota de diámetro radial |
El sufijo del valor de la cota. |
| Sample | Todas, excepto las cotas de centro y de directriz |
Este campo presenta una muestra de cómo aparecerá el texto de la cota de acuerdo con el Format especificado y cualquier Prefix y/o Suffixdefinido. |
| Start point (X/Y) | Cota estándar | El punto inicial de la cota para X (primer valor) e Y (segundo valor). |
| End point (X/Y) | Cota estándar | El punto final de la cota para X (primer valor) e Y (segundo valor). |
Conversión de cotas en primitivas
Las cotas son objetos de diseño agrupados, es decir, están compuestas por uno o varios segmentos de texto y de pista. Una cota se puede convertir en los objetos primitivos que la componen mediante el comando Tools » Convert » Explode Dimension to Free Primitives.


