Planification des zones rigides et flexibles - Mode avancé
En un coup d'œil
- Vous découvrirez la différence entre le mode rigide-flexible standard et le mode rigide-flexible avancé, ainsi que son incidence sur la création et la définition des régions de la carte.
- Vous verrez comment placer et modifier les régions de la carte en mode de planification de la carte, notamment en leur attribuant des noms et des empilages de couches, et en utilisant les guides et l’accrochage pour gagner en précision.
- Vous découvrirez des raccourcis, des modes de placement et des paramètres de propriétés utiles pour travailler plus efficacement sur des conceptions de PCB rigides-flexibles complexes.
Placement d'une zone de carte
Une zone de carte est un objet polygonal qui se place à l'aide des techniques standard de placement des objets polygonaux. La forme de la carte doit être définie avec précision ; il est donc important que les zones qui la composent soient créées exactement selon les besoins. La vidéo ci-dessous montre comment créer des zones de carte en alignant leurs bords sur des guides préalablement placés dans l'espace de conception. L'avantage de cette technique est que la position des guides de l'espace de conception peut être définie avec précision en modifiant leurs coordonnées dans le panneau Properties.
Des guides prédéfinis dans l'espace de travail servent de références pour le placement des zones de carte.
Les zones de carte sont placées et modifiées dans Board Planning Mode :
- Sélectionnez View » Board Planning Mode (ou utilisez le raccourci 1) pour passer en Board Planning Mode. La zone de carte existante par défaut s'affiche sous la forme d'un rectangle vert.
-
Sélectionnez Place » Board Region pour placer une nouvelle zone (ou cliquez sur le bouton
de la Active Bar).
- Positionnez le curseur et cliquez pour ancrer le sommet de départ de la zone de carte. La zone de carte est un objet polygonal, comme une région ou un polygone, et suit la même procédure de placement (et de modification).
- Déplacez le curseur pour placer le deuxième sommet. Par défaut, chaque clic place deux bords avec, entre eux, un angle dont la forme est définie par l'utilisateur. Appuyez sur Spacebar pour inverser l'orientation de l'angle. Reportez-vous à la section Placement Modes ci-dessous pour plus de détails sur le changement des modes d'angle.
- Continuez à déplacer la souris et à cliquer pour placer des sommets et créer les bords nécessaires à la définition de la forme globale de la zone de carte.
- Après avoir placé le dernier sommet, faites un clic droit ou appuyez sur Esc pour fermer et terminer la définition de la forme de la carte. Il n'est pas nécessaire de fermer manuellement la forme de la carte, car le logiciel la complète automatiquement en reliant le dernier point placé au point de départ.
- Chaque zone de carte porte un nom qui permet de l'identifier de manière unique. Saisissez un nom approprié dans le champ Name du mode Zone de carte du panneau Propriétés (la zone de carte doit être sélectionnée dans l'espace de conception pour que ses propriétés s'affichent dans le panneau).
-
Un empilage de couches doit être affecté à chaque zone de carte. Lorsqu'une nouvelle zone de carte est créée, l'empilage de couches par défaut, nommé
Board Layer Stack, lui est affecté. Affectez l'empilage de couches requis dans le mode Board Region du panneau Properties. Les empilages de couches sont définis et nommés dans le Gestionnaire d'empilage de couches. - Si le PCB final nécessite plusieurs zones de carte, poursuivez la définition de zones supplémentaires.
Vous pouvez également appuyer sur la touche Tab pour suspendre le placement et accéder au mode Zone de carte du Properties panneau, où vous pouvez modifier ses propriétés à la volée. Cliquez sur le bouton de pause superposé dans l'espace de conception pour reprendre le placement.
Placement Modes
Lors de la redéfinition de la forme de la carte, cinq modes d'angle sont disponibles, dont quatre proposent également des sous-modes d'orientation de l'angle. Pendant la redéfinition :
- Appuyez sur Shift+Spacebar pour parcourir les cinq modes d'angle disponibles.
- Appuyez sur Spacebar pour basculer entre les deux sous-modes d'orientation de l'angle.
-
Dans l'un ou l'autre des modes d'angle en arc, maintenez la touche
pour réduire l’arc ou sur la touche
pour l’agrandir. Maintenez la touche Shift enfoncée pendant cette opération pour accélérer le redimensionnement de l’arc.
- Appuyez sur la touche de raccourci 1 pour basculer entre le placement de deux segments par clic et celui d’un seul segment par clic. Dans le second mode, le segment en pointillés est appelé segment d’anticipation (comme illustré dans la dernière image de la série ci-dessous).
- Appuyez sur la touche Backspace pour supprimer le dernier sommet.



Appuyez sur Shift+Spacebar pour parcourir les cinq modes de coin disponibles, puis sur la touche de raccourci 1 pour basculer entre le placement de deux segments et celui d’un seul segment.
Propriétés de la région de carte

Le mode Board Region du panneau Properties.
Actions
Ces commandes permettent d’ajouter ou de supprimer le film de protection (coverlay) de la région de carte active. Pour activer les boutons Add et Remove Coverlay , la région de carte doit être associée à un empilage de couches dans lequel l’option Is Flex est activée et qui comprend des couches de coverlay.
- Add Coverlay - Ajoute des polygones de coverlay générés automatiquement à la région de carte sélectionnée.
- Remove Coverlay - Supprime les polygones de coverlay générés automatiquement et définis manuellement de la région de carte sélectionnée.
Position
- (X/Y) - Coordonnées X et Y du premier sommet placé lors de la création de la région de carte, par rapport à l’origine actuelle de l’espace de conception. Modifiez ces valeurs pour changer la position X ou Y de la région de carte. Les valeurs peuvent être saisies en unités métriques ou impériales ; précisez les unités lorsque vous saisissez une valeur dans une unité autre que celle définie par défaut.
Propriétés
- Name - Nom personnalisable de cette région de carte. Il est utile de nommer chaque région de carte lorsque la conception en comporte plusieurs.
- Layer Stack - Spécifie l’empilage de couches affecté à cette région de carte. La liste déroulante comprend tous les empilages de couches (sous-empilages) définis dans le gestionnaire d’empilage de couches.
- Color - Cliquez pour ouvrir une palette permettant de définir ou de modifier la couleur des régions de carte sélectionnées. Notez que les changements de couleur s’appliquent à toutes les régions de carte qui partagent l’empilage de couches utilisé par la région de carte sélectionnée.
- Priority - La valeur de priorité détermine quelle région de carte est rendue en dernier. Utilisez-la lors de la conception d’une carte comportant une région flexible dans une découpe située dans une région rigide : la région flexible doit avoir une valeur de priorité supérieure à celle de la région rigide qui l’entoure (et la découpe de la carte doit suivre le contour de la région flexible qu’elle contient).
- 3D Locked - Cochez cette case pour immobiliser cette région de carte lors du pliage de la carte en mode d’affichage 3D. Une seule région de carte rigide peut être verrouillée.
Sommets du contour
Cette section permet de modifier individuellement les sommets de l’objet région de carte actuellement sélectionné. Vous pouvez modifier la position des sommets existants, ajouter des sommets ou en supprimer selon vos besoins. Vous pouvez définir des arcs reliant les sommets et exporter ou importer les informations des sommets dans un fichier au format CSV (via le menu contextuel).
-
Vertices Grid - Répertorie tous les sommets actuellement définis pour la région de carte selon les paramètres suivants :
- Index - Indice attribué au sommet (non modifiable).
- X - Coordonnée X (horizontale) du sommet. Cliquez pour la modifier.
- Y - Coordonnée Y (verticale) du sommet. Cliquez pour la modifier.
-
Arc Angle (Neg = CW) - Angle de l’arc tracé pour relier ce sommet au suivant. Par défaut, les liaisons sont des segments de droite et ce champ reste vide. Cliquez pour le modifier, puis saisissez l’angle d’arc souhaité. Une valeur positive produit un arc tracé dans le sens antihoraire. Pour tracer un arc dans le sens horaire, saisissez une valeur négative.
-
Add - Cliquez pour ajouter un sommet. Le nouveau sommet sera ajouté sous l’entrée du sommet actif et aura initialement les mêmes coordonnées X,Y que celle-ci. Cliquez sur
pour supprimer le sommet actuellement sélectionné.
Créer une région de carte à partir d’un corps 3D
Vous pouvez également créer des régions de carte à partir d’objets corps 3D à l’aide de la commande Create Board Region from 3D Body en mode 3D. La procédure est la suivante :
- Assurez-vous que la carte est affichée en 3D (sinon, utilisez le raccourci clavier 3 pour passer rapidement à ce mode).
- Choisissez la commande Design » Board Shape » Create Board Region from 3D body dans les menus principaux.
- Placez le curseur sur le modèle 3D à utiliser pour générer la région de carte du PCB, puis cliquez ou appuyez sur Enter. Le modèle devient transparent.
- Déplacez le curseur sur le modèle 3D pour repérer une face. Lorsqu’une surface plane est détectée sous le curseur, elle devient opaque et est entourée d’un fin liseré bleu.
- Une fois la face appropriée repérée, cliquez ou appuyez sur Enter : la nouvelle région de carte est créée (elle remplace la région de carte précédemment définie dans l’espace de conception).
- La boîte de dialogue Board Outline Creation Successful s’affiche pour confirmer la création. Elle vous permet de masquer la pièce du modèle et de l’exclure des contrôles DRC. Elle propose également des options permettant de modifier la hauteur du modèle pour aligner la face sur la surface supérieure ou inférieure, ou de conserver sa position.
Créer une région de découpe de carte
Pour créer une découpe interne dans la carte, placez une région de découpe de carte (Place » Define Board Cutout, ou cliquez sur le bouton
dans Active Bar). Une découpe de carte est également un objet polygonal ; sa procédure de placement est donc identique à celle de la région de carte. Les images ci-dessous montrent une région de carte comportant deux découpes, qui deviennent des ouvertures dans la carte lors de sa fabrication.
Une découpe placée sur une région de carte devient une ouverture dans la carte finie.
Scinder le contour de la carte en régions
Vous pouvez scinder une région de carte existante en deux régions. Cette opération s’effectue lorsque l’éditeur de PCB est en mode Board Planning Mode.
La carte a été divisée en trois régions de carte à l’aide de la commande Slice Region.
Pour diviser une région de carte :
- Sélectionnez View » Board Planning Mode (ou utilisez le raccourci 1) pour passer en Board Planning Mode.
-
Sélectionnez Design » Slice Board Region (ou cliquez sur le bouton
de la barre active) pour passer en mode Slice Board Region.
- Lorsque vous sélectionnez cette commande, vous passez en mode de découpe, qui est similaire au mode de placement des pistes. En commençant à l’extérieur de la région à diviser, cliquez pour placer une série de sommets définissant la ligne de découpe. Pendant la définition de la découpe, appuyez sur Shift+Spacebar pour faire défiler les modes d’angle ; appuyez sur Spacebar pour basculer entre les modes d’angle de début et de fin, et utilisez la touche Backspace pour supprimer le dernier angle placé. Placez l’extrémité de la ligne de découpe au-delà du bord de la région de carte. Une fois la découpe définie, faites un clic droit ou appuyez sur Esc pour terminer la commande.
-
Une boîte de dialogue de confirmation s’ouvre et indique le nombre de polygones (régions) divisés par votre action, ainsi que le nombre de polygones (régions) qui seront créés. Cliquez sur Yes pour confirmer leur création.
Création de régions de carte à partir d’objets sélectionnés
Selon la forme de votre carte, il peut être plus efficace de construire cette forme en créant plusieurs régions de carte. Comme indiqué ci-dessus, les régions peuvent être placées de manière interactive ou créées en suivant un contour défini par des objets de type piste et arc. La vidéo ci-dessous montre comment définir trois régions de carte à partir d’objets sélectionnés. Vous remarquerez dans la vidéo que le même objet est utilisé pour définir les bords adjacents là où les régions se touchent, ce qui garantit leur positionnement exact.
Une approche courante consiste à définir le contour des régions à l’aide de pistes et d’arcs, puis à créer les régions de carte à partir des contours sélectionnés.
Conversion entre primitives de dessin 2D et objets de définition de carte
Une approche courante pour définir la forme de la carte et les régions nécessaires à l’intérieur de celle-ci consiste à importer un dessin depuis un logiciel de CAO mécanique. Par exemple, vous pouvez importer des détails mécaniques à partir d’un fichier DWG afin d’obtenir un ensemble de lignes (pistes) sur une couche mécanique définissant la forme de la carte, les régions à l’intérieur de cette forme et, pour une conception rigide-flexible, l’emplacement des lignes de pliage dans les régions flexibles.
Le logiciel comprend plusieurs commandes permettant de créer des objets de définition de carte (région, découpe, ligne de pliage) à partir de primitives de dessin 2D, ainsi que des commandes complémentaires permettant de reconvertir ces objets en primitives de dessin.
Remarques :
- Les commandes de conversion dans les deux sens sont disponibles dans le sous-menu Tools » Convert du mode View correspondant (à l’exception de la commande Create Board Region from Selected Objects, qui se trouve dans le sous-menu Design » Board Shape).
-
Pour convertir des primitives de dessin 2D en objets de définition de carte, passez la vue en 2D Layout Mode.
- La ou les primitives doivent être sélectionnées avant d’exécuter la commande.
- Les primitives doivent former un contour fermé pour créer une région ou une découpe. Consultez l’encadré d’avertissement ci-dessous pour en savoir plus sur les exigences relatives à ce contour.
-
Pour convertir des objets de définition de carte en objets de dessin 2D, passez la vue en Board Planning Mode.
- Ces commandes ne nécessitent pas de présélectionner les objets, mais elles s’appliquent à l’objet sélectionné si une sélection existe déjà.
- Si plusieurs régions de carte sont présentes, la région disparaît lorsqu’elle est décomposée en primitives. S’il n’existe qu’une seule région de carte, les primitives sont créées et la région de carte choisie est conservée (il doit toujours exister au moins une région de carte).
- Les objets de dessin 2D sont créés sur la couche mécanique de type Board Shape. Si aucune couche de ce type n’existe sur la carte, une couche mécanique est ajoutée avec son type de couche défini sur Board Shape. Pour en savoir plus, consultez Couches mécaniques et types de couches.
- Bien qu’il n’existe pas de commande spécifique pour regrouper un objet décomposé, vous pouvez utiliser la commande Undo pour y parvenir.
Modification des régions de carte
Lorsque le PCB est configuré pour utiliser le mode rigide-flexible standard, la jonction entre deux régions adjacentes est définie par une ligne de séparation bleue déplaçable. Cette approche n’est pas utilisée en mode rigide-flexible avancé : chaque région est alors une forme polygonale fermée distincte. Chaque région peut donc être ajustée selon les besoins à l’aide des techniques standard de modification des formes polygonales. Notez que certaines commandes de modification des polygones ne sont pas disponibles pour modifier une région de carte, notamment les commandes d’ajout et de soustraction de polygones.
Points à retenir pour modifier un objet polygonal :
- Lorsque vous cliquez sur un sommet ou sur le bord d’un polygone et que vous le faites glisser, trois modes de modification de forme sont disponibles : glissement, cassure et incurvation. Appuyez sur Shift+Spacebar pour faire défiler ces modes pendant le déplacement. Le mode actif est indiqué dans la barre d’état et dans l’affichage tête haute.
- Le comportement d’accrochage du curseur est contrôlé par les paramètres d’accrochage actifs, notamment la grille d’accrochage actuelle, les objets disponibles pour l’accrochage, la présence de guides dans l’espace de travail et les paramètres d’accrochage aux axes. Utilisez ces fonctionnalités pour obtenir la forme souhaitée. Pour en savoir plus, consultez Comprendre le comportement d’accrochage.
Attribution d’un empilage de couches et modification du nom de la région de carte
Related page: Définition de l’empilage de couches
Lorsqu’une nouvelle carte est créée, elle comporte une seule région, nommée Default Layer Stack Region. L’empilage de couches par défaut nommé Board Layer Stack est attribué à cette région.
Lorsque vous divisez la forme d’une carte en plusieurs régions, l’empilage de couches par défaut est également attribué à chaque nouvelle région. Une fois les empilages de couches requis définis dans le gestionnaire d’empilage de couches, vous pouvez attribuer un empilage à chaque région et lui donner un nom explicite.
Pour attribuer un empilage de couches et nommer une région :
- Sélectionnez View » Board Planning Mode ou appuyez sur le raccourci 1 pour passer en Board Planning Mode.
- Cliquez sur l’onglet Multi-Layer en bas de l’espace de travail pour en faire la couche active (si l’onglet de couche n’est pas visible, appuyez sur L pour ouvrir le panneau View Configuration et l’activer).
- Double-cliquez sur la région de carte pour ouvrir la boîte de dialogue Board Region, ou cliquez une fois sur la région de carte et ouvrez le panneau Properties. Si la région ne se sélectionne pas et que la boîte de dialogue ne s’ouvre pas, assurez-vous que le filtre de sélection n’exclut pas les régions.
- Attribuez l’empilage de couches en sélectionnant l’empilage requis dans la liste déroulante Layer stack.
- Modifiez le Name selon vos besoins.

Le nom de la région de carte et l’empilage de couches qui lui est attribué s’affichent au centre géométrique de cette région. La mention (Flex) s’affiche également lorsque l’empilage attribué est configuré comme flexible.