Planification des zones rigides et flexibles - Mode avancé

En un coup d'œil

Cet article explique comment planifier et placer les régions rigides et flexibles d’un circuit imprimé dans Altium Designer en mode rigide-flexible avancé, avec une comparaison claire avec le mode standard pour comprendre dans quels cas ce flux de travail avancé est nécessaire. Il décrit comment les régions de la carte sont définies, comment identifier le mode rigide-flexible utilisé par un PCB, comment travailler en mode de planification de la carte, ainsi que comment placer, nommer et modifier précisément les régions et leur attribuer des empilages de couches. Il présente également les principaux comportements de placement, raccourcis et propriétés des régions à connaître pour concevoir des circuits rigides-flexibles plus complexes. Si vous recherchez un guide pratique pour configurer et gérer avec plus d’assurance les régions d’une carte rigide-flexible en mode avancé, poursuivez votre lecture.

- Vous découvrirez la différence entre le mode rigide-flexible standard et le mode rigide-flexible avancé, ainsi que son incidence sur la création et la définition des régions de la carte.
- Vous verrez comment placer et modifier les régions de la carte en mode de planification de la carte, notamment en leur attribuant des noms et des empilages de couches, et en utilisant les guides et l’accrochage pour gagner en précision.
- Vous découvrirez des raccourcis, des modes de placement et des paramètres de propriétés utiles pour travailler plus efficacement sur des conceptions de PCB rigides-flexibles complexes.
Approfondissez avec l'IA :

Le logiciel de conception de PCB d'Altium propose deux modes de conception rigide-flexible. Le mode d'origine, ou mode standard, appelé Rigide-flexible, prend en charge les conceptions rigides-flexibles simples. Si votre conception présente des exigences rigides-flexibles plus complexes, telles que des zones flexibles qui se chevauchent, vous devez utiliser le mode Rigide-flexible avancé (également appelé rigide-flexible 2.0). Le mode se choisit dans le menu Tools du Gestionnaire d'empilage de couches.

La différence fondamentale entre les modes est que, dans le mode d'origine, la forme de la carte est divisée en zones de carte distinctes en plaçant une ligne de séparation. Cette ligne reste un objet qui définit où une zone de carte se termine et où une autre commence. En mode avancé, chaque zone de carte est placée séparément ou, si une zone plus grande est découpée, elle devient deux objets de zone distincts. En mode avancé, ce sont les bords des zones de carte adjacentes qui définissent leur jonction, et non la présence d'une ligne de séparation. En raison de cette différence, aucun objet de type ligne de séparation n'existe lorsque la carte est en mode Rigide-flexible avancé.

► En savoir plus sur la conception d'un PCB rigide-flexible

Le menu View propose trois modes de travail de l'éditeur de PCB, avec des raccourcis faciles à mémoriser qui permettent de passer rapidement de l'un à l'autre :

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

Par défaut, le passage entre les modes d'affichage 2D et 3D conserve des réglages de zoom et d'orientation distincts pour chaque mode. Si vous souhaitez conserver la même position et la même orientation de la carte lors du changement de mode, appuyez sur Ctrl+Alt+2 ou Ctrl+Alt+3, au lieu de 2 ou 3.

Vous venez d'ouvrir un PCB et vous vous demandez s'il utilise le mode rigide-flexible standard ou avancé ?

Vous pouvez ouvrir le Gestionnaire d'empilage de couches pour le vérifier. Vous pouvez également passer en mode de planification de la carte (raccourci 1) et consulter la barre active :

Mode Rigide-flexible standard
Mode Rigide-flexible avancé

Placement d'une zone de carte

Une zone de carte est un objet polygonal qui se place à l'aide des techniques standard de placement des objets polygonaux. La forme de la carte doit être définie avec précision ; il est donc important que les zones qui la composent soient créées exactement selon les besoins. La vidéo ci-dessous montre comment créer des zones de carte en alignant leurs bords sur des guides préalablement placés dans l'espace de conception. L'avantage de cette technique est que la position des guides de l'espace de conception peut être définie avec précision en modifiant leurs coordonnées dans le panneau Properties.

Des guides prédéfinis dans l'espace de travail servent de références pour le placement des zones de carte.

Les zones de carte sont placées et modifiées dans Board Planning Mode :

  1. Sélectionnez View » Board Planning Mode (ou utilisez le raccourci 1) pour passer en Board Planning Mode. La zone de carte existante par défaut s'affiche sous la forme d'un rectangle vert.
  2. Sélectionnez Place » Board Region pour placer une nouvelle zone (ou cliquez sur le bouton de la Active Bar).
  3. Positionnez le curseur et cliquez pour ancrer le sommet de départ de la zone de carte. La zone de carte est un objet polygonal, comme une région ou un polygone, et suit la même procédure de placement (et de modification).
  4. Déplacez le curseur pour placer le deuxième sommet. Par défaut, chaque clic place deux bords avec, entre eux, un angle dont la forme est définie par l'utilisateur. Appuyez sur Spacebar pour inverser l'orientation de l'angle. Reportez-vous à la section Placement Modes ci-dessous pour plus de détails sur le changement des modes d'angle.
  5. Continuez à déplacer la souris et à cliquer pour placer des sommets et créer les bords nécessaires à la définition de la forme globale de la zone de carte.
  6. Après avoir placé le dernier sommet, faites un clic droit ou appuyez sur Esc pour fermer et terminer la définition de la forme de la carte. Il n'est pas nécessaire de fermer manuellement la forme de la carte, car le logiciel la complète automatiquement en reliant le dernier point placé au point de départ.
  7. Chaque zone de carte porte un nom qui permet de l'identifier de manière unique. Saisissez un nom approprié dans le champ Name du mode Zone de carte du panneau Propriétés (la zone de carte doit être sélectionnée dans l'espace de conception pour que ses propriétés s'affichent dans le panneau).
  8. Un empilage de couches doit être affecté à chaque zone de carte. Lorsqu'une nouvelle zone de carte est créée, l'empilage de couches par défaut, nommé Board Layer Stack, lui est affecté. Affectez l'empilage de couches requis dans le mode Board Region du panneau Properties. Les empilages de couches sont définis et nommés dans le Gestionnaire d'empilage de couches.
  9. Si le PCB final nécessite plusieurs zones de carte, poursuivez la définition de zones supplémentaires.
  • Chaque zone affiche une étiquette indiquant son nom et celui de l'empilage de couches qui lui est affecté, sous la forme Region Name - Layer Stack Name. La zone de carte est nommée dans le mode Board Region du panneau Properties, et l'empilage de couches est nommé dans le Gestionnaire d'empilage de couches.
  • Vous pouvez placer autant de zones de carte que nécessaire pour obtenir la forme de carte souhaitée. Les zones de carte peuvent se chevaucher. Notez que cela ne définit pas la distance de pénétration d'une zone dans la zone voisine ; celle-ci est définie dans le cadre de la configuration de l'empilage de couches, dans le Gestionnaire d'empilage de couches.
  • Une zone de carte est un objet polygonal. Pour modifier sa forme, cliquez une fois dessus pour la sélectionner, puis cliquez sur un bord ou une poignée de modification et faites glisser. En savoir plus sur la modification d'un objet polygonal. Notez qu'en mode avancé, comme les zones de carte sont modifiées de manière interactive, le menu Design ne comporte plus de commandes de modification en mode de planification de la carte.
  • Pour supprimer une zone de carte, sélectionnez-la, puis appuyez sur la touche Suppr du clavier. Il doit toujours rester au moins une zone de carte ; vous ne pouvez pas supprimer la dernière.
  • Outre le tracé, il est également possible de créer des zones de carte à partir de primitives : pour en savoir plus, consultez la section Conversion entre les primitives de dessin 2D et les objets de définition de carte de cette page.
  • Lors du placement ou de la modification d'une zone de carte, le curseur est contraint par les paramètres d'accrochage, qui comprennent la grille d'accrochage actuelle, les objets disponibles pour l'accrochage, la présence de guides dans l'espace de travail et les paramètres d'accrochage aux axes. Utilisez ces fonctions pour obtenir la forme souhaitée.

    ► En savoir plus sur le fonctionnement de l'accrochage.

Vous pouvez également appuyer sur la touche Tab pour suspendre le placement et accéder au mode Zone de carte du Properties panneau, où vous pouvez modifier ses propriétés à la volée. Cliquez sur le bouton de pause superposé dans l'espace de conception () pour reprendre le placement.

Placement Modes

Lors de la redéfinition de la forme de la carte, cinq modes d'angle sont disponibles, dont quatre proposent également des sous-modes d'orientation de l'angle. Pendant la redéfinition :

  • Appuyez sur Shift+Spacebar pour parcourir les cinq modes d'angle disponibles.
  • Appuyez sur Spacebar pour basculer entre les deux sous-modes d'orientation de l'angle.
  • Dans l'un ou l'autre des modes d'angle en arc, maintenez la touche  pour réduire l’arc ou sur la touche pour l’agrandir. Maintenez la touche Shift enfoncée pendant cette opération pour accélérer le redimensionnement de l’arc.
  • Appuyez sur la touche de raccourci 1 pour basculer entre le placement de deux segments par clic et celui d’un seul segment par clic. Dans le second mode, le segment en pointillés est appelé segment d’anticipation (comme illustré dans la dernière image de la série ci-dessous).
  • Appuyez sur la touche Backspace pour supprimer le dernier sommet.

Appuyez sur Shift+Spacebar pour parcourir les cinq modes de coin disponibles, puis sur la touche de raccourci 1 pour basculer entre le placement de deux segments et celui d’un seul segment. 
 
 
Appuyez sur Shift+Spacebar pour parcourir les cinq modes de coin disponibles, puis sur la touche de raccourci 1 pour basculer entre le placement de deux segments et celui d’un seul segment.

Créer une région de carte à partir d’un corps 3D

Vous pouvez également créer des régions de carte à partir d’objets corps 3D à l’aide de la commande Create Board Region from 3D Body en mode 3D. La procédure est la suivante :

  1. Assurez-vous que la carte est affichée en 3D (sinon, utilisez le raccourci clavier 3 pour passer rapidement à ce mode).
  2. Choisissez la commande Design » Board Shape » Create Board Region from 3D body dans les menus principaux.
  3. Placez le curseur sur le modèle 3D à utiliser pour générer la région de carte du PCB, puis cliquez ou appuyez sur Enter. Le modèle devient transparent.
  4. Déplacez le curseur sur le modèle 3D pour repérer une face. Lorsqu’une surface plane est détectée sous le curseur, elle devient opaque et est entourée d’un fin liseré bleu.
  5. Une fois la face appropriée repérée, cliquez ou appuyez sur Enter : la nouvelle région de carte est créée (elle remplace la région de carte précédemment définie dans l’espace de conception).
  6. La boîte de dialogue Board Outline Creation Successful s’affiche pour confirmer la création. Elle vous permet de masquer la pièce du modèle et de l’exclure des contrôles DRC. Elle propose également des options permettant de modifier la hauteur du modèle pour aligner la face sur la surface supérieure ou inférieure, ou de conserver sa position.
Le contour de carte de la face sélectionnée doit être aligné sur le PCB pour définir la région de carte. 

Créer une région de découpe de carte

Pour créer une découpe interne dans la carte, placez une région de découpe de carte (Place » Define Board Cutout, ou cliquez sur le bouton dans Active Bar). Une découpe de carte est également un objet polygonal ; sa procédure de placement est donc identique à celle de la région de carte. Les images ci-dessous montrent une région de carte comportant deux découpes, qui deviennent des ouvertures dans la carte lors de sa fabrication.

Une découpe placée sur une région de carte devient une ouverture dans la carte finie. Une découpe placée sur une région de carte devient une ouverture dans la carte finie.

Scinder le contour de la carte en régions

Vous pouvez scinder une région de carte existante en deux régions. Cette opération s’effectue lorsque l’éditeur de PCB est en mode Board Planning Mode.

La carte a été divisée en trois régions de carte à l’aide de la commande Slice Region.

Pour diviser une région de carte :

  1. Sélectionnez View » Board Planning Mode (ou utilisez le raccourci 1) pour passer en Board Planning Mode.
  2. Sélectionnez Design » Slice Board Region (ou cliquez sur le bouton  de la barre active) pour passer en mode Slice Board Region.
  3. Lorsque vous sélectionnez cette commande, vous passez en mode de découpe, qui est similaire au mode de placement des pistes. En commençant à l’extérieur de la région à diviser, cliquez pour placer une série de sommets définissant la ligne de découpe. Pendant la définition de la découpe, appuyez sur Shift+Spacebar pour faire défiler les modes d’angle ; appuyez sur Spacebar pour basculer entre les modes d’angle de début et de fin, et utilisez la touche Backspace pour supprimer le dernier angle placé. Placez l’extrémité de la ligne de découpe au-delà du bord de la région de carte. Une fois la découpe définie, faites un clic droit ou appuyez sur Esc pour terminer la commande.
  4. Une boîte de dialogue de confirmation s’ouvre et indique le nombre de polygones (régions) divisés par votre action, ainsi que le nombre de polygones (régions) qui seront créés. Cliquez sur Yes pour confirmer leur création.

Chaque nouvelle région créée peut hériter d’un ou de plusieurs composants contenus dans la région d’origine. Lorsque ces composants appartiennent à une classe de composants, une nouvelle classe est créée pour chaque nouvelle région et l’appartenance des composants est mise à jour en conséquence.

Création de régions de carte à partir d’objets sélectionnés

Selon la forme de votre carte, il peut être plus efficace de construire cette forme en créant plusieurs régions de carte. Comme indiqué ci-dessus, les régions peuvent être placées de manière interactive ou créées en suivant un contour défini par des objets de type piste et arc. La vidéo ci-dessous montre comment définir trois régions de carte à partir d’objets sélectionnés. Vous remarquerez dans la vidéo que le même objet est utilisé pour définir les bords adjacents là où les régions se touchent, ce qui garantit leur positionnement exact.

Une approche courante consiste à définir le contour des régions à l’aide de pistes et d’arcs, puis à créer les régions de carte à partir des contours sélectionnés.

Conversion entre primitives de dessin 2D et objets de définition de carte

Une approche courante pour définir la forme de la carte et les régions nécessaires à l’intérieur de celle-ci consiste à importer un dessin depuis un logiciel de CAO mécanique. Par exemple, vous pouvez importer des détails mécaniques à partir d’un fichier DWG afin d’obtenir un ensemble de lignes (pistes) sur une couche mécanique définissant la forme de la carte, les régions à l’intérieur de cette forme et, pour une conception rigide-flexible, l’emplacement des lignes de pliage dans les régions flexibles.

Le logiciel comprend plusieurs commandes permettant de créer des objets de définition de carte (région, découpe, ligne de pliage) à partir de primitives de dessin 2D, ainsi que des commandes complémentaires permettant de reconvertir ces objets en primitives de dessin.

Objet À partir de primitives de dessin 2D sélectionnées À partir d’objets de conception de carte
Région de carte Create Board Region from Selected Objects
(sous-menu Design » Board Shape)
Explode Region to Free Primitives
Découpe de carte Create Board Cutout from Selected Primitives Explode Board Cutout to Free Primitives
Ligne de pliage Convert Selected Line to Bend Line Explode Bend Line

Remarques :

  • Les commandes de conversion dans les deux sens sont disponibles dans le sous-menu Tools » Convert du mode View correspondant (à l’exception de la commande Create Board Region from Selected Objects, qui se trouve dans le sous-menu Design » Board Shape).
  • Pour convertir des primitives de dessin 2D en objets de définition de carte, passez la vue en 2D Layout Mode.
    • La ou les primitives doivent être sélectionnées avant d’exécuter la commande.
    • Les primitives doivent former un contour fermé pour créer une région ou une découpe. Consultez l’encadré d’avertissement ci-dessous pour en savoir plus sur les exigences relatives à ce contour.
  • Pour convertir des objets de définition de carte en objets de dessin 2D, passez la vue en Board Planning Mode.
    • Ces commandes ne nécessitent pas de présélectionner les objets, mais elles s’appliquent à l’objet sélectionné si une sélection existe déjà.
    • Si plusieurs régions de carte sont présentes, la région disparaît lorsqu’elle est décomposée en primitives. S’il n’existe qu’une seule région de carte, les primitives sont créées et la région de carte choisie est conservée (il doit toujours exister au moins une région de carte).
    • Les objets de dessin 2D sont créés sur la couche mécanique de type Board Shape. Si aucune couche de ce type n’existe sur la carte, une couche mécanique est ajoutée avec son type de couche défini sur Board Shape. Pour en savoir plus, consultez Couches mécaniques et types de couches.
    • Bien qu’il n’existe pas de commande spécifique pour regrouper un objet décomposé, vous pouvez utiliser la commande Undo pour y parvenir.
Toutes les commandes qui créent une forme polygonale à partir d’un contour constitué de lignes (pistes) et d’arcs tentent de déterminer la forme en suivant la ligne médiane des objets sélectionnés. Si les coordonnées de l’extrémité d’un segment de piste ou d’arc ne correspondent pas exactement à celles du segment suivant, l’algorithme d’identification du contour échoue et un message indique l’emplacement de l’échec. Le logiciel propose alors d’utiliser un algorithme de traçage à la place. Notez que cet algorithme suit le bord extérieur des objets de type piste ou arc : la forme obtenue sera donc légèrement différente de celle créée à partir des lignes médianes. Ne choisissez cette option que si votre conception peut tolérer les conséquences de cette différence.

Modification des régions de carte

Lorsque le PCB est configuré pour utiliser le mode rigide-flexible standard, la jonction entre deux régions adjacentes est définie par une ligne de séparation bleue déplaçable. Cette approche n’est pas utilisée en mode rigide-flexible avancé : chaque région est alors une forme polygonale fermée distincte. Chaque région peut donc être ajustée selon les besoins à l’aide des techniques standard de modification des formes polygonales. Notez que certaines commandes de modification des polygones ne sont pas disponibles pour modifier une région de carte, notamment les commandes d’ajout et de soustraction de polygones.

Si vous modifiez la forme d’une région de carte et qu’elle chevauche une région adjacente, le logiciel considère que la région ayant le plus grand nombre de couches est celle qui occupe la zone de chevauchement.

Points à retenir pour modifier un objet polygonal :

  • Lorsque vous cliquez sur un sommet ou sur le bord d’un polygone et que vous le faites glisser, trois modes de modification de forme sont disponibles : glissement, cassure et incurvation. Appuyez sur Shift+Spacebar pour faire défiler ces modes pendant le déplacement. Le mode actif est indiqué dans la barre d’état et dans l’affichage tête haute.
  • Le comportement d’accrochage du curseur est contrôlé par les paramètres d’accrochage actifs, notamment la grille d’accrochage actuelle, les objets disponibles pour l’accrochage, la présence de guides dans l’espace de travail et les paramètres d’accrochage aux axes. Utilisez ces fonctionnalités pour obtenir la forme souhaitée. Pour en savoir plus, consultez Comprendre le comportement d’accrochage.

Attribution d’un empilage de couches et modification du nom de la région de carte

Related page: Définition de l’empilage de couches

Lorsqu’une nouvelle carte est créée, elle comporte une seule région, nommée Default Layer Stack Region. L’empilage de couches par défaut nommé Board Layer Stack est attribué à cette région.

Lorsque vous divisez la forme d’une carte en plusieurs régions, l’empilage de couches par défaut est également attribué à chaque nouvelle région. Une fois les empilages de couches requis définis dans le gestionnaire d’empilage de couches, vous pouvez attribuer un empilage à chaque région et lui donner un nom explicite.

Chaque région affiche une étiquette indiquant son nom et celui de l’empilage de couches qui lui est attribué sous la forme Region Name - Layer Stack Name. Si l’empilage de couches sélectionné est configuré comme flexible, cela est également indiqué par (flex). L’activation du paramètre flexible pour un empilage s’effectue dans le Layer Stack Manager.

Pour attribuer un empilage de couches et nommer une région :

  1. Sélectionnez View » Board Planning Mode ou appuyez sur le raccourci 1 pour passer en Board Planning Mode.
  2. Cliquez sur l’onglet Multi-Layer en bas de l’espace de travail pour en faire la couche active (si l’onglet de couche n’est pas visible, appuyez sur L pour ouvrir le panneau View Configuration et l’activer).
  3. Double-cliquez sur la région de carte pour ouvrir la boîte de dialogue Board Region, ou cliquez une fois sur la région de carte et ouvrez le panneau Properties. Si la région ne se sélectionne pas et que la boîte de dialogue ne s’ouvre pas, assurez-vous que le filtre de sélection n’exclut pas les régions.
  4. Attribuez l’empilage de couches en sélectionnant l’empilage requis dans la liste déroulante Layer stack.
  5. Modifiez le Name selon vos besoins.

Le nom de la région de carte et l’empilage de couches qui lui est attribué s’affichent au centre géométrique de cette région. La mention (Flex) s’affiche également lorsque l’empilage attribué est configuré comme flexible.
Le nom de la région de carte et l’empilage de couches qui lui est attribué s’affichent au centre géométrique de cette région. La mention (Flex) s’affiche également lorsque l’empilage attribué est configuré comme flexible.

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents