Définition des lignes de pliage - Mode standard

En un coup d'œil

Cet article explique comment définir, placer, déplacer, supprimer et configurer les lignes de pliage des zones flexibles lorsque vous travaillez en mode rigide-flexible standard dans Altium Designer. Il précise également les différences entre les modes rigide-flexible standard et avancé, comment vérifier le mode utilisé par votre carte, ainsi que les vues de l’éditeur et les panneaux permettant de gérer les pliages avec précision. Vous souhaitez suivre une procédure pratique pour régler la position, l’angle et le rayon de pliage, la largeur de la zone affectée et l’ordre de pliage dans le mode approprié ? Ce guide vous aidera à travailler avec plus d’assurance. Poursuivez votre lecture et appliquez ces étapes à votre prochaine conception.

- Découvrez dans quels cas les lignes de pliage peuvent être utilisées en mode rigide-flexible standard et en quoi ce mode diffère du mode rigide-flexible avancé pour la définition des zones de la carte.
- Suivez les étapes précises pour placer, repositionner, supprimer et aligner avec précision les lignes de pliage en mode de planification de la carte.
- Découvrez les propriétés configurables des lignes de pliage, notamment l’angle et le rayon de pliage, la largeur de la zone affectée et l’ordre de pliage pour les vérifications du pliage en 3D.
Approfondissez avec l'IA :

Le logiciel de conception de PCB d'Altium propose deux modes de conception rigide-flexible. Le mode d'origine, ou mode standard, appelé Rigid-Flex, prend en charge les conceptions rigides-flexibles simples. Si votre conception présente des exigences rigides-flexibles plus complexes, telles que des zones flexibles qui se chevauchent, vous devez utiliser le mode Advanced Rigid-Flex (également appelé rigid-flex 2.0). Le mode se choisit dans le menu Tools du gestionnaire d'empilage des couches.

La différence fondamentale entre ces modes est que, dans le mode d'origine, la forme de la carte est divisée en zones distinctes par le placement d'une ligne de séparation. Cette ligne reste un objet qui définit la limite entre deux zones de la carte. Dans le mode avancé, chaque zone de la carte est placée séparément ; si une zone plus grande est découpée, elle devient deux objets de zone distincts. Dans le mode avancé, ce sont les bords des zones adjacentes qui définissent leur jonction, et non la présence d'une ligne de séparation. En raison de cette différence, aucun objet de ligne de séparation n'existe lorsque la carte est en mode Advanced Rigid-Flex.

► En savoir plus sur la conception d'un PCB rigide-flexible

Le menu View propose trois modes de travail de l'éditeur de PCB, avec des raccourcis faciles à mémoriser pour passer rapidement de l'un à l'autre :

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

Par défaut, lors du passage entre les modes d'affichage 2D et 3D, les paramètres de zoom et d'orientation sont conservés séparément pour chaque mode. Pour conserver le même emplacement et la même orientation de la carte lors du changement de mode, appuyez sur Ctrl+Alt+2 ou Ctrl+Alt+3, au lieu de 2 ou 3.

Vous venez d'ouvrir un PCB et vous vous demandez s'il utilise le mode rigide-flexible standard ou avancé ?

Vous pouvez ouvrir le gestionnaire d'empilage des couches pour le vérifier. Vous pouvez aussi passer en mode de planification de la carte (raccourci 1) et examiner la barre active :

Mode Rigid-Flex standard
Mode Advanced Rigid-Flex

Pour définir la manière dont une carte flexible doit se plier, placez une ou plusieurs lignes de pliage. La ligne de pliage définit l'emplacement du pli sur la surface de la zone flexible. Elle définit également l'angle et le rayon du pli, ainsi que la largeur de la bande de surface de la carte qui est pliée. Les lignes de pliage sont placées et modifiées dans l'éditeur de PCB en Board Planning Mode (View » Board Planning Mode, ou appuyez sur le raccourci 1).

Une ligne de pliage ne peut être placée que sur une zone configurée comme une zone Flex dans le Layer Stack Manager.


Une ligne de pliage est placée sur la zone flexible et configurée de manière à permettre à la carte de se plier à 180 degrés. Cette vidéo montre comment placer une ligne de pliage en mode Rigid-Flex standard.

Placement d'une ligne de pliage

Pour placer une ligne de pliage :

  1. Sélectionnez View » Board Planning Mode ou appuyez sur le raccourci 1 pour passer en Board Planning Mode.

  2. Les lignes de pliage sont placées sur la couche Multi-Layer. Si l'onglet Mutli-Layer n'est pas visible au bas de l'espace d'édition, activez la couche dans le panneau View Configuration (raccourci L pour afficher le panneau).

  3. Sélectionnez la commande Design » Define Bending Line.

  4. Cliquez à l'intérieur de la zone de la carte où la ligne de pliage doit être placée. Une extrémité de la ligne s'attache au bord de la zone le plus proche du point de clic, tandis que l'autre s'attache au curseur.

  5. Positionnez la seconde extrémité à l'emplacement souhaité, puis cliquez une fois pour la placer.

  6. Vous restez en mode de placement des lignes de pliage, prêt à en placer une autre si nécessaire. Sinon, faites un clic droit ou appuyez sur Esc pour quitter ce mode.

Le panneau PCB en mode Layer Stack Regions affiche les données Bending Lines. Double-cliquez sur une entrée pour ouvrir la boîte de dialogue Ligne de pliage. 

Trois lignes de pliage ont été placées sur cette zone flexible de la carte. La largeur de la bande orange correspond à la largeur de la zone affectée.
Trois lignes de pliage ont été placées sur cette zone flexible de la carte. La largeur de la bande orange correspond à la largeur de la zone affectée.

Lorsqu'une zone de la carte est configurée pour utiliser un empilage de couches flexible, une ligne de pliage est automatiquement ajoutée verticalement en passant par son centre géométrique. Supprimez cette ligne de pliage ou repositionnez-la et configurez-la selon vos besoins.

Déplacement d'une ligne de pliage

Pour modifier l'emplacement d'une ligne de pliage existante :

  1. Sélectionnez View » Board Planning Mode (ou appuyez sur le raccourci  1) pour passer en Board Planning Mode.
  2. Cliquez une fois pour sélectionner la zone de la carte qui contient la ligne de pliage. Les poignées de toutes les lignes de pliage de cette zone s'affichent.
  3. Pour déplacer l'extrémité d'une ligne, cliquez sur le nœud et maintenez le bouton enfoncé, puis faites-le glisser jusqu'à l'emplacement souhaité sur le périmètre du contour de la zone de la carte. Le curseur sera contraint par la grille d'accrochage actuelle et/ou les objets de conception existants.
  4. L'emplacement du pli sera redéfini par la nouvelle position de la ligne de pliage.

Sélectionnez et faites glisser un nœud d'extrémité d'une ligne de pliage pour modifier la position du pli sur la carte.
Sélectionnez et faites glisser un nœud d'extrémité d'une ligne de pliage pour modifier la position du pli sur la carte.

Positionnement précis d'une ligne de pliage

Lorsqu'une ligne de pliage est déplacée, sa poignée s'accroche aux points de la grille d'accrochage actuelle. Pendant le déplacement, elle peut également s'accrocher à des objets de conception existants, tels que des lignes sur une couche mécanique. L'image ci-dessous montre la poignée d'une ligne de pliage positionnée à l'extrémité d'une ligne sur la couche Mechanical 2 (repérée par le chiffre 1). Notez que la couche mécanique doit être la couche de conception active pour que l'accrochage fonctionne.

Le chiffre 1 désigne une poignée de ligne de pliage accrochée à une ligne sur Mechanical 2 ; notez que cette couche est la couche active.
Le chiffre 1 désigne une poignée de ligne de pliage accrochée à une ligne sur Mechanical 2 ; notez que cette couche est la couche active.

Pour illustrer plus en détail le processus ci-dessus, les images ci-dessous montrent les lignes de construction placées sur Mechanical 2 en 2D Layout Mode, qui définissent précisément des points de référence supérieur et inférieur permettant de placer une ligne de pliage à 45 degrés.

La carte en mode de conception 2D, avec les lignes de construction qui facilitent le placement précis des lignes de pliage diagonales.La carte en mode de conception 2D, avec les lignes de construction qui facilitent le placement précis des lignes de pliage diagonales.

La carte en mode de planification de la carte, avec les lignes de pliage diagonales accrochées aux lignes de construction sur Mechanical 2.La carte en mode de planification de la carte, avec les lignes de pliage diagonales accrochées aux lignes de construction sur Mechanical 2.

Suppression d'une ligne de pliage

Pour supprimer une ligne de pliage :

  1. Sélectionnez View » Board Planning Mode (ou appuyez sur le raccourci 1) pour passer en Board Planning Mode.
  2. Cliquez sur l'une de ses extrémités et maintenez le bouton enfoncé, puis appuyez sur la touche Delete. Vous pouvez également sélectionner et supprimer une entrée de ligne de pliage dans la section Bending Lines du panneau PCB.

Lorsqu'une zone de la carte est configurée pour utiliser un empilage de couches flexible, une ligne de pliage est automatiquement ajoutée verticalement en passant par son centre géométrique. Supprimez cette ligne de pliage ou repositionnez-la et configurez-la selon vos besoins.

Configuration des propriétés de la ligne de pliage

Les zones de la carte, les lignes de séparation et les lignes de pliage peuvent être examinées et modifiées en Board Planning Mode (appuyez sur 1). Les lignes de pliage peuvent être modifiées de manière interactive dans l'espace de conception ou via le PCB panneau lorsqu’il est réglé sur le mode Layer Stack Regions. Pour afficher le panneau, cliquez sur le bouton Panels en bas à droite d’Altium Designer, puis sélectionnez PCB dans le menu. Dans le panneau, sélectionnez Layer Stack Regions dans la liste déroulante située en haut du panneau. Dans ce mode, le panneau affiche :

  • Les empilages de couches disponibles pour la carte dans la zone Layer Stacks.
  • Les régions affectées à ces empilages dans la zone Stackup Regions.
  • Les lignes de pliage définies dans la région sélectionnée dans la zone Bending Lines.

Lorsque vous passez en Board Planning Mode, le panneau PCB est automatiquement configuré en mode Layer Stack Regions.

Pour modifier les propriétés d’une ligne de pliage dans le panneau PCB :

  1. Les lignes de pliage peuvent être modifiées en 2D Layout Mode (appuyez sur 2) ou en Board Planning Mode (appuyez sur 1).
  2. Cochez la case Select en haut du panneau.
  3. Sélectionnez la région de la carte qui contient la ligne de pliage dans la zone Stackup Regions du panneau PCB .
  4. Sélectionnez la ligne de pliage dans la liste de la zone Bending Lines du panneau. La ligne de pliage est mise en surbrillance (sélectionnée) sur la carte si l’option Select du panneau PCB est activée. Une entrée de ligne de pliage peut également être supprimée de la zone Bending Lines.
  5. Double-cliquez sur l’entrée de la ligne de pliage dans la zone Bending Lines pour ouvrir la boîte de dialogue Bending Line, comme illustré ci-dessous.

  6. Dans la boîte de dialogue Bending Line, modifiez deux des trois premières propriétés, par exemple Radius (la distance entre la surface de pliage et le centre de courbure) et Bending Angle (l’angle de pliage de la surface de la région flexible). La troisième propriété, Affected area width (la largeur de la surface qui sera pliée pour les valeurs données de Radius et de Bending Angle), est calculée automatiquement (voir les détails ci-dessous). Notez que la propriété Affected area width de chaque ligne de pliage est représentée par une zone ombrée orange.
  7. Dans la boîte de dialogue Bending Line, réglez Fold Index selon vos besoins pour définir l’ordre dans lequel les plis sont réalisés lorsque vous utilisez le curseur Fold State du panneau PCB ou la commande View » Fold/Unfold, qui permettent de plier la carte en mode 3D. Le pli ayant la valeur la plus faible est réalisé en premier, puis les suivants par ordre croissant de valeur.

La case 3D Locked doit être cochée pour l’une des régions de la carte dans la boîte de dialogue Board Region afin de définir le plan de référence physique du mode d’affichage 3D (où Z = 0). Sinon, Affected area width ne sera pas affiché pour chaque ligne de pliage définie.

La boîte de dialogue Bending Line est également accessible en appuyant sur Tab pendant le placement ou le déplacement d’une poignée de ligne de pliage, ou en double-cliquant sur une poignée de ligne de pliage.

Résumé de la définition des plis

Une ligne de pliage est un objet linéaire placé en travers d’une région pour définir l’emplacement, le rayon et l’angle du pli à appliquer à cette région flexible de la carte.

Définition d’une ligne de pliage :

  • Les lignes de pliage sont placées en mode de planification de la carte (raccourci 1).
  • Pour placer une ligne de pliage, exécutez la commande Design » Define Bending Line.
  • Placez la ligne de pliage en travers de la région flexible de la carte. Il n’est pas nécessaire que le début et la fin de la ligne de pliage touchent précisément chaque bord de la région : le logiciel la prolonge automatiquement (si elle est trop courte) ou la raccourcit (si elle est trop longue). Au moins une extrémité de la ligne de pliage doit toucher ou dépasser le bord de la région.
  • Pour modifier les propriétés d’une ligne de pliage, cliquez n’importe où dans la région afin d’afficher les sommets de toutes les lignes de pliage de cette région, puis :
    • Double-cliquez sur le sommet d’une ligne de pliage pour ouvrir la boîte de dialogue Ligne de pliage, ou
    • Affichez le panneau PCB et réglez-le sur le mode Layer Stack Regions, dans lequel vous pouvez examiner et modifier les régions et les lignes de pliage.
    • Réglez Bending Angle et Radius du pli selon vos besoins.
    • Les plis sont réalisés dans l’ordre de leur Fold Index ; utilisez cette fonctionnalité lorsqu’il est important de vérifier l’ordre de pliage.
  • Pour déplacer une ligne de pliage, cliquez sur chaque sommet et faites-le glisser.
  • Pour supprimer une ligne de pliage, cliquez sur l’un de ses sommets et maintenez le bouton de la souris enfoncé, puis appuyez sur Delete sur le clavier.
  • Les lignes de pliage ne peuvent pas être appliquées au bord d’une découpe de carte. Si votre carte le nécessite, passez en mode rigide-flexible avancé.
AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents