他の設計ツールとのインターフェイス

Altiumの設計ソフトウェアは、あなたが使用している、またはインターフェースする必要がある多くのエンジニアリング設計環境のうちの1つに過ぎないかもしれません。

電力シミュレーションを実行するために別の設計および分析プラットフォームにインターフェースする必要があるかもしれませんし、別の設計環境で開発された古い設計をインポートする必要があるかもしれません。理由は何であれ、いつか別の設計ツールにインターフェースする必要があるかもしれません。

インポートまたはエクスポートの実行

別の設計環境にインターフェースすることは、設計データの転送に関することです。これは、異なるファイル形式から/へ設計データを読み書きするか、またはソフトウェアAPIを介してデータを直接転送することによって行うことができます。

インポートアクションは、File » Importコマンドを介して実行されます。また、多くのインポーターはImport Wizardを介してアクセスできます。ウィザードを使用すると、設計ファイルとそのライブラリなどの関連ファイルをバッチでインポートできます。

エクスポート出力は、Outputjobファイルに必要な出力を追加し(Edit » Add Export Outputsサブメニューまたは[Add New Export Output]コントロールに関連するメニューから、メインジョブ設定ウィンドウのExport Outputs領域の下部で)、その後ファイルから出力を生成するか、プロジェクトリリースプロセスの一部として出力を生成することによって作成できます。または、適切なエディターのFile » Exportメニューを介してエクスポートアクションを実行します。

インポートウィザード

Import Wizard(File » Import Wizard)は、他のベンダーの設計ファイルをAltium Designerファイルに迅速かつ簡単に変換します。ウィザードはインポートプロセスを案内し、プロジェクトの回路図とPCBの両方、およびそれらの間の関係を管理します。

  • CancelをクリックしてImport Wizardを閉じます。

  • Backをクリックして前の画面に戻ります。

  • Nextをクリックして次の画面に進みます。

  • FinishをクリックしてImport Wizardを閉じます。このオプションはウィザードの最終ページでのみ利用可能です。

インポートするファイルの種類を選択

ウィザードのこのページを使用して、インポートしたいファイルの種類を選択します。Import Wizardを使用してインポートできる設計ファイルの種類の概要については、下のEDA設計ツールへのインターフェースセクションを参照してください。

さらにGet More Importersをクリックして、必要に応じて追加の拡張機能を追加できるExtensions and Updatesページを開きます。

ウィザードの後続のページは、選択したファイルタイプに応じて変わります。次のリストで目的のファイルタイプを見つけて、そのファイルタイプに関する情報にアクセスするためのリンクをクリックしてください。

EDA設計ツールへのインターフェース

以下の表は、EDA設計ツールと、それらがAltium Designerへのインポートおよび/またはエクスポートのためにサポートするファイル形式をまとめたものです。

名前 サポートされている形式 詳細を学ぶ
Protel® / Altium

インポート
以前のすべてのProtel/Altium回路図ファイル/ライブラリ
以前のすべてのProtel/Altium PCBファイル/ライブラリ
CircuitMaker(現行 - *.CMPcbDoc)、CircuitStudio(*.CSPcbDoc)、PCBWorks(*.PWPcbDoc, *.SWPcbDoc)PCBファイル
CircuitMaker 2000回路図(*.ckt)
CircuitMaker 2000ユーザーライブラリ(*.lib)
CircuitMaker 2000デバイスライブラリ(*.lib)
Protel 99SE設計データベース(*.ddb)
Protel DOS回路図(*.s??)
Tango PCB ASCIIファイル(*.pcb)
Autorax PCB(*.pcb)

エクスポート
CircuitMaker PCBファイル(*.CMPcbDoc)
CircuitStudio PCBファイル(*.CSPcbDoc)
Protel PCB 2.8 ASCII(*.pcb)

Altium Design Softwareインポート-エクスポートサポート

P-CAD®

インポート
P-CAD V16またはV17バイナリ回路図設計ファイル(*.sch)
P-CAD V16またはV17 ASCII回路図設計ファイル(*.sch)
P-CAD V15、V16、またはV17バイナリPCB設計ファイル(*.pcb)
P-CAD V15、V16、またはV17 ASCII PCB設計ファイル(*.pcb)
P-CAD V16またはV17バイナリライブラリファイル(*.lib)
P-CAD V16またはV17 ASCIIライブラリファイル(*.lia)
P-CAD PDIFファイル(*.pdf)

エクスポート
P-CAD V16回路図設計ファイル(*.sch)
P-CAD V16回路図ライブラリファイル(*.lia)
P-CAD ASCII PCB(*.pcb)
P-CAD V16 PCBライブラリファイル(*.lia)

Altium Design Softwareインポート-エクスポートサポート - P-CAD設計ファイルインポート-エクスポートサポート

Autodesk® EAGLE™

インポート(XML形式、バージョン6.4から9.4まで)
EAGLE回路図(*.sch)
EAGLE PCB(*.brd)
EAGLEライブラリ(*.lbr)

EAGLEからの設計のインポート

Cadence® Allegro® インポート (Allegroバージョン17.4まで;Allegroが必要です、インポート前提条件を確認してください)
AllegroバイナリPCB(*.brd)
Allegro ASCII PCB(*.alg)
Allegroフットプリント(*.dra)

Allegroからの設計のインポート

Cadence® OrCAD®

インポート(OrCADバージョン17.4まで)
OrCADキャプチャ設計(*.dsn)
OrCADキャプチャライブラリ(*.olb)
OrCADレイアウトPCBドキュメント(*.max)

OrCAD PCB Editor (*.brd) (Allegro インポーターが必要)
OrCAD PCB ライブラリ (*.llb)
OrCAD CIS 設定ファイル (*.dbc)  バイナリ形式で
OrCAD SDT (*.sch)
エクスポート
OrCAD SDT スキーマティック (*.sch)
OrCAD v7 キャプチャデザイン (*.dsn)

OrCAD キャプチャ スキーマティック ライブラリ (*.olb)

OrCAD からのデザインのインポート

OrCAD CIS からのデザインのインポート

OrCAD へのデザインのエクスポート

KiCad®

インポート (KiCad バージョン 8.x まで)
KiCad pro ファイル (*.pro)
KiCad kicad_pro ファイル (*.kicad_pro)
KiCad sch ファイル (*.sch)
KiCad kicad_sch ファイル (*.kicad_sch)
KiCad kicad_pcb ファイル (*.kicad_pcb)
KiCad lib ファイル (*.lib)
KiCad kicad_sym ファイル (*.kicad_sym)
KiCad kicad_mod ファイル (*.kicad_mod)

KiCad からのデザインのインポート

LTspice® インポート
LTspice ASC ファイル (*.asc)
LTspice ASY ファイル (*.asy)

LTspice からのデザインのインポート

Siemens EDA® DxDesigner® インポート (VX2.x まで)
DxDesigner デザインとライブラリ

xDX Designer または DxDesigner からのデザインのインポート

Siemens EDA® Xpedition™ インポート (VX2.x まで)
Xpedition ファイル (*.prj, *.pcb, *.lmc)

Xpedition からのデザインのインポート

Siemens EDA® PADS™

インポート (VX2.x まで)
PADS Layout ASCII デザインファイル (*.asc)
PADS Layout ASCII デカールライブラリ (*.d)
PADS Logic ASCII デザインファイル (*.txt)
PADS Logic ASCII CAE デカールライブラリ (*.c)
PADS Logic ASCII パートタイプライブラリ (*.p)

エクスポート
PADS Logic 5

PADS Logic および PADS Layout からのデザインのインポート

PADS Logic へのデザインのエクスポート

Siemens EDA® xDX Designer® インポート (EE7.9.4 まで)
xDX Designer デザイン (*.prj) とライブラリ

xDX Designer または DxDesigner からのデザインのインポート

Simbeor® エクスポート
Simbeor ファイル (*.esx)

レイヤースタックの定義 - レイヤースタックのエクスポート

Zuken® CADSTAR® インポート (2018 バージョンまで)
CADSTAR スキーマティックアーカイブ (*.csa)
CADSTAR PCB アーカイブ (*.cpa)
CADSTAR パートライブラリ (*.lib)

CADSTAR からのデザインのインポート

Zuken® CR-5000® インポート
Zuken CR-5000 PCF ファイル (*.pcf)
Zuken CR-5000 FTF ファイル (*.ftf)
Zuken CR-5000 EDS ファイル (*.eds)
Zuken CR-5000 EDF ファイル (*.edf)
Zuken CR-5000 LAF ファイル (*.laf)
Zuken CR-5000 SMB ファイル (*.smb)
Zuken CR-5000 PRF ファイル (*.prf)
Zuken CR-5000 CDFLAF ファイル (*.cdf)

CR-5000 からのデザインのインポート

ネットリストの作成

Altium Designer は、アクティブプロジェクトまたはアクティブソースドキュメント内のすべての関連ソースドキュメントから、指定された形式のネットリストを作成する機能をサポートしています。関連するインデックス付きコマンドは、スキーマティックエディターから、Design » Netlist For Project または Design » Netlist For Document サブメニューからアクセスできます。

ネットリスト出力は、指定されたデータソースで、アクティブな出力ジョブ設定ファイルにも追加できます。これは、Edit » Add Netlist Outputs サブメニューまたは、メインのジョブ設定ウィンドウの [Add New Netlist Output] コントロールに関連するメニューからコマンドを選択することで行えます。各サブメニューは特定のネットリスト形式に関連し、n、各ネットリスト形式サブメニュー上のエントリは特定のデータソース、mに関連します。

以下のネットリスト形式がサポートされています:

  • Cadnetix
  • Calay
  • EDIF for PCB
  • EESof
  • Intergraph
  • Mentor BoardStation
  • MultiWire
  • OrCad/PCB2
  • PADS
  • Pcad for PCB
  • PCAD
  • PCADnlt
  • Protel2
  • Protel
  • Racal
  • RINF
  • SciCards
  • Tango
  • Telesis
  • Wirelist
  • XSpice
ネットリスト形式を生成するためのコマンドエントリの大部分は、関連する機能が Altium Designer インストールの一部としてインストールされている場合にのみ、メニューで利用可能です。インストールに利用可能な機能を表示および変更するには、Extensions & Updates ビューにアクセスします(デザインスペースの右上にある  コントロールをクリックし、メニューから Extensions and Updates コマンドを選択)。Installed ページから、右上にある Configure コントロールをクリックして Configure Platform ページにアクセスします。上記で 赤 でリストされているネットリスターについては、Netlisters エントリが Importers\Exporters 領域で有効になっていることを確認してください。PADS ネットリスターについては、この領域の PADS エントリが有効になっていることを確認してください。XSpice ネットリスターについては、Mixed Simulation エントリが Platform Extensions 領域で有効になっていることを確認してください。必要な機能が有効になったら、Apply をクリックします。変更を有効にするには Altium Designer を再起動する必要があります。

ネットリストを作成するために選択した形式に応じて、コマンドを起動すると、直接ネットリストが生成されるか、または特定の形式関連オプションを定義できる中間ダイアログが表示されます。生成されたファイルは初期状態では閉じられています。

  • 出力ファイルは、Options for ProjectダイアログのOptionsタブにあるOutput Pathフィールドで指定された出力フォルダに書き込まれます。デフォルトでは、出力パスはプロジェクトファイルを含むフォルダのサブフォルダに設定され、名前はProject Outputs for <ProjectName>となります。出力パスは必要に応じて変更できます。プロジェクトパネルでは、ネットリストファイル(<ActiveDocumentName>.NET)がGenerated\Netlist Filesサブフォルダの下に表示されます。異なる形式のネットリストが同じアクティブドキュメントから生成された場合、以前に生成されたネットリストファイルは上書きされることに注意してください。

  • Use separate folder for each output typeオプションが有効になっている場合(Optionsタブでも)、出力はさらにサブフォルダに書き込まれ、そのフォルダは選択したネットリストの形式に応じて名付けられます(例:Project Outputs for <ProjectName>\<NetlistFormat> Output)。Projectsパネルでは、出力がGenerated (<NetlistFormat> Output)サブフォルダの下に表示されます。これにより、プロジェクトの同じアクティブドキュメントから複数のネットリストを生成しても、ファイルが上書きされることはありません。

他の設計ツールとのインターフェース

Altium Designerは、中立ファイル形式を使用して、他の設計ツール(MCAD、CAEなど)ともインターフェースできます。以下の表は、Altium Designerへのインポートおよび/またはエクスポートに対応する他のファイル形式をまとめたものです。

ECAD-MCAD CoDesign

対応するMCADパッケージについては、CoDesigner、AltiumのECADからMCADへの接続技術を使用して、基板とコンポーネントをMCADとECAD間で直接転送することも可能です。接続されたワークスペース、例えばAltium 365ワークスペースを通じて、CoDesignerは基板の形状と配置されたコンポーネントをMCADソフトウェアとAltium Designerの間で行き来させることができます。

Altium CoDesignerを使用した直接のECAD-MCAD設計についてもっと学ぶ

名前 対応する形式 詳細を学ぶ
Ansoft™ エクスポート (バージョン4.0まで)
Ansoft™/ANSYS ® ニュートラルファイル (*.anf)

Ansoftニュートラル形式への設計のエクスポート

Ansys® エクスポート
EDBファイル (*.def)

Ansys EDB形式への設計のエクスポート

AutoCAD® インポート/エクスポート (2018年版まで)
DXFファイル (*.dxf)
DWGファイル (*.dwg)

AutoCAD-DXF インポート-エクスポート サポート

HyperLynx™ エクスポート
HyperLynxファイル (*.hyp)

HyperLynx形式への設計のエクスポート

IDF インポート/エクスポート
IDFボードファイル (*.brd, *.bdf, *.idb, *.enm, *.idf)

機械データのインポート-エクスポート サポート - IDFファイルのインポート-エクスポート サポート

IDX インポート/エクスポート
インクリメンタルデザイン交換形式ファイル (*.idx)

機械データのインポート-エクスポート サポート - IDXファイルのインポート-エクスポート サポート

MathWorks® エクスポート
カンマ区切り値ファイル (*.csv)
MathWorks CSV形式への設計のエクスポート
Parasolid

インポート
Parasolidテキストファイル (*.x_t)

エクスポート
Parasolidテキストファイル (*.x_t)
Parasolidバイナリファイル (*.x_b)

機械データのインポート-エクスポート サポート - Parasolidファイルのインポート-エクスポート サポート

SolidWorks® インポート
SolidWorksパートファイル (*.sldprt)

機械データのインポート-エクスポート サポート - SolidWorksパートファイルのインポート サポート

Specctra®

インポート
Specctra設計ファイル (*.dsn)
Specctraルートファイル (*.rte)

エクスポート
Specctra設計ファイル (*.dsn)

Specctra互換ルーターのためのPCB準備の確認

STEP インポート/エクスポート
STEP形式ファイル (*.step, *.stp)

機械データのインポート-エクスポート サポート - STEPファイルのインポート-エクスポート サポート

VRML エクスポート
VRMLファイル (*.wrl)

機械データのインポート-エクスポート サポート - VRMLファイルのエクスポート サポート

ほとんどのインポーターとエクスポーターはAltium Designerの拡張機能として提供され、特定のファイルタイプのインポート/エクスポートコマンドは、その拡張機能がインストールされている場合にのみ表示されます。特定のインポーター/エクスポーターのページを参照して、必要な拡張機能について詳しく学んでください。

Altium自身または第三者によって開発されたソフトウェア拡張機能がいくつかあり、Altium Designerの機能と機能性をある程度拡張します。これらの拡張機能には以下のものが含まれます:

  • JTAG Maps – 無料のJTAG Maps™拡張機能は、ハードウェアエンジニアが自分の設計でバウンダリスキャンテストの使用可能性を評価し、JTAGテストデータを事前に準備するのに役立ちます。JTAG Live®ウェブサイトから拡張機能をダウンロードしてください。

  • XJTAG DFT Assistant x64 – 無料のXJTAG® DFT Assistant拡張機能は、ボードデザイナーが設計プロセス全体を通じてPCBのテスタビリティを評価および改善することを可能にします。

  • MTBFおよび信頼性ツールキット – BQR fiXtress™を使用して、高価な再スピンや物理的なプロトタイプなしに信頼性の高い電子システムを設計するのに役立ちます。BQR®ウェブサイトから拡張機能をダウンロードしてください。

► Altium Productsエリアで利用可能な設計拡張機能についてもっと学ぶ。

ヘルプの入手

Altiumソフトウェアでの設計が初めてで、このページを読んでいる場合は、始めるのに役立ついくつかのヒントがあります:

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Content