メカニカルレイヤーの操作

Altium Training

Altium Essentials: PCB Configuration

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

概略

この記事では、Altium Designerのメカニカルレイヤーが、配線やパッドだけでは表せない重要な基板設計情報をどのように扱うかを解説します。これには、基板外形、製造注記、部品のコートヤード、寸法、3Dモデルなどが含まれます。個別のメカニカルレイヤーとコンポーネントレイヤーペアの違い、それぞれの使いどころ、View Configurationパネルでの追加・管理方法を順に説明します。また、使用可能なレイヤータイプの概要と、PCBライブラリや配置済み部品を扱う際に、Altium Designerがレイヤーの作成とマッピングをどのように処理するかも紹介します。PCB設計のワークフローにおいて、こうした重要な非電気的設計情報を整理・管理する方法を、ぜひ読み進めてご確認ください。

- 特に基板の片面または両面に適用される情報について、単一のメカニカルレイヤーとコンポーネントレイヤーペアをどのように使い分けるかを学びます。
- View Configurationパネルでメカニカルレイヤーを追加、設定、管理する方法を、名前、番号、表示状態、レイヤータイプの設定も含めて確認します。
- 定義済みのレイヤータイプとPCBライブラリの設定が、基板設計におけるレイヤーの自動作成とマッピングにどのような影響を与えるかを理解します。
AIでさらに深掘り:

最もシンプルな基板でも、回路を構成する配線やパッド以外に設計上の詳細情報が必要です。基板寸法や製造に関する詳細、部品のコートヤード、あるいは部品の3Dモデルなどが該当します。Altium Designerでは、このような追加情報をメカニカルレイヤーに記載します。

メカニカルレイヤーとコンポーネントレイヤーペア

メカニカルレイヤーに含める情報が基板の特定の面に関連しない場合、たとえばレイヤーの順序を詳述する製造注記の場合は、individual mechanical layerを追加します。

基板の両面に情報が必要な場合、たとえば部品のコートヤードの場合は、2つのメカニカルレイヤーを割り当てます。 一方のレイヤーには、部品を基板の上面に配置したときのコートヤードの詳細を保持し、 もう一方のメカニカルレイヤーには、部品を基板の下面に反転したときの同じコートヤードの詳細を鏡像として保持します。 この場合、メカニカルレイヤーのペアをComponent Layer Pairとして追加します。メカニカルレイヤーをコンポーネントレイヤーペアとして追加すると、下図のように、View ConfigurationパネルのComponent Layer Pairsセクションに表示されます。その下には、個別のMechanical Layersが表示されます。

ユーザー定義のコンポーネントレイヤーペアが複数追加されています。
ユーザー定義のコンポーネントレイヤーペアが複数追加されています。

Display of Layer Pairs

設計スペースでは、コンポーネントレイヤーペアの2つのレイヤーが、Top <LayerPairName>とBottom <LayerPairName>()という名前で、それぞれ別のレイヤータブに表示されます。

In the Library editor PCBライブラリエディターでは、部品フットプリントに必要な追加の設計オブジェクトを、コンポーネントレイヤーペアの上面レイヤーに配置します。PCBレイアウト中に部品を基板の下面に反転すると(部品の移動中にLのショートカットを使用)、ペアの上面レイヤーの内容が自動的に鏡像化され、ペアの下面レイヤーに移されます。
Automatic layer creation PCBライブラリで定義されたメカニカルレイヤーまたはコンポーネントレイヤーペアにレイヤータイプが割り当てられている場合、そのレイヤーを使用する部品を配置すると、そのメカニカルレイヤー/レイヤーペアがPCB上に自動的に作成されます。同じレイヤータイプのメカニカルレイヤー/レイヤーペアがPCBにすでに存在する場合は、各レイヤーの内容が対応するレイヤーにマッピングされます。
Layers without
a Layer Type
PCBライブラリで定義されたメカニカルレイヤー/レイヤーペアに、ライブラリ内でレイヤータイプが割り当てられていない場合、PCB上には個別のメカニカルレイヤーが作成されます。この場合は、部品を配置する前に、同じレイヤー番号を使用してPCB内にメカニカルレイヤー/レイヤーペアを定義しておいてください。ソフトウェアは、レイヤータイプで一致させられない場合、レイヤー番号による照合を行います。

設計へのメカニカルレイヤーの追加

メカニカルレイヤーの追加、編集、削除は、下図のようにView Configurationパネルで行います。表示/非表示と色も、このパネルで設定します。設計スペースの右下にあるボタンをクリックしてView Configurationを選択するか、Lショートカットキーを押すと、パネルが表示されます。

パネルのLayers領域内で右クリックするとコンテキストメニューが表示され、Add Component Layer Pair(メカニカルレイヤーのペア)とAdd Mechanical Layer(個別のメカニカルレイヤー)のコマンドを使用できます。

個別のメカニカルレイヤーまたはメカニカルレイヤーのペアは、View Configurationパネルの右クリックメニューから追加します。個別のメカニカルレイヤーまたはメカニカルレイヤーのペアは、View Configurationパネルの右クリックメニューから追加します。

  • メカニカルレイヤー/レイヤーペアは、View Configurationパネルで名前順または番号順に並べ替えられます。この設定は、PreferencesダイアログのPCB Editor – General page()で行います。

  • ビアのプロパティでビアタイプをIPC-4761に設定すると、新しいタイプのメカニカルレイヤー(Capping、Filling)とコンポーネントレイヤーペア(Covering、Plugging、Tenting)が設計に自動的に追加され、これらのレイヤー上に対応する形状が配置されます。これらのレイヤーの項目は、View Configurationパネルに表示されます。これらのレイヤーでは、名前とタイプは変更できず、番号のみ変更できます。 

  • 追加できるメカニカルレイヤーの数に制限はありません。 AltiumのPCB設計ソフトウェアの旧バージョンではメカニカルレイヤーが32層に制限されていますが、32層を超えるレイヤーを含む新しいPCBファイルでも、旧バージョンのソフトウェアで安全に開いて編集できます。

個別のメカニカルレイヤーの追加

個別のメカニカルレイヤーを追加するために、View Configurationパネルの右クリックコンテキストメニューからAdd Mechanical Layerコマンドを選択すると、Edit Layerダイアログが開きます。 

新しいメカニカルレイヤーを設定します。新しいメカニカルレイヤーを設定します。

Edit Layerダイアログ

Layer Name レイヤー名にはユーザー定義の名前を指定できます。また、Layer Typeドロップダウンで定義済みのタイプを選択すると、システムによって名前が割り当てられます。定義済みのレイヤータイプを選択した後に、このフィールドにユーザー定義の名前を入力すると、View Configurationパネルでは、ユーザー定義の名前の横に、割り当てられたレイヤータイプが括弧付きで表示されます。
Layer Number 設定対象のメカニカルレイヤーの番号です。使用可能な次のレイヤー番号が提示されます。別の番号を選択し、その番号がすでに使用されている場合は、警告アイコンが表示されます()。続行するには、未使用のレイヤー番号を割り当てる必要があります。
Layer Type レイヤータイプは未割り当て(N/A)にすることも、リストから選択することもできます。使用可能なレイヤータイプについては、以下で説明します。

コンポーネントレイヤーペアの追加

View Configurationパネルの右クリックコンテキストメニューからAdd Component Layer Pairコマンドを選択すると、Edit Layers Pairダイアログが開きます。 

Edit Layers Pair ダイアログ

Layer Name ユーザー定義のレイヤー名を指定できます。また、Layer Typeドロップダウンで定義済みのタイプを選択すると、システムによって名前が割り当てられます。定義済みのレイヤータイプを選択した後にこのフィールドにユーザー定義の名前を入力すると、View Configurationパネルでは、ユーザー定義の名前の横に、割り当てられたレイヤータイプが括弧付きで表示されます。
Layer Number 設定するメカニカルレイヤーの番号です。使用可能な次のレイヤー番号が提示されます。別の番号を選択し、その番号がすでに使用されている場合は、警告アイコンが表示されます()。続行するには、未使用のレイヤー番号を割り当てる必要があります。
Layer Type レイヤータイプは未割り当て(N/A)にすることも、リストから選択することもできます。使用可能なレイヤータイプについては、以下で説明します。

Draftsmanでは、PCBエディターのAssemblyコンポーネントレイヤーペアで定義された形状に基づいて、基板実装ビュー内の各コンポーネントの外形を定義できます。また、デジグネーターペアなど、任意のメカニカルレイヤーペアやコンポーネントレイヤーペアを基板実装ビューに含めることもできます。これらの設定は、基板実装ビューを選択した状態で、DraftsmanのPropertiesパネルで行います。Draftsmanの詳細をご覧ください。

レイヤータイプを割り当てる利点

メカニカルレイヤーの使用を管理する一般的な方法は、必要なメカニカルレイヤーの機能ごとに専用のレイヤー番号を割り当てることです。この方法では、すべての設計者が同じレイヤーの割り当てと番号付けのルールに従う必要があります。また、同じ割り当てと番号付けのルールに従っていない外部ソースからコンポーネントを入手した場合、問題が生じることがあります。異なるルールが使用されている場合は、設計オブジェクトを現在のメカニカルレイヤーから、その機能に割り当てられたメカニカルレイヤーに移動する必要があります。

この問題は、Layer Typeプロパティを割り当てることで解決します。ライブラリからPCBエディターにコンポーネントを配置する場合、あるライブラリから別のライブラリにコピーする場合、またはIPC Footprint Wizardで作成する場合、各レイヤータイプに割り当てられているメカニカルレイヤー番号に関係なく、既存のレイヤータイプの割り当てが自動的に照合されます。オブジェクトは、レイヤータイプに応じて適切なレイヤーに移動されます。レイヤータイプによる照合ができない場合は、レイヤー番号による照合が行われます。

個別のメカニカルレイヤーとコンポーネントレイヤーペアのどちらについても、定義済みのタイプのリストからレイヤータイプを選択できます。以下の画像は、使用可能なレイヤータイプのリストを示しています。個別のレイヤーを右クリックし、メニューからEdit LayerまたはAdd Component Layerコマンドを選択すると、以下のダイアログにアクセスできます。

定義済みのタイプのリストからレイヤータイプを選択します。左側に個別のメカニカルレイヤー、右側にコンポーネントレイヤーペアを示しています。
定義済みのタイプのリストからレイヤータイプを選択します。左側に個別のメカニカルレイヤー、右側にコンポーネントレイヤーペアを示しています。

レイヤータイプが割り当てられたレイヤーの命名

レイヤータイプを割り当てると、レイヤーのレイヤー名プロパティが自動的にレイヤータイプと同じ名前に変更されます。必要に応じて、ユーザー定義の名前を入力して上書きできます。レイヤーにユーザー定義の名前とレイヤータイプが割り当てられている場合は、以下のレイヤーペアGP (Gold Plating)の例のように、両方が表示され、レイヤータイプは括弧付きで表示されます。

レイヤータイプがレイヤー名として使用されますが、必要に応じて上書きできます。レイヤータイプがレイヤー名として使用されますが、必要に応じて上書きできます。

Route Tool Pathレイヤータイプ

レイヤータイプを割り当てた際の、上述の命名動作には例外が1つあります。Layer TypeがRoute Tool Pathに設定されている場合、ユーザー定義の名前は使用できません。これは、旧バージョンのソフトウェアがRoute Tool Pathレイヤーの名前を使用して、ルーター加工情報(rout情報とも呼ばれます)を含むレイヤーを識別するためです。このレイヤーの名前を固定することで、旧バージョンでも設計が引き続き正しく機能するようにしています。

Route Tool Pathレイヤータイプは、機械的なルーター加工情報を含むレイヤーを示すために使用します。このレイヤーの一般的な使用方法は、基板形状の外周に沿ってトラックと円弧を配置し、加工経路と加工幅を定義することです。基板をパネル内に保持するために切削しない部分を残し、その各部分に小さな穴を連続して配置してミシン目(一般にマウスバイトと呼ばれます)を形成します。これにより、実装工程の完了後に基板をパネルから折り取ることができます。

基板を3Dモードで表示すると、Route Tool Pathレイヤー上で検出されたオブジェクトは、以下に示すように、基板のルーター加工されたスロットとして表示されます。

Route Tool Pathレイヤー上で検出されたオブジェクトは、3D表示モードでルーター加工後の基板を可視化するために使用されます。
Route Tool Pathレイヤー上で検出されたオブジェクトは、3D表示モードでルーター加工後の基板を可視化するために使用されます。

Line/Arc Primitives from Board Shapeダイアログを使用して、トラックとアークで基板形状の外周をトレースします(下図参照)。ダイアログでRoute Tool Outlineオプションを有効にすると、オブジェクトは基板形状のエッジを中心に配置されるのではなく、基板形状の外側に配置されます。製造情報を実際の基板ファイルに含めず、Embedded Board Array機能を使用して実装パネルを作成する際に追加する設計者もいます。

詳細はこちら:Embedded Board Arrayを使用した基板のパネル化

PCBライブラリエディターでのレイヤータイプの定義

PCBライブラリで定義されたメカニカルレイヤーまたはコンポーネントレイヤーペアにレイヤータイプが割り当てられている場合、それらのレイヤーを使用するコンポーネントを配置すると、そのメカニカルレイヤー/レイヤーペアがPCB上に自動的に作成されます。そのレイヤータイプのメカニカルレイヤー/レイヤーペアがPCBにすでに存在する場合は、各レイヤーの内容が対応するレイヤーにマッピングされます。

可能な場合は、元のライブラリを編集してレイヤータイプを割り当てることをお勧めします。ライブラリからコンポーネントフットプリントを配置(またはコピー)すると、それらのレイヤータイプのメカニカルレイヤーおよびコンポーネントレイヤーペアが、配置先の基板(またはライブラリ)に存在しなければ自動的に作成されます。それらのレイヤータイプが配置先の基板(またはライブラリ)にすでに存在する場合は、レイヤーの内容が適切なレイヤーに自動的にマッピングされます。

レイヤータイプが割り当てられたユーザーレイヤーは、コンポーネントを基板に配置すると自動的に作成またはマッピングされます。

基板に配置されたコンポーネント。

 

PCBライブラリで定義されたメカニカルレイヤー/レイヤーペアに、ライブラリ内でレイヤータイプが割り当てられていない場合は、個別のメカニカルレイヤーがPCB上に作成されます。この場合、コンポーネントを配置する前に、同じレイヤー番号を使用してPCBにメカニカルレイヤー/レイヤーペアを定義しておいてください。ソフトウェアはレイヤータイプで照合できない場合、レイヤー番号による照合を行うためです。

詳細はこちら: PCBライブラリエディターでのレイヤー固有の特殊要件への対応

メカニカルレイヤーの操作

メカニカルレイヤーの追加、編集、削除、表示は、PCBエディターのView Configurationパネルで行います。Layer Stack Managerでは表示や編集はできません。

表示

View Configurationパネルでレイヤーの表示/非表示を設定し、よく使用するレイヤーの組み合わせをユーザー定義のレイヤーセットとして保存します。View Configurationパネルでレイヤーの表示/非表示を設定し、よく使用するレイヤーの組み合わせをユーザー定義のレイヤーセットとして保存します。

Controlling layer visibility レイヤー名の横にある表示アイコン()をクリックすると、そのメカニカルレイヤーの表示/非表示を切り替えられます。または、レイヤー名をクリックして選択し、Spacebarを押します(コンポーネントレイヤーペアの両方のレイヤーの表示が切り替わります)。
Include in Single Layer Mode

メカニカルレイヤーには、単一レイヤーモードでも表示を維持する追加の表示機能があります。Ctrlを押しながらメカニカルレイヤーの表示アイコンをクリックすると、Display in Single Layer Mode機能が有効になります。表示アイコンが変わり、このレイヤーで機能が有効になっていることを示します()。 Ctrl+Clickもう一度操作すると、このモードが無効になります。

単一レイヤーモードは、アクティブな(現在の)レイヤー以外のすべてのレイヤーを非表示にする便利な表示制御機能です。デザインスペースでShift+Sを押すと、有効な単一レイヤーモードが順に切り替わります。単一レイヤーモードでは、非アクティブなレイヤーを完全に非表示にしたり、グレー表示またはモノクロ表示にしたりできます。詳細はこちら:単一レイヤーモード。

Include in 3D View Mode

3D設定でColors - By Layerオプションを有効にすると、メカニカルレイヤーを3D表示に含めることもできます。基板を3Dビューモードで表示しているときに、View ConfigurationパネルのView Optionsタブでこのオプションを有効にします。現在表示するように設定されているメカニカルレイヤーが含まれます()。

編集スペースに表示する内容を制御するには、レイヤーの表示/非表示を頻繁に切り替える必要があります。この作業に非常に役立つのが、独自のレイヤーセットを定義する機能です。編集スペース下部のボタンを使用して、レイヤーセットをすばやく切り替えられます。

詳細はこちら:レイヤーセット

編集と削除

既存のコンポーネントレイヤーペアまたはメカニカルレイヤーの設定を編集するには、View Configurationパネル内の該当項目を直接ダブルクリックします(または、目的の項目を右クリックし、コンテキストメニューからEdit Layerを選択します)。Edit Layers Pair/Edit Layerダイアログで必要な変更を行います。メカニカルレイヤーの表示/非表示と色は、View Configurationパネルで直接設定します。

レイヤーを削除するには、目的のレイヤーを右クリックしてDelete Layerを選択します。レイヤーの使用状況に応じて、次の3つの結果のいずれかになります。

Nothing on the layer レイヤー上にプリミティブが配置されていない場合、Delete Layerを選択すると、確認なしで直ちに削除されます。
Contains unlocked primitives レイヤー上にロックされていないプリミティブがある場合、削除の確認を求めるポップアップが表示されます。
Contains locked primitives レイヤー上にロックされたプリミティブがある場合(たとえば、コンポーネントに属するプリミティブが含まれている場合)、操作を完了できないことを知らせるエラーポップアップが表示されます。

エクスポートとインポート

PCBに追加されたメカニカルレイヤーとコンポーネントレイヤーペアの構成は、元のPCBドキュメントからファイルにエクスポートし、そのファイルを別のPCBドキュメントにインポートすることで複製できます。

レイヤーのエクスポート/インポート

  • 必要なメカニカルレイヤーとコンポーネントレイヤーペアの構成が追加されている元のPCBドキュメントで、メインメニューからTools » Export Mechanical Layersコマンドを実行します。開いたExport Mechanical Layersダイアログで、メカニカルレイヤーの構成データを保存する*.stackupファイルの名前と保存先ディレクトリを指定します。

  • インポート先のPCBドキュメントで、メインメニューからTools » Import Mechanical Layersコマンドを実行し、開いたImport Mechanical Layersダイアログで保存済みの*.stackupファイルを選択します。追加されたメカニカルレイヤーとコンポーネントレイヤーペアの構成は、View Configurationパネルで確認できます。

レイヤー内容のコピー/貼り付け

インポート/エクスポートコマンドで転送されるのは、メカニカルレイヤーとコンポーネントレイヤーペアの構成のみであり、それらのレイヤーの内容は転送されないことに注意してください。

内容をコピーするには:

  • 単一のメカニカルレイヤーの場合、元のPCBで対象のレイヤーがアクティブな状態でEdit » Select » All on Layerコマンドを使用し、その後、通常のコピー/貼り付け操作でそのデータをコピー先のPCBに複製します。

  • 複数のメカニカルレイヤーの場合は、View Configuration パネルでレイヤーの表示を設定し、必要なメカニカルレイヤーだけを表示します。次に、コピー元のPCBで必要なすべてのプリミティブを囲むように、接触したオブジェクトを選択する矩形を右から左へドラッグし、通常のコピー/貼り付け操作でそのデータをコピー先のPCBに複製します。

コピー先のPCBに貼り付ける際、アクティブレイヤーは関係ありません。プリミティブは、コピー元と同じレイヤーに自動的に貼り付けられます。

表示と出力の設定

メカニカルレイヤーは、印刷物や生成される製造用出力に含める必要がある情報を記載するためによく使用されます。これには、図面テンプレート、製造指示、組立指示などが含まれます。必要に応じて、これらをPCBエディターで直接作成できます。

必要に応じて、基板製造ドキュメントの情報をメカニカルレイヤーに含めることができます。必要に応じて、基板製造ドキュメントの情報をメカニカルレイヤーに含めることができます。

また、これらのドキュメント作成作業は、基板設計の製造用ドキュメントを作成するための高度で柔軟なグラフィカル編集環境であるDraftsmanでも行えます。専用の描画ツール一式を備えたDraftsmanの図面作成システムでは、製造図面や組立図面に、カスタムテンプレート、注釈、寸法、引き出し線付き注記、備考を対話的に組み合わせることができます。

詳しくは Draftsman

シートの表示と設定

上の画像には、シートテンプレートを表すために配置された描画オブジェクトにぴったり合う白い背景が表示されています。これは、Layer Type を Sheet に設定したメカニカルレイヤーを追加し、そのレイヤーでドキュメントの図面テンプレートの外枠を定義することで作成されます。

この白い背景のサイズは Sheet Settings によって定義されます。 これは、編集領域で何も選択されていないときに、 Properties パネルでカスタマイズできます。シート左下隅の X/Y の値、および Width と Height は手動で設定できます。また、Get Size From Sheet Layer オプションを有効にすると、シートの背景は、レイヤータイプが Sheet のメカニカルレイヤーに配置されたオブジェクト群の外接矩形から自動的に算出されます。

シートの背景サイズは、レイヤータイプがSheetのレイヤーに配置されたオブジェクトから自動的に設定できます。シートの背景サイズは、レイヤータイプがSheetのレイヤーに配置されたオブジェクトから自動的に設定できます。

シートの背景色と表示/非表示は、View Configuration パネルの System Colors セクションで設定します。 カラーボタンをクリックすると、 Sheet Line  と  Area Color の色を変更できます。/ を切り替えて、シートを表示/非表示にします。

出力へのメカニカルレイヤーの追加

メカニカルレイヤーは、基板設計、製造、組立、製品ドキュメントの作成で使用する情報を記載するなど、幅広い用途に使用されます。これらのすべての要件に対応するため、印刷や出力ファイルの生成を含む、レイヤーベースのあらゆる出力で、メカニカルレイヤーを含めるか除外するかを選択できます。

印刷出力

メカニカルレイヤーを含め、設計内に存在するどのレイヤーもPCB印刷の設定に含めることができます。印刷出力は、Print ダイアログで必要なレイヤーを追加し、その順序を設定して構成します。

メカニカルレイヤーにオブジェクトを配置することで、非常に詳細な製造図面や組立図面を作成できます。
メカニカルレイヤーにオブジェクトを配置することで、非常に詳細な製造図面や組立図面を作成できます。

詳しくは 2D印刷ベースのPCB出力の準備

生成される出力

GerberやODB++など、すべての製造用出力では、メカニカルレイヤーを出力 Layer to Plot として含めたり、プロットするすべてのレイヤーに詳細情報として追加したりできます。出力は、OutputJob Configurationファイル(*.OutJob)でODB出力ジェネレーターを使用する場合など、設定済みの出力ジェネレーターを実行すると生成されます。

メカニカルレイヤーは個別にプロットすることも、必要に応じてすべてのプロットに追加することもできます。
メカニカルレイヤーは個別にプロットすることも、必要に応じてすべてのプロットに追加することもできます。

詳しくは 製造に向けた設計の準備

 

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents