배치된 컴포넌트 작업하기
개요
- 컴포넌트의 출처, 부품과 멀티파트 컴포넌트의 처리 방식, 회로도에 배치하는 주요 방법을 알아봅니다.
- 컴포넌트를 더 효율적으로 검색하고 배치 중이나 배치 후에 그래픽 요소를 빠르게 편집하는 방법을 살펴봅니다.
- 회로도 컴포넌트와 PCB 컴포넌트의 관계를 이해하고, 배치 후 확인하거나 편집할 수 있는 핵심 속성을 알아봅니다.
라이브러리 내의 컴포넌트는 실제 인쇄 회로 기판에 배치되는 Physical 소자를 나타냅니다. Schematic 시트에서 컴포넌트는 해당 Schematic 심볼 모델로 표현됩니다. 각 컴포넌트는 하나 이상의 파트를 포함할 수 있습니다.
파트

파트는 실제 Physical 전자 컴포넌트를 나타냅니다.
개요
파트는 전기 설계 프리미티브입니다. 저항, 스위치, 연산 증폭기, 전압 레귤레이터 등의 전자 소자를 나타내는 Schematic 심볼입니다. 파트는 Schematic 컴포넌트 라이브러리의 컴포넌트 내에 저장됩니다. 각 컴포넌트는 하나 이상의 파트를 포함할 수 있습니다. 파트에는 컴포넌트의 심볼 표현과 함께 PCB 풋프린트 등의 모델 링크가 포함되며, 컴포넌트 파라미터 및 공급업체 정보와 같은 세부 정보를 문서화하는 데 사용되는 파라미터도 포함됩니다. 파트에 모델 링크와 파라미터를 추가하는 방법은 사용하는 라이브러리 저장소 유형에 따라 달라집니다.
사용 가능 환경
파트는 Schematic Editor와 Schematic 라이브러리 Editor 모두에서 배치할 수 있습니다.
- Schematic Editor에서 Place » Part을 클릭합니다.
- 설계 공간에서 마우스 오른쪽 버튼을 클릭한 다음 컨텍스트 메뉴에서 Place » Part을 선택합니다.
- 컴포넌트 Panel에서 컴포넌트를 마우스 오른쪽 버튼으로 클릭하고 Place <ComponentName>을 선택합니다.
- Components Panel에서 범용 컴포넌트를 자리 표시자로 선택합니다.
- Components Panel에서 컴포넌트를 끌어다 놓습니다.
- Components Panel의 Details 창에서 Place 버튼을 선택하거나 Enter 단축키를 사용합니다.
- Schematic 라이브러리 Editor의 SCH Library Panel에서 컴포넌트를 선택한 다음 Place을 클릭합니다.
컴포넌트 Panel에서 배치하기
Schematic Editor에서는 Components Panel에서 파트를 선택하고 배치할 수 있습니다.
- Panel에는 현재 선택된 라이브러리의 내용이 표시됩니다. 라이브러리 이름 옆의 드롭다운을 사용하여 다른 라이브러리를 선택합니다.
- 현재 선택된 라이브러리 필드 아래의 마스크 필드를 사용하여 목록을 필터링하고 검색 속도를 높이거나, 목록을 스크롤하여 필요한 파트를 선택합니다.
- Place을 클릭하거나, 두 번 클릭하거나, 클릭한 채로 끌어서 선택한 컴포넌트를 활성 Schematic 시트에 배치합니다. 파트가 커서에 붙어 있는 동안 배치하기 전에 회전(Spacebar 누르기), 축을 기준으로 대칭 이동(X 또는 Y 누르기), 편집(Tab 누르기)을 수행할 수 있습니다.
- 현재 선택된 라이브러리의 컴포넌트 목록에 표시되는 열은 순서를 변경하거나(클릭한 채로 끌기), 다시 구성할 수 있습니다(마우스 오른쪽 버튼을 클릭한 다음 Select Columns 선택).
-
범용 컴포넌트 타일 내의
버튼을 클릭하면 컴포넌트가 커서에 붙어 활성 Schematic 문서에 배치할 수 있습니다. 타일 자체를 선택하면 Components Panel에서 해당 컴포넌트 유형 카테고리가 열립니다.
컴포넌트 검색하기
워크스페이스 외 라이브러리의 메뉴 옵션을 통해 환경설정을 지정하고, 검색을 수행하고, 데이터베이스 및 파일 기반 라이브러리 콘텐츠를 마이그레이션할 수 있습니다. 이러한 옵션에 접근하려면 Components Panel 오른쪽 상단의 라이브러리 메뉴
버튼을 선택합니다.
File-based Libraries Preferences을 선택하면 사용 가능한 파일 기반 라이브러리 대화상자가 열립니다. 여기에서 라이브러리 추가 또는 제거, 라이브러리 설치, 라이브러리 검색 경로 지정을 위한 컨트롤을 확인할 수 있습니다.
Components Panel의 Search 필드에 검색어를 입력하여 현재 표시되는 데이터베이스 및 파일 기반 라이브러리 컴포넌트 목록을 필터링할 수 있습니다. 컴포넌트 라이브러리에 대한 고급 검색 기능에 접근하려면 Panel 오른쪽 상단의
메뉴에서 File-based Libraries Search 옵션을 선택합니다. 그러면 파일 기반 라이브러리 검색 대화상자가 열립니다. 이 대화상자는 쿼리 기반 필터 조건을 비롯한 유연한 검색 옵션을 제공하며, 사용 가능한 모든 데이터베이스 및 파일 기반 라이브러리나 지정된 경로 내의 라이브러리를 검색할 수 있습니다.
- Default 검색 Scope은 Available File-based Libraries에서 Components을 검색하는 것입니다.
- 또한 이 대화상자에서는 드라이브의 폴더에 저장된 Libraries on path을 검색할 수도 있습니다. 이렇게 하려면 Libraries on path 옵션을 활성화한 다음 필요에 따라 Path 옵션을 구성합니다.
- Filters은 "AND"를 사용하므로, 간단한 필터로 시작한 후 결과가 많으면 Refine last search 모드를 사용하여 결과 내에서 검색하는 것이 좋습니다.
- Helper을 선택하면 쿼리 검색 결과가 File-based Libraries Search 대화상자에 표시됩니다.
Schematic 라이브러리 Editor에서 배치하기
Schematic 라이브러리 Editor에서 열려 있는 라이브러리의 파트는 SCH Library Panel에서 직접 배치할 수도 있습니다. 다음 사항에 유의하세요.
- Panel의 Place 버튼을 클릭하면 선택한 파트(컴포넌트)가 마지막으로 활성화된 Schematic 시트에 배치됩니다.
- 파트가 커서에 붙어 있는 동안 배치하기 전에 회전(Spacebar 누르기), 축을 기준으로 대칭 이동(X 또는 Y 누르기), 편집(Tab 누르기)을 수행할 수 있습니다. 이러한 작업은 객체를 끄는 동안에도 수행할 수 있습니다. 회전은 90° 단위로 이루어집니다.
-
라이브러리에서 파트를 직접 배치하는 경우, 해당 라이브러리를 사용 가능한 파일 기반 라이브러리 대화상자에 미리 추가할 필요가 없습니다.
그래픽 편집
파트의 그래픽 편집은 이동, 회전, 대칭 이동으로 제한됩니다. 설계 공간에서 파트를 선택하면 주위에 점선 선택 상자가 나타납니다. 선택한 컴포넌트를 그래픽으로 조작하려면 다음과 같이 합니다.
- Delete을 눌러 선택한 파트를 설계에서 제거합니다.
- 클릭한 상태로 유지하여 선택한 파트를 이동합니다. 커서는 가장 가까운 전기적 핫스폿(가장 가까운 핀의 배선 끝점)으로 이동합니다.
- Spacebar을 눌러 Arc를 시계 반대 방향으로 회전하거나, Shift+Spacebar을 눌러 시계 방향으로 회전합니다. 이 작업은 객체를 끄는 동안에도 수행할 수 있습니다. 회전은 90° 단위로 이루어집니다.
- 파트가 커서에 붙어 이동하는 동안 X 또는 Y 키를 눌러 해당 축을 기준으로 대칭 이동합니다.
Schematic 컴포넌트와 PCB 컴포넌트 간 작업
소프트웨어에는 Schematic의 컴포넌트와 PCB의 동일한 컴포넌트 간 작업을 지원하는 도구가 포함되어 있습니다. 이러한 도구에는 교차 탐색, 교차 선택, Schematic에서 PCB 컴포넌트 선택이 있습니다.
교차 탐색
이름에서 알 수 있듯이, 교차 탐색을 사용하면 한 Editor에서 컴포넌트를 클릭하여 다른 Editor의 해당 컴포넌트로 이동할 수 있습니다. 교차 탐색을 사용하려면:
- Schematic 또는 PCB Editor의 Tools 메뉴에 있는 Cross Probe을 클릭합니다.
- Schematic Editor에서 컴포넌트를 클릭하면 PCB Editor에서 해당 컴포넌트가 화면 중앙에 확대 표시됩니다. 확대 수준은 Preferences 대화 상자의 시스템 – 탐색 페이지에서 설정합니다.
- 기본 동작은 동일한 Editor에 머물면서 다른 컴포넌트를 교차 탐색할 수 있도록 대기하는 것입니다. 교차 탐색 시 다른 Editor로 전환하려면 Ctrl 키를 누르고 있습니다.
교차 선택 모드
교차 선택 모드는 다른 Editor에서 동일한 컴포넌트를 선택합니다. 확대하거나 화면 중앙에 표시하지는 않습니다. 교차 선택은 켜거나 끌 수 있습니다. Tools » Cross Select Mode을 클릭하여 모드를 켜거나 끕니다. Shift 키를 누른 상태에서 클릭하면 여러 컴포넌트를 선택할 수 있습니다.
PCB 컴포넌트 선택
이 기능을 사용하면 여러 Schematic 컴포넌트를 특정 순서로 선택한 다음 PCB Editor에서 동일한 컴포넌트를 같은 순서로 배치할 수 있습니다. 이 기능을 사용하려면:
- Schematic에서 컴포넌트를 하나씩 선택합니다(여러 컴포넌트를 선택하려면 Shift 키를 누른 상태에서 클릭합니다).
- PCB Editor로 전환한 다음 I, C 단축키를 눌러 Reposition Selected Components 명령을 실행합니다. I 단축키를 누른 후 마우스 오른쪽 버튼 클릭 메뉴에서도 Reposition Selected Components 명령을 사용할 수 있습니다.
파트 속성
일반 탭
일반
-
Reuse Block – 컴포넌트가 재사용 블록의 일부인 경우 이 필드에는 Parent 재사용 블록의 이름이 표시됩니다. Reuse Block 하이퍼링크를 클릭하면 이 재사용 블록의 속성을 볼 수 있습니다.
-
Designator – Designator를 입력합니다. 눈 아이콘을 전환하여 Designator를 표시하거나 숨깁니다. 잠금 아이콘을 사용하여 Designator를 잠그거나 잠금을 해제합니다. Designator에 대해 자세히 알아보세요.
-
Comment – 이름 또는 Comment를 입력합니다. 눈 아이콘을 전환하여 이름을 표시하거나 숨깁니다. 잠금 아이콘을 사용하여 이름을 잠그거나 잠금을 해제합니다. Comment 필드는 사용자 정의 또는 시스템 파라미터의 값을 표시하는 데에도 사용할 수 있습니다. Comment에 대해 자세히 알아보세요.
-
Part <x> of Parts – 선택한 파트의 번호와 전체 파트 수를 표시합니다.
을 클릭하여 필드를 잠그거나 잠금을 해제한 다음 드롭다운에서 연결된 파트의 번호를 선택합니다.
-
Description – 컴포넌트/파트 설명입니다.
-
Type – 여기에서 컴포넌트 풋프린트에 대해 다음 컴포넌트 유형 중 하나를 선택합니다. 사용 가능한 유형은 다음과 같습니다:
-
Standard– 표준 전기적 속성을 가지며, Schematic과 PCB 간에 항상 동기화되고(풋프린트, 핀/패드 및 Net 할당이 모두 일치해야 함), BOM에 포함되는 컴포넌트입니다. 저항과 같은 표준 전기 컴포넌트가 그 예입니다. -
Mechanical– 전기적 속성이 없으며, 동기화되지 않고(두 Editor에 모두 수동으로 배치해야 함), BOM에 포함되는 컴포넌트입니다. 방열판이 그 예입니다. -
Graphical– 전기적 속성이 없으며, 동기화되지 않고(두 Editor에 모두 수동으로 배치해야 함), BOM에 not 포함되는 컴포넌트입니다. 회사 로고가 그 예입니다. -
Net Tie (In BOM)– 서로 다른 두 개 이상의 Net을 단락하는 데 사용되며, Schematic과 PCB 간에 항상 동기화되고(풋프린트, 핀/패드 및 Net 할당이 모두 일치해야 함), BOM에 포함되는 컴포넌트입니다. 풋프린트 내부의 구리로 생성된 연결을 검사하지 않는다는 점에서 Standard 컴포넌트와 다릅니다. 이 구리를 통해 Net을 단락할 수 있습니다. 참고: 컴포넌트 내부에 연결되지 않은 구리가 없는지 확인하려면 Design Rule 검사기 대화 상자에서 Verify Shorting Copper 옵션을 활성화하세요. -
Net Tie (No BOM)– 서로 다른 두 개 이상의 Net을 단락하는 데 사용되며, Schematic과 PCB 간에 항상 동기화되고(풋프린트, 핀/패드 및 Net 할당이 모두 일치해야 함), BOM에 not 포함되는 컴포넌트입니다. 풋프린트 내부의 구리로 생성된 연결을 검사하지 않는다는 점에서 Standard 컴포넌트와 다릅니다. 이 구리를 통해 Net을 단락할 수 있습니다. 참고: 컴포넌트 내부에 연결되지 않은 구리가 없는지 확인하려면 Design Rule 검사기 대화 상자에서 Verify Shorting Copper 옵션을 활성화하세요. -
Standard (No BOM)– 표준 전기적 속성을 가지며, Schematic과 PCB 간에 항상 동기화되고(풋프린트, 핀/패드 및 Net 할당이 모두 일치해야 함), BOM에 not 포함되는 컴포넌트입니다. BOM에서 제외하려는 테스트 포인트 컴포넌트가 그 예입니다. -
Jumper– PCB 설계에 와이어 링크를 포함하는 데 사용되는 컴포넌트입니다. 예를 들어 하나의 레이어에서 배선을 완료할 수 없는 단면 PCB에 사용됩니다. 이 컴포넌트 유형에서는 컴포넌트 풋프린트와 핀이 Schematic과 PCB 간에 동기화되지만 Net 할당은 동기화되지 않으며, 컴포넌트는 BOM에 포함됩니다. 컴포넌트 수준에서 이 옵션을 선택하는 것 외에도 컴포넌트의 두 패드에 대해 JumperID를 동일한 0이 아닌 값으로 설정해야 합니다. Jumper 유형 컴포넌트는 Schematic에서 배선할 필요가 없으며, BOM에 필요한 경우에만 Schematic에 포함하면 됩니다. BOM에 필요하지 않은 경우 PCB에 직접 배치하여 Component Type 및 JumperIDs 을 설정하고, 패드에 대해 Nets 을 수동으로 할당할 수 있습니다.
-
-
Design Item ID – 이 필드에는 선택한 컴포넌트의 이름(워크스페이스 컴포넌트의 경우), 그리고 Field Settings에 정의된 선택한 키 필드가 나열됩니다. DbLib/SVNDbLib 파일의 Region(데이터베이스 라이브러리 컴포넌트의 경우) 또는 컴포넌트 심볼에 정의된 Design Item ID 파라미터(파일 기반 라이브러리 컴포넌트의 경우)입니다.
을 클릭하면 컴포넌트 교체 대화 상자가 열립니다. 이 대화 상자에서는 선택한 컴포넌트의 전체 세부 정보(파라미터, 모델, 부품 선택 항목, 공급업체 데이터 등)를 확인하고, 컴포넌트를 비교하고, 현재 컴포넌트를 다른 컴포넌트로 교체하는 등 다양한 작업을 수행할 수 있습니다. 교체할 다른 컴포넌트를 선택하면 이 필드에 새로 선택한 컴포넌트의 전체 Design Item ID이 표시됩니다. Validate 버튼을 클릭하면 컴포넌트가 있는 위치에 관한 정보가 표시됩니다. 워크스페이스 컴포넌트가 아닌 경우 컴퓨터에 저장된 파일 경로가 표시됩니다. 워크스페이스 컴포넌트인 경우에는 컴포넌트를 찾았다는 정보만 표시됩니다.
-
Source – 컴포넌트의 소스 라이브러리 이름을 표시합니다.
을 클릭하여 원하는 라이브러리를 검색하고 선택합니다.
-
Revision state – 이 필드는 선택한 컴포넌트 리비전의 현재 수명 주기 상태를 리비전 상태의 색상 아이콘 및 이름과 함께 표시합니다.
-
Revision status – 선택한 컴포넌트 리비전이 적용 가능한 상태(설계에서 사용 허용)인 경우, 이 Entry는 해당 리비전이 최신인지(
Up to date) 아닌지(Out of date)를 나타냅니다. 리비전이 적용 불가능한 상태(설계에서 사용 불가)인 경우 Entry에Not applicable이 표시됩니다.
버튼을 클릭하면 컴포넌트가 최신 리비전으로 업데이트됩니다.
-
Component issues (Properties Panel만 해당) – 연결된 Altium 365 워크스페이스에서 가져온 선택한 컴포넌트에 상태 문제가 있는 경우,
(오류) 또는
(치명적 오류) 아이콘으로 표시됩니다. 아이콘 오른쪽의 숫자는 발견된 문제의 수를 나타냅니다. 숫자 오른쪽의 아래쪽 화살표를 클릭하면 문제에 대한 간략한 설명을 볼 수 있습니다.

발견된 라이브러리 상태 문제의 예. -
Supply Chain Data (Properties Panel만 해당) – 관련 부품 선택 항목의 공급망 정보를 표시합니다.
- 단가 중앙값. 가격 정보가 없거나 가격이 0인 경우 이 Entry는 빨간색으로 표시됩니다.
- 재고. 이 Entry는 워크스페이스의 Altium Parts Provider 소스에 포함되도록 활성화된 공급업체에서 제공하는 재고의 총합을 표시합니다.
-
제조업체 수명 주기 막대. 막대 위에 마우스를 올리면 정보를 제공하는 도구 설명이 표시됩니다. 다음 네 가지 상태 중 하나로 표시될 수 있습니다.
- 흰색/회색 = Default, 알 수 없음 또는 정보 없음
- 녹색 = 신규 또는 대량 생산 상태
- 주황색 = 신규 설계에 권장하지 않음
- 빨간색 = 단종 또는 EOL
위치
-
(X/Y)
- X (첫 번째 필드) – 현재 설계 공간 원점을 기준으로 한 객체 기준점의 현재 X(수평) 좌표입니다. 객체의 X 위치를 변경하려면 이 값을 편집합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위로 값을 입력할 때는 단위를 함께 입력하세요.
- Y (두 번째 필드) – 현재 원점을 기준으로 한 객체 기준점의 현재 Y(수직) 좌표입니다. 객체의 Y 위치를 변경하려면 이 값을 편집합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위로 값을 입력할 때는 단위를 함께 입력하세요.
-
Rotation – 드롭다운에서 회전 각도를 선택합니다. 선택 항목은
0 Degrees,90 Degrees,180 Degrees및270 Degrees입니다.
파라미터
-
Grid – 현재 선택한 컴포넌트와 연결된 파라미터의 Name 및 Value을 나열합니다.
을 사용하여 목록에 있는 파라미터를 잠그거나 잠금 해제하고 업데이트되지 않도록 설정할 수 있습니다. 파라미터 값은 직접 입력하거나, 해당 유형의 사용 가능한 모든 컴포넌트에서 가져온 값을 제공하는 드롭다운 메뉴 목록에서 선택할 수 있습니다. 눈 아이콘을 클릭하여 파라미터를 표시하거나 숨길 수 있습니다.
-
Favorites – 즐겨찾기로 지정된 파라미터는 파라미터 목록에 표시되고, 지정되지 않은 파라미터는 숨겨집니다. 파라미터 필터 이름 오른쪽에 마우스 커서를 놓고
아이콘을 클릭하여 필터를 즐겨찾기로 지정합니다. 파라미터를 즐겨찾기에서 제거하려면 아이콘을 다시 클릭합니다.
숨겨진 모든 파라미터를 보려면 목록 하단의 Show More 컨트롤을 클릭합니다. 즐겨찾기 파라미터만 보려면 Show Less 컨트롤을 클릭합니다.
-
Font – 표시된 글꼴을 클릭하여 글꼴 스타일을 변경합니다.
-
Other – 클릭하여 추가 옵션을 변경할 수 있는 드롭다운을 엽니다.
- Show Parameter Name – 파라미터 이름을 표시하려면 활성화합니다.
- Allow Synchronization with Database – 데이터베이스와 동기화하려면 활성화합니다. 이 옵션은 Comment를 업데이트할 수 있는지 여부를 제어하는 데 사용됩니다. 기본적으로 이러한 옵션은 소스 라이브러리/데이터베이스와의 동기화를 항상 허용하도록 활성화되어 있습니다. 이 옵션을 비활성화하면 해당 Comment가 업데이트 프로세스에 포함되지 않도록 할 수 있습니다.
- (X/Y) – X 및 Y 좌표를 입력합니다.
-
Rotation – 드롭다운을 사용하여 회전 각도를 선택합니다. 선택 가능한 값은
0°,90°,180°및270°입니다. - Autoposition – 자동 배치를 활성화하려면 선택합니다. 자동 배치를 활성화하면 연결된 컴포넌트가 회전할 때마다 파라미터가 자동으로 배치됩니다. 컴포넌트가 회전할 때 해당 컴포넌트에 대한 파라미터의 상대적 위치를 유지하려면 이 옵션을 비활성화합니다.
-
Add – 클릭하여 풋프린트, 모델, Rule 등의 파라미터를 추가합니다. Grid에서 선택한 Entry를 삭제하려면
을 클릭합니다. 파라미터에 해당하는 대화 상자에서 파라미터를 편집하려면
를 클릭합니다.
그래픽
-
Mode – 드롭다운을 사용하여 원하는 모드를 선택합니다. Normal 이외의 모드를 사용할 수 없으면 이 드롭다운이 비활성화됩니다.
- Mirrored – 파트를 미러링하려면 활성화합니다.
- Local Colors – 로컬 색상 옵션을 활성화하면 Schematic 컴포넌트의 채우기, 선 및 핀 색상이 각각 Fill, Lines 및 Pins 색상 상자의 색상으로 재정의됩니다. 라이브러리에 미리 정의된 색상을 사용하려면 이 옵션을 비활성화합니다.
부품 선택 항목
이 영역에는 선택한 컴포넌트에 할당된 부품 선택 항목 및 공급업체 링크 정보가 표시됩니다. 이 섹션의 항목에서 제공하는 정보에 대한 자세한 내용은 컴포넌트에 공급망 정보 추가 페이지를 참조하세요.
핀 탭
-
Grid – 이 영역에는 선택한 컴포넌트의 모든 핀에 대한 Pins 및 Names이 나열됩니다. 눈 아이콘을 사용하여 핀을 표시하거나 숨길 수 있습니다. 잠금 아이콘을 사용하여 핀을 잠그거나 잠금 해제할 수 있습니다.
다기능 핀(Properties 패널의 핀 모드에 있는 Functions 필드에 기능이 지정된 핀)의 경우, Name 열에서 해당 핀의 셀을 클릭하고 나타나는 드롭다운에서 핀 기능을 선택합니다. 선택한 기능은 Schematic 시트에 핀 이름으로 표시됩니다.
- Show Full/Show Short - Show Full 에서는 나열된 모든 핀의 전체 확장 핀 이름이 표시되며, Show Short 모드에서는 현재 핀 이름이 표시됩니다.
-
– 버튼이 활성화되어 있으면(닫힌 자물쇠 아이콘) Schematic Editor에서 컴포넌트 핀을 편집할 수 없습니다(단, Schematic 라이브러리 Editor에서는 편집할 수 있습니다). Schematic 시트에서 컴포넌트 핀을 편집하려면 이 옵션을 비활성화합니다.
-
– 클릭하면 컴포넌트 핀 Editor에서 Show 속성이 비활성화된 핀을 포함하여 모든 숨겨진 핀과 핀 속성(이름 및 번호)이 표시됩니다. Schematic 라이브러리 Editor에서 작업 중이라면 라이브러리 Editor에 숨겨진 핀을 표시하기 위해 View » Show Hidden Pins 옵션도 활성화해야 합니다.
-
– 클릭하여 컴포넌트에 핀을 추가합니다. Properties Panel에서 핀을 구성한 다음 클릭하고 드래그하여 위치를 지정합니다.
-
– 클릭하여 컴포넌트에서 선택한 핀을 삭제합니다.
-
– 클릭하여 컴포넌트 핀 Editor 대화 상자를 엽니다. 이 대화 상자를 사용하면 Schematic 라이브러리 Editor에서 현재 열려 있는 컴포넌트 또는 Schematic Editor에서 선택한 컴포넌트(또는 해당 컴포넌트의 일부)의 모든 핀을 편리하게 확인하고 편집할 수 있습니다.
일반 컴포넌트 속성
일반 컴포넌트

Components Panel에서 일반 컴포넌트 배치하기
Altium Designer가 워크스페이스에 연결되어 있으면, 컴포넌트 Panel에서 사용 가능한 일반 컴포넌트에 접근할 수 있습니다. 일반 컴포넌트는 Categories 창에서 All 옵션을 선택하면 표시되며, Panel이 간소화 모드일 때는 상단 드롭다운 메뉴에서 접근할 수 있습니다. 일반 컴포넌트 타일 내의
버튼을 클릭하면 컴포넌트가 커서에 부착되어 활성 Schematic에 배치할 수 있습니다. 타일 자체를 선택하면 Components Panel에서 해당 컴포넌트 유형의 카테고리가 열립니다.
일반 컴포넌트 속성
일반
- Designator – Designator를 입력합니다. 눈 아이콘을 전환하여 Designator를 표시하거나 숨깁니다. 자물쇠 아이콘을 클릭하여 Designator를 잠그거나 잠금을 해제합니다.
- Comment – 이름을 입력합니다. 눈 아이콘을 전환하여 이름을 표시하거나 숨깁니다.
-
Description – 일반 컴포넌트/부품에 대한 설명입니다.
- Replace – 설계가 진행되어 일반 컴포넌트를 특정 Physical 컴포넌트로 교체할 수 있는 단계에 도달하면 Replace 버튼을 선택하여 컴포넌트 교체 대화 상자를 사용합니다.
위치
-
(X/Y)
- X (첫 번째 필드) – 현재 설계 공간 원점을 기준으로 한 객체 기준점의 현재 X(수평) 좌표입니다. 값을 편집하여 객체의 X 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 Default 단위와 다른 단위의 값을 입력할 때는 단위도 함께 입력합니다.
- Y (두 번째 필드) – 현재 원점을 기준으로 한 객체 기준점의 현재 Y(수직) 좌표입니다. 값을 편집하여 객체의 Y 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 Default 단위와 다른 단위의 값을 입력할 때는 단위도 함께 입력합니다.
- Rotation – 드롭다운을 사용하여 회전 각도를 선택합니다.
파라미터
- Grid – 현재 선택한 컴포넌트에 연결된 파라미터의 Name 및 Value을 나열합니다. 자물쇠 아이콘을 사용하여 목록의 파라미터를 잠그거나 잠금을 해제합니다. 파라미터 값은 직접 입력하거나, 해당 유형의 사용 가능한 모든 컴포넌트에서 가져온 값을 제공하는 드롭다운 메뉴 목록에서 선택할 수 있습니다. 눈 아이콘을 사용하여 파라미터를 표시하거나 숨길 수 있습니다.
- Font – 표시된 글꼴을 클릭하여 글꼴 스타일을 변경합니다.
-
Other – 클릭하면 추가 옵션을 변경할 수 있는 드롭다운이 열립니다.
- Show Parameter Name – 활성화하면 파라미터 이름이 표시됩니다.
- Allow Synchronization with Database – 활성화하면 데이터베이스와 동기화됩니다. 이 옵션은 Comment의 업데이트 가능 여부를 제어하는 데 사용됩니다. Default 상태에서는 이 옵션이 활성화되어 항상 원본 라이브러리/데이터베이스와 동기화할 수 있습니다. 이 옵션을 비활성화하면 해당 Comment가 업데이트 과정에 포함되지 않도록 할 수 있습니다.
- (X/Y) – X 및 Y 좌표를 입력합니다.
- Rotation – 드롭다운을 사용하여 회전 각도를 선택합니다.
- Autoposition – 선택하면 자동 위치 지정이 활성화되어 연결된 컴포넌트가 회전할 때마다 파라미터의 위치가 자동으로 지정됩니다. 컴포넌트가 회전할 때 컴포넌트에 대한 파라미터의 상대 위치를 유지하려면 이 옵션을 비활성화합니다.
Designator
Designator는 설계의 각 컴포넌트를 고유하게 식별합니다.
요약
Designator 필드는 Schematic 컴포넌트(부품)의 하위 파라미터 객체입니다. 배치된 각 부품을 고유하게 식별하여 프로젝트의 모든 Schematic 시트에 배치된 다른 부품과 구분하는 데 사용됩니다.
사용 및 배치
Designator는 Parent 컴포넌트 부품 객체가 배치될 때 자동으로 배치됩니다. 직접 배치할 수 있는 설계 객체는 아닙니다.
그래픽 편집
Designator 문자열은 in-place 편집 방식을 사용하여 그래픽 방식으로 편집할 수 있습니다. Designator 문자열을 제자리에서 편집하려면 커서를 드래그하여 Designator를 둘러싸 선택한 다음 Enter 키를 누릅니다.

제자리 편집 예시
편집이 완료되면 Enter 키를 누르거나 문자열 바깥을 클릭하여 제자리 편집 모드를 종료합니다.
비그래픽 편집
Designator 편집과 관련해서는 Designator 값 편집과 Designator 표시 속성 편집이라는 두 가지 측면을 고려해야 합니다.
Designator(및 Comment) 문자열을 Schematic 라이브러리 Editor에 표시한 다음 두 번 클릭하여 속성을 편집할 수 있습니다. Properties 패널의 해당 필드에 연결된
아이콘은 Designator를 표시하거나 숨기는 데 사용됩니다.
Schematic Editor에서 Designator 값 편집
Designator는 컴포넌트를 배치하는 동안 또는 Schematic 시트에 컴포넌트를 배치한 후 Schematic Editor의 Properties panel에서 지정할 수 있습니다.
- 컴포넌트를 배치하는 동안 Designator를 편집하려면 컴포넌트가 커서에 떠 있는 상태에서 Tab 키를 누릅니다. Properties 패널이 열리면 필요한 Designator 문자열을 입력합니다. 설계 공간에 오버레이로 표시되는 일시 정지 버튼을 클릭하여 배치를 재개합니다.
- 계속해서 컴포넌트를 배치하거나 Esc 키를 눌러 배치를 종료합니다.
- Spacebar 키를 누르면 Arc가 시계 반대 방향으로 회전하고, Shift+Spacebar 키를 누르면 시계 방향으로 회전합니다. 객체를 드래그하는 동안에도 이 동작을 수행할 수 있습니다. 회전은 90° 단위로 이루어집니다.
- 배치 후 Designator를 편집하려면 배치된 컴포넌트를 두 번 클릭하여 Properties 패널을 엽니다. 이 패널에서 Designator를 편집할 수 있습니다.
Designator 표시 속성 편집
글꼴 종류, 크기, 색상 등 Designator 문자열의 모양은 Preferences 대화 상자의 Schematic - 기본값 페이지에서 설정할 수 있습니다. Schematic 라이브러리 Editor의 컴포넌트 심볼에 정의된 설정으로 재정의하지 않는 한 이 설정이 적용됩니다.
Designator 문자열의 위치 고정
Designator의 기본 동작은 배치 중 컴포넌트를 회전할 때 위치를 자동으로 조정하는 것입니다. 이 동작이 필요하지 않으면 심볼을 생성하는 동안 또는 Schematic 시트에 컴포넌트를 배치한 후 Preferences 대화 상자에서 Autoposition 옵션을 끕니다(이전 이미지 참조). 이렇게 하면 이 파라미터가 manual parameter(수동으로 배치한 파라미터)로 분류됩니다. 수동 파라미터는 선택 상자의 왼쪽 아래 모서리에 점으로 표시됩니다.
참고 사항
-
Schematic Editor에는 동일한 부품의 여러 인스턴스를 배치할 때 사용할 수 있는 간단한 Designator 자동 증가 기능이 있습니다. 이 기능을 사용하려면 첫 번째 컴포넌트가 커서에 떠 있는 상태에서 Tab 키를 누르고 적절한 Designator(예:
R1)를 입력합니다. 이후 컴포넌트에는R2,R3등의 Designator가 지정됩니다. 다른 유형의 컴포넌트 배치로 전환할 때는 Tab 키를 다시 누르고 적절한 Designator 접두사를 입력해야 합니다. -
멀티파트 컴포넌트를 배치할 때 앞서 설명한 대로 초기 Designator를 지정하면 부품 접미사가 자동으로 할당됩니다(예:
U3A,U3B등). 초기 Designator를 지정하지 않으면 모든 부품에 동일한 접미사가 지정됩니다. 이 문제는 Schematic Editor의 Annotation 명령으로 해결할 수 있습니다. 부품 접미사는 알파벳 또는 숫자로 지정할 수 있습니다. Preferences 대화 상자의 Schematic - 일반 페이지에 있는 Alpha Numeric Suffix 옵션을 사용하여 설정합니다.
Designator 속성
위치
-
(X/Y)
- X (첫 번째 필드) - 현재 워크스페이스 원점을 기준으로 한 객체 기준점의 현재 X(수평) 좌표입니다. 값을 편집하여 객체의 X 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위가 아닌 단위로 값을 입력할 때는 단위를 함께 입력해야 합니다.
- Y (두 번째 필드) - 현재 원점을 기준으로 한 객체 기준점의 현재 Y(수직) 좌표입니다. 값을 편집하여 객체의 Y 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위가 아닌 단위로 값을 입력할 때는 단위를 함께 입력해야 합니다.
- Rotation - 드롭다운을 사용하여 회전을 선택합니다.
속성
- Object - 연결된 객체를 표시합니다.
- 이름 - 표시 아이콘을 클릭하여 이 필드를 활성화하면 Designator 값 앞에 "Designator:" 접두사가 추가됩니다. 이를 통해 해당 텍스트 값이 Schematic 문서의 Designator임을 시각적으로 구분하고 확인할 수 있습니다.
-
Value - Designator 이름 자체를 표시합니다. 눈 모양 아이콘
을 전환하여 값을 표시하거나 숨깁니다.
- 자동 위치 지정 - 선택하면 자동 위치 지정이 활성화되어 컴포넌트를 이동하거나 회전해도 텍스트가 선택한 위치를 유지합니다.
- 파라미터 잠금 - 선택하면 파라미터가 잠겨 Properties 패널이나 Schematic 문서에서 값을 편집할 수 없습니다.
- 데이터베이스와 동기화 허용 - 활성화하면 데이터베이스와 동기화합니다. 이 옵션은 Comment의 업데이트 가능 여부를 제어하는 데 사용됩니다. 기본적으로 이 옵션은 활성화되어 있어 소스 라이브러리/데이터베이스와의 동기화가 항상 허용됩니다. 업데이트 과정에 해당 Comment가 포함되지 않도록 하려면 이 옵션을 비활성화할 수 있습니다.
- 글꼴 - 컨트롤을 사용하여 글꼴, 글꼴 크기, 글꼴 색상을 선택하고 굵게, 기울임꼴, 밑줄 등 원하는 글꼴 스타일을 추가합니다.
- 정렬 - 화살표를 클릭하여 텍스트 정렬을 설정하거나 원을 클릭하여 가운데 정렬합니다.
- Override Library Primitive (Preferences 대화 상자에만 해당) - 이 체크박스를 활성화하면 라이브러리의 Designator 객체에 정의된 프리미티브 설정을 재정의합니다. 따라서 컴포넌트를 배치하면 라이브러리에서 해당 컴포넌트에 정의된 설정 대신 Preferences 대화 상자에서 정의한 프리미티브 설정이 적용됩니다.
Comment
Comment를 사용하면 컴포넌트에 대한 추가 정보를 표시할 수 있습니다.
요약
Comment 필드는 Schematic 컴포넌트(부품)의 하위 파라미터 객체입니다. 컴포넌트에 대한 추가 정보를 표시합니다.
사용 및 배치
Comment는 상위 컴포넌트 부품 객체를 배치할 때 설정됩니다. 직접 배치할 수 있는 설계 객체는 아닙니다.
그래픽 편집
Comment는 in-place 편집이라는 방식을 사용하여 그래픽으로 편집할 수 있습니다. Comment를 제자리에서 편집하려면 한 번 클릭하여 선택하고 잠시 기다린 다음, 다시 클릭하여 편집 모드로 들어갑니다.
편집이 완료되면 Enter 키를 누르거나 문자열 바깥을 클릭하여 제자리 편집 모드를 종료합니다.
비그래픽 편집
Comment 편집과 관련하여 고려해야 할 사항은 두 가지입니다. Comment 값 편집과 Comment 표시 속성 편집입니다.
Schematic Editor에서 Comment 편집
컴포넌트를 배치하는 동안이나 Schematic 시트에 컴포넌트를 배치한 후, Schematic Editor의 Properties 패널에 있는 Comment 필드에서 Comment를 정의할 수 있습니다.
- 컴포넌트 배치 중에 Comment를 편집하려면 컴포넌트가 커서에 떠 있는 상태에서 Tab 키를 누릅니다. Properties 패널이 열리면 필요한 Comment를 입력합니다. 설계 공간에 오버레이로 표시되는 일시 정지 버튼을 클릭하여 컴포넌트 배치를 다시 시작합니다.
- 컴포넌트를 계속 배치하거나 Esc 키를 눌러 배치를 종료합니다.
- 배치 후 Comment를 편집하려면 배치된 컴포넌트를 두 번 클릭하여 Properties 패널을 엽니다. 여기에서 Comment를 편집할 수 있습니다.
Comment 표시 속성 편집
글꼴 종류, 크기, 색상을 비롯한 Comment의 모양은 Preferences 대화 상자의 Schematic - Defaults 페이지에서 구성할 수 있습니다.
Comment 위치 고정
Comment의 기본 동작은 배치 중 컴포넌트가 회전할 때 위치를 자동으로 지정하는 것입니다. 이 동작이 필요하지 않으면 심볼 생성 중이나 Schematic 시트에 컴포넌트를 배치한 후 Preferences 대화 상자에서 Autoposition 옵션을 비활성화합니다(이전 이미지 참조). 이렇게 하면 해당 파라미터가 manual parameter(수동으로 위치를 지정한 파라미터)로 분류됩니다. 수동 파라미터는 선택 상자의 왼쪽 아래 모서리에 있는 점으로 식별할 수 있습니다.
Comment 속성
위치
-
(X/Y)
- X (첫 번째 필드) - 현재 설계 공간 원점을 기준으로 한 객체 기준점의 현재 X(수평) 좌표입니다. 객체의 X 위치를 변경하려면 이 값을 편집합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력합니다.
- Y (두 번째 필드) - 현재 원점을 기준으로 한 객체 기준점의 현재 Y(수직) 좌표입니다. 객체의 Y 위치를 변경하려면 이 값을 편집합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력합니다.
- Rotation - 드롭다운에서 회전 각도를 선택합니다. 선택 항목은 0 Degrees, 90 Degrees, 180 Degrees, 270 Degrees입니다.
속성
- 컴포넌트 - 연결된 컴포넌트의 이름을 표시합니다. Component 링크를 클릭하여 부품 속성 패널을 열면 컴포넌트 옵션과 Comment 자체를 편집할 수 있습니다. Comment는 해당 패널의 Comment 필드에서 정의됩니다.
- 이름 - 표시 아이콘을 클릭하여 이 필드를 활성화하면 Comment 값 앞에 "Comment:" 접두사가 추가됩니다. 이를 통해 해당 텍스트 값이 Schematic 문서의 Comment임을 시각적으로 구분하고 확인할 수 있습니다.
-
값 - Comment 이름 자체를 표시합니다. 를 전환하여 값을 표시하거나 숨깁니다.
- 자동 위치 지정 - 선택하면 자동 위치 지정이 활성화되어 컴포넌트를 이동하거나 회전해도 텍스트가 선택한 위치에 유지됩니다.
- 파라미터 잠금 - 선택하면 파라미터가 잠겨 Properties 패널이나 Schematic 문서에서 값을 편집할 수 없게 됩니다.
- 데이터베이스와 동기화 허용 - 활성화하면 데이터베이스와 동기화됩니다. 이 옵션은 Comment의 업데이트 가능 여부를 제어하는 데 사용됩니다. 기본적으로 이 옵션은 활성화되어 소스 라이브러리/데이터베이스와의 동기화를 항상 허용합니다. Comment가 업데이트 과정에 포함되지 않도록 하려면 이 옵션을 비활성화할 수 있습니다.
- 글꼴 - 컨트롤을 사용하여 글꼴, 글꼴 크기, 글꼴 색상을 선택하고 굵게, 기울임꼴, 밑줄 등 원하는 글꼴 스타일을 추가합니다.
- 정렬 - 화살표를 클릭하여 텍스트 정렬을 구성하거나 원을 클릭하여 가운데로 정렬합니다.
- Override Library Primitive (Preferences 대화 상자에만 해당) - 이 확인란을 선택하면 라이브러리의 Comment 객체에 정의된 프리미티브 설정을 재정의합니다. 따라서 컴포넌트를 배치할 때 라이브러리의 컴포넌트에 정의된 설정 대신 Preferences 대화 상자에서 정의한 프리미티브 설정이 적용됩니다.
라이브러리에서 컴포넌트 업데이트 및 교체
보드 설계의 Schematic 시트에 컴포넌트를 처음 배치한 후에는 해당 워크스페이스에서 연결된 소스 컴포넌트가 변경될 때 배치된 컴포넌트 인스턴스에도 변경 사항을 반영할 수 있어야 합니다. 즉, 설계가 사용하는 워크스페이스 항목과 설계를 동기화 상태로 유지할 수단이 필요합니다.
예를 들어 하위 모델의 변경 사항 등을 반영하여 컴포넌트를 워크스페이스에 다시 저장했을 수 있습니다. 그러면 해당 컴포넌트의 새 리비전이 생성됩니다. 배치된 컴포넌트 인스턴스는 이제 이전 리비전을 사용하므로 최신 리비전을 사용하도록 업데이트해야 할 수 있습니다. 또는 완전히 다른 컴포넌트를 사용하기로 결정하여 설계의 기존 컴포넌트를 대체 컴포넌트로 변경해야 할 수도 있습니다.
설계에 처음 배치한 후 컴포넌트를 관리하는 데 사용할 수 있는 다양한 방법이 있습니다.
싱글 인스턴스 컴포넌트 변경
배치된 각 컴포넌트에는 워크스페이스의 컴포넌트 리비전으로 연결되는 링크가 있습니다. 선택한 컴포넌트의 속성을 살펴볼 때 Properties 패널에서 이 정보를 확인할 수 있습니다.
배치된 각 컴포넌트 인스턴스에는 워크스페이스에 있는 해당 컴포넌트의 특정 리비전으로 연결되는 링크가 있습니다.
가장 작은 단위인 개별 컴포넌트 수준에서는 배치된 인스턴스를 다음과 같이 변경할 수 있습니다.
-
버튼을 클릭하여 기존 컴포넌트의 최신 리비전으로 업데이트합니다.
동일한 컴포넌트를 최신 리비전으로 업데이트하는 예 — 이미지 위에 마우스를 올리면 결과를 볼 수 있습니다.
-
Design Item ID 필드 오른쪽에 있는
버튼을 클릭하여 다른 워크스페이스 컴포넌트(대체 컴포넌트)의 최신 리비전 또는 파일 기반 라이브러리 컴포넌트로 교체합니다. Replace Component 대화 상자가 열리며, 연결된 워크스페이스와 사용 가능한 파일 기반 라이브러리의 컴포넌트가 표시됩니다. 현재 컴포넌트는 목록 맨 위에 표시됩니다. 필요한 대체 컴포넌트를 검색하여 선택한 다음 OK를 클릭합니다.
Replace Component 대화 상자에서는 사용 가능한 모든 워크스페이스 라이브러리 컴포넌트와 파일 기반 라이브러리 컴포넌트에 직접 접근할 수 있습니다. 이 대화 상자는 선택한 컴포넌트의 전체 세부 정보(파라미터, 모델, 부품 선택 항목, 공급업체 데이터 등)와 컴포넌트 비교 기능을 제공하며, 워크스페이스 라이브러리 컴포넌트의 경우 타겟 컴포넌트의 파라미터를 지정할 수 있는 필터 기반 파라미터 검색 기능도 제공합니다.
컴포넌트 교체 대화 상자의 옵션 및 컨트롤
- Search - 검색 텍스트 상자를 사용하여 특정 컴포넌트를 직접 검색합니다.
-
- 클릭하여 Categories 창을 펼치거나 접습니다. 특정 유형의 컴포넌트를 표시하거나 사용 가능한 모든 컴포넌트를 표시할 수 있습니다. Categories 창 아래의 검색창을 사용하여 특정 컴포넌트 범주 또는 사용 가능한 파일 기반 컴포넌트 라이브러리를 직접 검색합니다.
-
- 클릭하여 메뉴를 열고 다음 중에서 선택합니다.
- File-based Libraries Preferences - 클릭하여 사용 가능한 파일 기반 라이브러리 대화 상자를 열고 라이브러리를 추가하거나 제거합니다.
- File-based Libraries Search - 클릭하여 파일 기반 라이브러리 검색 대화 상자를 열고 라이브러리를 검색합니다.
- Refresh - 클릭하여 대화 상자를 새로 고칩니다.
-
- 클릭하여 대화 상자의 Details Region (아래 설명)을 열거나 닫습니다.
필터
워크스페이스 컴포넌트 범주를 선택한 상태에서 Filters 아이콘을 클릭하면 Filters Region이 열립니다. 여기에서 Components 목록에서 선택한 범주를 추가로 필터링할 수 있습니다. 특정 파라미터 유형을 Favorites로 선택하여 패널의 Filters 옵션을 필요에 맞게 조정할 수 있으며, 선택한 유형은 현재 컴포넌트 범주의 목록 맨 위로 이동합니다. 파라미터 필터 이름 오른쪽에 마우스를 올리고 아이콘을 클릭하여 해당 필터를 즐겨찾기로 설정합니다. 즐겨찾기 필터 설정은 개별 컴포넌트 Categories에 적용되며 저장됩니다.
컴포넌트
- Name - 컴포넌트의 이름입니다.
- Description - 각 컴포넌트의 설명입니다.
- Footprint - 컴포넌트의 풋프린트입니다.
- Results - 검색에서 발견되거나 나열된 컴포넌트의 총 개수를 표시합니다.
세부 정보
- Component Revision ID - 해당 컴포넌트의 리비전 ID와 가격을 표시합니다. 리비전 ID를 클릭하면 Explorer 패널이 열려 컴포넌트에 대한 추가 정보를 확인할 수 있습니다.
- References - 클릭하여 웹 브라우저에서 컴포넌트의 참조 정보를 엽니다. 드롭다운을 사용하여 Manufacturer URL 또는 Datasheet에 접근합니다.
- Place - 클릭하여 선택한 컴포넌트를 Schematic 문서에 배치합니다.
- Component information - 제조업체, 출시일, 설명 등 컴포넌트에 관한 정보를 표시합니다. Show More 링크를 클릭하면 모든 정보를 볼 수 있으며, Show Less 를 클릭하면 정보를 접을 수 있습니다.
- Models - 펼쳐서 제공된 모델을 확인합니다. 사용 가능한 링크를 사용하여 싱글 모델의 다양한 부분을 표시합니다.
- References - 펼쳐서 Manufacturer URL, Datasheet, Package Specification에 접근합니다.
- Part Choices - 펼쳐서 부품 선택 항목을 확인합니다. 이름, 가격 및 설명이 제공됩니다. 컴포넌트의 데이터시트도 표시됩니다.
- Where Used - 펼쳐서 해당 컴포넌트를 사용하는 프로젝트를 확인합니다.
마우스 오른쪽 버튼 클릭 메뉴
- Find Similar Components - 클릭하여 유사 컴포넌트 찾기 대화 상자를 엽니다. 여기에서 특성이 비슷한 다른 컴포넌트를 검색할 수 있습니다.
- Place <component> - 클릭하여 적절한 문서에 컴포넌트를 배치합니다.
- Edit - 클릭하여 선택한 컴포넌트의 컴포넌트 라이브러리 문서를 엽니다.
- Navigate to <revision> - 클릭하여 Explorer 패널에서 선택한 컴포넌트를 엽니다.
- Operations - 마우스를 올리면 Submit Request, Create, Download, Clone, Change Component Type, Create / Edit PCL, Full Item History 기능에 접근할 수 있습니다.
- Refresh- 클릭하여 새로 고치고 최근 업데이트나 수정 사항을 확인합니다. F5 단축키를 사용하여 새로 고칠 수도 있습니다.
- Library Report - Categories 창에서 파일 기반 라이브러리를 선택한 상태에서 클릭하면 라이브러리 보고서 설정 대화 상자에 접근할 수 있습니다. 여기에서 제공되는 컨트롤을 사용하여 라이브러리 보고서를 구성할 수 있습니다.
컴포넌트 일괄 변경 수행 – Item Manager
Related page: Item Manager로 콘텐츠 관리
개별 컴포넌트 변경은 유용하지만, 컴포넌트 수가 많아지면 금세 번거로워집니다. 이 경우 여러 변경을 일괄적으로 수행할 수 있는 하나의 중앙 관리 위치가 필요합니다. 바로 Item Manager(Tools » Item Manager)입니다.
Item Manager는 Schematic 시트에 배치된 워크스페이스 설계 개체를 워크스페이스에서 연결된 원본 콘텐츠와 동기화하는 '중앙 제어실'입니다. 모든 컴포넌트를 자동으로 감지하여 나열하고 워크스페이스 개체인지 여부를 표시한 다음, Schematic에 있는 각 워크스페이스 컴포넌트의 Item-리비전을 워크스페이스에서 사용 가능한 해당 컴포넌트의 리비전과 비교합니다. 각 개체에 대해 현재 연결된 Item의 리비전, 수명 주기 상태, 해당 Item이 있는 원본 워크스페이스 정보가 제공됩니다.
이러한 워크스페이스 개체 중 무엇을 어떤 방식으로 업데이트할지는 사용자가 전적으로 제어할 수 있습니다. 예를 들면 다음과 같습니다.
- 개별 Entry를 선택하여 연결된 Item의 최신 리비전을 사용하도록 업데이트하거나, 완전히 다른 Item의 최신 리비전을 사용하도록 선택할 수 있습니다.
- 동일한 Item에 연결된 Entry 그룹을 선택하여 해당 Item의 최신 리비전으로 업데이트하거나, 완전히 다른 Item의 최신 리비전을 사용하도록 선택할 수 있습니다.
예정된 모든 변경 사항은 관리자에 반영됩니다.
필요에 따라 변경 사항을 설정한 후에는 ECO(Engineering Change Order)를 생성하고 변경 사항을 적용하기 위해 수행될 작업을 검토하세요. 필요하면 원하는 작업을 비활성화할 수 있으므로, 언제나 사용자가 모든 과정을 제어할 수 있습니다! 준비가 되면 ECO를 실행하여 변경 사항을 적용하세요. 배치된 워크스페이스 콘텐츠를 빠르고 효율적이며 간편하게 관리할 수 있습니다.
다음 예는 Item Manager의 사용 방법을 보여줍니다.
- 여러 컴포넌트를 업데이트하여 기존 워크스페이스 컴포넌트의 최신 리비전을 사용하도록 합니다.

오래된 컴포넌트 그룹을 최신 리비전으로 업데이트합니다.
- 몇 개의 컴포넌트를 컴포넌트 교체 대화상자에서 선택한 다른 워크스페이스 컴포넌트의 최신 리비전으로 변경합니다.

하나 이상의 컴포넌트를 다른 워크스페이스 컴포넌트로 교체합니다.
Item Manager는 설계 내 컴포넌트를 연결된 워크스페이스의 원본 콘텐츠 변경 사항과 동기화하는 데 사용할 수 있을 뿐만 아니라, 기존 보드 설계에서 로컬 설계 항목 대신 워크스페이스 설계 콘텐츠를 사용하도록 마이그레이션하는 데에도 유용한 강력한 도구입니다. 설계 컴포넌트와 Schematic 시트(디바이스 시트)를 워크스페이스로 마이그레이션한 후에는 Item Manager를 사용하여 기존 컴포넌트와 시트 심볼을 새로 마이그레이션된 워크스페이스 버전으로 '교체'합니다. 즉, 설계 관점에서는 컴포넌트가 동일하게 유지되지만 해당 컴포넌트의 원본이 변경됩니다.
BomDoc에서 컴포넌트 변경하기
부품 주문을 위해 BomDoc을 검토하고 준비하는 과정에서 컴포넌트의 문제를 발견하는 경우는 드물지 않습니다. 예를 들어 설계자가 컴포넌트 선택을 확정하는 것을 잊었거나, 컴포넌트가 단종(EOL)되어 대체 후보의 가격과 공급 가능 여부를 살펴보려는 경우가 있습니다. Schematic으로 돌아가 컴포넌트를 편집하고 적절한 부품을 선택한 다음 BomDoc을 새로 고쳐 해결할 수도 있지만, ActiveBOM을 사용하면 BomDoc에서 직접 이 작업을 수행한 뒤 ECO(Engineering Change Order)를 통해 해당 변경 사항을 Schematic에 반영할 수 있습니다.
BomDoc에서 선택한 컴포넌트를 마우스 오른쪽 버튼으로 클릭하고 Operations » Change <ComponentName> 명령을 선택하세요. 컴포넌트 교체 대화상자가 열리면 교체할 컴포넌트를 검색할 수 있습니다. 원하는 대체 컴포넌트를 찾아 선택한 다음 OK를 클릭하세요. Engineering Change Order 대화상자가 열리고 Schematic을 BomDoc과 동기화하는 데 필요한 변경 사항이 상세히 표시됩니다.
일반 컴포넌트 교체하기
설계가 진행되어 일반 컴포넌트를 구체적인 실제 컴포넌트로 교체할 수 있는 단계가 되면, Properties Panel에서
버튼을 선택하여 컴포넌트 교체 대화상자를 여세요. 이 작업은 Item 관리자 또는 프로젝트의 ActiveBOM 문서에서도 수행할 수 있습니다.
일반 컴포넌트에 적용된 파라미터 값(여기서는 전력 및 저항 값)이 Replace Generic Component 대화상자에서 검색어로 자동 사용되므로, 필터링된 결과에서 적절한 대체 컴포넌트를 선택할 수 있습니다. 이 예에서는 두 개의 컴포넌트 Entry가 검색 조건에 부합합니다.
|
Properties Panel에서 일반 컴포넌트 교체하기. Properties Panel에서 일반 컴포넌트 교체하기. |
전체 설계의 풋프린트 관리하기
Altium Designer의 Schematic Editor에는 강력한 Footprint Manager가 포함되어 있습니다. Schematic Editor의 Tools 메뉴(Tools » Footprint Manager)에서 실행하는 Footprint Manager를 통해 전체 프로젝트의 모든 컴포넌트에 연결된 풋프린트를 검토할 수 있습니다. 다중 선택이 지원되므로 여러 컴포넌트의 풋프린트 할당을 편집하거나, 풋프린트 연결 방식을 변경하거나, 풋프린트가 여러 개 할당된 컴포넌트의 현재 풋프린트 할당을 쉽게 변경할 수 있습니다. 이 Footprint Manager 기능을 통해 전체 설계의 풋프린트 할당을 검토하고 문제를 감지할 수 있으며, 특히 기존 설계나 다른 조직에서 만든 설계로 작업할 때 유용합니다. 설계 변경 사항은 ECO 시스템을 통해 적용되며, 필요한 경우 Schematic과 PCB가 모두 업데이트됩니다.
Footprint Manager 대화상자는 활성 프로젝트의 모든 원본 설계 Schematic에 있는 전체 컴포넌트 목록을 표시합니다. 대화상자 오른쪽에 있는 컨트롤을 사용하여 설계의 컴포넌트에서 사용할 수 있는 풋프린트와 현재 사용 중인 풋프린트를 관리하세요. 다음과 같은 기능이 제공됩니다.
- 선택한 하나 이상의 컴포넌트에 대해 풋프린트 모델을 추가, 편집 및 제거합니다.
- 컴포넌트 간에 풋프린트를 복사합니다.
- 현재 풋프린트 할당을 변경합니다. 이는 해당 컴포넌트에 사용할 수 있는 여러 풋프린트 중 PCB 영역에서 컴포넌트를 나타내는 데 현재 사용될 풋프린트입니다.
- 풋프린트를 검증하여 풋프린트 모델, 특히 현재 모델로 설정된 풋프린트 모델을 실제로 사용할 수 있는지 확인합니다.
풋프린트 모델 할당을 필요에 따라 모두 변경한 후에는 표준 엔지니어링 변경 지시(ECO)를 통해 해당 변경 사항을 적용합니다. 이를 위해 Footprint Manager 대화 상자의 오른쪽 하단에 있는 Accept Changes (Create ECO) 버튼을 클릭하면 됩니다.
Footprint Manager 대화 상자의 옵션 및 컨트롤
컴포넌트 목록
현재 활성화된 PCB 설계 프로젝트의 Schematic 시트에 있는 모든 컴포넌트의 목록입니다. 다음 정보가 포함됩니다.
- Designator
- Comment
- Current Footprint
- Design Item ID
- Part Count
- Sheet Name
풋프린트 보기 및 편집
Component List에서 선택한 컴포넌트에 연결된 풋프린트 목록입니다. 영역 하단의 컨트롤 또는 마우스 오른쪽 버튼 클릭 메뉴 명령을 사용하여 목록의 풋프린트를 조작할 수 있습니다.
마우스 오른쪽 버튼 클릭 메뉴
-
Add - 클릭하면 PCB Model 대화 상자가 열리며, 강조 표시된 Schematic 컴포넌트에 추가할 새 풋프린트 모델을 선택할 수 있습니다. 관리형 컴포넌트를 선택한 경우 사용할 수 없습니다.
-
Remove - 클릭하면 선택한 풋프린트가 제거됩니다. 관리형 컴포넌트를 선택한 경우 사용할 수 없습니다.
-
Edit Footprint - 클릭하면 PCB Model 대화 상자가 열립니다. PCB Model 대화 상자에서는 Schematic 컴포넌트에 연결할 풋프린트 모델과 Schematic Editor가 풋프린트를 검색할 라이브러리를 정의합니다. 관리형 컴포넌트를 선택한 경우 사용할 수 없습니다.
-
Validate Footprint Paths - 클릭하면 강조 표시된 풋프린트를 허용된 위치에서 찾을 수 있는지 확인합니다. 풋프린트를 찾을 수 없으면 Found In 필드에 Not Validated 이 표시됩니다. 풋프린트가 검증되면 해당 풋프린트의 전체 경로가 표시됩니다.
-
Change PCB Library - 클릭하면 Edit PCB Library 대화 상자가 열리며, 선택한 풋프린트의 PCB 라이브러리를 변경할 수 있습니다. 이 대화 상자는 PCB Model 대화 상자의 간소화된 버전으로, 소프트웨어가 풋프린트 모델을 검색할 위치를 정의하는 PCB Library 옵션을 제공합니다.

Edit PCB Library 대화 상자- Any - 사용 가능한 모든 라이브러리에서 일치하는 모델을 검색합니다.
- Library name - 사용 가능한 라이브러리 중 이 이름을 가진 라이브러리에서만 일치하는 모델을 검색합니다.
- Library path - 이 위치에 있으며 이 이름을 가진 라이브러리에서만 일치하는 모델을 검색합니다. 경로와 라이브러리 이름을 직접 입력하거나 Choose 버튼을 클릭하여 Windows Open 대화 상자를 연 다음 필요한 라이브러리를 찾아볼 수 있습니다.
- Use footprint from source integrated library, database library, or server - 컴포넌트를 배치할 때 사용한 통합 라이브러리/데이터베이스 라이브러리/서버에서만 모델을 검색합니다. 통합 라이브러리 또는 데이터베이스 라이브러리를 사용할 수 있어야 하며, 서버의 경우 해당 서버에 연결되어 있어야 합니다.
-
Copy - 클릭하면 현재 선택한 풋프린트의 세부 정보를 복사합니다.
-
Paste - 클릭하면 복사한 풋프린트 세부 정보를 현재 선택한 Schematic 컴포넌트에 붙여넣어 추가합니다.
-
Select All - 클릭하면 View and Edit Footprints 목록에 현재 표시된 모든 풋프린트를 선택합니다.
-
Set As Current - 클릭하면 선택한 풋프린트를 현재 풋프린트로 설정합니다(Current 열에
표시).
-
Add to All Parts - 클릭하면 선택한 풋프린트를 동일한 Schematic 컴포넌트의 다른 모든 파트에 추가합니다(선택한 컴포넌트가 멀티파트 컴포넌트이고, 컴포넌트 내 하나 이상의 파트에 이 풋프린트가 지정되어 있지 않은 경우에만 사용할 수 있는 명령입니다).
추가 컨트롤
-
Menu - 클릭하면 위의 마우스 오른쪽 버튼 클릭 메뉴와 동일한 컨트롤이 있는 메뉴가 표시됩니다.
-
Add, Remove, Edit, Validate - 이 버튼들은 위에서 설명한 메뉴 항목과 동일한 기능을 수행합니다.
-
Accept Changes (Create ECO) - 클릭하면 Schematic 컴포넌트와 연결된 풋프린트 모델의 변경 사항을 적용하고 Engineering Change Order 대화 상자를 실행합니다. ECO 대화 상자에서는 해당 Schematic 컴포넌트의 풋프린트 값 수정 사항을 검토한 후 변경 사항을 검증하고 실행할 수 있습니다.















