Working with Placed Components
W skrócie
- Dowiedz się, skąd pochodzą komponenty, jak obsługiwane są części i komponenty wieloczęściowe oraz jakie są główne sposoby umieszczania ich na schemacie.
- Zobacz, jak sprawniej wyszukiwać komponenty i szybko edytować je graficznie podczas umieszczania lub po jego zakończeniu.
- Poznaj powiązania między komponentami na schemacie a komponentami na PCB oraz najważniejsze właściwości, które możesz przeglądać lub edytować po ich umieszczeniu.
Komponent w bibliotece reprezentuje fizyczny element umieszczany na rzeczywistej płytce drukowanej. Na arkuszu schematu komponent jest reprezentowany przez model symbolu schematowego. Każdy komponent może zawierać jedną lub więcej części.
Część

Część reprezentuje rzeczywisty fizyczny element elektroniczny.
Podsumowanie
Część jest podstawowym obiektem projektu elektrycznego. Jest to symbol schematowy reprezentujący element elektroniczny, taki jak rezystor, przełącznik, wzmacniacz operacyjny, stabilizator napięcia itp. Części są przechowywane w komponentach w bibliotekach komponentów schematowych. Należy pamiętać, że każdy komponent może zawierać jedną lub więcej części. Oprócz symbolicznej reprezentacji komponentu część zawiera również łącza do modeli, takich jak obudowa PCB, a także parametry służące do dokumentowania szczegółów, takich jak parametry komponentu i informacje o dostawcach. Sposób dodawania łączy do modeli i parametrów do części zależy od używanego typu biblioteki.
Dostępność
Części można umieszczać zarówno w edytorze schematów, jak i w edytorze bibliotek schematowych.
- W edytorze schematów kliknij Place » Part.
- Kliknij prawym przyciskiem myszy w obszarze projektowym, a następnie wybierz Place » Part z menu kontekstowego.
- W panelu Components kliknij komponent prawym przyciskiem myszy i wybierz Place <ComponentName>.
- W panelu Components wybierz komponent ogólny jako element zastępczy.
- Przeciągnij i upuść komponent z panelu Components.
- Wybierz przycisk Place w sekcji Details panelu Components lub użyj skrótu klawiaturowego Enter.
- W edytorze bibliotek schematowych wybierz komponent w panelu SCH Library, a następnie kliknij Place.
Umieszczanie z panelu Components
W edytorze schematów wybór i umieszczanie części można przeprowadzić z poziomu panelu Components.
- Panel wyświetla zawartość aktualnie wybranej biblioteki. Użyj listy rozwijanej obok nazwy biblioteki, aby wybrać inną bibliotekę.
- Użyj pola maski poniżej pola aktualnie wybranej biblioteki, aby przefiltrować listę i przyspieszyć wyszukiwanie, lub przewiń listę i wybierz żądaną część.
- Kliknij Place, kliknij dwukrotnie lub kliknij i przeciągnij, aby umieścić wybrany komponent na aktywnym arkuszu schematu. Gdy część jest dołączona do kursora, przed umieszczeniem można ją obrócić (naciśnij Spacebar), odbić lustrzanie względem osi (naciśnij X lub Y) albo edytować (naciśnij Tab).
- Kolejność kolumn wyświetlanych na liście komponentów w aktualnie wybranej bibliotece można zmienić (klikając i przeciągając) lub można je ponownie skonfigurować (klikając prawym przyciskiem myszy, a następnie wybierając Select Columns).
-
Kliknij przycisk
na kafelku komponentu ogólnego, aby dołączyć komponent do kursora i umieścić go w aktywnym dokumencie schematu. Wybranie samego kafelka spowoduje otwarcie kategorii tego typu komponentów w panelu Components.
Wyszukiwanie komponentu
Opcje menu bibliotek spoza przestrzeni roboczej umożliwiają ustawianie preferencji, wyszukiwanie oraz migrację zawartości bibliotek bazodanowych i plikowych. Aby uzyskać dostęp do tych opcji, wybierz przycisk menu bibliotek
w prawym górnym rogu panelu Components.
Wybierz File-based Libraries Preferences, aby otworzyć okno dialogowe Available File-based Libraries, w którym dostępne są elementy sterujące umożliwiające dodawanie i usuwanie bibliotek, instalowanie bibliotek oraz określanie ścieżek ich wyszukiwania.
Bieżącą listę komponentów bibliotek bazodanowych i plikowych można filtrować, wpisując frazę wyszukiwania w polu Search panelu Components. Aby uzyskać dostęp do bardziej zaawansowanych funkcji wyszukiwania w bibliotekach komponentów, wybierz opcję File-based Libraries Search z menu
panelu (w prawym górnym rogu). Spowoduje to otwarcie okna dialogowego File-based Libraries Search. Okno to oferuje elastyczne opcje wyszukiwania, w tym ograniczenia filtrowania oparte na zapytaniach oraz możliwość przeszukiwania wszystkich dostępnych bibliotek bazodanowych i plikowych lub tylko tych znajdujących się we wskazanej ścieżce.
- Domyślne ustawienie wyszukiwania Scope polega na wyszukiwaniu Components w Available File-based Libraries.
- Okno dialogowe umożliwia również przeszukiwanie Libraries on path przechowywanych w folderach na dysku. W tym celu włącz opcję Libraries on path, a następnie odpowiednio skonfiguruj opcje Path.
- Filters korzystają z operatora „AND”, dlatego najlepiej zacząć od prostego filtra, a jeśli wyników jest dużo, użyć trybu Refine last search, aby przeszukać wyniki.
- Wyniki wyszukiwania za pomocą zapytania są wyświetlane w oknie dialogowym File-based Libraries Search po wybraniu Helper.
Umieszczanie z edytora bibliotek schematowych
Część można również umieścić bezpośrednio z biblioteki otwartej w edytorze bibliotek schematowych, korzystając z panelu SCH Library. Należy pamiętać, że:
- Kliknięcie przycisku Place w panelu spowoduje umieszczenie wybranej części (komponentu) na ostatnio aktywnym arkuszu schematu.
- Gdy część jest dołączona do kursora, przed umieszczeniem można ją obrócić (naciśnij Spacebar), odbić lustrzanie względem osi (naciśnij X lub Y) albo edytować (naciśnij Tab). Czynności te można również wykonywać podczas przeciągania obiektu. Obrót odbywa się w krokach co 90°.
-
Jeśli część jest umieszczana bezpośrednio z biblioteki, nie trzeba wcześniej dodawać tej biblioteki w oknie dialogowym Available File-based Libraries.
Edycja graficzna
Edycja graficzna części jest ograniczona do przesuwania, obracania i odbijania lustrzanego. Po zaznaczeniu części w obszarze projektowym pojawi się wokół niej przerywana ramka zaznaczenia. Aby graficznie zmodyfikować wybrany komponent:
- Naciśnij Delete, aby usunąć wybraną część z projektu.
- Kliknij i przytrzymaj przycisk myszy, aby przesunąć wybraną część. Kursor przeskoczy do najbliższego punktu połączenia elektrycznego (końca najbliższego pinu, do którego dołącza się przewód).
- Naciśnij Spacebar, aby obrócić łuk przeciwnie do ruchu wskazówek zegara, lub Shift+Spacebar, aby obrócić go zgodnie z ruchem wskazówek zegara. Czynność tę można również wykonać podczas przeciągania obiektu. Obrót odbywa się w krokach co 90°.
- Podczas przesuwania części dołączonej do kursora naciśnij klawisz X lub Y, aby odbić ją lustrzanie względem danej osi.
Praca z komponentem na schemacie i na PCB
Oprogramowanie zawiera narzędzia ułatwiające pracę z komponentem na schemacie i odpowiadającym mu komponentem na PCB. Należą do nich wskazywanie krzyżowe, zaznaczanie krzyżowe oraz wybieranie komponentów PCB ze schematu.
Wskazywanie krzyżowe
Jak sugeruje nazwa, wskazywanie krzyżowe pozwala kliknąć komponent w jednym edytorze i przejść do niego w drugim edytorze. Aby skorzystać ze wskazywania krzyżowego:
- Kliknij Cross Probe w menu Tools edytora schematów lub PCB.
- Po kliknięciu komponentu w edytorze schematów zostanie on wyśrodkowany i powiększony w edytorze PCB. Poziom powiększenia ustawia się na stronie System – Nawigacja w oknie dialogowym Preferences.
- Domyślnie aktywny pozostaje ten sam edytor, co pozwala wskazać kolejny komponent. Aby podczas wskazywania krzyżowego przejść do drugiego edytora, przytrzymaj klawisz Ctrl.
Tryb zaznaczania krzyżowego
Tryb zaznaczania krzyżowego zaznacza ten sam komponent w drugim edytorze. Nie powoduje jednak powiększenia ani wyśrodkowania widoku. Zaznaczanie krzyżowe może być włączone lub wyłączone. Kliknij Tools » Cross Select Mode, aby włączyć lub wyłączyć ten tryb. Aby zaznaczyć wiele komponentów, przytrzymaj klawisz Shift podczas ich klikania.
Wybieranie komponentów PCB
Ta funkcja pozwala zaznaczyć wiele komponentów na schemacie w określonej kolejności, a następnie rozmieścić te same komponenty w edytorze PCB w tej samej kolejności. Aby skorzystać z tej funkcji:
- Zaznaczaj kolejno komponenty na schemacie (przytrzymaj Shift podczas klikania, aby zaznaczyć wiele komponentów).
- Przejdź do edytora PCB, a następnie naciśnij skrót klawiaturowy I, C, aby uruchomić polecenie Reposition Selected Components. Polecenie Reposition Selected Components jest również dostępne w menu kontekstowym po naciśnięciu skrótu klawiaturowego I.
Właściwości części
Karta Ogólne
Ogólne
-
Reuse Block – jeśli komponent należy do bloku wielokrotnego użytku, to pole wyświetla nazwę nadrzędnego bloku wielokrotnego użytku. Kliknij hiperłącze Reuse Block, aby wyświetlić właściwości tego bloku.
-
Designator – wprowadź oznaczenie. Kliknij ikonę oka, aby wyświetlić lub ukryć oznaczenie. Użyj ikony kłódki, aby zablokować lub odblokować oznaczenie. Dowiedz się więcej o oznaczeniu.
-
Comment – wprowadź nazwę lub komentarz. Kliknij ikonę oka, aby wyświetlić lub ukryć nazwę. Użyj ikony kłódki, aby zablokować lub odblokować nazwę. Pole komentarza może również służyć do wyświetlania wartości parametru zdefiniowanego przez użytkownika lub parametru systemowego. Dowiedz się więcej o komentarzu.
-
Part <x> of Parts – wyświetla numer wybranej części oraz całkowitą liczbę części. Kliknij
, aby zablokować lub odblokować pola, a następnie wybierz numer odpowiedniej części z listy rozwijanej.
-
Description – opis komponentu/części.
-
Type – wybierz tutaj jeden z poniższych typów komponentu dla jego footprintu. Dostępne typy:
-
Standard– komponenty o standardowych właściwościach elektrycznych, które są zawsze synchronizowane między schematem a PCB (footprint, wyprowadzenia/pady i przypisania sieci muszą być zgodne) i są uwzględniane w zestawieniu BOM. Przykładem jest standardowy komponent elektryczny, taki jak rezystor. -
Mechanical– komponenty, które nie mają właściwości elektrycznych, nie są synchronizowane (trzeba je ręcznie umieścić w obu edytorach) i są uwzględniane w zestawieniu BOM. Przykładem jest radiator. -
Graphical– komponenty, które nie mają właściwości elektrycznych, nie są synchronizowane (trzeba je ręcznie umieścić w obu edytorach) i not są uwzględniane w zestawieniu BOM. Przykładem jest logo firmy. -
Net Tie (In BOM)– komponenty służące do zwierania dwóch lub większej liczby różnych sieci, które są zawsze synchronizowane między schematem a PCB (footprint, wyprowadzenia/pady i przypisania sieci muszą być zgodne) i są uwzględniane w zestawieniu BOM. Różnią się od komponentów standardowych tym, że połączenia utworzone przez miedź w obrębie footprintu nie są sprawdzane — to właśnie ta miedź umożliwia zwarcie sieci. Uwaga: włącz opcję Verify Shorting Copper w oknie dialogowym kontroli reguł projektowych, aby sprawdzić, czy w obrębie komponentu nie ma niepodłączonej miedzi. -
Net Tie (No BOM)– komponenty służące do zwierania dwóch lub większej liczby różnych sieci, które są zawsze synchronizowane między schematem a PCB (footprint, wyprowadzenia/pady i przypisania sieci muszą być zgodne) i not są uwzględniane w zestawieniu BOM. Różnią się od komponentów standardowych tym, że połączenia utworzone przez miedź w obrębie footprintu nie są sprawdzane — to właśnie ta miedź umożliwia zwarcie sieci. Uwaga: włącz opcję Verify Shorting Copper w oknie dialogowym kontroli reguł projektowych, aby sprawdzić, czy w obrębie komponentu nie ma niepodłączonej miedzi. -
Standard (No BOM)– komponenty o standardowych właściwościach elektrycznych, które są zawsze synchronizowane między schematem a PCB (footprint, wyprowadzenia/pady i przypisania sieci muszą być zgodne) i not są uwzględniane w zestawieniu BOM. Przykładem jest komponent punktu testowego, który chcesz wykluczyć z zestawienia BOM. -
Jumper– komponenty służące do dodawania zwór drutowych do projektu PCB, na przykład na jednostronnej płytce PCB, na której nie można poprowadzić wszystkich połączeń na jednej warstwie. W przypadku tego typu komponentu footprint i wyprowadzenia są synchronizowane między schematem a PCB, ale przypisania sieci nie są synchronizowane, a komponent jest uwzględniany w zestawieniu BOM. Oprócz wybrania tej opcji na poziomie komponentu należy ustawić dla obu jego padów tę samą niezerową wartość JumperID. Komponenty typu zwora nie wymagają podłączania przewodami na schemacie; muszą się na nim znajdować tylko wtedy, gdy mają być uwzględnione w zestawieniu BOM. Jeśli nie są wymagane w zestawieniu BOM, można je umieścić bezpośrednio na PCB, gdzie ustawia się Component Type oraz JumperIDs, a następnie ręcznie przypisuje Nets do padów.
-
-
Design Item ID – to pole wyświetla nazwę wybranego komponentu (w przypadku komponentu z przestrzeni roboczej) lub wybrane pole kluczowe zdefiniowane w Field Settings obszarze pliku DbLib/SVNDbLib (w przypadku komponentu z biblioteki bazodanowej) lub parametrze Design Item ID zdefiniowanym dla symbolu komponentu (w przypadku komponentu z biblioteki opartej na plikach). Kliknij
, aby otworzyć okno dialogowe Zastąp komponent. Okno to zapewnia między innymi dostęp do pełnych informacji o wybranym komponencie (parametrów, modeli, wybranych części, danych dostawców itp.), porównywania komponentów oraz możliwości zastąpienia bieżącego komponentu innym. Jeśli jako zamiennik zostanie wybrany inny komponent, w tym polu zostanie wyświetlony pełny Design Item ID nowo wybranego komponentu. Kliknij przycisk Validate , aby wyświetlić informacje o lokalizacji komponentu. Jeśli komponent nie pochodzi z przestrzeni roboczej, pojawi się ścieżka do pliku, w którym jest zapisany na komputerze. Jeśli komponent pochodzi z przestrzeni roboczej, pojawi się jedynie informacja o jego znalezieniu.
-
Source – wyświetla nazwę biblioteki źródłowej komponentu. Kliknij
, aby wyszukać i wybrać odpowiednią bibliotekę.
-
Revision state – to pole wyświetla bieżący stan cyklu życia wybranej rewizji komponentu wraz z kolorową ikoną i nazwą stanu rewizji.
-
Revision status – jeśli wybrana rewizja komponentu jest w stanie dopuszczającym jej użycie w projektach, wpis wskazuje, czy rewizja jest najnowsza (
Up to date), czy nie (Out of date). Jeśli rewizja jest w stanie niedopuszczającym jej użycia w projektach, wpis wyświetlaNot applicable. Kliknij przycisk
, aby zaktualizować komponent do najnowszej rewizji.
-
Component issues (tylko panel Properties) – jeśli wybrany komponent pochodzący z połączonej przestrzeni roboczej Altium 365 ma jakiekolwiek problemy z kondycją, zostaną one zasygnalizowane ikoną
(w przypadku błędów) lub
(w przypadku błędów krytycznych). Liczba po prawej stronie ikony wskazuje liczbę znalezionych problemów. Kliknij strzałkę w dół po prawej stronie liczby, aby wyświetlić krótkie opisy problemów.

Przykład wykrytych problemów z kondycją biblioteki. -
Supply Chain Data (tylko panel Properties) – wyświetla informacje o łańcuchu dostaw dla powiązanej wybranej części:
- Mediana ceny jednostkowej. Ten wpis będzie wyświetlany na czerwono, jeśli brak cen lub cena = 0.
- Stan magazynowy. Ten wpis wyświetla łączny stan magazynowy u dostawców włączonych w ramach źródła Altium Parts Provider dla przestrzeni roboczej.
-
Pasek cyklu życia producenta. Najedź kursorem na pasek, aby wyświetlić podpowiedź z informacjami. Może on wskazywać jeden z czterech stanów:
- Biały/szary = domyślny, nieznany lub brak informacji
- Zielony = nowy lub w produkcji seryjnej
- Pomarańczowy = niezalecany do nowych projektów
- Czerwony = wycofany lub koniec cyklu życia (EOL)
Położenie
-
(X/Y)
- X (pierwsze pole) – bieżąca współrzędna X (pozioma) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych obszaru projektowego. Edytuj ją, aby zmienić położenie obiektu w osi X. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli używasz jednostek innych niż bieżące domyślne, podaj je przy wprowadzaniu wartości.
- Y (drugie pole) – bieżąca współrzędna Y (pionowa) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych. Edytuj ją, aby zmienić położenie obiektu w osi Y. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli używasz jednostek innych niż bieżące domyślne, podaj je przy wprowadzaniu wartości.
-
Rotation – użyj listy rozwijanej, aby wybrać obrót. Dostępne opcje to
0 Degrees,90 Degrees,180 Degreesi270 Degrees.
Parametry
-
Grid – wyświetla Name i Value parametrów powiązanych z aktualnie wybranym komponentem. Użyj
, aby zablokować/odblokować parametr na liście i zapobiec jego aktualizacji. Wartości parametrów można wprowadzać ręcznie lub wybierać z listy rozwijanej zawierającej wartości pochodzące ze wszystkich dostępnych komponentów danego typu. Klikając ikonę oka, można pokazać/ukryć parametr.
-
Favorites – parametry oznaczone jako ulubione będą wyświetlane na liście parametrów, a pozostałe będą ukryte. Najedź kursorem na obszar po prawej stronie nazwy filtra parametrów i kliknij ikonę
, aby oznaczyć filtr jako ulubiony. Aby usunąć parametr z ulubionych, kliknij tę ikonę ponownie.
Aby zobaczyć wszystkie ukryte parametry, kliknij element sterujący Show More u dołu listy. Kliknij element sterujący Show Less, aby wyświetlić tylko ulubione parametry.
-
Font – kliknij wyświetlaną czcionkę, aby zmienić jej styl.
-
Other – kliknij, aby otworzyć listę rozwijaną i zmienić dodatkowe opcje:
- Show Parameter Name – włącz, aby wyświetlić nazwę parametru.
- Allow Synchronization with Database – włącz, aby synchronizować z bazą danych. Ta opcja określa, czy komentarz może być aktualizowany. Domyślnie opcje te są włączone, aby zawsze umożliwiać synchronizację ze źródłową biblioteką/bazą danych. Możesz wyłączyć tę opcję, aby dany komentarz nie był uwzględniany w procesie aktualizacji.
- (X/Y) – wprowadź współrzędne X i Y.
-
Rotation – użyj listy rozwijanej, aby wybrać kąt obrotu. Dostępne opcje to:
0°,90°,180°i270°. - Autoposition – zaznacz, aby włączyć automatyczne pozycjonowanie, co oznacza, że parametr jest pozycjonowany automatycznie przy każdym obrocie powiązanego komponentu. Wyłącz tę opcję, aby podczas obracania komponentu zachować położenie parametru względem niego.
-
Add – kliknij, aby dodać parametr, na przykład obudowę PCB, model lub regułę. Kliknij
, aby usunąć wybrany wpis z tabeli. Kliknij
, aby edytować parametr w odpowiednim dla niego oknie dialogowym.
Grafika
-
Mode – użyj listy rozwijanej, aby wybrać żądany tryb. Jeśli nie są dostępne żadne tryby poza Normal, ta lista rozwijana będzie nieaktywna.
- Mirrored – włącz, aby utworzyć lustrzane odbicie części.
- Local Colors – włącz opcję kolorów lokalnych, aby kolory wypełnienia, linii i wyprowadzeń komponentu schematu zostały zastąpione kolorami odpowiednio z pól kolorów Fill, Lines i Pins. Wyłącz tę opcję, aby używać kolorów zdefiniowanych w bibliotece.
Warianty części
Ta sekcja zawiera informacje o wariantach części i łączach do dostawców przypisanych do wybranego komponentu. Więcej informacji o danych prezentowanych we wpisach w tej sekcji znajdziesz na stronie Dodawanie informacji o łańcuchu dostaw do komponentu.
Karta wyprowadzeń
-
Grid – ta sekcja zawiera listę Pins i Names dla wszystkich wyprowadzeń wybranego komponentu. Użyj ikony oka, aby pokazać/ukryć wyprowadzenie. Użyj ikony kłódki, aby zablokować/odblokować wyprowadzenia.
W przypadku wyprowadzenia wielofunkcyjnego (wyprowadzenia, którego funkcje określono w polu Functions w trybie Pins panelu Properties) kliknij komórkę tego wyprowadzenia w kolumnie Name i wybierz jego funkcję z wyświetlonej listy rozwijanej. Wybrana funkcja będzie wyświetlana jako nazwa wyprowadzenia na arkuszu schematu.
- Show Full/Show Short – w Show Full wyświetlane są pełne rozszerzone nazwy wszystkich wyprowadzeń na liście; w trybie Show Short wyświetlana jest bieżąca nazwa wyprowadzenia.
-
– gdy przycisk jest włączony (ikona zamkniętej kłódki), wyprowadzeń komponentu nie można edytować w edytorze schematów (ale można je edytować w edytorze bibliotek schematowych). Wyłącz tę opcję, aby edytować wyprowadzenie komponentu na arkuszu schematu.
-
– kliknij, aby wyświetlić wszystkie ukryte wyprowadzenia i ich właściwości (nazwy i numery), w tym wyprowadzenia z wyłączoną właściwością Show w edytorze wyprowadzeń komponentu. Pamiętaj, że podczas pracy w edytorze bibliotek schematowych opcja View » Show Hidden Pins również musi być włączona, aby ukryte wyprowadzenia były w nim wyświetlane.
-
– kliknij, aby dodać wyprowadzenie do komponentu. Skonfiguruj wyprowadzenie w panelu Properties, a następnie kliknij i przeciągnij, aby je ustawić.
-
– kliknij, aby usunąć zaznaczone wyprowadzenia z komponentu.
-
– kliknij, aby otworzyć okno dialogowe edytora wyprowadzeń komponentu. Okno to umożliwia wygodne przeglądanie i edytowanie wszystkich wyprowadzeń komponentu aktualnie otwartego w edytorze bibliotek schematowych lub zaznaczonego komponentu (bądź jego części) w edytorze schematów.
Właściwości komponentu ogólnego
Komponenty ogólne

Umieszczanie komponentu ogólnego z panelu Components
Gdy Altium Designer jest połączony z przestrzenią roboczą, dostęp do komponentów ogólnych można uzyskać z panelu Components, w którym są one widoczne po wybraniu opcji All w obszarze Categories – lub z górnego menu rozwijanego, gdy panel działa w trybie kompaktowym. Kliknij przycisk
na kafelku komponentu ogólnego, aby dołączyć komponent do kursora i umieścić go na aktywnym schemacie. Wybranie samego kafelka otworzy kategorię danego typu komponentu w panelu Components.
Właściwości komponentu ogólnego
Ogólne
- Designator – wprowadź oznaczenie. Przełącz ikonę oka, aby pokazać lub ukryć oznaczenie. Kliknij ikonę kłódki, aby zablokować lub odblokować oznaczenie.
- Comment – wprowadź nazwę. Przełącz ikonę oka, aby pokazać lub ukryć nazwę.
-
Description – opis komponentu ogólnego/części.
- Replace – wybierz przycisk Replace, gdy projekt osiągnie etap, na którym komponent ogólny można zastąpić konkretnym komponentem fizycznym za pomocą okna dialogowego zastępowania komponentu.
Położenie
-
(X/Y)
- X (pierwsze pole) – bieżąca współrzędna X (pozioma) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych obszaru projektowego. Edytuj ją, aby zmienić położenie obiektu w osi X. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; podaj jednostkę, jeśli wprowadzana wartość jest wyrażona w jednostkach innych niż aktualnie domyślne.
- Y (drugie pole) – bieżąca współrzędna Y (pionowa) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych. Edytuj ją, aby zmienić położenie obiektu w osi Y. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; podaj jednostkę, jeśli wprowadzana wartość jest wyrażona w jednostkach innych niż aktualnie domyślne.
- Rotation – użyj listy rozwijanej, aby wybrać kąt obrotu.
Parametry
- Grid – lista Name i Value parametrów powiązanych z aktualnie zaznaczonym komponentem. Użyj ikony kłódki, aby zablokować lub odblokować parametr na liście. Wartości parametrów można wprowadzać ręcznie lub wybierać z listy rozwijanej zawierającej wartości pochodzące ze wszystkich dostępnych komponentów danego typu. Użyj ikony oka, aby pokazać lub ukryć parametr.
- Font – kliknij wyświetlaną czcionkę, aby zmienić jej styl.
-
Other – kliknij, aby otworzyć listę rozwijaną umożliwiającą zmianę dodatkowych opcji:
- Show Parameter Name – włącz, aby wyświetlać nazwę parametru.
- Allow Synchronization with Database – włącz, aby synchronizować z bazą danych. Ta opcja określa, czy komentarz może być aktualizowany. Domyślnie opcje te są włączone, aby zawsze umożliwiać synchronizację z biblioteką źródłową lub bazą danych. Możesz wyłączyć tę opcję, aby wykluczyć dany komentarz z procesu aktualizacji.
- (X/Y) – wprowadź współrzędne X i Y.
- Rotation – użyj listy rozwijanej, aby wybrać kąt obrotu.
- Autoposition – zaznacz, aby włączyć automatyczne pozycjonowanie, co oznacza, że parametr jest ustawiany automatycznie przy każdym obrocie powiązanego komponentu. Wyłącz tę opcję, aby podczas obrotu komponentu zachować położenie parametru względem niego.
Oznaczenie
Oznaczenie jednoznacznie identyfikuje każdy komponent w projekcie.
Podsumowanie
Pole oznaczenia jest podrzędnym obiektem parametru komponentu schematowego (części). Służy do jednoznacznej identyfikacji każdej umieszczonej części, aby odróżnić ją od wszystkich pozostałych części umieszczonych na wszystkich arkuszach schematu w projekcie.
Dostępność i umieszczanie
Oznaczenie jest umieszczane automatycznie wraz z nadrzędnym obiektem części komponentu. Nie jest to obiekt projektowy, który można umieścić bezpośrednio.
Edycja graficzna
Tekst oznaczenia można edytować graficznie za pomocą tak zwanej edycji in-place. Aby edytować tekst oznaczenia bezpośrednio w miejscu jego wyświetlania, zaznacz oznaczenie, przeciągając wokół niego kursor, a następnie naciśnij Enter.

Przykład edycji w miejscu
Po zakończeniu edycji naciśnij Enter lub kliknij poza tekstem, aby wyjść z trybu edycji w miejscu.
Edycja niegraficzna
W odniesieniu do edycji oznaczenia należy rozpatrzyć dwa aspekty: edycję wartości oznaczenia i edycję właściwości jego wyświetlania.
Ciągi tekstowe oznaczenia (i komentarza) można wyświetlić w edytorze bibliotek schematów, a następnie kliknąć je dwukrotnie, aby edytować ich właściwości. Ikona
powiązana z polem w panelu Properties służy do wyświetlania lub ukrywania oznaczenia.
Edycja wartości oznaczenia w edytorze schematów
Oznaczenie można zdefiniować w edytorze schematów podczas umieszczania elementu lub po umieszczeniu go na arkuszu schematu w Properties panel.
- Aby edytować oznaczenie podczas umieszczania elementu, naciśnij klawisz Tab, gdy element jest dołączony do kursora. Otworzy się panel Properties ; wprowadź wymagany ciąg oznaczenia. Kliknij przycisk wstrzymania nałożony na obszar projektowy , aby wznowić umieszczanie.
- Kontynuuj umieszczanie elementów lub naciśnij Esc, aby zakończyć umieszczanie.
- Naciśnij Spacebar, aby obrócić łuk przeciwnie do ruchu wskazówek zegara, lub Shift+Spacebar, aby obrócić go zgodnie z ruchem wskazówek zegara. Czynność tę można również wykonać podczas przeciągania obiektu. Obrót odbywa się w krokach co 90°.
- Aby edytować oznaczenie po umieszczeniu elementu, kliknij dwukrotnie umieszczony element, aby otworzyć panel Właściwości , w którym można edytować oznaczenie.
Edycja właściwości wyświetlania oznaczenia
Wygląd ciągu oznaczenia, w tym krój, rozmiar i kolor czcionki, można skonfigurować na stronie Schemat — Ustawienia domyślne w oknie dialogowym Preferences. Ustawienia te będą obowiązywać, o ile nie zostaną zastąpione ustawieniami zdefiniowanymi w symbolu elementu w edytorze bibliotek schematów.
Ustalanie położenia ciągu oznaczenia
Domyślnie oznaczenie jest pozycjonowane automatycznie podczas obracania elementu w trakcie umieszczania. Jeśli takie zachowanie nie jest wymagane, wyłącz opcję Autoposition w oknie dialogowym Preferences (patrz poprzednia ilustracja) podczas tworzenia symbolu lub po umieszczeniu elementu na arkuszu schematu. Spowoduje to sklasyfikowanie tego parametru jako manual parameter (czyli parametru pozycjonowanego ręcznie). Parametry pozycjonowane ręcznie są oznaczone kropką w lewym dolnym rogu ramki zaznaczenia.
Uwagi
-
Edytor schematów udostępnia prostą funkcję automatycznego zwiększania numeru oznaczenia, z której można korzystać podczas umieszczania wielu wystąpień tego samego elementu. Aby z niej skorzystać, naciśnij Tab, gdy pierwszy element jest dołączony do kursora, i wprowadź odpowiednie oznaczenie, na przykład
R1. Kolejnym elementom zostaną nadane oznaczeniaR2,R3itd. Pamiętaj, że po przejściu do umieszczania innego typu elementu należy ponownie nacisnąć Tab i wprowadzić odpowiedni prefiks oznaczenia. -
Podczas umieszczania elementów wieloczęściowych, jeśli początkowe oznaczenie zostanie przypisane w opisany wyżej sposób, automatycznie zostanie dodany przyrostek części, na przykład
U3A,U3Bitd. Jeśli początkowe oznaczenie nie zostanie przypisane, wszystkie części będą miały ten sam przyrostek. Problem ten rozwiązuje polecenie Annotation edytora schematów. Przyrostek części może być literowy lub liczbowy. Aby go skonfigurować, użyj opcji Alpha Numeric Suffix na stronie Schemat — Ogólne w oknie dialogowym Preferences.
Właściwości oznaczenia
Położenie
-
(X/Y)
- X (pierwsze pole) — bieżąca współrzędna X (pozioma) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych obszaru roboczego. Edytuj ją, aby zmienić położenie obiektu w osi X. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; podaj jednostkę, jeśli jest inna niż aktualnie domyślna.
- Y (drugie pole) — bieżąca współrzędna Y (pionowa) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych. Edytuj ją, aby zmienić położenie obiektu w osi Y. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; podaj jednostkę, jeśli jest inna niż aktualnie domyślna.
- Rotation — użyj listy rozwijanej, aby wybrać kąt obrotu.
Właściwości
- Object — wyświetla powiązany obiekt.
- Nazwa — włącz to pole, klikając ikonę widoczności , aby dodać prefiks „Designator:” do samej wartości oznaczenia. Pozwala to wizualnie wyróżnić wartość tekstową i potwierdzić, że jest ona oznaczeniem w dokumencie schematu.
-
Value — wyświetla samą nazwę oznaczenia. Kliknij ikonę oka
, aby wyświetlić lub ukryć wartość.
- Automatyczne pozycjonowanie — zaznacz, aby włączyć automatyczne pozycjonowanie, dzięki któremu tekst pozostanie w wybranym położeniu podczas przesuwania i obracania elementu.
- Zablokuj parametr — zaznacz, aby zablokować parametr, co uniemożliwi edytowanie jego wartości z poziomu panelu Properties lub dokumentu schematu.
- Zezwalaj na synchronizację z bazą danych — włącz, aby umożliwić synchronizację z bazą danych. Ta opcja określa, czy komentarz może być aktualizowany. Domyślnie opcje te są włączone, aby zawsze zezwalać na synchronizację ze źródłową biblioteką lub bazą danych. Możesz wyłączyć tę opcję, aby wykluczyć dany komentarz z procesu aktualizacji.
- Czcionka — użyj dostępnych elementów sterujących, aby wybrać krój, rozmiar i kolor czcionki oraz nadać jej dodatkowe atrybuty, takie jak pogrubienie, kursywa i podkreślenie.
- Wyrównanie — klikaj strzałki, aby skonfigurować wyrównanie tekstu, lub kółko, aby go wyśrodkować.
- Override Library Primitive (tylko okno dialogowe Preferences ) — zaznacz to pole wyboru, aby zastąpić ustawienia obiektu podstawowego zdefiniowane dla oznaczenia w bibliotece. Dzięki temu umieszczany element przyjmie ustawienia obiektu podstawowego określone w oknie dialogowym Preferencje zamiast ustawień zdefiniowanych dla tego elementu w bibliotece.
Komentarz
Komentarz umożliwia wyświetlanie dodatkowych informacji o elemencie.
Podsumowanie
Pole komentarza jest podrzędnym obiektem parametru elementu schematowego (części). Wyświetla dodatkowe informacje o elemencie.
Dostępność i umieszczanie
Komentarz jest konfigurowany podczas umieszczania nadrzędnego obiektu części elementu. Nie jest obiektem projektowym, który można umieścić bezpośrednio.
Edycja graficzna
Komentarz można edytować graficznie za pomocą tzw. edycji in-place. Aby edytować komentarz w miejscu, kliknij go raz, aby go zaznaczyć, odczekaj sekundę, a następnie kliknij ponownie, aby przejść do trybu edycji.
Kliknij raz, aby zaznaczyć tekst.
Po zakończeniu edycji naciśnij Enter lub kliknij poza tekstem, aby wyjść z trybu edycji w miejscu.
Edycja niegraficzna
Podczas edycji komentarza należy uwzględnić dwa aspekty: edycję jego wartości oraz edycję właściwości jego wyświetlania.
Edycja komentarza w edytorze schematów
Komentarz można zdefiniować w edytorze schematów podczas umieszczania komponentu lub po umieszczeniu go na arkuszu schematu, w polu Comment panelu Properties.
- Aby edytować komentarz podczas umieszczania komponentu, naciśnij klawisz Tab, gdy komponent jest dołączony do kursora. Otworzy się panel Properties ; wprowadź żądany komentarz. Kliknij przycisk pauzy wyświetlany nad obszarem projektowym , aby wznowić umieszczanie komponentu.
- Kontynuuj umieszczanie komponentów lub naciśnij Esc, aby je zakończyć.
- Aby edytować komentarz po umieszczeniu komponentu, kliknij dwukrotnie umieszczony komponent, aby otworzyć panel Właściwości , w którym można edytować komentarz.
Edycja właściwości wyświetlania komentarza
Wygląd komentarzy, w tym typ, rozmiar i kolor czcionki, można skonfigurować na stronie Schemat – Ustawienia domyślne w oknie dialogowym Preferences .
Ustalanie położenia komentarza
Domyślnie położenie komentarza jest ustalane automatycznie podczas obracania komponentu w trakcie jego umieszczania. Jeśli takie zachowanie nie jest wymagane, wyłącz opcję Autoposition w oknie dialogowym Preferences (patrz poprzedni obraz) podczas tworzenia symbolu lub po umieszczeniu komponentu na arkuszu schematu. Należy pamiętać, że spowoduje to sklasyfikowanie tego parametru jako manual parameter (czyli parametru o położeniu ustalanym ręcznie). Parametry ręczne są oznaczane kropką w lewym dolnym rogu ramki zaznaczenia.
Właściwości komentarza
Położenie
-
(X/Y)
- X (pierwsze pole) – bieżąca współrzędna X (pozioma) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych obszaru projektowego. Zmień tę wartość, aby zmienić położenie obiektu w osi X. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli używasz jednostek innych niż aktualnie domyślne, podaj je wraz z wartością.
- Y (drugie pole) – bieżąca współrzędna Y (pionowa) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych. Zmień tę wartość, aby zmienić położenie obiektu w osi Y. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli używasz jednostek innych niż aktualnie domyślne, podaj je wraz z wartością.
- Rotation – wybierz kąt obrotu z listy rozwijanej. Dostępne opcje to: 0 Degrees, 90 Degrees, 180 Degrees i 270 Degrees.
Właściwości
- Komponent – wyświetla nazwę powiązanego komponentu. Kliknij łącze Component , aby otworzyć panel Właściwości części, w którym można edytować opcje komponentu, a także sam komentarz, zdefiniowany w polu Comment tego panelu.
- Nazwa – włącz to pole, klikając ikonę widoczności , aby dodać prefiks „Comment:” do wartości komentarza. Pozwala to wizualnie wyróżnić tekst i potwierdzić, że jest on komentarzem w dokumencie schematu.
-
Wartość – wyświetla treść komentarza. Przełącz , aby pokazać lub ukryć wartość.
- Automatyczne pozycjonowanie – zaznacz, aby włączyć automatyczne pozycjonowanie, dzięki któremu tekst pozostanie w wybranym położeniu względem komponentu podczas jego przesuwania i obracania.
- Zablokuj parametr – zaznacz, aby zablokować parametr, co uniemożliwi edycję jego wartości w panelu Properties lub w dokumencie schematu.
- Zezwalaj na synchronizację z bazą danych – włącz, aby umożliwić synchronizację z bazą danych. Ta opcja określa, czy komentarz może być aktualizowany. Domyślnie jest włączona, aby zawsze zezwalać na synchronizację z biblioteką źródłową lub bazą danych. Można ją wyłączyć, aby wykluczyć komentarz z procesu aktualizacji.
- Czcionka – za pomocą dostępnych elementów sterujących wybierz czcionkę, jej rozmiar i kolor oraz dodaj żądane style, takie jak pogrubienie, kursywa i podkreślenie.
- Wyrównanie – kliknij strzałki, aby ustawić wyrównanie tekstu, lub kółko, aby go wyśrodkować.
- Override Library Primitive (tylko okno dialogowe Preferences ) – zaznacz to pole wyboru, aby zastąpić ustawienia obiektu podstawowego zdefiniowane dla komentarza w bibliotece. Dzięki temu po umieszczeniu komponentu zostaną zastosowane ustawienia obiektu podstawowego określone w oknie dialogowym Preferences, a nie ustawienia zdefiniowane dla komponentu w bibliotece.
Aktualizowanie i zastępowanie komponentów z biblioteki
Po wstępnym umieszczeniu komponentów na arkuszach schematu projektu płytki potrzebny jest sposób aktualizowania tych instancji komponentów, aby uwzględniały wszelkie zmiany w powiązanych komponentach źródłowych w odpowiednim obszarze roboczym. Innymi słowy, potrzebny jest mechanizm utrzymywania synchronizacji projektu z wykorzystywanymi przez niego obiektami obszaru roboczego.
Na przykład komponent mógł zostać ponownie zapisany w obszarze roboczym, choćby w związku ze zmianą powiązanego modelu podrzędnego. Powoduje to utworzenie nowej rewizji tego komponentu. Umieszczona instancja komponentu korzysta teraz ze starszej rewizji i można ją zaktualizować, aby zamiast niej używała najnowszej. Możliwe też, że podjęto decyzję o użyciu zupełnie innego komponentu i wystarczy zastąpić istniejący komponent w projekcie innym.
Dostępne są różne metody zarządzania komponentami po ich początkowym umieszczeniu w projekcie.
Zmiana pojedynczej instancji komponentu
Każdy umieszczony komponent jest powiązany z rewizją komponentu w przestrzeni roboczej. Informacje te można znaleźć w panelu Properties podczas przeglądania właściwości wybranego komponentu.
Każda umieszczona instancja komponentu jest powiązana z konkretną rewizją tego komponentu w przestrzeni roboczej.
Na tym najniższym poziomie, dotyczącym pojedynczego komponentu, umieszczoną instancję można:
-
Zaktualizować do najnowszej rewizji istniejącego komponentu, klikając przycisk
.
Przykład aktualizacji tego samego komponentu do najnowszej rewizji — najedź kursorem na obraz, aby zobaczyć wynik.
-
Zastąpić najnowszą rewizją innego komponentu (zamiennika) z przestrzeni roboczej lub komponentem z biblioteki plikowej, klikając przycisk
po prawej stronie pola Design Item ID. Otworzy się okno dialogowe Replace Component z komponentami z połączonej przestrzeni roboczej oraz dostępnych bibliotek plikowych. Bieżący komponent jest wyświetlany na początku listy. Wyszukaj odpowiedni komponent zastępczy, zaznacz go, a następnie kliknij OK.
Przykład zastąpienia istniejącego komponentu innym (alternatywnym)
Okno dialogowe Replace Component zapewnia bezpośredni dostęp do wszystkich dostępnych komponentów z bibliotek przestrzeni roboczej oraz bibliotek plikowych. Udostępnia pełne informacje o wybranym komponencie (parametry, modele, warianty części, dane dostawców itp.), porównywanie komponentów, a w przypadku komponentów bibliotek przestrzeni roboczej — wyszukiwanie parametryczne oparte na filtrach, umożliwiające określenie docelowych parametrów komponentu.
Opcje i elementy sterujące okna dialogowego Replace Component
- Search - użyj pola wyszukiwania tekstowego, aby ręcznie wyszukać określony komponent.
-
- kliknij, aby rozwinąć lub zwinąć Categories panel i wyświetlić określone typy komponentów lub wszystkie dostępne komponenty. Użyj paska wyszukiwania pod panelem Categories, aby ręcznie wyszukać określoną kategorię komponentów lub dostępną bibliotekę plikową komponentów.
-
- kliknij, aby otworzyć menu i wybrać jedną z opcji:
- File-based Libraries Preferences - kliknij, aby otworzyć okno dialogowe Available File-based Libraries i dodać lub usunąć biblioteki.
- File-based Libraries Search - kliknij, aby otworzyć okno dialogowe File-based Libraries Search i wyszukać biblioteki.
- Refresh - kliknij, aby odświeżyć okno dialogowe.
-
- kliknij, aby otworzyć lub zamknąć Details sekcję okna dialogowego (opisaną poniżej).
Filtry
Po wybraniu kategorii komponentów przestrzeni roboczej kliknij ikonę Filters , aby otworzyć sekcję Filters, w której można dodatkowo filtrować kategorie wybrane na liście Components . Opcje Filters panelu można dostosować do własnych potrzeb, wybierając określone typy parametrów jako Favorites. Zostaną one przeniesione na początek listy dla bieżącej kategorii komponentów. Najedź kursorem na obszar po prawej stronie nazwy filtra parametru i kliknij ikonę , aby oznaczyć filtr jako ulubiony. Ustawienia ulubionych filtrów mają zastosowanie do poszczególnych Categories komponentów i są dla nich zapisywane.
Komponenty
- Name - nazwa komponentu.
- Description - opis każdego komponentu.
- Footprint - obudowa PCB komponentu.
- Results - łączna liczba komponentów znalezionych lub wyświetlonych w wynikach wyszukiwania.
Szczegóły
- Component Revision ID - identyfikator rewizji i cena danego komponentu. Kliknij identyfikator rewizji, aby otworzyć panel Explorer i uzyskać dodatkowe informacje o komponencie.
- References - kliknij, aby otworzyć informacje referencyjne dotyczące komponentu w przeglądarce internetowej. Użyj listy rozwijanej, aby uzyskać dostęp do Manufacturer URL lub Datasheet.
- Place - kliknij, aby umieścić wybrany komponent w dokumencie schematu.
- Component information - istotne informacje o komponencie, w tym producent, data wydania i opis. Kliknij łącze Show More , aby wyświetlić wszystkie informacje; kliknij Show Less , aby je zwinąć.
- Models - rozwiń, aby wyświetlić udostępnione modele. Użyj dostępnych łączy, aby wyświetlić różne części pojedynczego modelu.
- References - rozwiń, aby uzyskać dostęp do Manufacturer URL, Datasheet i Package Specification.
- Part Choices - rozwiń, aby wyświetlić warianty części. Dostępne są nazwa, cena i opis. Wyświetlana jest również karta katalogowa komponentu.
- Where Used - rozwiń, aby wyświetlić projekty wykorzystujące dany komponent.
Menu kontekstowe
- Find Similar Components - kliknij, aby otworzyć okno dialogowe Find Similar Components, w którym można wyszukać inne komponenty o podobnych właściwościach.
- Place <component> - kliknij, aby umieścić komponent w odpowiednim dokumencie.
- Edit - kliknij, aby otworzyć dokumenty biblioteki komponentów dla wybranego komponentu.
- Navigate to <revision> - kliknij, aby otworzyć wybrany komponent w panelu Explorer.
- Operations - najedź kursorem, aby uzyskać dostęp do opcji Submit Request, Create, Download, Clone, Change Component Type, Create / Edit PCL i Full Item History.
- Refresh- kliknij, aby odświeżyć widok i zobaczyć najnowsze aktualizacje lub zmiany. Widok można również odświeżyć za pomocą skrótu F5.
- Library Report - gdy w panelu Categories wybrana jest biblioteka plikowa, kliknij, aby otworzyć okno dialogowe Library Report Settings, w którym można skonfigurować raport biblioteki za pomocą dostępnych elementów sterujących.
Wprowadzanie zbiorczych zmian komponentów — Item Manager
Related page: Zarządzanie zawartością za pomocą Item Manager
Zmiana pojedynczego komponentu jest wygodna, ale przy większej liczbie komponentów szybko staje się uciążliwa. Potrzebne jest wtedy jedno centralne miejsce umożliwiające zbiorcze wprowadzanie wielu zmian. Do tego służy Item Manager (Tools » Item Manager).
Item Manager to „centrum dowodzenia” służące do synchronizacji obiektów projektowych Workspace umieszczonych na arkuszach schematu z powiązanymi z nimi danymi źródłowymi w Workspace. Automatycznie wykrywa i wyświetla wszystkie komponenty, wskazując, czy są one obiektami Workspace, a następnie porównuje rewizję elementu każdego komponentu Workspace na schematach z dostępnymi rewizjami tego komponentu w Workspace. Dla każdego obiektu podawane są informacje o aktualnie powiązanym elemencie: jego rewizji, stanie cyklu życia oraz źródłowym Workspace, w którym się znajduje.
Masz pełną kontrolę nad tym, które z tych obiektów Workspace zostaną zaktualizowane i w jaki sposób. Na przykład:
- Wybierz pojedynczą pozycję i zaktualizuj ją tak, aby korzystała z najnowszej rewizji powiązanego elementu, lub wybierz najnowszą rewizję zupełnie innego elementu.
- Wybierz grupę pozycji korzystających z tego samego powiązanego elementu i zaktualizuj je do najnowszej rewizji tego elementu albo wybierz najnowszą rewizję zupełnie innego elementu.
Wszystkie proponowane zmiany są odzwierciedlane w menedżerze.
Po skonfigurowaniu zmian zgodnie z wymaganiami wygeneruj zlecenie zmiany inżynierskiej (ECO) i przejrzyj operacje, które zostaną wykonane w celu ich wprowadzenia. W razie potrzeby wyłącz wybrane operacje — zawsze masz pełną kontrolę! Gdy wszystko będzie gotowe, wykonaj ECO, aby zastosować zmiany. Zarządzanie umieszczonymi w projekcie danymi Workspace jest szybkie, sprawne i niezwykle proste.
Poniższe przykłady ilustrują zastosowanie Item Manager:
- Aktualizacja wielu komponentów tak, aby korzystały z najnowszej rewizji istniejącego komponentu Workspace.

Zaktualizuj grupę nieaktualnych komponentów do ich najnowszych rewizji.
- Zamiana kilku komponentów na najnowszą rewizję innego komponentu Workspace wybranego w oknie dialogowym Zastąp komponent.

Zastąp jeden lub więcej komponentów innym komponentem Workspace.
Item Manager nie tylko pozwala utrzymywać zgodność komponentów w projektach ze zmianami danych źródłowych w połączonych Workspace, ale jest również zaawansowanym narzędziem wspomagającym migrację istniejących projektów płytek — z lokalnych elementów projektowych na dane projektowe Workspace. Po przeniesieniu komponentów projektu oraz używanych arkuszy schematu (arkuszy urządzeń) do Workspace użyj Item Manager, aby „zastąpić” istniejące komponenty i symbole arkuszy ich nowo przeniesionymi odpowiednikami z Workspace. Innymi słowy, z punktu widzenia projektu komponenty pozostają takie same, ale zmienia się ich źródło.
Zmiana komponentu z poziomu dokumentu BomDoc
Podczas sprawdzania dokumentu BomDoc i przygotowywania go do zamówienia części nierzadko wykrywane są problemy z komponentami. Na przykład projektant mógł zapomnieć o ostatecznym wyborze komponentu albo komponent został wycofany z produkcji (EOL), a projektant chce sprawdzić ceny i dostępność potencjalnych zamienników. Można rozwiązać ten problem, wracając do schematu, edytując komponent, wybierając odpowiednią część, a następnie odświeżając dokument BomDoc. Jednak ActiveBOM umożliwia wykonanie tych czynności bezpośrednio w dokumencie BomDoc, a następnie przeniesienie zmiany na schemat za pomocą zlecenia zmiany inżynierskiej.
W dokumencie BomDoc kliknij prawym przyciskiem myszy wybrane komponenty i wybierz polecenie Operations » Change <ComponentName>. Otworzy się okno dialogowe Zastąp komponent, w którym można wyszukać zamiennik. Po znalezieniu odpowiedniego komponentu wybierz go, a następnie kliknij OK. Otworzy się okno dialogowe Engineering Change Order ze szczegółowym zestawieniem zmian niezbędnych do zsynchronizowania schematu z dokumentem BomDoc.

Przykład zastępowania komponentu bezpośrednio w dokumencie BomDoc.
Zastępowanie komponentu ogólnego
Gdy projekt osiągnie etap, na którym komponent ogólny można zastąpić konkretnym komponentem fizycznym, otwórz okno dialogowe Zastąp komponent, wybierając przycisk
w panelu Properties. Można to również zrobić z poziomu menedżera elementów lub dokumentu ActiveBOM projektu.
Wartości parametrów przypisane do komponentu ogólnego (tutaj wartości mocy i rezystancji) są automatycznie używane jako kryteria wyszukiwania w oknie dialogowym Replace Generic Component. Pozwala to wybrać odpowiedni zamiennik z przefiltrowanych wyników — w tym przykładzie kryteria wyszukiwania spełniają dwie pozycje komponentów.
|
Zastępowanie komponentu ogólnego za pomocą panelu Properties. Zastępowanie komponentu ogólnego za pomocą panelu Properties. |
Zarządzanie footprintami w całym projekcie
Edytor schematów Altium Designer zawiera zaawansowane narzędzie Footprint Manager. Narzędzie Footprint Manager, uruchamiane z menu Narzędzia edytora schematów (Tools » Footprint Manager), umożliwia przeglądanie wszystkich footprintów powiązanych z każdym komponentem w całym projekcie. Obsługa zaznaczania wielu pozycji ułatwia edycję przypisania footprintów do wielu komponentów, zmianę sposobu powiązania footprintu lub zmianę aktualnie przypisanego footprintu w przypadku komponentów, do których przypisano ich kilka. Narzędzie Footprint Manager ułatwia przeglądanie przypisań footprintów i wykrywanie związanych z nimi problemów w całym projekcie, co jest szczególnie przydatne podczas pracy nad starszym projektem lub projektem pochodzącym z innej organizacji. Zmiany w projekcie są wprowadzane za pomocą systemu ECO, który w razie potrzeby aktualizuje zarówno schemat, jak i PCB.
Okno dialogowe Footprint Manager przedstawia listę wszystkich komponentów ze wszystkich źródłowych arkuszy schematu w aktywnym projekcie. Elementy sterujące po prawej stronie okna dialogowego umożliwiają zarządzanie footprintami dostępnymi dla komponentów projektu oraz aktualnie przez nie używanymi. Dostępne funkcje obejmują:
- Dodawanie, edytowanie i usuwanie modeli footprintów dla jednego lub kilku wybranych komponentów.
- Kopiowanie footprintów między komponentami.
- Zmianę aktualnie przypisanego footprintu (footprintu, który będzie używany do reprezentowania komponentu na PCB, spośród wielu footprintów dostępnych dla danego komponentu).
- Weryfikację footprintów — sprawdzenie, czy modele footprintów są rzeczywiście dostępne, zwłaszcza te ustawione jako aktualnie używane.
Po wprowadzeniu wszystkich wymaganych zmian w przypisaniach modeli obudów należy je wdrożyć za pomocą standardowego zlecenia zmiany inżynierskiej (ECO). W tym celu wystarczy kliknąć przycisk Accept Changes (Create ECO) w prawym dolnym rogu okna dialogowego Footprint Manager.
Opcje i elementy sterujące okna dialogowego Footprint Manager
Lista komponentów
Jest to lista wszystkich komponentów z arkuszy schematu aktualnie aktywnego projektu PCB. Dostępne informacje obejmują:
- Designator
- Comment
- Current Footprint
- Design Item ID
- Part Count
- Sheet Name
Przeglądanie i edycja modeli obudów
Jest to lista modeli obudów powiązanych z komponentem wybranym na Component List. Do zarządzania modelami obudów na liście służą elementy sterujące u dołu tego obszaru lub polecenia menu kontekstowego.
Menu kontekstowe
-
Add — kliknij, aby otworzyć okno dialogowe PCB Model i wybrać nowy model obudowy, który ma zostać dodany do zaznaczonego komponentu na schemacie. Niedostępne po wybraniu komponentu zarządzanego.
-
Remove — kliknij, aby usunąć wybrany model obudowy. Niedostępne po wybraniu komponentu zarządzanego.
-
Edit Footprint — kliknij, aby otworzyć okno dialogowe PCB Model. Okno dialogowe PCB Model określa, który model obudowy jest powiązany z komponentem na schemacie oraz w których bibliotekach edytor schematów może go szukać. Niedostępne po wybraniu komponentu zarządzanego.
-
Validate Footprint Paths — kliknij, aby potwierdzić, że zaznaczony model obudowy można znaleźć w dozwolonej lokalizacji. Jeśli nie można go znaleźć, w polu Found In pojawi się Not Validated . Jeśli model obudowy zostanie zweryfikowany pomyślnie, zostanie wyświetlona pełna ścieżka do niego.
-
Change PCB Library — kliknij, aby otworzyć okno dialogowe Edit PCB Library i zmienić bibliotekę PCB wybranego modelu obudowy. To okno dialogowe jest uproszczoną wersją okna PCB Model i zapewnia dostęp do opcji PCB Library, które określają, gdzie oprogramowanie może szukać modeli obudów.

Okno dialogowe Edit PCB Library- Any — przeszukuje wszystkie dostępne biblioteki w poszukiwaniu pasującego modelu.
- Library name — przeszukuje tylko dostępne biblioteki o tej nazwie w poszukiwaniu pasującego modelu.
- Library path — przeszukuje tylko bibliotekę o tej nazwie i w tej lokalizacji w poszukiwaniu pasującego modelu. Wpisz ręcznie ścieżkę i nazwę biblioteki lub kliknij przycisk Choose , aby otworzyć okno dialogowe systemu Windows Open, w którym można przejść do wymaganej biblioteki.
- Use footprint from source integrated library, database library, or server — szuka modelu tylko w bibliotece zintegrowanej, bibliotece bazodanowej lub na serwerze, z których wstawiono komponent. Biblioteka zintegrowana lub bazodanowa musi być dostępna, a w przypadku serwera wymagane jest połączenie z nim.
-
Copy — kliknij, aby skopiować szczegóły aktualnie wybranego modelu obudowy.
-
Paste — kliknij, aby wkleić (dodać) skopiowane szczegóły modelu obudowy do aktualnie wybranego komponentu na schemacie.
-
Select All — kliknij, aby zaznaczyć wszystkie modele obudów aktualnie widoczne na liście View and Edit Footprints.
-
Set As Current — kliknij, aby ustawić wybrany model obudowy jako bieżący (oznaczony symbolem
w kolumnie Current ).
-
Add to All Parts — kliknij, aby dodać wybrany model obudowy do wszystkich pozostałych części tego samego komponentu na schemacie (polecenie jest dostępne tylko wtedy, gdy wybrany komponent jest wieloczęściowy i co najmniej jedna z jego części nie ma przypisanego tego modelu obudowy).
Dodatkowe elementy sterujące
-
Menu — kliknij, aby wyświetlić menu z tymi samymi elementami sterującymi co opisane powyżej menu kontekstowe.
-
Add, Remove, Edit, Validate — te przyciski pełnią te same funkcje co opisane powyżej pozycje menu.
-
Accept Changes (Create ECO) — kliknij, aby zaakceptować zmiany w komponentach na schemacie i powiązanych z nimi modelach obudów oraz otworzyć okno dialogowe Engineering Change Order. W oknie dialogowym ECO można zweryfikować i wdrożyć zmiany po przejrzeniu modyfikacji wartości modeli obudów dla odpowiednich komponentów na schemacie.












