Roteamento de Impedância Controlada

Num relance

Este artigo explica por que o roteamento com impedância controlada é importante à medida que as velocidades de comutação dos dispositivos aumentam e como o Altium Designer ajuda a lidar com os riscos à integridade de sinal antes que se tornem problemas na placa. Você terá uma introdução prática às causas das reflexões e das oscilações, a como avaliar se suas trilhas tendem a se comportar como linhas de transmissão e a como as ferramentas de análise de integridade de sinal do Altium Designer auxiliam no casamento de impedâncias e nas decisões de roteamento dentro do fluxo de projeto. Se você quer entender melhor quando a impedância controlada é importante e como o Altium Designer ajuda a lidar com ela, este artigo é um ótimo ponto de partida. Continue lendo com confiança.

- Saiba o que são problemas de integridade de sinal, como reflexões e oscilações, e como o aumento das velocidades de comutação torna o roteamento com impedância controlada mais importante.
- Veja como avaliar se o seu projeto pode exigir atenção à impedância controlada, incluindo a regra prática usada para estimar quando o comprimento das trilhas passa a ser motivo de preocupação.
- Entenda como o Altium Designer auxilia no casamento de impedâncias dos componentes e na análise de redes por meio de suas ferramentas de integridade de sinal, antes de avançar para as decisões de roteamento.
Aprofunde-se com a IA:

Com o aumento das velocidades de comutação dos dispositivos, o roteamento com impedância controlada tornou-se um tema de destaque para os projetistas de circuitos digitais. Esta página apresenta como usar o mecanismo de análise de integridade de sinal para casar as impedâncias dos componentes e os recursos de roteamento com impedância controlada do editor de PCB.

Há um ditado nos círculos da engenharia: existem apenas dois tipos de engenheiros eletrônicos que trabalham com projetos digitais: os que já tiveram problemas de integridade de sinal e os que ainda terão. Até poucos anos atrás, o termo integridade de sinal era restrito aos especialistas, e você só precisava lidar com isso em projetos de alta velocidade. No entanto, as velocidades de comutação dos dispositivos desses projetos de alta velocidade já não são excepcionais; elas estão rapidamente se tornando a norma. À medida que os avanços na tecnologia de circuitos integrados reduzem o tamanho dos transistores, as velocidades com que eles podem comutar aumentam. É essa velocidade de comutação que afeta a integridade dos sinais digitais.

Felizmente, muitos problemas potenciais de integridade de sinal podem ser evitados seguindo boas práticas de projeto e implementando o projeto como uma placa de impedância controlada. Para isso, são necessários recursos específicos nas ferramentas de projeto: você precisa de ferramentas de análise que detectem redes com possíveis problemas de oscilação e reflexão, além de ferramentas de projeto de placas que permitam obter as impedâncias corretas de roteamento. O editor de PCB do Altium Designer oferece esses recursos.

Esta página ajudará você a entender o que causa problemas de integridade de sinal e se a sua placa tem probabilidade de apresentá-los. Ela também abordará as duas estratégias de projeto que você deve empregar para minimizar possíveis problemas de integridade de sinal: o casamento das impedâncias dos componentes e o roteamento com impedância controlada.

Controlled Impedance Routing: configurar as larguras e os espaçamentos das trilhas, bem como as propriedades e dimensões dos materiais, para obter as impedâncias de roteamento necessárias.

Quando o roteamento se torna parte do circuito

À medida que as velocidades de comutação dos dispositivos aumentam, também aumentam as exigências para o projetista e o fabricante da placa de circuito impresso. Quando o comprimento da borda de comutação do sinal se torna menor que o comprimento da trilha da PCB que o transporta, a trilha precisa ser tratada como parte do circuito. Essa trilha tem uma impedância, denominada characteristic impedance (Zo).

A melhor maneira de gerenciar o impacto desses elementos adicionais do circuito é projetar o roteamento das trilhas de modo que a impedância característica seja constante ao longo de seu comprimento — uma técnica chamada controlled impedance routing.

A impedância do roteamento das trilhas é definida pelos seguintes fatores:

  • Cross-sectional area of the trace - determinada pela largura, pela altura (espessura do cobre) e pela inclinação das bordas da trilha criadas durante o processo de corrosão.
  • Distance from the trace to the reference plane(s) - o caminho de retorno da energia do sinal é tão importante quanto o caminho do próprio sinal. Esse caminho de retorno acompanha o caminho do sinal nos planos de referência adjacentes.
  • Properties of the surrounding materials - a energia do sinal não fica contida no cobre da trilha; devido ao efeito pelicular, ela também se propaga pelo material dielétrico que envolve a trilha. A permissividade do material dielétrico mede quanto o dielétrico afeta o fluxo dessa energia.

A calculadora de impedância Simbeor calcula as larguras necessárias para atingir a impedância especificada.   
A calculadora de impedância Simbeor calcula as larguras necessárias para atingir a impedância especificada.

Preciso de roteamento com impedância controlada?

Você pode estar se perguntando: preciso me preocupar com o roteamento com impedância controlada?

Em uma situação ideal, toda a energia que sai de um pino de saída de um componente seria acoplada à trilha conectada na PCB, percorreria o roteamento da PCB até o pino de entrada da carga na outra extremidade e seria absorvida por essa carga. Se toda a energia não for absorvida pela carga, a energia restante poderá ser refletida de volta para o roteamento da PCB, seguindo até o pino de saída da fonte. Essa energia refletida pode interagir com o sinal original, somando-se a ele ou subtraindo-se dele (dependendo da polaridade da energia), resultando em oscilações. Se essas oscilações forem suficientemente grandes, afetarão a integridade do sinal, resultando em um comportamento imprevisível e incorreto do circuito.

Então, como saber se isso pode ocorrer? Se o pino da fonte conseguir concluir sua transição de borda antes que o sinal alcance o pino da carga, existirão condições para que o projeto seja afetado pela energia refletida. Uma regra prática comum para determinar a probabilidade de problemas de integridade de sinal é a regra de “1/3 do tempo de subida”. Essa regra estabelece que, se o tempo de propagação pela trilha for maior que 1/3 do tempo de subida, poderão ocorrer reflexões (oscilações). Se o pino da fonte tiver um tempo de subida de 1 ns, uma trilha com tempo de propagação superior a 0,33 ns (aproximadamente 2 polegadas em FR4) deverá ser considerada uma linha de transmissão, sujeita a problemas de integridade de sinal. Se os seus dispositivos tiverem esse tipo de tempo de subida e você souber que haverá trilhas com esse comprimento, poderá acabar enfrentando problemas de integridade de sinal na PCB.

A velocidade com que a energia elétrica pode se deslocar ao longo da trilha é conhecida como velocidade de propagação, em que:

Vp = velocidade da luz / √ constante dielétrica

Usando:

Time = 1/3 * tempo de subida
eR = 4 (aproximação para FR4)
C = 11,811 pol/ns (velocidade da luz, em polegadas por nanossegundo)

√ é o símbolo de raiz quadrada

Para encontrar o comprimento de trilha acima do qual a integridade do sinal pode se tornar um problema:

LR = Time * Vp
LR = Time * C / √ eR
LR = .33 * 11.811 / 2
LR = 1.95 in

Como controlar as impedâncias?

Como evitar a situação em que a energia é refletida de um lado para o outro entre a fonte e a carga? Você pode evitá-la fazendo o casamento das impedâncias. O casamento de impedâncias garante que toda a energia seja acoplada da fonte para o roteamento e, em seguida, do roteamento para a carga. Rotear a placa levando em conta a impedância é o que chamamos de roteamento com impedância controlada. Em outras palavras, uma placa cujas impedâncias foram gerenciadas é chamada de PCB de impedância controlada.

Há dois elementos distintos para obter o casamento de impedâncias: o primeiro é casar as impedâncias dos componentes; o segundo é rotear a placa para obter a impedância necessária.

Casamento das impedâncias dos componentes

Não é possível obter uma PCB de impedância controlada apenas com o roteamento. Primeiro, você deve verificar e, se necessário, casar as impedâncias dos componentes.

O ideal é detectar redes que possam apresentar problemas de integridade de sinal durante a fase de captura do projeto, para que quaisquer componentes de terminação adicionais possam ser incluídos antes do início do processo de projeto da placa. Como os pinos de saída têm baixa impedância e os pinos de entrada têm alta impedância, é provável que você precise adicionar componentes de terminação ao projeto para obter o casamento de impedâncias.

Você pode realizar uma análise de integridade de sinal no seu projeto durante a etapa de captura do esquemático. Ao executar o comando Tools » Signal Integrity, a caixa de diálogo Errors or Warnings geralmente será exibida, indicando que nem todos os componentes têm modelos de integridade de sinal atribuídos. O mecanismo de análise de integridade de sinal selecionará automaticamente modelos padrão com base nos designadores dos componentes. Clique em Continue para usar os padrões ou em Model Assignments para examinar e alterar os modelos. Você pode acessar a caixa de diálogo Signal Integrity Model Assignments a qualquer momento pelo botão Model Assignments no painel Signal Integrity.

O mecanismo de análise de integridade de sinal usará valores padrão para a impedância necessária e o comprimento médio das trilhas. Ele também usará valores padrão para o estímulo de sinal (as propriedades do sinal teórico que é injetado). Esses valores padrão podem ser configurados após a abertura do painel Signal Integrity, usando o comando Menu button » Setup Options do painel. Esse comando abre a caixa de diálogo SI Setup Options (mostrar imagem), na qual as redes de alimentação também podem ser configuradas. Se o projeto incluir uma PCB, serão verificadas as configurações do empilhamento de camadas, bem como as regras de projeto de redes de alimentação e estímulo de sinal. Observe que o mecanismo de análise de integridade de sinal exige planos de alimentação como planos de referência. Ele não consegue usar uma camada de sinal coberta por um polígono.

Para acessar o mecanismo de análise de integridade de sinal no Altium Designer, a extensão de sistema Signal Integrity Analysis deve estar instalada. Essa extensão é instalada com o Altium Designer por padrão. Ela pode ser instalada ou removida manualmente.

Para obter mais informações sobre o gerenciamento de extensões, consulte a página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Análise do projeto

Quando o comando Tools » Signal Integrity é executado, o projeto é analisado e as redes com possíveis problemas são identificadas no painel Signal Integrity, conforme mostrado abaixo.

Verificação de possíveis problemas de integridade de sinal durante a captura do projeto. Verificação de possíveis problemas de integridade de sinal durante a captura do projeto.

No painel, você pode realizar uma análise de reflexão em uma ou mais redes selecionadas. À esquerda estão os resultados da análise de todas as redes do projeto. Selecione uma rede e clique no botão  Button to add the selected net(s) to the analysis region of the Signal Integrity panel (ou clique duas vezes no nome de uma rede) para transferi-la para o campo Net à direita do painel, onde você pode realizar uma análise detalhada dessa rede, incluindo:

  • Examinar os pinos dessa rede, clicando uma vez para localizar o pino correspondente no esquemático por referência cruzada ou clicando duas vezes para verificar e configurar o modelo atribuído a esse pino.
  • Habilitar uma ou mais opções teóricas de terminação para essa rede.
  • Realizar uma análise de reflexão na rede, produzindo um conjunto de formas de onda que mostram o comportamento em cada pino da rede.

O painel permite experimentar possíveis configurações e valores de terminação. Observe que a região Termination do painel Signal Integrity mostrada na imagem acima está com a opção Serial Res habilitada. A seção do painel abaixo mostra um resistor de terminação em série. É nessa seção que você define os valores mínimo e máximo da resistência teórica de terminação em série que serão usados na análise de reflexão (desmarque a caixa de seleção Suggest para inserir seus próprios valores).

Exploração dos resultados

Ao clicar no botão Reflection Waveforms, uma análise de reflexão precisa é realizada nessa rede, e os resultados são apresentados em uma nova janela de formas de onda (*.SDF).

A janela de formas de onda incluirá:

  • Um gráfico para cada rede analisada; clique nas abas na parte inferior da janela para alternar entre os gráficos.
  • Cada gráfico incluirá um traçado para cada pino dessa rede, mostrando o comportamento do sinal nesse pino.

As imagens abaixo mostram dois gráficos dos resultados no pino de entrada da rede selecionada na imagem anterior do painel. O primeiro gráfico mostra o pino de entrada da rede sem terminação; o segundo gráfico mostra seis varreduras: uma para a rede original sem terminação e, em seguida, cinco com a resistência teórica de terminação em série incluída no pino de origem.

Foram realizadas cinco execuções da análise de reflexão (valor da opção Sweep Steps = 5), com o resistor de terminação teórico variando de Min = 20 ohms a Max = 60 ohms. As cinco execuções (a primeira com 20 ohms e a última com 60 ohms) estão listadas no lado direito do gráfico. Clicar em cada rótulo destaca o resultado correspondente e exibe o valor teórico da resistência de terminação no canto inferior direito. Para essa rede, uma resistência de terminação em série de 40 ohms produziria o gráfico selecionado na imagem à direita.

O gráfico à esquerda mostra a análise de reflexão de uma rede com possíveis problemas de integridade de sinal; o gráfico à direita mostra a mesma rede com a adição de um resistor teórico de terminação em série de aproximadamente 40 ohms. Reflection analysis results when the net includes a theoretical series termination resistor, with its value being sweptO gráfico à esquerda mostra a análise de reflexão de uma rede com possíveis problemas de integridade de sinal; o gráfico à direita mostra a mesma rede com a adição de um resistor teórico de terminação em série de aproximadamente 40 ohms.

Para ocultar um painel flutuante, pressione F4 quando o painel estiver ativo (a barra de título fica colorida). Pressione F4 para voltar a exibir o painel.

O que determina a impedância do roteamento?

A segunda etapa para obter uma PCB com impedância controlada é rotear a placa de modo que as trilhas tenham uma impedância definida. Vários fatores influenciam a impedância do roteamento de sinais, incluindo as dimensões das trilhas e as propriedades dos materiais usados na fabricação da PCB.

O editor de PCB inclui o mecanismo eletromagnético de integridade de sinal Simbeor® da Simberian. A precisão do modelo do Simbeor é validada usando algoritmos avançados de análise de onda completa 3D, testes comparativos e validação experimental. O mecanismo Simbeor oferece suporte a todas as estruturas e materiais modernos de placas.

Versão do Simbeor

Este recurso está disponível quando a opção PCB.SimbeorVersion está habilitada na caixa de diálogo Configurações avançadas.

A versão do Simbeor usada no cálculo de atraso e impedância pode ser controlada pelas configurações incluídas na opção de configurações avançadas PCB.SimbeorVersion. Selecione a opção '0' para usar o Simbeor 2020.3 e a opção '1' para o Simbeor 2023.1.

O site da Simberian também inclui uma ampla biblioteca de notas de aplicação e artigos publicados pelo principal desenvolvedor da Simberian, Yuriy Shlepnev, além de artigos escritos em colaboração com outros pesquisadores de destaque da indústria e do meio acadêmico.

O Simbeor SFS

As impedâncias são calculadas pelo Simbeor SFS, um solucionador de campos quase estáticos. O Simbeor SFS é um solucionador avançado de campos 2D quase estáticos baseado no Método dos Momentos, validado por convergência, comparações e medições. O solucionador gera uma malha nas fronteiras dos dielétricos e condutores e resolve as equações correspondentes para construir matrizes RLGC dependentes da frequência para as equações do telegrafista.

O Simbeor SFS não é um solucionador de onda completa, pois isso não é necessário para avaliar a impedância, o atraso ou a atenuação nas interconexões de PCB, devido à natureza quase TEM das ondas que se propagam nelas. Essas ondas podem ser simuladas com precisão usando parâmetros RLGC extraídos com um solucionador de campos 2D quase estáticos.

Uma propriedade exclusiva do solucionador Simbeor SFS é o suporte a modelos de rugosidade de condutores. Observe que ele não oferece suporte a um modelo de condutor multicamada (revestimento metálico), e a rugosidade é comum a todos os condutores. O solucionador é quase estático porque a solução não inclui a dispersão de alta frequência que ocorre em linhas de microfita (maior concentração de campos em um dielétrico com constante dielétrica mais alta em altas frequências).

► Saiba mais sobre a tecnologia eletromagnética de integridade de sinal da Simberian

Estruturas de PCB compatíveis

As impedâncias podem ser calculadas para as seguintes estruturas de PCB:

  • Microfita
  • Stripline simétrica
  • Stripline assimétrica
  • Estruturas coplanares simples e diferenciais
  • Várias camadas dielétricas adjacentes com propriedades dielétricas diferentes.

Configuração da PCB para roteamento com impedância controlada

O roteamento com impedância controlada consiste em configurar as dimensões das trilhas e as propriedades dos materiais da placa para obter uma impedância específica. Isso é feito no Layer Stack Manager do editor de PCB. Para abrir o Layer Stack Manager,, selecione Design » Layer Stack Manager nos menus principais. O Layer Stack Manager é aberto em um editor de documentos, da mesma forma que uma folha de esquemático, a PCB e outros tipos de documento.

A largura de trilha necessária para obter uma impedância específica é calculada como parte do perfil de impedância, configurado na aba Impedance do Layer Stack Manager.

Com base em:

  • Os valores de Target Impedance, Target Tolerance e Roughness que você configura na aba Impedance, e
  • as configurações dos materiais definidas na aba Stackup, incluindo:
    • a espessura da camada de sinal,
    • a espessura das camadas dielétricas adjacentes (as distâncias em relação aos planos de referência), e 
    • as propriedades do material dielétrico (permissividade Dk e fator de dissipação Df).

Quando esses parâmetros estão configurados corretamente, a calculadora de impedância tem informações suficientes para calcular o seguinte:

  • Largura da trilha
  • Impedância calculada (Z)
  • Impedância de modo comum (Zcomm)
  • Desvio de impedância (Z Deviation)
  • Atraso de propagação (Tp)
  • Indutância por unidade de comprimento (p.u.l.)
  • Capacitância por unidade de comprimento (p.u.l.)

Os perfis de impedância são calculados em threads separadas (quando disponíveis) para aumentar a velocidade dos cálculos.

Os valores calculados são exibidos na seção Transmission Line do painel Properties quando a aba Impedance é selecionada no Layer Stack Manager, conforme mostrado abaixo.

Um perfil de impedância de 50ΩUm perfil de impedância de 50Ω definido para redes individuais roteadas na camada superior. Passe o cursor sobre a imagem para exibir as configurações do mesmo perfil para a camada L3 (imagem cedida por FEDEVEL Open Source, www.fedevel.com).

Configuração do empilhamento de camadas

Main page: Definição do empilhamento de camadas

As camadas de fabricação de cobre e dielétrico são configuradas na aba Stackup do Layer Stack Manager.

  • As camadas são adicionadas, removidas e configuradas nesta aba. Em um projeto rígido-flexível, as camadas também são habilitadas e desabilitadas nesta aba.
  • As propriedades da camada selecionada podem ser editadas diretamente na grade ou no painel Properties. Clique no botão  Panels button, click to show or hide a workspace panel na parte inferior da área de projeto para habilitar o painel.
  • Clique com o botão direito na grade de camadas ou use os comandos Edit » Add Layer para adicionar uma camada. Ao adicionar uma camada de cobre, uma camada dielétrica também será adicionada se uma camada adjacente existente também for de cobre.
  • Se a opção Stack Symmetry estiver habilitada na seção Placa do painel Properties, as camadas serão adicionadas em pares correspondentes, simétricos em relação à camada dielétrica central.
  • O material da camada pode ser digitado na célula Material selecionada ou escolhido na caixa de diálogo Select Material; clique no botão de reticências (Ellipsis button, click to select a suitable material from the Select Material dialog) para abri-la.
  • Um acabamento superficial pode ser adicionado a uma camada de cobre. Use o submenu Add Layer para adicionar uma camada Surface Finish à camada de cobre selecionada e, em seguida, clique no botão de reticências da nova camada de acabamento superficial para selecionar o tipo de acabamento.
  • A camada selecionada pode ser movida para cima ou para baixo entre as camadas do mesmo tipo usando o menu do botão direito ou os menus Edit.
  • A região Board do painel Properties inclui opções para impor Stack Symmetry e Library Compliance. Veja mais sobre essas opções abaixo.
  • A região Board do painel Properties exibe um resumo do empilhamento selecionado (ou do subempilhamento, no caso de um projeto rígido-flexível com vários empilhamentos).

Considerações sobre o empilhamento de camadas

Um requisito fundamental para controlar a impedância é incluir um caminho de retorno do sinal abaixo de cada caminho de sinal. O mecanismo Simbeor SI oferece suporte tanto a camadas de plano quanto a camadas de sinal cobertas por um polígono. Essas camadas de retorno devem ser distribuídas ao longo do empilhamento da placa. Idealmente, elas devem ser organizadas de modo que pelo menos uma camada de retorno fique adjacente a cada camada de sinal com roteamento de impedância controlada. A camada de retorno adjacente fornece o caminho de retorno do sinal e, por razões que não serão abordadas aqui, faz isso independentemente da tensão CC distribuída por esse plano.

A corrente de retorno que flui pelo plano tende a seguir o mesmo caminho físico da trilha na camada de sinal. Por isso, é importante evitar a introdução de descontinuidades, como uma divisão ou um recorte na camada de retorno sob qualquer roteamento de sinal crítico.

Além de selecionar uma ordem adequada para as camadas de sinal e de plano, você também precisa definir as propriedades dos materiais de cada camada, incluindo:

  • Espessura do cobre
  • Espessura do dielétrico
  • Constante dielétrica

Esses valores e a largura das trilhas contribuem para a impedância final. Assim, obter a impedância necessária torna-se um processo de ajuste de todos esses valores. Lembre-se de que os valores possíveis de espessura do cobre e do dielétrico também podem ser limitados pelos materiais disponíveis no seu fabricante de PCB.

► Saiba mais sobre possíveis empilhamentos de camadas

Definição dos perfis de impedância

O mecanismo Simbeor está integrado ao Layer Stack Manager (Design » Layer Stack Manager) do editor de PCB. Para configurar o empilhamento de camadas para roteamento com impedância controlada, acesse a aba Layer Stack Manager's Impedance, onde você pode adicionar e configurar um perfil de impedância.

Um perfil de impedância de 50Ω definido para redes individuais roteadas na camada superior. Passe o cursor sobre a imagem para exibir as configurações do mesmo perfil para a camada L3.Um perfil de impedância de 50Ω definido para redes individuais roteadas na camada superior. Passe o cursor sobre a imagem para exibir as configurações do mesmo perfil para a camada L3.

Observações sobre a criação e a configuração de um perfil de impedância:

  1. No Layer Stack Manager, acesse a aba Impedance, conforme mostrado acima.
  2. Clique no botão Add Impedance Profile button, appears when there are no impedance profiles defined (ou no botão Plus button, click to add an additional impedance profile, se já houver um perfil definido) para adicionar um novo perfil.
  3. Defina Type, Target Impedance e Target Tolerance da impedância desejada no painel Properties. O Description é opcional e será exibido onde quer que o nome do perfil de impedância seja exibido.
  4. A grade de camadas é dividida em duas regiões: as camadas do empilhamento são exibidas à esquerda e, para cada camada de sinal do empilhamento, há uma camada exibida na região Perfil de impedância à direita. Use a caixa de seleção da camada na região Perfil para habilitar o cálculo de impedância para essa camada. Usando a imagem acima como exemplo e tomando como referência o número da camada mostrado na coluna mais à esquerda, as camadas L1, L3, L10 e L12 estão com suas caixas de seleção marcadas, habilitando-as para os cálculos de impedância.
  5. Ao clicar em uma camada habilitada na região Profile, todas as camadas do empilhamento ficarão esmaecidas, exceto aquelas usadas para calcular a impedância da camada de sinal selecionada (como mostrado na imagem acima). Edite as camadas de referência dessa camada nas colunas Top Ref e Bottom Ref da região Impedance Profile . Observe que as camadas de referência podem ter uma camada Type de Plane ou Signal. Por exemplo, na imagem acima, a camada L10 do empilhamento está habilitada para cálculos de impedância, com Top Ref definido como 9-L9, que é uma camada Plane, e Bottom Ref definido como 11-L11, que é uma camada Signal . O software pressupõe que, se uma camada de sinal estiver sendo usada como plano de referência, ela contém um plano contínuo de cobre conectado a uma rede de alimentação ou terra.
  6. Marque a caixa de seleção Impedance Profile para cada uma das demais camadas que terão roteamento com essa impedância e configure os planos de referência. Passe o cursor sobre a imagem acima para exibir o perfil de impedância S50 da camada L3.
  7. Se a largura calculada da trilha de roteamento for um valor que não possa ser fabricado, você poderá ajustar as configurações de largura e espaçamento.

Ajuste das configurações de largura e espaçamento

O software calcula a largura da trilha a partir da impedância-alvo e da tolerância. Não é incomum que a largura calculada da trilha seja um valor que não possa ser fabricado, por exemplo, 0,0683 mm. O fabricante informará quais espessuras de material estão disponíveis e qual precisão pode alcançar para as larguras das trilhas. O processo passa então a consistir em partir dos valores desejados e testar o impacto nos valores de impedância calculados quando as dimensões são ajustadas para os valores disponíveis.

Para auxiliar nesse processo de teste e ajuste das configurações, as calculadoras de impedância permitem cálculos diretos e inversos de impedância. O modo padrão é o direto (você informa a impedância e o software calcula a largura). O ícone  indica a variável calculada.

Uma impedância-alvo de 50Ω  Uma impedância-alvo de 50Ω resulta em uma largura (W1) de 94,6 µm no cálculo direto. A imagem à direita mostra o cálculo inverso quando a largura (W1) é definida como 95 µm.

Para inverter o cálculo e explorar diferentes larguras de trilha para a camada selecionada, digite o novo valor de Width (W1) e pressione Enter no teclado. Os valores calculados serão atualizados para refletir o impacto da alteração para essa largura. Clique no botão  para retornar a calculadora ao modo de cálculo direto. Inserir um novo valor em Width (W2) alterará o valor de Etch.

Para explorar os resultados da linha de transmissão de par diferencial, selecione a variável calculada — Trace Width ou Trace Gap — clicando no botão correspondente. Edite a outra variável para alterar Target Impedance ou, como alternativa, altere Target Impedance para explorar o impacto na outra variável.

Pressione Enter no teclado para aplicar um valor digitado em um campo do painel.

Fator de corrosão

As trilhas de sinal de uma PCB são fabricadas removendo o cobre indesejado por corrosão química. Como o agente corrosivo começa a remover o cobre pela superfície, esse cobre passa mais tempo em contato com o agente corrosivo. Como resultado, as bordas finais da trilha ficam inclinadas, reduzindo a área da seção transversal da trilha acabada, como mostrado na imagem abaixo.

A área de cobre perdida nas bordas da trilha (em ambas as bordas) durante a corrosão = X * Y

O grau de inclinação é denominado fator de corrosão, em que:

Etch Factor = Y/X

Se Y = X, então Etch Factor = 1

Com referência à imagem mostrada no painel Properties:

Passe o cursor sobre o símbolo ? para exibir a fórmula.Passe o cursor sobre o símbolo ? para exibir a fórmula.

A definição padrão do fator de corrosão o especifica como a razão entre  trace thickness / amount of over-etching. Isso resulta na seguinte fórmula:

Etch Factor = T/[0.5(W1-W2)]

A desvantagem dessa abordagem é que, para especificar a ausência de corrosão excessiva (ou seja, bordas verticais da trilha), seria necessário inserir um valor de inf (infinito) para o fator de corrosão. Para simplificar a especificação do grau de corrosão, a fórmula foi invertida para que um valor de 0 (zero) possa ser inserido para indicar que não há corrosão excessiva.

Etch = [0.5(W1-W2)]/T

  • Para excluir o fator de corrosão dos cálculos (especificar que não há inclinação ao longo da borda da trilha), defina o valor como 0 (zero). O valor inverso é usado para o fator de corrosão para simplificar a configuração sem corrosão.
  • Consulte o fabricante da placa para obter informações sobre o fator de corrosão resultante de seus processos.

Orientação do cobre

Outro detalhe de fabricação que contribui para o fator de corrosão é a orientação do cobre. As trilhas da PCB são formadas pela remoção, por corrosão química, do cobre indesejado de uma folha contínua de cobre laminada sobre um substrato dielétrico. A orientação do cobre define a direção em que o cobre se projeta a partir desse substrato. Você também pode entendê-la como a direção a partir da qual o cobre é corroído: por cima ou por baixo.

Clique na caixa de seleção Trace Inverted para alternar a orientação do cobre de Above para Below.  Clique na caixa de seleção Trace Inverted para alternar a orientação do cobre de Above para Below.

A orientação do cobre pode ser editada no painel Properties: na seção Transmission line (com a aba Impedance ativa) ou na seção Layer (com a aba Stackup ativa). Ela também pode ser editada na grade do Layer Stack Manager se a coluna Copper Orientation estiver sendo exibida na grade.

As camadas de cobre também incluem uma opção Orientation. Esse campo define em qual lado dessa camada de cobre os componentes são montados. Configure-o quando um projeto rígido-flexível tiver uma camada interna/flexível com componentes montados nela ou quando o projeto usar componentes embutidos para indicar a direção em que o componente está orientado em relação a essa camada de cobre.

► Saiba mais sobre Definição e configuração dos subempilhamentos rígido-flexíveis

► Saiba mais sobre Componentes embutidos

Rugosidade da superfície do condutor

A superfície de cada camada de cobre de uma placa de circuito impresso apresenta certo grau de rugosidade. Durante a fabricação da PCB, a superfície das camadas de cobre é tratada para aumentar a rugosidade e melhorar a adesão entre o cobre e as camadas dielétricas. Essa rugosidade superficial passa a contribuir significativamente para a impedância do condutor em velocidades de comutação acima de 10 GB/s. Por meio de extensas pesquisas e análises, especialistas do setor concluíram que a rugosidade superficial pode ser modelada por um coeficiente de correção de rugosidade derivado dos valores de Surface Roughness e Roughness Factor.

Roughness estão disponíveis no modo Layer Stack Manager do painel Properties . Esses parâmetros são usados apenas para camadas condutoras.

A rugosidade superficial é incluída no cálculo da impedância característica.A rugosidade superficial é incluída no cálculo da impedância característica.

Rugosidade:

  • Model Type - modelo preferencial para calcular o impacto da rugosidade superficial (consulte os artigos abaixo para obter mais informações sobre os vários modelos). Aplica-se a todas as camadas de cobre do subempilhamento.

  • Surface Roughness - valor da rugosidade superficial (fornecido pelo fabricante). Insira um valor entre 0 e 10 µm; o padrão é 0,1 µm.

  • Roughness Factor - caracteriza o aumento máximo esperado nas perdas do condutor devido ao efeito da rugosidade. Insira um valor entre 1 e 100; o padrão é 2.

Leitura complementar

Suporte a estruturas de linhas de transmissão coplanares

A calculadora de impedância no Layer Stack Manager oferece suporte a estruturas coplanares simples e diferenciais. Crie um novo perfil de impedância e selecione Single-Coplanar ou Differential-Coplanar na lista suspensa Type do perfil de impedância.

Como trabalhar com estruturas coplanares:

  • Assim como nas impedâncias simples e diferenciais padrão, os valores de cada variável são calculados automaticamente com base em Target Impedance e Target Tolerance definidos pelo usuário e nas propriedades físicas das camadas da placa. Esses valores calculados automaticamente podem ser ajustados inserindo novos valores nas caixas de edição do modo Layer Stack Manager do painel Properties.
  • Para especificar as redes de sinais que você deseja rotear com uma estrutura coplanar, configure uma regra de projeto de Largura de roteamento (ou Roteamento de pares diferenciais) com a opção Use Impedance Profile habilitada e o perfil de impedância coplanar necessário selecionado.
  • As estruturas coplanares exigem um plano de referência em ambos os lados do roteamento do sinal; ele pode ser criado por um polígono que você posicionar ou, se forem adicionadas vias de costura, pelo comando Add Shielding to Net (mais informações abaixo). Se você posicionar um polígono, a separação entre ele e o roteamento do sinal será definida pelo valor de Clearance (S) determinado pela calculadora de impedância Simbeor (exibido no painel Properties, mostrado nas imagens acima e abaixo). Configure uma regra de projeto de afastamento para controlar o afastamento entre o polígono de referência e o roteamento do sinal (mostrar imagem).
  • É prática comum incluir uma cerca de vias ao longo de cada lado da trilha de sinal quando a estrutura coplanar é aterrada. Use o comando Tools » Via Stitching/Shielding » Add Shielding to Net no editor de PCB para fazer isso. Além de posicionar vias, ao habilitar a opção Add shielding copper, esse comando também pode posicionar um polígono ao redor do roteamento do sinal para cobrir a cerca de vias, conforme mostrado na imagem à direita abaixo.
    ► Saiba mais sobre Blindagem com vias

A calculadora de impedância determina as propriedades do sinal e os afastamentos (primeira imagem); use esse afastamento na configuração de distância da blindagem com vias.  A calculadora de impedância determina as propriedades do sinal e os afastamentos (primeira imagem); use esse afastamento na configuração de distância da blindagem com vias.

Seleção do material da camada

Em um projeto com impedância controlada, a seleção dos materiais usados no empilhamento de camadas é muito importante.

Por exemplo, o material mais comum para a fabricação de PCBs é a resina epóxi reforçada com fibra de vidro, com uma folha de cobre aderida a cada lado. A densidade da trama do tecido de fibra de vidro afeta o valor e a uniformidade da constante dielétrica Dk (permissividade) e da tangente de perdas Df. Ao redor do tecido de fibra de vidro há resina — a porcentagem de resina utilizada também é importante para o desempenho do material.

Há uma grande variedade de tramas de fibra de vidro disponíveis. Para ajudar a garantir a previsibilidade e o desempenho dos materiais à base de fibra de vidro usados na fabricação de PCBs, o IPC possui uma norma para tramas:

IPC standard IPC-4412B: Specification for Finished Fabric Woven from "E" Glass for Printed Boards

  • Os números de trama detalhados na norma são os valores de Constructions exibidos na caixa de diálogo Altium Material Library.
  • Se a estrutura de camadas for simétrica, habilite a opção Stack Symmetry na seção Placa do painel Properties. Sempre que você adicionar uma camada, uma camada correspondente será adicionada automaticamente na outra metade do empilhamento. 

A biblioteca de materiais

Como projetista, você pode editar as propriedades dos materiais diretamente no Layer Stack Manager ou selecionar materiais da Altium Material Library.

A biblioteca inteira pode ser visualizada (e ampliada) na caixa de diálogo Biblioteca de materiais da Altium (Tools » Material Library).

Os materiais são organizados em categorias de uso, acessíveis por uma estrutura em árvore à esquerda da caixa de diálogo. Abaixo desse nível, cada categoria de uso é dividida em categorias funcionais, como Conductive layer material, Dielectric layer material, e Surface Layer Material i na categoria PCB layer material.

Adição, salvamento e carregamento de materiais

É possível adicionar novos materiais à biblioteca quando uma categoria específica de materiais está selecionada na árvore. Materiais definidos em uma biblioteca externa de materiais podem ser carregados (botão Load), e os materiais definidos pelo usuário que foram adicionados na caixa de diálogo Altium Material Library também podem ser salvos em uma biblioteca do usuário (botão Save). Apenas os materiais definidos pelo usuário são salvos.

Adição de propriedades personalizadas aos materiais

É possível adicionar propriedades personalizadas aos materiais detalhados na biblioteca (materiais padrão e definidos pelo usuário). Para adicionar uma propriedade personalizada, primeiro selecione o nó correto na árvore à esquerda para definir os materiais aos quais ela será adicionada e, em seguida, clique no botão  para abrir a caixa de diálogo Material Library Settings.

O valor necessário pode então ser adicionado ao material selecionado na caixa de diálogo Altium Material Library; selecione a linha e clique no botão Edit.

Comportamento dos materiais dielétricos

Os valores de Dk/Df dos dielétricos de PCB dependem da frequência — em dielétricos compósitos, Dk diminui com a frequência, enquanto Df aumenta ligeiramente (devido à polarização atômica do tipo relaxação nesses dielétricos).

A dispersão em função da frequência pode ser descrita por um modelo de Debye multipolar, que exige vários pontos de frequência para ser construído. Para dielétricos de PCB, foi desenvolvido um modelo mais simples de polos contínuos, chamado Djordjevic-Sarkar ou modelo de Debye de banda larga. O modelo é analítico e causal e pode ser construído com a medição de Dk/Df em apenas um ponto de frequência — uma abordagem muito mais simples, mas ainda precisa (para obter mais informações, consulte Material World tutorial #2016_01 na Biblioteca de apresentações técnicas da Simberian).

A calculadora de impedância Layer Stack Manager's usa o modelo de Debye de banda larga, com um valor de frequência padrão de 1 GHz. Se for necessária uma frequência diferente, selecione os valores de Dk/Df de um ponto de frequência entre 1 e 10 GHz nas especificações do laminado e use o valor de impedância característica calculado a 1 GHz.

  • Todos os cálculos usam uma frequência padrão de 1 GHz.
  • Se Df não estiver definido, será usado o valor padrão zero.

Painel Propriedades

Quando a aba Impedance do documento de empilhamento de camadas está ativa, o painel Properties permite configurar os requisitos do perfil de impedância. O perfil de impedância necessário pode então ser selecionado nas regras de projeto de Largura de roteamento ou Roteamento de pares diferenciais.

  • Impedance Profile
    • Description – insira uma descrição significativa. Este campo é opcional e será exibido onde quer que o nome do perfil de impedância seja exibido.
    • Type – use a lista suspensa para escolher o tipo de impedância. As opções são Single, Differential, Single-Coplanar e Differential-Coplanar.
Ao trabalhar com impedâncias de estruturas coplanares e com impedâncias simples/diferenciais padrão, os valores de cada variável são calculados automaticamente com base em Target Impedance e Target Tolerance definidos pelo usuário e nas propriedades físicas das camadas da placa. Esses valores calculados automaticamente podem ser ajustados inserindo novos valores nas caixas de edição do modo Layer Stack Manager do painel Properties.
  • Target Impedance – insira a impedância que deseja obter.
  • Target Tolerance – insira a tolerância que deseja obter. Consulte o fabricante para determinar um valor realista de tolerância que ele possa atender.
  • Transmission Line
    • Trace inverted – habilite esta opção para inverter a trilha, conforme demonstrado no painel Properties. Esta opção é a mesma que a opção Copper Orientation exibida quando a aba Stackup está ativa e define a direção em que o cobre é laminado sobre o núcleo. A orientação do cobre define a direção em que ele se projeta para fora desse substrato. Você também pode entendê-la como a direção a partir da qual o cobre é corroído, por cima ou por baixo.
    • Etch – o fator de corrosão é = T/[(W1-W2)/2], o que reduz a área total da seção transversal da trilha pelo quadrado da espessura do cobre. Consulte o fabricante da placa para obter informações sobre o Etch resultante dos processos utilizados.
Para excluir o Etch dos cálculos (ou seja, considerar que não há inclinação na borda da trilha), defina o valor como 0.
  • Width (W1) / (W2) – W1 é a largura da trilha que você roteia; W2 é a largura da superfície superior dessa trilha após a corrosão, com o fator Etch aplicado. Há um recurso de cálculo direto/inverso disponível para a largura da trilha. Por padrão, a largura é calculada com base no Target Impedance inserido (cálculo direto). Essa largura pode ser um valor que o fabricante não consiga produzir, como 5,978, e ele precisará de um valor mais adequado, como 6,0. Você pode inserir 6,0 no campo Width e pressionar Enter no teclado para recalcular os valores calculados (Impedance, Deviation etc.). O botão fica cinza (inativo), e você passa para o modo de cálculo inverso. Se clicar no botão para ativá-lo, você retornará ao modo direto, e o Width (W1) voltará ao valor calculado. Esse recurso permite explorar opções de largura que sejam viáveis para fabricação. A inserção manual de um valor para W2 atualizará o fator de corrosão de acordo.
  • Impedance – o software calcula a impedância com base nas propriedades dos materiais usados para fabricar a placa (cobre, núcleo e prepreg) e na área da seção transversal da trilha (determinada pela largura, espessura e fator de corrosão da trilha).
  • Deviation – esta é uma medida da diferença entre o que você desejava (impedância-alvo) e o que obteve (impedância calculada). O software calcula o desvio de impedância (o que você realmente obterá com base no material e nas dimensões inseridos) com base nas propriedades dos materiais usados para fabricar a placa (cobre, núcleo e prepreg) e na área da seção transversal da trilha (determinada pela largura, espessura e fator de corrosão da trilha).
  • Delay – este é o tempo que o sinal leva para percorrer o caminho do transmissor ao receptor.
  • Inductance – a calculadora de impedância usa o valor de Impedance para calcular a indutância por unidade de comprimento.
  • Capacitance – a calculadora de impedância usa o valor de Impedance para calcular a capacitância por unidade de comprimento.
  • Board
    • Stack Symmetry – habilite para adicionar camadas em pares correspondentes, centralizados em torno da camada dielétrica central. Quando habilitada, a simetria do empilhamento de camadas em relação à camada dielétrica central é verificada imediatamente. Se algum par de camadas equidistantes da camada dielétrica central de referência não for idêntico, a caixa de diálogo O empilhamento não é simétrico será aberta.
    • Library Compliance – quando habilitada, para cada camada selecionada na Biblioteca de Materiais, as propriedades atuais da camada são verificadas em relação aos valores da definição desse material na biblioteca.
Quando Stack Symmetry está habilitado:
– Uma edição aplicada a uma propriedade de camada é automaticamente aplicada à camada simétrica correspondente.
– A adição de camadas adicionará automaticamente as camadas simétricas correspondentes.
  • Substack – estas informações se referem ao subempilhamento atualmente selecionado (camadas, dielétricos, espessuras etc.). Ao alternar de um subempilhamento para outro, estas informações serão atualizadas de acordo com o subempilhamento selecionado.
A região Substack só estará disponível se a opção Rigid/Flex estiver habilitada no menu suspenso Features.
  • Stack Name – insira um nome significativo para o subempilhamento. Este campo é útil ao atribuir um subempilhamento de camadas à região X/Y do empilhamento.
  • Is Flex – habilite se o subempilhamento for flexível.
  • Layers – o número total de camadas.
  • Dielectrics – o número total de dielétricos.
  • Conductive Thickness – a espessura da(s) camada(s) condutora(s). As camadas de sinal de cobre são chamadas de camadas condutoras.
  • Dielectric Thickness – a espessura da(s) camada(s) dielétrica(s).
  • Total Thickness – a espessura total da placa.
  • Other
  • Roughness – mostra a rugosidade das camadas condutoras.
    • Model Type – modelo preferencial para calcular o impacto da rugosidade superficial (consulte os artigos abaixo para obter mais informações sobre os vários modelos). Aplica-se a todas as camadas de cobre do empilhamento (deveria ser o subempilhamento?).
    • Surface Roughness – valor da rugosidade superficial (disponível com o fabricante). Insira um valor entre 0 e 10 µm; o padrão é 0,1 µm.
    • Roughness Factor – caracteriza o aumento máximo esperado nas perdas do condutor devido ao efeito da rugosidade. Insira um valor entre 1 e 100; o padrão é 2.

Configuração das regras de projeto

A impedância de roteamento é determinada pela largura e pela altura da trilha e pelas propriedades dos materiais dielétricos ao redor. Com base nas propriedades dos materiais definidas no Layer Stack Manager, as larguras de roteamento necessárias são calculadas quando cada perfil de impedância é criado. Dependendo das propriedades dos materiais, a largura pode mudar conforme a camada de roteamento muda. Essa necessidade de alterar as larguras ao mudar de camada de roteamento é gerenciada automaticamente pela regra de projeto de roteamento aplicável, configurada no Editor de Regras e Restrições da PCB (Design » Rules).

Na maioria dos projetos de placas, um conjunto específico de nets será roteado com impedância controlada. Uma abordagem comum é criar uma classe de nets ou uma classe de pares diferenciais que inclua essas nets e, em seguida, criar uma regra de roteamento direcionada a essa classe, conforme mostrado nas imagens abaixo.

Normalmente, você define manualmente Min, Max e Preferred Widths, nas configurações de restrição superiores para aplicá-los a todas as camadas ou individualmente para cada camada na grade de camadas. Para o roteamento com impedância controlada, habilite a opção Use Impedance Profile e selecione o Perfil de Impedância desejado no menu suspenso. Ao fazer isso, a região Constraints da regra mudará. A primeira coisa que você perceberá é que a região de camadas disponíveis não mostrará mais todas as camadas de sinal da placa. Ela mostrará apenas as camadas habilitadas no Perfil de Impedância selecionado. Os valores de Preferred Width (e o espaçamento do par diferencial) serão atualizados para refletir as larguras (e os espaçamentos) calculados para cada camada. Esses valores preferenciais não podem ser editados, mas os valores de Min e Max podem. Defina-os com valores menores/maiores adequados. As nets poderão então ser roteadas interativamente da maneira habitual.

  • Quando um Perfil de Impedância é aplicado, todas as outras camadas de sinal são removidas da restrição da regra de projeto, pois se pressupõe que as nets abrangidas serão roteadas apenas nessas camadas.
  • A Largura Preferencial fica bloqueada nos valores calculados no Perfil de Impedância; os valores de Largura Mínima e Largura Máxima ainda podem ser definidos pelo usuário.
  • Se as dimensões estiverem definidas no sistema métrico, talvez seja necessário reduzir/aumentar ligeiramente os valores de Largura mínima e Largura máxima para evitar falsas violações das regras de projeto causadas por erros de arredondamento.

Regra de projeto de largura de roteamento

Para redes de terminação simples, a largura de roteamento é definida pela regra de projeto Largura de roteamento.

Quando você opta por Usar um perfil de impedância, as camadas disponíveis e as Larguras preferenciais são controladas pelo perfil selecionado.Quando você opta por Usar um perfil de impedância, as camadas disponíveis e as Larguras preferenciais são controladas pelo perfil selecionado.

Regra de projeto de roteamento de pares diferenciais

O roteamento de pares diferenciais é controlado pela regra de projeto Roteamento de pares diferenciais.

Para um par diferencial, as camadas disponíveis, a Largura preferencial e o Espaçamento preferencial são controlados pelo perfil selecionado.Para um par diferencial, as camadas disponíveis, a Largura preferencial e o Espaçamento preferencial são controlados pelo perfil selecionado.

► Saiba mais sobre Roteamento de pares diferenciais

Regra de projeto de caminho de retorno

Interrupções ou estreitamentos no caminho de retorno podem ser detectados pela regra de projeto Caminho de retorno. A regra de projeto Caminho de retorno verifica se há um caminho de retorno de sinal contínuo nas camadas de referência designadas, acima ou abaixo dos sinais aos quais a regra se aplica. O caminho de retorno pode ser criado com preenchimentos, regiões e preenchimentos poligonais posicionados na camada de sinal de referência ou em uma camada de plano.

As camadas do caminho de retorno são as camadas de referência definidas no Impedance Profile selecionado na regra de projeto Return Path. Essas camadas são verificadas para garantir que o Minimum Gap especificado (largura além da borda do sinal) exista ao longo do trajeto do sinal. Adicione uma nova regra de projeto Return Path na categoria de regras High Speed.

As camadas do caminho de retorno são definidas no Impedance Profile selecionado, e a largura do caminho (além da borda do sinal) é definida pelo Minimum Gap.As camadas do caminho de retorno são definidas no Impedance Profile selecionado, e a largura do caminho (além da borda do sinal) é definida pelo Minimum Gap.

A imagem abaixo mostra erros de caminho de retorno detectados para o sinal, NetXcom uma configuração de Minimum Gap de 0.1mm. Pode ser mais fácil localizar erros de Caminho de retorno configurando o DRC Violation Display Style para mostrar os Detalhes da violação, mas não a Sobreposição de violações (mostrar imagem) na caixa de diálogo Preferences. Isso destaca os locais exatos em que a regra não foi atendida, em vez de destacar todos os objetos em violação. 

Para evitar a detecção de pequenos erros, como a seção destacada no segmento diagonal da trilha na imagem acima, ajuste a configuração PCB.Rules.ReturnPathIgnoreArea na caixa de diálogo Configurações avançadas. O padrão é ignorar áreas < 10 sq mils.

► Saiba mais sobre Projeto de alta velocidade no Altium Designer

Roteamento de redes com a impedância necessária

À medida que você roteia a placa e muda de camada, o software ajusta automaticamente a largura da trilha para o valor necessário para atingir a impedância especificada. Esse roteamento interativo com impedância controlada simplifica muito a tarefa de projetar uma PCB com impedância controlada.

Nem a calculadora de impedância Simbeor integrada ao Layer Stack Manager nem o mecanismo de Análise de integridade de sinal incluem vias em seus cálculos. Saiba mais sobre Definição dos tipos de via.

Ajuste de comprimento das trilhas

Dois dos principais desafios no roteamento de um projeto de alta velocidade são controlar a impedância das trilhas e igualar os comprimentos das redes críticas. O roteamento com impedância controlada garante que o sinal que sai de um pino de saída seja recebido corretamente pelos pinos de entrada de destino. A equalização dos comprimentos das trilhas garante que os sinais com temporização crítica cheguem aos pinos de destino ao mesmo tempo. Ajustar e igualar os comprimentos das trilhas também é uma parte essencial do roteamento de pares diferenciais.

Padrões em sanfona foram adicionados ao roteamento para garantir que os pares diferenciais tenham comprimentos iguais. Padrões em sanfona foram adicionados ao roteamento para garantir que os pares diferenciais tenham comprimentos iguais.

Os comandos Interactive Length Tuning e Interactive Diff Pair Length Tuning (menu Route) oferecem uma maneira dinâmica de otimizar e controlar os comprimentos de redes ou pares diferenciais, permitindo inserir padrões de onda de amplitude variável (sanfonas) de acordo com o espaço disponível, as regras e os obstáculos do projeto.

► Saiba mais sobre Ajuste de comprimento

Teste da integridade de sinal da placa roteada

Da mesma forma que você testou as redes durante a captura do projeto usando valores presumidos de comprimento de roteamento e impedância de roteamento, após concluir o roteamento, você deve repetir esse processo na placa para verificar possíveis descasamentos de impedância e problemas de reflexão. Execute o comando Signal Integrity no menu Tools do editor de PCB. Como a PCB faz parte do projeto, as propriedades dos materiais e as dimensões definidas no Layer Stack Manager, assim como as larguras reais das trilhas na placa, serão usadas para calcular as impedâncias utilizadas nos testes de integridade de sinal.

Obtenção das impedâncias especificadas

Além do processo iterativo de ajuste de dimensões realizado para obter as impedâncias corretas, há outros fatores que influenciam a impedância final da PCB fabricada. Entre eles estão a uniformidade e a estabilidade do material dielétrico usado na PCB, bem como a uniformidade e a qualidade do processo de corrosão. Se você precisa de uma PCB com impedância controlada, converse sobre isso com o fabricante da sua PCB. Alguns fabricantes podem orientar sobre as geometrias das trilhas se você fornecer o empilhamento de camadas desejado. Muitos também podem incluir um cupom de teste de impedância em cada painel fabricado — ele pode ser usado para medir as impedâncias reais obtidas na placa.

Leituras e recursos adicionais

Este artigo apresenta uma introdução ao tema de integridade de sinal e projeto de PCBs com impedância controlada. Use os links a seguir para saber mais e acessar recursos desenvolvidos por especialistas reconhecidos do setor.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents