Técnicas de Posicionamento e Edição de PCB
Num relance
- Entenda a diferença entre objetos primitivos e agrupados e como isso afeta o posicionamento e a manipulação no editor de PCB.
- Conheça o fluxo de edição habitual antes, durante e depois do posicionamento, incluindo valores padrão, acesso às propriedades e alternância das unidades exibidas.
- Veja quais comandos de seleção de PCB estão disponíveis para ajudar você a trabalhar com objetos sobrepostos, hierarquias lógicas de redes, cobre conectado e seleções de roteamento baseadas em componentes.
Uma variedade de objetos está disponível para uso no projeto de uma PCB. A maioria dos objetos inseridos em um documento de PCB define áreas de cobre ou áreas sem cobre. Isso se aplica tanto a objetos elétricos, como trilhas e pads, quanto a objetos não elétricos, como texto e cotas. Portanto, é importante considerar a largura das linhas usadas para definir cada objeto e a camada em que ele é inserido.
Existem dois tipos de objetos no editor de PCB: objetos primitivos e objetos de grupo:
-
Os objetos primitivos são os elementos fundamentais do projeto e incluem trilhas, pads, vias, preenchimentos, arcos e objetos de texto. Eles são chamados de “primitivos” devido à sua natureza elementar ou mais básica.
-
Qualquer elemento composto por primitivos e identificado como um objeto de projeto é um objeto de grupo. Exemplos de objetos de grupo incluem componentes, cotas e preenchimentos poligonais. Um objeto de grupo pode ser manipulado como um único objeto no espaço de projeto. Por exemplo, ele pode ser inserido, selecionado, copiado, alterado, movido e excluído.
Aspectos comuns da inserção e edição de objetos
No Altium Designer, o processo de inserção de um objeto é praticamente o mesmo, independentemente do objeto inserido. Em sua forma mais simples, o processo é o seguinte:
-
Selecione o objeto a ser inserido em uma das barras de ferramentas ou no menu Place .
-
Use o mouse para definir a localização do objeto inserido no espaço de projeto do editor de PCB e seu tamanho (quando aplicável).
-
Clique com o botão direito do mouse (ou pressione Esc) para encerrar o comando e sair do modo de inserção.
Edição antes da inserção
As propriedades padrão de um objeto podem ser alteradas a qualquer momento na página Editor de PCB – Padrões da caixa de diálogo Preferences . Essas propriedades serão aplicadas ao inserir objetos subsequentes.

Use a coluna Primitives para acessar as propriedades dos objetos e editar os valores padrão conforme necessário.
Edição durante a inserção
Vários atributos podem ser editados quando um objeto é inserido pela primeira vez. Para acessar esses atributos, pressione a tecla Tab no modo de inserção para abrir o painel Properties associado. Pressionar a tecla Tab pausa a inserção para que você possa fazer as edições necessárias no objeto.
Exemplo de caixa de diálogo de propriedades de um objeto Pad .
Após fazer as edições, clique no botão de pausa sobreposto ao espaço de projeto (
) para retomar a inserção.
Edição após a inserção
Depois que um objeto é inserido, ele pode ser editado de várias maneiras. Elas são descritas abaixo.
Painel ou caixa de diálogo de propriedades associado
Esse método de edição usa o modo do painel Properties e a caixa de diálogo associados para modificar as propriedades de um objeto inserido.
Após a inserção, a caixa de diálogo associada pode ser acessada das seguintes maneiras:
-
Clicando duas vezes no objeto inserido.
-
Posicionando o cursor sobre o objeto, clicando com o botão direito do mouse e escolhendo Properties no menu de contexto.
Após a inserção, o modo associado do painel Properties pode ser acessado de uma das seguintes maneiras:
- Se o painel Properties já estiver ativo, selecione o objeto.
- Após selecionar o objeto, selecione o painel Properties no botão Panels no canto inferior direito do espaço de projeto ou selecione View » Panels » Properties nos menus principais.
Comandos de seleção de objetos da PCB
Além dos comandos padrão de seleção/desseleção de objetos, o editor de PCB inclui vários comandos especiais que facilitam as operações de seleção/desseleção de objetos. Esses comandos são acessados nos submenus Edit » Select e Edit » DeSelect dos menus principais. Os comandos de seleção também podem ser acessados no menu do botão
em Active Bar.
-
Select overlapped - use para selecionar individualmente o próximo objeto de projeto em um conjunto de objetos localizados na mesma posição (sobrepostos) sem usar uma janela pop-up de seleção. A seleção obedece à seguinte ordem fixa de prioridade, percorrida ciclicamente a cada uso do comando:
- Pad
- Via
- Trilha/Arco
- Componente
- Polígono
- Região/Preenchimento
- Texto
Além disso, ao usar a tecla Shift para adicionar objetos à seleção atual, você pode usar Shift+Tab para alternar entre os objetos sobrepostos sem perder a seleção original.
-
Select next (atalho: Tab) - com um objeto inicial selecionado no projeto, este comando é usado para ampliar a seleção e incluir o objeto (ou objetos) do próximo nível superior com base na hierarquia lógica. Os seguintes 'fluxos' cíclicos de seleção lógica são suportados:
- Segmento de trilha ---> Todas as trilhas conectadas (contíguas) na mesma camada ---> Todo o cobre conectado ---> Todos os objetos elétricos da net associada
- Pad conectado ---> Todas as trilhas conectadas (contíguas) na mesma camada ---> Todo o cobre conectado ---> Todos os objetos elétricos da net associada
- Pad não conectado ---> Todos os objetos elétricos da net associada
- Via ---> Todas as trilhas conectadas (contíguas) nas camadas associadas à via ---> Todo o cobre conectado ---> Todos os objetos elétricos da net associada
- Cobre (região/área de cobre poligonal/preenchimento) ---> Todo o cobre conectado ---> Todos os objetos elétricos da net associada
- Pad/via livre ---> Todas as trilhas conectadas (contíguas) na mesma camada do pad ou nas camadas associadas à via ---> Todo o cobre conectado ---> Todos os objetos elétricos da net associada.
- Componente ---> Fanouts com vias, escapes, interconexão
Além disso, o recurso permite ampliar a seleção de vários objetos selecionados em diferentes nets do projeto.

Exemplo de seleção em várias nets, ampliada a partir dos segmentos de trilha inicialmente selecionados para os níveis superiores da hierarquia lógica.Este comando é especialmente útil ao selecionar nets roteadas. Saiba mais sobre Estratégias para selecionar o roteamento.
-
Board - use para selecionar todos os objetos dentro dos limites do formato definido da placa.
-
Net - use para selecionar todos os objetos elétricos associados a uma determinada net.
Após executar o comando, você pode clicar em um objeto elétrico ou em uma conexão para selecionar todos os objetos elétricos da net associada ou, se souber o nome da net que deseja selecionar, clicar em uma área do projeto sem objetos; a caixa de diálogo Net Name será aberta. Nela, você pode inserir o nome da net desejada; essa net será selecionada quando você fechar a caixa de diálogo. Se não tiver certeza do nome da net, digite ? e clique em OK para abrir a caixa de diálogo Nets Loaded, que lista todas as nets atualmente carregadas no projeto.
-
Connected Copper - use para selecionar todos os objetos elétricos conectados à mesma porção de cobre.
-
Physical Connection - use para selecionar todas as trilhas fisicamente roteadas entre pads. Clique em uma trilha, pad ou via; todas as trilhas contíguas até outro pad serão selecionadas, incluindo quaisquer vias (os próprios pads não serão incluídos na seleção).
-
Physical Connection Single Layer - use para selecionar todas as trilhas fisicamente roteadas entre pads em uma única camada. Clique em uma trilha ou via; todas as trilhas contíguas na mesma camada até outro pad serão selecionadas (os próprios pads e vias não serão incluídos na seleção).
-
Component Connections - use para selecionar todas as conexões roteadas que partem dos pads de um componente escolhido (incluindo trilhas e vias) até o próximo pad encontrado em cada caso. Os próprios pads não serão incluídos na seleção.
O comando também pode ser acessado clicando com o botão direito sobre um componente posicionado e escolhendo o comando Component Actions » Select Component Connections no menu de contexto.
-
Component Nets - use para selecionar todas as nets (e seus respectivos objetos) conectadas a um componente escolhido no documento atual.
O comando também pode ser acessado clicando com o botão direito sobre um componente posicionado e escolhendo o comando Component Actions » Select Component Nets no menu de contexto.
-
Room Connections - use para selecionar todas as conexões roteadas de pad a pad que estejam inteiramente dentro dos limites da room escolhida no documento atual.
O comando também pode ser acessado clicando com o botão direito sobre uma room posicionada e escolhendo o comando Room Actions » Select Room Connections no menu de contexto.
-
All on Layer - use para selecionar/desmarcar todos os objetos na camada atual.
-
Free Objects - use para selecionar todos os objetos primitivos livres no projeto. Objetos de componente, coordenada, dimensão, ajuste de comprimento, OLE e área de cobre poligonal são todos objetos de grupo e, portanto, não serão afetados por este comando.
-
All Locked - use para selecionar todos os objetos do projeto que tenham a propriedade Locked ativada.
-
Off Grid Pads - use para selecionar todos os pads que não estejam posicionados na grade de ajuste atual.
Edição gráfica
Este método de edição permite selecionar um objeto posicionado diretamente na área de projeto e alterar seu tamanho, forma ou localização graficamente. A modificação da forma e/ou do tamanho (quando aplicável) é realizada por meio de alças de edição que aparecem quando o objeto é selecionado.

Exemplo de alças de edição de um objeto de preenchimento selecionado.
Clique em qualquer ponto de um objeto fora das alças de edição (quando existirem) para arrastá-lo e reposicioná-lo. Dependendo do tipo de objeto, ele pode ser girado e/ou espelhado durante o arraste.
- Pressione Spacebar para girar o objeto no sentido anti-horário ou Shift+Spacebar para girá-lo no sentido horário. A rotação segue o valor de Rotation Step definido na página Editor de PCB – Geral da caixa de diálogo Preferences.
- Pressione a tecla L para virar o objeto para o outro lado da placa (quando aplicável).
- Pressione as teclas X ou Y para espelhar o objeto ao longo do eixo X ou Y, quando aplicável.
- Pressione a tecla Alt para restringir a direção do movimento ao eixo horizontal ou vertical, dependendo da direção inicial do movimento.
- Desloque o objeto em pequenos incrementos (de acordo com o valor atual da grade de ajuste) pressionando as teclas de seta enquanto mantém a tecla Ctrl pressionada. Para deslocá-lo em incrementos maiores (10 vezes o valor da grade de ajuste), pressione as teclas de seta enquanto mantém as teclas Ctrl+Shift pressionadas.
Comandos de movimentação
A posição dos objetos pode ser alterada usando os comandos do submenu Edit » Move dos menus principais ou do submenu de movimentação em Active Bar.
-
Move - este comando é usado para mover qualquer objeto no documento atual. Todas as redes associadas a um objeto permanecerão conectadas, e as linhas de conexão acompanharão o objeto quando ele for movido (exibidas ou não, de acordo com o modo de conexão em vigor). Nenhuma trilha roteada conectada ao objeto será movida.
-
Drag - este comando é usado para mover qualquer objeto no documento atual. Se o objeto tiver trilhas e/ou arcos conectados (por exemplo, um componente, pad ou via), eles permanecerão conectados enquanto o objeto for movido.
-
Component - este comando permite mover componentes no documento atual. Após iniciar o comando, clique no componente do projeto que deseja mover, mova-o para a posição desejada e clique novamente. Como alternativa, clique na área de projeto fora de qualquer objeto para abrir a caixa de diálogo Escolher componente. Use essa caixa de diálogo para localizar o componente que deseja mover (indo até o componente ou trazendo-o até o cursor) e, em seguida, reposicione-o da mesma forma descrita acima. Observe que esse recurso só funcionará se o componente de destino estiver not bloqueado.
O comando também pode ser acessado clicando com o botão direito do mouse sobre um componente na área de projeto e escolhendo o comando Component Actions » Move Component no menu de contexto.
-
Move Selection - este comando permite reposicionar manualmente os objetos selecionados no documento atual. Todas as redes associadas a um objeto da seleção permanecerão conectadas, e as linhas de conexão acompanharão o objeto quando ele for movido (exibidas ou não, de acordo com o modo de conexão em vigor). Nenhuma trilha roteada conectada ao objeto será movida.
-
Move Selection by X, Y - este comando é usado para deslocar a seleção atual de objetos por uma distância precisa nas direções X e/ou Y. Após iniciar o comando, a caixa de diálogo Get X/Y Offsets será aberta. Use essa caixa de diálogo para especificar os valores de incremento delta X e/ou delta Y pelos quais a seleção será movida.

A caixa de diálogo Get X/Y OffsetsOpções e controles da caixa de diálogo Obter deslocamentos X/Y
- X Offset - use este campo para especificar a distância pela qual a seleção deve ser movida ao longo do eixo horizontal. Valores positivos e negativos podem ser especificados dependendo da direção de movimento desejada. Use o botão à direita deste campo para alternar rapidamente o valor inserido entre positivo e negativo.
- Y Offset - use este campo para especificar a distância pela qual a seleção deve ser movida ao longo do eixo vertical. Valores positivos e negativos podem ser especificados dependendo da direção de movimento desejada. Use o botão à direita deste campo para alternar rapidamente o valor inserido entre positivo e negativo.
- Toggle X/Y Offsets - clique neste botão para trocar rapidamente os valores de deslocamento. O valor de X Offset será usado como valor de Y Offset e vice-versa.
- Reset X/Y Offsets - clique neste botão para zerar rapidamente ambos os valores de deslocamento.
- Define X/Y Offsets Interactively - clique neste botão para calcular os deslocamentos de forma interativa. Você será levado à área de trabalho e solicitado a escolher, em sequência, um ponto inicial e um ponto final. Clique nos locais desejados; os valores de dX e dY serão inseridos nos campos X Offset e Y Offset, respectivamente.
-
Rotate Selection - este comando é usado para girar os objetos selecionados no espaço de projeto no sentido anti-horário ou horário por um ângulo de rotação especificado. Após executar o comando, a caixa de diálogo Rotation Angle (Degrees) será aberta. Insira o ângulo de rotação desejado de 0,001° a 360,00° (resolução de 0,001°). Insira um valor positivo para a rotação no sentido anti-horário ou um valor negativo para a rotação no sentido horário. Clique em OK para fechar a caixa de diálogo e, em seguida, posicione o cursor e clique para definir o ponto de referência da rotação. Os objetos selecionados serão girados em torno do ponto de referência pelo ângulo informado.

A caixa de diálogo Rotation Angle -
Flip Selection - inverte horizontalmente os objetos selecionados (em torno do eixo Y), transferindo-os para a camada correspondente no lado oposto da placa. Por exemplo, os objetos na Top Layer serão transferidos para a Bottom Layer, os objetos na Top Overlay serão transferidos para a Bottom Overlay etc.
Comandos de alinhamento
Os objetos também podem ser movidos alterando seu alinhamento. Para alinhar objetos com outros objetos, clique com o botão direito do mouse em um objeto selecionado e selecione Align. Como alternativa, use o submenu Edit » Align dos menus principais ou o submenu de alinhamento no Active Bar. O submenu de alinhamento contém diversas opções para distribuir os objetos selecionados.
O comando Align é usado para acessar a caixa de diálogo Align Objects, que fornece controles para alinhar rapidamente o conjunto de objetos de projeto atualmente selecionados, conforme necessário. Use a caixa de diálogo para definir as opções de alinhamento Vertical e/ou Horizontal dos objetos selecionados, conforme necessário, e clique em OK para aplicar o alinhamento.

A caixa de diálogo Align Objects
Opções e controles da caixa de diálogo Alinhar objetos
-
Horizontal - escolha uma das opções a seguir para determinar o alinhamento horizontal dos objetos selecionados:
- No Change - mantém o alinhamento horizontal dos objetos inalterado.
- Left - alinha os objetos de modo que a borda externa de suas primitivas mais à esquerda tenha a mesma posição X. O objeto com a primitiva mais à esquerda é usado como referência.
- Center - move os objetos horizontalmente para que seus centros fiquem alinhados. Após clicar em OK, será solicitado que você clique para escolher o objeto de referência.
- Right - alinha os objetos de modo que a borda externa de suas primitivas mais à direita tenha a mesma posição X. O objeto com a primitiva mais à direita é usado como referência.
- Space equally - os objetos ficam igualmente espaçados na direção horizontal, entre os objetos mais à esquerda e mais à direita (que não se movem).
-
Vertical - escolha uma das opções a seguir para determinar o alinhamento vertical dos objetos selecionados:
- No Change - mantém o alinhamento vertical dos objetos selecionados inalterado.
- Top - alinha os objetos de modo que a borda externa de suas primitivas mais acima tenha a mesma posição Y. O objeto com a primitiva mais acima é usado como referência.
- Center - move os objetos verticalmente para que seus centros fiquem alinhados. Após clicar em OK, será solicitado que você clique para escolher o objeto de referência.
- Bottom - alinha os objetos de modo que a borda externa de suas primitivas mais abaixo tenha a mesma posição Y. O objeto com a primitiva mais abaixo é usado como referência.
- Space equally - os objetos ficam igualmente espaçados na direção vertical, entre os objetos mais acima e mais abaixo (que não se movem).
O comando Position Component Text é usado para abrir a caixa de diálogo Component Text Position, na qual você pode alterar a posição do texto do designador e/ou do comentário de um ou mais componentes selecionados no documento atual.

A caixa de diálogo Component Text Position
A caixa de diálogo é dividida essencialmente em duas regiões — o texto do designador e o texto do comentário. Tanto para o designador quanto para o comentário, uma representação gráfica de um componente é usada como auxílio para mostrar onde o texto aparecerá com base na posição selecionada. Os nove estilos de posicionamento a seguir estão disponíveis para o texto, todos classificados como “posições automáticas”, o que significa que o texto permanece na posição escolhida conforme o componente é movido e girado:
- Left-Above
- Left-Center
- Left-Below
- Center-Above
- Center
- Center-Below
- Right-Above
- Right-Center
- Right-Below
Para manter o texto na posição atual sem modificações, deixe a opção No Change ativada.
O comando Align Left / Align Right / Align Top / Align Bottom permite alinhar os objetos de projeto selecionados pelas bordas esquerda/direita/superior/inferior, respectivamente. Após executar o comando, a borda esquerda/direita/superior/inferior do objeto mais à esquerda/mais à direita/mais acima/mais abaixo é usada como referência, e todos os outros objetos da seleção serão movidos para a esquerda/direita/cima/baixo, de modo que suas bordas esquerdas fiquem alinhadas com essa referência.
O Align Left (maintain spacing) / Align Right (maintain spacing) / Align Top (maintain spacing) / Align Bottom (maintain spacing) permite alinhar os objetos de projeto selecionados pelas bordas esquerda/direita/superior/inferior, mantendo o espaçamento adequado de acordo com as regras de projeto aplicáveis. Após executar o comando, a borda esquerda/direita/superior/inferior do objeto mais à esquerda/à direita/acima/abaixo é usada como referência, e todos os outros objetos da seleção serão movidos para a esquerda/direita/cima/baixo, de modo que suas bordas esquerdas fiquem alinhadas com essa referência. Um objeto será movido para a esquerda/direita/cima/baixo até ficar tão próximo do objeto de referência quanto a regra de distância mínima aplicável permitir:
- Para o alinhamento apenas de componentes, a regra de distância mínima entre componentes é respeitada.
- Para o alinhamento apenas de objetos que não são componentes, a regra de distância mínima é respeitada.
- Para o alinhamento de componentes e objetos que não são componentes, a regra de distância mínima é respeitada.
O comando Align Horizontal Centers / Align Vertical Centers permite posicionar os objetos selecionados em uma única coluna/linha, alinhados pelos seus centros horizontais/verticais. Após executar o comando, o cursor mudará para uma mira e você será solicitado a selecionar um dos objetos da seleção; clique nele. Esse objeto passa a ser o objeto de referência. Todos os outros objetos da seleção serão movidos em relação a esse objeto de referência, alinhados pelos seus centros horizontais/verticais.
O comando Distribute Horizontally / Distribute Vertically permite uniformizar o espaçamento horizontal/vertical de uma seleção de objetos. Após executar o comando, os objetos mais à esquerda e mais à direita / mais acima e mais abaixo da seleção permanecerão fixos em suas posições, com todos os outros objetos igualmente espaçados entre eles. A posição vertical/horizontal dos objetos não é alterada.
O comando Increase Horizontal Spacing / Increase Vertical Spacing permite aumentar o espaçamento horizontal/vertical de uma seleção de objetos. Após executar o comando, o objeto mais à esquerda/mais abaixo permanecerá fixo, enquanto os outros objetos da seleção serão movidos para a direita/cima. O movimento faz com que a distância horizontal/vertical entre os pontos de referência de objetos consecutivos seja aumentada pelo valor especificado no campo Step X / Step Y para o Global Board Snap Grid padrão.
O comando Decrease Horizontal Spacing / Decrease Vertical Spacing permite diminuir o espaçamento horizontal/vertical de uma seleção de objetos. Após executar o comando, o objeto mais à esquerda/mais abaixo permanecerá fixo, enquanto os outros objetos da seleção serão movidos para a esquerda/baixo. O movimento faz com que a distância horizontal/vertical entre os pontos de referência de objetos consecutivos seja diminuída pelo valor especificado no campo Step X / Step Y para o Global Board Snap Grid padrão.
O comando Align To Grid é usado para mover os componentes selecionados para o ponto mais próximo na grade de ajuste aplicável e modificada. Após executar o comando, os pontos de referência de cada componente selecionado serão movidos para o ponto mais próximo na grade de ajuste aplicável.
O comando Move All Components Origin To Grid é usado para mover o ponto de referência de todos os componentes para a grade de ajuste atual. Após executar o comando, todos os componentes no espaço de projeto cujos pads estejam na grade serão movidos para que seus pontos de referência fiquem alinhados à grade de ajuste atual. Por padrão, um relatório — Move Component(s) Origin To Grid - <PCBDocumentName>.html — será gerado automaticamente e aberto como documento ativo, detalhando quais componentes foram e quais não foram movidos.
Pelo painel PCB List
O painel PCB List permite exibir objetos de projeto em formato de tabela, possibilitando a inspeção e a modificação rápidas dos atributos dos objetos. Quando usado em conjunto com o painel PCB Filter, permite exibir apenas os objetos abrangidos pelo filtro ativo — possibilitando selecionar e editar vários objetos de projeto com maior precisão e eficiência.
Selecionando a camada ativa
A camada ativa é a camada na qual você posicionará os objetos. A camada ativa pode ser selecionada entre as camadas atualmente visíveis clicando na aba dessa camada na parte inferior do espaço de projeto ou usando a lista suspensa Active Layer na região Layers da aba Layers & Colors do painel View Configuration.
Você também pode usar os seguintes atalhos para selecionar rapidamente a camada ativa:
- * (no teclado numérico) – alternar para a próxima camada de sinal habilitada.
-
Shift+* (no teclado numérico) – alternar para a camada de sinal habilitada anterior.
- + (no teclado numérico) – alternar para a próxima camada habilitada.
- - (no teclado numérico) – alternar para a camada habilitada anterior.
Usando Recortar/Copiar e Colar
No editor de PCB, você pode recortar/copiar e colar objetos dentro de um documento de PCB ou entre documentos de PCB. Por exemplo, componentes de uma PCB podem ser copiados para outro documento de PCB. Você pode recortar/copiar objetos para a área de transferência do Windows e colá-los em outros documentos.
Ao usar 2D Layout Mode, selecione os objetos que deseja recortar/copiar, clique em Edit » Cut (Ctrl+X) / Edit » Copy (Ctrl+C) nos menus principais ou escolha o comando Cut/Copy no menu do botão direito. O cursor mudará para uma mira e você será solicitado a selecionar um ponto de referência. Esse ponto é uma coordenada relativa aos objetos selecionados e é usado para posicionar a seleção com precisão ao usar o comando Colar.
Para copiar o(s) objeto(s) de projeto atualmente selecionado(s) para a área de transferência em formato textual, pode-se usar o comando Edit » Copy As Text nos menus principais. Essas informações podem então ser coladas em qualquer campo de texto ou documento de texto externo. Os detalhes copiados para a área de transferência incluem:
- O tipo de objeto.
- O designador e o comentário (para um objeto de componente).
- A localização do objeto no espaço de projeto.
- A camada na qual o objeto se encontra (ou as camadas inicial e final, no caso de uma via).
Um exemplo de componente copiado como texto para a área de transferência é:
Component Y1-25MHz (100.6mm,1.5mm) on Top Layer
Um exemplo de trilha e via copiadas como texto para a área de transferência é:
Track (20mm,6mm)(80mm,6mm) Top Layer
Via (45mm,6mm) Top Layer to Bottom Layer
Para inserir o último conteúdo recortado/copiado para a área de transferência no documento ativo, escolha o comando Edit » Paste nos menus principais ou clique com o botão direito no espaço de projeto e escolha o comando Paste no menu de contexto (atalho: Ctrl+V). O conteúdo mais recente da área de transferência aparecerá flutuando junto ao cursor. A posição do cursor em relação ao conteúdo é determinada pelo ponto de referência definido quando Cut ou Copy foi usado para adicionar a seleção à área de transferência.
Para inserir o texto copiado de um aplicativo OLE compatível em qualquer documento de PCB aberto, pode-se usar o comando Edit » Paste Text nos menus principais. O texto é convertido e colado como objetos de texto da PCB, em vez de um único objeto OLE. Os tipos de arquivo compatíveis incluem formatos universais, como planilhas nos formatos CSV e XLS e documentos de texto nos formatos DOC e RTF.
Para controlar o que acontece com determinados atributos dos objetos quando eles são colados de volta no espaço de projeto, pode-se usar o comando Edit » Paste Special nos menus principais. Após executar o comando, a caixa de diálogo Paste Special será aberta.

A caixa de diálogo Paste Special
Opções e controles da caixa de diálogo Colar especial
Atributos de colagem
- Paste on current layer - habilite esta opção para colar objetos na camada atual.
- Keep net name - habilite esta opção para manter os nomes originais das redes dos objetos.
- Duplicate designator - habilite esta opção para colar um componente com o mesmo designador, sem incremento automático.
- Add to component class - habilite esta opção para adicionar o componente colado à mesma classe de componentes do componente de origem.
Botões
- Paste - clique para colar o objeto com todos os atributos especificados.
- Paste Array - clique para abrir a caixa de diálogo Configurar matriz de colagem, na qual você pode configurar as opções de colagem em matriz.
Dependendo do conteúdo específico que está sendo colado, os seguintes atributos podem ser controlados:
-
Os objetos podem ser colados na camada atual, em vez de seguir o comportamento padrão de colagem na mesma camada da qual os objetos de origem foram copiados.
- Possibilidade de manter os nomes de rede atribuídos.
- Possibilidade de duplicar o designador (para um componente colado).
- Possibilidade de adicionar um componente colado à mesma classe de componentes do componente de origem.
Configure as opções conforme necessário e clique no botão Paste para iniciar a operação de colagem.
Clicar no botão Paste Array na caixa de diálogo Paste Special abrirá a caixa de diálogo Setup Paste Array, que permite colar várias cópias dos objetos da área de transferência no documento atual.

A caixa de diálogo Setup Paste Array
Opções e controles da caixa de diálogo Configurar matriz de colagem
Variáveis de posicionamento
- Item Count - o número de posicionamentos repetidos a serem realizados. Por exemplo, digitar 4 posicionará 4 cópias do conteúdo atual da área de transferência.
-
Text Increment - insira o incremento automático para o texto exibido (por exemplo, o designador do componente ou do pad). São aceitos incrementos alfabéticos e numéricos diferentes de 1. Por exemplo, ao definir o designador de um pad antes de copiá-lo para a área de transferência e configurar o campo Text Increment, é possível posicionar os seguintes tipos de sequências de designadores de pad:
- Numérica (1, 3, 5)
- Alfabética (A, B, C)
- Combinação de letras e números (A1, A2, ou 1A, 1B, ou A1, B1 ou 1A, 2A, etc.)
Tipo de matriz
- Circular- habilite esta opção para colar uma matriz circular usando as configurações atuais de Circular Array.
- Linear - habilite esta opção para colar a matriz em linha reta usando as configurações atuais de Linear Array.
Matriz circular
- Rotate Item to Match - se habilitada, os itens da matriz serão girados pelo mesmo ângulo definido em Espaçamento.
- Spacing (degrees) - o espaçamento angular entre dois itens colados adjacentes.
Matriz linear
- X-Spacing - insira o espaçamento desejado em X entre dois itens adjacentes.
- Y- Spacing - insira o espaçamento desejado em Y entre dois itens adjacentes.
Insira os valores apropriados nesta caixa de diálogo e clique em OK para posicionar a matriz.
- Se estiver posicionando uma matriz linear, você será solicitado a selecionar o ponto inicial da matriz. Posicione o cursor e clique ou pressione Enter para posicionar a matriz.
- Ao posicionar uma matriz circular, será solicitado que você selecione o ponto central da matriz e, em seguida, o ponto inicial. Posicione o cursor em cada caso e clique ou pressione Enter para posicionar a matriz. Os objetos serão posicionados no sentido anti-horário ao redor do ponto central indicado.
Prioridades ao colar objetos
Quando um objeto é colado em uma camada de cobre e se sobrepõe a um conjunto de objetos de tipos diferentes, a net do objeto de maior prioridade será atribuída ao objeto colado. As prioridades são as seguintes (1 é a prioridade mais alta):
- Pad
- Preenchimento
- Região
- Trilha
- Arco
- Via
- Preenchimento poligonal

A net do objeto de maior prioridade é atribuída ao objeto colado. Aqui é mostrado um objeto (trilha) colado sobre um conjunto de objetos de tipos diferentes com nets diferentes atribuídas. Como o pad é o objeto de maior prioridade nesse conjunto, sua net (Pad_Net) será atribuída ao objeto colado. Passe o cursor sobre a imagem para ver o resultado.
Quando um objeto é colado em uma camada de cobre e se sobrepõe a um conjunto de objetos do mesmo tipo, será atribuída a net do objeto que estiver sob o cursor no momento do clique para colar.

A net do objeto sob o cursor é atribuída ao objeto colado. Aqui é mostrado um objeto (trilha) colado sobre um conjunto de objetos do mesmo tipo (pads). Como o pad 2 é o objeto que está sob o cursor no momento do clique para colar o objeto, a net desse pad (Pad2_Net) será atribuída ao objeto colado. Passe o cursor sobre a imagem para ver o resultado.
Quando um conjunto de objetos fisicamente conectados é colado em uma camada de cobre e objetos de tipos diferentes desse conjunto se sobrepõem a objetos existentes com nets diferentes, a net do objeto de maior prioridade desse conjunto será atribuída a todos os objetos colados. As prioridades acima se aplicam a esse caso.

A net atribuída ao objeto de maior prioridade é atribuída ao conjunto de objetos fisicamente conectados. Aqui é mostrado um conjunto de objetos conectados (da esquerda para a direita: preenchimento, região, trilha, arco, via e preenchimento poligonal) colado sobre objetos (vias) com nets diferentes atribuídas. Como o preenchimento é o objeto de maior prioridade nesse conjunto colado, a net atribuída a ele (Via1_Net) será atribuída a cada objeto desse conjunto. Passe o cursor sobre a imagem para ver o resultado.
Bloqueio de objetos de projeto
Os objetos de projeto podem ser bloqueados para impedir que sejam movidos ou editados no documento de PCB, habilitando seus atributos Locked . Por exemplo, se a posição ou o tamanho de determinados objetos for crítico, bloqueie-os. O bloqueio pode ser feito no painel Properties , clicando no ícone de cadeado dos objetos desejados, conforme mostrado nos exemplos a seguir.
Exemplos do ícone Lock no painel Properties para um componente e um pad selecionados.
Para alternar o estado da propriedade Locked de um objeto posicionado que tenha a propriedade Locked , você também pode clicar com o botão direito sobre o objeto no espaço de projeto e escolher o comando <ObjectType> Locked no menu de contexto. Quando o objeto já estiver bloqueado, a entrada do comando no menu exibirá um ícone de marca de seleção à esquerda.
Se você tentar mover ou girar um objeto de projeto que tenha a propriedade Locked habilitada, será exibida uma caixa de diálogo solicitando confirmação para prosseguir com a edição.
Bloqueio de primitivas de componentes
Se um componente de PCB estiver com suas primitivas bloqueadas (a opção Primitives no modo Componente do painel Propriedades estiver no estado , todas ou a maioria das propriedades dessas primitivas não poderão ser modificadas por métodos de edição gráficos (por exemplo, arrastar e soltar) e não gráficos (por exemplo, usando o painel Properties ou List). Isso ajudará a evitar alterações acidentais nas primitivas dos componentes que possam resultar em saídas incorretas de montagem e fabricação.
Como exemplo, o modo Pad do painel Propriedades é mostrado na imagem abaixo para um pad que é parte integrante de um componente de PCB com suas primitivas bloqueadas. Observe que todas as propriedades do pad (exceto as propriedades Net e Testpoint) estão esmaecidas e indisponíveis para edição. Observe também que o ícone
é mostrado na extremidade direita de Component do pad. campo, que indica que o componente pai está com suas primitivas bloqueadas e que as propriedades do pad não podem ser modificadas.

O modo Pad do painel Properties (à esquerda) para um pad de um componente de PCB com suas primitivas bloqueadas (à direita).
Edição reentrante
O Editor de PCB inclui um recurso avançado chamado re-entrant editing. Ele permite executar uma segunda operação usando atalhos de teclado sem encerrar a operação atual. A edição reentrante permite trabalhar de forma mais flexível e intuitiva. Por exemplo, imagine começar a posicionar uma trilha e perceber que outro segmento de trilha precisa ser excluído. Não é necessário sair do modo Roteamento interativo. Pressione as teclas de atalho E, D, exclua o segmento de trilha desejado e pressione a tecla Esc para retornar ao roteamento interativo do projeto.
Configuração da aparência do cursor de PCB
Por padrão, o cursor de PCB é uma pequena cruz verde de 90 graus. Isso pode ser configurado usando as opções Cursor Type e Cursor Color, na página Editor de PCB – Geral da caixa de diálogo Preferences . Por exemplo, uma cruz grande de 90 graus que se estende até as bordas da janela de projeto (opção Large 90) pode ser útil ao posicionar e alinhar objetos do projeto. Como alternativa, uma cruz de 45 graus (opção Small 45) pode ser útil se as opções de 90 graus forem difíceis de distinguir das linhas da grade.
Suporte a fontes TrueType
O Editor de PCB permite usar fontes baseadas em traços ou fontes TrueType para objetos relacionados a texto em um projeto (cadeias de texto/quadros de texto, cotas, tabelas de furação e/ou tabelas de empilhamento de camadas). A fonte é escolhida no painel Properties correspondente. Há três opções de fontes baseadas em traços disponíveis: Default, Sans Serif e Serif. O estilo Default é uma fonte vetorial simples que oferece suporte à plotagem com caneta e à fotoplotagem vetorial. As fontes Sans Serif e Serif são mais complexas e tornam mais lenta a geração de saídas vetoriais, como Gerber. As fontes baseadas em traços são integradas ao software e não podem ser alteradas. As três fontes contêm o conjunto completo de caracteres ASCII estendido da IBM, que oferece suporte ao inglês e a outros idiomas europeus. Ao usar fontes TrueType, as fontes TrueType e OpenType (um superconjunto de TrueType) encontradas na pasta \Windows\Fonts ficam disponíveis para uso. O recurso também oferece suporte completo a Unicode.
As geometrias dos objetos de texto que usam fontes TrueType são armazenadas automaticamente nos documentos de PCB. Quando objetos em um documento de PCB usam uma fonte TrueType, esses objetos serão exibidos com a mesma geometria de fonte quando o documento de PCB for aberto em outro computador, mesmo que essa fonte TrueType não esteja instalada.
Quando um objeto que usa uma fonte ausente é selecionado, uma mensagem de aviso aparece na parte superior do painel Properties. Ao alterar propriedades do objeto que afetam seu texto (por exemplo, a altura do texto ou o próprio texto), a caixa de diálogo Missing fonts é aberta, permitindo selecionar uma fonte substituta (Replacement). Habilite a opção Apply to all text elements para aplicar a fonte substituta a todos os objetos do documento de PCB que usam a fonte ausente.
A caixa de diálogo também aparece ao alterar propriedades relacionadas a texto no painel PCB List.
Ao tentar editar vários objetos que usam diferentes fontes ausentes, a caixa de diálogo permite selecionar uma substituta para cada fonte ausente.
Suporte à renderização de arcos reais
Há suporte a arcos reais gerados no espaço de projeto tanto do Editor de PCB quanto do Editor de Biblioteca de PCB, em vez de aproximações. Esse suporte abrange os modos de layout 2D/3D (e o modo de planejamento da placa no Editor de PCB). A renderização de arcos reais pode ser observada nas seguintes áreas:
-
Preenchimentos de polígonos (sólido, hachurado, nenhum)
-
Recortes de preenchimentos de polígonos
-
Contorno de seleção de preenchimentos de polígonos e regiões
-
Regiões
-
Expansões de máscara de solda e máscara de pasta
-
Realce de nets
-
Limites de espaçamento
-
Sobreposição de violação (preenchimento de polígono separado sobre uma região ou um preenchimento de polígono)
Exemplos de renderização de arcos reais em preenchimentos de polígonos ao redor de outros objetos de uma PCB são mostrados abaixo.
Informações da net
Para objetos de cobre em uma PCB (trilha, via, polígono etc.), as seguintes informações são apresentadas na região Net Information do painel Properties quando o objeto é selecionado:
- O Net, Diff Pair e/ou xSignal pai e a classe associada em cada caso. Observe que as entradas Diff Pair e xSignal são exibidas apenas se o objeto fizer parte de um par diferencial ou de um xSignal, respectivamente.
-
Delay – o atraso do(s) objeto(s) selecionado(s) e o atraso dos segmentos roteados de toda a net. Inclui os valores de Propagation Delay dos pads e das vias, caso tenham sido definidos para esses pads e vias.
-
Length – a soma dos comprimentos dos objetos selecionados e o Signal Length total. O Signal Length é o cálculo preciso da distância total entre nós. Os objetos posicionados são analisados para resolver objetos empilhados ou sobrepostos e caminhos sinuosos dentro dos pads; os comprimentos das vias também são incluídos. O Pin Package Length também é incluído se tiver sido definido para os pads. Se a rede não estiver completamente roteada, o comprimento Manhattan (X + Y) da linha de conexão também será incluído. Para obter mais informações sobre o Comprimento do sinal e suas aplicações, consulte as informações sobre o painel PCB - Nets.
-
Max Current - a corrente máxima que os objetos Trilha, Arco ou Via selecionados podem conduzir, determinada pela fórmula IPC-2221A (Seção 6.2):
I = k * ΔT0.44 * A0.725
onde:
I = corrente [amperes]
A = área da seção transversal [mils quadrados] (largura da trilha * espessura do cobre no empilhamento de camadas, ou Acilindro, conforme mostrado abaixo)
ΔT = elevação de temperatura permitida acima da temperatura ambiente [°C]
k = constante, tal que:k = 0.048 para camadas externas
k = 0.024 para camadas internas -
Resistance - a soma das resistências dos objetos Trilha, Arco e Via selecionados, determinada pela fórmula derivada:
R = (ρ * L / A)
onde:
R = resistência [Ω]
ρ = resistividade do cobre [Ω*mm2/m]
L = comprimento da trilha [m] (ou Comprimento da via, conforme descrito abaixo)
A = área da seção transversal = T * W [mm2] (ou Acilindro, conforme mostrado abaixo)
T = espessura da trilha (do empilhamento de camadas) [mm]
W = largura da trilha [mm]Assumptions:
- Temperatura ambiente = 22 °C
- Elevação de temperatura permitida = 20 °C
- Espessura da parede de cobre do furo passante = 0.018mm
- Resistividade do cobre = 0.017 Ω*mm2/m

A região Net Information do painel Properties. Aqui é mostrado um exemplo de uma trilha selecionada.
Clique em um link na região Net Information para abrir a rede/o par diferencial/o xSignal associado no painel PCB.
Atribuição de redes a objetos
O editor de PCB oferece várias maneiras de atribuir redes a objetos primitivos:
- Quando um ou mais objetos estiverem selecionados, use a lista suspensa do campo Nets no painel Properties. Todas as redes do projeto da placa ativo serão exibidas na lista suspensa. Selecione No Net para especificar que a trilha não está conectada a nenhuma rede. Como alternativa, você pode clicar no ícone Assign Net para escolher um objeto no espaço de projeto - a rede desse objeto será atribuída aos objetos selecionados.
- Clique com o botão direito sobre um ou mais objetos selecionados e escolha Net Actions » Assign Net. Após iniciar o comando, um cursor em cruz será exibido. Posicione o cursor em cruz sobre a rede à qual deseja atribuir os objetos e clique para selecionar essa rede.
- Para ressincronizar o nome da rede das primitivas de roteamento com o nome da rede dos pads aos quais elas se conectam, selecione o comando Design » Netlist » Update Free Primitives From Component Pads nos menus principais. Após executar o comando, uma caixa de diálogo de confirmação será aberta, perguntando se você deseja atualizar as redes das primitivas livres com as redes dos pads dos componentes. Após clicar em Yes, partindo de cada pad, o cobre conectado é selecionado e o nome da rede de cada primitiva é definido para corresponder ao do pad. Essa operação não afeta a netlist interna da PCB.
Para examinar e confirmar que os objetos fisicamente conectados estão atribuídos à rede correta para pertencerem a essa rede física (um physical net significa connected copper neste caso), você pode usar a caixa de diálogo Configure Physical Nets, acessada ao escolher o comando Design » Netlist » Configure Physical Nets nos menus principais. O software analisa o projeto, verificando se todos os pads e os objetos que os conectam fisicamente (trilhas, arcos, preenchimentos etc.) têm o mesmo nome de rede atribuído. Quando todos os objetos da rede estão corretos, a rede é exibida em verde. Se forem detectados objetos em contato, mas com uma rede diferente atribuída, eles serão sinalizados em vermelho. Um exemplo comum de quando isso pode ocorrer é quando o footprint de um componente contém objetos de cobre adicionais. Quando esse footprint é carregado durante a sincronização, o nome da rede atribuído é aplicado a cada pad, mas não ao cobre adicional. A caixa de diálogo é interativa; clique em uma rede ou primitiva para localizar o objeto correspondente no projeto. Clique com o botão direito ou clique no botão Menu para acessar os comandos disponíveis. A região Action da caixa de diálogo fornece controles para especificar a ação necessária para resolver problemas com o cobre conectado. Por padrão, as ações serão definidas automaticamente, mas podem ser ajustadas conforme necessário. Depois de definir as ações, clique no botão Execute para atualizar as atribuições de rede.

A caixa de diálogo Configure Physical Nets (exibindo a opção Only Show Errors ativada (ao fundo) e a opção Only Show Errors desativada (à frente)).
Opções e controles da caixa de diálogo Configurar redes físicas
-
Electrically Connected Copper - esta região lista grupos distintos de primitivas de cobre que estão eletricamente conectadas, conforme detectado nas conexões do projeto. Para cada grupo, são apresentadas as seguintes informações:
-
Primitive - no nível superior, esta entrada indica quantas primitivas existem no cobre conectado. As primitivas podem ser exibidas em uma lista simples ou agrupadas por tipo de primitiva. O agrupamento por tipo é configurado ativando a opção Show Primitive Groups nas opções do botão Menu . Nesse caso, as primitivas serão divididas nos seguintes grupos:
- Connected Component Primitives - lista todas as primitivas de pads de componentes como itens filhos. Elas também podem ser agrupadas pelo componente ao qual pertencem, ativando a opção Show Components do botão Menu .
- Connected Free Primitives - lista todas as primitivas de cobre que não pertencem a componentes como itens filhos, agrupadas por tipo de primitiva (preenchimentos, polígonos, trilhas, vias).
-
Primitive - no nível superior, esta entrada indica quantas primitivas existem no cobre conectado. As primitivas podem ser exibidas em uma lista simples ou agrupadas por tipo de primitiva. O agrupamento por tipo é configurado ativando a opção Show Primitive Groups nas opções do botão Menu . Nesse caso, as primitivas serão divididas nos seguintes grupos:
- Original Net Names - este campo indica o nome da rede atualmente atribuída à primitiva, ou seja, a rede à qual a primitiva está conectada no momento. A entrada será uma das redes definidas para a placa. No entanto, se uma primitiva não estiver conectada a uma rede, ela terá a entrada <Unassigned>.
-
Status - este campo fornece uma indicação de status de nível superior para o grupo, que pode ser um de quatro estados:
- Blank - a atribuição de redes para o agrupamento de cobre conectado está correta e nenhuma atualização é necessária. A entrada de nível superior do agrupamento aparece em verde.
- 1. Update Required - Unassigned Nets - neste estado, nenhuma das primitivas do agrupamento foi atribuída a uma rede. A entrada de nível superior do agrupamento aparece em amarelo.
- 2. Update Required - Some Unassigned Nets - neste estado, algumas primitivas foram atribuídas à mesma rede, mas outras ainda não foram atribuídas a nenhuma rede. A entrada de nível superior do agrupamento aparece em laranja.
- 3. Ambiguous - Multiple Net Names - neste estado, há primitivas no agrupamento que foram atribuídas a redes diferentes. Também pode haver primitivas ainda não atribuídas. A entrada de nível superior do agrupamento aparece em vermelho.
-
Action - esta região fornece controles para especificar a ação necessária para resolver problemas com o cobre conectado, além de apresentar o resultado da execução das alterações configuradas. Para cada agrupamento, são apresentados os seguintes elementos:
-
Proposed Action - este campo é usado para determinar qual ação, se houver, deve ser realizada. No nível mais alto de um agrupamento, esta entrada pode ser definida como Update Net To ou Don't Update Net To. Ao atualizar, escolha a nova rede de destino no campo New Net Name. Com base nessas duas configurações, o software calcula as ações a serem realizadas no nível das primitivas filhas, chegando a uma das seguintes propostas:
- No Action Required - a primitiva já está atribuída/conectada à rede de destino.
- Update - incluir a primitiva na atualização para que ela seja atribuída/conectada à nova rede de destino.
- Don't Update - não incluir a primitiva na atualização. Ela permanecerá conectada à rede atual.
- New Net Name - use este campo para definir uma nova rede de destino à qual as primitivas devem ser conectadas. A lista suspensa do campo apresenta todas as redes detectadas entre as primitivas do agrupamento de cobre conectado. Se precisar usar uma rede diferente, clique com o botão direito no campo e use o comando Change Copper Net To Board Net do menu de contexto. Isso abre a caixa de diálogo Choose Net, que lista todas as redes atualmente definidas para a placa. Escolha a rede desejada e clique em OK. Essa rede será inserida no campo.
- Done - este campo indica o sucesso ou a falha da ação de atualização depois que o botão Execute é pressionado e as alterações são aplicadas.
-
Proposed Action - este campo é usado para determinar qual ação, se houver, deve ser realizada. No nível mais alto de um agrupamento, esta entrada pode ser definida como Update Net To ou Don't Update Net To. Ao atualizar, escolha a nova rede de destino no campo New Net Name. Com base nessas duas configurações, o software calcula as ações a serem realizadas no nível das primitivas filhas, chegando a uma das seguintes propostas:
- Execute - quando estiver satisfeito com as ações atribuídas à netlist, clique neste botão para atualizar as atribuições de redes.
-
Menu - clique para acessar o seguinte menu de comandos relacionados à lista principal em geral ou às primitivas atualmente selecionadas. Os comandos são idênticos aos disponíveis no menu acessado com o botão direito na região da lista principal.
- Update/Don't Update/No Action - use para alternar rapidamente a ação proposta para as primitivas selecionadas. Em um nível pai mais alto na hierarquia de primitivas, use para alternar a ação proposta para todos os filhos descendentes.
- Select All - use para selecionar rapidamente todos os agrupamentos de cobre conectado (as entradas de nível mais alto da lista).
- Select All With Same Status - com uma entrada de agrupamento de cobre conectado de nível superior selecionada, use este comando para selecionar rapidamente todos os outros agrupamentos de nível superior com o mesmo status.
- Clear All Selected - use para desmarcar todas as entradas da lista.
- Expand All In Connected Copper - use para expandir rapidamente todos os agrupamentos filhos dentro do agrupamento de cobre conectado atualmente em foco.
- Expand All - use para expandir rapidamente todos os agrupamentos de todos os agrupamentos de cobre conectado da lista.
- Expand Children - use para expandir rapidamente todos os grupos filhos descendentes abaixo do agrupamento atualmente selecionado.
- Collapse All In Connected Copper - use para recolher rapidamente todos os agrupamentos filhos dentro do agrupamento de cobre conectado atualmente em foco.
- Collapse All - use para recolher rapidamente todos os agrupamentos de todos os agrupamentos de cobre conectado da lista.
- Collapse Children - use para recolher rapidamente todos os grupos filhos descendentes abaixo do agrupamento atualmente selecionado.
- Only Show Errors - habilite para mostrar apenas erros na caixa de diálogo. A lista apresentará apenas agrupamentos de cobre conectado cujo Status seja de nível 1, 2 ou 3. Desabilite para mostrar também o cobre conectado que está corretamente atribuído.
- Show Components - habilite para que as primitivas de pads de componentes sejam agrupadas por seus componentes pais.
- Show Primitive Groups - habilite para que as primitivas sejam agrupadas por tipo de primitiva.
- Animate Action Execution - habilite para que a caixa de diálogo percorra a lista à medida que a execução avança, mostrando de forma animada, em tempo real, o progresso da execução das alterações de redes. Ao desabilitar esta opção, as alterações serão executadas sem essa animação.
-
Warn On Netlist Change - habilite para receber um aviso quando as alterações afetarem a netlist da placa. A caixa de diálogo Netlist Change será aberta, informando quantas primitivas terão suas redes alteradas e que isso afetará a netlist. Você pode clicar em Continue ou clicar em Filter Affected para examinar mais detalhadamente as alterações propostas.

A caixa de diálogo Netlist Change - Show Component Pads - habilite para mostrar as primitivas de componentes conectadas na lista.
- Show Non Component Pads - habilite para mostrar as primitivas livres conectadas na lista.
- Show Changes That Affect Netlist - habilite para apresentar apenas uma lista das ações propostas (alterações) que afetarão a netlist da placa.
- Change Copper Net To - uma ou mais entradas de menu deste tipo aparecem quando não há muitas redes atualmente atribuídas às primitivas do agrupamento de cobre conectado em foco. Use uma dessas entradas para escolher rapidamente a rede de destino para o campo New Net Name.
- Change Copper Net To Net - esta entrada de menu aparece quando há redes demais atualmente atribuídas às primitivas de um agrupamento de cobre conectado para exibi-las como entradas de menu individuais. Este comando dá acesso à caixa de diálogo Choose Net, que lista todas as redes atualmente atribuídas às primitivas do agrupamento. Escolha a rede desejada e clique em OK; essa rede será inserida no campo New Net Name do agrupamento de cobre conectado em foco.
- Change Copper Net To Board Net - use este comando se precisar usar uma rede diferente das atualmente atribuídas às primitivas do agrupamento de cobre conectado em foco. Isso abre a caixa de diálogo Choose Net, que lista todas as redes atualmente definidas para a placa. Escolha a rede desejada e clique em OK; essa rede será inserida no campo New Net Name.
- Show All Primitives - clique neste botão para exibir rapidamente todas as primitivas. Este botão fica disponível se as opções Show Component Pads e/ou Show Non Component Pads estiverem desabilitadas no menu.
Você também pode remover todas as redes do documento de projeto atual, essencialmente limpando a netlist interna da PCB. Isso pode ser útil se você tiver alterado as informações de redes nos documentos esquemáticos de origem e quiser ressincronizar completamente sua PCB com as informações da netlist do esquemático de origem. Para fazer isso, escolha Design » Netlist » Clear All Nets comando nos menus principais. Após executar o comando, uma caixa de diálogo de confirmação será aberta, alertando que esta operação apagará todas as informações de redes da PCB. Após clicar em Yes, todas as informações de redes serão removidas. Qualquer trilha roteada permanecerá roteada, mas terá uma atribuição No Net. Todas as conexões lógicas não roteadas serão removidas.
Para criar um arquivo de netlist com base na conectividade criada pelo roteamento no projeto atual, selecione o comando Design » Netlist » Create Netlist From Connected Copper nos menus principais. Após clicar em Yes na caixa de diálogo de confirmação que se abre, uma netlist (Generated <PCBDocumentName>.Net, adicionada ao painel Projects como um documento avulso na subpasta Source Documents) é criada na mesma pasta do documento de projeto da PCB e aberta automaticamente como o documento ativo. Cada rede na netlist recebe seu nome de um dos pads aos quais o cobre roteado se conecta.

