Projeto de Alta Velocidade

Num relance

Este artigo explica como o Altium Designer oferece suporte ao layout de PCBs de alta velocidade, ajudando você a gerenciar a integridade de sinal, definir caminhos de sinais críticos e aplicar regras de roteamento com impedância controlada com base no empilhamento de camadas e nos materiais da sua placa. Ele apresenta os principais elementos de projeto a considerar, explica como a análise de integridade de sinal antes e depois do layout pode ser usada para identificar problemas de reflexão antecipadamente e mostra como recursos como xSignals, perfis de impedância e regras de roteamento trabalham em conjunto para orientar uma implementação precisa de alta velocidade. Se você quer entender melhor como configurar o Altium Designer para projetar placas de alta velocidade confiáveis, esta visão geral ajudará você a relacionar as ferramentas e configurações essenciais. Continue lendo e ganhe confiança passo a passo.

- Entenda os principais fatores de projeto de alta velocidade que o Altium Designer ajuda você a gerenciar, desde terminações e caminhos de retorno até vias, pares diferenciais e controle de comprimento.
- Veja como a análise de integridade de sinal pode ser usada antes e depois do layout para identificar possíveis problemas de reflexão e aprimorar as decisões sobre terminação.
- Saiba como xSignals, perfis de impedância do empilhamento de camadas e regras de projeto de roteamento são usados para definir, medir e controlar rotas críticas de alta velocidade.
Aprofunde-se com a IA:

Projeto de alta velocidade no Altium Designer

O projeto de placas de circuito impresso de alta velocidade é um processo de equilíbrio entre os requisitos do projeto do circuito, as tecnologias dos dispositivos e os materiais e métodos de fabricação, para produzir uma PCB capaz de transferir sinais entre os componentes com integridade.

Esta página descreve as diversas opções e configurações que você pode definir no Altium Designer para projetar sua placa de alta velocidade com sucesso. Se você quiser saber mais sobre projetos de alta velocidade, confira os Elementos essenciais do projeto de PCBs de alta velocidade.

Elementos a considerar

O processo de roteamento de uma placa com sinais de alta velocidade exige que você gerencie:

  • Os componentes de terminação que possam ser necessários

  • A definição dos sinais aos quais devem ser aplicadas regras de projeto de alta velocidade

  • As dimensões mecânicas das trilhas — para roteamento com impedância controlada

  • As propriedades e dimensões dos materiais da placa

  • A quantidade e a disposição das camadas no empilhamento de camadas

  • O caminho de retorno de cada sinal de alta velocidade

  • O impacto e a configuração das vias

  • A configuração e o roteamento dos pares diferenciais

  • A configuração e o controle dos comprimentos das trilhas

Análise de integridade de sinal pré e pós-layout

No início do processo de projeto, é importante identificar os sinais que podem exigir casamento de impedância para que componentes de terminação adicionais possam ser incluídos antes da conclusão do posicionamento dos componentes. Como os pinos de saída normalmente apresentam baixa impedância e os pinos de entrada normalmente apresentam alta impedância, pode ser necessário adicionar componentes de terminação ao projeto para obter o casamento de impedância.

O Altium Designer inclui um simulador de integridade de sinal que pode ser acessado tanto na fase de captura do projeto quanto na fase de layout da placa, permitindo realizar análises de integridade de sinal pré e pós-layout (Tools » Signal Integrity). O simulador de integridade de sinal modela o comportamento da placa roteada usando a impedância característica calculada das trilhas, combinada com informações de macromodelos dos buffers de E/S, como entrada para as simulações. O simulador é baseado em um simulador rápido de reflexões e diafonia, que produz simulações muito precisas usando algoritmos comprovados pela indústria.

Como tanto a captura do projeto quanto o projeto da placa usam um sistema integrado de componentes que vincula os símbolos esquemáticos aos respectivos footprints de PCB, modelos de simulação SPICE e macromodelos de integridade de sinal, a análise de integridade de sinal pode ser executada na etapa de captura do esquemático, antes da criação do projeto da placa. Quando ainda não existe um projeto de placa, a ferramenta permite configurar as características físicas do projeto, como a impedância característica desejada das trilhas, no próprio simulador de integridade de sinal. Nessa etapa pré-layout do processo de projeto, o simulador de integridade de sinal não consegue determinar o comprimento real de conexões específicas e, por isso, usa um comprimento médio de conexão definido pelo usuário para realizar os cálculos de linha de transmissão. Ao escolher cuidadosamente esse comprimento padrão para refletir as dimensões da placa pretendida, você pode obter uma visão bastante precisa do provável desempenho do projeto em termos de integridade de sinal.

As redes com possíveis problemas de reflexão podem ser identificadas, e quaisquer componentes de terminação adicionais podem ser incluídos no esquemático antes de prosseguir para o layout da placa. Os valores desses componentes podem então ser ajustados com maior precisão após a análise de integridade de sinal pós-layout.

O mecanismo de análise de integridade de sinal ajuda a identificar redes com possíveis problemas de reflexão. Observe que as medições podem ser feitas diretamente nas formas de onda.
O mecanismo de análise de integridade de sinal ajuda a identificar redes com possíveis problemas de reflexão. Observe que as medições podem ser feitas diretamente nas formas de onda.

► Saiba mais sobre Casamento de impedância dos componentes

Para acessar o mecanismo de análise de integridade de sinal no Altium Designer, a extensão de sistema Signal Integrity Analysis deve estar instalada. Essa extensão é instalada por padrão com o Altium Designer. Ela pode ser instalada ou removida manualmente.

Para obter mais informações sobre o gerenciamento de extensões, consulte a página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Definição dos sinais de alta velocidade

Main page: Definição de caminhos de sinais de alta velocidade com xSignals

O projeto de alta velocidade é a arte de gerenciar o fluxo de energia de um ponto a outro de uma placa de circuito. Como projetista, você precisa ser capaz de concentrar sua atenção e aplicar as restrições de projeto a um sinal que percorre o caminho de um ponto da placa a outro. No entanto, esse sinal no qual você está se concentrando não é necessariamente uma única rede da PCB. O sinal pode ser uma ramificação de A0 em um projeto que você pretende rotear em uma topologia de ramificação em T, sendo a outra ramificação de A0 outro sinal ao qual você também precisa dedicar atenção, além de poder comparar os comprimentos das trilhas desses dois sinais. Ou o sinal pode incluir um componente de terminação em série em seu caminho (que o editor de PCB identifica como um componente e duas redes de PCB) e, se esse sinal fizer parte de um par diferencial, seu comprimento precisará ser comparado ao comprimento do outro sinal desse par.

Você pode gerenciar esses requisitos usando um recurso conhecido como xSignals, no qual um xSignal é essencialmente um caminho de sinal definido pelo usuário. Você seleciona o pad de origem e o pad de destino (na área de trabalho ou no painel PCB) e, em seguida, clica com o botão direito do mouse em qualquer um deles para definir esse caminho de sinal como um xSignal. Além de definir interativamente um xSignal por seus pads inicial e final, você também pode executar o assistente inteligente xSignals Wizard, cujas heurísticas ajudam a configurar rapidamente um grande número de xSignals entre os componentes escolhidos. Esses xSignals podem então ser usados para direcionar regras de projeto aos seus sinais de alta velocidade. O software compreende a estrutura desses xSignals; por exemplo, calcula o comprimento total de várias redes conectadas por meio de um componente de terminação, bem como a distância percorrida através desse componente.

O painel PCB inclui um modo xSignal usado para examinar e gerenciar os xSignals. O painel também fornece informações sobre o comprimento do sinal, destacando os xSignals que estão próximos de atender (amarelo) ou que não atendem (vermelho) às restrições de projeto aplicáveis. Na imagem abaixo, os comprimentos dos xSignals do par diferencial CLK1 diferem entre si mais do que o permitido pela regra de projeto de correspondência de comprimentos aplicável. O painel inclui o Signal Length, que representa um comprimento preciso de ponto a ponto. As inconsistências tradicionais de comprimento, como trilhas dentro de pads e segmentos de trilha sobrepostos, são resolvidas, e as distâncias exatas percorridas pelas vias são usadas para calcular o comprimento do sinal.

Use o modo xSignals do painel PCB  para gerenciar e investigar seus xSignals. Observe a linha fina; ela indica o caminho do sinal através de um componente em série. (Imagem cedida por FEDEVEL Open Source, www.fedevel.com)
Use o modo xSignals do painel PCB para gerenciar e investigar seus xSignals. Observe a linha fina; ela indica o caminho do sinal através de um componente em série. (Imagem cedida por FEDEVEL Open Source, www.fedevel.com)

O atraso causado pelo comprimento do pino dentro do encapsulamento do dispositivo também é considerado, por meio da definição do Atraso do pino no encapsulamento.

► Saiba mais sobre xSignals.

Definição das propriedades do roteamento

Main page: Roteamento com impedância controlada

Tradicionalmente, os projetistas de placas definiam as larguras e a espessura do roteamento inserindo uma dimensão para a largura e selecionando uma espessura de cobre para aquela camada. Isso geralmente era suficiente, pois bastava garantir que as trilhas suportassem a corrente e que as distâncias de isolamento exigidas para a tensão fossem mantidas. Essa abordagem não é suficiente para os sinais de alta velocidade do seu projeto; para eles, é necessário controlar a impedância das trilhas.

O roteamento com impedância controlada consiste em configurar as dimensões das trilhas e as propriedades dos materiais da placa para obter uma impedância específica. Isso é feito definindo um perfil de impedância adequado e, em seguida, atribuindo esse perfil às redes críticas de alta velocidade nas regras de projeto de roteamento.

Definição do perfil de impedância

Main page: Configuração do empilhamento de camadas para roteamento com impedância controlada

Os perfis de impedância são definidos no Layer Stack Manager (Design » Layer Stack Manager) do editor de PCB. O Layer Stack Manager é aberto em um editor de documentos, da mesma forma que uma folha de esquemático, a PCB e outros tipos de documento.

Depois de configurar as propriedades das camadas, acesse a aba Layer Stack Manager's Impedance para adicionar ou editar perfis de impedância para sinais individuais ou diferenciais.

Um perfil de impedância de 50Ω definido para redes individuais roteadas na camada superior. Passe o cursor sobre a imagem para exibir as configurações do mesmo perfil para a camada L3.Um perfil de impedância de 50Ω definido para redes individuais roteadas na camada superior. Passe o cursor sobre a imagem para exibir as configurações do mesmo perfil para a camada L3.

Os cálculos de impedância são realizados pelo mecanismo eletromagnético de integridade de sinal Simbeor® SFS, da Simberian. O Simbeor SFS é um solucionador avançado de campos 2D quase estáticos baseado no Método dos Momentos, validado por convergência, comparações e medições. O mecanismo Simbeor SFS oferece suporte a todas as estruturas e materiais modernos de placas, incluindo o uso de polígonos em camadas de sinal como camadas de referência.

► Saiba mais sobre Configuração do empilhamento de camadas para roteamento com impedância controlada

Configuração das regras de projeto

A impedância do roteamento é determinada pela largura e pela espessura da trilha e pelas propriedades dos materiais dielétricos ao seu redor. Com base nas propriedades dos materiais definidas no Layer Stack Manager, as larguras de roteamento necessárias são calculadas quando cada perfil de impedância é criado. Dependendo das propriedades dos materiais, a largura pode mudar quando a camada de roteamento é alterada. Essa necessidade de alterar as larguras ao mudar de camada de roteamento é gerenciada automaticamente pela regra de projeto de roteamento aplicável, configurada no Editor de regras e restrições de PCB (Design » Rules).

Na maioria dos projetos de placas, haverá um conjunto específico de redes a serem roteadas com impedância controlada. Uma abordagem comum é criar uma classe de redes ou uma classe de pares diferenciais que inclua essas redes e, em seguida, criar uma regra de roteamento direcionada a essa classe, conforme mostrado nas imagens abaixo.

Normalmente, você define manualmente as larguras mínima, máxima e preferencial, seja nas configurações de restrições superiores, para aplicá-las a todas as camadas, seja individualmente para cada camada na grade de camadas. Para o roteamento com impedância controlada, em vez disso, habilite a opção Use Impedance Profile e selecione o perfil de impedância desejado na lista suspensa. Ao fazer isso, a região Constraints da regra será alterada. A primeira coisa que você notará é que a região de camadas disponíveis da regra de projeto deixará de mostrar todas as camadas de sinal da placa e passará a mostrar apenas as camadas habilitadas no perfil de impedância selecionado. Os valores de largura preferencial (e de espaçamento do par diferencial) serão atualizados para refletir as larguras (e os espaçamentos) calculadas para cada camada. Esses valores preferenciais não podem ser editados, mas os valores mínimo e máximo podem; defina-os com valores menores/maiores adequados.

Regra de projeto de largura de roteamento

Para redes de sinal individual, a largura de roteamento é definida pela regra de projeto Largura de roteamento.

Quando você opta por usar um perfil de impedância, as camadas disponíveis e as larguras preferenciais são controladas pelo perfil selecionado.Quando você opta por usar um perfil de impedância, as camadas disponíveis e as larguras preferenciais são controladas pelo perfil selecionado.

Regra de projeto de roteamento de pares diferenciais

O roteamento de pares diferenciais é controlado pela regra de projeto Roteamento de pares diferenciais.

Para um par diferencial, as camadas disponíveis, a largura preferencial e o espaçamento preferencial são controlados pelo perfil selecionado.Para um par diferencial, as camadas disponíveis, a largura preferencial e o espaçamento preferencial são controlados pelo perfil selecionado.

► Saiba mais sobre Roteamento de pares diferenciais

Há muito debate sobre os cantos nas trilhas de sinais de alta velocidade. Embora haja consenso de que os elétrons não sairão voando ao atingir um canto de 90 graus, um canto tradicional de 90 graus é mais largo ao longo da diagonal, o que altera a impedância da trilha. Cantos arredondados ou de 45 graus são preferíveis — ambos são recursos padrão do roteador interativo do editor de PCB — e, se necessário, os cantos de 90 graus podem ser chanfrados usando o comando Convert Selected Tracks to Chamfered Path. Observe que esse comando converte os segmentos de trilha selecionados em um único objeto de região.

Escolha da impedância

Como saber qual impedância-alvo selecionar? Normalmente, ela é determinada pela impedância característica da fonte da família lógica ou tecnologia utilizada. Por exemplo, a lógica ECL tem uma impedância característica de 50Ω, e a TTL tem uma faixa de impedância de fonte de 70Ω a 100Ω. Uma impedância-alvo de 50Ω a 60Ω é comum em muitos projetos e, para pares diferenciais, é comum uma impedância diferencial de 90Ω ou 100 Ω. Lembre-se: quanto menor a impedância, maior o consumo de corrente; quanto maior a impedância, maior a possibilidade de emissão de interferência eletromagnética (EMI) e maior a suscetibilidade desse sinal à diafonia.

Um par diferencial de 100Ω também pode ser visto como duas trilhas de sinal individual de 50Ω com o mesmo comprimento. Isso não é totalmente correto devido ao acoplamento que ocorre entre as trilhas do par, que se torna mais forte à medida que elas se aproximam, reduzindo a impedância diferencial do par. Para manter a impedância diferencial de 100Ω , a largura de cada trilha pode ser reduzida, o que aumenta ligeiramente a impedância característica de cada trilha do par em alguns ohms.

Definição das propriedades da placa

Main page: Gerenciamento do empilhamento de camadas

Os materiais utilizados nas camadas da placa, suas dimensões, a quantidade de camadas e a ordem em que são dispostas são todos definidos no Gerenciador de empilhamento de camadas. Nele, você configura as diversas camadas necessárias para fabricar a placa final, incluindo as camadas de cobre de sinal e de plano, as camadas dielétricas que separam o cobre, as camadas de cobertura e a serigrafia dos componentes.

Todas as camadas a serem fabricadas são definidas na aba Empilhamento do Gerenciador de empilhamento de camadas.
Todas as camadas a serem fabricadas são definidas na aba Empilhamento do Gerenciador de empilhamento de camadas.

Informações detalhadas sobre as propriedades dos materiais inseridas no Layer Stack Manager são incluídas na Tabela de empilhamento de camadas e também na Legenda de empilhamento de camadas inserida em um documento do Draftsman.

Você também pode Save um empilhamento de camadas como modelo no Layer Stack Manager (menu File) e Load esse modelo em projetos futuros.

Configuração das vias

Main page: Definição dos tipos de via

Como mencionado na seção de visão geral desta página, as vias afetam a impedância do roteamento de sinais e são um fator importante a considerar em projetos de alta velocidade. Além do comprimento, do diâmetro do furo e da área da ilha da via, que afetam a impedância vista pelo sinal, qualquer trecho não utilizado do corpo metalizado de uma via pode atuar como um stub, contribuindo para reflexões do sinal. Para controlar esse efeito, podem ser fabricados vários tipos de vias entre camadas, incluindo vias cegas, enterradas, microvias (µVia) e vias com salto de camada. Todos esses tipos de vias são compatíveis com o Altium Designer.

As vias são definidas como parte do empilhamento de camadas, na aba Layer Stack Manager's Via Types. Também há suporte à retrofuração de trechos não utilizados do corpo metalizado das vias, definida na aba Layer Stack Manager's Back Drills (saiba mais sobre como configurar a placa para retrofuração).

Todos os tipos de vias que podem ser fabricados podem ser definidos na aba Tipos de vias do Gerenciador de empilhamento de camadas.Todos os tipos de vias que podem ser fabricados podem ser definidos na aba Tipos de vias do Gerenciador de empilhamento de camadas.

Foram realizados estudos quantitativos para compreender o impacto das vias, como a nota de aplicação AN529 da Altera, Técnicas de otimização de vias para projetos de canais de alta velocidade.

Resumindo esse estudo e outras referências, as diretrizes a seguir ajudam a minimizar o impacto das vias:

  • Reduza o tamanho do anel anular da via no ponto em que a trilha de sinal se conecta à via. A nota de aplicação sugere um diâmetro de via/furo de 20/10 mil (0,5/0,25 mm) para vias com furação mecânica.
  • Remova os anéis anulares não utilizados (também conhecidos como NFPs, ou ilhas não funcionais) nas camadas às quais a via não está conectada. Use o comando Tools » Remove Unused Pad Shapes para fazer isso.
  • Aumente a distância de isolamento entre o corpo metalizado da via e as camadas de plano adjacentes. Isso é controlado pela regra de projeto de distância de isolamento do plano de alimentação; a nota de aplicação sugere de 40 a 50 mil (1,0 a 1,25 mm). Observe que isso aumenta o tamanho das aberturas nessas camadas de plano.
  • Posicione vias de costura próximas às vias de sinal sempre que a trilha de sinal mudar de camada e isso fizer com que o caminho de retorno passe para outra camada. Se a nova camada do plano de referência tiver a mesma tensão que o plano de referência original, esses planos devem ser interligados por uma via, a uma distância de até 35 mil (0,9 mm) da via de sinal (de centro a centro).
  • Quando a trilha de sinal mudar de camada e a nova camada do plano de referência tiver uma tensão diferente, posicione capacitores de desacoplamento próximos à via de sinal. Esse capacitor faz o desacoplamento diretamente entre os dois planos, independentemente das tensões presentes neles. Observe que essa solução pode resultar no acoplamento de ruído de um plano para o outro, portanto, deve ser usada apenas como último recurso para reduzir a área do laço do caminho de retorno.
  • Remova os stubs das vias (o comprimento excedente da via além da camada em que a trilha de sinal se conecta à via). Isso é feito usando vias cegas e enterradas adequadas ou por meio da retrofuração das vias durante a fabricação.

O projeto das vias é um elemento fundamental no processo de projeto de placas de alta velocidade. As opções possíveis de conexão de vias entre camadas são determinadas pelo processo de fabricação escolhido para produzir o empilhamento de camadas, o que significa que os processos de fabricação e furação devem ser escolhidos durante a definição do tipo de via e do empilhamento de camadas.

O editor de PCB oferece suporte à retrofuração (também chamada de furação com profundidade controlada). O recurso permite a retrofuração pelos dois lados da placa, e os locais retrofurados podem ser facilmente examinados no painel PCB, com a placa exibida no modo 3D.

Leia mais sobre Furação com profundidade controlada.

Gerenciamento do caminho de retorno para sinais de alta velocidade

Um caminho de retorno de boa qualidade é essencial para cada sinal de alta velocidade no projeto. Sempre que o caminho de retorno se desvia e não passa sob a trilha de sinal, forma-se um laço que gera interferência eletromagnética (EMI), cuja intensidade está diretamente relacionada à área desse laço.

Criação de planos de alimentação

  • Um plano de alimentação pode ser criado a partir de uma camada de plano ou de uma camada de sinal coberta por um ou mais polígonos.
  • Criação de um plano de alimentação com uma camada de plano:
    • As camadas de plano são adicionadas no Layer Stack Manager. Clique com o botão direito do mouse em uma camada existente para Insert layer above ou Insert layer below e adicionar uma nova camada de plano.
    • Com a camada de plano selecionada como camada ativa, clique duas vezes em qualquer ponto do plano para abrir a caixa de diálogo Dividir plano, na qual é possível atribuir a rede.
    • O software recua automaticamente a borda do plano em relação à borda da placa pelo valor especificado na coluna Pullback Distance dessa camada no Layer Stack Manager. Se essa coluna não estiver visível, clique com o botão direito do mouse no cabeçalho de uma coluna existente para acessar o comando Select Columns.
    • Uma camada de plano pode ser dividida em regiões separadas por meio da inserção de linhas (Place » Line). Pressione Tab após começar a inserir o primeiro segmento de linha para definir a largura da linha de divisão. Insira os segmentos de linha de uma borda da placa à outra ou crie uma forma fechada para uma ilha. O software detectará automaticamente as formas separadas criadas pelas linhas de divisão; clique duas vezes em cada forma para atribuí-la a uma rede.
  • Criação de um plano de alimentação com polígonos em uma camada de sinal:
    • As camadas de sinal são adicionadas no Layer Stack Manager. Clique com o botão direito do mouse em uma camada existente para Insert layer above ou Insert layer below e adicionar uma nova camada de sinal.
    • Se forem necessárias zonas de alimentação separadas, pode ser mais fácil cobrir toda a camada com um polígono e depois recortá-lo (Place » Slice Polygon Pour). Pressione Tab após começar a inserir a linha de corte para abrir a caixa de diálogo Restrições de linha, na qual é possível definir a largura do corte — essa largura será a distância entre os dois polígonos criados pela operação de corte. A linha de corte deve começar fora do polígono e terminar fora dele.
    • Para preencher novamente um polígono, clique com o botão direito do mouse e selecione Polygon Actions » Repour Selected no menu de contexto. 
    • Os polígonos também podem ser suspensos (ocultados temporariamente). Clique com o botão direito do mouse e selecione o comando correspondente no Polygon Actions submenu. Use esse recurso quando precisar mover componentes e trilhas.
  • Pode ser útil exibir as diferentes redes em cores distintas, como mostrado nas imagens abaixo. Isso pode ser feito no esquemático ou na PCB; saiba mais sobre Como aplicar cores às redes.

A primeira imagem mostra uma camada de plano dividida em zonas de 3v3 e 5v0; a segunda mostra uma camada de sinal com um polígono de 3v3 e outro de 5v0. Foram atribuídas cores às redes e o realce foi ativado.  Two power zones created by polygons on a signal layerA primeira imagem mostra uma camada de plano dividida em zonas de 3v3 e 5v0; a segunda mostra uma camada de sinal com um polígono de 3v3 e outro de 5v0. Foram atribuídas cores às redes e o realce foi ativado.

O plano como caminho de retorno do sinal

Um caminho de retorno de boa qualidade é aquele em que:

  • Não há interrupções, divisões ou aberturas (furos no plano criados por uma via ou um pino de furo passante) sob a trilha de sinal no plano que fornece o caminho de retorno (o plano mais próximo do sinal de interesse).
  • A largura do caminho de retorno deve ser, idealmente, 3 vezes a largura da trilha de sinal ou 3 vezes a distância da trilha ao plano, o que for menor. Embora a maior densidade de corrente esteja diretamente abaixo da trilha de sinal, ela também se espalha pelo plano em ambos os lados da trilha, com aproximadamente 95% da corrente fluindo dentro de uma faixa de 3 vezes a largura da trilha. Interrupções no plano dentro dessa região aumentam a impedância do caminho de retorno, e qualquer desvio nesse caminho criará um laço. Em termos de integridade de sinal, esse aumento na impedância do caminho de retorno afeta a qualidade do sinal tanto quanto um aumento na impedância do caminho do sinal.
  • A área do laço foi minimizada. Em geral, é mais importante reduzir a área do laço do que minimizar o comprimento da trilha de sinal. Se o caminho de retorno encontrar uma abertura no plano, considere refazer o roteamento do sinal para adequá-lo a um caminho de retorno disponível. 
  • Quando um plano de alimentação fornece o caminho de retorno, a energia de retorno chegará ao terra por meio de um capacitor de desacoplamento. Avalie cuidadosamente a localização dos capacitores de desacoplamento próximos ao pino de origem do sinal para minimizar o tamanho de qualquer laço criado.

Gerenciamento de planos de alimentação e terra divididos e múltiplos

Há um consenso geral de que um plano de terra não deve ser dividido, a menos que haja um requisito específico para isso e você saiba como defini-lo e gerenciá-lo. Em vez disso, os componentes devem ser organizados de modo a manter os componentes ruidosos separados dos componentes de baixo ruído, além de agrupá-los de acordo com a linha de alimentação que utilizam.

Outros pontos a considerar sobre os planos de alimentação e terra incluem:

  • Se o projeto exigir que um plano de terra seja parcialmente dividido, os sinais que atravessam essas áreas deverão ser roteados sobre a ponte (a região sem divisão abaixo dela).
  • Se você estiver tentando minimizar o ruído do circuito, é melhor usar planos de terra adicionais do que dividir um plano e, sempre que possível, incluir camadas de plano para as linhas de alimentação e de terra de cada fonte de alimentação regulada. 
  • Se o projeto incluir várias linhas de alimentação, cada uma distribuída em seu próprio plano, certifique-se de que cada plano de alimentação tenha como referência apenas seu próprio plano de terra. Não permita que um plano de alimentação se sobreponha ao plano de terra de outra linha de alimentação, usando-o como referência. Isso cria acoplamento capacitivo, permitindo que o ruído passe de uma fonte para outra.
  • Se o plano adjacente for um plano de alimentação que precise ser dividido em áreas de tensões diferentes, talvez seja necessário realizar o desacoplamento diretamente entre as duas áreas de tensão para fornecer um caminho de retorno adequado.

Visualização de planos divididos

Para ajudar na verificação visual dos caminhos de retorno, você pode configurar a exibição para examinar com mais facilidade o caminho de retorno sob as trilhas de sinais críticos.

Verificação de sinais que passam sobre uma linha de divisão ao atravessar áreas de tensões diferentes no plano. As quatro redes destacadas cruzam uma divisão no plano de alimentação VCC, criando uma interrupção no caminho de retorno desses sinais.
Verificação de sinais que passam sobre uma linha de divisão ao atravessar áreas de tensões diferentes no plano. As quatro redes destacadas cruzam uma divisão no plano de alimentação VCC, criando uma interrupção no caminho de retorno desses sinais.

Para fazer isso:

  • Atribua uma cor a cada rede de alimentação. Saiba mais em Aplicação de cores às redes.
  • Limite a exibição das camadas para mostrar apenas as camadas de sinal e de plano relevantes. Esse conjunto de camadas pode ser salvo como um conjunto de camadas. Saiba mais sobre como criar um conjunto de camadas.
  • Mude para a camada de sinal e Ctrl+Click na rede de interesse para destacá-la (inclua Shift ao clicar para destacar várias redes). A vantagem de destacar em vez de selecionar é que o destaque é persistente: as redes permanecerão destacadas se você clicar em outro lugar. Pressione Shift+C para limpar o conjunto atual de destaques.
  • O destaque é obtido esmaecendo os demais objetos no espaço de projeto. O nível de Dimmed Objects é definido na seção Configurações de máscara e esmaecimento do painel View Configuration.
  • Torne a camada de plano a camada ativa.

Suas redes ficarão em evidência, e será mais fácil visualizar quaisquer divisões ou descontinuidades no caminho de retorno, como linhas de divisão ou aberturas criadas por ilhas de furos passantes e vias. 

  • Tanto camadas de plano quanto camadas de sinal cobertas por polígonos podem ser usadas como planos de linhas de alimentação.
  • Você pode garantir que os sinais não sejam roteados inadvertidamente sobre uma divisão em um plano colocando uma área de exclusão ao longo da divisão, na camada de exclusão.

Detecção de interrupções no caminho de retorno

Interrupções ou estreitamentos no caminho de retorno podem ser detectados pela regra de projeto de caminho de retorno. A regra de projeto de caminho de retorno verifica a existência de um caminho de retorno de sinal contínuo nas camadas de referência designadas, acima ou abaixo dos sinais abrangidos pela regra. O caminho de retorno pode ser criado a partir de preenchimentos, regiões e preenchimentos poligonais colocados na camada de sinal de referência, ou pode ser uma camada de plano.

As camadas de caminho de retorno são as camadas de referência definidas no Impedance Profile selecionado na regra de projeto de caminho de retorno. Essas camadas são verificadas para garantir que o Minimum Gap especificado (largura além da borda do sinal) exista ao longo do caminho do sinal. Adicione uma nova regra de projeto de caminho de retorno na categoria de regras High Speed.

 
 
 
 
 

As camadas de caminho de retorno são definidas no Impedance Profile selecionado; a largura do caminho (além da borda do sinal) é definida pelo Minimum Gap.
As camadas de caminho de retorno são definidas no Impedance Profile selecionado; a largura do caminho (além da borda do sinal) é definida pelo Minimum Gap.

A imagem abaixo mostra erros de caminho de retorno detectados para o sinal NetX, com a configuração de Minimum Gap definida como 0.1mm. Pode ser mais fácil localizar erros de caminho de retorno configurando o DRC Violation Display Style para mostrar os detalhes das violações, mas não a sobreposição das violações, na caixa de diálogo Preferências – mostrar imagem. Isso destaca os locais exatos onde a regra não foi atendida, em vez de destacar todos os objetos que apresentam violações. 

Para evitar a detecção de pequenos erros, como a seção destacada no segmento de trilha diagonal na imagem acima, ajuste a configuração PCB.Rules.ReturnPathIgnoreArea na caixa de diálogo Configurações avançadas. Por padrão, são ignoradas as áreas < 10 sq mils.

Verificação de vias do caminho de retorno

Este recurso está disponível quando a opção PCB.Rules.CheckReturnPathVia está habilitada na caixa de diálogo Configurações avançadas.

 
 
 
 
 

Quando um sinal de alta velocidade passa de um plano de referência para outro, também devem existir vias de retorno para conduzir os sinais de retorno entre os planos. Para verificar se existe uma via desse tipo dentro de uma distância específica de uma via de sinal, defina se uma via do caminho de retorno deve estar presente dentro de uma determinada distância de uma via do sinal abrangido pela regra usando a opção Max Stitch Via Distance na regra de projeto de caminho de retorno aplicável. A via do caminho de retorno deve fornecer conexão à camada de referência definida em Layer Stack Manager para o perfil de impedância correspondente.

Com Max Stitch Via Distance definido na regra, a presença de uma via do caminho de retorno dentro da distância especificada é verificada como parte da DRC em lote.

Um exemplo de violação da restrição de distância máxima da via de costura. Aqui, uma via da net DQS4R_N não tem nenhuma via do caminho de retorno dentro da distância especificada.
Um exemplo de violação da restrição de distância máxima da via de costura. Aqui, uma via da net DQS4R_N não tem nenhuma via do caminho de retorno dentro da distância especificada.

Configuração e roteamento de pares diferenciais

Main pages: Roteamento de pares diferenciais, Roteamento com impedância controlada

A definição dos pares diferenciais pode ser feita durante a captura do esquemático ou após a transferência do projeto para o layout da placa. Um requisito fundamental para definir um par no esquemático é incluir um _P ou _N no final do nome de cada uma das nets relevantes. Os pares diferenciais são identificados no esquemático colocando um Differential Pair directive em cada net ou colocando um em um Blanket directive, em que a diretiva Blanket se sobrepõe a um conjunto de rótulos de net com nomenclatura de par diferencial contidos nela, conforme mostrado na imagem abaixo.

Example of how a Blanket directive can be used with a Differential Pair directive to target multiple nets

Uma Blanket pode ser usada para configurar várias nets como membros de pares diferenciais.

Como trabalhar com pares diferenciais:

  • No editor de PCB, os pares diferenciais podem ser definidos no modo Editor de pares diferenciais do painel PCB. Para simplificar o processo de definição das regras de projeto que se aplicam aos pares diferenciais, eles podem ser atribuídos a classes de nets ou a classes de pares diferenciais, ambas definidas no Explorador de classes de objetos.
  • Para rotear um par diferencial com impedância controlada, crie um perfil de impedância no Layer Stack Manager. Saiba mais sobre Roteamento com impedância controlada.
  • As propriedades do roteamento de pares diferenciais são definidas pela regra de projeto Roteamento de pares diferenciais.
  • Para rotear um par diferencial, use o comando de roteamento Par diferencial interativo. Clique no pad _P ou _N para iniciar o roteamento e use Spacebar para alternar entre os formatos de saída de roteamento disponíveis. O comportamento do roteamento é o mesmo do roteamento de uma única net; pressione Shift+F1 para ver uma lista de atalhos de roteamento interativo. Ao se aproximar dos pads de destino, pressione Ctrl+Click para concluir o roteamento até os pads.

Regras práticas para pares diferenciais:

  • O casamento de comprimentos é fundamental para que os pares diferenciais sejam eficazes; mantenha os comprimentos casados dentro de uma tolerância adequada à tecnologia de sinalização. Por exemplo, case os comprimentos dos pares USB 3.x com uma tolerância de 5 a 10 mil. Outra regra prática utilizada é casar os comprimentos para que a diferença corresponda a, no máximo, 20% do tempo de subida do sinal. A sinalização diferencial funciona porque a energia de retorno flui de volta pelo outro membro do par; quanto maior a diferença entre os comprimentos, maior a quantidade de energia que retorna pela camada de plano mais próxima.

  • Descontinuidades no acoplamento, como quando os membros do par são roteados por lados opostos de um obstáculo, aumentam a impedância. Pode ser melhor rotear todo o par com um acoplamento mais fraco (por exemplo, com espaçamento de 2 vezes a largura da trilha de sinal) para reduzir a variação de impedância causada por descontinuidades no acoplamento.

  • Mantenha as trilhas agressoras afastadas, especialmente nas camadas externas; procure manter um afastamento de 3 vezes a largura da trilha de sinal para nets potencialmente agressoras.

  • Como regra geral, procure manter um afastamento entre o par e outros sinais de 2 vezes a largura da trilha de sinal.

  • Mantenha os polígonos de terra na mesma camada afastados por pelo menos 3 vezes a largura da trilha de sinal.

  • As reflexões introduzidas por vias e descontinuidades de acoplamento são gerenciadas por meio do roteamento com impedância controlada; isso exige um plano de referência contínuo abaixo do caminho do sinal.

  • Reduza a separação entre a camada de sinal e o plano para melhorar a imunidade à diafonia.

Controle e ajuste dos comprimentos das trilhas

Main pages: Ajuste de comprimento, Regra de projeto de comprimento, Regra de projeto de casamento de comprimentos

Um requisito fundamental para gerenciar sinais de alta velocidade em uma placa é controlar e ajustar os comprimentos de suas trilhas.

  • Os comprimentos absolutos podem ser monitorados pela regra de projeto de comprimento, e os comprimentos relativos das trilhas, pela regra de projeto de casamento de comprimentos.
  • Os comprimentos atuais de um conjunto de redes e sua conformidade com as regras de projeto aplicáveis podem ser verificados no painel PCB, no modo Nets (conforme mostrado abaixo).
  • Se houver uma regra de comprimento e/ou de casamento de comprimentos definida, você poderá monitorar o comprimento durante o roteamento interativo ou o ajuste de comprimento exibindo o indicador de ajuste de comprimento (Shift+G).
  • O atraso causado pelo comprimento do pino dentro do encapsulamento do dispositivo é considerado. Para saber mais, leia sobre Atraso do pino no encapsulamento.
  • As redes que incluem componentes em série em seu caminho são gerenciadas por meio da definição de xSignals.

Regras de projeto

  • Managing the Overall Route Lengths - o comprimento total das trilhas de uma rede ou de um conjunto de redes pode ser monitorado por uma regra de projeto de comprimento. A regra de projeto de comprimento tem um comprimento mínimo e um máximo permitidos. Se o comprimento do sinal for menor que o mínimo permitido, ele será destacado em amarelo no painel PCB (no modo Nets); um comprimento de sinal maior que o máximo permitido será destacado em vermelho.
  • Managing the Relative Route Lengths - os comprimentos relativos das trilhas de um conjunto de redes podem ser monitorados por uma regra de projeto de casamento de comprimentos. A regra de projeto de casamento de comprimentos tem uma tolerância e usa a trilha mais longa do conjunto de redes abrangidas como comprimento de referência. O destaque em amarelo do comprimento do sinal no painel indica que o comprimento desse sinal é menor que o comprimento da trilha mais longa menos a tolerância. O destaque em vermelho indica que o comprimento desse sinal é maior que o comprimento da trilha mais longa. 

Para entender como as configurações dessas duas regras são conciliadas quando ambas estão presentes em um projeto, consulte a página Ajuste de comprimento.

Monitoramento do comprimento das trilhas

Os comprimentos atuais das trilhas são exibidos no modo Redes do painel PCB e são atualizados durante o roteamento. O valor do comprimento Routed ficará amarelo à medida que você se aproximar do comprimento desejado e vermelho se você o exceder.

Se houver uma regra de comprimento e/ou de casamento de comprimentos definida, você poderá monitorar o comprimento durante o roteamento interativo ou o ajuste de comprimento exibindo o indicador de ajuste de comprimento. Durante o roteamento, use o atalho Shift+G para exibir ou ocultar o indicador.

O indicador mostra o comprimento roteado atual como um número acima do controle deslizante, enquanto o controle deslizante mostra o comprimento estimado. Durante o ajuste de comprimento, Estimated Length = Current Routed Length; se você estiver usando o indicador durante o roteamento interativo, Estimated Length = Routed Length + distance to target (length of connection line).

As configurações do indicador são calculadas a partir das restrições definidas pelas regras aplicáveis.As configurações do indicador são calculadas a partir das restrições definidas pelas regras aplicáveis.

  • O mínimo do indicador (borda esquerda do indicador) é 45 (menor MinLimit)
  • O máximo do indicador (borda direita do indicador) é 48 (maior MaxLimit)
  • A barra amarela esquerda (maior MinLimit) é 46,58
  • A barra amarela direita (menor MaxLimit) é 47,58 (oculta pela barra verde na imagem acima)
  • A barra verde (TargetLength) é 47,58 (comprimento da trilha da rede mais longa do conjunto, igual a MaxLimit)
  • O controle deslizante verde e o valor numérico sobreposto (comprimento atual da trilha) são 47,197.

Ajuste dos comprimentos das trilhas

Os comprimentos das trilhas podem ser ajustados após a conclusão do roteamento, usando o comando Interactive Length Tuning ou o comando Interactive Diff Pair Length Tuning (menu Route). Esses comandos adicionam seções em sanfona ao roteamento, com três opções de formato.

Se houver uma regra de comprimento e uma regra de casamento de comprimentos aplicáveis, a ferramenta de ajuste de comprimento considerará ambas e determinará o conjunto de restrições mais rigoroso. Assim, se o comprimento máximo especificado pela regra de comprimento for menor que o maior comprimento visado pela regra de casamento de comprimentos, a regra de comprimento prevalecerá e seu comprimento será usado durante o ajuste.

Para ver quais regras estão sendo aplicadas ou alterar as propriedades da sanfona durante o ajuste de comprimento, pressione Tab para abrir o modo Interactive Length Tuning do painel Properties, conforme mostrado abaixo. Observe o Target Length: ele é o Max Limit das configurações de regra aplicáveis mais rigorosas.

Pressione Tab durante o ajuste de comprimento para abrir o painel no modo Interactive Length Tuning, no qual você pode selecionar o modo de comprimento desejado e ajustar os parâmetros da sanfona.
Pressione Tab durante o ajuste de comprimento para abrir o painel no modo Interactive Length Tuning, no qual você pode selecionar o modo de comprimento desejado e ajustar os parâmetros da sanfona.

Para ajustar o comprimento de uma rede, execute o comando e clique em qualquer ponto ao longo da rede. Mova o cursor acompanhando o caminho da trilha; seções de ajuste em sanfona serão adicionadas à medida que você fizer isso. As seções de ajuste continuarão sendo adicionadas até que os requisitos de comprimento definidos pelas regras de projeto aplicáveis sejam atendidos. Se o cursor sair dos limites das sanfonas de ajuste, elas desaparecerão; quando o cursor voltar para dentro dos limites da sanfona, elas reaparecerão.

Saiba mais sobre Ajuste de comprimento.

As regras de comprimento e de casamento de comprimentos podem ser aplicadas a redes, pares diferenciais ou xSignals. Os xSignals são ideais quando os comprimentos monitorados ou casados incluem componentes em série ou roteamento ramificado. O modo xSignals do painel PCB exibe o comprimento roteado atual de cada xSignal.

Saiba mais sobre xSignals.

Conclusão

Embora não seja possível estabelecer um conjunto universal de regras aplicável a todos os projetos de alta velocidade, é possível seguir boas práticas de projeto que ajudarão você a ter sucesso em seu projeto de alta velocidade. Vários especialistas do setor oferecem cursos de treinamento práticos e bastante procurados sobre projetos de alta velocidade. Use os links abaixo para saber mais e pesquisar opções de treinamento especializado.

Referências

O autor agradece o trabalho dos especialistas do setor listados a seguir; esta página é uma tentativa de resumir o conhecimento coletivo deles.

Artigos de Douglas Brooks

  • Tempos de propagação em microfitas
  • Divisão de planos para velocidade e alimentação
  • Efeito pelicular
  • Regras de projeto de trilhas diferenciais — verdade versus ficção

Artigos do Dr. Howard Johnson

  • Indutância de vias
  • Empilhamento de 10 camadas

Livros e artigos de Lee W. Ritchey

  • Certo da primeira vez
  • Uma abordagem da sinalização diferencial e seus requisitos de projeto
  •  Os laminados de PCB influenciam as taxas de dados de alta velocidade, Parte 1, Parte 2

Artigos da In-Circuit Design — Barry Olney

  • Roteamento de pares diferenciais
  • A verdade sobre os jumpers de planos
  • Posicionamento crítico
  • Planejamento do empilhamento (Partes 1, 2 & 3)
  • O empilhamento perfeito

Boas práticas no projeto de placas de circuito - Tim Jarvis RadioCAD Limited

Layout de PCB - Site Learn EMC

Artigos de Keith Armstrong, EMC Information Centre (requer cadastro gratuito)

Manual de encapsulamento eletrônico - Glenn R. Blackwell

Manual de circuitos impressos - Clyde Coombs e Happy Holden

Manual de HDI - Happy Holden e outros

Técnicas de otimização de vias para projetos de canais de alta velocidade - Nota de aplicação AN529 da Altera

Considerações sobre o projeto de PCBs de alta velocidade - Nota de aplicação TN 1033 da Lattice Semiconductor 

Medição do tempo de propagação de um sinal - Chris Grachanen, EDN

O futuro das estruturas de vias HDI, da distribuição de energia e do gerenciamento térmico em circuitos impressos de próxima geração - Tom Buck TTM Technologies

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents