Планирование жестких и гибких областей — стандартный режим

Краткий обзор

В этой статье рассматривается работа стандартного режима проектирования гибко-жестких плат в Altium Designer. Основное внимание уделяется планированию областей платы с помощью разделительных линий (Split Lines) в режиме планирования платы (Board Planning Mode). Вы узнаете, как определить, какой режим используется для печатной платы — стандартный или расширенный, как разделительные линии задают отдельные области платы в стандартном рабочем процессе и как размещать, перемещать и удалять эти линии по мере работы над проектом. Также в статье описано, как назначать стеки слоев, переименовывать области и задавать или изменять контур платы, чтобы правильно организовать жесткие и гибкие участки с самого начала. Если вам нужно практическое руководство по планированию областей несложных гибко-жестких плат в Altium Designer, эта статья поможет увереннее работать над проектом и не замедлять процесс трассировки.

- Узнайте о ключевом различии между стандартным и расширенным режимами проектирования гибко-жестких плат и о том, как быстро определить, какой режим используется для вашей печатной платы.
- Освойте базовый процесс создания и редактирования областей платы в стандартном режиме, включая размещение, перемещение и удаление разделительных линий.
- Разберитесь, как назначать стеки слоев, переименовывать области и задавать контуры плат, чтобы правильно настроить жесткие и гибкие участки.
Узнайте больше с ИИ:

В программном обеспечении Altium для проектирования печатных плат доступны два режима проектирования жестко-гибких плат. Исходный, или стандартный, режим Rigid-Flex поддерживает простые жестко-гибкие конструкции. Если к конструкции предъявляются более сложные требования, например нужны перекрывающиеся гибкие области, необходимо использовать режим Advanced Rigid-Flex (также известный как rigid-flex 2.0). Режим выбирается в меню Tools в редакторе стека слоев.

Принципиальное различие между режимами заключается в том, что в исходном режиме контур платы делится на отдельные области путем размещения линии разделения. Эта линия остается объектом, определяющим, где заканчивается одна область платы и начинается другая. В расширенном режиме каждая область платы размещается отдельно, а при разрезании более крупной области образуются два отдельных объекта области. В расширенном режиме место стыка двух соседних областей платы определяется их краями, а не наличием линии разделения. Поэтому в режиме Advanced Rigid-Flex объект «Линия разделения» отсутствует.

► Подробнее о проектировании жестко-гибкой печатной платы

Меню View содержит три режима работы редактора печатных плат с легко запоминающимися сочетаниями клавиш, позволяющими быстро переключаться между ними:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

По умолчанию при переключении между режимами 2D- и 3D-просмотра для каждого из них сохраняются отдельные настройки масштаба и ориентации. Если при переключении вы хотите видеть тот же участок платы в той же ориентации, нажмите Ctrl+Alt+2 или Ctrl+Alt+3 вместо 2 или 3.

Вы только что открыли печатную плату и хотите узнать, какой режим жестко-гибкого проектирования в ней используется — стандартный или расширенный?

Для проверки можно открыть редактор стека слоев. Другой способ — перейти в режим планирования платы (сочетание клавиш 1) и посмотреть на активную панель:

Стандартный режим Rigid-Flex
Расширенный режим Advanced Rigid-Flex

Чтобы разделить контур платы на две области, разместите линию разделения. Это выполняется в редакторе печатных плат в режиме Board Planning Mode. Области платы — это участки между линиями разделения, которым по умолчанию присваиваются имена.

Размещение линии разделения

Чтобы разместить линию разделения:

  1. Выберите View » Board Planning Mode (или нажмите сочетание клавиш 1), чтобы перейти в Board Planning Mode.
  2. Выберите Design » Define Split Line, чтобы перейти в режим размещения линии разделения (для быстрого вызова этой команды используйте последовательность клавиш D, S).
  3. Щелкните within контура платы, чтобы начать построение линии разделения. Один конец линии будет привязан к ближайшей к месту щелчка точке на границе контура платы, а другой — к курсору.
  4. Переместите курсор в нужное место и щелкните один раз, чтобы разместить второй конец. Если положение допустимо, линия разделения останется синей. При недопустимом положении (например, за пределами контура платы) линия разделения станет красной. Если щелкнуть для размещения, пока линия красная, она будет удалена.
  5. Режим размещения линии разделения остается активным, и при необходимости можно разместить еще одну линию. В противном случае щелкните правой кнопкой мыши или нажмите Esc, чтобы выйти из режима размещения линии разделения.

Области платы — это участки между линиями разделения, которым по умолчанию присваиваются имена.

Плата делится на отдельные области путем размещения линии разделения, проходящей от одного края контура платы до другого.
Плата делится на отдельные области путем размещения линии разделения, проходящей от одного края контура платы до другого.

Плата разделена на несколько отдельных областей с помощью линий разделения. Обратите внимание, что на ней также размещены линии сгиба.
Плата разделена на несколько отдельных областей с помощью линий разделения. Обратите внимание, что на ней также размещены линии сгиба.

Перемещение линии разделения

Чтобы переместить линию разделения:

  1. Выберите View » Board Planning Mode или нажмите сочетание клавиш 1, чтобы перейти в Board Planning Mode.
  2. Чтобы переместить конец линии, нажмите на него и, удерживая кнопку мыши, перетащите в нужное место по периметру контура платы. Перемещение курсора будет ограничено текущей сеткой привязки.

Границы области платы будут изменены в соответствии с новым положением редактируемой линии разделения.

При перетаскивании в допустимое положение, обеспечивающее корректное разделение, линия разделения остается синей. Если новое положение перемещаемого конца недопустимо, например он находится на том же краю контура платы, что и закрепленный конец, линия разделения станет красной. Попытка разместить линию, пока она красная, приведет к ее удалению.

Выберите и перетащите конечный узел линии разделения, чтобы изменить границы области платы.
Выберите и перетащите конечный узел линии разделения, чтобы изменить границы области платы.

Удаление линии разделения

Чтобы удалить линию разделения:

  1. Выберите View » Board Planning Mode или нажмите сочетание клавиш 1, чтобы перейти в Board Planning Mode.
  2. Нажмите на одну из конечных точек линии и, удерживая кнопку мыши, нажмите клавишу Delete. Другой способ — нажать на конечную точку и, удерживая кнопку мыши, переместить ее в такое место на контуре платы, где линия разделения станет красной (что означает недопустимое разделение), затем отпустить кнопку.

Чтобы удалить одну или несколько существующих линий разделения на активной плате, можно также воспользоваться командой Design » Delete Split Line из главного меню в режиме Board Planning Mode. После запуска команды курсор примет вид перекрестия, и включится режим удаления линий разделения. Чтобы удалить линию разделения, наведите курсор на один из ее концов (маркеров редактирования), затем щелкните или нажмите Enter. Продолжайте удалять другие линии разделения таким же способом либо щелкните правой кнопкой мыши или нажмите Esc, чтобы выйти из режима удаления линий разделения.

Назначение стека слоев и изменение имени области платы

Related page: Определение стека слоев

При создании новой платы она содержит одну область с именем Default Layer Stack Region. Этой области назначается стек слоев по умолчанию с именем Board Layer Stack.

При разделении контура платы на несколько областей каждой новой области также назначается стек слоев по умолчанию. При этом исходная область получает имя Default Layer Stack Region, а последующие области — имена в формате Layer Stack Region. Если необходимые стеки слоев уже определены в редакторе стека слоев, каждой области можно назначить свой стек и присвоить содержательное имя.

У каждой области отображается метка с ее именем и именем назначенного ей стека слоев в формате Region Name - Layer Stack Name. Если для стека слоев включена поддержка гибкой части, это также обозначается с помощью (flex). Поддержка гибкой части для стека включается в Layer Stack Manager.

Чтобы назначить стек слоев и задать имя области:

  1. Выберите View » Board Planning Mode или нажмите сочетание клавиш 1, чтобы перейти в Board Planning Mode.
  2. Нажмите Multi-Layer вкладку в нижней части рабочей области, чтобы сделать этот слой активным (если вкладка слоя не отображается, нажмите L, чтобы открыть панель View Configuration и включить его отображение).
  3. Дважды щёлкните по области платы, чтобы открыть диалоговое окно Board Region. Если область не выделяется и диалоговое окно не открывается, убедитесь, что фильтр выделения не исключает области (Regions).
  4. Назначьте стек слоёв, выбрав нужный стек в раскрывающемся списке Layer stack.
  5. При необходимости измените Name.
  6. Для одной из областей платы необходимо включить параметр 3D Locked, чтобы задать физическую опорную плоскость для режима трёхмерного отображения.
  7. Нажмите OK, чтобы применить настройки и закрыть диалоговое окно.

Дважды щёлкните по области платы, чтобы задать её имя и назначить стек слоёв.
Дважды щёлкните по области платы, чтобы задать её имя и назначить стек слоёв.

Диалоговое окно Board Region также можно открыть, дважды щёлкнув по нужной области стека слоёв в режиме Layer Stack Regions панели PCB. Панель PCB автоматически перейдёт в этот режим при переключении в Board Planning Mode.

Краткое описание создания областей путём разделения контура платы

Плата разделяется на отдельные области с помощью линий разделения. Форму платы можно задать несколькими способами. В видео ниже показано использование контура, созданного из линий и дуг на механическом слое. После задания общего контура плата разделяется на жёсткие и гибкие области.

Определение формы и областей платы:

  • Форму платы можно задать интерактивно в режиме планирования платы (View » Board Planning Mode) или на основе существующего контура в режиме двумерной трассировки (View » 2D Layout Mode), как показано в видео выше.
  • Чтобы задать форму платы на основе существующего контура, выделите контур в режиме двумерной трассировки и выполните команду Design » Board Shape » Define Board Shape from Selected Objects. Программа пройдёт по осевой линии выбранных объектов — дорожек и дуг, — чтобы определить внешний край платы. Обратите внимание: концы дорожек и дуг, образующих контур, должны совпадать, чтобы алгоритм обхода мог следовать по осевой линии. Если это не удастся, алгоритм предложит попробовать пройти по внешнему краю выбранных объектов.
  • Чтобы задать форму платы интерактивно, переключитесь в режим планирования платы (сочетание клавиш 1) и выберите команду Design » Redefine Board Shape. При определении формы платы действуют стандартные правила размещения объекта «область»; для удобства используйте сетку привязки и направляющие рабочей области. Включите параметр Board Shape в палитре Snap Options, чтобы обеспечить максимальный контроль при редактировании формы платы. Подробнее см. в разделе Принципы работы привязки.
  • Чтобы задать Name и назначить Layer stack для каждой области, дважды щёлкните по ней. Также можно переключить панель PCB в режим Layer Stack Regions, в котором можно просматривать и редактировать области и линии сгиба.
  • Чтобы разделить область платы на две меньшие области, используйте команду Design » Define Split Line. Команда размещает прямую линию между двумя точками, заданными щелчками мыши. При щелчке внутри контура платы первая точка будет расположена на ближайшем к месту щелчка краю платы. Переместите курсор, чтобы указать вторую точку, затем щёлкните ещё раз. Чтобы переместить вершину линии разделения, нажмите на неё и перетащите, удерживая кнопку мыши.
  • Положение и форму существующей области платы можно изменить. Выполните команду Design Design » Edit Board Shape, затем скорректируйте форму, используя стандартные приёмы редактирования многоугольных объектов.
AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents