Планирование жестких и гибких областей — стандартный режим
Краткий обзор
- Узнайте о ключевом различии между стандартным и расширенным режимами проектирования гибко-жестких плат и о том, как быстро определить, какой режим используется для вашей печатной платы.
- Освойте базовый процесс создания и редактирования областей платы в стандартном режиме, включая размещение, перемещение и удаление разделительных линий.
- Разберитесь, как назначать стеки слоев, переименовывать области и задавать контуры плат, чтобы правильно настроить жесткие и гибкие участки.
Чтобы разделить контур платы на две области, разместите линию разделения. Это выполняется в редакторе печатных плат в режиме Board Planning Mode. Области платы — это участки между линиями разделения, которым по умолчанию присваиваются имена.
Размещение линии разделения
Чтобы разместить линию разделения:
- Выберите View » Board Planning Mode (или нажмите сочетание клавиш 1), чтобы перейти в Board Planning Mode.
- Выберите Design » Define Split Line, чтобы перейти в режим размещения линии разделения (для быстрого вызова этой команды используйте последовательность клавиш D, S).
- Щелкните within контура платы, чтобы начать построение линии разделения. Один конец линии будет привязан к ближайшей к месту щелчка точке на границе контура платы, а другой — к курсору.
- Переместите курсор в нужное место и щелкните один раз, чтобы разместить второй конец. Если положение допустимо, линия разделения останется синей. При недопустимом положении (например, за пределами контура платы) линия разделения станет красной. Если щелкнуть для размещения, пока линия красная, она будет удалена.
- Режим размещения линии разделения остается активным, и при необходимости можно разместить еще одну линию. В противном случае щелкните правой кнопкой мыши или нажмите Esc, чтобы выйти из режима размещения линии разделения.
Области платы — это участки между линиями разделения, которым по умолчанию присваиваются имена.

Плата делится на отдельные области путем размещения линии разделения, проходящей от одного края контура платы до другого.

Плата разделена на несколько отдельных областей с помощью линий разделения. Обратите внимание, что на ней также размещены линии сгиба.
Перемещение линии разделения
Чтобы переместить линию разделения:
- Выберите View » Board Planning Mode или нажмите сочетание клавиш 1, чтобы перейти в Board Planning Mode.
- Чтобы переместить конец линии, нажмите на него и, удерживая кнопку мыши, перетащите в нужное место по периметру контура платы. Перемещение курсора будет ограничено текущей сеткой привязки.
Границы области платы будут изменены в соответствии с новым положением редактируемой линии разделения.

Выберите и перетащите конечный узел линии разделения, чтобы изменить границы области платы.
Удаление линии разделения
Чтобы удалить линию разделения:
- Выберите View » Board Planning Mode или нажмите сочетание клавиш 1, чтобы перейти в Board Planning Mode.
- Нажмите на одну из конечных точек линии и, удерживая кнопку мыши, нажмите клавишу Delete. Другой способ — нажать на конечную точку и, удерживая кнопку мыши, переместить ее в такое место на контуре платы, где линия разделения станет красной (что означает недопустимое разделение), затем отпустить кнопку.
Чтобы удалить одну или несколько существующих линий разделения на активной плате, можно также воспользоваться командой Design » Delete Split Line из главного меню в режиме Board Planning Mode. После запуска команды курсор примет вид перекрестия, и включится режим удаления линий разделения. Чтобы удалить линию разделения, наведите курсор на один из ее концов (маркеров редактирования), затем щелкните или нажмите Enter. Продолжайте удалять другие линии разделения таким же способом либо щелкните правой кнопкой мыши или нажмите Esc, чтобы выйти из режима удаления линий разделения.
Назначение стека слоев и изменение имени области платы
Related page: Определение стека слоев
При создании новой платы она содержит одну область с именем Default Layer Stack Region. Этой области назначается стек слоев по умолчанию с именем Board Layer Stack.
При разделении контура платы на несколько областей каждой новой области также назначается стек слоев по умолчанию. При этом исходная область получает имя Default Layer Stack Region, а последующие области — имена в формате Layer Stack Region. Если необходимые стеки слоев уже определены в редакторе стека слоев, каждой области можно назначить свой стек и присвоить содержательное имя.
Чтобы назначить стек слоев и задать имя области:
- Выберите View » Board Planning Mode или нажмите сочетание клавиш 1, чтобы перейти в Board Planning Mode.
- Нажмите Multi-Layer вкладку в нижней части рабочей области, чтобы сделать этот слой активным (если вкладка слоя не отображается, нажмите L, чтобы открыть панель View Configuration и включить его отображение).
- Дважды щёлкните по области платы, чтобы открыть диалоговое окно Board Region. Если область не выделяется и диалоговое окно не открывается, убедитесь, что фильтр выделения не исключает области (Regions).
- Назначьте стек слоёв, выбрав нужный стек в раскрывающемся списке Layer stack.
- При необходимости измените Name.
- Для одной из областей платы необходимо включить параметр 3D Locked, чтобы задать физическую опорную плоскость для режима трёхмерного отображения.
- Нажмите OK, чтобы применить настройки и закрыть диалоговое окно.

Дважды щёлкните по области платы, чтобы задать её имя и назначить стек слоёв.
Краткое описание создания областей путём разделения контура платы
Плата разделяется на отдельные области с помощью линий разделения. Форму платы можно задать несколькими способами. В видео ниже показано использование контура, созданного из линий и дуг на механическом слое. После задания общего контура плата разделяется на жёсткие и гибкие области.
Определение формы и областей платы:
- Форму платы можно задать интерактивно в режиме планирования платы (View » Board Planning Mode) или на основе существующего контура в режиме двумерной трассировки (View » 2D Layout Mode), как показано в видео выше.
- Чтобы задать форму платы на основе существующего контура, выделите контур в режиме двумерной трассировки и выполните команду Design » Board Shape » Define Board Shape from Selected Objects. Программа пройдёт по осевой линии выбранных объектов — дорожек и дуг, — чтобы определить внешний край платы. Обратите внимание: концы дорожек и дуг, образующих контур, должны совпадать, чтобы алгоритм обхода мог следовать по осевой линии. Если это не удастся, алгоритм предложит попробовать пройти по внешнему краю выбранных объектов.
- Чтобы задать форму платы интерактивно, переключитесь в режим планирования платы (сочетание клавиш 1) и выберите команду Design » Redefine Board Shape. При определении формы платы действуют стандартные правила размещения объекта «область»; для удобства используйте сетку привязки и направляющие рабочей области. Включите параметр Board Shape в палитре Snap Options, чтобы обеспечить максимальный контроль при редактировании формы платы. Подробнее см. в разделе Принципы работы привязки.
- Чтобы задать Name и назначить Layer stack для каждой области, дважды щёлкните по ней. Также можно переключить панель PCB в режим Layer Stack Regions, в котором можно просматривать и редактировать области и линии сгиба.
- Чтобы разделить область платы на две меньшие области, используйте команду Design » Define Split Line. Команда размещает прямую линию между двумя точками, заданными щелчками мыши. При щелчке внутри контура платы первая точка будет расположена на ближайшем к месту щелчка краю платы. Переместите курсор, чтобы указать вторую точку, затем щёлкните ещё раз. Чтобы переместить вершину линии разделения, нажмите на неё и перетащите, удерживая кнопку мыши.
- Положение и форму существующей области платы можно изменить. Выполните команду Design Design » Edit Board Shape, затем скорректируйте форму, используя стандартные приёмы редактирования многоугольных объектов.