Планирование жестких и гибких областей — расширенный режим
Краткий обзор
- Вы узнаете, чем стандартный режим проектирования жёстко-гибких плат (Standard Rigid-Flex) отличается от расширенного режима (Advanced Rigid-Flex) и как это влияет на создание и определение областей платы.
- Вы увидите, как размещать и редактировать области платы (Board Regions) в режиме планирования платы (Board Planning Mode), в том числе задавать имена, назначать стеки слоёв и использовать направляющие и привязку для точного размещения.
- Вы освоите полезные сочетания клавиш, режимы размещения и настройки свойств, которые помогут эффективнее работать со сложными жёстко-гибкими печатными платами.
Размещение области платы
Область платы (Board Region) — это полигональный объект, который размещается стандартными способами размещения полигональных объектов. Контур платы должен быть точно задан, поэтому важно, чтобы составляющие плату области были созданы в точном соответствии с требованиями. В видео ниже показано создание областей платы с выравниванием их краев по заранее размещенным направляющим рабочей области. Преимущество этого способа в том, что положение направляющих можно точно задать, изменив их координаты на панели Properties.
Заранее заданные направляющие рабочей области используются как ориентиры при размещении областей платы.
Области платы размещаются и изменяются в Board Planning Mode:
- Выберите View » Board Planning Mode (или нажмите сочетание клавиш 1), чтобы перейти в Board Planning Mode. Существующая по умолчанию область платы будет отображаться в виде зеленого прямоугольника.
-
Выберите Place » Board Region, чтобы разместить новую область (или нажмите кнопку
на Active Bar).
- Установите курсор в нужное место и щелкните, чтобы зафиксировать начальную вершину области платы. Область платы — это полигональный объект, подобный области или полигону, поэтому процесс ее размещения и редактирования аналогичен.
- Переместите курсор в положение второй вершины. По умолчанию при каждом щелчке размещаются два ребра с заданной пользователем формой угла между ними. Нажмите Spacebar, чтобы изменить направление угла. Подробнее об изменении режимов построения углов см. в разделе Placement Modes ниже.
- Продолжайте перемещать мышь и щелкать для размещения вершин, создавая ребра, необходимые для формирования общего контура области платы.
- После размещения последней вершины щелкните правой кнопкой мыши или нажмите Esc, чтобы замкнуть контур платы и завершить его определение. Замыкать контур вручную не требуется: программа автоматически завершит его, соединив последнюю размещенную точку с начальной.
- Каждой области платы присваивается уникальное имя. Введите подходящее имя в поле Name в режиме Board Region панели Properties (чтобы свойства области платы отображались на панели, ее необходимо выбрать в рабочей области).
-
Каждой области платы должен быть назначен стек слоев. При создании новой области платы ей назначается стек слоев по умолчанию с именем
Board Layer Stack. Назначьте нужный стек слоев в режиме Board Region панели Properties. Стеки слоев определяются и получают имена в менеджере стека слоев. - Если итоговая печатная плата должна содержать несколько областей, продолжайте создавать дополнительные области.
Кроме того, можно нажать клавишу Tab, чтобы приостановить размещение и перейти в режим Board Region панели Properties , где можно изменять свойства объекта непосредственно в процессе размещения. Чтобы продолжить размещение, нажмите наложенную на рабочую область кнопку паузы
Placement Modes
При переопределении контура платы доступны пять режимов построения углов, четыре из которых также имеют подрежимы направления угла. Во время переопределения:
- Нажимайте Shift+Spacebar для последовательного переключения между пятью доступными режимами построения углов.
- Нажимайте Spacebar для переключения между двумя подрежимами направления угла.
-
В любом из режимов построения дуговых углов удерживайте
клавишу для уменьшения или клавишу
для увеличения дуги. Удерживайте клавишу Shift при нажатии, чтобы ускорить изменение размера дуги.
- Нажмите сочетание клавиш 1, чтобы переключиться между размещением двух рёбер за щелчок и одного ребра за щелчок. Во втором режиме пунктирное ребро называется сегментом предварительного просмотра (как показано на последнем изображении в наборе ниже).
- Нажмите клавишу Backspace, чтобы удалить последнюю вершину.



Нажимайте Shift+Spacebar для циклического переключения между пятью доступными режимами углов; используйте сочетание клавиш 1 для переключения между размещением двух рёбер и одного ребра.
Свойства области платы

Режим Board Region панели Properties.
Действия
Эти элементы управления используются для добавления или удаления покровной плёнки в текущей области платы. Чтобы кнопки Add и Remove Coverlay стали доступны, области платы должен быть назначен стек слоёв, в котором включён параметр Is Flex и в набор слоёв включены слои покровной плёнки.
- Add Coverlay — добавить автоматически созданные полигоны покровной плёнки в выбранную область платы.
- Remove Coverlay — удалить автоматически созданные и заданные вручную полигоны покровной плёнки из выбранной области платы.
Расположение
- (X/Y) — координаты X и Y первой вершины, размещённой при создании области платы, относительно текущего начала координат рабочей области. Измените их, чтобы переместить область платы по оси X или Y. Значения можно вводить как в метрических, так и в дюймовых единицах; если единицы вводимого значения отличаются от используемых по умолчанию, укажите их.
Свойства
- Name — задаваемое пользователем имя этой области платы. Имена помогают различать области платы, если в проекте их несколько.
- Layer Stack — определяет, какой стек слоёв назначен этой области платы. Раскрывающийся список содержит все стеки слоёв (подстеки), заданные в менеджере стека слоёв.
- Color — нажмите, чтобы открыть цветовую палитру и задать или изменить цвет выбранных областей платы. Обратите внимание: изменение цвета применяется ко всем областям платы с тем же стеком слоёв, что и у выбранной области.
- Priority — значение приоритета определяет, какая область платы отрисовывается последней. Используйте этот параметр при проектировании платы с гибкой областью внутри выреза в жёсткой области: значение приоритета гибкой области должно быть выше, чем у окружающей жёсткой области (а контур выреза должен огибать гибкую область внутри него).
- 3D Locked — установите этот флажок, чтобы зафиксировать данную область платы при сгибании платы в режиме 3D. Зафиксировать можно только одну жёсткую область платы.
Вершины контура
Этот раздел используется для изменения отдельных вершин выбранного объекта области платы. Можно изменять положение существующих вершин, добавлять новые или удалять их по мере необходимости. Между вершинами можно задавать дуговые соединения. Также поддерживаются экспорт данных о вершинах в файл CSV и импорт из него (через контекстное меню).
-
Vertices Grid — список всех вершин, заданных для области платы, со следующими параметрами:
- Index — присвоенный индекс вершины (недоступен для редактирования).
- X — координата X (по горизонтали) вершины. Нажмите для редактирования.
- Y — координата Y (по вертикали) вершины. Нажмите для редактирования.
-
Arc Angle (Neg = CW) — угол дуги, соединяющей эту вершину со следующей. По умолчанию вершины соединяются прямолинейными рёбрами, а это поле остаётся пустым. Нажмите для редактирования и введите требуемый угол дуги. При положительном значении дуга строится против часовой стрелки. Чтобы построить дугу по часовой стрелке, введите отрицательное значение.
-
Add — нажмите, чтобы добавить новую вершину. Она будет добавлена ниже текущей активной записи вершины и первоначально получит те же координаты X, Y. Нажмите
, чтобы удалить выбранную вершину.
Создание области платы из 3D-тела
Области платы также можно создавать из объектов 3D-тел с помощью команды Create Board Region from 3D Body в режиме 3D. Порядок действий:
- Убедитесь, что плата отображается в режиме 3D (если нет, используйте сочетание клавиш 3 для быстрого перехода в этот режим).
- Выберите в главном меню команду Design » Board Shape » Create Board Region from 3D body.
- Наведите курсор на 3D-модель, которую хотите использовать для создания области печатной платы, и щёлкните или нажмите Enter. Модель станет прозрачной.
- Перемещайте курсор по 3D-модели, чтобы найти грань. Когда под курсором окажется плоская поверхность, она станет непрозрачной и будет выделена тонкой синей рамкой.
- Найдя нужную грань, щёлкните или нажмите Enter — будет создана новая область платы (с заменой ранее заданной области платы в рабочей области).
- Появится диалоговое окно Board Outline Creation Successful, подтверждающее успешное создание. В нём можно скрыть компонент модели и исключить его из проверки DRC. Также можно изменить высоту модели, чтобы совместить грань с верхней или нижней поверхностью платы, либо оставить её положение без изменений.
Создание области выреза в плате
Чтобы создать внутренний вырез в плате, разместите область выреза в плате (Place » Define Board Cutout или нажмите кнопку
на Active Bar). Вырез в плате — также полигональный объект, поэтому процесс его размещения совпадает с размещением самой области платы. На изображениях ниже показана область платы с двумя вырезами, которые при изготовлении становятся отверстиями в плате.
Вырез, размещённый в области платы, становится отверстием в готовой плате.
Разделение контура платы на области
Существующую область платы можно разделить на две области, разрезав её. Эта операция выполняется, когда редактор печатных плат находится в режиме Board Planning Mode.
Плата разделена на три области платы с помощью команды Slice Region.
Чтобы разрезать область платы:
- Выберите View » Board Planning Mode (или используйте сочетание клавиш 1), чтобы перейти в Board Planning Mode.
-
Выберите Design » Slice Board Region (или нажмите кнопку
на панели Active Bar), чтобы перейти в режим Slice Board Region.
- После выбора команды включается режим разрезания, аналогичный режиму размещения проводников. Начиная за пределами разрезаемой области, щелчками задайте последовательность вершин, определяющих линию разреза. При задании разреза нажимайте Shift+Spacebar для циклического переключения режимов углов; нажимайте Spacebar для переключения между начальным и конечным вариантами угла и используйте клавишу Backspace для удаления последнего размещенного угла. Конец линии разреза разместите за границей области платы. Завершив задание разреза, щелкните правой кнопкой мыши или нажмите Esc, чтобы завершить команду.
-
Откроется диалоговое окно подтверждения с указанием количества разделяемых полигонов (областей) и количества полигонов (областей), которые будут созданы. Нажмите Yes для подтверждения их создания.
Создание областей платы из выбранных объектов
В зависимости от формы платы может быть удобнее сформировать ее из нескольких областей платы. Как отмечалось выше, области можно размещать интерактивно или создавать по контуру, заданному проводниками и дугами. В видеоролике ниже показано создание трех областей платы из выбранных объектов. Обратите внимание: для задания смежных границ в местах соприкосновения областей используется один и тот же объект, что обеспечивает точное совмещение этих областей.
Распространенный подход — задать контуры областей с помощью проводников и дуг, а затем создать области платы из выбранных контуров.
Преобразование между примитивами 2D-чертежа и объектами определения платы
Распространенный подход к заданию формы платы и необходимых областей внутри нее — импорт чертежа из механической САПР. Например, можно импортировать механический чертеж из файла DWG и получить набор линий (проводников) на механическом слое, задающих форму платы, области внутри нее, а для гибко-жесткой платы — также расположение линий сгиба в гибких областях.
Программа содержит ряд команд для создания объектов определения платы (области, выреза, линии сгиба) из примитивов 2D-чертежа, а также соответствующие команды для обратного преобразования этих объектов в чертежные примитивы.
Примечания:
- Команды преобразования в обоих направлениях доступны в подменю Tools » Convert соответствующего режима View (за исключением команды Create Board Region from Selected Objects, которая находится в подменю Design » Board Shape).
-
Чтобы преобразовать примитивы 2D-чертежа в объекты определения платы, переключите вид в 2D Layout Mode.
- Перед выполнением команды необходимо выбрать примитивы.
- Для создания области или выреза примитивы должны образовывать замкнутый контур. Подробнее о требованиях к этому контуру см. в блоке предупреждения ниже.
-
Чтобы преобразовать объекты определения платы в объекты 2D-чертежа, переключите вид в Board Planning Mode.
- Эти команды не требуют предварительного выбора объектов, однако, если объект уже выбран, команда будет применена к нему.
- Если на плате несколько областей, при разбиении на примитивы область исчезает. Если область платы только одна, примитивы будут созданы, а выбранная область сохранится (на плате всегда должна оставаться хотя бы одна область).
- Объекты 2D-чертежа создаются на механическом слое типа Board Shape. Если слоя такого типа на плате нет, будет добавлен механический слой с типом Board Shape. Подробнее см. в разделе Механические слои и типы слоев.
- Хотя отдельной команды для обратного объединения объекта, разбитого на примитивы, нет, для этого можно использовать команду Undo.
Изменение областей платы
В стандартном режиме проектирования гибко-жестких плат граница между двумя смежными областями задавалась перемещаемой синей линией разделения. В расширенном режиме проектирования гибко-жестких плат этот подход не используется: каждая область представляет собой отдельную замкнутую многоугольную фигуру. Поэтому каждую область можно изменять по мере необходимости с помощью стандартных приемов редактирования многоугольных фигур. Обратите внимание: для изменения области платы доступны не все команды редактирования многоугольников; в частности, недоступны команды добавления и вычитания многоугольников.
Что следует помнить при редактировании многоугольного объекта:
- При перетаскивании вершины или ребра многоугольника доступны три режима изменения формы: сдвиг, излом и изгиб. Нажимайте Shift+Spacebar во время перетаскивания для циклического переключения режимов. Текущий режим отображается в строке состояния и на экранном индикаторе Heads-Up.
- Привязка курсора определяется текущими настройками, в том числе сеткой привязки, доступными объектами привязки, наличием направляющих рабочей области и настройками привязки к осям. Используйте эти возможности для получения нужной формы. Подробнее см. в разделе Принципы работы привязки.
Назначение стека слоев и изменение имени области платы
Related page: Определение стека слоев
При создании новой платы она содержит одну область с именем Default Layer Stack Region. Этой области назначается стек слоев по умолчанию с именем Board Layer Stack.
При разделении формы платы на несколько областей каждой новой области также назначается стек слоев по умолчанию. После определения необходимых стеков слоев в менеджере стека слоев каждой области можно назначить свой стек и присвоить осмысленное имя.
Чтобы назначить стек слоев и задать имя области:
- Выберите View » Board Planning Mode или нажмите сочетание клавиш 1, чтобы перейти в Board Planning Mode.
- Нажмите вкладку Multi-Layer в нижней части рабочей области, чтобы сделать этот слой активным (если вкладка слоя не видна, нажмите L, чтобы открыть панель View Configuration и включить ее отображение).
- Дважды щелкните область платы, чтобы открыть диалоговое окно Board Region, или щелкните область платы один раз и откройте панель Properties. Если область не выделяется и диалоговое окно не открывается, убедитесь, что фильтр выбора не исключает области.
- Назначьте стек слоев, выбрав нужный стек в раскрывающемся списке Layer stack.
- При необходимости измените Name.

Имя области платы и назначенный ей стек слоев отображаются в геометрическом центре этой области. Если назначенный стек настроен как гибкий, также отображается надпись (Flex).