Планирование жестких и гибких областей — расширенный режим

Краткий обзор

В этой статье рассказывается, как планировать и размещать жёсткие и гибкие области платы в Altium Designer в расширенном режиме проектирования жёстко-гибких плат (Advanced Rigid-Flex). Сравнение со стандартным режимом поможет понять, когда необходим расширенный подход. Вы узнаете, как задаются области платы, как определить, какой режим проектирования жёстко-гибких плат используется в проекте, как работать в режиме планирования платы (Board Planning Mode), а также как точно размещать, именовать и редактировать области и назначать им стеки слоёв. Кроме того, в статье рассматриваются важные особенности размещения, сочетания клавиш и свойства областей, которые имеют значение при разработке сложных жёстко-гибких плат. Если вам нужно практическое руководство, которое поможет увереннее создавать области жёстко-гибкой платы и управлять ими в расширенном режиме, читайте дальше.

- Вы узнаете, чем стандартный режим проектирования жёстко-гибких плат (Standard Rigid-Flex) отличается от расширенного режима (Advanced Rigid-Flex) и как это влияет на создание и определение областей платы.
- Вы увидите, как размещать и редактировать области платы (Board Regions) в режиме планирования платы (Board Planning Mode), в том числе задавать имена, назначать стеки слоёв и использовать направляющие и привязку для точного размещения.
- Вы освоите полезные сочетания клавиш, режимы размещения и настройки свойств, которые помогут эффективнее работать со сложными жёстко-гибкими печатными платами.
Узнайте больше с ИИ:

В программном обеспечении Altium для проектирования печатных плат доступны два режима проектирования гибко-жестких плат. Исходный, или стандартный, режим Rigid-Flex предназначен для простых гибко-жестких конструкций. Если проект предъявляет более сложные требования, например предусматривает перекрывающиеся гибкие области, необходимо использовать режим Advanced Rigid-Flex (также известный как rigid-flex 2.0). Режим выбирается в меню Tools в менеджере стека слоев.

Принципиальное различие между режимами заключается в том, что в исходном режиме контур платы разделяется на отдельные области с помощью линии разделения (Split Line). Эта линия остается объектом, определяющим, где заканчивается одна область платы и начинается другая. В расширенном режиме каждая область платы размещается отдельно, а при разрезании большой области образуются два отдельных объекта области. В расширенном режиме место стыка двух соседних областей платы определяется их краями, а не наличием линии разделения. Поэтому в режиме Advanced Rigid-Flex объект Split Line отсутствует.

► Подробнее о проектировании гибко-жестких печатных плат

В меню View доступны три режима работы редактора печатных плат с легко запоминаемыми сочетаниями клавиш для быстрого переключения между ними:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

По умолчанию при переключении между режимами 2D и 3D для каждого из них сохраняются собственные настройки масштаба и ориентации. Если при переключении требуется сохранить положение и ориентацию платы, нажмите Ctrl+Alt+2 или Ctrl+Alt+3 вместо 2 или 3.

Вы только что открыли печатную плату и хотите узнать, какой режим гибко-жесткого проектирования в ней используется — стандартный или расширенный?

Это можно проверить, открыв менеджер стека слоев. Или переключитесь в режим планирования платы (сочетание клавиш 1) и посмотрите на панель Active Bar:

Стандартный режим Rigid-Flex
Расширенный режим Advanced Rigid-Flex

Размещение области платы

Область платы (Board Region) — это полигональный объект, который размещается стандартными способами размещения полигональных объектов. Контур платы должен быть точно задан, поэтому важно, чтобы составляющие плату области были созданы в точном соответствии с требованиями. В видео ниже показано создание областей платы с выравниванием их краев по заранее размещенным направляющим рабочей области. Преимущество этого способа в том, что положение направляющих можно точно задать, изменив их координаты на панели Properties.

Заранее заданные направляющие рабочей области используются как ориентиры при размещении областей платы.

Области платы размещаются и изменяются в Board Planning Mode:

  1. Выберите View » Board Planning Mode (или нажмите сочетание клавиш 1), чтобы перейти в Board Planning Mode. Существующая по умолчанию область платы будет отображаться в виде зеленого прямоугольника.
  2. Выберите Place » Board Region, чтобы разместить новую область (или нажмите кнопку на Active Bar).
  3. Установите курсор в нужное место и щелкните, чтобы зафиксировать начальную вершину области платы. Область платы — это полигональный объект, подобный области или полигону, поэтому процесс ее размещения и редактирования аналогичен.
  4. Переместите курсор в положение второй вершины. По умолчанию при каждом щелчке размещаются два ребра с заданной пользователем формой угла между ними. Нажмите Spacebar, чтобы изменить направление угла. Подробнее об изменении режимов построения углов см. в разделе Placement Modes ниже.
  5. Продолжайте перемещать мышь и щелкать для размещения вершин, создавая ребра, необходимые для формирования общего контура области платы.
  6. После размещения последней вершины щелкните правой кнопкой мыши или нажмите Esc, чтобы замкнуть контур платы и завершить его определение. Замыкать контур вручную не требуется: программа автоматически завершит его, соединив последнюю размещенную точку с начальной.
  7. Каждой области платы присваивается уникальное имя. Введите подходящее имя в поле Name в режиме Board Region панели Properties (чтобы свойства области платы отображались на панели, ее необходимо выбрать в рабочей области).
  8. Каждой области платы должен быть назначен стек слоев. При создании новой области платы ей назначается стек слоев по умолчанию с именем Board Layer Stack. Назначьте нужный стек слоев в режиме Board Region панели Properties. Стеки слоев определяются и получают имена в менеджере стека слоев.
  9. Если итоговая печатная плата должна содержать несколько областей, продолжайте создавать дополнительные области.
  • Для каждой области отображается метка с именем области и именем назначенного ей стека слоев в формате Region Name - Layer Stack Name. Имя области платы задается в режиме Board Region панели Properties, а имя стека слоев — в менеджере стека слоев.
  • Для формирования требуемого контура платы можно разместить любое количество областей. Области платы могут перекрываться. Обратите внимание: такое перекрытие не задает глубину захода одной области в соседнюю — она задается при настройке стека слоев в менеджере стека слоев.
  • Область платы — это полигональный объект. Чтобы изменить ее форму, щелкните по ней один раз для выбора, затем перетащите ребро или маркер редактирования. Подробнее о редактировании полигонального объекта. Обратите внимание: в расширенном режиме области платы редактируются интерактивно, поэтому в меню Design режима планирования платы команды редактирования больше не предусмотрены.
  • Чтобы удалить область платы, выберите ее и нажмите клавишу Delete на клавиатуре. На плате всегда должна оставаться хотя бы одна область, поэтому удалить последнюю область невозможно.
  • Области платы можно не только рисовать, но и создавать из примитивов — подробнее см. в разделе Преобразование между примитивами 2D-чертежа и объектами определения платы на этой странице.
  • При размещении или редактировании области платы перемещение курсора ограничивается настройками привязки, в том числе текущей сеткой привязки, доступными объектами привязки, наличием направляющих рабочей области и настройками привязки по осям. Используйте эти возможности, чтобы получить нужную форму.

    ► Подробнее о принципах работы привязки.

Кроме того, можно нажать клавишу Tab, чтобы приостановить размещение и перейти в режим Board Region панели Properties , где можно изменять свойства объекта непосредственно в процессе размещения. Чтобы продолжить размещение, нажмите наложенную на рабочую область кнопку паузы ().

Placement Modes

При переопределении контура платы доступны пять режимов построения углов, четыре из которых также имеют подрежимы направления угла. Во время переопределения:

  • Нажимайте Shift+Spacebar для последовательного переключения между пятью доступными режимами построения углов.
  • Нажимайте Spacebar для переключения между двумя подрежимами направления угла.
  • В любом из режимов построения дуговых углов удерживайте  клавишу для уменьшения или клавишу для увеличения дуги. Удерживайте клавишу Shift при нажатии, чтобы ускорить изменение размера дуги.
  • Нажмите сочетание клавиш 1, чтобы переключиться между размещением двух рёбер за щелчок и одного ребра за щелчок. Во втором режиме пунктирное ребро называется сегментом предварительного просмотра (как показано на последнем изображении в наборе ниже).
  • Нажмите клавишу Backspace, чтобы удалить последнюю вершину.

Нажимайте Shift+Spacebar для циклического переключения между пятью доступными режимами углов; используйте сочетание клавиш 1 для переключения между размещением двух рёбер и одного ребра. 
 
 
Нажимайте Shift+Spacebar для циклического переключения между пятью доступными режимами углов; используйте сочетание клавиш 1 для переключения между размещением двух рёбер и одного ребра.

Создание области платы из 3D-тела

Области платы также можно создавать из объектов 3D-тел с помощью команды Create Board Region from 3D Body в режиме 3D. Порядок действий:

  1. Убедитесь, что плата отображается в режиме 3D (если нет, используйте сочетание клавиш 3 для быстрого перехода в этот режим).
  2. Выберите в главном меню команду Design » Board Shape » Create Board Region from 3D body.
  3. Наведите курсор на 3D-модель, которую хотите использовать для создания области печатной платы, и щёлкните или нажмите Enter. Модель станет прозрачной.
  4. Перемещайте курсор по 3D-модели, чтобы найти грань. Когда под курсором окажется плоская поверхность, она станет непрозрачной и будет выделена тонкой синей рамкой.
  5. Найдя нужную грань, щёлкните или нажмите Enter — будет создана новая область платы (с заменой ранее заданной области платы в рабочей области).
  6. Появится диалоговое окно Board Outline Creation Successful, подтверждающее успешное создание. В нём можно скрыть компонент модели и исключить его из проверки DRC. Также можно изменить высоту модели, чтобы совместить грань с верхней или нижней поверхностью платы, либо оставить её положение без изменений.
Для определения области платы контур выбранной грани должен быть совмещён с печатной платой. 

Создание области выреза в плате

Чтобы создать внутренний вырез в плате, разместите область выреза в плате (Place » Define Board Cutout или нажмите кнопку на Active Bar). Вырез в плате — также полигональный объект, поэтому процесс его размещения совпадает с размещением самой области платы. На изображениях ниже показана область платы с двумя вырезами, которые при изготовлении становятся отверстиями в плате.

Вырез, размещённый в области платы, становится отверстием в готовой плате. Вырез, размещённый в области платы, становится отверстием в готовой плате.

Разделение контура платы на области

Существующую область платы можно разделить на две области, разрезав её. Эта операция выполняется, когда редактор печатных плат находится в режиме Board Planning Mode.

Плата разделена на три области платы с помощью команды Slice Region.

Чтобы разрезать область платы:

  1. Выберите View » Board Planning Mode (или используйте сочетание клавиш 1), чтобы перейти в Board Planning Mode.
  2. Выберите Design » Slice Board Region (или нажмите кнопку  на панели Active Bar), чтобы перейти в режим Slice Board Region.
  3. После выбора команды включается режим разрезания, аналогичный режиму размещения проводников. Начиная за пределами разрезаемой области, щелчками задайте последовательность вершин, определяющих линию разреза. При задании разреза нажимайте Shift+Spacebar для циклического переключения режимов углов; нажимайте Spacebar для переключения между начальным и конечным вариантами угла и используйте клавишу Backspace для удаления последнего размещенного угла. Конец линии разреза разместите за границей области платы. Завершив задание разреза, щелкните правой кнопкой мыши или нажмите Esc, чтобы завершить команду.
  4. Откроется диалоговое окно подтверждения с указанием количества разделяемых полигонов (областей) и количества полигонов (областей), которые будут созданы. Нажмите Yes для подтверждения их создания.

Каждая новая область может унаследовать один или несколько компонентов исходной области. Если эти компоненты входят в класс компонентов, для каждой новой области будет создан новый класс, а состав классов будет соответствующим образом обновлен.

Создание областей платы из выбранных объектов

В зависимости от формы платы может быть удобнее сформировать ее из нескольких областей платы. Как отмечалось выше, области можно размещать интерактивно или создавать по контуру, заданному проводниками и дугами. В видеоролике ниже показано создание трех областей платы из выбранных объектов. Обратите внимание: для задания смежных границ в местах соприкосновения областей используется один и тот же объект, что обеспечивает точное совмещение этих областей.

Распространенный подход — задать контуры областей с помощью проводников и дуг, а затем создать области платы из выбранных контуров.

Преобразование между примитивами 2D-чертежа и объектами определения платы

Распространенный подход к заданию формы платы и необходимых областей внутри нее — импорт чертежа из механической САПР. Например, можно импортировать механический чертеж из файла DWG и получить набор линий (проводников) на механическом слое, задающих форму платы, области внутри нее, а для гибко-жесткой платы — также расположение линий сгиба в гибких областях.

Программа содержит ряд команд для создания объектов определения платы (области, выреза, линии сгиба) из примитивов 2D-чертежа, а также соответствующие команды для обратного преобразования этих объектов в чертежные примитивы.

Объект Из выбранных примитивов 2D-чертежа Из объектов конструкции платы
Область платы Create Board Region from Selected Objects
(подменю Design » Board Shape)
Explode Region to Free Primitives
Вырез в плате Create Board Cutout from Selected Primitives Explode Board Cutout to Free Primitives
Линия сгиба Convert Selected Line to Bend Line Explode Bend Line

Примечания:

  • Команды преобразования в обоих направлениях доступны в подменю Tools » Convert соответствующего режима View (за исключением команды Create Board Region from Selected Objects, которая находится в подменю Design » Board Shape).
  • Чтобы преобразовать примитивы 2D-чертежа в объекты определения платы, переключите вид в 2D Layout Mode.
    • Перед выполнением команды необходимо выбрать примитивы.
    • Для создания области или выреза примитивы должны образовывать замкнутый контур. Подробнее о требованиях к этому контуру см. в блоке предупреждения ниже.
  • Чтобы преобразовать объекты определения платы в объекты 2D-чертежа, переключите вид в Board Planning Mode.
    • Эти команды не требуют предварительного выбора объектов, однако, если объект уже выбран, команда будет применена к нему.
    • Если на плате несколько областей, при разбиении на примитивы область исчезает. Если область платы только одна, примитивы будут созданы, а выбранная область сохранится (на плате всегда должна оставаться хотя бы одна область).
    • Объекты 2D-чертежа создаются на механическом слое типа Board Shape. Если слоя такого типа на плате нет, будет добавлен механический слой с типом Board Shape. Подробнее см. в разделе Механические слои и типы слоев.
    • Хотя отдельной команды для обратного объединения объекта, разбитого на примитивы, нет, для этого можно использовать команду Undo.
Все команды, создающие многоугольную фигуру на основе контура из линий (проводников) и дуг, пытаются определить фигуру по осевым линиям выбранных объектов. Если координаты конца одного сегмента проводника или дуги не совпадают в точности с координатами следующего сегмента, алгоритм определения границы завершится с ошибкой, и появится сообщение с указанием места ошибки. Затем будет предложено использовать вместо него алгоритм обводки. Учтите, что алгоритм обводки следует по внешним краям проводников и дуг, поэтому полученная фигура будет немного отличаться от созданной по осевым линиям. Выбирайте этот вариант, только если такое отличие допустимо для вашего проекта.

Изменение областей платы

В стандартном режиме проектирования гибко-жестких плат граница между двумя смежными областями задавалась перемещаемой синей линией разделения. В расширенном режиме проектирования гибко-жестких плат этот подход не используется: каждая область представляет собой отдельную замкнутую многоугольную фигуру. Поэтому каждую область можно изменять по мере необходимости с помощью стандартных приемов редактирования многоугольных фигур. Обратите внимание: для изменения области платы доступны не все команды редактирования многоугольников; в частности, недоступны команды добавления и вычитания многоугольников.

Если при изменении формы область платы начнет перекрывать соседнюю область, программа будет считать, что в зоне перекрытия находится область с наибольшим количеством слоев.

Что следует помнить при редактировании многоугольного объекта:

  • При перетаскивании вершины или ребра многоугольника доступны три режима изменения формы: сдвиг, излом и изгиб. Нажимайте Shift+Spacebar во время перетаскивания для циклического переключения режимов. Текущий режим отображается в строке состояния и на экранном индикаторе Heads-Up.
  • Привязка курсора определяется текущими настройками, в том числе сеткой привязки, доступными объектами привязки, наличием направляющих рабочей области и настройками привязки к осям. Используйте эти возможности для получения нужной формы. Подробнее см. в разделе Принципы работы привязки.

Назначение стека слоев и изменение имени области платы

Related page: Определение стека слоев

При создании новой платы она содержит одну область с именем Default Layer Stack Region. Этой области назначается стек слоев по умолчанию с именем Board Layer Stack.

При разделении формы платы на несколько областей каждой новой области также назначается стек слоев по умолчанию. После определения необходимых стеков слоев в менеджере стека слоев каждой области можно назначить свой стек и присвоить осмысленное имя.

В каждой области отображается метка с ее именем и именем назначенного ей стека слоев в формате Region Name - Layer Stack Name. Если для выбранного стека слоев включен режим гибкой платы, это также обозначается с помощью (flex). Режим гибкой платы для стека включается в Layer Stack Manager.

Чтобы назначить стек слоев и задать имя области:

  1. Выберите View » Board Planning Mode или нажмите сочетание клавиш 1, чтобы перейти в Board Planning Mode.
  2. Нажмите вкладку Multi-Layer в нижней части рабочей области, чтобы сделать этот слой активным (если вкладка слоя не видна, нажмите L, чтобы открыть панель View Configuration и включить ее отображение).
  3. Дважды щелкните область платы, чтобы открыть диалоговое окно Board Region, или щелкните область платы один раз и откройте панель Properties. Если область не выделяется и диалоговое окно не открывается, убедитесь, что фильтр выбора не исключает области.
  4. Назначьте стек слоев, выбрав нужный стек в раскрывающемся списке Layer stack.
  5. При необходимости измените Name.

Имя области платы и назначенный ей стек слоев отображаются в геометрическом центре этой области. Если назначенный стек настроен как гибкий, также отображается надпись (Flex).
Имя области платы и назначенный ей стек слоев отображаются в геометрическом центре этой области. Если назначенный стек настроен как гибкий, также отображается надпись (Flex).

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents