Подготовка выходных данных и выпуск проекта

Краткий обзор

Подготовьте готовый проект печатной платы к производству с помощью этого пошагового руководства по Altium Designer. Узнайте, как создавать файлы Output Job, настраивать документацию для изготовления и сборки, а также включать проверку правил проектирования в процесс выпуска. После настройки выходных данных ваш проект будет готов к выпуску. Читайте дальше, чтобы пройти заключительные этапы подготовки проекта печатной платы.

- Настройте вывод файлов Gerber и NC Drill, включая единицы измерения, точность и расположение выходных файлов.
- Настройте формирование спецификации (BOM), документации Draftsman и файлов Pick & Place для сборки.
- Добавьте отчет о проверке DRC, чтобы проверять соблюдение правил проектирования до формирования остальных выходных данных для выпуска.
Узнайте больше с ИИ:

Main page: Подготовка проекта к производству

Теперь, когда проектирование и трассировка печатной платы завершены, можно сформировать выходную документацию, необходимую для проверки, изготовления и сборки платы.

Поскольку при производстве печатных плат используются различные технологии и методы, Altium Designer позволяет формировать множество типов выходных данных для разных целей, включая файлы Gerber, файлы ODB++, файлы установки компонентов, отчеты с перечнем материалов и т. д.

Добавление файла Output Job в проект

Main page: Подготовка производственных данных с помощью Output Job

Хотя необходимые выходные данные можно выборочно формировать в соответствующих редакторах (например, с помощью команд в подменю Fabrication Outputs и Assembly Outputs главного меню File редактора печатных плат), Altium Designer также поддерживает файлы Output Job. Файл Output Job (или сокращенно OutJob) хранит настройки для каждого типа выходных данных. OutJob позволяет настроить каждый тип выходных данных, правила именования, формат и расположение выходных файлов. Выходные данные можно формировать непосредственно из OutJob или в рамках встроенного процесса выпуска проекта.

  1. Щелкните правой кнопкой мыши запись проекта на панели Projects и выберите команду Add New to Project » Output Job File в контекстном меню. Откроется новый файл Output Job, а связанная с проектом запись этого файла появится на панели Projects в разделе Settings\Output Job Files.

    Javascript ID: Tutorial_AddNewOutJob_AD25_4
  2. Щелкните правой кнопкой мыши запись OutJob на панели Projects и выберите команду Save As. Откроется диалоговое окно Save As, в котором по умолчанию будет выбрано сохранение документа в той же папке, что и файл проекта. Введите имя Fabrication в поле File name и нажмите кнопку Save.

  3. Добавление OutJob изменило проект, поэтому сохраните проект локально: щелкните правой кнопкой мыши запись проекта на панели Projects и выберите Save.

Добавление и настройка выходных данных для изготовления платы

Main page: Подготовка данных для изготовления платы

В этой части руководства вы настроите выходные данные, необходимые для изготовления платы: файлы Gerber и NC Drill. 

  1. Чтобы добавить новый набор выходных данных Gerber, нажмите ссылку Add New Fabrication Output в разделе Fabrication Outputs области Outputs файла OutJob и выберите Gerber Files » [PCB Document].

    Если выбрать вариант [PCB Document], в качестве источника выходных данных будет автоматически использоваться документ печатной платы из проекта. Кроме того, с этим вариантом OutJob можно легко копировать между проектами, поскольку изменять данную настройку не потребуется. Если в проекте несколько документов печатных плат, потребуется выбрать конкретную плату.

  2. Дважды щелкните добавленную запись выходных данных Gerber Files. Откроется диалоговое окно Gerber Setup. Настройте параметры в нем следующим образом:

    1. Поскольку плата спроектирована в метрической системе единиц, убедитесь, что для параметра Units установлено значение Millimeters.

    2. Минимальный размер, используемый на плате для трассировки и зазоров, составляет 0,25 мм. Однако у большинства компонентов опорная точка находится в геометрическом центре (а сами компоненты размещены по сетке 1 мм), поэтому некоторые контактные площадки фактически расположены по сетке 0,01 мм. Установите для параметра Decimal значение 0.001 mm. Это обеспечит более чем достаточное разрешение выходных данных для точного представления этих координат сетки.

    3. Нажмите кнопку  внизу вкладки Layer to plot и выберите Select Used. Слои, используемые в проекте, будут включены в столбце Plot расположенной выше таблицы.

  3. Нажмите Apply, чтобы принять остальные настройки по умолчанию и закрыть диалоговое окно Gerber Setup.

  4. Поскольку на плате есть отверстия, также необходимо сформировать файл сверления NC Drill. Аналогичным образом добавьте выходные данные NC Drill в файл OutJob: нажмите ссылку Add New Fabrication Output в разделе Fabrication Outputs области Outputs файла OutJob и выберите NC Drill Files » [PCB Document].

  5. Дважды щелкните добавленную запись выходных данных NC Drill Files, чтобы открыть диалоговое окно NC Drill Setup. Чтобы файлы NC Drill создавались в том же формате, что и файлы Gerber, установите для параметра Units значение Millimeters, а для параметра Format — 4:3. Убедитесь, что для параметра Coordinate Position установлено значение Reference to relative origin.

  6. Нажмите ОК, чтобы принять остальные настройки по умолчанию и закрыть диалоговое окно NC Drill Setup.

  7. Теперь, когда параметры Gerber и NC Drill настроены, необходимо задать правила именования и расположение выходных файлов. Для этого их нужно связать с контейнером выходных данных в правой части OutJob. Для отдельных файлов, каждый из которых имеет собственный формат, используйте контейнер Folder Structure. Новый OutJob по умолчанию уже содержит несколько контейнеров. Выберите запись Folder Structure в списке контейнеров выходных данных, затем нажмите переключатели для Gerber и NC Drill Files в столбце Enabled области Outputs, чтобы связать эти выходные данные с выбранным контейнером, как показано ниже.

  8. Последний шаг — настройка контейнера. Для этого нажмите ссылку Change в записи выбранного контейнера, чтобы открыть диалоговое окно Folder Structure settings. В верхней части окна находятся элементы управления для настройки расположения выходных файлов. Убедитесь, что в первом элементе управления выбрано значение Release Managed. В нижней части окна будет показано, как меняются имена и структура папок при выборе различных вариантов.

  9. Нажмите OK, чтобы закрыть диалоговое окно Folder Structure settings.

Добавление и настройка отчета о проверке DRC

Main page: Подготовка отчетов о проверках

Altium Designer поддерживает ряд проверок, которые можно включить в процесс формирования выходных данных. Каждая из них создает файл отчета в формате HTML. В процессе выпуска проекта эти проверки выполняются до формирования остальных выходных данных. Если хотя бы одна проверка не будет успешно пройдена, выпуск завершится с ошибкой.

  1. Чтобы добавить новый отчет о проверке DRC, нажмите ссылку Add Validation Output в разделе Validation Outputs области Outputs файла OutJob и выберите Design Rules Check » [PCB Document].

  2. Свяжите добавленный отчет с существующим контейнером Folder Structure. Выберите запись Folder Structure в списке в правой части OutJob, затем нажмите переключатель для выходных данных Design Rules Check в столбце Enabled области Outputs.

  3. Сохраните файл Output Job локально: щелкните правой кнопкой мыши его запись на панели Projects и выберите Save в контекстном меню.

  4. Закройте файл Output Job, щелкнув правой кнопкой мыши его вкладку в верхней части рабочей области и выбрав команду Close Fabrication.OutJob в контекстном меню. 

Добавление и настройка выходных данных для сборки

Main page: Настройка спецификации BOM в Report Manager

Формирование выходного файла спецификации BOM выполняется с помощью диалогового окна Report Manager — гибко настраиваемого инструмента создания отчетов, который позволяет формировать выходные данные в различных форматах, включая текстовый формат, CSV, PDF, HTML и Excel. К спецификациям BOM в формате Excel также можно применять один из готовых шаблонов или собственный шаблон.

  1. Добавьте в проект новый файл OutJob, щелкнув правой кнопкой мыши запись проекта на панели Projects и выбрав команду Add New to Project » Output Job File в контекстном меню.

  2. Щелкните правой кнопкой мыши запись OutJob на панели Projects и выберите команду Save As. Откроется диалоговое окно Save As, в котором будет предложено сохранить документ в той же папке, что и файл проекта. Введите имя Assembly в поле File name и нажмите кнопку Save.

  3. Сохраните проект локально, щелкнув правой кнопкой мыши запись проекта на панели Projects и выбрав Save.

  4. Чтобы добавить новые выходные данные BOM, нажмите ссылку Add New Report Output в разделе Report Outputs файла OutJob и выберите Bill of Materials » [ActiveBOM Document].

  5. Дважды щелкните добавленные выходные данные Bill of Materials, чтобы открыть диалоговое окно Report Manager.

  6. В области Export Options панели Properties в правой части диалогового окна выберите Generic XLS (*.xls, *.xlsx, *.xlsm) в раскрывающемся списке File Format, а затем в раскрывающемся списке Template выберите шаблон BOM Template Single Supplier из числа шаблонов, хранящихся в вашем рабочем пространстве.

  7. Нажмите OK, чтобы сохранить изменения и закрыть диалоговое окно Report Manager.

  8. Добавьте новые выходные данные Draftsman, нажав ссылку Add New Documentation Output в разделе Documentation Outputs файла OutJob и выбрав Draftsman » All Draftsman Documents.

  9. Свяжите добавленные выходные данные BOM и Draftsman с существующим контейнером выходных данных PDF. Для этого выберите запись PDF в списке контейнеров выходных данных в правой части файла OutJob, затем установите переключатели для выходных данных Bill of Materials и Draftsman в столбце Enabled области Outputs.

  10. Выбрав запись контейнера PDF, нажмите ссылку Change в этой записи, чтобы открыть диалоговое окно PDF settings.

  11. Нажмите запись Assembly.PDF в верхней части диалогового окна PDF settings, выберите Separate file for each output using output name и нажмите кнопку . Выходным файлам спецификации BOM и чертежа будут присвоены имена, заданные для соответствующих выходных данных в файле OutJob (Bill of Materials.pdf и Draftsman.pdf соответственно). Эти имена отображаются в области Preview диалогового окна.

    Javascript ID: Tutorial_Dlg_PDFsettings_Path_AD24
  12. Нажмите OK, чтобы закрыть диалоговое окно.

  13. Добавьте новые выходные данные Pick & Place, нажав ссылку Add New Documentation Output в разделе Documentation Outputs файла OutJob и выбрав Generates pick and place files » [PCB Document].

  14. Дважды щелкните добавленные выходные данные Generates pick and place files, чтобы открыть диалоговое окно Pick and Place Setup.

  15. В области Output Setting в левой нижней части диалогового окна задайте для Units значение Metric.

  16. Нажмите OK, чтобы принять остальные настройки по умолчанию и закрыть диалоговое окно Pick and Place Setup.

  17. Свяжите добавленные выходные данные Pick & Place с существующим контейнером выходных данных Folder Structure. Для этого выберите запись Folder Structure в списке контейнеров выходных данных в правой части файла OutJob, затем установите переключатель для выходных данных Generates pick and place files в столбце Enabled области Outputs.

  18. Сохраните файл Output Job локально, щелкнув правой кнопкой мыши его запись на панели Projects и выбрав Save в контекстном меню.

  19. Закройте файл Output Job, щелкнув правой кнопкой мыши его вкладку в верхней части рабочей области и выбрав команду Close Assembly.OutJob в контекстном меню.

Выпуск проекта

Main page: Выпуск проекта

После настройки выходной документации в файлах Output Job проект готов к выпуску в подключенное рабочее пространство. Процесс выпуска проекта платы автоматизирован, что позволяет выпускать проекты плат без рисков, связанных с выполнением процедур выпуска вручную. При выпуске конкретного проекта создается снимок его исходных данных, который архивируется вместе со всеми сформированными выходными данными, представляющими материальный продукт, изготавливаемый по этому проекту и продаваемый компанией.

Сам процесс выпуска выполняется с помощью Project Releaser в Altium Designer. Пользовательский интерфейс этого инструмента представлен в отдельном представлении Release. Процесс выпуска состоит из нескольких этапов, а записи в левой части представления позволяют сразу определить текущий этап.

  1. Щелкните правой кнопкой мыши запись проекта на панели Projects и выберите команду Project Releaser в контекстном меню. Представление Release откроется на отдельной вкладке документа.

  2. На первом этапе — 1. Configure Server Release — укажите типы данных, которые требуется сформировать. Нажимайте элементы управления Details в правом конце заголовка каждого набора данных, чтобы просмотреть подробные сведения о том, какие именно данные будут сформированы.

  3. Нажмите кнопку  в левом нижнем углу представления, чтобы открыть диалоговое окно Project Release Options. На вкладке Release Options этого диалогового окна убедитесь, что Managed - <WorkspaceName> выбран в качестве Release Target, Fabrication назначен набору Fabrication Data, а Assembly назначен набору Assembly Data.

  4. Нажмите OK, чтобы закрыть диалоговое окно и вернуться в представление Release.

  5. Убедитесь, что оба параметра — Include Fabrication Data и Include Assembly Data for No Variant — включены.

  6. Нажмите кнопку  в правом нижнем углу представления, чтобы продолжить.

  7. Откроется диалоговое окно Item Creation со списком целевых элементов выпуска, которые будут созданы в рабочем пространстве. Выберите вариант Create items, чтобы подтвердить создание элементов.

  8. В открывшемся диалоговом окне Project Modified выберите вариант Save and Commit changes, чтобы сохранить изменения локально и перейти к сохранению изменений в рабочем пространстве.

  9. В открывшемся диалоговом окне Commit to Version Control введите содержательный комментарий в поле Comment (например, The project is ready for release), затем нажмите кнопку .

  10. Следующий этап процесса выпуска — 2. Validate Project — запускается автоматически, поскольку файл Output Job Fabrication включает отчет о проверке правил проектирования.

    Если какая-либо проверка не пройдена, выпуск завершится с ошибкой. При выпуске проекта в этом учебном руководстве это будет означать, что документ печатной платы содержит хотя бы одно нарушение правил проектирования (DRC). В этом случае остановите процесс выпуска кнопкой  в правом нижнем углу представления, откройте документ печатной платы, устраните нарушения DRC, а затем снова запустите процесс выпуска.

  11. После успешной проверки автоматически запускается следующий этап процесса выпуска — 3. Generate Data. На этом этапе формируются все остальные выходные данные, определенные в файлах OutJob, назначенных включенным в выпуск элементам данных. Полученные данные предназначены для выпуска в соответствующие целевые элементы рабочего пространства.

  12. Когда все проверки пройдены и выходные данные сформированы, следующий этап процесса выпуска — 4. Review Data — позволяет просмотреть полученные данные. Чтобы продолжить выпуск, нажмите кнопку  в правом нижнем углу представления.

  13. Откроется диалоговое окно Confirm Release со сводной информацией о конфигурациях проекта, которые будут выпущены в рабочее пространство. Введите Release Note (например, Initial Release) и нажмите OK.

  14. После подтверждения выпуска на предыдущем этапе автоматически начинается следующий этап — 5. Upload Data. На нем отображается ход загрузки данных в ревизии соответствующих элементов данных рабочего пространства.

  15. Заключительный этап процесса — 6. Execution Report — содержит сводную информацию о выпуске. Закройте представление Release, нажав кнопку  в его правом нижнем углу.

Совместное проектирование с использованием рабочего пространства

Как правило, в проектировании и разработке электронного изделия участвуют несколько человек. Для эффективной работы участники команды должны иметь возможность совместно работать над проектом. Altium Designer в сочетании с подключенным рабочим пространством поддерживает ряд функций совместного проектирования. Некоторые из них перечислены ниже.

  • Project history — специальное представление History представляет собой расширенную графическую шкалу истории проекта. На ней в хронологическом порядке отображаются основные события проекта: создание, фиксации изменений, выпуски, клонирование и обмен данными с MCAD. Для событий, где это применимо, доступны различные действия (). Чтобы открыть представление History проекта рабочего пространства из Altium Designer, щелкните правой кнопкой мыши запись проекта на панели Projects и выберите команду History & Version Control » Show Project History в контекстном меню.

    Подробнее: История проекта, Project History (Рабочее пространство Altium 365, Рабочее пространство Enterprise Server)

  • Web Viewer — интерфейс Web Viewer рабочего пространства обеспечивает универсальный доступ к документам проекта через обычный браузер. Это гораздо больше, чем просто средство просмотра в браузере: передовые веб-технологии позволяют пользователям перемещаться по структуре проекта, взаимодействовать с проектными документами, выделять области или объекты для добавления комментариев, а также искать, выполнять перекрестное выделение, выбирать и изучать компоненты и цепи во всем проекте. Чтобы открыть Web Viewer для проекта рабочего пространства из Altium Designer, щелкните правой кнопкой мыши запись проекта на панели Projects и выберите команду Show in Web Browser в контекстном меню.

    Подробнее: Web Viewer (Платформа Altium 365, Рабочее пространство Enterprise Server)

  • Document commenting — комментарий — это добавленное пользователем примечание, привязанное к определенной точке, объекту или области (в зависимости от ситуации) в поддерживаемом представлении данных. Другие пользователи могут отвечать на него. Комментарии упрощают совместную работу, не изменяя сами общие данные, поскольку рабочее пространство хранит комментарии отдельно от этих данных. Комментарии, добавленные в интерфейсе Web Viewer в перечисленных далее местах, становятся доступны в Altium Designer, и наоборот. В Altium Designer управление комментариями выполняется через панель Comments and Tasks ().

    Подробнее: Комментирование документов, Web Viewer (Платформа Altium 365, Рабочее пространство Enterprise Server)

  • Sharing a project — после сохранения проекта в рабочем пространстве можно определить, какие пользователи получат к нему доступ для совместного проектирования и/или рецензирования. Для этого необходимо предоставить общий доступ к проекту, точнее — настроить права доступа к нему. В Altium Designer общий доступ к проекту настраивается в диалоговом окне Share (). Чтобы открыть его, щелкните правой кнопкой мыши запись проекта на панели Projects и выберите команду Share в контекстном меню.

    Подробнее: Предоставление общего доступа к проекту, Workspace Projects (Рабочее пространство Altium 365, Рабочее пространство Enterprise Server)

Поздравляем! Вы начали с пустого листа схемы и создали готовую печатную плату, выпустив выходные данные в рабочее пространство, — то есть прошли весь процесс проектирования в Altium Designer!

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents