使用焊盘过孔模板

概览

本文介绍 Altium Designer 如何利用焊盘和过孔模板,提高 PCB 设计中的复用性、一致性和管理效率。您将了解如何在 PCB 中自动创建本地模板、如何添加可用的外部焊盘过孔模板库,以及如何通过 PCB 焊盘过孔模板面板集中查看、放置、筛选和管理这些模板定义。本文还将概述模板如何保持与源库的链接、这种链接对编辑有何影响,以及在设计流程的哪些环节可以应用模板。继续阅读,了解这些工具如何帮助您提高工作效率,更好地掌控设计。

- 了解本地焊盘和过孔模板与存储在外部焊盘过孔库中的模板有何区别,以及它们各自在 PCB 设计中的用途。
- 了解如何使用 PCB 焊盘过孔模板面板来放置模板、查看可用库、筛选模板列表,以及查看当前 PCB 中已使用的模板。
- 了解模板名称的生成方式、链接的库模板如何影响可编辑性,以及如何在设计规则和 PCB 设计流程中应用模板。
使用 AI 深入了解:
 

与走线对象一样,焊盘和过孔也是所有电路板设计的基本元素。每个焊盘和过孔都可以在放置期间或放置后配置为自定义对象。

3D 中的焊盘和过孔 
3D 中的焊盘和过孔

为了提高 PCB 设计中焊盘和过孔的设计复用与管理能力,Altium Designer 还支持:自动创建焊盘和过孔模板、焊盘和过孔模板库,以及多个相关的焊盘和过孔管理面板。

将焊盘和过孔模板集中存储在库中的概念与 PCB 封装库类似,只是更为基础。焊盘过孔模板库并不存储实际的焊盘和过孔,而是存储预先配置的定义,并在放置焊盘或过孔实例时应用这些定义。已保存的焊盘过孔模板库可以加载到任意 PCB 设计或 PCB 封装中,用于放置预定义的焊盘和过孔实例。

有关创建焊盘过孔库的更多信息,请参阅创建焊盘和过孔模板及库页面。

如前所述,可以将现有模板保存到焊盘和过孔模板库中,也可以创建新模板。这些库中的模板可通过 PCB Pad Via Templates 面板使用。面板中还列出了本地模板,因此该面板是使用焊盘和过孔模板库的核心工具。

PCB 焊盘过孔模板面板

PCB Pad Via Templates 面板是一个专用面板,其中列出了存储在当前 PCB 文档中的焊盘/过孔模板(本地),以及已安装或已包含在当前设计项目中的焊盘过孔库所提供的模板(可用库)。

单击设计空间右下角的 按钮,然后选择 PCB Pad Via Templates,即可打开该面板。

该面板具有访问本地模板和库模板的双重功能。
该面板具有访问本地模板和库模板的双重功能。

面板中呈现的两种库概念可概括如下:

  • Available Pad/Via Template Libraries – 已加载或已安装的焊盘过孔库(基于文件的焊盘/过孔模板集合)。面板的此区域列出了当前所选焊盘过孔库中包含的模板。
  • Local Pad & Via Library – 当前电路板设计中使用的焊盘/过孔模板的统称,包括从焊盘过孔库获取或添加的所有模板。面板的此区域列出了应用于当前电路板设计中焊盘/过孔的模板。

本地焊盘和过孔库

面板下方 Local Pad & Via Library 区域中列出的条目代表当前电路板设计中使用并保存的焊盘/过孔配置(模板)。所选模板的预览显示在该区域底部。

此处列出的模板是保存在 PCB 文件中的焊盘过孔模板,并不包含在单独定义的“库”中。将所选模板拖到布局中,或从面板的右键快捷菜单中选择 Place,即可在当前电路板中将其复用为新的焊盘或过孔实例。

放置本地焊盘模板实例。
放置本地焊盘模板实例。

可用的焊盘和过孔模板文件库

面板上方的 Available Pad/Via template Libraries 区域用于处理焊盘过孔模板文件库。

可以从面板拖动模板,或使用右键快捷菜单,将所选库中的模板放置到 PCB 中。由于焊盘/过孔是从外部模板文件库中放置的,因此无法在 PCB 中编辑其属性,如下方右侧的 Properties 面板图像所示。要编辑基于库的焊盘/过孔的属性,必须先解除其模板链接,详情请参阅 解除模板与库的链接部分。

当前活动焊盘过孔库中的模板,本例中为 Preferred.PvLib。第二张图像显示了所选焊盘已放置实例的属性。请注意,焊盘形状和孔尺寸等物理属性无法编辑。 
当前活动焊盘过孔库中的模板,本例中为 Preferred.PvLib。第二张图像显示了所选焊盘已放置实例的属性。请注意,焊盘形状和孔尺寸等物理属性无法编辑。

将基于文件的焊盘或过孔模板放置到电路板设计中后,它仍会保持与源库模板和源库名称的链接。由于其来源是外部文件,因此无法编辑使用该模板的焊盘或过孔的物理属性,从而保护外部库文件中源模板的完整性。要编辑基于文件的焊盘或过孔模板,可以先解除链接,详情请参阅解除模板与库的链接部分。

面板顶部的下拉列表用于选择当前活动的可用库,下图中为 ExampleViaLib.PvLib。 按钮用于打开 Available Libraries 对话框,可在其中添加和移除模板库文件。下文将介绍可用库。使用 Filter 字段可仅显示 Name 以该字符串开头的模板。

使用 Filter 字段可快速筛选模板列表。
使用 Filter 字段可快速筛选模板列表。

使焊盘过孔模板库可用

Available Libraries 指的是其模板可用于当前电路板设计的焊盘过孔模板库。这包括已添加到当前项目的模板库,以及已安装在 Altium Designer 中的模板库。这两类库都可以在 Available Libraries 对话框中查看和管理;单击 PCB Pad Via Templates 面板顶部的  按钮即可打开该对话框。

安装外部焊盘过孔库,或使用 Project 选项卡将现有库添加到当前项目。
安装外部焊盘过孔库,或使用 Project 选项卡将现有库添加到当前项目。

  • 该对话框的 Project 选项卡列出了项目中包含的所有 PvLib 文件,并提供了用于向项目添加库或从项目移除库的按钮。
  • Installed 选项卡列出了当前 Altium Designer 安装中所有可用的焊盘过孔模板库,因此这些库可用于所有 PCB 设计项目。请注意,对于已安装的库,可以通过启用/禁用对应的 Activated 选项来控制其是否可用。这样就无需反复移除和重新添加库。

在设计中使用模板

PCB Pad Via Templates 面板中列出的模板可通过以下方式用于当前电路板设计:

在布线过孔样式设计规则中,或为网络添加缝合过孔时,使用过孔模板。
在布线过孔样式设计规则中,或为网络添加缝合过孔时,使用过孔模板。

焊盘/过孔模板及其命名方式

对于放置到电路板设计中的每一种独特焊盘或过孔,系统都会自动创建焊盘/过孔模板,为其命名并将其存储在电路板文件中。模板存储焊盘/过孔的基本配置,包括尺寸、形状、焊盘堆叠类型、锡膏层/阻焊层和孔信息等。系统按照 IPC 标准(具体为 IPC-7251/7351 焊盘堆叠命名规范)自动为配置命名。设计中使用的每个焊盘和过孔都引用其对应的模板,这可以在 Properties 面板中查看,如下所示。

IPC 命名体系基于公制,其中一个单位等于百分之一毫米(10-5 米,即 10µm)。例如,直径为 1.5mm、孔径为 0.8mm 的圆形焊盘,其模板名称为 c150h80,其中 c 表示圆形,h 是孔径的前缀。名为 r155_125 的焊盘是尺寸为 1.55mm x 1.25mm 的矩形表面贴装焊盘;名为 s160h100 的焊盘是边长为 1.6mm、孔径为 1.0mm 的方形通孔焊盘。自定义形状焊盘模板的名称 以 u 为前缀。对于指定的锡膏层/阻焊层属性,还会添加相应的字母/整数组合。

要观察这一行为,请双击现有焊盘或过孔对象,或选择该对象后从右键菜单中选择 Properties,在其对应的 Properties 面板中查看属性。

Properties 面板中显示的自动生成的焊盘或过孔模板名称。
Properties 面板中显示的自动生成的焊盘或过孔模板名称。

请注意面板 Pad/Via Template 区域中分配的 Template 名称。根据 IPC 指南,该名称由焊盘/过孔的基本属性生成,例如尺寸、形状、孔以及锡膏层/阻焊层配置。如果这些属性发生变化,模板名称也会随之更改,以反映新的配置。正如您所预期的那样,使用英制单位而非公制单位时,焊盘或过孔属性与其模板名称之间的关系不那么直观。

在 PCB 设计空间中定位焊盘或过孔

每次使用 Place 菜单或 Active Bar 在 PCB 设计中放置一种尺寸独特的焊盘或过孔时,系统都会在电路板文件中自动创建一个新的焊盘/过孔模板。这些模板称为 <Local> 模板。对于当前 PCB,可以将 PCB 面板设置为焊盘和过孔模板模式,查看所有已使用的焊盘和过孔模板列表。

处于 Pad &amp; Via Templates 模式的 PCB 面板
处于 Pad & Via Templates 模式的 PCB 面板

Pad & Via Templates 模式可对当前 PCB 文档中使用的焊盘和过孔模板进行高级控制。 面板的此模式分为三个区域:

  • Library Name
  • Templates
  • Pads/Vias

库名称

此列表将设计中的焊盘和过孔模板实例显示为一组虚拟库和实体库。 这些库用于筛选面板下方区域列表中的模板, 排列如下:

  • All——显示所有焊盘和过孔模板, 包括来自焊盘和过孔库的模板。
  • Pads——显示所有焊盘, 包括本地焊盘和基于库的焊盘。
  • Vias——显示所有过孔, 包括本地过孔和基于库的过孔。
  • Local——显示应用于电路板的所有焊盘和过孔模板,但不包括从焊盘/过孔库添加的模板。
  • Pad & Via Libraries——仅显示从所选焊盘/过孔库应用的焊盘和过孔模板。

模板

此区域列出当前 PCB 设计中使用的所有焊盘/过孔模板。其列包括模板来源 Library Name(本地或焊盘/过孔库名称),以及每个模板的焊盘/过孔实例数量(Count)。

当面板的 Library Name 区域设置为某个特定的焊盘/过孔库时,Template 区域可能会显示 Count 为零的条目。这表示该模板目前未被电路板布局中的任何焊盘/过孔使用,但在设计项目中有所使用——例如,它可能用作默认的焊盘/过孔设置,或用于定义布线过孔样式等设计规则的约束。

可以将列表中的任意数量模板保存到单独的焊盘/过孔库中。为此,请使用标准的 Shift+Click 和 Ctrl+Click 多选方式选择多个模板,然后单击 Save as Library 按钮。该库将自动添加到项目中, 您可以在项目面板中使用 File » Save As,将其保存为所需的 *.PvLib 文件名。有关创建焊盘/过孔模板库的更多信息,请参阅创建和编辑焊盘/过孔模板库页面。

Templates 区域还允许使用 Place 按钮,将基于焊盘/过孔库的模板放置到 PCB 设计中。在面板顶部的 Library Name 区域中选择所需的焊盘/过孔库,即可启用此功能。

如果所选焊盘/过孔模板位于焊盘/过孔模板库中,可以使用 Place 按钮放置该模板。要放置本地焊盘/过孔,请使用 PCB Pad Via Templates 面板,如下所述。

焊盘/过孔

面板的此区域显示上方 Templates 区域中所选模板的各个焊盘/过孔实例。

选择各个焊盘/过孔实例时,设计空间中的相应对象会高亮显示,具体显示方式由 PCB 面板顶部的标准高亮、缩放和选择选项决定。 随后可在 Properties 面板中编辑所选焊盘或过孔,在 Template 下拉列表中选择所需模板,使其使用不同的模板。

此区域中列出的每个实例都带有一个 Changed 指示框。当关联的库源模板与本地焊盘或过孔所使用的模板不同时,即 源焊盘/过孔库已更新时,该指示框会被勾选。如果本地焊盘/过孔的焊盘堆叠类型发生变化,例如 某个焊盘实例在本地由多层改为单层,Changed 指示框也会被勾选。

在所有情况下,都可以使用PCB 焊盘/过孔模板面板 Update按钮,将本地版本的焊盘或过孔更新(或还原)为源焊盘/过孔库中的当前模板。

焊盘与过孔模板的编辑和管理任务

本节介绍需要编辑焊盘或过孔模板的各种情况。

为现有焊盘/过孔应用不同的模板

有时,您可能希望为现有焊盘或过孔应用不同的模板(例如,减少设计中使用的过孔类型数量)。在这种情况下,请使用 PCB 面板的 Pad & Via Templates 模式,查找并选择要更改的焊盘/过孔。然后,在 Properties 面板的 Template 下拉列表中选择所需模板,即可为选中的焊盘或过孔指定不同的模板。

正在应用不同的模板。
正在应用不同的模板。

解除模板与库的链接

对于使用基于文件的模板库中模板的焊盘/过孔,无法编辑其属性,否则本地实例将不再与引用的库模板一致。要编辑引用库模板的焊盘或过孔,必须先解除模板链接。

单击 Linked button, click to copy the template from the file library to the local library and reference the local template 按钮可解除模板链接。单击此按钮后,会在本地库中创建该模板的副本,并将所选焊盘/过孔实例的引用改为此本地模板。请注意,如果 Linked button, click to copy the template from the file library to the local library and reference the local template 按钮呈灰色,则表示该模板已经是本地模板。

单击以解除模板与基于文件的库之间的链接。模板将被复制到本地库,并使用该本地模板。
单击以解除模板与基于文件的库之间的链接。模板将被复制到本地库,并使用该本地模板。

如果要解除链接的焊盘/过孔在焊盘与过孔模板库中定义了自定义名称,该名称将被移除,本地模板将采用 IPC 标准命名规则。

将库模板添加到本地库

如有需要,可以将库模板添加到本地库。右键单击模板名称并从上下文菜单中选择 Add to Internal Library,或者将模板从面板的 Pad/Via Library 区域拖至 Local Pad & Via Library 区域的空白处,即可完成此操作。

使用右键菜单或拖放操作,将焊盘/过孔模板添加到本地库。
使用右键菜单或拖放操作,将焊盘/过孔模板添加到本地库。

单击 Removed Unused Pad/Via 按钮可从本地库中移除未使用的焊盘/过孔库模板。

这相当于放置一个使用焊盘与过孔库模板的焊盘/过孔,然后将其从电路板上删除,从而将该模板登记为本地可用模板。若要 replace 本地模板,而不是向本地列表中添加模板,请参阅下文的替换本地模板。

从焊盘与过孔库更新

如果焊盘/过孔的模板已在库中更新,并且该模板已用于电路板设计,请单击 PCB Pad Via Templates 面板中的 Update 按钮,以更新设计中的焊盘/过孔模板。更新将自动应用到电路板中使用该模板的所有焊盘/过孔实例。

如果焊盘/过孔所使用的模板已在库中更新,可使用 PCB Pad Via Templates 面板中的 Update 按钮,在 PCB 设计中更新该焊盘/过孔。
如果焊盘/过孔所使用的模板已在库中更新,可使用 PCB Pad Via Templates 面板中的 Update 按钮,在 PCB 设计中更新该焊盘/过孔。

启动更新时,将打开 Update Pads/Vias on Board 对话框,列出检测到的、即将应用的更改详情。

对于检测到与源库版本不同的焊盘/过孔模板,可以从库中更新到 PCB 设计。
对于检测到与源库版本不同的焊盘/过孔模板,可以从库中更新到 PCB 设计。

该对话框提供三个更新选项,用于控制更新过程:

  • Update locked objects – 强制更新焊盘/过孔对象的模板,无论该对象是否处于锁定状态。
  • Update free objects – 仅更新应用于自由焊盘和过孔的焊盘/过孔模板。
  • Update component objects – 仅更新应用于元件中焊盘和过孔的焊盘/过孔模板。

此同步行为由焊盘和过孔的 Library 属性决定;分别查看所选焊盘或过孔的属性时,可在 Properties 面板中看到该属性。如果模板的本地版本与源模板存在差异,PCB 面板的焊盘与过孔模板模式中 Pads/Vias 区域的 Changed 列会显示相应提示。

即使源焊盘与过孔库中的模板名称发生更改,仍可通过存储在电路板设计数据中的模板 GUID 引用,保持模板与 PCB 设计中使用该模板的焊盘/过孔之间的链接。

对话框底部区域列出了要更新的焊盘/过孔,并显示各对象的信息,包括 Type、 Description、 Library、 Template 和 Action。此外,您还可以选择将每个焊盘/过孔标记为 Locked 和/或 In Component。启用这些选项后,对象将受对话框顶部区域的设置控制。

替换本地模板

基于库的焊盘/过孔模板也可以 replace 本地模板,这会更新电路板上使用该本地模板的焊盘或过孔。

要执行此操作,请将所需的库模板从面板的 Pad/Via Library 区域拖至 Local Pad & Via Library 区域,但这次应将库模板放到现有本地模板条目on top of。使用该模板的所有自由焊盘/过孔或元件焊盘/过孔实例,都将更新为新库模板的样式。

在下面的动画中,请注意,C1 和 C2 元件焊盘的实际形状会变为拖放的库模板所指定的类型,即从 r110_100 变为 s120。

将库模板拖放到本地模板条目上,即可为设计中的所有实例替换该模板。
将库模板拖放到本地模板条目上,即可为设计中的所有实例替换该模板。

移除未使用的焊盘/过孔

由于本地库中列出的模板名称源自当前 PCB 布局中的焊盘和过孔,因此,如果某种本地焊盘/过孔配置的所有实例都已从电路板上删除,其对应模板也会从本地列表中移除。

但是,如果已放置的焊盘或过孔源自焊盘与过孔库,即使该焊盘/过孔的所有实例都已从电路板上移除,其模板仍会保留在本地列表中。对于不再需要的焊盘与过孔库模板实例,可使用 Remove Unused Pad/Via 按钮将其从本地“数据库”记录中移除。随后将打开 Update Templates from Library 对话框,您可以在其中选择要从本地焊盘与过孔库中移除的焊盘和过孔模板。使用 Templates 按钮或右键菜单,可选择或取消选择列表中的所有模板,也可反选。

Update Templates from Library 对话框
Update Templates from Library 对话框

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents