Arbeiten mit Leiterbahnen und Kreisbögen
Auf einen Blick
- Lernen Sie, wie Sie Leiterbahnsegmente im PCB-Editor mit den wichtigsten Befehlen und Tastenkombinationen platzieren, bearbeiten, verschieben und neu routen.
- Verstehen Sie, wie das interaktive Routing auf Netze, Lagen, Eckmodi, Konfliktlösungsstrategien und geltende Designregeln reagiert.
- Erfahren Sie, wie die Leiterbahnbreite bestimmt und angepasst wird und wie Voreinstellungen und Regeln die verfügbaren Breiten beeinflussen.
Arbeiten mit Leiterbahnen
Ein Leiterbahnsegment ist eine gerade Linie mit einer definierten Breite. Mit Leiterbahnen definieren Sie gerade Linien im PCB-Designbereich. Leiterbahnen werden auf einer Signallage platziert, um die elektrischen Verbindungen zwischen Bauteilpads herzustellen, also das Routing. Leiterbahnen auf einer nicht elektrischen Lage werden als Linien bezeichnet. Dort dienen sie als allgemeine Zeichenelemente, beispielsweise für Bauteilumrisse, Anweisungen oder Sperrbereichsgrenzen. Leiterbahnen werden auch in gruppierten Designobjekten wie Bemaßungen und Koordinaten verwendet.

Leiterbahnobjekte werden für das Routing und als allgemeine Zeichenlinien verwendet. Im obigen Bild sind vier bereits platzierte Leiterbahnsegmente und ein weiteres Segment zu sehen, das gerade platziert wird.
Obwohl Leiterbahnen und Linien eigentlich dasselbe Objekt sind, unterscheidet sich das Verhalten der Software bei ihrer Platzierung. Deshalb gibt es dafür unterschiedliche Befehle. Wenn ein Befehl zur Leiterbahnplatzierung ausgeführt wird, beispielsweise Interactive Routing, überwacht die Software die Klickposition und übernimmt automatisch den Netznamen eines dort vorhandenen Objekts, etwa eines Pads. Außerdem überwacht und berücksichtigt sie alle anwendbaren Designregeln. Beim Ausführen eines Befehls zur Linienplatzierung (Place » Line) erfolgt diese Überwachung nicht.
Leiterbahnen können sowohl im PCB-Editor als auch im PCB-Bibliothekseditor platziert werden. Unabhängig vom verwendeten Befehl (Routing/Leiterbahn- oder Linienplatzierung) ist das grundlegende Platzierungsverhalten gleich. Nach dem Starten des Befehls wird der Mauszeiger zu einem Fadenkreuz, und Sie gelangen in den Modus zur Leiterbahnplatzierung. Die Platzierung erfolgt in diesen Schritten:
- Klicken Sie oder drücken Sie Enter, um den Startpunkt des ersten Leiterbahnsegments festzulegen. Wenn ein Routing-Platzierungsbefehl ausgeführt wird und Sie die Platzierung durch Klicken auf ein vorhandenes Objekt beginnen, übernimmt die Leiterbahn dessen Netznamen. Beim Routing wird die Breite durch die anwendbare Designregel Routing-Breite bestimmt. Diese kann durch bestimmte Optionen für das interaktive Routing überschrieben werden, die weiter unten ausführlicher beschrieben werden.
- Bewegen Sie den Mauszeiger, um das Leiterbahnsegment zu definieren. Klicken Sie anschließend oder drücken Sie Enter , um den Endpunkt dieses ersten Segments festzulegen, der zugleich der Startpunkt des nächsten verbundenen Segments ist.
- Positionieren Sie den Mauszeiger weiter und klicken Sie jeweils oder drücken Sie Enter , um eine Reihe von Eckpunkten festzulegen, die die verbundenen Leiterbahnsegmente definieren.
- Klicken Sie mit der rechten Maustaste oder drücken Sie Esc, um die aktuelle Folge verbundener Leiterbahnsegmente abzuschließen.
Während der Platzierung sind außerdem folgende Aktionen möglich:
- Drücken Sie die Taste * auf dem Ziffernblock, um die verfügbaren Signallagen durchzuschalten. Alternativ können Sie mit der Kombination Shift+Ctrl+Wheel Roll zwischen den Routing-Lagen wechseln. Mit jeder Rastung des Mausrads wechseln Sie zur nächsten bzw. vorherigen verfügbaren Signallage.
- Drücken Sie die Tasten + und - auf dem Ziffernblock, um alle derzeit im Design sichtbaren Lagen vorwärts bzw. rückwärts durchzuschalten.
Beim Platzieren von Leiterbahnsegmenten stehen fünf Eckenmodi zur Verfügung. Vier davon bieten zusätzlich Untermodi für die Eckenrichtung. Während der Platzierung:
- Drücken Sie Shift+Spacebar, um die verfügbaren Eckenmodi durchzuschalten.
- Drücken Sie Spacebar, um zwischen den beiden Untermodi für die Eckenrichtung umzuschalten.
- Halten Sie in einem der beiden Bogen-Eckenmodi die Taste , oder . gedrückt, um den Bogen zu verkleinern bzw. zu vergrößern. Halten Sie dabei zusätzlich die Taste Shift gedrückt, um die Größenänderung zu beschleunigen.
- Drücken Sie die Tastenkombination 1, um zwischen der Platzierung eines Segments pro Klick (in den ersten fünf Bildern unten dargestellt) und zweier Segmente pro Klick (im letzten Bild unten dargestellt) umzuschalten. Im ersten Modus wird das nur als Umriss dargestellte Leiterbahnsegment als Vorschausegment bezeichnet.
- Drücken Sie die Taste Backspace, um den letzten Eckpunkt zu entfernen.



Drücken Sie Shift+Spacebar, um die fünf verfügbaren Eckenmodi durchzuschalten, Spacebar, um die Eckenrichtung umzuschalten, und die Tastenkombination 1, um zwischen der Platzierung eines oder zweier Segmente umzuschalten.
Bei der grafischen Bearbeitung können Sie ein platziertes Leiterbahnobjekt direkt im Designbereich auswählen und seine Größe, Form oder Position grafisch ändern.
Wenn ein Leiterbahnobjekt ausgewählt ist, stehen folgende Bearbeitungsgriffe zur Verfügung:
- Klicken und ziehen Sie A, um die Endpunkte der Leiterbahn neu zu positionieren.
- Klicken und ziehen Sie B, um die Form der Leiterbahn zu ändern.
Der PCB-Editor enthält ausgefeilte Algorithmen zum Verschieben von Leiterbahnsegmenten auf der Leiterplatte, mit denen die Routing-Struktur erhalten bleibt. Dieses gleitende Verschieben von Leiterbahnsegmenten können Sie interaktiv auslösen: Wählen Sie zunächst das Leiterbahnsegment durch Klicken aus. Sobald der spezielle Mauszeiger erscheint, klicken Sie erneut und halten die Maustaste gedrückt, um das Segment gleitend zu verschieben. Alternativ können Sie direkt auf ein Leiterbahnsegment klicken, die Maustaste gedrückt halten und es gleitend verschieben. Das Verhalten lässt sich über die Optionen Dragging auf der Seite „PCB Editor – Interactive Routing“ des Dialogs Preferences konfigurieren. Mit diesen Optionen können Sie einer Leiterbahn die Aktion „Move“ zuweisen. Das ist hilfreich, wenn Sie ein einzelnes Leiterbahnsegment frei verschieben möchten.

Steuern Sie das gleitende Verschieben von Leiterbahnen über die Ziehoptionen in den Voreinstellungen.
Wenn über diese Optionen die Aktion Move zugewiesen ist, kann das Leiterbahnsegment während des Verschiebens gedreht oder gespiegelt werden.
Interaktives Routing und die anwendbaren Designregeln
Beim interaktiven Routing stellt die Software standardmäßig sicher, dass Leiterbahnsegmente gemäß den anwendbaren elektrischen und Routing-Designregeln platziert werden. Das bedeutet, dass die Software die Platzierung eines neuen Leiterbahnsegments nicht zulässt, wenn dadurch eine Regelverletzung gegenüber einem vorhandenen Leiterbahnsegment eines anderen Netzes entstehen würde. Stattdessen kürzt sie das Leiterbahnsegment so, dass die Designregeln eingehalten werden. Dieses Verhalten beim interaktiven Routing wird als Modus Routing Conflict Resolution bezeichnet. Der Standardmodus ist Stop at First Obstacle (der aktuelle Modus wird in der Statusleiste angezeigt). Drücken Sie Shift+R, um die verfügbaren Modi durchzuschalten.
Der Begriff applicable design rules bezeichnet alle Regeln, die für das gerade platzierte Objekt gelten. Die Designregel-Engine basiert auf einem System, in dem Sie genau festlegen, für welche Objekte die einzelnen Regeln gelten sollen. Während der Platzierung wird die Designregel-Engine abgefragt, um die Regel mit der höchsten Priorität zu ermitteln, die in der aktuellen Platzierungssituation gilt. Zu den beim interaktiven Routing geltenden Regeln gehören:
- Elektrischer Abstand
- Routing-Breite
- Routing-Durchkontaktierungsstil
Die folgende Animation zeigt das Routing in Aktion. Das Netz GND wird gemäß einer definierten und anwendbaren Designregel für die Routing-Breite geroutet. Beachten Sie, dass die Leiterbahn automatisch gekürzt wird, wenn der Mauszeiger über die Durchkontaktierung des Netzes +12V bewegt wird. So wird sichergestellt, dass die anwendbare Designregel Elektrische Abstandsvorgabe eingehalten wird.

Die anwendbaren Designregeln für Routing-Breite und Abstand werden beim interaktiven Routing automatisch eingehalten.
So wird die Routing-Breite bestimmt
Sofern die Regelprüfung nicht deaktiviert ist, stellt die Software grundsätzlich sicher, dass die Leiterbahnbreite innerhalb des Bereichs liegt, den die jeweils geltende Designregel für die Leiterbahnbreite (Routing Width) zulässt. Ein gängiger Ansatz besteht darin, für ein Netz einen Bereich zulässiger Breiten festzulegen. So haben Sie beim Verlegen der Leiterbahn mehr Flexibilität und erfüllen gleichzeitig die Anforderungen an die Stromtragfähigkeit dieses Netzes. Hierfür bietet die Designregel Routing Width im PCB Rules and Constraints Editor die Einstellungen Min, Preferred und Max. Diese können so konfiguriert werden, dass sie einen Bereich von Breiten zulassen, oder auf denselben Wert gesetzt werden, um eine bestimmte Breite vorzugeben. Die Breite kann auch über eine Impedanz festgelegt werden. Zudem lässt sich für jede Signallage ein anderer Bereich angeben.

Bei einer neuen Leiterplatte gilt die standardmäßige Designregel Routing Width für alle Netze.
Als Entwickler stehen Ihnen verschiedene Optionen zur Verfügung, mit denen Sie zu Beginn des Routings die am besten geeignete Leiterbahnbreite auswählen können. Diese werden auf der Seite PCB Editor — Interactive Routing des Dialogs Preferences konfiguriert, wie unten gezeigt.

Die Optionen Interactive Routing Width Sources bestimmen, welche Breite beim Beginn einer Leiterbahn verwendet wird.
Beachten Sie, dass Track Width Mode im Bild auf Rule Preferred eingestellt ist. Das bedeutet, dass diese Breite verwendet wird, wenn die Leiterbahn an einem vorhandenen Netzobjekt, beispielsweise einem Pad, beginnt. Beginnt die Leiterbahn jedoch an einer vorhandenen Leiterbahn, hat die Option Pickup Track Width From Existing Routes Vorrang vor Track Width Mode und passt die neue Breite an die vorhandene Breite an.
Während des Routings können Sie außerdem das Tastenkürzel Shift+W verwenden, um einen Dialog aufzurufen, in dem Sie eine andere Breite auswählen können. Alternativ können Sie Tab drücken, um Properties panel zu öffnen und einen neuen Wert für Width einzugeben. Der ausgewählte oder eingegebene Wert muss zwischen den Einstellungen Min und Max der geltenden Regel liegen. Andernfalls wird er automatisch auf den nächstgelegenen dieser Grenzwerte begrenzt.
Tastenkürzel für das interaktive Routing
Während des Routings stehen Ihnen verschiedene Tastenkürzel zur Verfügung. Beispielsweise können Sie mit Shift+R die verfügbaren Konfliktlösungsmodi durchlaufen oder mit Backspace den zuletzt platzierten Eckpunkt löschen. Um während des Routings eine Liste der Tastenkürzel anzuzeigen, drücken Sie Shift+F1. Daraufhin wird ein Menü mit den verfügbaren interaktiven Tastenkürzeln angezeigt. Wählen Sie das gewünschte Tastenkürzel aus oder drücken Sie Esc, um das Menü zu schließen und die entsprechende Tastenkombination zu verwenden.

Drücken Sie während des interaktiven Routings Shift+F1, um ein Menü mit den verfügbaren interaktiven Tastenkürzeln anzuzeigen
Eine Leiterbahn verschieben
Das Untermenü Edit » Move und das Menü mit den Verschiebebefehlen in Active Bar enthalten verschiedene Befehle, mit denen Sie die Position oder Form einer Leiterbahn ändern können.
Neu routen
Mit diesem Befehl können Sie vorhandene Leiterbahnen auf der Leiterplatte manuell neu routen. Nach dem Aufrufen des Befehls nimmt der Cursor die Form eines Fadenkreuzes an und Sie werden aufgefordert, eine Leiterbahn auszuwählen. Positionieren Sie den Cursor über der gewünschten Leiterbahn und klicken Sie oder drücken Sie Enter. Die Funktionsweise hängt davon ab, ob die Option Preserve Angle When Dragging auf der Seite PCB Editor - Interactive Routing des Dialogs Preferences aktiviert ist:
- Preserve Angle Dragging enabled - Die Leiterbahn wird aufgeteilt und ein neues Segment wird hinzugefügt, um die orthogonalen bzw. diagonalen Verbindungen beizubehalten. Bewegen Sie den Cursor, um dieses Segment wie gewünscht zu verschieben, und klicken Sie anschließend, um es zu platzieren. Klicken Sie an dieser Stelle mit der rechten Maustaste oder drücken Sie Esc , da das neue Segment sonst erneut aufgeteilt und ein weiteres Segment hinzugefügt wird. Mit dem Tastenkürzel Shift+R können Sie die Optionen durchlaufen, die festlegen, wie Hindernisse beim Ziehen behandelt werden sollen (Ignore Obstacles, Avoid Obstacles oder Avoid Obstacles (Snap Grid)). Ist einer der Modi zur Hindernisvermeidung aktiviert, werden die Regeln beim Ziehen eingehalten. Dadurch wird verhindert, dass Sie ein Segment in eine Position ziehen, die eine Regelverletzung verursacht.
- Preserve Angle Dragging disabled - Beide Enden des Leiterbahnsegments werden fixiert und Sie können nun neue Leiterbahnsegmente dazwischen verlegen. Klicken Sie oder drücken Sie Enter, um ein neues Leiterbahnsegment zu platzieren. Platzieren Sie weitere Leiterbahnsegmente für die neue Führung oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Vorgang zu beenden.
Routen Sie weitere Leiterbahnen neu oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Befehl zu beenden.
Leiterbahn aufteilen
Mit diesem Befehl können Sie einen Eckpunkt (bzw. eine Unterteilung) in einem Leiterbahnsegment erstellen. Nach dem Aufrufen des Befehls nimmt der Cursor die Form eines Fadenkreuzes an und Sie werden aufgefordert, eine Leiterbahn auszuwählen. Positionieren Sie den Cursor über dem gewünschten Leiterbahnsegment genau an der Stelle, an der Sie die Unterteilung einfügen möchten, und klicken Sie oder drücken Sie Enter. Ein Eckpunkt wird eingefügt, wodurch das ursprüngliche Segment in zwei Segmente aufgeteilt wird.
Verschieben Sie den Eckpunkt an die gewünschte Position und klicken Sie oder drücken Sie Enter , um ihn zu platzieren. Das Verhalten der verbundenen Leiterbahnsegmente richtet sich nach der Einstellung der Option Preserve Angle When Dragging auf der Seite PCB Editor - Interactive Routing des Dialogs Preferences:
- Preserve Angle When Dragging aktiviert - Die Winkel zu benachbarten Leiterbahnsegmenten bleiben erhalten, sodass der Routingstil beibehalten wird.
- Preserve Angle When Dragging deaktiviert - Die beiden einzelnen Leiterbahnsegmente passen sich der Verschiebung nach dem Gummibandprinzip an, ohne den vorhandenen Routingstil beizubehalten.
Teilen Sie weitere Leiterbahnsegmente auf oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Befehl zu beenden.
Leiterbahnende ziehen
Mit diesem Befehl können Sie das Ende eines verlegten Leiterbahnsegments manuell neu positionieren oder ziehen. Nach dem Aufrufen des Befehls nimmt der Cursor die Form eines Fadenkreuzes an und Sie werden aufgefordert, ein Objekt auszuwählen. Positionieren Sie den Cursor über einer Leiterbahn und klicken Sie oder drücken Sie Enter. Der Cursor springt zum nächstgelegenen Ende des Leiterbahnsegments, und das Leiterbahnende wird an den Cursor angehängt. Bewegen Sie das Ende der Leiterbahn an die gewünschte Position und klicken Sie oder drücken Sie Enter, um es zu platzieren.
- Wenn das Ende des gewählten Leiterbahnsegments ein Scheitelpunkt ist, mit dem keine weiteren Leiterbahnsegmente verbunden sind, verschieben Sie den Scheitelpunkt an die gewünschte Position.
- Wenn das Ende des gewählten Leiterbahnsegments ein Scheitelpunkt ist, mit dem zwei Leiterbahnsegmente verbunden sind, werden die angeschlossenen Leiterbahnsegmente beim Verschieben des Scheitelpunkts gummibandartig mitgezogen.
- Wenn das Ende des Leiterbahnsegments mit einem Bauteil-Pad verbunden ist, wird diese Verbindung beim Verschieben des Endes gelöst. Nach der Neupositionierung des Endes wird eine logische Verbindungslinie vom Leiterbahnende zum Pad angezeigt, sofern die Option Smart Track Ends auf der Seite PCB-Editor – Allgemein des Dialogs Preferences aktiviert ist.
- Wenn das Ende des Leiterbahnsegments mit einem freien Pad verbunden ist, wird das Pad an den Cursor angehängt und kann neu positioniert werden. Alle mit dem Pad verbundenen Leiterbahnen werden entsprechend gummibandartig mitgezogen.
- Wenn das Ende des Leiterbahnsegments mit einer Durchkontaktierung verbunden ist, wird die Durchkontaktierung an den Cursor angehängt und kann neu positioniert werden. Alle mit der Durchkontaktierung verbundenen Leiterbahnen werden entsprechend gummibandartig mitgezogen.
Ziehen Sie weitere Leiterbahnenden oder klicken Sie mit der rechten Maustaste oder drücken Sie Esc, um den Vorgang zu beenden.
Leiterbahnen verschieben / Größe ändern
Mit diesem Befehl können Sie die Endpunkte mehrerer ausgewählter Leiterbahnsegmente verschieben und damit deren Länge ändern. Nach dem Aufrufen des Befehls wird der Cursor zu einem Fadenkreuz und Sie werden aufgefordert, einen Leiterbahnendpunkt auszuwählen. So verschieben Sie Leiterbahnen bzw. ändern deren Größe:
- Positionieren Sie den Cursor auf dem Endpunkt eines der ausgewählten Segmente und klicken Sie oder drücken Sie Enter.
- Bewegen Sie den Cursor. Die Größe aller ausgewählten Leiterbahnsegmente wird dynamisch angepasst, wobei die ursprünglichen Abstände und Winkel zueinander erhalten bleiben. Das andere Ende jedes Segments wird gummibandartig angepasst, um seine bestehende Verbindung bzw. Position beizubehalten.
- Sobald sich die Segmente an der gewünschten Position befinden, klicken Sie oder drücken Sie Enter , um sie zu platzieren und den Verschiebemodus zu beenden.
- Um den Vorgang abzubrechen, klicken Sie mit der rechten Maustaste oder drücken Sie Esc.
Während Sie die Segmente verschieben, stehen folgende zusätzliche Steuerungsmöglichkeiten zur Verfügung:
- Drücken Sie die Taste Tab , um den Cursor nacheinander zu den Endpunkten der einzelnen ausgewählten Leiterbahnsegmente zu bewegen.
- Halten Sie beim Verschieben die Taste Alt gedrückt, um die Bewegung auf eine bestimmte Richtung zu beschränken, die von der anfänglichen Bewegungsrichtung abhängt. Möglich sind horizontale und vertikale Richtungen sowie Richtungen im 45-Grad-Winkel.
- Drücken Sie Spacebar zweimal kurz hintereinander, um alle Endpunkte der Leiterbahnsegmente horizontal oder vertikal auf einer Linie auszurichten. Drücken Sie Spacebar erneut zweimal kurz hintereinander, um zur vorherigen Größe zurückzukehren.
Leiterbahnen durchtrennen
Das Werkzeug „Track Slicer“ bietet eine einfache Möglichkeit, ein oder mehrere Leiterbahnsegmente in zwei Teile zu schneiden. Es kann Leiterbahnen auf der aktuellen Signallage oder auf allen sichtbaren Signallagen durchtrennen. Um das Werkzeug aufzurufen, wählen Sie in den Hauptmenüs den Befehl Edit » Slice Tracks.
Nach dem Aufrufen des Befehls wird der Cursor zu einem Fadenkreuz und Sie werden aufgefordert, einen Startpunkt für den Schnitt auszuwählen. Darüber hinaus wird eine Filterung angewendet, sodass im Arbeitsbereich nur Leiterbahnobjekte angezeigt werden. Je nach aktueller Konfiguration des Track Slicer sind dies entweder alle Leiterbahnen auf allen sichtbaren Signallagen oder nur die Leiterbahnen auf der aktuellen Signallage. So durchtrennen Sie eine oder mehrere Leiterbahnen:
- Positionieren Sie den Cursor und klicken Sie oder drücken Sie Enter, um den Startpunkt des Schnitts festzulegen.
- Bewegen Sie den Cursor über die Stelle der Leiterbahn bzw. Leiterbahnen, an der Sie den Schnitt ausführen möchten. Der Schnittverlauf wird durch eine Linie dargestellt, wobei die vorgesehenen Schnitte visuell angezeigt werden.
- Klicken Sie oder drücken Sie Enter, um den Endpunkt des Schnittverlaufs festzulegen.
- Durchtrennen Sie weitere Leiterbahnsegmente oder klicken Sie mit der rechten Maustaste oder drücken Sie Esc, um den Schnittmodus zu beenden.
Nachdem der erste Ankerpunkt für den Schnitt festgelegt wurde und während Sie die „Schnittlinie“ bewegen, stehen folgende zusätzliche Aktionen zur Verfügung:
- Drücken Sie die Taste B, um zwischen dem Durchtrennen von Leiterbahnen nur auf der aktuellen Signallage und dem Durchtrennen von Leiterbahnen auf allen sichtbaren Signallagen umzuschalten.
- Drücken Sie Spacebar, um den Schnittwinkel zwischen 45-Grad-Schritten und einem beliebigen Winkel umzuschalten.
- Drücken Sie die Taste N, um die Klingenseite des Schneidwerkzeugs zwischen Links, Rechts und Mitte umzuschalten.
- Drücken Sie die Taste /, um alle durchtrennten Leiterbahnen auszuwählen.
- Drücken Sie die Taste „,“, um durchtrennte Leiterbahnen links vom Schneidwerkzeug auszuwählen.
- Drücken Sie die Taste „.“, um durchtrennte Leiterbahnen rechts vom Schneidwerkzeug auszuwählen.
- Drücken Sie die Taste M, um keine durchtrennten Leiterbahnen auszuwählen.
-
Drücken Sie die Taste Tab, um den Dialog Slicer Properties aufzurufen, in dem Sie die Eigenschaften des Track Slicer während des Vorgangs ändern können.

Der Dialog Slicer Properties
Leiterbahnen in einen Pfad mit abgeschrägten Ecken umwandeln
Das Abschrägen von 90-Grad-Ecken in Leiterbahnen ist eine Technik zur Verringerung der durch die Ecke verursachten Reflexionen bei Mikrowellenfrequenzen. Es können auch Kreisbögen verwendet werden, deren Radius jedoch mindestens das Dreifache der Leiterbahnbreite betragen sollte. Das Abschrägen (auch als Gehrung bezeichnet) ist eine Alternative, bei der die äußere Spitze der Ecke abgeschnitten wird. Da die Leiterbahnobjekte von Altium Designer abgerundete Enden haben, lassen sich damit keine abgeschrägten Ecken erzeugen. Um eine abgeschrägte Ecke zu erzeugen, werden die ausgewählten Leiterbahnsegmente durch Regionsobjekte ersetzt.
Wählen Sie alle Leiterbahnsegmente aus, die abgeschrägt werden sollen, und wählen Sie anschließend den Befehl Tools » Convert » Convert Selected Tracks to Chamfered Path aus den Hauptmenüs. Das Dialogfeld Convert Tracks to Chamfered Path wird geöffnet. Konfigurieren Sie in diesem Dialogfeld die Abschrägung und klicken Sie anschließend auf OK. Bei jedem ausgewählten Leiterbahnsegmentpaar mit einem entsprechenden 90-Grad-Winkel wird die Ecke durch eine abgeschrägte Ecke ersetzt. Die ursprünglichen Leiterbahnsegmente jedes Paares werden dabei in ein einzelnes gefülltes (Kupfer-)Regionsobjekt umgewandelt.

Ausgewählte Leiterbahnen werden an jeder rechtwinkligen Ecke um den angegebenen Betrag abgeschrägt.
Verwenden Sie die folgenden Optionen im Dialogfeld, um die Abschrägung zu konfigurieren:
- Chamfer - der Anteil der äußeren Ecke, der abgeschnitten bzw. abgeschrägt werden soll, als Prozentsatz des vorhandenen diagonalen Abstands zwischen den Ecken.
- Inside Chamfer - die Materialmenge, die an der inneren Ecke hinzugefügt werden soll, als Prozentsatz des vorhandenen diagonalen Abstands zwischen den Ecken.
How big should the Chamfer be?
Die prozentuale Abschrägung ist der abgeschnittene Anteil der Diagonale zwischen der inneren und der äußeren Ecke der nicht abgeschrägten Biegung.
Die optimale Abschrägung für eine Vielzahl von Mikrostreifengeometrien wurde von Douville und James experimentell ermittelt. Ihren Ergebnissen zufolge lässt sich die optimale prozentuale Abschrägung gut durch folgende Formel annähern:
Unter der Voraussetzung
und mit der Dielektrizitätskonstante des Substrats
.
Diese Formel ist vollständig unabhängig von
. Der tatsächliche Parameterbereich, für den Douville und James Nachweise vorlegen, ist
und
. Sie geben für jede prozentuale Abschrägung, die um höchstens 4 % (des ursprünglichen vom Formelwert abweicht, ein VSWR von unter 1,1 an (d. h. einen Reflexionspegel unter −26 dB). Beim Mindestwert von
von 0,25 beträgt die prozentuale Abschrägung 98,4 %, sodass der Leiterstreifen nahezu vollständig durchtrennt wird.
Leiterbahneigenschaften

Der Modus Track des Panels Properties.
Netzinformationen
Dieser Bereich enthält Informationen über das Netz, zu dem die Leiterbahn gehört, sowie über das differenzielle Paar und/oder xSignal, sofern das Netz diesen angehört. Gegebenenfalls werden auch Klasseninformationen angezeigt. Außerdem werden die Werte für Delay, Length, Max Current und Resistance angegeben.
Weitere Informationen zu Netzinformationen finden Sie auf der Seite Techniken zur PCB-Platzierung & -Bearbeitung.
Position
-
(X/Y)
- X (erstes Feld) – die aktuelle X-Koordinate (horizontal) des Referenzpunkts der Leiterbahn relativ zum aktuellen Ursprung des Designbereichs. Bearbeiten Sie diesen Wert, um die X-Position der Leiterbahn zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden. Geben Sie die Einheit mit an, wenn sie von der aktuell voreingestellten Einheit abweicht.
- Y (zweites Feld) – die aktuelle Y-Koordinate (vertikal) des Referenzpunkts der Leiterbahn relativ zum aktuellen Ursprung. Bearbeiten Sie diesen Wert, um die Y-Position der Leiterbahn zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden. Geben Sie die Einheit mit an, wenn sie von der aktuell voreingestellten Einheit abweicht.
Eigenschaften
- Component – dieses Feld wird im PCB-Editor nur angezeigt, wenn die ausgewählte Leiterbahn Bestandteil eines PCB-Bauteils ist, und zeigt den Bezeichner des übergeordneten PCB-Bauteils an. Klicken Sie auf den Link Component, um den Modus Component des Panels Properties für das übergeordnete Bauteil zu öffnen.
- Net – hier können Sie ein Netz für die Leiterbahn auswählen. In der Dropdown-Liste werden alle Netze des aktiven Leiterplattendesigns aufgeführt. Beachten Sie, dass beim Platzieren eines Objekts an derselben Position wie ein vorhandenes, bereits mit einem Netz verbundenes Objekt die Eigenschaft Net des neuen Objekts automatisch diesem Netz zugewiesen wird. Wählen Sie No Net aus, um festzulegen, dass die Leiterbahn mit keinem Netz verbunden ist. Die Eigenschaft Net eines Primitivs wird vom Design Rule Checker verwendet, um zu ermitteln, ob ein PCB-Objekt regelkonform platziert ist. Alternativ können Sie auf das Symbol Assign Net klicken, um ein Objekt im Designbereich auszuwählen. Das Netz dieses Objekts wird den ausgewählten Leiterbahnen zugewiesen.
- Layer – wählen Sie in der Dropdown-Liste die Lage aus, auf der sich die Leiterbahn befindet.
- Width – zeigt die aktuelle Breite der Leiterbahn an. Bearbeiten Sie dieses Feld, um die Leiterbahnbreite im Bereich von 0,001 mil bis 10000 mil zu ändern.
- Start (X/Y) – zeigt die aktuellen X/Y-Koordinaten des Startpunkts der Leiterbahn relativ zum aktuellen Ursprung an.
- End (X/Y) – zeigt die aktuellen X/Y-Koordinaten des Endpunkts der Leiterbahn relativ zum aktuellen Ursprung an.
-
Length – zeigt die aktuelle Länge der Leiterbahn an. Bearbeiten Sie dieses Feld, um die Leiterbahnlänge im Bereich von 0,001 mil bis 10000 mil zu ändern.
Lotpastenerweiterung
- Rule/Manual – wählen Sie die gewünschte Konfiguration für die Lotpastenerweiterung aus. Wählen Sie Rule, damit die Lotpastenerweiterung der Leiterbahn dem Wert folgt, der in der entsprechenden Designregel Lotpastenerweiterung definiert ist. Wählen Sie Manual, um die entsprechende Designregel zu überschreiben und den Wert der Lotpastenerweiterung für die Leiterbahn festzulegen. Anschließend können Sie die Eingabe aktivieren und das gewünschte Maß eingeben.
Lötstoppmaskenerweiterung
- Rule/Manual – wählen Sie die gewünschte Konfiguration für die Lötstoppmaskenerweiterung aus. Wählen Sie Rule, damit die Lötstoppmaskenerweiterung der Leiterbahn dem Wert folgt, der in der entsprechenden Designregel Lötstoppmaskenerweiterung definiert ist. Wählen Sie Manual, um die entsprechende Designregel zu überschreiben und den Wert der Lötstoppmaskenerweiterung für die Leiterbahn festzulegen. Anschließend können Sie die Eingabe aktivieren und das gewünschte Maß eingeben.
Arbeiten mit Kreisbögen
Ein Kreisbogen ist ein primitives Designobjekt. Im Wesentlichen handelt es sich um ein kreisförmiges Leiterbahnsegment, das auf jeder beliebigen Lage platziert werden kann. Kreisbögen lassen sich im Leiterplattenlayout vielseitig einsetzen. Beispielsweise können sie zum Definieren von Bauteilumrissen auf den Bestückungsdrucklagen oder auf einer mechanischen Lage zur Darstellung der Leiterplattenkontur, der Kanten von Ausschnitten usw. verwendet werden. Sie können auch dazu dienen, beim interaktiven Routing gekrümmte Leiterbahnverläufe zu erzeugen. Kreisbögen können offen sein oder geschlossen einen Kreis bilden (häufig als Vollkreisbogen bezeichnet).

Zwei platzierte Kreisbögen; links ein Vollkreisbogen, rechts ein zur Bearbeitung ausgewählter Kreisbogen.
Kreisbögen können sowohl im PCB-Editor als auch im PCB-Bibliothekseditor platziert werden. Es stehen vier Platzierungsmodi für Kreisbögen zur Verfügung (Mittelpunkt, Kante, beliebiger Winkel und Vollkreis). Wie ein Kreisbogen platziert wird, hängt von der gewählten Platzierungsmethode ab:
-
Place arc by center – mit dieser Methode können Sie ein Kreisbogenobjekt ausgehend vom Mittelpunkt des Kreisbogens platzieren.
Nach dem Aufrufen des Befehls wird der Cursor zu einem Fadenkreuz und Sie wechseln in den Kreisbogen-Platzierungsmodus. Die Platzierung erfolgt in diesen Schritten:
- Klicken Sie oder drücken Sie Enter, um den Mittelpunkt des Kreisbogens festzulegen.
- Bewegen Sie den Cursor, um den Radius des Kreisbogens anzupassen, und klicken Sie dann oder drücken Sie Enter, um ihn festzulegen.
- Bewegen Sie den Cursor, um den Startpunkt des Kreisbogens anzupassen, und klicken Sie dann oder drücken Sie Enter, um ihn festzulegen.
- Bewegen Sie den Cursor, um die Position des Endpunkts des Kreisbogens zu ändern, und klicken Sie dann oder drücken Sie Enter, um ihn festzulegen und die Platzierung des Kreisbogens abzuschließen.
- Platzieren Sie weitere Kreisbögen oder klicken Sie mit der rechten Maustaste oder drücken Sie Esc, um den Platzierungsmodus zu verlassen.
-
Place arc by edge – mit dieser Methode können Sie ein Kreisbogenobjekt ausgehend von der Kante des Kreisbogens platzieren. Der Bogenwinkel ist auf 90° festgelegt.
Nach dem Aufrufen des Befehls wird der Cursor zu einem Fadenkreuz und Sie wechseln in den Kreisbogen-Platzierungsmodus. Die Platzierung erfolgt in diesen Schritten:
- Klicken Sie oder drücken Sie Enter, um den Startpunkt des Kreisbogens festzulegen.
- Bewegen Sie den Cursor, um die Position des Endpunkts des Kreisbogens zu ändern, und klicken Sie dann oder drücken Sie Enter, um ihn festzulegen und die Platzierung des Kreisbogens abzuschließen.
- Platzieren Sie weitere Kreisbögen oder klicken Sie mit der rechten Maustaste oder drücken Sie Esc, um den Platzierungsmodus zu verlassen.
-
Place arc by edge (any angle) – mit dieser Methode können Sie ein Kreisbogenobjekt ausgehend von der Kante des Kreisbogens platzieren. Der Bogenwinkel kann einen beliebigen Wert haben.
Nach dem Aufrufen des Befehls wird der Cursor zu einem Fadenkreuz und Sie wechseln in den Kreisbogen-Platzierungsmodus. Die Platzierung erfolgt in diesen Schritten:
- Klicken Sie oder drücken Sie Enter, um den Startpunkt des Kreisbogens festzulegen.
- Bewegen Sie den Cursor, um den Radius des Kreisbogens anzupassen, und klicken Sie dann oder drücken Sie Enter, um den Mittelpunkt festzulegen.
- Bewegen Sie den Cursor, um die Position des Endpunkts des Kreisbogens zu ändern, und klicken Sie dann oder drücken Sie Enter, um ihn festzulegen und die Platzierung des Kreisbogens abzuschließen.
- Platzieren Sie weitere Kreisbögen oder klicken Sie mit der rechten Maustaste oder drücken Sie Esc, um den Platzierungsmodus zu verlassen.
-
Place full circle arc – mit dieser Methode können Sie einen 360°-Kreisbogen (Vollkreis) platzieren.
Nach dem Aufrufen des Befehls wird der Cursor zu einem Fadenkreuz und Sie wechseln in den Kreisbogen-Platzierungsmodus. Die Platzierung erfolgt in diesen Schritten:
- Klicken Sie oder drücken Sie Enter, um den Mittelpunkt des Kreisbogens festzulegen.
- Bewegen Sie den Cursor, um den Radius des Kreisbogens anzupassen, und klicken Sie dann oder drücken Sie Enter, um ihn festzulegen und die Platzierung des Kreisbogens abzuschließen.
- Platzieren Sie weitere Kreisbögen oder klicken Sie mit der rechten Maustaste oder drücken Sie Esc, um den Platzierungsmodus zu verlassen.
Während der Platzierung können Sie außerdem folgende Aktionen ausführen:
- Drücken Sie bei allen Methoden (außer bei Vollkreisbögen) Spacebar, bevor Sie den Endpunkt des Kreisbogens festlegen, um den Kreisbogen in die entgegengesetzte Richtung zu zeichnen.
- Drücken Sie die Taste L, um den Kreisbogen auf die andere Seite der Leiterplatte zu spiegeln – beachten Sie, dass dies nur möglich ist, bevor Sie den Start- bzw. Mittelpunkt des Kreisbogens festgelegt haben.
- Drücken Sie die Tasten + und - (auf dem Ziffernblock) oder verwenden Sie die Tastenkombinationen Shift+Ctrl+Wheelroll, um alle sichtbaren Lagen im Design vorwärts bzw. rückwärts zu durchlaufen und so die Platzierungslage schnell zu wechseln.
Bei der grafischen Bearbeitung können Sie ein platziertes Kreisbogenobjekt direkt im Designbereich auswählen und seine Größe, Form oder Position grafisch ändern.
Wenn ein Kreisbogenobjekt ausgewählt ist, stehen die folgenden Bearbeitungsgriffe zur Verfügung:

Ein ausgewählter Kreisbogen
- Klicken Sie auf A und ziehen Sie, um den Radius anzupassen.
- Klicken Sie auf B und ziehen Sie, um die Endpunkte (Start- und Endwinkel) anzupassen.
-
Klicken Sie auf eine beliebige Stelle des Kreisbogens außerhalb der Bearbeitungsgriffe und ziehen Sie ihn anschließend an die gewünschte Position. Alternativ können Sie auf den Mittelpunkt des Kreisbogens klicken und ihn ziehen. Während des Ziehens kann der Kreisbogen gedreht oder gespiegelt werden:
- Drücken Sie Spacebar, um den Kreisbogen gegen den Uhrzeigersinn zu drehen, oder Shift+Spacebar, um ihn im Uhrzeigersinn zu drehen. Die Drehung erfolgt entsprechend dem Wert für Rotation Step, der auf der Seite PCB-Editor – Allgemein des Dialogs Preferences festgelegt ist.
- Drücken Sie die Taste X oder Y, um den Kreisbogen an der X- bzw. Y-Achse zu spiegeln.
Kreisbogen-Eigenschaften
Netzinformationen
Dieser Bereich enthält Informationen über das Netz, zu dem der Kreisbogen gehört, sowie über das differenzielle Paar und/oder xSignal, sofern das Netz diesem angehört. Gegebenenfalls werden auch Klasseninformationen angezeigt. Außerdem werden die Werte für Delay, Length, Max Current und Resistance angegeben.
Weitere Informationen zu Netzinformationen finden Sie auf der Seite Techniken zur Platzierung und Bearbeitung von Leiterplatten.
Position
-
(X/Y)
- X (erstes Feld) – dieses Feld zeigt die aktuelle X-Position des Kreisbogenmittelpunkts relativ zum aktuellen Ursprung an. Bearbeiten Sie den Wert im Feld, um die Position des Kreisbogens relativ zum aktuellen Ursprung zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden; geben Sie die Einheit mit an, wenn sie von der aktuellen Standardeinheit abweicht. Die Standardeinheiten (metrisch oder imperial) werden durch die Einstellung Units im Bereich Other des Panels Properties im Modus Board festgelegt (dieser ist zugänglich, wenn im Designbereich keine Objekte ausgewählt sind). Sie werden verwendet, wenn keine Einheit angegeben wird.
- Y (zweites Feld) – dieses Feld zeigt die aktuelle Y-Position des Kreisbogenmittelpunkts relativ zum aktuellen Ursprung an. Bearbeiten Sie den Wert im Feld, um die Position des Kreisbogens relativ zum aktuellen Ursprung zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden; geben Sie die Einheit mit an, wenn sie von der aktuellen Standardeinheit abweicht. Die Standardeinheiten (metrisch oder imperial) werden durch die Einstellung Units im Bereich Other des Panels Properties im Modus Board festgelegt (dieser ist zugänglich, wenn im Designbereich keine Objekte ausgewählt sind). Sie werden verwendet, wenn keine Einheit angegeben wird.
Eigenschaften
- Component – dieses Feld wird im PCB-Editor nur angezeigt, wenn der ausgewählte Kreisbogen Bestandteil eines PCB-Bauteils ist, und zeigt den Bezeichner des übergeordneten PCB-Bauteils an. Klicken Sie auf den Link Component, um den Bauteilmodus des Panels „Eigenschaften“ für das übergeordnete Bauteil zu öffnen.
- Net – hier wählen Sie ein Netz für den Kreisbogen aus. In der Dropdown-Liste werden alle Netze des aktiven Leiterplattendesigns aufgeführt. Beachten Sie: Wenn die Platzierung eines Objekts an derselben Position wie ein vorhandenes, bereits mit einem Netz verbundenes Objekt beginnt, wird die Eigenschaft Net des neuen Objekts automatisch diesem Netz zugewiesen. Wählen Sie No Net aus, um festzulegen, dass der Kreisbogen mit keinem Netz verbunden ist. Die Eigenschaft Net eines Grundelements wird von der Designregelprüfung verwendet, um zu bestimmen, ob ein PCB-Objekt regelkonform platziert ist. Alternativ können Sie auf das Symbol Assign Net klicken, um ein Objekt im Designbereich auszuwählen. Das Netz dieses Objekts wird dann dem ausgewählten Kreisbogen bzw. den ausgewählten Kreisbögen zugewiesen.
- Layer – dieses Feld zeigt die Lage an, der der Kreisbogen aktuell zugewiesen ist. Kreisbögen können jeder verfügbaren Lage zugewiesen werden. Um die zugewiesene Lage zu ändern, klicken Sie auf das Feld und wählen Sie eine Lage aus der Dropdown-Liste aus.
- Width – dieses Feld zeigt die Linienbreite des Kreisbogens an. Geben Sie bei Bedarf einen anderen Wert für die Breite ein.
- Radius – dieses Feld zeigt den Radius des Kreisbogens an, gemessen vom Mittelpunkt bis zur Mitte der Kreisbogenlinie. Geben Sie bei Bedarf einen anderen Wert für den Radius ein.
- Start Angle – dieses Feld zeigt den Startwinkel des Kreisbogens an, gemessen von der X-Achse im ersten Quadranten (ebene Geometrie). Geben Sie bei Bedarf einen anderen Wert für den Startwinkel ein.
- End Angle – dieses Feld zeigt den Endwinkel des Kreisbogens an. Geben Sie bei Bedarf einen anderen Wert für den Endwinkel ein.
- Propagation Delay – dieses Feld zeigt die Zeit an, die ein Signal benötigt, um sich entlang dieser Leitungsführung auszubreiten.
Lotpastenmaskenerweiterung
- Rule – wählen Sie diese Option aus, damit für die Lotpastenmaskenerweiterung des Kreisbogens der in der geltenden Designregel „Lotpastenmaskenerweiterung“ definierte Wert verwendet wird. Der zugehörige Erweiterungswert wird deaktiviert, wenn diese Option ausgewählt ist.
- Manual – wählen Sie diese Option aus, um die geltende Designregel zu überschreiben und den Wert der Lotpastenmaskenerweiterung für den Kreisbogen im Feld darunter anzugeben.
Lötstoppmaskenerweiterung
- Rule – aktivieren Sie das Kontrollkästchen, damit für die Lötstoppmaskenerweiterung des Kreisbogens der in der geltenden Designregel „Lötstoppmaskenerweiterung“ definierte Wert verwendet wird. Der zugehörige Erweiterungswert wird deaktiviert, wenn diese Option ausgewählt ist.
- Manual – aktivieren Sie das Kontrollkästchen, um die geltende Designregel zu überschreiben und den Wert der Lötstoppmaskenerweiterung für den Kreisbogen im Feld darunter anzugeben.
Ausgewählte Objekte mit Leiterbahnen und Kreisbögen umranden
Mit dem Befehl Tools » Outline Selected Objects aus den Hauptmenüs können Sie eine Umrandung aus Leiterbahnen und Kreisbögen um ausgewählte freie Grundelemente im Design platzieren. Diese Funktion kann besonders nützlich sein, wenn Sie kritische Netze elektrisch abschirmen möchten, indem Sie die Umrandung mit Masse verbinden. Nach dem Aufrufen des Befehls werden die Objekte mit Leiterbahnen und/oder Kreisbögen umrandet. Die Leiterbahnen/Kreisbögen der Umrandung werden mit einer Breite von 8 mil platziert, und die Eigenschaft Net wird auf No Net gesetzt.
Die Designregeln für Abstand, Breite und Kurzschluss werden berücksichtigt, sodass Abstandsverletzungen von der Designregelprüfung gemeldet werden.
Arbeiten mit Rechtecken
Ein Rechteck kann auf jeder Lage platziert werden. Rechtecke unterschiedlicher Größe können kombiniert werden, um unregelmäßig geformte Bereiche abzudecken. Sie lassen sich auch mit Leiterbahn- oder Kreisbogensegmenten kombinieren.
Rechtecke können auch auf nicht elektrischen Lagen platziert werden. Platzieren Sie beispielsweise ein Rechteck auf der Keep-Out-Lage, um einen Sperrbereich für das automatische Routing festzulegen. Platzieren Sie ein Rechteck auf einer Versorgungslage, einer Lötstoppmasken- oder Lotpastenmaskenlage, um eine Aussparung auf dieser Lage zu erzeugen.

Ein platziertes Rechteck
Rechtecke können sowohl im PCB-Editor als auch im PCB-Bibliothekseditor auf folgende Weise platziert werden:
- PCB-Editor – die folgenden Zugriffsmöglichkeiten stehen zur Verfügung:
- Wählen Sie Place » Rectangle in den Hauptmenüs.
- Klicken Sie auf die Schaltfläche Rectangle im Dropdown-Menü auf der Active Bar am oberen Rand des Designbereichs. (Klicken Sie auf eine Active Bar-Schaltfläche und halten Sie sie gedrückt, um auf weitere zugehörige Befehle zuzugreifen. Sobald ein Befehl verwendet wurde, wird er zum obersten Eintrag in diesem Abschnitt der Active Bar.)
- Klicken Sie mit der rechten Maustaste in den Designbereich und klicken Sie dann im Kontextmenü auf Place » Rectangle .
-
PCB-Bibliothekseditor – die folgenden Zugriffsmöglichkeiten stehen zur Verfügung:
- Wählen Sie Place » Rectangle in den Hauptmenüs.
- Klicken Sie auf die Schaltfläche Rectangle im Dropdown-Menü auf der Active Bar am oberen Rand des Designbereichs. (Klicken Sie auf eine Active Bar-Schaltfläche und halten Sie sie gedrückt, um auf weitere zugehörige Befehle zuzugreifen. Sobald ein Befehl verwendet wurde, wird er zum obersten Eintrag in diesem Abschnitt der Active Bar.)
- Klicken Sie mit der rechten Maustaste in den Designbereich und wählen Sie dann Place » Rectangle im Kontextmenü.
Nach dem Starten des Befehls wird der Cursor zu einem Fadenkreuz und der Rechteckplatzierungsmodus wird aktiviert. Die Platzierung erfolgt in der folgenden Reihenfolge:
- Klicken Sie oder drücken Sie Enter, um die erste Ecke des Rechtecks zu verankern.
- Bewegen Sie den Cursor, um die Größe des Rechtecks anzupassen, und klicken Sie dann oder drücken Sie Enter, um die diagonal gegenüberliegende Ecke zu verankern und die Platzierung des Rechtecks abzuschließen.
- Platzieren Sie weitere Rechtecke oder klicken Sie mit der rechten Maustaste bzw. drücken Sie Esc, um den Platzierungsmodus zu beenden.
Während der Platzierung können Sie außerdem folgende Aktionen ausführen:
- Drücken Sie die Taste Tab, um die Platzierung anzuhalten und auf den Rechteckmodus des Panels Properties zuzugreifen, in dem Sie die Eigenschaften direkt ändern können. Klicken Sie auf die eingeblendete Pausenschaltfläche im Designbereich , um die Platzierung fortzusetzen.
- Drücken Sie die Leertaste , um zwischen den verschiedenen Eckenmodi zu wechseln. Wählen Sie Rectangle für rechtwinklige Ecken, Fillet für abgerundete Ecken oder Chamfer für abgeschrägte Ecken.
- Drücken Sie die Tasten + und - (auf dem Ziffernblock), um vorwärts und rückwärts durch alle sichtbaren Lagen im Design zu wechseln und so die Platzierungslage schnell zu ändern.
- Halten Sie die Taste Alt gedrückt, um die Bewegungsrichtung je nach anfänglicher Bewegungsrichtung auf die horizontale oder vertikale Achse zu beschränken.
Mit der grafischen Bearbeitung können Sie ein platziertes Rechteckobjekt direkt im Designbereich auswählen und seine Größe, Form oder Position grafisch ändern.
Wenn ein Rechteckobjekt ausgewählt ist, stehen die folgenden Bearbeitungsgriffe zur Verfügung.
Ein ausgewähltes Rechteck
- Klicken Sie auf die Ecken (A) und ziehen Sie daran, um die Größe des Rechtecks gleichzeitig in vertikaler und horizontaler Richtung zu ändern.
- Klicken Sie auf die Mittelpunkte der Seiten (B) und ziehen Sie daran, um die Größe des Rechtecks in vertikaler und horizontaler Richtung getrennt zu ändern.
-
Klicken Sie auf eine beliebige Stelle des Rechtecks außerhalb der Bearbeitungsgriffe und ziehen Sie es, um seine Position zu ändern. Während des Ziehens kann das Rechteck gedreht oder gespiegelt werden:
- Drücken Sie Spacebar, um das Rechteck gegen den Uhrzeigersinn zu drehen, oder Shift+Spacebar, um es im Uhrzeigersinn zu drehen. Die Drehung erfolgt entsprechend dem Wert für Rotation Step, der auf der Seite PCB-Editor – Allgemein des Dialogs Preferences festgelegt ist.
- Drücken Sie die Taste X oder Y, um das Rechteck an der X- bzw. Y-Achse zu spiegeln.
Rechteckeigenschaften

Der Modus Rectangle des Panels Properties.
Position
-
(X/Y)
- X (erstes Feld) – die aktuelle X-Koordinate (horizontal) des Referenzpunkts des Rechtecks relativ zum aktuellen Ursprung des Designbereichs. Bearbeiten Sie diesen Wert, um die X-Position des Rechtecks zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden. Geben Sie die Einheit mit an, wenn sie von der aktuellen Standardeinheit abweicht.
- Y (zweites Feld) – die aktuelle Y-Koordinate (vertikal) des Referenzpunkts des Rechtecks relativ zum aktuellen Ursprung. Bearbeiten Sie diesen Wert, um die Y-Position der Füllfläche zu ändern. Der Wert kann in metrischen oder imperialen Einheiten eingegeben werden. Geben Sie die Einheit mit an, wenn sie von der aktuellen Standardeinheit abweicht.
- Rotation – der Drehwinkel des Rechtecks (in Grad), gegen den Uhrzeigersinn von null (der 3 o'clock Horizontalen) aus gemessen. Bearbeiten Sie diesen Wert, um die Drehung des Rechtecks zu ändern. Die minimale Winkelauflösung beträgt 0,001°.
Eigenschaften
-
Corner Mode – wählen Sie im Dropdown-Menü den gewünschten Eckenmodus des Rechtecks aus den folgenden Optionen:
- Rectangle – legt fest, dass das platzierte Rechteck rechtwinklige Ecken hat.
- Fillet – legt fest, dass das platzierte Rechteck abgerundete Ecken hat.
- Chamfer – legt fest, dass das platzierte Rechteck abgeschrägte Ecken hat.
- Track Width – zeigt die aktuelle Leiterbahnbreite an. Bearbeiten Sie dieses Feld, um die Leiterbahnbreite im Bereich von 0,001 mil bis 10000 mil zu ändern.
- Fillet/Chamfer Size – diese Option ist nur verfügbar, wenn Fillet oder Chamfer im Dropdown-Menü Corner Mode ausgewählt ist oder wenn während der Platzierung der Abrundungs- oder Fasenmodus gewählt wurde.
- Layer – die Lage, der das Rechteck aktuell zugewiesen ist. Rechtecke können jeder verfügbaren Lage zugewiesen werden. Wählen Sie im Dropdown-Menü eine andere Lage aus.
- Width – zeigt die Breite (X-Achse) des ausgewählten Rechtecks an.
- Height – zeigt die Höhe (Y-Achse) des ausgewählten Rechtecks an.
-
– Klicken Sie auf dieses Symbol, um das bestehende Seitenverhältnis (X zu Y) des Rechtecks beizubehalten.

