Das Layout Ihrer PCB
Altium Essentials: PCB Introduction
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Auf einen Blick
- So richten Sie den PCB-Editor und das PCB-Dokument ein, einschließlich Voreinstellungen, Rastern und Maßeinheiten.
- So definieren und bearbeiten Sie die Leiterplattenkontur, legen den Ursprung fest und verwalten die Ebenenanzeige während der Arbeit im PCB-Editor.
- So organisiert Altium Designer Fertigungs- und nicht elektrische Ebenen, und hier konfigurieren Sie den Lagenaufbau und die Via-Typen.
In jedem Elektronikprodukt steckt eine Leiterplatte, auch PCB genannt. Heute sind die Bauteile so klein geworden, dass ihre Abmessungen in Bruchteilen eines Millimeters statt in Zentimetern angegeben werden. Gleichzeitig haben sich die Leiterbahnbreiten von 10 mil breiten Linien mit großzügigen Abständen zu dünnen, haarfeinen Linien von 2 oder 3 mil verringert, die dicht nebeneinander liegen. Mit steigenden Signalgeschwindigkeiten haben sich auch die Verbindungen auf der Leiterplatte verändert: Statt als einfache Kupferleiter elektrische Energie zu transportieren, verhalten sie sich wie Hochgeschwindigkeits-Übertragungsleitungen. Dies erfordert entsprechende Designtechniken. Auch die mechanischen Anforderungen sind komplexer geworden. Kompakte, ungewöhnlich geformte moderne Elektronikprodukte benötigen kompakte, ungewöhnlich geformte Leiterplatten, die häufig als Starrflex-Strukturen ausgeführt werden. Diese Leiterplatten können gebogene Kanten und Ausschnitte aufweisen, was eine sorgfältige Positionierung der Bauteile erfordert.
Diese Herausforderungen lassen sich mit den Technologien von Altium für das Leiterplattendesign meistern. Mit dem PCB-Editor von Altium Designer können Sie Ihre Leiterplattendesigns erstellen, bearbeiten und überprüfen.
Einrichten des PCB-Editors
Die Kategorie PCB Editor im Dialog Preferences (den Sie durch Klicken auf das Symbol
oben rechts im Designbereich öffnen) bietet Zugriff auf Einstellungsseiten, die das Verhalten des PCB-Editors beeinflussen. Sie können jederzeit auf diese Einstellungen zugreifen und sie nach Bedarf anpassen.

Verwenden Sie die Kategorie PCB Editor in den Preferences von Altium Designer, um den PCB-Editor einzurichten.
Weitere Informationen zu den PCB-Einstellungen: Einstellungen des PCB-Editors.
Einrichten eines PCB-Dokuments
Um mit dem Layout Ihrer Leiterplatte zu beginnen, fügen Sie dem PCB-Projekt ein neues PCB-Dokument hinzu. Klicken Sie dazu im Panel Projects mit der rechten Maustaste auf den Projekteintrag und wählen Sie im Kontextmenü den Befehl Add New to Project » PCB . Das Standard-PCB-Dokument wird im Designbereich angezeigt.

Ein neu erstelltes PCB-Dokument ist das aktive Dokument im Designbereich.
Die Optionen für ein PCB-Dokument werden im Panel Properties konfiguriert, wenn im Designbereich kein Objekt ausgewählt ist. Die wichtigsten Optionen werden auf der Registerkarte General des Panels konfiguriert:
-
Rastereinstellungen (Bereich Grid Manager) – konfigurieren Sie die Optionen des globalen Standardrasters oder fügen Sie bei Bedarf zusätzliche Raster (kartesische und polare) hinzu. Raster gewährleisten das präzise Verschieben und Platzieren von Objekten.
- Einheiten (Bereich Other) – wählen Sie die bevorzugten Maßeinheiten (mm oder mils) für das Dokument aus.

Konfigurieren Sie die Optionen des PCB-Dokuments im Panel Properties.
Weitere Informationen zur Konfiguration eines PCB-Dokuments: Einrichten der PCB-Umgebung.
Definieren der Leiterplattenkontur und des Ursprungs
Die Leiterplattenkontur definiert die äußeren Abmessungen der Leiterplatte. Standardmäßig ist die Leiterplatte ein Rechteck mit 6000 x 4000 mil (152,4 x 101,6 mm). Der PCB-Editor bietet verschiedene Werkzeuge, um die Leiterplattenkontur nach Bedarf zu definieren.
Sie können eine neue Leiterplattenkontur mit den folgenden Schritten interaktiv definieren:
-
Wechseln Sie in den Leiterplattenplanungsmodus des Editors, indem Sie in den Hauptmenüs den Befehl View » Board Planning Mode auswählen.
-
Wählen Sie in den Hauptmenüs den Befehl Design » Redefine Board Shape aus.
-
Positionieren Sie den Cursor und klicken Sie, um den ersten Eckpunkt der Leiterplattenkontur festzulegen.
-
Bewegen Sie den Cursor zur Position des zweiten Eckpunkts und klicken Sie, um ihn zu platzieren.
-
Bewegen Sie die Maus weiter und klicken Sie, um weitere Eckpunkte zu platzieren.
-
Klicken Sie nach dem Platzieren des letzten Eckpunkts mit der rechten Maustaste, um die Definition der Leiterplattenkontur abzuschließen. Sie müssen die Leiterplattenkontur nicht manuell schließen, da der PCB-Editor die Kontur automatisch vervollständigt, indem er den Startpunkt mit dem zuletzt platzierten Punkt verbindet.
Sie können die bestehende Kontur auch bearbeiten, statt sie neu zu definieren. Gehen Sie dazu wie folgt vor:
- Wechseln Sie in den Leiterplattenplanungsmodus des Editors, indem Sie in den Hauptmenüs den Befehl View » Board Planning Mode auswählen.
- Wählen Sie in den Hauptmenüs den Befehl Design » Edit Board Shape aus.
-
Klicken Sie auf eine Kante oder einen Eckpunkt der Leiterplattenkontur, halten Sie die Maustaste gedrückt und ziehen Sie das Element, um es zu verschieben.
- Beenden Sie den Bearbeitungsmodus, indem Sie an einer beliebigen Stelle im Designbereich klicken (auf die Leiterplattenkontur oder außerhalb davon).
Verwenden Sie den Befehl View » 2D Layout Mode aus den Hauptmenüs, um in den 2D-Layoutmodus des Editors zurückzukehren.
Weitere Informationen zu den verfügbaren Verfahren zur Definition der Leiterplattenkontur: Definieren der Leiterplattenkontur.
Konfigurieren der Lagenanzeige
Neben den Lagen, die zur Fertigung der Leiterplatte verwendet werden – darunter Signal-, Versorgungsebenen-, Masken- und Bestückungsdrucklagen – unterstützt der PCB-Editor auch zahlreiche weitere nicht elektrische Lagen. Die Lagen werden häufig wie folgt gruppiert:
-
Electrical Layers – umfasst 128 Signallagen und 16 interne Versorgungsebenen.
-
Component Layers – Lagen, die beim Entwurf von Bauteilen verwendet werden, darunter Overlay- (Bestückungsdruck), Lötstoppmasken- und Lotpastenlagen. Wenn im Bibliothekseditor ein Objekt in einem Bauteil-Footprint auf einer dieser Lagen platziert wird und das Bauteil anschließend von der Oberseite auf die Unterseite der Leiterplatte gedreht wird, werden alle Objekte auf einer Bauteillage auf die jeweils zugehörige Partnerlage gespiegelt. Dies gilt auch für Objekte auf benutzerdefinierten Bauteillagenpaaren (gepaarten mechanischen Lagen).
-
Mechanical Layers – die Software unterstützt eine unbegrenzte Anzahl universell nutzbarer mechanischer Lagen für Designaufgaben wie Bemaßungen, Fertigungsdetails, Bestückungsanweisungen usw. Diese Lagen können bei Bedarf gezielt in die Druck- und Gerber-Ausgabe einbezogen werden. Mechanische Lagen können auch paarweise zugeordnet werden; in diesem Fall verhalten sie sich wie Bauteillagen. Gepaarte Bauteillagen werden beispielsweise für die Platzierung von 3D-Körpern, Klebepunkten und die selektive Vergoldung von Leiterplatten-Randsteckverbindern verwendet.
-
Other Layers – dazu gehören die Keep-Out-Lage (zur Definition von Sperrflächen, die für alle Kupferlagen gelten), die Multi-Layer-Lage (für Objekte, die auf allen Signallagen vorhanden sind, etwa Pads und Vias), die Bohrzeichnungslage (zur Platzierung von Bohrinformationen, etwa einer Bohrtabelle) und die Bohrführungslage (zur Anzeige von Markierungen, die Bohrpositionen und -größen kennzeichnen).
Die Kupferlagen werden im Layer Stack Manager zum Design hinzugefügt bzw. daraus entfernt. Dieser wird im nächsten Abschnitt erläutert. Alle anderen Lagen werden im Panel View Configuration aktiviert und konfiguriert.

Die beiden Registerkarten des Panels View Configuration
Neben dem Anzeigestatus und den Farbeinstellungen der Lagen bietet das Panel View Configuration auch Zugriff auf weitere Anzeigeeinstellungen, darunter:
-
Farbe und Sichtbarkeit von System Colors, beispielsweise die Auswahlfarbe oder die Sichtbarkeit von Verbindungslinien.
-
Die Darstellungsweise jedes Objekttyps (ausgefüllt oder als Umriss) und seine Transparenz (Abschnitt Object Visibility).
-
Verschiedene Ansichtsoptionen, etwa ob Origin Marker, die Namen von Pad Net und Pad Numbers angezeigt werden sollen (Abschnitt Additional Options).
-
Die Stärke der Abblendung der Anzeige, wenn Objekte abgeblendet oder maskiert werden (Abschnitt Mask and Dim Settings).
-
Die Erstellung von Lagensätzen, mit denen sich über das Bedienelement
schnell umschalten lässt, welche Lagen aktuell sichtbar sind (Abschnitt Layers).
-
Die Erstellung und Auswahl von Ansichtskonfigurationen, mit denen sich alle Lageneigenschaften wie Farbe, Sichtbarkeit, Objekttransparenz usw. vorkonfigurieren lassen (Abschnitt General Settings).
Einige Hinweise zu Lagen:
-
Die aktuell aktivierten Lagen werden als Reihe von Registerkarten am unteren Rand des PCB-Designbereichs angezeigt, wie in der folgenden Abbildung dargestellt. Klicken Sie mit der rechten Maustaste auf eine Registerkarte, um auf häufig verwendete Befehle zur Lagenanzeige zuzugreifen.
-
Beim Platzieren von Objekten auf einer Leiterplatte sollten Sie berücksichtigen, auf welcher Lage sie platziert werden. Objekte werden auf der aktuellen Lage platziert, deren Registerkarte am unteren Rand des Designbereichs als aktiv angezeigt wird. In der obigen Abbildung ist Top Layer die aktive Lage.
-
So wechseln Sie die aktive Lage:
-
Klicken Sie auf die Lagenregisterkarte am unteren Rand des Designbereichs, oder
-
drücken Sie die Zifferntaste + oder -, um alle Lagen nacheinander zu durchlaufen, oder
-
drücken Sie die Zifferntaste *, um die Signallagen nacheinander zu durchlaufen, oder
-
verwenden Sie die Tastenkombinationen Ctrl+Shift+Mouse Wheel.
-
-
Bei einem komplexen Design kann es hilfreich sein, nur die Lage anzuzeigen, an der gerade gearbeitet wird; dies wird als Single Layer Mode bezeichnet. Um den Einzellagenmodus ein- oder auszuschalten, drücken Sie die Tastenkombination Shift+S. Die Available Single Layer Modes werden auf der Seite PCB Editor – Board Insight Display des Dialogs Preferences konfiguriert. Mit jedem Drücken von Shift+S wechseln Sie zum nächsten aktivierten Einzellagenmodus.
Weitere Informationen zur Konfiguration der PCB-Ansicht: Ihre Ansicht der Leiterplatte.
Den Lagenaufbau definieren
Die Leiterplatte wird als Stapel von Lagen entworfen und aufgebaut, der im Layer Stack Manager (Design » Layer Stack Manager) definiert wird. Der Layer Stack Manager wird in einem Dokumenteditor geöffnet, genauso wie ein Schaltplanblatt, die Leiterplatte und andere Dokumenttypen. Die Funktionen sind auf die Registerkarten am unteren Rand des Layer Stack Manager verteilt. Die wichtigsten Konfigurationsschritte werden auf den Registerkarten Stackup und Via Types durchgeführt.
Die Registerkarte Stackup enthält die Details zu den Fertigungslagen. Auf dieser Registerkarte werden Lagen hinzugefügt, entfernt und konfiguriert.
|
Um eine Lage hinzuzufügen, wählen Sie im Tabellenbereich eine Lage aus, oberhalb oder unterhalb derer eine neue Lage eingefügt werden soll. Klicken Sie oben im Layer Stack Manager auf die Schaltfläche Add und verwenden Sie das angezeigte Pop-up. Um eine Lage zu löschen, wählen Sie sie im Tabellenbereich aus und klicken Sie auf die Schaltfläche Delete. Um ein Lagenmaterial aus der Materialbibliothek auszuwählen, wählen Sie die gewünschte Lage im Tabellenbereich aus und klicken Sie auf die Schaltfläche Modify. Die für das ausgewählte Material definierten Eigenschaften werden auf die Lage angewendet. Die Eigenschaften der aktuell ausgewählten Lage können auch direkt im Tabellenbereich oder im Panel Properties bearbeitet werden. |
Auf der Registerkarte Via Types werden die zulässigen Lagenspannen in Z-Richtung für die im Design verwendeten Vias definiert.
|
Der standardmäßige Typ für durchgehende Vias ist in einem PCB-Design immer vorhanden. Um einen weiteren Via-Typ (Blind Via, Buried Via oder Microvia) hinzuzufügen, klicken Sie oben im Layer Stack Manager auf die Schaltfläche Add. Wählen Sie anschließend bei ausgewähltem Via-Typ im Tabellenbereich in den Dropdown-Listen First layer und Last layer des Panels Properties die Lagen aus, die dieser Via-Typ verbindet. Um einen hinzugefügten Via-Typ zu löschen, wählen Sie ihn im Tabellenbereich aus und klicken Sie auf die Schaltfläche Delete. |
Verwenden Sie den Befehl File » Save to PCB im Layer Stack Manager, um die Änderungen auf die Leiterplatte zu übertragen.
Weitere Informationen zum Layer Stack Manager: Den Lagenaufbau definieren, Definition von Blind Vias, Buried Vias & Microvias.
Designregeln konfigurieren
Designregeln überwachen und prüfen Ihr Design auf verschiedene Designanforderungen, beispielsweise Abstände zwischen Kupferobjekten, Leiterbahnbreiten, Netzlängen usw. Zusammen bilden die Designregeln einen Satz von Anweisungen, den der PCB-Editor befolgt.
Designregeln werden im Dialog PCB Rules and Constraints Editor definiert und verwaltet. Sie öffnen ihn, indem Sie in den Hauptmenüs den Befehl Design » Rules wählen.
Der PCB Rules and Constraints Editor Dialog besteht aus zwei Bereichen:
- Auf der linken Seite des Dialogs wird eine Baumstruktur angezeigt, die die verfügbaren Regelkategorien, die Regeltypen jeder Kategorie und die aktuell definierten einzelnen Regeln jedes Typs auflistet.
- Auf der rechten Seite des Dialogs werden Informationen zum aktuell in der Baumstruktur ausgewählten Eintrag angezeigt. Wählen Sie beispielsweise eine einzelne Regel aus, um deren Einstellungen anzuzeigen.
Designregeln verfügen über drei Einstellungsgruppen, die im Folgenden beschrieben und in den anschließenden Abbildungen gezeigt werden:
- Hauptattribute der Regel – hier können Sie der Regel einen aussagekräftigen Namen geben und einen optionalen Kommentar hinzufügen.
- Geltungsbereich der Regel – legt fest, für welche Objekte innerhalb eines Designs die Regel gilt. Je nach Regeltyp müssen ein Geltungsbereich (bei einer unären Regel, die das erforderliche Verhalten eines Objekts definiert) oder zwei Geltungsbereiche (bei einer binären Regel, die die Wechselwirkung zwischen zwei Objekten definiert) festgelegt werden.
- Regelvorgaben – spezifische Vorgaben für die Regel.
|
Regeln des Typs Width sind unäre Regeln. Für eine unäre Regel muss ein einzelner Geltungsbereich (Where the Object Matches) definiert werden. Regeln des Typs Clearance sind binäre Regeln. Für eine binäre Regel müssen zwei Geltungsbereiche (Where the First Object Matches und Where the Second Object Matches) definiert werden. |
Um eine neue Regel zu erstellen, klicken Sie in der Baumstruktur des Dialogs mit der rechten Maustaste auf den gewünschten Regeltyp und wählen Sie im Kontextmenü den Befehl New Rule. Die neue Regel wird in der Baumstruktur unter der ausgewählten Kategorie hinzugefügt. Wählen Sie den Eintrag der Regel in der Baumstruktur aus, um sie zu bearbeiten.
Wenn mehrere Regeln desselben Typs für dieselben Objekte gelten, stellt der PCB-Editor anhand der Regelpriorität sicher, dass die zutreffende Regel mit der höchsten Priorität angewendet wird. Klicken Sie unten im PCB Rules and Constraints Editor Dialog auf die Schaltfläche Priorities , um den Dialog Edit Rule Priorities zu öffnen und die Prioritäten nach Bedarf zu ändern. 1 ist die höchste Priorität. Wenn eine neue Regel hinzugefügt wird (mit dem Befehl New Rule), erhält sie die höchste Priorität.
Weitere Informationen zum Arbeiten mit PCB-Designregeln und bestimmten Regeltypen finden Sie hier: PCB-Designregeln definieren, ihren Geltungsbereich festlegen und sie verwalten, PCB-Designregeltypen.
Bauteile platzieren
Wenn die Designdaten aus den Schaltplänen des PCB-Projekts in das PCB-Dokument übertragen werden (über den Befehl Design » Update PCB Document in den Hauptmenüs des Schaltplaneditors und den anschließenden ECO-Ausführungsprozess), werden die Standard-Footprints der in den Schaltplänen verwendeten Bauteile an beliebigen Positionen im PCB-Dokument platziert. Die Bauteilpads werden entsprechend den in den Schaltplänen definierten Netzen (verbundenen Bauteilpins) durch Verbindungslinien verbunden.

Eine Leiterplatte nach der Aktualisierung anhand der Schaltpläne.
Die grundlegenden Verfahren zum Festlegen der Position eines Bauteils auf einer Leiterplatte sind:
- Um ein Bauteil an die gewünschte Position zu verschieben, Click, Hold&Drag lassen Sie anschließend die Maustaste los, um es zu platzieren.
- Um ein Bauteil zu drehen, drücken Sie Spacebar während Sie es ziehen.
- Um ein Bauteil auf die andere Seite der Leiterplatte zu spiegeln, drücken Sie L, während Sie es ziehen.
Die Verbindungslinien werden beim Verschieben eines Bauteils automatisch neu optimiert. Nutzen Sie diese Linien als Orientierungshilfe, um die Bauteile so auszurichten und zu positionieren, dass möglichst wenige Verbindungslinien einander kreuzen.
Weitere Informationen zu Verbindungen auf einer Leiterplatte und zur Platzierung von Bauteilen finden Sie hier: Verbindungen auf Ihrer Leiterplatte verstehen, Bauteilplatzierung.
Leiterplatte routen
Beim Routing werden Leiterbahnen, Bögen und Durchkontaktierungen auf der Leiterplatte verlegt, um die Bauteilpads miteinander zu verbinden. Der PCB-Editor bietet Werkzeuge, darunter interaktive Routing-Werkzeuge, die Sie beim Routen der Verbindungen auf Ihrer Leiterplatte unterstützen.
Da die Routing-Werkzeuge regelgesteuert arbeiten, müssen die Designregeln unbedingt vor Beginn des Routings konfiguriert werden. Die wichtigsten Designregeln beim interaktiven Routing sind:
- Die Regel Clearance (Kategorie Electrical) – definiert, wie nahe die Leiterbahnen des gerade gerouteten Netzes anderen Objekten auf der Leiterplatte kommen dürfen.
- Die Regel Width (Kategorie Routing) – definiert die Breite der Leiterbahnen für das gerade geroutete Netz.
- Die Regel Routing Via Style (Kategorie Routing) – definiert den Durchmesser und die Bohrungsgröße der Durchkontaktierungen, die beim Lagenwechsel während des Routings platziert werden.
Es empfiehlt sich außerdem, ein für das Routing geeignetes Fangraster einzustellen.
Zum Routen einer einzelnen Verbindung wird das Werkzeug Interactive Routing verwendet. Gehen Sie wie folgt vor:
-
Wählen Sie in den Hauptmenüs den Befehl Route » Interactive Routing aus.
-
Klicken Sie auf das Bauteilpad, an dem Sie mit dem Routing beginnen möchten.
-
Positionieren Sie den Cursor und klicken Sie dann in den Designbereich, um die Leiterbahnen bis zum Cursor zu platzieren. Setzen Sie die Festlegung des Leiterbahnverlaufs fort.
-
Klicken Sie auf das Zielpad, um das Routing der Verbindung abzuschließen. Die Verbindung wird automatisch freigegeben, und Sie bleiben im interaktiven Routing-Modus, bereit zum Routen der nächsten Verbindung.
-
Klicken Sie mit der rechten Maustaste, um den interaktiven Routing-Modus zu verlassen.
Hinweise zum interaktiven Routing:
-
Wenn Sie den Cursor beim interaktiven Routing in die Nähe eines Pads bewegen, rastet er automatisch in dessen Mitte ein. Dafür sorgt die Objekt-Hotspot-Funktion, die den Cursor zum Hotspot des nächstgelegenen elektrischen Objekts zieht.
Erfahren Sie mehr über das Arbeiten mit dem Cursor-Einrastsystem.
-
Beim interaktiven Routing können Sie die folgenden Tastenkürzel verwenden:
-
Tab, um das Routing anzuhalten und das Panel Properties zu öffnen, in dem Sie die Optionen für das interaktive Routing konfigurieren können. Klicken Sie anschließend auf die Schaltfläche
im Designbereich, um zum interaktiven Routing-Modus zurückzukehren.
-
Shift+Spacebar, um zwischen den Eckstilen zu wechseln: Leiterbahn 45°, Linie 45°/90° mit Bogen, beliebiger Winkel usw.
-
Spacebar , um die Eckrichtung umzuschalten.
-
Shift+R , um zwischen den verfügbaren Modi zur Auflösung von Routing-Konflikten zu wechseln: Hindernisse umgehen, Hindernisse verschieben, Hindernisse ignorieren usw.
-
Ctrl+Shift+Wheel Scroll, um zur nächsten verfügbaren Signallage zu wechseln und eine Durchkontaktierung einzufügen.
-
Shift+F1, um die Liste der Tastenkürzel für das interaktive Routing anzuzeigen.
-
-
Beim Routing werden Leiterbahnsegmente auf unterschiedliche Weise dargestellt (wie in den folgenden Abbildungen gezeigt):
-
Solid – das Segment wurde platziert.
-
Hatched – schraffierte Segmente sind vorgeschlagen, aber noch nicht bestätigt; sie werden platziert, sobald Sie klicken.
-
Hollow – dies wird als Vorschausegment bezeichnet. Es hilft Ihnen dabei, festzulegen, wo das letzte vorgeschlagene Segment enden soll. Dieses Segment wird beim Klicken not platziert, es sei denn, der nächste Klick schließt die Verbindung ab. In diesem Fall greift die Option Automatically Terminate Routing und setzt das standardmäßige Vorschauverhalten außer Kraft. Der Vorschaumodus lässt sich während des Routings mit dem Tastenkürzel
1ein- und ausschalten.

Ausgefüllte Segmente sind platziert, schraffierte Segmente sind vorgeschlagen, aber noch nicht bestätigt, und das unausgefüllte Segment ist das Vorschausegment. -
-
Eine besonders hilfreiche Funktion zur Visualisierung des verfügbaren Routing-Platzes ist die Anzeige von Abstandsgrenzen um alle Objekte anderer Netze Mit dem Tastenkürzel
Ctrl+Wkönnen Sie die Abstandsgrenzen ein- und ausschalten. Wenn die Funktion aktiviert ist und ein Netz geroutet wird, wird um alle Objekte anderer Netze eine Abstandsgrenze angezeigt, die durch die jeweils geltende elektrische Abstandsregel definiert ist. Diese Grenze kann beim Routing nicht überschritten werden. -
Während des Routings stehen Ihnen im Heads-up-Display und in der Statusleiste zahlreiche nützliche Informationen zur Verfügung, darunter der Netzname und die aktuell eingestellte Breite
-
Statt die Verbindung bis zum Zielpad manuell zu routen, können Sie auch
Ctrl+Clickdrücken, um die Funktion Auto-Complete zu verwenden und die Routing-Engine anzuweisen, die gesamte Verbindung automatisch zu routen. Die automatische Vervollständigung verhält sich wie folgt:-
Sie wählt den kürzesten Weg. Dieser ist jedoch nicht unbedingt der beste, da Sie stets auch die Wege für andere, noch nicht geroutete Verbindungen berücksichtigen müssen. Im Modus zum Verschieben von Hindernissen kann die automatische Vervollständigung vorhandene Leiterbahnen verschieben, um das Ziel zu erreichen.
-
Bei längeren Verbindungen ist die automatische Vervollständigung möglicherweise nicht immer verfügbar, da der Routing-Pfad abschnittsweise ermittelt wird und unter Umständen kein vollständiger Pfad zwischen Ausgangs- und Zielpad gefunden werden kann.
-
Sie können die automatische Vervollständigung (
Ctrl+Click) auch direkt auf einem Pad oder einer Verbindungslinie ausführen.
-
Es gibt nicht nur eine einzige Lösung für das Routing einer Leiterplatte. Daher werden Sie das Routing zwangsläufig an manchen Stellen ändern wollen. Der PCB-Editor bietet dafür verschiedene Funktionen und Werkzeuge. Es gibt zwei Ansätze: neu routen oder umordnen.
-
Reroute – wählen Sie den Befehl Route » Interactive Routing und beginnen Sie an einer beliebigen Stelle einer vorhandenen Leiterbahn mit dem Routing, um den Verbindungsweg neu festzulegen. Die Funktion zur Schleifenentfernung entfernt automatisch alle überflüssigen Leiterbahnsegmente und Durchkontaktierungen, sobald Sie die Schleife schließen und mit einem Rechtsklick signalisieren, dass Sie fertig sind.
-
Rearrange –
Click, Hold&Drag, um Leiterbahnsegmente interaktiv über die Leiterplatte zu verschieben oder zu ziehen.
Erfahren Sie mehr über das Routing der Leiterplatte: Routing der Leiterplatte.
Polygone platzieren
Um eine Signallage der Leiterplatte mit einer großen Kupferfläche zu bedecken, können Sie eine Polygonfüllung verwenden. Eine Polygonfüllung wird automatisch um vorhandene Objekte herum ausgefüllt und verbindet sich nur mit Objekten, die zum selben Netz wie die Polygonfüllung gehören. Abstände und Verbindungseigenschaften werden durch die jeweils geltenden Designregeln für Abstände und den Polygon-Anbindungsstil gesteuert.
So platzieren Sie eine Polygonfüllung:
- Wählen Sie den Befehl Place » Polygon Pour in den Hauptmenüs.
-
Während der Platzierung können Sie die Taste Tab drücken, um das Panel Properties zu öffnen und die Eigenschaften des zu platzierenden Polygons zu konfigurieren: Netz, Lage, Füllmodus usw. Klicken Sie anschließend auf die Schaltfläche
im Designbereich, um zum Platzierungsmodus zurückzukehren.
- Positionieren Sie den Cursor und klicken Sie, um den ersten Eckpunkt der Polygonfüllung zu setzen.
-
Bewegen Sie den Cursor an die Position des zweiten Eckpunkts und klicken Sie, um diesen zu platzieren.
- Bewegen Sie die Maus weiter und klicken Sie, um weitere Eckpunkte zu platzieren.
- Klicken Sie nach dem Platzieren des letzten Eckpunkts mit der rechten Maustaste, um die Polygonfüllung zu schließen und die Platzierung abzuschließen. Sie müssen die Polygonform nicht manuell schließen, da der PCB-Editor die Form automatisch vervollständigt, indem er den Startpunkt mit dem zuletzt platzierten Punkt verbindet.
- Platzieren Sie weitere Polygonfüllungen oder klicken Sie mit der rechten Maustaste, um den Platzierungsmodus zu verlassen.
Wenn eine Polygonfüllung geändert wird, beispielsweise ihre Form oder ihre Eigenschaften, muss sie erneut ausgefüllt werden, damit die Änderungen wirksam werden. Wählen Sie dazu das Polygon aus und klicken Sie oben im Panel Properties auf die Schaltfläche Repour.
Erfahren Sie mehr über Polygonfüllungen: Polygone auf Signallagen.
Eine Designregelprüfung durchführen
Der PCB-Editor bietet Funktionen zur Designregelprüfung (DRC), mit denen Sie überprüfen können, ob Ihr Design den aktivierten Designregeln entspricht.
Die Designregelprüfung wird im Dialog Design Rule Checker konfiguriert, den Sie über den Befehl Tools » Design Rule Check in den Hauptmenüs öffnen.
-
Klicken Sie im Baum auf der linken Seite des Dialogs auf den Eintrag Report Options, um zusätzliche Optionen für die Batch-DRC zu konfigurieren.
-
Klicken Sie auf den Eintrag Rules to Check oder auf einen Eintrag für eine bestimmte Regelkategorie, um im Dialog eine Liste der Regeltypen anzuzeigen und die einzelnen Regeltypen nach Bedarf für die Online- und/oder Batch-DRC zu aktivieren:
-
Online-DRC – die Prüfung erfolgt in Echtzeit während der Designarbeit.
-
Batch-DRC – die Prüfung wird als Stapelverarbeitung ausgeführt, indem Sie im Dialog auf die Schaltfläche Run Design Rule Check klicken. Die Ergebnisse werden im Panel Messages und optional in einem generierten Bericht aufgeführt.
-
Bei der Ausführung einer Online- oder Batch-DRC werden erkannte Regelverstöße im Designbereich angezeigt (mithilfe der spezifischen Verstoßgrafiken und/oder der Verstoßüberlagerung). Nachfolgend sehen Sie einige Beispiele für Verstöße im Designbereich:

Leiterbahnen, die gegen eine Breitenregel verstoßen. Der Verstoß wird sowohl durch spezifische Verstoßgrafiken als auch durch eine Verstoßüberlagerung angezeigt.

Eine Leiterbahn, die gegen eine Regel für Netzantennen verstößt. Der Verstoß wird durch spezifische Verstoßgrafiken angezeigt.
Sie können auf der Seite PCB-Editor – Anzeige von DRC-Verstößen des Dialogs Preferences konfigurieren, wie Verstöße gegen verschiedene Regeltypen im Designbereich dargestellt werden.
Anhand der Informationen darüber, wie stark ein Grenzwert verletzt wurde, können Sie entscheiden, wie sich der Verstoß am besten beheben lässt. Wenn beispielsweise die Mindestbreite des Lötstoppmaskenstegs auf 0,25 mm festgelegt ist und die tatsächliche Stegbreite 0,24 mm beträgt, ist die Abweichung gering. Möglicherweise können Sie den Grenzwert anpassen, um diesen Wert zuzulassen. Beträgt die tatsächliche Stegbreite jedoch 0,02 mm, lässt sich das Problem wahrscheinlich nicht durch eine Anpassung des Grenzwerts beheben.
-
Die Details finden Sie im Panel Messages. Der tatsächliche Wert wird zusammen mit dem vorgegebenen Wert angegeben (zum Beispiel 0.017mm < 0.254mm).
-
Sie können auch mit der rechten Maustaste auf einen Verstoß klicken und das Untermenü Violations öffnen, um zu prüfen, welcher Grenzwert verletzt wird und unter welchen Bedingungen der Verstoß auftritt
-
Der PCB-Editor enthält außerdem praktische Messwerkzeuge, mit denen Sie den Abstand zwischen zwei Punkten, ausgewählte Objekte (die Länge ausgewählter Leiterbahnen und Kreisbögen) sowie den Abstand zwischen zwei Primitiven messen können. Weitere Informationen finden Sie auf der Seite Abstände auf einer Leiterplatte messen.
Das Panel PCB Rules And Violations eignet sich hervorragend, um Verstöße zu lokalisieren und deren Bedingungen zu verstehen. Standardmäßig wird [All Rules] in der Liste Rule Classes angezeigt. Sobald Sie einen relevanten Regeltyp identifiziert haben, wählen Sie die entsprechende Regelklasse aus, sodass im unteren Bereich des Panels nur die zugehörigen Verstöße angezeigt werden. Das Panel zeigt den Verstoßtyp, den gemessenen Wert, den Grenzwert und die Objekte, die den Verstoß verursachen. Erkannte Regelverstöße für die ausgewählte Regelklasse oder eine bestimmte Regel werden auch im Bereich Violations des Panels aufgeführt. Klicken Sie auf einen Verstoßeintrag, um den Verstoß im Designbereich hervorzuheben. Die Darstellung richtet sich nach der Einstellung oben im Panel: Mask/Dim/Normal, Select, Zoom. Doppelklicken Sie auf einen Verstoß, um den Dialog Violation Details zu öffnen.
Die DRC kann auch für alle Regeln, für Regeln eines bestimmten Typs oder für eine einzelne Regel ausgeführt werden. Klicken Sie dazu mit der rechten Maustaste auf den entsprechenden Eintrag im Panel PCB Rules And Violations und wählen Sie den Befehl Run DRC.

Führen Sie die DRC direkt im Panel PCB Rules And Violations aus. Hier ist die Ausführung der DRC für alle definierten Abstandsregeln dargestellt.
Weitere Informationen zur DRC: Designregelprüfung (DRC).















).
).


).