Steuerung der 3D-Ansicht
Altium Essentials: PCB Introduction
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Auf einen Blick
- Lernen Sie die Tastenkombinationen und Mausfunktionen kennen, mit denen Sie Ihre Leiterplatte im 3D-Layoutmodus zoomen, verschieben, drehen und neu ausrichten können.
- Erfahren Sie, wie Altium Designer beim Wechsel zwischen 2D und 3D mit Ansichtszuständen umgeht und wie Sie das Standardverhalten außer Kraft setzen können.
- Entdecken Sie die 3D-spezifischen Anzeigeoptionen im Panel „Ansichtskonfiguration“, darunter Projektion, Farben, Skalierung der Leiterplattendicke und Sichtbarkeit von 3D-Körpern.
Der PCB-Editor ist ein echter dreidimensionaler Designbereich, in dem Sie einfach zwischen dem zweidimensionalen und dem dreidimensionalen Anzeigemodus wechseln können. Diese Seite beschreibt die Funktionen des PCB-Editors zur Steuerung der Leiterplattendarstellung im 3D-Layout-Modus.
So wechseln Sie in den dreidimensionalen Anzeigemodus: Wählen Sie den Befehl View » 3D Layout Mode im Hauptmenü, verwenden Sie das Tastenkürzel 3 oder setzen Sie die Option 3D im Bereich General Settings auf der Registerkarte View Options des Panels View Configuration auf On. Drücken Sie das Tastenkürzel 2, um wieder in den zweidimensionalen Anzeigemodus zu wechseln.
Navigation auf einer Leiterplatte in 3D
Im 3D-Layout-Modus des PCB-Editors können Sie die Ansicht mit verschiedenen Tastatur- und Mauskombinationen stufenlos zoomen, drehen und sich sogar innerhalb der Leiterplatte bewegen. Das folgende Video zeigt diese Techniken zur Ansichtssteuerung.
Verwenden Sie die Tastatur in Kombination mit der rechten Maustaste, um die 3D-Ansicht auszurichten.
Verwenden Sie die folgenden Tastatur- und Mauskombinationen für diese Aktionen:
Drehen
| Richtungskugel anzeigen | Hold Shift key down Wenn Sie die Taste Shift gedrückt halten, erscheint an der aktuellen Cursorposition eine Richtungskugel (wie in der Animation oben gezeigt). Das Modell wird um den Mittelpunkt dieser Kugel gedreht. Positionieren Sie daher den Cursor, um den Drehpunkt festzulegen, bevor Sie Shift drücken. Verwenden Sie anschließend die folgenden Bedienelemente, um die Leiterplatte zu drehen: |
| Shift + Right-drag mouse | Halten Sie Shift gedrückt, um die Kugel anzuzeigen. Bewegen Sie die Maus, um das gewünschte Bedienelement auf der Kugel hervorzuheben und auszuwählen. Klicken Sie dann mit der rechten Maustaste und führen Sie die Aktion Shift + Right-drag mouse aus:
|
| Numeric keypad | Drücken Sie die folgenden Tasten auf dem Ziffernblock, um diese Aktionen auszuführen:
|
Ansicht neu ausrichten
| Main keyboard |
|
| Numeric keypad |
|
Ansichtssteuerung beim Wechsel zwischen dem 2D- und dem 3D-Anzeigemodus
Wenn Sie mit den Tastenkürzeln 2 und 3 zwischen dem 2D- und dem 3D-Anzeigemodus wechseln, behält jede Ansicht standardmäßig ihren zuletzt verwendeten Ansichtszustand bei. Wenn Sie also im 2D-Modus die gesamte Leiterplatte angezeigt haben, dann in den 3D-Modus wechseln und hineinzoomen, wird beim Zurückwechseln in den 2D-Modus wieder die gesamte Leiterplatte angezeigt. Bei Bedarf können Sie dieses Verhalten ändern, indem Sie Ctrl+Alt gedrückt halten, während Sie 2 oder 3 drücken.
|
Die gesamte Leiterplatte wird in 2D angezeigt Wenn Sie zu 3D wechseln und anschließend hineinzoomen, wird beim Drücken von 2 zum Zurückwechseln zu 2D der letzte 2D-Ansichtszustand (gesamte Leiterplatte) angezeigt. Halten Sie stattdessen Ctrl+Alt gedrückt, während Sie 2 drücken, um die Leiterplatte in 2D mit dem zuletzt verwendeten 3D-Ansichtszustand anzuzeigen. |
Konfigurationseinstellungen für die 3D-Ansicht
Sowohl der 2D- als auch der 3D-Anzeigemodus werden im Panel View Configuration konfiguriert. So öffnen Sie das Panel: Drücken Sie das Tastenkürzel L, verwenden Sie die Schaltfläche Panels unten rechts in der Software oder wählen Sie den Menüeintrag View » Panels » View Configuration.
Wenn Sie in den 3D-Layout-Modus wechseln, stehen auf der Registerkarte View Options des Panels View Configuration zusätzliche Optionen zur Steuerung der Leiterplattendarstellung in 3D zur Verfügung.
Die Registerkarte „View Options“ des Panels „View Configuration“ enthält 3D-spezifische Bedienelemente.
Allgemeine Einstellungen
3D-Einstellungen
| Board thickness (Scale) | Steuert die vertikale Skalierung der 3D-Ansicht, um die Lagen leichter unterscheiden zu können, beispielsweise bei der Überprüfung der Verbindungen zwischen den Lagen einer innenliegenden Sackloch-Durchkontaktierung. Die Transparenz jeder 3D-Lage wird unten eingestellt; mit dem Schieberegler können Sie die Objekte auf einer bestimmten Lage see through. Ziehen Sie den Schieberegler für die Dicke, um die vertikale Skalierung auf das 1- bis 100-Fache der tatsächlichen Leiterplattendicke einzustellen. |
| Colors – Realistic / By Layer |
Standardmäßig wird die 3D-Leiterplatte mit Realistic-Farben dargestellt, die auf der aktuell im Abschnitt General Settings dieses Panels ausgewählten Configuration basieren. Klicken Sie auf die Schaltfläche By Layer, um die 3D-Ansicht mit den aktuellen 2D-Lagenfarbzuweisungen anzuzeigen. |
| Grid |
|
| Component transparency | Die Transparenz von 3D-Bauteilen wird im Modus 3D Models des Panels PCB konfiguriert. Wählen Sie ein oder mehrere Bauteile aus, um deren Transparenz anzupassen |
Schnittansicht der 3D-Leiterplatte
Mit einer Schnittansicht können Sie die Leiterplatte an einer ausgewählten Stelle virtuell schneiden und so eine Schnittdarstellung der Leiterplatte und der Bauteile anzeigen. Damit können Sie kleinere Bauteile untersuchen, die unter einem größeren Bauteil oder einem mechanischen Teil platziert sind, oder den Verlauf von Sackloch- und vergrabenen Durchkontaktierungen durch die Lagen der Leiterplatte prüfen. Eine Schnittansicht wird durch die Definition von Ebenen erzeugt, an denen ein Abschnitt der Leiterplatte entlang einer, zweier oder dreier Leiterplattenachsen sliced oder cut away wird.
Die Schnittansichtsfunktion ist im 3D-Layout-Modus des PCB-Editors verfügbar. So aktivieren Sie die Schnittansicht: Wählen Sie den Befehl View » Toggle Section View; klicken Sie auf die Schaltfläche
in der Active Bar; oder verwenden Sie die Schaltflächen der Option Section View auf der Registerkarte Section View des Panels View Configuration, um die Anzeige zwischen Edit, On und Off umzuschalten.
|
Edit-Modus der Schnittansicht, angewendet auf eine Leiterplatte. On-Modus der Schnittansicht, angewendet auf eine Leiterplatte. Off-Modus der Schnittansicht, angewendet auf eine Leiterplatte. |
Bedienelemente der Schnittansicht
| Section View Origin | Wenn die Schnittansicht aktiviert ist, wird der aktuelle Ursprung durch das Manipulationswerkzeug mit drei Pfeilen angezeigt. PCB-Objekte jenseits des Ursprungs (im positiven Raum der Schnittansicht) werden angezeigt, wenn die Schnittansicht auf Edit oder On eingestellt ist. |
| Edit | Im Modus Edit werden die Schnittebenen im Designbereich angezeigt; jede Ebene wird durch eine farbige, halbtransparente Fläche gekennzeichnet, die sich vom Ursprung der Schnittansicht aus erstreckt. Die Position jeder Schnittebene kann durch Klicken und Ziehen am entsprechenden farbigen Pfeil des Manipulationswerkzeugs der Schnittansicht geändert werden. Sie können außerdem einzelne Schnittebenen aktivieren oder deaktivieren und ihre Richtung und Farbe mit den Bedienelementen unten im Panel konfigurieren. |
| On | Der Schnitt wird angewendet und die Schnittebenen werden ausgeblendet. |
| Off | In diesem Modus wird kein Schnitt angewendet. |
| Invert Cutout | Standardmäßig wird alles ausgeblendet, was sich im negativen Raum der aktuellen Schnittansicht befindet, d. h. es werden nur Objekte im positiven Raum der Schnittansicht angezeigt. Dieses Verhalten wird umgekehrt, wenn die Option Invert Cutout aktiviert ist: Objekte im negativen Raum werden angezeigt und Objekte im positiven Raum ausgeblendet. |
| Plane controls | Im unteren Bereich des Panels befinden sich die Steuerelemente für die Schnittebenen: 1) Verwenden Sie die Kontrollkästchen, um eine bestimmte Schnittebene zu aktivieren/deaktivieren, 2) klicken Sie auf das Farbfeld, um die Farbe dieser Ebene festzulegen, und 3) klicken Sie auf den Richtungspfeil, um die Richtung festzulegen, in der die Ebene angewendet wird |
3D-Ausgaben erzeugen
Aus der Leiterplatte lassen sich verschiedene Arten von 3D-Ausgaben erzeugen. Die folgende Tabelle bietet einen Überblick über die verfügbaren Ausgaben und deren Konfiguration und Erzeugung.

Ein im PCB-Editor aufgenommener 3D-Screenshot mit 300 dpi, der anschließend in einem Bildbearbeitungsprogramm auf die maximale Bildgröße verkleinert wurde, die dieser Web-Dokumentationseditor unterstützt.
Verfügbare 3D-Ausgaben
Ausgabetyp |
Quelle |
Hinweise |
| Screen capture | PCB-Editor | Wenn sich der Editor im 3D-Layoutmodus befindet, drücken Sie Ctrl+C, um einen Screenshot der aktuellen Ansicht aufzunehmen. Das Dialogfeld 3D Snapshot Resolution wird angezeigt. Wählen Sie die gewünschte Render Resolution aus und klicken Sie auf OK, um das Bild in die Windows-Zwischenablage zu kopieren. Fügen Sie es von dort in Ihr bevorzugtes Bitmap-Bildbearbeitungsprogramm ein. |
| Export as an image | PCB-Editor | Wählen Sie den Befehl File » Export » PCB 3D Print. Nachdem Sie den Speicherort für die Bilddatei ausgewählt haben, öffnet sich das Dialogfeld PCB 3D Print Settings, in dem Sie die Rendering-Auflösung, die gewünschte Ansicht der Leiterplatte und das Bildformat festlegen können. |
| PCB 3D Print | OutputJob | Die Konfiguration erfolgt im Dialogfeld PCB-3D-Druckeinstellungen. Ordnen Sie die Ausgabe im OutputJob einem New PDF-Container oder direkt einem Drucker zu. Positionieren Sie die Leiterplatte vor dem Erzeugen der Ausgabe wie gewünscht und klicken Sie dann auf die Schaltflächen Take Current Camera Position und Take Current View Configuration, um einen Ausdruck der Bildschirmansicht zu erzeugen. Sie können auch eine Bilddatei erstellen, indem Sie den OutputJob einem Ausgab econtainer für Ordnerstrukturen zuordnen. |
| PCB 3D Video | OutputJob | Die Konfiguration erfolgt im Dialogfeld PCB 3D Video. Ordnen Sie die Ausgabe im OutputJob einem New Video-Container zu. Die Ausgabe ist in verschiedenen Videoformaten möglich. Um diese Ausgabe zu erzeugen, müssen Sie zunächst im Panel PCB 3D Movie Editor einen PCB-3D-Film definieren. Weitere Informationen finden Sie auf der Seite Ein 3D-PCB-Video vorbereiten. |
| PDF 3D | Hinweise/PCB-Editor | Die Konfiguration erfolgt im Dialogfeld PDF3D. Ordnen Sie die Ausgabe im OutputJob einem New Folder Structure zu. Für die Unterstützung der 3D-Bewegung ist Adobe Acrobat v9 oder neuer erforderlich. Die Ausgabe kann auch Schlüsselbilder aus einem PCB-3D-Film enthalten, sofern ein solcher definiert wurde. Weitere Informationen finden Sie auf der Seite Eine PDF3D-Datei vorbereiten. |
| Mechanical data | PCB-Editor | Die fertige Leiterplatte kann auch in verschiedenen mechanischen Datenformaten exportiert werden (bei einer Starrflex-Leiterplatte bei Bedarf im gefalteten Zustand), sodass sie direkt in Ihr MCAD-Designwerkzeug geladen werden kann. Erfahren Sie mehr über den Import/Export mechanischer Formate. |
).
).
).


).


)
).