ActiveRoute
De un vistazo
- Comprende en qué se diferencia ActiveRoute de un enrutador automático y por qué es más adecuado para el enrutamiento guiado y de alta calidad de redes seleccionadas.
- Conoce las principales funciones de ActiveRoute, como las guías de enrutamiento, el enrutamiento multicapa, el suavizado, el ajuste de longitudes, el control de meandros y el intercambio de pines.
- Descubre cómo utilizar el panel PCB ActiveRoute para configurar y ejecutar ActiveRoute según tus reglas de diseño y objetivos de enrutamiento.
Una de las fases del diseño de placas que más tiempo consume es el enrutado de las redes. Aunque el sistema de reglas gestiona las restricciones de diseño, como las anchuras, los tamaños de las vías, las separaciones, etc., corresponde al diseñador colocar los miles de segmentos de pista necesarios para enrutar por completo una placa.
Los enrutadores automáticos pueden aliviar esta tarea, pero generalmente se consideran insuficientes porque:
-
No tienen debidamente en cuenta la infinidad de restricciones de diseño sutiles que un diseñador aplica de forma instintiva al enrutar.
-
Su configuración completa lleva tanto tiempo que a menudo resulta más eficiente ponerse directamente a enrutar la placa de forma interactiva.
-
La corrección del enrutado puede ser un proceso tan largo y difícil que a menudo resulta más eficiente enrutar la placa de forma interactiva.
El santo grial del enrutado de PCB es obtener rápidamente resultados de alta calidad que cumplan las reglas de diseño, bajo el control del diseñador. Este es el reto que ActiveRoute se propone superar.
¿Qué es ActiveRoute?
ActiveRoute es una tecnología de enrutado interactivo automatizado que ofrece algoritmos eficientes de enrutado de múltiples redes y se aplica a las redes o conexiones específicas que seleccione. ActiveRoute también permite al diseñador definir de forma interactiva una trayectoria de enrutado o guía, que a su vez define the river por donde discurrirán las nuevas rutas.
Entre las principales funciones de ActiveRoute que hacen que este enfoque sea considerablemente mejor que una combinación de enrutado interactivo convencional y enrutado automático se incluyen:
- Optimización automática de las rutas de escape de las matrices de pines y vías: el aspecto del enrutado manual que más tiempo consume.
- Alto rendimiento: las redes de señales se enrutan en < 1 segundo cada una.
- Cumple las reglas de diseño de anchura, separación, capas, topología y regiones por red y clase de red, respetando las prioridades.
- Enruta en varias capas simultáneamente y distribuye las rutas entre ellas.
- Una guía de enrutado intuitiva que el diseñador puede utilizar para dirigir la colocación de las rutas.
- Utiliza un enfoque de enrutado en paralelo (River Route) para lograr altas tasas de finalización sin necesidad de vías.
- Permite enrutar a través de planos poligonales y volver a rellenarlos (si la opción de nuevo relleno está activada).
- Admite tanto redes de señal de extremo único como de pares diferenciales.
- Finaliza con una potente herramienta de optimización que reduce aún más el número de esquinas y acorta el enrutado.
El panel PCB ActiveRoute
ActiveRoute sigue los criterios y las restricciones definidos por las reglas de diseño de PCB, por lo que utilizarlo es tan sencillo como seleccionar las conexiones o redes de interés y ejecutarlo. Dispone de una serie de funciones de control específicas que se configuran en el panel PCB ActiveRoute. El panel PCB ActiveRoute se utiliza para configurar y utilizar las distintas funciones que ofrece ActiveRoute, entre ellas: realizar un enrutado interactivo con ActiveRoute; definir una guía de enrutado y la separación entre las rutas dentro de ella; activar el ajuste automático de longitud; y activar el intercambio automático de pines. Se recomienda encarecidamente abrir el panel PCB ActiveRoute antes de iniciar ActiveRoute.
Para abrir el panel PCB ActiveRoute cuando el documento activo sea una PCB:
-
Haga clic en el botón
de la esquina inferior derecha del espacio de trabajo y, a continuación, seleccione la opción de menú PCB ActiveRoute.
-
Haga clic en View » Panels » PCB ActiveRoute.
Utilice el panel PCB ActiveRoute para controlar el proceso de ActiveRoute.
El panel PCB ActiveRoute se utiliza para:
- Habilitar las capas de señal en las que ActiveRoute puede enrutar conexiones.
- Realizar un enrutado con ActiveRoute en las conexiones seleccionadas.
- Activar una pasada de optimización después de ActiveRoute.
-
Definir una guía de enrutado.
- Configurar la separación entre pistas que desea utilizar dentro de la guía de enrutado.
- Configurar y activar el ajuste de longitud de las rutas colocadas por ActiveRoute.
- Configurar la opción de meandro, que permite a ActiveRoute definir una trayectoria de enrutado más larga, lo que puede ayudar a aumentar la tasa de finalización.
- Configurar y activar el intercambio de pines. ActiveRoute puede intercambiar pines durante el enrutado para ayudar a mejorar su calidad.
El contenido del panel PCB ActiveRoute está organizado en secciones desplegables que se abren y cierran mediante el icono ► asociado al encabezado de cada sección. La información sobre los controles de propiedades que se incluye a continuación está organizada en las secciones correspondientes, y cada sección desplegable se abre y cierra del mismo modo.
Acción
Estas son las opciones principales utilizadas para controlar ActiveRoute.
-
ActiveRoute - haga clic en el botón
del panel para realizar un enrutado con ActiveRoute en las conexiones seleccionadas. ActiveRoute intenta enrutar las conexiones seleccionadas o, si hay pads o vías seleccionados, todas las conexiones de esas redes. Consulte la página de ActiveRoute para obtener más información sobre las técnicas de selección.
-
Route Guide - una guía de enrutado es una trayectoria definida por el usuario dentro de la cual ActiveRoute debe enrutar las conexiones seleccionadas. Uno de los objetivos principales de ActiveRoute es encontrar el conjunto de rutas con la menor longitud total, lo que puede no corresponder a la trayectoria deseada para cada conjunto de conexiones. La guía de enrutado proporciona al diseñador una herramienta para trazar una trayectoria específica por la que desea que discurran las conexiones seleccionadas. El color de la guía de enrutado viene determinado por las capas habilitadas para enrutar las conexiones seleccionadas con ActiveRoute: si solo hay una capa habilitada, se dibuja con el color de esa capa; si hay varias capas habilitadas, se dibuja con el color predeterminado de la guía de enrutado.
-
Para definir una guía de enrutado, seleccione primero las conexiones que se deben enrutar dentro de la guía y haga clic en
botón del panel y, a continuación, haga clic para definir la ubicación inicial de la guía; siga moviendo el ratón y haciendo clic para definir el recorrido. Una vez definido el recorrido, haga clic en el botón ActiveRoute para enrutar las conexiones seleccionadas a lo largo de ese recorrido.
-
Durante la colocación de la guía de enrutado, puede aumentar o reducir su anchura pulsando las teclas
o
. La anchura predeterminada es la suma de las reglas de diseño de anchura y separación aplicables a las conexiones seleccionadas, dividida entre el número de capas y multiplicada por 1,3. Pulse la tecla Backspace para deshacer el trazado de la guía si necesita definir otro recorrido.
- ActiveRoute intentará separar las pistas de acuerdo con las reglas de diseño; no intentará distribuirlas ni utilizar todo el espacio disponible dentro de una guía de enrutado. Para distribuir las pistas dentro de una guía de enrutado, utilice la función Separación entre pistas en la guía de enrutado, como se describe más adelante en esta página.
-
Para definir una guía de enrutado, seleccione primero las conexiones que se deben enrutar dentro de la guía y haga clic en
-
Tune Selected - cuando esta opción está habilitada, se aplica la regla de igualación de longitudes de mayor prioridad que sea aplicable y esté habilitada en la sección Ajuste del panel.
-
Pin Swap Routing – el editor de PCB admite el intercambio de pines; habilite esta opción para permitir que ActiveRoute intercambie pines durante el proceso de enrutado. Además de habilitar esta opción, también debe habilitar los componentes necesarios en la sección Pin Swap del panel, como se describe a continuación. Para obtener más información sobre el sistema de intercambio de pines, consulte la página Intercambio de pines, pares y partes.
-
Gloss Results – habilite esta opción para optimizar automáticamente los resultados de ActiveRoute. También puede aplicar la optimización a pistas existentes seleccionadas; para ello, ejecute el comando Route » Gloss Selected (Ctrl+Alt+G). Consulte la página Optimización y retrazado de pistas existentes para obtener más información.
Capas
ActiveRoute puede enrutar en varias capas simultáneamente. Aunque no puede colocar vías para cambiar de capa, sí puede distribuir las conexiones y las redes entre las capas disponibles. Las capas disponibles se configuran en la sección Capas del panel.
- Show Signal Layers Only – de forma predeterminada, se muestran todas las capas de señal y de plano disponibles; habilite esta opción para mostrar únicamente las capas de señal.
- List of Layers – habilite las capas de señal en las que ActiveRoute puede enrutar señales. ActiveRoute distribuirá las conexiones entre las capas de señal disponibles. Tenga en cuenta que ActiveRoute no coloca vías para cambiar de capa.
Control
Estos controles permiten flexibilizar el criterio de ActiveRoute de separar las pistas para cumplir la regla de diseño de separación aplicable y permitirle utilizar un recorrido menos directo para completar una conexión.
- Track-Track Space in Route Guide – este control permite indicar a ActiveRoute la distancia a la que debe intentar distribuir las conexiones enrutadas a lo largo de la guía de enrutado (de centro a centro de pista). Este ajuste debe realizarse antes de definir la guía de enrutado, para que la anchura de la guía pueda calcularse correctamente según la separación. Utilice el control deslizante para seleccionar un valor o introduzca una distancia en el cuadro de edición.
-
Meander % Over Manhattan Length – ActiveRoute intenta enrutar las conexiones seleccionadas por el recorrido más corto posible, es decir, con el mínimo de meandros. Si la tasa de finalización de ActiveRoute es inferior a la esperada, aumentar la cantidad de meandros permitida puede ayudar a mejorarla. El ajuste máximo predeterminado de meandros es del 100 %, lo que significa que las pistas pueden tener una longitud total de
Manhattan Length + 100% of Manhattan Length. Utilice el control deslizante para seleccionar un valor o introduzca un porcentaje en el cuadro de edición. Tenga en cuenta que el ajuste de meandros se ignora al utilizar la guía de enrutado, ya que esta permite definir un recorrido que puede aumentar considerablemente los meandros.
Ajuste
ActiveRoute puede ajustar la longitud de las conexiones que se están enrutando o de las pistas existentes seleccionadas.
-
Match Length Rules for Selected – aquí se muestran todas las reglas de diseño de igualación de longitudes definidas. Habilite la regla que ActiveRoute debe utilizar para las conexiones seleccionadas.
-
Single Ended – propiedades del acordeón de ajuste que se utilizará para ajustar las señales de extremo único.
- Max Amplitude - amplitud máxima permitida del acordeón de ajuste. La amplitud se reduce automáticamente cuando hay obstáculos, como pads, vías o pistas existentes, para garantizar que se mantengan las separaciones exigidas por las reglas de diseño.
- Min Space - separación mínima entre bordes en los cruces por cero de la forma del acordeón.
-
Differential Pair - propiedades del acordeón de ajuste que se utilizará para ajustar los pares diferenciales.
- Max Amplitude - amplitud máxima permitida del acordeón de ajuste para el miembro exterior del par diferencial. La amplitud se reduce automáticamente cuando hay obstáculos de colocación, para garantizar que se mantengan las separaciones exigidas por las reglas de diseño.
- Min Space - separación mínima entre bordes en los cruces por cero de la forma del acordeón para el miembro interior del par diferencial.
Intercambio de pines
Los pines funcionalmente equivalentes de un componente pueden configurarse como intercambiables; para ello, seleccione el comando Tools » Pin/Part Swapping » Configure. Antes de realizar cualquier intercambio de pines (de forma interactiva o mediante ActiveRoute), debe compilar el proyecto (menú Project) cada vez que lo abra.
- Components with Pin Swap Enabled – aquí se mostrarán todos los componentes habilitados para el intercambio de pines; habilite los que desee que estén disponibles para el intercambio automático durante una operación de ActiveRoute.
Funciones adicionales de ActiveRoute
ActiveRoute es un enrutador interactivo automatizado y su uso es sencillo y directo: seleccione las conexiones y pulse Shift+A para enrutarlas con ActiveRoute de acuerdo con las reglas de diseño. ActiveRoute incluye otras funciones y controles que proporcionan al diseñador un mayor control sobre determinadas características y capacidades.
Entre ellas se incluyen:
- Definir el recorrido de enrutado y la separación entre pistas mediante la colocación de una guía de enrutado.
- Permitir un recorrido de enrutado más largo con el control de meandros.
- Igualar automáticamente las longitudes de las pistas mediante el ajuste de longitud.
- Permitir el intercambio de pines para simplificar el enrutado.
Veamos cada una de ellas con más detalle.
Definir el recorrido con la guía de enrutado
Uno de los principales objetivos de ActiveRoute es encontrar el conjunto de pistas con la menor longitud total, lo que puede no coincidir con el recorrido deseado para cada conjunto de conexiones. La guía de enrutado proporciona al diseñador una herramienta para trazar un recorrido específico por el que desea que pasen las conexiones seleccionadas, aunque no sea el más corto.
-
Defining the Route Guide - primero seleccione las conexiones que se van a enrutar dentro de la guía y haga clic en
botón del panel PCB ActiveRoute y, a continuación, haga clic para definir la ubicación inicial de la guía y siga moviendo el ratón y haciendo clic para definir el recorrido. Una vez definido el recorrido, haga clic en el botón ActiveRoute para enrutar las conexiones seleccionadas a lo largo de él. Consulte la sección Definir una guía de enrutamiento más adelante en esta página para obtener más información.
-
Changing the Route Guide Width - durante la colocación de la guía de enrutamiento, puede aumentar o reducir su anchura pulsando las teclas
o
. La anchura predeterminada es la suma de los valores de las reglas de diseño de anchura y separación aplicables a las conexiones seleccionadas, dividida entre el número de capas y multiplicada por 1,3. Pulse la tecla Backspace para retroceder en el trazado de la guía si necesita definir un recorrido diferente.
- The Route Guide color - determinado por las capas disponibles para enrutar las conexiones seleccionadas con ActiveRoute. Si solo hay una capa habilitada, se dibuja con el color de esa capa; si hay varias capas habilitadas, se dibuja con el color predeterminado de la guía de enrutamiento.
- The track spacing within the Route Guide - de forma predeterminada, ActiveRoute separa las pistas de acuerdo con las reglas de diseño; no intenta distribuirlas ni utilizar todo el espacio disponible dentro de una guía de enrutamiento. Para distribuir las pistas dentro de una guía de enrutamiento, utilice la función Separación entre pistas en la guía de enrutamiento, como se describe más adelante en esta página.

Vídeo que muestra la colocación de una guía de enrutamiento, cuya anchura se modifica de forma interactiva durante la colocación.
Separación entre pistas dentro de la guía de enrutamiento
Con la función Separación entre pistas en la guía de enrutamiento, puede indicar a ActiveRoute que distribuya las pistas a lo ancho de la guía de enrutamiento. Utilice el control deslizante para seleccionar un valor de separación o introduzca un valor en el cuadro de edición. El tamaño de la guía de enrutamiento se ajustará automáticamente para tener en cuenta este ajuste. Para ello, debe configurar el ajuste Track-Track Space in Route Guide antes de colocar la guía de enrutamiento. Puede ajustar aún más la anchura de la guía de enrutamiento durante la colocación pulsando las teclas
y
.

Utilice la función Separación entre pistas para distribuir las pistas en la guía de enrutamiento.
Permitir que las pistas serpenteen
ActiveRoute intenta enrutar las conexiones seleccionadas por el recorrido más corto posible o, en otras palabras, con el mínimo serpenteo. Si el porcentaje de conexiones completadas por ActiveRoute es inferior al esperado, el control Serpenteo le permite aumentar el serpenteo permitido para ActiveRoute, lo que puede ayudar a elevar dicho porcentaje. El ajuste máximo predeterminado de Serpenteo es del 100 %, lo que significa que se permite que las pistas tengan una longitud total de Manhattan Length + 100% of Manhattan Length. Utilice el control deslizante para seleccionar un valor de serpenteo o introduzca un porcentaje en el cuadro de edición.
Tenga en cuenta que el ajuste de serpenteo se ignora cuando se utiliza la guía de enrutamiento porque esta está pensada para definir un recorrido que puede aumentar considerablemente el serpenteo.
Ajuste de las longitudes de las pistas
ActiveRoute puede ajustar la longitud de las conexiones que se estén enrutando o de las pistas existentes seleccionadas. ActiveRoute intentará cumplir la regla de diseño de igualación de longitudes seleccionada.
Para configurar ActiveRoute para el ajuste de longitudes:
-
Active la casilla Tune Selected en la sección Action del panel.
-
Habilite la regla de diseño de igualación de longitudes necesaria en la sección Tune del panel.
-
Configure los ajustes Max Amplitude y Min Space necesarios (para señales de extremo único o pares diferenciales) en la sección Tune del panel.
Intercambio de pines
El software incluye un potente sistema de intercambio de pines y partes, vinculado entre los editores de esquemas y de PCB. ActiveRoute puede acceder a los ajustes de intercambio de pines e intercambiar pines durante el enrutamiento si con ello se reduce la longitud total de las pistas y se mejora la calidad del enrutamiento.
Para utilizar el intercambio de pines:
- Antes de poder realizar cualquier intercambio de pines (de forma interactiva o mediante ActiveRoute), es necesario compilar el proyecto (menú Project) cada vez que se abre.
- Para configurar y gestionar los ajustes de intercambio de pines de los componentes, ejecute el comando Tools » Pin/Part Swapping » Configure para abrir el cuadro de diálogo Configure Swapping Information in Components.
- Active la opción Pin Swap Routing en la sección Action del panel PCB ActiveRoute.
- Habilite los componentes necesarios en la sección Pin Swap del panel PCB ActiveRoute.
Preparación para utilizar ActiveRoute
1. Crear clases de redes
ActiveRoute requiere que las redes estén seleccionadas. Disponer de clases de redes puede facilitar considerablemente el proceso de selección cuando hay un gran número de redes que se van a enrutar con ActiveRoute. Consulte la sección Técnicas de selección más adelante en este artículo para conocer las mejores formas de seleccionar conexiones.
2. Ocultar temporalmente los polígonos existentes
ActiveRoute puede enrutar a través de los polígonos existentes si la opción Repour Polygons after Modification está habilitada en la página Editor de PCB - General del cuadro de diálogo Preferences. Como alternativa, los polígonos se pueden ocultar temporalmente (dejarlos invisibles, pero conservarlos en el diseño) mediante el comando Tools » Polygon Pours » Shelve Polygons.
3. Configurar las reglas de diseño
- Separaciones: ActiveRoute respeta las reglas de diseño de separación aplicables y las aplica según su orden de prioridad.
- Anchos de enrutamiento: utiliza el ajuste Preferred de las reglas de ancho aplicables. Al igual que en el enrutamiento interactivo, para cambiar los anchos en una zona, por ejemplo, cuando el trazado pasa por debajo de un BGA, defina una región Room que aplique una regla de diseño de ancho con un ancho preferido más estrecho. Si no puede enrutar manualmente con el ancho preferido, ActiveRoute tampoco podrá hacerlo.
- Pares diferenciales: ActiveRoute puede enrutar pares diferenciales. Asegúrese de que los pares diferenciales estén definidos correctamente (compruébelo en el modo Editor de pares diferenciales del panel PCB) y confirme que las reglas de enrutamiento de pares diferenciales estén configuradas correctamente (se utilizan los valores Preferred).
- Entrada a pads: ActiveRoute intenta utilizar la ruta más directa de entrada o salida de un pad que respete las reglas sin crear ángulos agudos. Respeta las reglas SMT a esquina y Entrada a pads SMT, pero no siempre centra la pista en el pad (como hace el enrutador interactivo cuando está habilitada la regla SMT a esquina). Incluye algoritmos especiales para los pads de pares diferenciales, que se centran en el acoplamiento del par sin descuidar la disposición ordenada del trazado.
4. Configurar la topología de las redes
ActiveRoute seguirá el patrón de las líneas de conexión. Si tiene un conjunto de redes que requieren una topología específica, por ejemplo, una topología fly-by DDR3/4, puede definir el orden de origen a destino mediante xSignals. El Asistente xSignals multichip (Design » xSignals » Run xSignals Wizard) puede crear xSignals para diseños que incluyan señalización de tipo DDR3/4 y USB 3.0. Como alternativa, se pueden definir patrones de líneas de conexión punto a punto para una red creando conexiones From-To en el modo Editor From-To del panel PCB.
5. Crear los fanouts del diseño
ActiveRoute no coloca vías, por lo que debe crear fanouts para los BGA, los conectores y los componentes discretos que utilicen pines SMT (excepto para los pines que se vayan a enrutar en las capas externas).
6. Enrutar la alimentación y la tierra
ActiveRoute está diseñado para redes de señal; ignora las redes asignadas a planos de alimentación y las redes que contienen más de 20 pines (se supone que estas son redes de alimentación). Si desea utilizar ActiveRoute en un diseño ya terminado, elimine los trazados de señal, pero conserve el enrutamiento de alimentación y tierra, así como los fanouts.
7. Habilitar las capas de enrutamiento necesarias
Habilite las capas de enrutamiento necesarias en el panel PCB ActiveRoute. Más información al respecto a continuación.
Ejecutar ActiveRoute
Para ejecutar ActiveRoute:
1. Seleccionar las conexiones que se van a enrutar
Mediante las técnicas descritas en la página Estrategias para seleccionar el enrutamiento, seleccione las conexiones o redes que se van a enrutar. Las conexiones se pueden seleccionar directamente o seleccionando un objeto de enrutamiento, como un pin, una pista, una vía o un componente. La barra de estado mostrará el número de conexiones que se acaban de seleccionar hasta que el cursor pase sobre otro objeto.
- Cuando se seleccionan conexiones, se enrutan con el ancho preferido definido en la regla de diseño de ancho de enrutamiento aplicable.
- Cuando se selecciona un trazado existente, la conexión unida a la pista seleccionada se enruta utilizando el ancho de esa pista.
- Cuando se seleccionan pads de componentes, todas las conexiones de los pads seleccionados se enrutan con el ajuste preferido de la regla.
2. Habilitar las capas en las que se ejecutará ActiveRoute
En el panel PCB ActiveRoute, habilite las capas en las que se enrutarán las conexiones seleccionadas. ActiveRoute distribuirá los trazados entre estas capas.
Si no se selecciona ninguna capa, el enrutamiento se realizará en la capa activa, que corresponde a la pestaña seleccionada en la parte inferior de la ventana principal del editor de PCB.
El panel PCB ActiveRoute permite seleccionar las capas en las que se va a enrutar, crear una guía de enrutamiento e iniciar ActiveRoute.
3. Definir una guía de enrutamiento, si es necesario
Para colocar una guía de enrutamiento:
- Seleccione las conexiones que desee enrutar a lo largo de la guía de enrutamiento. La barra de estado mostrará el número de conexiones que se acaban de seleccionar hasta que el cursor pase sobre otro objeto.
- Haga clic en el botón Route Guide del panel PCB ActiveRoute.
- El cursor parecerá estar holding todas las conexiones seleccionadas, lo que indica que este conjunto de conexiones debe pasar por la guía. Mueva el cursor a una ubicación inicial adecuada, en cualquiera de los extremos del recorrido que desee definir.
- Haga clic para definir la ubicación inicial de la guía y deje espacio para que las conexiones entrantes accedan al extremo curvo de la guía.
- La guía se coloca como si fuera una pista muy ancha. Mueva el cursor hasta la ubicación de la primera esquina que deba formar la guía y, a continuación, haga clic para definir esa esquina.
- Continúe este proceso de definición del recorrido y deténgase a cierta distancia de donde terminan las líneas de conexión, dejando espacio para que las conexiones salgan de la guía hacia sus pads, vías o extremos de pista de destino.
- Pulse la tecla Up Arrow para ensanchar la guía o la tecla Down Arrow para estrecharla.
- Pulse Backspace para eliminar la última esquina de la guía.
- Haga clic con el botón derecho para salir del modo de colocación de la guía.
Solo se puede definir una guía de enrutamiento a la vez.
4. Ejecutar ActiveRoute
Para ejecutar ActiveRoute, puede:
- Seleccionar el comando Route » ActiveRoute.
-
Hacer clic en el botón ActiveRoute (
) de Active Bar.
- Hacer clic en el botón ActiveRoute del panel PCB ActiveRoute.
- Usar el atajo Shift+A.
5. Supervisar el progreso y comprobar los resultados
- La barra de estado del editor de PCB muestra el progreso de ActiveRoute.
- El panel Messages informa de los porcentajes de finalización.
Mejorar su dominio de la herramienta
-
Un aspecto clave para dominar ActiveRoute es familiarizarse con los atajos. Las secuencias de teclas que utilizará con mayor frecuencia son:
- Alt+Click - para seleccionar una línea de conexión individual.
- Alt+Click&Drag - para seleccionar conexiones dentro de un área, arrastre de derecha a izquierda para seleccionar todas las conexiones que toque el rectángulo de selección, o de izquierda a derecha para seleccionar solo las que queden dentro de él. Pulse Tab para ampliar la selección e incluir otras conexiones de las mismas redes. La barra de estado mostrará el número de conexiones que acaba de seleccionar hasta que el cursor se sitúe sobre otro objeto.
- Ctrl+Click&Drag - para seleccionar pads de un componente, arrastre de derecha a izquierda para seleccionar todos los pads que toque el rectángulo de selección, o de izquierda a derecha para seleccionar solo los que queden dentro de él. Pulse Tab para ampliar la selección e incluir otros objetos de enrutamiento de las mismas redes. Siga pulsando Tab para recorrer todos los estados de selección posibles.
- Click&Drag - para seleccionar segmentos de pista existentes, arrastre de derecha a izquierda para seleccionar todas las pistas que toque el rectángulo de selección, o de izquierda a derecha para seleccionar solo las que queden dentro de él. Pulse Tab para ampliar la selección e incluir otros objetos de enrutamiento de las mismas redes. Siga pulsando Tab para recorrer todos los estados de selección posibles.
- Incluya Shift para conservar la selección actual mientras realiza otra selección.
- Shift+A para enrutar la selección actual con ActiveRoute.
- Ctrl+Alt+G - para suavizar el enrutamiento de la selección actual.
-
Las acciones de selección solo se realizan sobre objetos visibles (excepto en el caso de Ctrl+A):
- Pulse Shift+S para entrar o salir del modo de una sola capa de modo que solo se muestre la capa de interés.
- Si el diseño utiliza regiones de colocación, estas pueden bloquearse como parte de su definición en las reglas de diseño, o bien ocultarse para evitar que se seleccionen o muevan al hacer clic y arrastrar. Las regiones pueden ocultarse en la pestaña View Options del panel Configuración de vista.
-
Realice el fanout de los pads SMD. ActiveRoute no cambia de capa, por lo que deberá realizar el fanout de los pads SMD. Para acelerar este proceso:
- Mientras enruta una conexión, pulse el atajo / (teclado numérico) para colocar una vía y soltar esta conexión. Utilice el atajo 2 si no dispone de teclado numérico (coloca una vía sin suspender el enrutamiento).
- Copie y pegue un fanout existente; el editor de PCB actualizará automáticamente los nombres de las redes. Esto puede hacerse con varios fanouts.
-
Conserve los fanouts existentes. ActiveRoute modificará los fanouts si encuentra una solución mejor; bloquéelos si no desea que se modifiquen. La forma más sencilla de bloquearlos es seleccionar las pistas y vías del fanout (utilice Selection Filter en la parte superior del panel Properties para facilitar este proceso), pulsar F11 para abrir el panel Properties y activar la casilla Locked. Esto bloqueará todos los objetos seleccionados en una sola acción.
-
Si utiliza una guía de enrutamiento y observa que el porcentaje de finalización es bajo, puede que haya demasiados obstáculos a lo largo del recorrido y sea necesario ensanchar la guía. Pulse la tecla de flecha Up para ensanchar la guía durante su colocación.
-
Cuando ActiveRoute termina, aplica un suavizado del enrutamiento (si está habilitado en el panel PCB ActiveRoute). Para examinar las rutas tal como estaban al finalizar el enrutamiento con ActiveRoute, pulse Ctrl+Z una vez para deshacer el suavizado. El comando Gloss (Route » Gloss Selected) puede utilizarse para suavizar las pistas y mejorar las entradas a los pads de cualquier enrutamiento, no solo de los realizados con ActiveRoute. Se ha prestado especial atención a garantizar entradas a los pads de alta calidad para los pares diferenciales. Para obtener más información sobre el suavizado, consulte la página Suavizado y retrazado de rutas existentes.
-
Si ActiveRoute no funciona, suele deberse a que las reglas no están configuradas correctamente. El motivo más común de fallo de ActiveRoute es la falta de espacio para las pistas. Compruebe que las reglas sean adecuadas; por ejemplo, los valores de las reglas predeterminadas de un archivo PCB nuevo podrían ser demasiado grandes para un diseño de tipo BGA de alta densidad.
-
ActiveRoute respeta las reglas de enrutamiento configuradas para anchos, separaciones y distancias entre pistas de pares diferenciales, por capa, por región y por clase. ActiveRoute no enruta con arcos ni con pistas de ángulo libre.