Bibliothèques de schémas
En un coup d'œil
- Découvrez différentes méthodes de création de bibliothèques, notamment pour constituer une bibliothèque de travail ou une archive contenant exactement les composants utilisés dans un projet.
- Apprenez à gérer les composants et à convertir les ports d’une feuille de schéma en broches de symbole.
- Découvrez comment ajouter et organiser des modèles d’empreinte, de simulation et d’intégrité du signal, ainsi que les informations de correspondance nécessaires pour les relier aux symboles.
Le composant physique monté sur la carte est représenté par un symbole schématique lors de la saisie du schéma et par une empreinte de circuit imprimé lors de la conception de la carte. Les composants Altium Designer peuvent être :
- Créés dans des bibliothèques locales et placés à partir de celles-ci ou
- Placés directement depuis un espace de travail connecté, accessible à toute l’équipe de conception.
Les symboles peuvent être copiés depuis l’éditeur de schémas vers une bibliothèque de schémas, copiés entre bibliothèques de schémas ou créés de toutes pièces à l’aide de Schematic Symbol Generation Tool ou des outils de dessin.
Créer une bibliothèque de schémas
Pour créer une bibliothèque de schémas, sélectionnez la commande File » New » Library dans les menus principaux, puis l’option Schematic Library dans la zone File de la boîte de dialogue New Library.
Après avoir cliqué sur Create, un nouveau document de bibliothèque de schémas nommé Schlib1.SchLib est créé et affiché dans le panneau Projects, et une feuille de composant vide nommée Component_1 s’affiche.
Le contenu de la bibliothèque est affiché dans le panneau SCH Library.
Vous pouvez maintenant ajouter, supprimer ou modifier les composants schématiques de la nouvelle bibliothèque de schémas à l’aide des commandes de l’éditeur de symboles schématiques.
Créer une bibliothèque de schémas à partir de documents schématiques
Vous pouvez également créer une bibliothèque de schémas regroupant tous les composants utilisés dans les documents schématiques sources du projet actif en cliquant sur Design » Make Schematic Library. Cette fonction est très utile pour créer une bibliothèque de travail ou une archive reflétant exactement votre conception finalisée. Si des composants possèdent la même référence de bibliothèque, mais une structure interne différente, la boîte de dialogue Component Grouping s’ouvre et vous permet de préciser les paramètres à utiliser pour le regroupement.
Tous les documents schématiques sources du projet actif sont ouverts, si ce n’est pas déjà le cas, et un document de bibliothèque (<ProjectName>.SchLib) est automatiquement créé et ajouté au projet. Ce document s’ouvre en tant que document actif dans l’éditeur de symboles schématiques. La bibliothèque contient tous les composants utilisés dans la conception. Le fichier créé apparaît dans le panneau Projects au sein du projet, dans le sous-dossier Libraries\Schematic Library Documents. Le fichier n’est pas initialement enregistré sur le disque dur.
Créer une bibliothèque de schémas à partir d’une feuille de schéma
Vous pouvez créer un symbole de composant schématique à partir de la feuille de schéma active ; les ports de cette feuille deviennent alors les broches du composant. Pour ce faire, sélectionnez la commande Design » Create Component From Sheet dans les menus principaux ou effectuez un clic droit dans l’espace de conception principal, à l’écart des objets de conception, puis sélectionnez la commande Sheet Actions » Create Component From Sheet dans le menu contextuel.
Après le lancement de la commande, la boîte de dialogue Symbol Options s’affiche. Utilisez cette boîte de dialogue pour définir la hauteur et la largeur du symbole, la longueur de ses broches ainsi que leur style, en fonction des ports de la feuille source.

La boîte de dialogue Symbol Options
Options et commandes de la boîte de dialogue Symbol Options
- Auto Width - permet de déterminer automatiquement la largeur du composant créé. Si cette option est décochée, vous pouvez personnaliser la largeur en saisissant une valeur dans la zone de texte.
- Auto Height - permet de déterminer automatiquement la hauteur du composant créé. Si cette option est décochée, vous pouvez personnaliser la hauteur en saisissant une valeur dans la zone de texte.
- Pin Length - saisissez une longueur de broche pour le composant créé. La valeur par défaut est 10.
-
Style - permet de sélectionner le style des ports :
- Input/Output - les ports d’entrée apparaissent sous forme de broches sur le côté droit du symbole et les ports de sortie sous forme de broches sur le côté gauche. Dans les deux cas, ils sont classés par ordre alphabétique.
- Relative Schematic Port Layout - les ports de la feuille de schéma apparaissent sous forme de broches sur le symbole, dans le même ordre que dans le schéma.
- Proportional Schematic Port Layout - les ports de la feuille de schéma apparaissent sous forme de broches sur le symbole, dont les dimensions sont adaptées pour refléter la disposition des ports dans le schéma.
Après avoir cliqué sur OK dans la boîte de dialogue, le nouveau composant est créé dans un nouveau document de bibliothèque de schémas (Schlib1.SchLib) et porte le nom du document schématique. La bibliothèque s’ouvre en tant que document actif et le nouveau composant y est présenté comme composant actif.
Créer un composant schématique
Une bibliothèque de schémas peut contenir un nombre illimité de symboles de composants. Pour créer un composant schématique dans une bibliothèque existante, sélectionnez Tools » New Component dans les menus principaux ou dans le menu contextuel de l’espace de conception, ou cliquez sur le bouton Add sous la zone Design Item ID du panneau SCH Library.
Après le lancement de la commande, la boîte de dialogue New Component s’ouvre. Utilisez le champ Design Item ID de cette boîte de dialogue pour attribuer un nom approprié au composant.

La boîte de dialogue New Component
Après avoir cliqué sur OK, un nouveau composant portant ce nom est créé dans la bibliothèque et une feuille de composant vide s’ouvre et devient active dans l’espace de conception.
Puisqu’une nouvelle bibliothèque contient toujours un composant vide, vous pouvez également renommer Component_1 pour commencer à créer un composant. Pour ce faire, sélectionnez Component_1 dans la liste Design Item ID du panneau SCH Library, puis cliquez sur le bouton Edit du panneau ou double-cliquez sur Component_1 pour ouvrir le panneau Properties en mode Component. Saisissez le nouveau nom identifiant de manière unique le composant dans le champ Design Item ID, puis appuyez sur Enter.
Pour supprimer le composant courant de la bibliothèque active, sélectionnez Tools » Remove Component dans les menus principaux ou effectuez un clic droit dans l’espace de conception, puis sélectionnez Tools » Remove Component dans le menu contextuel. Vous pouvez également supprimer des composants directement depuis le panneau SCH Library. Sélectionnez les composants concernés dans la liste Design Item ID , puis cliquez sur le bouton Delete sous la liste ou effectuez un clic droit et sélectionnez la commande Delete dans le menu contextuel. Le panneau permet de supprimer plusieurs composants à la fois.
Ajouter des modèles au composant schématique
Vous pouvez ajouter autant de modèles d’empreinte PCB que vous le souhaitez à un composant schématique, ainsi que des fichiers de modèles utilisés pour la simulation de circuits et l’analyse de l’intégrité du signal. Si un composant possède plusieurs modèles (par exemple, plusieurs empreintes), vous pouvez sélectionner le modèle approprié dans le panneau Properties lorsque vous placez le composant sur un schéma. Pour obtenir ces modèles, vous pouvez les créer vous-même ou télécharger le fichier de modèle d’un fournisseur sur Internet. Les bibliothèques PCB peuvent contenir un nombre quelconque d’empreintes PCB.
Vous pouvez ajouter des modèles au composant actuel de différentes manières :
-
Depuis la zone Model située en bas de l’espace de conception (cliquez sur le symbole de flèches vers le bas/chevron en bas à droite de l’espace de conception, comme illustré dans l’image suivante).

Cliquez sur le chevron en surbrillance pour accéder à la zone Model de l’espace de conception. -
À l’aide de la liste déroulante Add dans la zone Parameters du panneau Properties en mode Component, puis en sélectionnant le modèle.
-
La boîte de dialogue Model Manager de l’éditeur de symboles schématiques (Tools » Model Manager, ou cliquez avec le bouton droit sur un composant dans le panneau SCH Library puis sélectionnez Model Manager dans le menu contextuel) vous permet de visualiser et d’organiser les modèles de tous les composants de la bibliothèque de schémas active. Vous pouvez, par exemple, ajouter le même modèle à plusieurs composants sélectionnés.

La boîte de dialogue Model ManagerOptions et commandes de la boîte de dialogue Model Manager
-
Mask – saisissez un nom de composant dans ce champ pour filtrer le contenu. Utilisez «
*» comme caractère générique. - Component list – répertorie tous les composants existants dans la bibliothèque de schémas actuelle, ainsi que leur description.
- Model list – répertorie tous les modèles associés au composant sélectionné. Le menu contextuel de cette zone comprend des commandes permettant de Add, Copy, Paste, Remove ou Edit un modèle.
-
Add – cliquez pour accéder à une liste déroulante et choisir parmi les options de modèle ci-dessous. Pour chaque option, une boîte de dialogue associée s’ouvre afin de vous permettre de personnaliser (si nécessaire) et d’ajouter le modèle souhaité.
-
Footprint– disposition physique requise sur le circuit imprimé pour monter un composant ou une fixation mécanique. -
Pin Info– ajoute un fichier Pin Info, qui peut servir de description des broches FPGA/MC pour tout outil FPGA tiers, ou pour d’autres types de composants. -
PCB3D– ajoute un modèle 3D au composant. -
Simulation– ajoute un modèle Spice au composant si vous souhaitez exécuter une simulation de circuit. -
Ibis Model– ajoute un modèle Ibis pour améliorer la modélisation des broches des circuits intégrés lors des analyses de l’intégrité du signal. -
Signal Integrity– ajoute un modèle d’intégrité du signal pour configurer et contrôler les analyses de l’intégrité du signal.
-
- Copy – cliquez pour copier le modèle souhaité depuis la liste.
- Paste – cliquez pour coller un modèle dans la liste. Le nouveau modèle apparaît en bas de la liste.
- Remove – cliquez pour supprimer les empreintes sélectionnées.
- Edit – cliquez pour ouvrir la boîte de dialogue correspondante, dans laquelle vous pouvez modifier l’affectation du modèle.
- Refresh Preview – cliquez pour actualiser l’aperçu du modèle. Cliquez sur 2D/3D pour basculer entre les aperçus 2D et 3D.
-
Mask – saisissez un nom de composant dans ce champ pour filtrer le contenu. Utilisez «
Mise en correspondance du modèle avec le symbole
Lors de l’association du modèle, les informations du composant doivent être mises en correspondance entre le schéma et le modèle cible.
Les informations propres à chaque domaine sont contenues dans des fichiers de modèles au format prédéfini, tels que les fichiers IBIS, MDL et CKT. D’autres informations sont nécessaires pour que le système puisse accéder à ces données, notamment la correspondance des broches et la netlist reliant le symbole schématique au modèle propre au domaine. Ces informations sont définies dans un éditeur de modèles spécifique au domaine, qui s’ouvre lorsqu’un modèle est ajouté ou modifié. Outre la référence au fichier de modèle, il contient également toutes les informations de correspondance des broches ou de netlist requises pour ce type de modèle.
Emplacements de recherche des fichiers de modèles
Lorsque vous ajoutez un modèle à un composant dans l’éditeur de symboles schématiques, le modèle est lié ; ses données ne sont ni copiées ni stockées dans le composant schématique. Les modèles liés doivent donc être disponibles à la fois lors de la création de la bibliothèque et lorsque le composant est placé sur une feuille de schéma. Lorsque vous travaillez dans l’éditeur de bibliothèques, le lien entre le composant et les informations du modèle est résolu à l’aide des emplacements de recherche valides suivants :
- La recherche s’effectue d’abord dans les bibliothèques incluses dans le projet de package de bibliothèques actuel.
- Elle se poursuit dans les bibliothèques PCB (et non les bibliothèques intégrées) disponibles dans la liste Installed Libraries actuelle. Remarque : l’ordre des bibliothèques de cette liste peut être modifié.
- Enfin, la recherche s’effectue dans toutes les bibliothèques de modèles situées dans les chemins de recherche du projet. Les chemins de recherche sont définis dans l’onglet Search Paths de la boîte de dialogue Project Options (Project » Project Options). Remarque : il n’est pas possible de parcourir les bibliothèques situées dans les chemins de recherche pour y localiser un modèle ; le compilateur les inclut toutefois lors de la recherche d’un modèle.
Consultez la section Gestion des bibliothèques de bases de données et de fichiers disponibles de la page Recherche de composants dans les bibliothèques de fichiers et de bases de données pour plus d’informations sur la recherche de modèles dans l’éditeur de symboles schématiques et l’éditeur de schémas.
Ajout d’une empreinte au composant schématique
Pour ajouter une empreinte au composant schématique actuel, choisissez Footprint lors de la sélection d’une option d’ajout de modèle, comme décrit ci-dessus. La boîte de dialogue PCB Model s’ouvre.

La boîte de dialogue PCB Model
Options et commandes de la boîte de dialogue PCB Model
Modèle d’empreinte
- Name – affiche le nom de l’empreinte.
- Browse – cliquez pour ouvrir la boîte de dialogue Browse Libraries afin de rechercher l’empreinte cible.
- Pin Map – cliquez pour ouvrir la boîte de dialogue Model Map afin d’établir la correspondance des broches entre le symbole schématique et l’empreinte PCB.
- Description - saisissez une description pertinente de l'empreinte.
Bibliothèque PCB
- Any - activez cette option pour rechercher l'empreinte cible dans toutes les bibliothèques actuellement disponibles.
- Library name - activez cette option pour rechercher l'empreinte cible dans la bibliothèque nommée. Saisissez directement le nom de la bibliothèque dans le champ de texte.
- Library path - activez cette option pour rechercher les empreintes cibles dans la bibliothèque nommée à l'emplacement spécifié. Cliquez sur le bouton Choose pour sélectionner un chemin.
- Use footprint from component library - cette option devient disponible lorsque le composant est placé à partir d'une bibliothèque compilée, telle qu'une bibliothèque intégrée, ou à partir d'un serveur. Si nécessaire, elle peut être remplacée pour un composant placé, afin de permettre la sélection d'une autre bibliothèque PCB source.
Empreinte sélectionnée
Cette zone affiche un aperçu de l'empreinte cible. Cliquez sur l'icône en bas à gauche de l'aperçu pour basculer entre les modes 2D et 3D. La zone d'affichage reste vide si l'empreinte est introuvable dans la bibliothèque PCB spécifiée.
En haut de la boîte de dialogue PCB Model se trouve un champ Name qui doit contenir le nom de l'empreinte. Vous pouvez saisir le nom directement ou utiliser le bouton Browse pour le rechercher dans les bibliothèques d'empreintes disponibles à l'aide de la boîte de dialogue Parcourir les bibliothèques. La liste déroulante Libraries donne accès à une liste des bibliothèques disponibles. Cliquez sur le bouton
pour ouvrir la boîte de dialogue Bibliothèques basées sur des fichiers disponibles, dans laquelle vous pouvez ajouter ou supprimer des bibliothèques. Si l'empreinte souhaitée n'est disponible dans aucune des bibliothèques actuelles, vous devrez la rechercher en utilisant le bouton Find pour ouvrir la boîte de dialogue Recherche dans les bibliothèques basées sur des fichiers.
Au bas de la boîte de dialogue PCB Model, une chaîne de texte indique où ce modèle a été trouvé.
La capacité du logiciel à trouver le modèle dépend du paramètre qui définit où il peut rechercher les modèles. Ce paramètre se trouve juste sous le nom du modèle. Les options vont de Any, qui signifie rechercher ce modèle dans toutes les bibliothèques disponibles, à Integrated Library ou Server, qui indique que le modèle ne peut être utilisé qu'à partir de la bibliothèque intégrée ou de l'espace de travail spécifié.
La boîte de dialogue PCB Model comprend les options suivantes :
Pour configurer la correspondance des broches d'une empreinte liée, cliquez sur Pin Map dans la boîte de dialogue PCB Model pour ouvrir la boîte de dialogue Model Map et apporter les modifications nécessaires aux paires broche-pastille. Notez que vous associez la propriété Designator de la broche du symbole schématique au désignateur de broche équivalent du modèle, qui, pour une empreinte PCB, est le Designator de la pastille.
- Component Pin Designator colonne - répertorie toutes les broches du symbole schématique ; ce champ n'est pas modifiable.
- Model Pin Designator colonne - répertorie les numéros des broches du modèle. Dans cet exemple, elle affiche les pastilles de l'empreinte PCB attribuée ; modifiez chacun de ces champs pour faire correspondre la pastille du PCB à la broche équivalente du symbole schématique.
Ajout d'un modèle de simulation au composant schématique
Si vous créez un nouveau composant, vous récupérerez généralement le modèle SPICE sur le site du fournisseur du composant. Pour ajouter un modèle de simulation au composant schématique actuel, choisissez Simulation lors de la sélection d'une option d'ajout de modèle, comme décrit ci-dessus. La boîte de dialogue Modèle de simulation s'ouvre. La sélection du modèle et la définition des correspondances entre les broches du symbole schématique et celles du modèle s'effectuent dans cette boîte de dialogue.
Vous pouvez également utiliser SPICE Model Wizard (Tools » XSpice Model Wizard) pour créer certains types de modèles SPICE à ajouter au composant : en savoir plus.
Ajout d'un modèle à l'étape de la schématique
À l'étape de la schématique, la conception est un ensemble de composants reliés logiquement. Pour tester ou mettre en œuvre la conception, par exemple pour la simulation du circuit, le routage du PCB, l'analyse de l'intégrité du signal, etc., il est nécessaire de la transférer vers un autre domaine de conception. Pour cela, un modèle adapté de chaque composant doit être disponible pour le domaine cible.
-
Les empreintes sont liées au composant schématique en les ajoutant dans la zone Paramètres du panneau Properties. Cliquez sur la liste déroulante Add, puis sélectionnez Footprint pour ouvrir la boîte de dialogue PCB Model afin de configurer l'empreinte.
-
Les modèles sont liés au composant schématique en les ajoutant dans la zone Paramètres du panneau Properties. Cliquez sur la liste déroulante Add , puis sélectionnez Simulation ou Ibis Model pour ouvrir la boîte de dialogue correspondante.
Utilisation des paramètres pour enrichir les informations du composant
Les paramètres des composants permettent de définir des informations supplémentaires sur le composant. Ils vous permettent de définir des informations textuelles supplémentaires à son sujet. Il peut s'agir de spécifications électriques (par exemple, la puissance ou la tolérance), de détails sur les achats ou les stocks, de notes du concepteur, de références aux fiches techniques du composant — en somme, de toute information utile : les données dont votre entreprise a besoin dans la nomenclature, les données du fabricant, une référence à la fiche technique du composant ou des instructions de conception, telles que des règles de conception ou l'affectation à une classe PCB, etc.
Les paramètres peuvent être définis dans l'éditeur de bibliothèques schématiques lors de la création du composant à l'aide du panneau Properties.
Ajout de paramètres à un composant
Pour un composant individuel, les paramètres sont ajoutés dans la zone Parameters du panneau Properties en mode Component . Comme indiqué précédemment, cela peut être effectué dans la bibliothèque ou une fois le composant placé sur la feuille schématique.
Suivez les étapes ci-dessous pour ajouter un paramètre à un composant schématique :
- Double-cliquez sur le nom du composant dans le panneau Bibliothèque SCH pour ouvrir le panneau Propriétés en mode Composant.
- Dans la zone Parameters, sélectionnez Parameter dans la liste déroulante Add.
- Saisissez le nom souhaité pour le paramètre ainsi qu'une valeur.
- Assurez-vous que l'option de visibilité du paramètre est activée si vous souhaitez que le nom et la valeur s'affichent lorsque le composant est placé sur une feuille schématique.
-
Cliquez sur Font Link et Other en bas de la zone Parameters pour accéder à des options supplémentaires de configuration des paramètres.
Ajout de paramètres à plusieurs composants
Les paramètres sont un élément essentiel de chaque composant, et il est courant que de nombreux paramètres soient utilisés pour plusieurs composants. Outre leur ajout individuel à chaque composant, vous pouvez également utiliser la commande Parameter Manager (Tools » Parameter Manager) pour les ajouter à plusieurs composants. En plus d’ajouter et de supprimer des paramètres, vous pouvez également modifier leurs valeurs sur plusieurs composants.

La boîte de dialogue Parameter Table Editor permet de modifier tous les paramètres de tous les composants.
Remarques concernant la modification de plusieurs paramètres :
- Les paramètres des composants d’une bibliothèque ou des composants utilisés dans une conception schématique peuvent être modifiés selon la même procédure. Sélectionnez Tools » Parameter Manager dans l’éditeur de schémas ou dans l’éditeur de bibliothèques de schémas pour lancer la procédure.
- Comme les paramètres peuvent être ajoutés à différents objets, la première étape consiste à sélectionner les types d’objets dont les paramètres doivent être modifiés dans la boîte de dialogue Parameter Editor Options.
- La modification des paramètres s’effectue dans la boîte de dialogue Éditeur de table des paramètres. Cette boîte de dialogue est accessible de différentes manières, son titre peut donc varier. Son utilisation reste la même, quel que soit le mode d’accès : utilisez les raccourcis de sélection standard de Windows pour sélectionner les cellules souhaitées, puis faites un clic droit et choisissez une action de modification.
- Les modifications ne sont pas appliquées immédiatement ; elles sont effectuées au moyen d’un ordre de modification technique (ECO).
- Chaque cellule en cours de modification est signalée par une petite icône colorée. Consultez la page Boîte de dialogue Éditeur de table des paramètres pour obtenir une description de chaque icône.
Association d’un paramètre au champ Commentaire du composant
Les paramètres de composant affichés par défaut sur le schéma sont le désignateur et le commentaire. Lorsque la conception est transférée de l’éditeur de schémas vers l’éditeur de PCB, les chaînes du désignateur et du commentaire sont également les chaînes par défaut qui peuvent facilement être affichées sur la carte.
Pour vous permettre d’afficher la valeur de n’importe quel paramètre de composant sur le schéma et le PCB, par exemple celle d’un paramètre nommé Capacitance, vous pouvez associer n’importe quel paramètre de composant au champ Comment du composant au moyen d’une technique appelée indirection de chaîne.
Pour cela, saisissez le nom du paramètre sous la forme =ParameterName. Par exemple, pour associer la valeur du paramètre de composant Capacitance au champ Comment du composant, saisissez la chaîne =Capacitance dans le champ Comment du panneau Properties, comme illustré ci-dessous. Une chaîne définie à l’aide de la syntaxe '=ParameterName' est appelée special string.
Les chaînes spéciales sont automatiquement converties pour l’affichage à l’écran. Si un paramètre associé en tant que chaîne spéciale n’a pas de valeur, son nom s’affiche en gris si l’option Display Names of Special Strings that have No Value Defined est activée sur la page Schéma - Édition graphique de la boîte de dialogue Preferences. Si cette option est désactivée, rien ne s’affiche.

Utilisez la fonctionnalité des chaînes spéciales pour associer n’importe quelle valeur de paramètre au Comment du composant.
Définition de liens cliquables vers des informations de référence
La zone Paramètres du panneau Properties en mode Component permet d’ajouter un lien en cliquant sur la liste déroulante Add , puis en sélectionnant Link. Cette fonctionnalité peut servir à inclure des liens vers une fiche technique ou le site web d’un fabricant, par exemple. Vous pouvez définir autant de liens que nécessaire pour un composant.
Un lien doit être configuré comme suit :
- Name - sert à définir l’entrée qui apparaît dans le menu :
-
Url - sert à définir le document cible. Les exemples suivants sont des entrées valides :
-
C:\Design_Projects\Schematics\Modifications.txt -
C:\Design_Projects\Schematics\MyDataSheet.pdf -
https://www.altium.com -
www.altium.com/documentation
-
Les liens affichés dans le panneau sont actifs : lorsque vous cliquez sur le texte du lien, l’URL s’ouvre dans votre navigateur préféré. Pour modifier un lien existant, cliquez dans la cellule en dehors du texte du lien, puis cliquez sur le bouton de modification.
Les liens sont accessibles dans le menu contextuel lorsque vous faites un clic droit sur le composant placé sur le schéma. Bien que vous puissiez définir autant de liens nommés que nécessaire, seuls les 9 premiers seront disponibles dans le menu contextuel References de l’éditeur de schémas. Les liens nommés supplémentaires n’apparaîtront pas dans le menu Reference de l’éditeur de schémas, mais ils seront inclus dans le PDF généré et y fonctionneront comme des liens actifs lorsque vous cliquerez sur le composant dans le document PDF (voir ci-dessous).
Faites un clic droit sur un composant de la feuille pour accéder à ses liens.
Après le lancement de la commande, le document cible indiqué s’ouvre. Une page web cible définie par une URL s’ouvre directement (si elle est disponible). Pour un document PDF ou texte, la recherche du document s’effectue comme suit :
-
Si un chemin est spécifié, la recherche s’effectue d’abord à cet emplacement,
-
Si le document est introuvable à cet emplacement, ou si aucun chemin n’est spécifié, la recherche s’effectue dans le dossier
\Helpde l’installation d’Altium Designer.
Vérification du composant et génération de rapports
Pour vérifier que les nouveaux composants ont été créés correctement, plusieurs rapports peuvent être générés. Veillez à enregistrer le fichier de bibliothèque avant de générer les rapports.
Liste des composants de la bibliothèque
Le Library List répertorie chaque composant et les détails correspondants du document de bibliothèque actif.
- Sélectionnez Reports » Library List.
-
Un fichier texte ASCII (<LibraryName>.rep) est généré et ouvert en tant que document actif. Ce fichier indique le nombre total de composants dans la bibliothèque et répertorie le nom de chaque composant ainsi qu'une description, si elle est disponible.
Un deuxième fichier est également créé et ouvert (<LibraryName>.csv), et référencé dans le fichier .rep. Il s'agit d'un fichier de valeurs séparées par des virgules qui contient des informations plus détaillées sur chaque composant de la bibliothèque, extraites de ses propriétés.
Rapport de bibliothèque
Vous pouvez générer un rapport à partir du document de bibliothèque actif, contenant des informations sur les composants stockés dans cette bibliothèque. Le rapport peut être configuré pour inclure des informations sur les paramètres, les broches et les modèles, ainsi que des aperçus des composants et des modèles (en couleur ou en noir et blanc). Le rapport peut être généré sous forme de document Microsoft Word (*.doc) ou de document HTML standard (*.html).
-
Sélectionnez Reports » Library Report pour ouvrir la boîte de dialogue Library Report Settings. Utilisez cette boîte de dialogue pour configurer le contenu et le style du rapport, ainsi que l'emplacement et le nom sous lequel il sera généré. Par défaut, le rapport porte le nom de la bibliothèque de schémas et est enregistré au même emplacement.
Options et commandes de la boîte de dialogue des paramètres du rapport de bibliothèque
Nom du fichier de sortie
- Output File Name - affiche le nom complet du fichier de sortie, chemin compris. Utilisez l'icône de recherche de dossier pour rechercher et sélectionner un autre emplacement et un autre nom
- Document style - l'extension du fichier sera .doc et un document au format Word sera généré pour le rapport de bibliothèque.
- Browser style - l'extension du fichier sera .html et une page Web sera générée dans un navigateur Internet. Vous pouvez modifier le nom complet du fichier de sortie si vous le souhaitez.
- Open generated report - activez cette option pour ouvrir le rapport généré dans MS Word ou dans un navigateur Internet.
- Add generated report to current project - activez cette option pour ajouter le rapport généré au projet en cours.
Inclure dans le rapport
- Component's Parameters - activez cette option pour inclure les paramètres du composant dans le rapport.
- Component's Pins - activez cette option pour inclure les broches du composant dans le rapport.
- Component's Models - activez cette option pour inclure les modèles du composant dans le rapport.
Créer des aperçus pour
- Components - activez cette option pour créer un aperçu des composants dans le rapport.
- Models - activez cette option pour créer un aperçu des modèles dans le rapport.
Paramètres
- Use Color - activez cette option pour autoriser l'utilisation d'éléments en couleur dans le rapport de bibliothèque, qu'il s'agisse d'un document Word ou Web.
-
Configurez les paramètres du rapport, puis cliquez sur OK. Si vous avez choisi d'ouvrir le rapport après sa génération, il s'ouvrira à condition que vous disposiez de Microsoft Word (pour un rapport au format Doc) ou de votre navigateur par défaut (pour un rapport au format HTML).
Si vous avez choisi d'ajouter le rapport au projet après sa génération, il apparaîtra dans le panneau Projects, sous le sous-dossier Generated\Documents (pour un rapport au format HTML) ou le sous-dossier Generated\Text Documents (pour un rapport au format Doc).
Vérificateur de règles des composants
Le Component Rule Checker recherche les erreurs telles que les doublons et les broches manquantes.
-
Sélectionnez Reports » Component Rule Check (raccourci R, R) pour ouvrir la boîte de dialogue Library Component Rule Check. Définissez les attributs à vérifier, puis cliquez sur OK.
Options et commandes de la boîte de dialogue de vérification des règles des composants de bibliothèque
Doublons
- Component Names – activez cette option pour rechercher les noms de composants en double.
- Pins – activez cette option pour rechercher les broches en double.
Éléments manquants
- Description – activez cette option pour rechercher les descriptions manquantes.
- Footprint – activez cette option pour rechercher les noms d'empreintes manquants.
- Default Designator – activez cette option pour rechercher les désignateurs par défaut manquants.
- Pin Name – activez cette option pour rechercher les noms de broches manquants.
- Pin Number – activez cette option pour rechercher les numéros de broches manquants.
- Missing Pins In Sequence – activez cette option pour rechercher les broches manquantes dans une séquence.
-
Un rapport intitulé <
libraryname.ERR> s'affiche dans l'espace de conception et répertorie tous les composants qui ne respectent pas les règles vérifiées. - Apportez les modifications nécessaires à la bibliothèque, puis générez à nouveau le rapport.
- Enregistrez la bibliothèque de schémas. Fermez le rapport pour revenir à l'espace de conception de l'éditeur de schémas.
Copie de composants depuis d'autres sources
Déplacement et copie de composants depuis d'autres bibliothèques
Vous pouvez également copier des composants dans votre bibliothèque de schémas depuis d'autres bibliothèques de schémas ouvertes, puis modifier leurs propriétés selon vos besoins. Si le composant fait partie d'une bibliothèque intégrée, vous devez ouvrir le fichier .IntLib et choisir Yes pour extraire les bibliothèques sources. Ouvrez ensuite la bibliothèque source générée (*.SchLib) depuis le panneau Projects .
-
Sélectionnez le composant à déplacer ou à copier dans la liste Design Item ID du panneau SCH Library afin qu'il s'affiche dans la fenêtre de conception.
-
Sélectionnez Tools » Move Component ou Tools » Copy Component pour ouvrir la boîte de dialogue Destination Library, qui répertorie tous les documents de bibliothèque de schémas actuellement ouverts. Toutes les bibliothèques ouvertes sont répertoriées dans cette boîte de dialogue, qu'il s'agisse de documents libres ou qu'elles fassent partie du projet en cours ou d'un autre projet ouvert.
-
Sélectionnez le document vers lequel vous souhaitez déplacer/copier le composant, puis cliquez sur OK. Le composant ou une copie de celui-ci sera placé dans la bibliothèque de destination, où vous pourrez le modifier si nécessaire.
Copie de composants à partir de schémas
Vous pouvez également copier des composants depuis des feuilles de schéma vers votre bibliothèque de schémas, puis modifier leurs propriétés selon vos besoins. Sélectionnez le composant à copier sur la feuille de schéma et copiez-le à l’aide de la commande Copy du menu contextuel du composant sélectionné (raccourci : Ctrl+C). Ouvrez ensuite la bibliothèque de schémas cible, faites un clic droit dans la zone de la liste des composants du panneau SCH Library, puis sélectionnez Paste (raccourci : Ctrl+V).
Notez que si le composant a été placé sur une feuille de schéma depuis votre espace de travail connecté ou depuis le panneau Manufacturer Part Search, un lien vers l’espace de travail source est conservé. Ces composants se distinguent par l’icône
dans le panneau SCH Library. Vous pouvez supprimer les liens vers l’espace de travail pour tous les composants de la bibliothèque ouverte en choisissant la commande Tools » Clear Server Links dans les menus principaux. Après le lancement de la commande, la boîte de dialogue Confirm Clear Vault Links s’ouvre. Cliquez sur Yes pour supprimer les liens vers l’espace de travail spécifiés dans la boîte de dialogue et enregistrer la bibliothèque ; cliquez sur No pour fermer la boîte de dialogue sans effectuer d’action.

La boîte de dialogue Confirm Clear Vault Links
Copie de plusieurs composants
Vous pouvez également utiliser le panneau SCH Library pour copier plusieurs composants. Sélectionnez les composants dans le panneau à l’aide des fonctions standard Ctrl+Click ou Shift+Click, puis faites un clic droit sur l’un des composants sélectionnés et choisissez Copy dans le menu contextuel. Vous pouvez ensuite faire un clic droit dans la liste et :
- Coller le ou les composants dans la même bibliothèque.
- Coller le ou les composants dans une autre bibliothèque ouverte.
- Copier et coller des composants d’un schéma vers une bibliothèque ouverte en utilisant la même méthode.
Déplacement d’une conception d’un emplacement à un autre
Lorsqu’un composant est placé dans une conception à partir d’une bibliothèque, il est mis en cache dans le fichier de conception afin que le document puisse toujours être ouvert à n’importe quel emplacement, sans que ses bibliothèques sources soient présentes ou chargées. Cela s’avère utile pour déplacer une conception d’un emplacement à un autre, puisqu’il n’est pas nécessaire de déplacer également les bibliothèques. Notez que le nom de la bibliothèque source d’origine et les noms des modèles sont également enregistrés dans les propriétés du composant placé.
Panneau SCH Library
Le panneau SCH Library vous permet de consulter et de modifier les composants stockés dans le document de bibliothèque de schémas actif. Il permet également de répercuter directement dans le document de conception schématique les modifications apportées aux composants de la bibliothèque, ainsi que de définir les liens vers les modèles d’un composant.

Parcourez, visualisez et modifiez de manière interactive les composants de la bibliothèque de schémas et leurs broches.
Contenu et utilisation du panneau SCH Library
Parcourir la bibliothèque
Lorsque vous cliquez sur une entrée de composant dans la liste, celui-ci devient l’élément actif dans la fenêtre de l’éditeur de conception. Cette fenêtre est modifiable : vous pouvez changer le symbole du composant et ajouter, modifier ou supprimer les modèles liés au composant selon vos besoins. La sélection d’un objet Pin dans le panneau entraîne la mise en surbrillance de l’objet graphique correspondant (et un zoom sur celui-ci) dans l’espace de travail de l’éditeur. Le panneau SCH Library offre ainsi un moyen simple et rapide de parcourir, de visualiser et d’accéder aux composants et aux broches de la bibliothèque de schémas.
Filtrage du contenu
Le contenu de la liste Components peut être filtré pour vous permettre de trouver rapidement un composant particulier dans la bibliothèque. Cette fonction est particulièrement utile si la bibliothèque contient un grand nombre d’éléments. Le filtrage peut être appliqué à l’aide de l’une des méthodes décrites dans les sections suivantes.
Filtrage indirect
Cette méthode de filtrage utilise le champ de recherche en haut du panneau pour filtrer le contenu de la liste. Un masque de nom est appliqué en fonction de la saisie dans ce champ. Seuls les composants de la liste correspondant à cette saisie restent affichés.
La fonction de filtrage ne tient pas compte de la casse et prend en charge le filtrage au fil de la saisie : le contenu de la liste Components est filtré à mesure que vous tapez.
Utilisez le caractère générique * pour un filtrage plus élaboré. Par exemple, si vous saisissez MN*, seules les empreintes de composants dont le nom commence par MN seront affichées ; de même, comme dans l’image ci-dessous, si vous saisissez *r34, seules les empreintes de composants dont le nom contient R34 seront affichées.
Filtrage direct
Cette méthode est disponible dans toutes les zones du panneau et vous permet d’accéder rapidement à une entrée en tapant directement dans la zone de la liste. Aucun masque n’est appliqué : le contenu complet de la liste reste visible en permanence.
Pour utiliser cette fonction afin de trouver rapidement une empreinte de composant, cliquez dans la section Components du panneau, puis saisissez la première lettre de l’empreinte de composant à laquelle vous souhaitez accéder. Par exemple, pour accéder rapidement aux entrées de composants commençant par la lettre R, appuyez sur R sur le clavier. Le premier composant de la liste commençant par R devient alors actif.
Si plusieurs Design Item IDs commencent par la même lettre, et en particulier si la bibliothèque est très volumineuse, saisissez des lettres supplémentaires pour cibler l’entrée souhaitée. Par exemple, saisissez res pour mettre en surbrillance le premier élément de la série RES dans la liste.
Filtrage combiné
Dans certaines situations, il peut être utile d’utiliser simultanément le filtrage indirect et le filtrage direct. Si, par exemple, vous savez que le composant recherché possède une variante de sous-type BRMZ et un préfixe AD74, ces informations peuvent être utilisées respectivement comme saisies de filtrage indirect (masque) et direct.
Sections du panneau
Composants
Lorsque vous cliquez sur une entrée de la liste Components , elle devient le composant actif dans la fenêtre de l’éditeur de conception ainsi que pour les quatre boutons situés directement sous la liste. Ces boutons donnent accès aux commandes suivantes, applicables à la liste des composants :
-
Place - cliquez pour placer le composant actif sur un document schématique. Le document schématique utilisé dépend de la présence ou non de documents schématiques ouverts.
- Si aucun document schématique n’est ouvert, un clic sur ce bouton crée un nouveau document schématique, qui devient le document actif dans la fenêtre de l’éditeur de conception. Le composant actif de la bibliothèque apparaît attaché au curseur, prêt à être placé.
- Si un ou plusieurs documents schématiques sont ouverts, le dernier document actif (quel que soit le projet auquel il appartient) devient le document actif dans la fenêtre de l’éditeur de conception et le composant actif de la bibliothèque apparaît attaché au curseur, prêt à être placé.
- Add - cliquez pour ajouter un nouveau composant au document de bibliothèque. La boîte de dialogue Nouveau composant s’ouvre. Saisissez le nom souhaité pour le nouveau composant à ajouter à la liste. Une feuille vierge s’ouvre dans la fenêtre de l’éditeur de conception pour vous permettre de définir le composant.
- Delete - cliquez pour supprimer définitivement les composants sélectionnés du document de bibliothèque. Une boîte de dialogue de confirmation s’ouvre pour vous demander si vous souhaitez poursuivre la suppression.
- Edit - cliquez pour ouvrir le panneau Propriétés, dans lequel vous pouvez consulter et modifier les propriétés associées au composant actif. Ce panneau permet de créer des liens vers de nouveaux modèles ou de modifier les modèles existants. Un double-clic sur une entrée Design Item ID ouvre également le panneau Properties.
Menu contextuel
Un clic droit sur une entrée de la liste Components ouvre un menu de commandes.
Les commandes sont les suivantes :
- Select all - sélectionnez rapidement toutes les entrées de composants de la liste.
- Update Schematic Sheets - cliquez pour répercuter toutes les modifications apportées aux composants du document de bibliothèque actif dans tous les documents schématiques ouverts. Toutes les instances des composants modifiés présentes dans ces documents seront mises à jour.
-
Model Manager - accédez à la boîte de dialogue Gestionnaire de modèles, dans laquelle vous pouvez ajouter, modifier ou supprimer des modèles pour n’importe lequel des composants de la bibliothèque active.
- Copy - placez une copie des composants sélectionnés dans le presse-papiers interne de l’éditeur de bibliothèques schématiques.
- Cut - placez une copie des composants sélectionnés dans le presse-papiers interne de l’éditeur de bibliothèques schématiques et supprimez-les définitivement de la bibliothèque. Une boîte de dialogue vous demande de confirmer la suppression.
- Paste - collez un composant du presse-papiers interne de l’éditeur de bibliothèques schématiques dans le document de bibliothèque actif.
- Delete - supprimez définitivement les composants sélectionnés du document de bibliothèque. Une boîte de dialogue vous demande de confirmer si vous souhaitez poursuivre la suppression.
Remarques
-
Les fonctions standard Ctrl+Click et Shift+Click permettent de sélectionner plusieurs entrées dans une liste.
-
Le composant actif est celui dont le symbole et les informations de modèle correspondantes sont actuellement affichés dans la fenêtre de l’éditeur de conception. Un composant peut être actif sans nécessairement être sélectionné dans la liste Components .
-
Ctrl+Click sur une entrée sélectionnée dans une liste pour la désélectionner.
-
Les raccourcis clavier Home, Down Arrow, Up Arrow et End , ainsi que les commandes First Component, Next Component, Previous Component et Last Component du sous-menu contextuel Tools de l’espace de conception, permettent d’afficher respectivement la première entrée, l’entrée suivante, l’entrée précédente et la dernière entrée d’une zone de liste.
-
Les composants à plusieurs parties apparaissent dans la liste avec une flèche à côté de leur nom. Chaque partie est répertoriée en dessous sous forme de sous-entrée.
-
Dans les sections du panneau comportant plusieurs colonnes de données, vous pouvez trier les données selon n’importe quelle colonne en cliquant sur son en-tête. Cliquez une fois pour trier par ordre croissant, puis une seconde fois pour trier par ordre décroissant.
-
Vous pouvez modifier l’ordre d’affichage des colonnes de données. Pour déplacer une colonne, cliquez sur son en-tête et faites-le glisser horizontalement jusqu’à la position souhaitée. Deux flèches de positionnement apparaissent pour indiquer une position valide.
-
Le composant que vous collez dans le document de bibliothèque actif peut provenir d’un document schématique ou d’un autre document de bibliothèque schématique.
-
Si plusieurs composants ont été copiés dans le presse-papiers depuis la conception principale dans l’éditeur de schémas, tous les composants de la sélection sont collés dans le document de bibliothèque.
-
Si le même composant est collé plusieurs fois dans la bibliothèque, ou si plusieurs nouveaux composants y sont ajoutés sans être renommés, les copies sont distinguées par les suffixes _1, _2, _3, etc.
-
Un document schématique doit être ouvert pour pouvoir répercuter les modifications apportées aux composants du document de bibliothèque.
-
Lorsqu’un nouveau document de bibliothèque schématique est créé, le panneau contient un seul composant vierge : Component_1.











