Synchronisation des données de la base de données de la chaîne d’approvisionnement vers l’espace de travail

En un coup d'œil

Maintenez les données fournisseurs de votre espace de travail en phase avec les sources internes de votre organisation grâce à la synchronisation des fournisseurs de composants personnalisés dans Altium Designer. Cet article explique comment connecter une base de données, une feuille de calcul ou un fichier CSV, associer les informations fournisseurs aux choix de composants de l’espace de travail et synchroniser les mises à jour à la demande ou selon un calendrier défini. Poursuivez votre lecture pour découvrir comment intégrer les données fournisseurs de votre entreprise à votre espace de travail.

- Apprenez à créer une configuration de synchronisation et à connecter les sources de données prises en charge.
- Découvrez comment associer les paramètres fournisseurs et les paliers tarifaires, en utilisant la référence fabricant pour relier les entrées fournisseurs aux composants de l’espace de travail.
- Découvrez comment lancer ou planifier la synchronisation et retrouver les données du fournisseur de composants personnalisé ainsi obtenues dans Altium Designer.
Approfondissez avec l'IA :

Grâce au concept de choix de pièces, les composants hébergés dans un Workspace Altium 365 ou un Workspace Enterprise Server peuvent être associés à des références de pièces réellement proposées par les fournisseurs, sur la base de la référence fabricant spécifiée. Par défaut, ces données de chaîne d’approvisionnement proviennent du service cloud Altium Parts Provider et comprennent des informations en temps réel sur les pièces des fournisseurs, telles que les niveaux de stock, les prix unitaires et les paliers tarifaires.

Pour de nombreuses organisations, toutefois, les données des fournisseurs de composants proviennent (et doivent provenir) d’un système d’entreprise interne qui fournit un ensemble propriétaire de données de fournisseurs de pièces, pouvant reposer sur une sélection strictement approuvée de fournisseurs et/ou des structures tarifaires spécifiques. Cette situation est prise en charge par la solution alternative Altium Custom Parts Provider qui, lorsqu’elle est configurée pour la synchronisation via Altium Designer, permet de faire correspondre les données fournisseurs d’une base de données spécifiée aux données de chaîne d’approvisionnement du Workspace.

À l’aide de la fonctionnalité Custom Parts Provider Synchronization d’Altium Designer, décrite ci-dessous, les données fournisseurs d’une table sélectionnée dans une base de données principale sont mises en correspondance pour constituer une source de données alternative pour les choix de pièces des composants effectués dans Altium Designer. En pratique, la configuration de correspondance que vous créez sert à synchroniser la base de données source avec les données fournisseurs du Workspace, selon un calendrier défini ou simplement à la demande. Ainsi, les mises à jour des données fournisseurs dans la base de données principale sont répercutées dans les données fournisseurs des composants correspondants du Workspace connecté.

Cette fonctionnalité permet aux entreprises qui gèrent de manière centralisée les données des fournisseurs de composants dans la base de données d’un système d’entreprise de profiter des avantages d’un Workspace Altium tout en maintenant la synchronisation avec leur système d’entreprise (PLM, PDM, ERP, etc.), ou simplement avec une base de données partagée ou un fichier CSV. En mode de synchronisation automatique, une tâche planifiée Windows met à jour les données du Workspace à partir de la base de données, indépendamment du client de conception Altium Designer.

Pour accéder aux fonctions de synchronisation des fournisseurs de pièces personnalisés dans Altium Designer, la fonctionnalité Custom Data Synchronization doit être activée dans votre installation d’Altium Designer. Cette fonctionnalité peut être activée ou désactivée après l’installation.

Pour en savoir plus sur la modification des fonctionnalités de base installées, consultez la page Installing & Managing (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Création d’une configuration de synchronisation de fournisseur de pièces personnalisé

La synchronisation des données fournisseurs de pièces entre une base de données et un Workspace s’établit en créant et en configurant un document Custom Parts Provider Synchronization Configuration (*.PrtSync) dans Altium Designer. L’interface du document et ses fonctionnalités sont similaires à celles du synchroniseur de composants. Une fois connecté à votre Workspace Altium, créez le nouveau document à l’aide de la commande de menu File » New » Custom Parts Provider Synchronization Configuration.

Ajoutez la source de données principale souhaitée à la configuration de synchronisation à l’aide du bouton , ou en faisant glisser des fichiers de données compatibles dans la zone Data Sources de l’interface. La configuration prend en charge les sources de données de paramètres de composants suivantes :

  • Fichiers de base de données Access (*.mdb, *.accdb)

  • Feuilles de calcul Excel (*.xlsx)

  • Fichiers CSV (*.csv)

  • Autres sources de données, telles que des interfaces compatibles OLE DB sur serveur (y compris les bases de données PostgreSQL), au moyen d’une chaîne de connexion propriétaire. Consultez la section Configuration de MySQL ci-dessous pour connaître la procédure de connexion ODBC à MySQL.

Pour se connecter à la base de données, le synchroniseur de fournisseurs de pièces doit avoir accès à la version 64 bits du Microsoft OLE DB Provider.

Dans l’exemple présenté ici, une base de données hébergeant les données fournisseurs de pièces (pour des composants de type diode Zener) a été ajoutée à la configuration. La base de données source (SupplierData.mdb) contient deux tables, CustomSupplierParts1 et CustomSupplierParts2, dont la première est activée pour la mise en correspondance et la synchronisation.

Mise en correspondance des paramètres des données fournisseurs

La nouvelle configuration de fournisseur de pièces personnalisé accède à la table de base de données en tant que source de données paramétriques. Lorsque la table est sélectionnée dans l’arborescence Data Sources de la configuration, ses champs peuvent être mis en correspondance avec les paramètres standard des données fournisseurs utilisés par Altium Designer et le Workspace Altium.

Notez que le paramètre clé (identifiant unique) qui relie les entrées de données fournisseurs aux composants du Workspace est le Manufacturer Part Number.

Ainsi, dans l’exemple présenté ici, un composant du Workspace dont le Manufacturer Part Number (nom) a pour valeur 1N4741A se verra proposer les données fournisseurs personnalisées issues des entrées de la base de données source dont le Part Number a pour valeur 1N4741A ; consultez la mise en correspondance des paramètres dans le panneau Properties ci-dessous.

Les paramètres des données fournisseurs sont mis en correspondance entre la base de données source et la configuration du fournisseur de pièces dans la zone Parameter Mapping du panneau Properties. Utilisez les options du menu déroulant de l’entrée Column pour choisir un paramètre de la base de données source correspondant au paramètre de données fournisseurs, ou pour exclure un paramètre de la synchronisation (<Skip>). Chaque ensemble de données de paramètres est ajouté à la liste Components Preview au fur et à mesure de leur mise en correspondance. Ces colonnes peuvent être réorganisées en faisant glisser leurs en-têtes, et activées ou désactivées à l’aide du menu Select Columns (accessible par un clic droit sur un en-tête).

Plusieurs paramètres système de données fournisseurs sont pris en charge, notamment Manufacturer Name, Manufacturer Part Number, Category, Datasheet, etc. Vous pouvez également ajouter et supprimer des paramètres personnalisés de données fournisseurs à l’aide des boutons  et  dans la zone Parameter Mapping du panneau Properties.

Les paliers de prix des composants correspondent aux quantités de composants à commander auprès d’un fournisseur pour bénéficier d’un coût unitaire réduit. Les quantités à commander sont généralement organisées par puissances de dix (10 unités, 100 unités, etc.) et sont prises en charge par les entrées de choix de pièces des données fournisseurs d’Altium.

Ces données numériques peuvent être mises en correspondance entre les entrées de la base de données source et les données fournisseurs de l’espace de travail en ajoutant des entrées Quantity de paliers de prix dans la section Price Breaks du panneau Properties (dont les quantités augmentent successivement par puissances de dix), puis en associant ces entrées aux champs appropriés de la base de données. Notez que le paramètre de coût classique unit (Price) figure dans la section générale Parameter Mapping.

Un paramètre de la base de données source associé au paramètre système de données fournisseurs Product Photo URL prend en charge un URI contenant le chemin complet d’une image. Ce chemin peut pointer vers une ressource locale (par exemple, C:\Component_Images\smd_cap.png) ou vers une ressource sur Internet (par exemple, http://my-website/images/smd_cap.png). Tous les formats d’image standard (*.bmp, *.png, *.jpeg, *.jpg, etc.) sont pris en charge.

Synchronisation de la base de données vers l’espace de travail

Une fois la configuration de la correspondance des données fournisseurs terminée, enregistrez le document de configuration du fournisseur de pièces personnalisé (File » Save), puis lancez une synchronisation des données de la base de données source vers le serveur à l’aide du bouton , ou configurez une synchronisation planifiée (). La synchronisation initiale transfère les données fournisseurs associées depuis la base de données de votre entreprise vers l’espace de travail Altium, et les cycles de synchronisation suivants mettent ces données à jour.

Des fichiers journaux de synchronisation détaillés sont disponibles dans le dossier C:\Users\Public\Documents\Altium\Logs\ComponentSync du système.

Dans l’exemple présenté ici, les données fournisseurs des diodes Zener synchronisées depuis la base de données source vers l’espace de travail deviennent disponibles sous forme de données Custom Parts Provider pour ces composants, en complément des données fournisseurs de pièces habituelles fournies par le service cloud Altium Parts Provider.

Vous pouvez le constater immédiatement dans le panneau de recherche de pièces fabricant lorsque la catégorie Custom Parts Provider est sélectionnée : celui-ci propose des solutions d’approvisionnement en composants issues du service Custom Parts Provider, synchronisées à partir de la base de données fournisseurs de votre organisation.

Les paramètres Category et Datasheet, ainsi que les paramètres personnalisés, sont pris en charge dans le panneau Manufacturer Part Search ().

Cette fonctionnalité est disponible lorsque l’option EDMS.CustomOffersMerge est activée dans la boîte de dialogue des paramètres avancés. Notez qu’elle est uniquement disponible lorsque vous êtes connecté à un espace de travail sur Altium Platform (Altium 365 Workspace, Altium Develop Workspace, Altium Agile Workspace) dans lequel BOM Portal est activé. Elle n’est pas disponible lorsque vous êtes connecté à un espace de travail Enterprise Server hébergé sur site.

Fusion des données fournisseurs

Cette fonctionnalité est disponible lorsque l’option EDMS.CustomOffersMerge est activée dans la boîte de dialogue des paramètres avancés. Notez qu’elle est uniquement disponible lorsque vous êtes connecté à un espace de travail sur Altium Platform (Altium 365 Workspace, Altium Develop Workspace, Altium Agile Workspace) dans lequel BOM Portal est activé. Elle n’est pas disponible lorsque vous êtes connecté à un espace de travail Enterprise Server hébergé sur site.

Si le nom du fabricant et la référence fabricant d’une pièce de la base de données fournisseurs que vous avez synchronisée sont identiques à ceux d’une pièce fournie par Altium Parts Provider, les données fournisseurs de votre service Custom Parts Provider configuré sont fusionnées avec celles d’Altium Parts Provider. Toutes les informations fournisseurs sont ainsi regroupées partout où les données fournisseurs (SPN) sont affichées dans l’interface utilisateur du logiciel, notamment dans le panneau Manufacturer Part Search, dans ActiveBOM et lors de l’ajout de choix de pièces.

Choix de pièces à partir des données du fournisseur personnalisé

Lorsque vous ajoutez des informations de choix de pièces aux entrées de composants dans le panneau des composants (clic droit, Operations » Create/Edit PCL), les données fournisseurs fournies par Custom Parts Provider apparaissent en haut de la liste dans la boîte de dialogue Add Part Choices, comme illustré ici pour l’entrée de diode Zener 1N4747A. L’entrée sélectionnée (en surbrillance) sera ajoutée comme choix de pièce pour le composant sélectionné dans le panneau Components.

La boîte de dialogue Add Part Choices est renseignée avec les données fournisseurs fournies par les services Parts Provider actuellement activés sur la page Catalog Management de l’espace de travail connecté (Admin » Part Providers). Les services Altium Parts Provider et Custom Parts Provider sont tous deux activés par défaut.

Comme le service Altium Parts Provider, le service Custom Parts Provider prend également en charge les données fournisseurs de plusieurs fabricants et de plusieurs fournisseurs, à partir d’entrées distinctes dans la table de la base de données source. Notez également que les données du fournisseur personnalisé incluent les informations sur les paliers de prix et les niveaux de stock synchronisées depuis la base de données source.

Outre le panneau Components présenté ici, les choix de pièces des fournisseurs de composants peuvent être associés à une référence de composant dans les interfaces suivantes d’Altium Designer :

Notez que lorsque les données fournisseurs ont été modifiées dans la base de données source, les données Custom Parts Provider de l’espace de travail intègrent ces modifications lors de la prochaine synchronisation, qu’elle soit lancée manuellement ou par un service de planification. Actualisez les vues de l’interface d’Altium Designer (répertoriées ci-dessus) à l’aide de la touche F5 ou du bouton pour afficher les données fournisseurs les plus récentes.

Synchronisation planifiée

Les configurations de synchronisation des pièces enregistrées sont paramétrées pour le traitement automatisé des données de la base de données vers l’espace de travail dans la boîte de dialogue Auto Synchronization Schedule, accessible à l’aide du bouton de l’interface principale.

La synchronisation planifiée, conforme au profil de configuration actuel, peut être définie pour s’exécuter à une heure précise chaque jour, à une heure donnée certains jours de la semaine ou lorsque vous ouvrez une session Windows. Vous pouvez également désactiver la synchronisation lorsque vous n’êtes pas connecté. Une fois vos paramètres confirmés à l’aide du bouton , la configuration est ajoutée en tant que tâche récurrente dans Windows Task Scheduler. Sélectionnez No automatic synchronization pour supprimer une planification de synchronisation existante.

La synchronisation des données de la base de données vers celles des composants peut également être exécutée manuellement depuis la ligne de commande à l’aide de l’application ComponentSync.Executor.exe, située dans le dossier \System de l’installation du logiciel. La syntaxe de la commande est ComponentSync.Executor.exe [configuration file name]. La configuration MyPrtSyncConfig de cet exemple a été exécutée dans l’image ci-dessous, à l’aide de la commande suivante :
"C:\Program Files\Altium\AD<Solution/Version>\System\ComponentSync.Executor.exe" C:\Users\Public\Documents\PrtSync\MyPrtSyncConfig.PrtSync

Selon le système d’exploitation, il peut être nécessaire de placer entre guillemets les chemins contenant des espaces (comme illustré ici).

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents