Travailler avec des directives sur un schéma
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
En un coup d'œil
- Découvrez ce que sont les directives de conception et comment elles sont utilisées lors de la saisie et de la validation des schémas.
- Comprenez quand utiliser No ERC plutôt qu’un masque de compilation pour supprimer les messages de validation indésirables.
- Découvrez comment placer, activer, désactiver et modifier les masques de compilation dans l’éditeur de schémas.
Les directives de conception sont des objets placés sur le schéma lors de la saisie de la conception. Elles permettent de spécifier des instructions à transmettre à d’autres parties du logiciel. Diverses directives de conception sont disponibles pour les deux usages suivants :
- Directives associées à la compilation automatique des documents schématiques sources.
- Directives utilisées pour transmettre au PCB des informations définies sur une feuille de schéma.
Les sections suivantes examinent plus en détail ces usages et les directives associées.
Directives liées à la compilation
Les conceptions évoluent au fil du temps et sont saisies par étapes. À mesure que chaque étape se stabilise, il est fréquent de vouloir la vérifier indépendamment du reste de la conception. La compilation d’un document schématique individuel (ou du projet entier) à différentes étapes du processus de saisie génère souvent plusieurs messages d’erreur dus à des circuits qui n’ont pas encore été saisis ou à des connexions d’interface entre des portions de circuit encore incomplètes. Ces messages n’apportent aucune information utile : ils ne font que masquer les informations pertinentes. Le moyen le plus rapide et le plus simple de supprimer ces erreurs de compilation consiste à placer des directives No ERC ou Masque de compilation.
Directive No ERC
La directive No ERC est placée sur un nœud du circuit pour supprimer tous les avertissements et/ou erreurs de violation des règles électriques détectés lors de la validation du projet schématique. Consultez la page Validation de votre projet de conception pour en savoir plus.
Directive Masque de compilation
Les directives No ERC sont idéales pour supprimer les violations concernant un petit nombre de broches, de ports, d’entrées de feuille ou de nets dans une conception. Cependant, dans certains cas, il peut être souhaitable d’exclure une section entière de la conception, composants compris. Utilisez une directive Masque de compilation (commande Place » Directives » Compile Mask) ou cliquez sur le bouton Masque de compilation dans la liste déroulante des directives de Active Bar pour masquer au compilateur la zone de conception qu’elle contient. Vous pouvez ainsi empêcher manuellement la vérification des erreurs pour des circuits encore incomplets dont vous savez qu’ils généreront des erreurs de compilation. Cela peut s’avérer très utile si vous devez compiler le document actif ou le projet pour vérifier l’intégrité de la conception dans d’autres zones spécifiques, sans être gêné par les messages du compilateur associés aux parties inachevées.
Comme son nom l’indique, cette directive demande au compilateur d’ignorer tous les objets situés completely dans les limites du masque défini. Placez le masque exactement comme vous le feriez pour une note ou un rectangle.
Prenons l’exemple du circuit schématique illustré ci-dessous, dans lequel le câblage du composant LCD1 n’est pas encore terminé. La compilation de ce seul schéma (Project » Validate PCB Project) génère de nombreux messages de violation (illustrés ci-dessous), tous dus au circuit incomplet. Survolez l’image pour voir l’effet du placement d’une directive Masque de compilation autour du circuit incomplet. Ces violations seront ignorées par le compilateur, tandis que le reste du circuit du schéma, entièrement câblé, sera vérifié. Notez que les objets réellement masqués, c’est-à-dire ceux qui se trouvent entièrement dans le rectangle délimitant le masque, apparaissent grisés.

Survolez l’image pour voir comment une directive Masque de compilation masque les violations signalées par le compilateur en raison d’un circuit incomplet.
Masque de compilation
Un masque de compilation placé, visible sur le côté gauche du schéma ci-dessus.
Résumé
Un masque de compilation est une directive de conception permettant de masquer au compilateur la zone de conception qu’il contient lors de la validation effectuée à l’aide de la commande Project » Validate Project . Il permet d’empêcher manuellement la vérification des erreurs pour des circuits encore incomplets susceptibles de générer des erreurs de validation. Le masque de compilation est utile lorsque le projet courant doit être validé pour vérifier l’intégrité de la conception dans d’autres zones spécifiques, sans être encombré par les messages du compilateur associés aux parties inachevées.
Disponibilité
Les masques de compilation peuvent être placés uniquement dans l’éditeur de schémas. Pour placer un masque de compilation :
- Cliquez sur la commande Place » Directives » Compile Mask dans les menus principaux.
- Cliquez sur le bouton Masque de compilation dans la liste déroulante des directives de Active Bar , en haut de l’espace de conception. Cliquez sur un bouton Active Bar et maintenez-le enfoncé pour accéder aux autres commandes associées. Une fois utilisée, une commande devient le premier élément de cette section de Active Bar.
- Faites un clic droit dans l’éditeur de schémas, puis cliquez sur Place » Directives » Compile Mask.
Placement
Après le lancement de la commande, le curseur prend la forme d’un réticule, indiquant que le mode de placement d’un masque de compilation est actif. Pour effectuer le placement, procédez comme suit :
- Positionnez le curseur, puis cliquez ou appuyez sur Enter pour fixer le premier coin du masque.
- Déplacez le curseur pour ajuster la taille du masque afin qu’il englobe entièrement la zone de conception à masquer au compilateur, puis cliquez ou appuyez sur Enter pour fixer le coin diagonalement opposé et terminer le placement du masque. Les objets de conception situés entièrement dans les limites du masque apparaîtront grisés.
- Continuez à placer d’autres masques de compilation, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
Modification graphique
Cette méthode de modification vous permet de sélectionner directement un masque de compilation placé dans l’espace de conception et de modifier graphiquement sa taille, sa forme ou son emplacement.
Un masque de compilation peut être affiché en mode actif (cadre complet) ou réduit (triangle encadré), qui correspondent respectivement à l’activation et à la désactivation du masque. Pour changer de mode d’affichage, cliquez sur l’icône ▲ ou ▼ dans le coin supérieur gauche d’un masque de compilation placé.
Cliquez sur le triangle dans le coin supérieur gauche pour réduire (et désactiver) un masque de compilation.
Lorsqu’un masque de compilation actif (développé) est sélectionné, les poignées de modification suivantes sont disponibles :
Un masque de compilation sélectionné (à l’état actif).
- Cliquez sur A et faites glisser pour redimensionner le masque de compilation simultanément dans les directions verticale et horizontale.
- Cliquez sur B et faites glisser pour redimensionner le masque de compilation séparément dans les directions verticale et horizontale.
- Cliquez n’importe où sur le masque de compilation – à l’écart des poignées de modification – et faites-le glisser pour le repositionner. Pendant le déplacement, le masque de compilation peut être pivoté (Spacebar/Shift+Spacebar) ou retourné par symétrie (touches X ou Y pour une symétrie selon l’axe X ou l’axe Y, respectivement).
Modification non graphique
Les méthodes de modification non graphique suivantes sont disponibles.
Modification via la boîte de dialogue Compile Mask ou le panneau Properties
Panel page: Propriétés du masque de compilation
Cette méthode de modification utilise la boîte de dialogue Compile Mask et le mode du panneau Properties associés pour modifier les propriétés d’un objet masque de compilation.
Après le placement, vous pouvez accéder à la boîte de dialogue Compile Mask en procédant comme suit :
- Double-cliquez sur l’objet masque de compilation placé.
- Sélectionnez l’objet masque de compilation, faites un clic droit, puis choisissez Properties dans le menu contextuel.
Pendant le placement, vous pouvez accéder au mode Compile Mask du panneau Properties en appuyant sur la touche Tab. Une fois le masque de compilation placé, toutes les options s’affichent.
Après le placement, vous pouvez accéder au mode Compile Mask du panneau Properties de l’une des façons suivantes :
- Si le panneau Properties est déjà actif, sélectionnez l’objet masque de compilation.
- Après avoir sélectionné l’objet masque de compilation, sélectionnez le panneau Properties à partir du bouton Panels situé en bas à droite de l’espace de conception ou en sélectionnant View » Panels » Properties dans le menu principal.
Modification de plusieurs objets
Le panneau Properties prend en charge la modification de plusieurs objets : les propriétés dont les valeurs sont identiques pour tous les objets actuellement sélectionnés peuvent être modifiées. Lorsque plusieurs objets du même type sont sélectionnés manuellement, via la boîte de dialogue Rechercher des objets similaires ou via un panneau Filtre ou Liste, toute valeur d’un champ du panneau Properties qui n’est pas représentée par un astérisque (*) peut être modifiée pour tous les objets sélectionnés.
Modification via un panneau de liste
Panel pages: Panneaux de liste, SCH Filter
Un panneau List affiche les types d’objets de conception d’un ou de plusieurs documents sous forme de tableau, ce qui permet d’inspecter et de modifier rapidement leurs attributs. Associé à un filtrage approprié – en sélectionnant les types d’objets (à l’aide des options Include du panneau) ou en utilisant le panneau Filter applicable ou la boîte de dialogue Rechercher des objets similaires – il permet de n’afficher que les objets correspondant au filtre actif. Les propriétés des objets répertoriés peuvent ensuite être modifiées directement dans le panneau List.
Propriétés du masque de compilation
Les propriétés des objets de l’éditeur de schémas sont des options configurables qui définissent le style visuel, le contenu et le comportement de l’objet placé. Les propriétés de chaque type d’objet sont définies de la manière suivante :
- Post-placement settings – toutes les propriétés de l’objet masque de compilation peuvent être modifiées dans la boîte de dialogue Compile Mask et le panneau Properties lorsqu’un masque de compilation placé est sélectionné dans l’espace de conception.
Emplacement
-
(X/Y)
- X (premier champ) - coordonnée X (horizontale) actuelle du point de référence de l’objet, par rapport à l’origine actuelle de l’espace de conception. Modifiez cette valeur pour changer la position X de l’objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent des unités par défaut actuelles.
- Y (deuxième champ) - coordonnée Y (verticale) actuelle du point de référence de l’objet, par rapport à l’origine actuelle. Modifiez cette valeur pour changer la position Y de l’objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent des unités par défaut actuelles.
Propriétés
- Width - saisissez la largeur de l’objet.
- Height - saisissez la hauteur de l’objet.
- Border - utilisez la liste déroulante pour sélectionner la bordure souhaitée.
- Fill Color - cliquez sur la case de couleur pour sélectionner la couleur souhaitée pour l’objet.
- Collapsed and Disabled - cochez la case pour replier et désactiver l’objet.
Directives relatives au PCB
En tant qu’environnement de conception unifié, Altium Designer permet de définir les exigences du PCB avant de procéder à la conception physique de la carte. Pour cela, des paramètres sont ajoutés et définis sur les objets placés sur les feuilles de schéma.
Pour certains objets de conception schématique – tels que les composants, les symboles de feuille, les ports, etc. – cela consiste à ajouter les paramètres appropriés aux propriétés de l’objet. Pour les objets de connexion tels que les fils et les bus, les paramètres ne peuvent pas être ajoutés directement en tant que propriétés du fil ou du bus. Les paramètres nécessaires pour stocker ces informations sont donc définis à l’aide de directives de conception dédiées.
Les informations suivantes peuvent être définies à l’aide de directives et seront transférées vers les définitions correspondantes du PCB lors de la synchronisation de la conception :
- Contraintes de conception physique du PCB
- Paires différentielles
- Classes de nets
En incluant des directives de conception dans le schéma, les ingénieurs peuvent spécifier des contraintes de conception explicites et garantir que le schéma reste la référence principale de la conception. Toute modification de la conception est alors effectuée uniquement dans le schéma, puis transférée au PCB. Cela peut s'avérer particulièrement important lorsque plusieurs personnes travaillent sur la conception, surtout si elles se trouvent dans des lieux différents. Plutôt que de communiquer par de longues chaînes d'e-mails ou par téléphone, la personne chargée de la saisie du schéma peut s'assurer que les contraintes spécifiées sont effectivement prises en compte lors du placement et du routage.
Au cœur de cette fonctionnalité se trouve la directive d'ensemble de paramètres.
Il s'agit essentiellement d'objets d'ensemble de paramètres définis par l'utilisateur, qui peuvent être associés à un objet de type net dans un schéma. Placez une directive de placement et de routage du PCB sur un fil, un bus ou un faisceau de signaux pour définir une ou plusieurs contraintes de conception s'appliquant aux nets associés. Lorsqu'un PCB est créé à partir du schéma, les informations contenues dans cette directive servent à créer les règles de conception PCB correspondantes. Les informations spécifiées par une directive de placement et de routage du PCB s'appliquent uniquement au net, ou à l'ensemble de nets, auquel la directive est connectée.

Une directive d'ensemble de paramètres.
Elle sert de conteneur pour un nombre quelconque de paramètres s'appliquant au net auquel elle est rattachée. Vous pouvez placer une directive d'ensemble de paramètres par défaut, sans aucun paramètre (Place » Directives » Parameter Set), puis ajouter les paramètres appropriés ultérieurement. Les sections suivantes présentent plus en détail l'utilisation de ces directives basées sur des paramètres. Des directives d'ensemble de paramètres définies par l'utilisateur (ensemble de paramètres) et prédéfinies (paire différentielle) sont disponibles. La seule différence entre un ensemble de paramètres vide et un ensemble prédéfini est que les ensembles prédéfinis contiennent déjà un paramètre, comme décrit ci-dessous.
Ensemble de paramètres
Présentation
Un ensemble de paramètres est une directive de conception permettant d'associer des spécifications de conception à un objet de type net dans un schéma. Par exemple, vous pouvez utiliser un ensemble de paramètres pour déclarer que deux nets constituent une paire différentielle. Le logiciel se base sur la présence de paramètres portant des noms spécifiques dans l'ensemble de paramètres pour déterminer quelle directive de conception vous placez.
Disponibilité
Les ensembles de paramètres peuvent être placés uniquement dans l'éditeur de schémas. Des directives d'ensemble de paramètres par défaut (vides) et prédéfinies (paire différentielle) sont disponibles. La seule différence entre un ensemble de paramètres vide et un ensemble prédéfini est que les ensembles prédéfinis contiennent déjà un paramètre, comme décrit ci-dessous.
Accédez aux commandes correspondantes depuis le menu principal Place comme suit :
| • | Place » Directives » Parameter Set | |
| • | Place » Directives » Differential Pair | |
Placement
Un ensemble de paramètres permet d'associer des paramètres à un :
- Fil
- Bus
- Faisceau de signaux
- Symbole de feuille
Après le lancement de la commande, le curseur prend la forme d'un réticule et vous passez en mode de placement de directive de conception. Pour effectuer le placement, procédez comme suit :
- Positionnez le curseur sur un fil ou un autre objet de type net, puis cliquez ou appuyez sur Enter pour placer la directive.
- Continuez à placer d'autres directives, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
Pendant le placement, lorsque l'ensemble de paramètres est encore attaché au curseur, vous pouvez également effectuer les actions suivantes :
-
Appuyez sur la touche Tab pour suspendre le placement et accéder au mode Ensemble de paramètres du panneau Properties, où vous pouvez modifier ses propriétés à la volée. Cliquez sur le bouton de pause superposé dans l'espace de conception pour reprendre le placement.
-
Appuyez sur la touche Alt pour limiter le déplacement à l'axe horizontal ou vertical, selon la direction initiale du mouvement.
-
Appuyez sur Spacebar pour faire pivoter l'arc dans le sens antihoraire ou sur Shift+Spacebar pour le faire pivoter dans le sens horaire. Cette action peut également être effectuée pendant le déplacement de l'objet. La rotation s'effectue par incréments de 90°.
-
Appuyez sur les touches X ou Y en mode de placement pour retourner l'ensemble de paramètres selon l'axe X ou Y.
Modification graphique
Cette méthode de modification vous permet de sélectionner une directive d'ensemble de paramètres déjà placée directement dans l'espace de conception, puis de modifier graphiquement sa position ou son orientation.
Lorsqu'une directive d'ensemble de paramètres est sélectionnée dans l'espace de conception, un cadre en pointillés apparaît autour d'elle. Ce cadre entoure uniquement la zone occupée par la directive. Pour chaque paramètre de l'ensemble dont la visibilité est activée, une ligne en pointillés relie le champ de texte du paramètre au corps de la directive, confirmant ainsi leur association :
Cliquez n’importe où à l’intérieur du cadre en pointillés, puis faites glisser l’ensemble de paramètres pour le repositionner selon vos besoins. Pendant le déplacement, vous pouvez faire pivoter l’ensemble de paramètres (Spacebar/Shift+Spacebar) ou lui appliquer une symétrie (touches X ou Y pour une symétrie selon l’axe X ou Y).
La taille des champs de texte de l’ensemble de paramètres (qui peuvent être modifiés graphiquement indépendamment de la directive parente) ne peut être ajustée qu’en modifiant l’option Style sur la page Schématique – Valeurs par défaut de la boîte de dialogue Preferences. Par conséquent, aucune poignée de modification n’est disponible lorsque l’un de ces objets est sélectionné.
Cliquez n’importe où à l’intérieur du cadre en pointillés, puis faites glisser l’objet texte pour le repositionner selon vos besoins. Pendant le déplacement, vous pouvez faire pivoter l’objet texte (Spacebar/Shift+Spacebar) ou lui appliquer une symétrie (touches X ou Y pour une symétrie selon l’axe X ou Y).
Si l’option Enable In-Place Editing est activée sur la page Schématique – Général de la boîte de dialogue Preferences, vous pouvez modifier la valeur d’un paramètre directement dans l’espace de conception (à l’exception des paramètres ajoutés en tant que règles). Sélectionnez l’objet texte, puis cliquez une fois pour activer cette fonctionnalité. Saisissez la nouvelle valeur souhaitée, puis cliquez en dehors de l’objet texte ou appuyez sur Enter pour appliquer la modification.
Modification non graphique
Les méthodes de modification non graphique suivantes sont disponibles.
Modification via la boîte de dialogue Ensemble de paramètres ou le panneau Propriétés
Panel page: Propriétés de l’ensemble de paramètres
Cette méthode de modification utilise la boîte de dialogue Parameter Set associée et le mode Properties du panneau pour modifier les propriétés d’un objet ensemble de paramètres.

La boîte de dialogue Parameter Set sur la première image et le mode Parameter Set du panneau Propriétés sur la seconde image
Après le placement, vous pouvez accéder à la boîte de dialogue Parameter Set en :
- Double-cliquant sur l’objet ensemble de paramètres placé.
- Positionnant le curseur sur l’objet ensemble de paramètres, en cliquant avec le bouton droit, puis en choisissant Properties dans le menu contextuel.
Pendant le placement, vous pouvez accéder au mode Parameter Set du panneau Properties en appuyant sur la touche Tab. Une fois l’ensemble de paramètres placé, toutes les options s’affichent.
Après le placement, vous pouvez accéder au mode Parameter Set du panneau Properties de l’une des façons suivantes :
- Si le panneau Properties est déjà actif, sélectionnez l’objet ensemble de paramètres.
- Après avoir sélectionné l’objet ensemble de paramètres, sélectionnez le panneau Properties à partir du bouton Panels situé en bas à droite de l’espace de conception, ou sélectionnez View » Panels » Properties dans le menu principal.
Modification de plusieurs objets
Le panneau Properties permet de modifier plusieurs objets à la fois : les propriétés dont les valeurs sont identiques pour tous les objets actuellement sélectionnés peuvent être modifiées. Lorsque plusieurs objets du même type sont sélectionnés manuellement, via la boîte de dialogue Rechercher des objets similaires ou via un panneau de filtrage ou de liste, toute valeur de champ du panneau Properties qui n’est pas représentée par un astérisque (*) peut être modifiée pour l’ensemble des objets sélectionnés.
Modification via un panneau de liste
Panel pages: Panneaux de liste, Filtre SCH
Un panneau List permet d’afficher les objets de conception d’un ou de plusieurs documents sous forme de tableau, afin d’examiner et de modifier rapidement leurs attributs. Associé à un filtrage approprié, à l’aide du panneau Filter correspondant ou de la boîte de dialogue Rechercher des objets similaires, il permet de n’afficher que les objets correspondant au filtre actif. Vous pouvez ainsi cibler et modifier plusieurs objets de conception avec davantage de précision et d’efficacité.
Remarques
- Lors du placement d’une directive d’ensemble de paramètres par défaut, aucun paramètre n’est défini. Une fois la directive placée, ajoutez-y les paramètres appropriés dans la section Parameters du panneau Properties .
- Une directive d’ensemble de paramètres permet d’affecter des informations de conception du PCB à un net du schéma. Lorsqu’un PCB est créé à partir du schéma, les informations de l’ensemble de paramètres servent à créer les règles de conception PCB correspondantes. Les informations définies par une directive d’ensemble de paramètres ne s’appliquent qu’aux nets auxquels elle est connectée.
- Lorsqu’une directive d’ensemble de paramètres est ajoutée à un net, les champs Power Net et High Speed sont disponibles dans le panneau Properties du net. Lors de la mise à jour du document PCB à partir des schémas, l’ajout de la règle de conception Nets d’alimentation est proposé pour chaque net dont le paramètre Power Net est activé.
- Les directives de classe de nets permettent de créer des classes de nets définies par l’utilisateur sur le schéma. Lorsqu’un PCB est créé à partir du schéma, les informations d’une directive de classe de nets servent à créer la classe de nets correspondante sur le PCB. Pour intégrer un net à une classe de nets, associez au fil ou au bus concerné une directive d’ensemble de paramètres et une classe portant le nom de la classe souhaitée. L’option Generate Net Classes (pour les classes définies par l’utilisateur) doit être activée sur l’onglet Class Generation de la boîte de dialogue Options du projet pour utiliser cette fonctionnalité.
- Si une directive de classe de nets a été définie pour un net, toutes les règles de conception de PCB également créées par cet objet d’ensemble de paramètres auront pour portée la classe de nets lorsque la conception sera transférée vers l’éditeur de PCB.
- Vous pouvez créer une directive de classe de nets à partir de la directive d’ensemble de paramètres placée en ajoutant une classe dont la valeur doit correspondre à la classe de nets requise pour le PCB.
-
Une couverture, associée à une directive d’ensemble de paramètres, peut également servir à appliquer des classes de composants et des paramètres aux composants entièrement inclus dans la zone qu’elle délimite. Pour ce faire, utilisez les options Component Class et Parameter du menu déroulant du bouton Add dans les propriétés de la directive d’ensemble de paramètres associée à la couverture. Les informations relatives à la classe de composants et aux paramètres seront transférées vers le document PCB du projet au cours du processus ECO lors de la mise à jour du PCB.
Propriétés de l’ensemble de paramètres
Les propriétés des objets de l’éditeur de schémas sont des options configurables qui définissent le style visuel, le contenu et le comportement de l’objet placé.
Les propriétés de chaque type d’objet sont définies de deux manières différentes :
-
Pre-placement settings – la plupart des propriétés de l’objet Ensemble de paramètres, ou celles qui peuvent logiquement être prédéfinies, sont disponibles sous forme de réglages par défaut modifiables sur la page Schéma – Valeurs par défaut de la boîte de dialogue Preferences (accessible via le bouton
situé en haut à droite de l’espace de conception). Sélectionnez l’objet dans Primitive List pour afficher ses options sur la droite.
-
Post-placement settings – toutes les propriétés de l’objet Ensemble de paramètres peuvent être modifiées dans les boîtes de dialogue Parameter Set et dans le panneau Properties lorsqu’un ensemble de paramètres est sélectionné dans l’espace de conception.
Emplacement
-
(X/Y)
- X (premier champ) – la coordonnée X (horizontale) actuelle du point de référence de l’objet, par rapport à l’origine actuelle de l’espace de conception. Modifiez-la pour changer la position X de l’objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent des unités par défaut actuelles.
- Y (deuxième champ) – la coordonnée Y (verticale) actuelle du point de référence de l’objet, par rapport à l’origine actuelle. Modifiez-la pour changer la position Y de l’objet. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent des unités par défaut actuelles.
- Rotation – utilisez le menu déroulant pour sélectionner la rotation.
Propriétés
- Label – le libellé de l’ensemble de paramètres. Modifiez-le si nécessaire.
- Style – utilisez le menu déroulant pour sélectionner le style. Cliquez sur la case de couleur pour ouvrir un menu déroulant permettant de sélectionner la couleur par défaut.
Paramètres
- Grid – répertorie les Name et Value des paramètres associés au paramètre actuellement sélectionné. Une fois les paramètres ajoutés, les champs Name et Value peuvent être modifiés. Vous pouvez nommer le Value en cliquant sur le champ et en saisissant le texte souhaité. Le champ Name ne peut être modifié que dans le mode Properties du panneau de l’objet Ensemble de paramètres, à l’aide de Ctrl+Click. Cette méthode ouvre le mode Parameter du panneau Properties, dans lequel vous pouvez saisir le nom souhaité dans le champ Name. Utilisez l’icône de cadenas pour verrouiller ou déverrouiller un paramètre de la liste. Utilisez l’icône en forme d’œil pour afficher ou masquer le paramètre. Vous pouvez afficher tous les paramètres, certains paramètres ou aucun paramètre dans cette zone en activant ou désactivant le bouton All et les boutons individuels des paramètres. Les paramètres sont désactivés lorsque leurs boutons respectifs sont gris et activés lorsqu’ils sont bleus.
-
Add – utilisez le menu déroulant pour ajouter un type de classe :
-
Net Class – sélectionnez cette option pour ajouter une nouvelle classe de nets.
- Component Class – sélectionnez cette option pour ajouter une nouvelle classe de composants. Cette option est accessible uniquement dans la variante Ensemble de paramètres de la boîte de dialogue Parameter Set ou du panneau Properties.
-
Diff. Pair Net Class – sélectionnez cette option pour ajouter une nouvelle classe de nets de paires différentielles. Cette option est accessible uniquement dans la variante Paire différentielle de la boîte de dialogue Parameter Set ou du panneau Properties.
-
Parameter – sélectionnez cette option pour ajouter un nouveau paramètre.
-
Rule – cliquez pour ouvrir la boîte de dialogue Select Design Rule Type, dans laquelle vous pouvez sélectionner le type d’une nouvelle règle Après avoir choisi un type de règle et cliqué sur
, la boîte de dialogue Edit PCB Rule (From Schematic) s’ouvre pour vous permettre de modifier la nouvelle règle si nécessaire.
-
Cliquez sur l’icône de crayon pour ouvrir la boîte de dialogue Edit PCB Rule (From Schematic) et modifier l’élément sélectionné. Cliquez sur
pour supprimer l’élément sélectionné.
- Font Settings – cliquez sur la police affichée pour modifier le style de police. Cette option n’est disponible qu’après l’ajout d’une classe de nets, d’une classe de nets de paires différentielles, d’un paramètre ou d’une règle.
-
Other – si une classe de nets, une classe de nets de paires différentielles, un paramètre ou une règle a été ajouté, cliquez pour ouvrir un menu déroulant permettant de modifier des options supplémentaires :
- Show Parameter Name – activez cette option pour afficher le nom du paramètre.
- Allow Synchronization with Database – activez cette option pour synchroniser avec la base de données.
- X/Y – saisissez les coordonnées X et Y.
- Rotation – utilisez la liste déroulante pour sélectionner la rotation.
- Autoposition – cochez cette case pour activer le positionnement automatique.
Placement de directives de jeu de paramètres
Placez une directive de ce type en choisissant la commande Place » Directives » Parameter Set dans le menu principal ou dans le menu contextuel accessible par un clic droit dans l’espace de conception. Lors du placement d’une directive de jeu de paramètres par défaut, aucun paramètre n’est encore défini. Un jeu de paramètres est une directive de conception qui permet d’associer des spécifications de conception à un objet de type net dans un schéma. Par exemple, utilisez un jeu de paramètres pour déclarer que deux nets constituent une paire différentielle. Le logiciel s’appuie sur la présence de paramètres portant des noms spécifiques dans le jeu de paramètres pour déterminer quelle directive de conception vous placez.
Outre les directives de paramètres définies par l’utilisateur, une directive de paramètre basée sur une règle se définit dans la boîte de dialogue Choose Design Rule Type, accessible depuis le mode Properties du panneau associé au paramètre. Pour y accéder, procédez comme suit :
-
Appuyez sur
Tabavant de placer le jeu de paramètres ou double-cliquez sur une directive de jeu de paramètres déjà placée pour afficher ses propriétés dans le panneau Properties. -
Ensuite, cliquez sur le bouton
dans la zone Parameters du panneau Properties et choisissez Rule dans la liste déroulante pour sélectionner une règle dans la boîte de dialogue Select Design Rule Type.

Modification de la valeur d’une règle.
Utilisez la boîte de dialogue Select Design Rule Type pour sélectionner le type de règle que vous souhaitez ajouter à la directive en tant que paramètre de règle. Double-cliquez sur un type de règle pour accéder à la boîte de dialogue Edit PCB Rule (From Schematic) correspondante, dans laquelle vous pouvez définir les contraintes de la règle.

Définition des contraintes d’une règle sélectionnée.
L’entrée de la zone Parameters indique le type de règle choisi ainsi que les contraintes spécifiées. L’image suivante illustre les paramètres de règle de contrainte de largeur définis pour une directive Parameter Set. Pour afficher la règle dans l’espace de conception, cliquez sur l’icône de visibilité dans la zone Rules.

Plusieurs contraintes de règle définies pour un net donné à l’aide d’une directive de jeu de paramètres.
Lors du transfert de la conception vers le PCB par le processus de synchronisation, les règles de conception correspondantes sont créées à partir des informations contenues dans une directive. Le mot Schematic est utilisé dans le nom de chaque règle générée pour en identifier la source.

Règles de conception générées côté PCB.
Placement de directives de classe de nets
Une directive de classe de nets vous permet de créer des classes de nets définies par l’utilisateur dans le schéma. Vous pouvez placer une directive de classe de nets en choisissant la commande Place » Directives » Parameter Set dans les menus principaux, puis en définissant le jeu de paramètres comme une directive de classe de nets, comme indiqué dans le conseil n° 2 de la page de la commande. Lorsqu’un PCB est créé à partir du schéma, les informations d’une directive de classe de nets servent à créer la classe de nets correspondante sur le PCB. Pour ajouter un net à une classe de nets, associez une directive de classe de nets au fil, au bus ou au faisceau de signaux concerné, puis attribuez au paramètre ClassName de la directive le nom de la classe souhaitée. L’option Generate Net Classes (pour les classes définies par l’utilisateur) doit être activée dans l’onglet de génération des classes de la boîte de dialogue des options du projet pour utiliser cette fonctionnalité.
Si une directive de classe de nets a été définie pour un net, toutes les règles de conception de PCB également créées par cet objet de jeu de paramètres auront pour portée la classe de nets lors du transfert de la conception vers l’éditeur de PCB. Vous pouvez créer une directive de classe de nets à partir d’une directive de jeu de paramètres déjà placée en ajoutant une classe dont la valeur doit être définie sur la classe de nets PCB requise.
Exigences importantes concernant les options du projet
Pour garantir que les jeux de paramètres définis dans le schéma sont propagés au PCB, les options suivantes doivent être configurées dans la boîte de dialogue Options for PCB Project :
- Activez l’option Generate Net Classes située dans la zone User-Defined Classes de l’onglet de génération des classes de la boîte de dialogue.
-
Dans l’onglet du comparateur de la boîte de dialogue, définissez le mode de vérification Differences Associated with Nets » Extra Net Classes sur
Find Differences.

Pour propager les directives de jeu de paramètres au PCB, deux options du projet doivent être configurées. Tout d’abord, activez l’option Generate Net Classes dans l’onglet Class Generation. Survolez l’image pour afficher l’onglet Comparator, dans lequel vous devrez définir l’option Extra Net Classes sur Find Differences.
Lors du transfert de la conception vers le PCB par le processus de synchronisation, les classes de nets correspondantes sont créées à partir des informations contenues dans une directive.
Placement de directives de couverture
Les directives de jeu de paramètres ne peuvent cibler que le net auquel elles sont rattachées, mais lorsqu’elles sont associées à une directive de couverture, leur portée peut être étendue à tous les nets situés dans cette couverture.
Placez une directive de ce type en choisissant la commande Place » Directives » Blanket dans les menus principaux. Lors du placement d’une couverture, vous pouvez définir une forme rectangulaire simple ou une forme polygonale. Cette dernière permet de contrôler plus précisément les objets de net à couvrir sur une feuille.
La couverture identifie les nets concernés : placez une directive Parameter Set n’importe où sur son contour pour appliquer les exigences de conception à ces nets. Pour qu’une directive placée sur le contour s’applique à un net sous une directive de couverture, un objet associé à ce net — une broche, un port, une étiquette de net, un port d’alimentation, un segment de fil, de bus ou de faisceau (y compris ses deux extrémités) — doit se trouver dans les limites de la couverture. Notez que, pour les identifiants de net tels que les étiquettes de net, le point d’ancrage doit se trouver dans la couverture. Si les nets membres ne sont pas transférés dans le jeu de paramètres du PCB comme prévu, essayez d’ajuster la zone de la couverture en conséquence.

Exemple d’utilisation d’une directive de couverture pour appliquer une directive de jeu de paramètres aux nets situés dans la couverture.
Voici quelques exemples d’utilisation d’une directive de couverture :
- Rattacher une directive de jeu de paramètres à un objet de couverture afin d’appliquer ses paramètres de règle à chaque net couvert par cet objet.
- Rattacher une directive de jeu de paramètres à un objet de couverture pour créer un jeu de paramètres dont les membres sont les nets individuels couverts par cet objet.
- Rattacher une directive de paire différentielle à un objet de couverture pour créer des objets de paire différentielle à partir des nets différentiels situés dans les limites de cette couverture.
Une couverture, associée à une directive de jeu de paramètres, peut également servir à appliquer des classes de composants et des paramètres aux composants entièrement compris dans la zone qu’elle définit. Pour ce faire, utilisez les options Component Class et Parameter du menu déroulant du bouton Add dans les propriétés de la directive de jeu de paramètres rattachée à la couverture. Les informations relatives à la classe de composants et au paramètre seront transférées au document PCB du projet pendant le processus ECO, lors de la mise à jour du PCB.
Couverture
Une couverture rectangulaire et une couverture polygonale, chacune avec une directive rattachée
Résumé
Une couverture est un objet de directive de groupe, de forme rectangulaire ou polygonale, placé sur un ensemble de nets et/ou de composants. Une directive (objet Jeu de paramètres) appliquée à la couverture s’appliquera alors à tous les nets et composants qu’elle couvre. Lors du placement d’une couverture, vous pouvez définir une forme rectangulaire simple ou une forme polygonale. Cette dernière permet de contrôler plus précisément les objets de net à couvrir sur une feuille.
La couverture s’applique à tous les nets qui :
- se trouvent entièrement dans la zone définie par la couverture, ou
- possèdent au moins un sommet d’extrémité connecté du fil, du bus ou du faisceau sous la couverture, ou
- possèdent une étiquette de net rattachée au fil, au bus ou au faisceau, cette étiquette se trouvant sous la couverture.
Pour les composants, la couverture s’applique à tous ceux qui se trouvent dans la zone qu’elle définit.
Une directive appliquée au contour de la couverture (Place » Directive), telle qu’une directive d’exclusion ERC, de paire différentielle ou de jeu de paramètres de règle/classe spécifique, s’appliquera à tous les nets et composants pris en compte par l’objet de couverture. Les couvertures peuvent être désactivées et masquées.
Disponibilité
Les couvertures ne peuvent être placées que dans l’éditeur de schémas. Pour placer une couverture :
- Cliquez sur Place » Directives » Blanket dans les menus principaux.
- Cliquez sur le bouton Couverture dans le menu déroulant des directives de la Active Bar située en haut de l’espace de conception. Cliquez sur un bouton Active Bar et maintenez-le enfoncé pour accéder aux autres commandes associées. Une fois qu’une commande a été utilisée, elle devient l’élément affiché en tête de cette section de la Active Bar.
- Faites un clic droit dans l’éditeur de schémas, puis cliquez sur Place » Directives » Blanket.
Placement
Pour placer une couverture rectangulaire :
- Lancez la commande comme indiqué ci-dessus.
- Positionnez le curseur, puis cliquez ou appuyez sur Enter pour placer le coin supérieur gauche.
- Positionnez le curseur, puis cliquez ou appuyez sur Enter pour placer le coin inférieur droit.
- Faites un clic droit ou appuyez sur Enter pour terminer le placement.
- Continuez à placer d’autres couvertures ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
Pour placer une couverture polygonale :
- Lancez la commande de placement.
- Positionnez le curseur, puis cliquez ou appuyez sur Enter pour ancrer le point de départ de la couverture.
- Positionnez le curseur, puis cliquez ou appuyez sur Enter pour ancrer une série de segments définissant la forme de la couverture.
- Après avoir placé le dernier segment, faites un clic droit ou appuyez sur Esc pour terminer le placement. Il n’est pas nécessaire de « fermer » le polygone : le logiciel complétera automatiquement la forme en ajoutant les segments nécessaires pour relier le point de départ au dernier segment placé.
- Continuez à placer d’autres couvertures ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
Les actions supplémentaires suivantes peuvent être effectuées pendant le placement des segments de la couverture :
- Appuyez sur la touche Tab pour suspendre le placement et accéder au mode Blanket du panneau Propriétés, dans lequel vous pouvez modifier les propriétés de ligne à la volée. Cliquez sur le bouton de pause superposé dans l’espace de conception pour reprendre le placement.
- Appuyez sur Spacebar pour changer l’orientation du coin d’un segment non encore validé.
- Appuyez sur Backspace pour supprimer le segment précédemment validé lors de la définition d’une forme polygonale pour le Blanket. L’utilisation répétée de Backspace supprimera les segments précédents dans l’ordre.
Modification graphique
Cette méthode de modification vous permet de sélectionner directement un objet Blanket placé dans l’espace de conception et de modifier graphiquement sa taille, sa forme ou sa position. Lorsqu’un objet Blanket est sélectionné, les poignées de modification suivantes sont disponibles :
Blankets rectangulaire et polygonal sélectionnés, avec leurs poignées de modification graphique.
Cliquez sur une poignée de modification au centre d’un segment et faites-la glisser pour déplacer ce bord du Blanket.
Pour un Blanket rectangulaire, cliquez sur une poignée de modification située dans un angle et faites-la glisser pour le redimensionner simultanément dans les directions verticale et horizontale.
Cliquez n’importe où sur le contour du Blanket à l’écart des poignées de modification et faites-le glisser pour le repositionner. Le Blanket peut être pivoté ou retourné pendant le déplacement :
- Appuyez sur Spacebar pour faire pivoter le Blanket dans le sens antihoraire autour de la position du curseur. Shift+Spacebar fait pivoter le Blanket dans le sens horaire autour du curseur. La rotation s’effectue par incréments de 90°.
- Appuyez sur les touches X ou Y pour retourner le Blanket selon l’axe X ou Y, par rapport à la position du curseur.
Modification non graphique
Les méthodes de modification non graphique suivantes sont disponibles.
Modification via la boîte de dialogue Blanket ou le panneau Properties
Panel page: Propriétés du Blanket
Cette méthode de modification utilise le mode boîte de dialogue Blanket et le mode panneau Properties associés pour modifier les propriétés d’un objet Blanket.
La boîte de dialogue Blanket , à gauche, et le mode Blanket du panneau Properties, à droite
Après le placement, la boîte de dialogue Blanket est accessible :
- En double-cliquant sur l’objet Blanket placé.
- En plaçant le curseur sur l’objet Blanket, en cliquant avec le bouton droit, puis en choisissant Properties dans le menu contextuel.
Pendant le placement, le mode Blanket du panneau Properties est accessible en appuyant sur la touche Tab. Une fois le Blanket placé, toutes les options s’affichent.
Après le placement, le mode Blanket du panneau Properties est accessible de l’une des façons suivantes :
- Si le panneau Properties est déjà actif, en sélectionnant l’objet Blanket.
- Après avoir sélectionné l’objet Blanket, sélectionnez le panneau Properties à l’aide du bouton Panels situé dans la partie inférieure droite de l’espace de conception ou en sélectionnant View » Panels » Properties dans le menu principal.
Modification de plusieurs objets
Le panneau Properties prend en charge la modification de plusieurs objets : les paramètres de propriété identiques pour tous les objets actuellement sélectionnés peuvent être modifiés. Lorsque plusieurs objets du même type sont sélectionnés manuellement, via la boîte de dialogue Rechercher des objets similaires ou via un panneau Filter ou List, toute valeur de champ du panneau Properties qui n’est pas affichée sous forme d’astérisque (*) peut être modifiée pour tous les objets sélectionnés.
Modification via un panneau List
Panel pages: Panneaux List, SCH Filter
Un panneau List affiche les types d’objets de conception d’un ou de plusieurs documents sous forme de tableau, ce qui permet d’inspecter et de modifier rapidement les attributs des objets. Utilisé conjointement avec un filtrage approprié — en sélectionnant les types d’objets (à l’aide des options Include du panneau), ou en utilisant le panneau Filter approprié ou la boîte de dialogue Rechercher des objets similaires — il permet de n’afficher que les objets correspondant au filtre actif. Les propriétés des objets répertoriés peuvent ensuite être modifiées directement dans le panneau List.
Prise en charge du filtrage
Deux mots-clés particulièrement utiles permettent de cibler les objets Blanket à l’aide d’expressions de requête logiques. Ils complètent les autres mots-clés permettant de cibler un Blanket en fonction de ses propriétés.
-
Collapsed– l’objet est réduit (également utile pour cibler les objets Compile Mask). Ce mot-clé se trouve dans la catégorie SCH Functions - Fields lorsque vous utilisez l’Assistant de requête. -
IsBlanket– vérifie si l’objet est un Blanket. Ce mot-clé se trouve dans la catégorie SCH Functions - Object Type Checks lorsque vous utilisez l’Assistant de requête.
Créez des expressions logiques de requête pour cibler et renvoyer les Blankets de votre conception selon vos besoins. Voici quelques exemples d’expressions de requête logiques ciblant les Blankets :
IsBlanket And Collapsed – cible tous les objets Blanket actuellement réduits.
IsBlanket And Not Collapsed – cible tous les objets Blanket qui ne sont pas actuellement réduits.
Désactivation d’un Blanket
Une fois placés, les Blankets peuvent être temporairement désactivés en cliquant sur le petit triangle situé en haut à gauche Cliquez une fois pour désactiver et masquer le Blanket ; cliquez à nouveau pour le réactiver. Cela permet de contrôler facilement l’effet du Blanket sans devoir le supprimer complètement de la conception.
Propriétés de la zone Blanket
Les propriétés des objets de l’éditeur de schémas sont des options configurables qui définissent le style visuel, le contenu et le comportement de l’objet placé. Les paramètres de propriétés de chaque type d’objet sont définis de deux manières différentes :
-
Pre-placement settings – la plupart des propriétés de l’objet Blanket, ou celles qui peuvent logiquement être prédéfinies, sont disponibles sous forme de paramètres par défaut modifiables sur la page Schematic - Defaults de la boîte de dialogue Preferences (accessible à partir du bouton
en haut à droite de l’espace de conception). Sélectionnez l’objet dans Primitive List pour afficher ses options à droite.
- Post-placement settings – toutes les propriétés de l’objet Blanket peuvent être modifiées dans la boîte de dialogue Blanket et le panneau Properties lorsqu’une zone Blanket placée est sélectionnée dans l’espace de conception.
Propriétés
- Border Width - utilisez la liste déroulante pour sélectionner la largeur de bordure souhaitée.
- Style de ligne - utilisez la liste déroulante pour sélectionner le style de ligne souhaité.
- Border Color - cliquez sur la case de couleur pour sélectionner la couleur souhaitée pour la bordure.
- Fill Color - cliquez sur la case de couleur pour sélectionner la couleur de remplissage souhaitée.
- Collapsed and Disabled - cochez cette option pour réduire et désactiver les zones Blanket.
Directives indirectes (basées sur des paramètres)
Les directives Parameter Set sont nécessaires pour cibler des objets du schéma qui ne peuvent pas contenir de paramètres. Pour les objets qui le peuvent, les directives de conception peuvent être appliquées indirectement en les ajoutant (et en les définissant) comme paramètres de l’objet de schéma concerné. En substance, ce sont des parameter-based directives.
Les directives basées sur des paramètres peuvent, par exemple, servir à limiter la hauteur d’un composant particulier ou à ajouter une contrainte d’espacement ciblant tous les objets de la conception. Le paramètre requis qui définit la contrainte est ajouté à l’objet en tant que règle.
Lors de la synchronisation avec le PCB, les directives basées sur des paramètres ajoutées aux objets du schéma deviennent des règles de conception du PCB. La portée de la règle de conception du PCB correspondante est déterminée par la nature de l’objet auquel le paramètre a été initialement attribué. Le tableau suivant récapitule les correspondances prises en charge entre les paramètres du schéma et la portée des règles du PCB.
| Ajouter un paramètre (en tant que règle) à… | Depuis… | Pour une portée de règle PCB couvrant… |
|---|---|---|
| Broche | l’onglet Parameters du mode Pin du panneau Properties. | Pastille |
| Port | l’onglet Parameters du mode Port du panneau Properties. | Net |
| Composant | la section Parameters du mode Components du panneau Properties. | Composant |
| Symbole de feuille | l’onglet Parameters du mode Sheet Symbol du panneau Properties, lorsque Local est sélectionné dans la section Source. | Classe de composants |
| Symbole de feuille de dispositif | l’onglet Parameters du mode Sheet Symbol du panneau Properties, lorsque Device est sélectionné dans la section Source. | Classe de composants |
| Symbole de feuille gérée | la section Parameters du mode Sheet Symbol du panneau Properties, lorsque Managed est sélectionné dans la section Source. | Classe de composants |
| Feuille | l’onglet Parameters du mode Document Options du panneau Properties. | Tous les objets |
Dans chaque cas, la méthode d’ajout d’un paramètre basé sur une règle est identique. Depuis l’onglet ou la boîte de dialogue concerné, procédez comme suit :
- Ajoutez un paramètre en tant que règle.
- Sélectionnez le type de règle à utiliser.
- Configurez les contraintes du type de règle choisi.
Définition des classes de composants
De la même manière, les classes de composants peuvent être définies dans le schéma en ajoutant un paramètre ClassName aux composants ciblés et en lui attribuant comme valeur le nom de classe souhaité. Lorsque la conception est transférée au PCB, les classes de composants définies sont créées.
Pour garantir que les classes de composants définies dans le schéma sont transférées au PCB, les options suivantes doivent être configurées dans la boîte de dialogue Project Options :
- Activez l’option Generate Component Classes située dans la section User-Defined Classes de l’onglet Class Generation de la boîte de dialogue.
-
Dans l’onglet Comparator de la boîte de dialogue, définissez le paramètre Differences Associated with Components » Extra Component Classes Mode sur
Find Differences.
L’option de l’onglet Class Generation mentionnée ci-dessus est illustrée dans l’image ci-dessous. Survolez l’image pour voir le réglage de l’option de l’onglet Comparator .

Pour transférer les classes de composants au PCB, activez l’option Generate Component Classes dans l’onglet Class Generation. Survolez l’image pour afficher l’onglet Comparator dans lequel vous devez définir le paramètre Extra Component Classes Mode sur Find Differences.
Une fois définies, les classes peuvent être verrouillées dans la section Properties du panneau Properties des propriétés du composant concerné.
Contrôle de l’impression des directives
Par défaut, toutes les directives de conception sont incluses lors de l’impression des feuilles de schéma. Ce comportement peut toutefois être modifié :
- Depuis la boîte de dialogue Schematic Print Properties, lors d’une impression directement depuis le schéma ou dans le cadre d’une sortie configurée dans un fichier Output Job Configuration.
- Depuis la section Schematics include, sur la page Additional PDF Settings de l’assistant Smart PDF.

Contrôlez l’impression des directives selon vos besoins. Pour les directives No ERC, vous pouvez choisir d’imprimer certains styles de symboles tout en excluant les autres.



).
).