Lavorare con le Rooms su un PCB
A colpo d'occhio
- Imparerai cos'è una room su un PCB e come viene utilizzata per controllare il posizionamento degli oggetti e i requisiti di progettazione all'interno di un'area definita della scheda.
- Scoprirai i principali metodi per creare room nell'editor PCB, tra cui il posizionamento interattivo, la creazione a partire dai componenti selezionati e la creazione tramite vincoli di progettazione.
- Capirai come interagiscono gli oggetti room e i vincoli Room Definition in Altium Designer, anche nel PCB Rules and Constraints Editor e nel Constraint Manager.
Riepilogo
Una room è un'area definita su uno degli strati superficiali del PCB. Una room viene utilizzata per definire i requisiti di progettazione all'interno di quell'area della scheda, ad esempio: these components must be in this area, oppure route these nets this width, oppure use routing vias of this size.
Una room viene posizionata come gli altri oggetti poligonali, con una forma rettangolare oppure poligonale.
Oltre a essere presente sulla scheda come forma X-Y con un nome, ogni room diventa automaticamente un vincolo di progettazione Room Definition con un nome Le impostazioni del vincolo Room Definition definiscono: gli objects a cui si applica la room, se tali oggetti devono essere mantenuti inside or outside della room e lo layer a cui si applica la room.
Oltre al semplice requisito keep these objects in (or out) specificato direttamente dal vincolo Room Definition, la room può essere utilizzata anche per definire un'area della scheda in cui vengono applicati altri vincoli di progettazione. Ad esempio, le piste sotto un BGA potrebbero richiedere una larghezza specifica , oppure il routing delle coppie differenziali sotto un BGA potrebbe richiedere l'applicazione di un profilo di impedenza specifico
Disponibilità
Le room possono essere posizionate o create solo nell'editor PCB. Per creare le room, utilizzare i seguenti metodi:
-
Selezionare il comando desiderato dal sottomenu Design » Rooms , quindi definire interattivamente la forma della room (se è stato selezionato un comando Place) oppure creare automaticamente la room (se è stato selezionato un comando Create).
-
Aggiungere un nuovo vincolo di progettazione Room Definition, modificare il nuovo vincolo della room, quindi fare clic sul pulsante Define per definire interattivamente la forma della room poligonale.
-
Creare una room a partire da un contorno chiuso (selezionato) formato da un insieme di piste/archi, utilizzando il comando Tools » Convert » Create Room from Selected Primitives.
-
Creare automaticamente le room durante la sincronizzazione del progetto dallo schematico al PCB. Ulteriori informazioni sulle room generate automaticamente (inclusa la procedura per disabilitarle).
Creazione di una room
La procedura utilizzata per creare una room nel documento PCB dipende dal fatto che la room venga posizionata interattivamente o creata, nonché dal metodo di posizionamento o creazione scelto.
Sono disponibili diverse tecniche per posizionare o creare una room.
Posizionamento interattivo di una room
Le room di forma rettangolare o poligonale possono essere posizionate sullo strato superiore o inferiore del progetto. Si noti che, sebbene possano essere posizionate con qualsiasi strato attivo, lo strato a cui si applicano viene assegnato nell'ambito del vincolo di progettazione Room Definition.
Room rettangolare
Dopo aver avviato il comando Design » Rooms » Place Rectangular Room, il cursore assumerà la forma di un mirino e si entrerà nella modalità di posizionamento delle room. Il posizionamento avviene eseguendo la seguente sequenza di azioni:
-
Fare clic o premere Enter per fissare il primo angolo della room.
-
Per modificare al volo le proprietà del vincolo Room Definition associato, premere il tasto Tab durante il posizionamento.
-
Spostare il cursore per regolare le dimensioni della room, quindi fare clic o premere Enter per fissare l'angolo diagonalmente opposto e completare il posizionamento della room.
-
Continuare a posizionare altre room oppure fare clic con il pulsante destro del mouse o premere Esc per uscire dalla modalità di posizionamento.
Room poligonale
Dopo aver avviato il comando Design » Rooms » Place Polygonal Room, il cursore assumerà la forma di un mirino e si entrerà nella modalità di posizionamento delle room. Il posizionamento avviene eseguendo la seguente sequenza di azioni:
-
Posizionare il cursore, quindi fare clic per fissare il punto iniziale della room.
-
Posizionare il cursore, quindi fare clic per fissare una serie di vertici che definiscono la forma poligonale della room.
-
Dopo aver posizionato l'ultimo vertice, fare clic con il pulsante destro del mouse o premere Esc per completare il posizionamento della room. Non è necessario chiudere il poligono, poiché il software completerà automaticamente la forma collegando il punto iniziale all'ultimo punto posizionato.
-
Continuare a posizionare altre room poligonali oppure fare clic con il pulsante destro del mouse o premere Esc per uscire dalla modalità di posizionamento.
In base ai componenti selezionati
Se i componenti sono già posizionati sulla scheda e si desidera creare una nuova room adatta alla loro disposizione, utilizzare uno dei tre comandi Create xxx Room from selected components. Questi comandi consentono di creare automaticamente room di forma non ortogonale, ortogonale e rettangolare, in base ai componenti attualmente selezionati nello spazio di progettazione. In ogni caso, il metodo di creazione è lo stesso:
-
Selezionare tutti i componenti per i quali si desidera creare la room. Per selezionare i componenti del PCB dallo schematico, eseguire il comando Tools » Cross Select Mode, quindi selezionare i componenti sullo schematico.
-
Nell'editor PCB, avviare il comando di creazione appropriato (Design » Rooms » Create xxx Room from selected components). Verrà creata automaticamente una classe di componenti che include i componenti selezionati (a meno che non ne esista già una).
-
Viene quindi creata la room del tipo scelto e la relativa regola di progettazione Room Definition viene associata automaticamente alla classe di componenti creata.
-
La room verrà dimensionata in modo da contenere tutti i componenti selezionati, in base ai rispettivi rettangoli di selezione.
-
Facendo clic e trascinando per spostare la room, verranno spostati anche tutti i componenti della classe di componenti associata.
Viene creata una room ortogonale a partire dai componenti PCB selezionati, che erano stati selezionati nello schematico.
Aggiungendo un vincolo di progettazione Room Definition
È possibile creare una nuova room anche definendo un nuovo vincolo nel PCB Rule and Constraints Editor o nel Constraint Manager.
Quale approccio viene utilizzato per definire i vincoli di progettazione?
Altium Designer supporta due approcci distinti per definire i vincoli di progettazione: il Constraint Manager e il PCB Rule and Constraints Editor.
Il PCB Rule and Constraints Editor è stata la prima interfaccia sviluppata per definire i vincoli nell'editor PCB. Se si utilizza il PCB Rule and Constraints Editor, il progettista definisce: what objects the constraint (rule) applies to e how those objects are to be constrained. Questo approccio è potente perché consente al progettista di individuare con precisione gli oggetti a cui applicare i vincoli: può riguardare tutti gli oggetti (ad esempio tutte le net) oppure un oggetto specifico sulla scheda (una determinata piazzola). Questo metodo flessibile per individuare gli oggetti del progetto si basa su un motore di regole che utilizza un linguaggio di query.
Il Constraint Manager adotta un approccio incentrato sugli oggetti per la definizione dei vincoli. Il progettista lavora dal punto di vista degli oggetti, applicando i vari vincoli elettrici e fisici richiesti dal progetto in un'interfaccia simile a un foglio di calcolo; gli oggetti vengono evidenziati nell'editor grafico quando vengono selezionati nel Constraint Manager. Ciò consente al progettista di configurare ed esaminare facilmente tutti i requisiti di un oggetto, ad esempio: questa classe di net deve essere sbrogliata con questa larghezza, con questa distanza di isolamento, utilizzando questo via di sbroglio e questo stile di connessione al poligono. Si potrebbe inoltre richiedere che tale classe di net venga sbrogliata su questi layer, con queste impedenze. Questa vista incentrata sugli oggetti non è disponibile nel PCB Rule and Constraints Editor. In definitiva, il software converte i vincoli incentrati sugli oggetti nello stesso formato delle regole definite nel PCB Rule and Constraints Editor; per visualizzarle, passare alla vista All Rules dopo aver aperto i vincoli dall'editor PCB.
Questa pagina della documentazione mostra immagini dei vincoli così come vengono definiti sia nella finestra di dialogo PCB Rule and Constraints Editor sia nel Constraint Manager. Si noti che i termini constraint e rule sono usati in modo intercambiabile.
Aggiunta di un nuovo vincolo di progettazione Room Definition
Nel PCB Rules and Constraints Editor
Per ogni room posizionata o creata, viene creato automaticamente un vincolo di progettazione Room Definition associato. Vale anche il contrario: se si aggiunge una nuova regola di questo tipo, l'oggetto room corrispondente apparirà nell'area di progettazione. Si noti che questo vale anche per l'eliminazione: se si elimina una room nell'editor grafico, il vincolo viene eliminato automaticamente; se invece si elimina il vincolo di progettazione, viene eliminato l'oggetto grafico.
Se il vincolo della room viene definito dal PCB Rules and Constraint Editor, viene creato un oggetto room predefinito di 5 × 5 pollici, a 1 pollice dall'origine assoluta (in basso a sinistra nell'area di modifica). Si noti che l'indicatore dell'origine mostra l'origine relativa definita dall'utente, che può essere impostata in qualsiasi punto dell'area di modifica.
Quando viene aggiunto un nuovo vincolo della room, nell'area di modifica viene definita una room predefinita.
Una volta aggiunto il vincolo, è possibile tornare all'area di modifica e modificare graficamente la room. In alternativa, nel PCB Rules and Constraints Editor è possibile modificare il vincolo della room, quindi fare clic sul pulsante Define per definirne interattivamente la forma. Poiché una room definisce un'area sulla scheda, è più comune posizionarla in modo interattivo e lasciare che il vincolo di progettazione venga creato automaticamente.
Scopri di più su come aggiungere un nuovo vincolo nel PCB Rules and Constraints Editor.
Nel Constraint Manager
Per creare un nuovo vincolo di confinamento (room) nel Constraint Manager:, passare alla vista All Rules, selezionare Room Definition nella categoria Placement, quindi fare clic con il pulsante destro del mouse nell'elenco Advanced Rules e selezionare Add Advanced Rule dal menu contestuale, come mostrato di seguito.
È possibile aggiungere un nuovo vincolo della room nel Constraint Manager.
In questa fase l'oggetto room non esiste nell'area di modifica grafica: occorre fare clic sul pulsante Define (che consente di passare all'editor PCB) e definire la forma della room. Una volta completata questa operazione, esisteranno sia il vincolo della room sia l'oggetto room e sarà possibile salvare i vincoli.
-
Se il vincolo della room verrà utilizzato per vincolare gli oggetti a trovarsi all'interno (o all'esterno) di quell'area della scheda, il passo successivo consiste nel configurare Object Match e le altre impostazioni del vincolo nella parte inferiore del Constraint Manager. Continua a leggere per saperne di più.
-
Se il vincolo della room verrà utilizzato per definire un'area in un altro tipo di vincolo, ad esempio la larghezza di sbroglio, fare riferimento alla sezione Definizione dei vincoli all'interno di una room per saperne di più.
Scopri di più su come aggiungere un nuovo vincolo nel Constraints Manager.
Che cos'è un vincolo della room?
Come indicato in precedenza, una room è un'area definita su uno dei layer superficiali del PCB, utilizzata per definire i requisiti di progettazione all'interno di quell'area della scheda.
Tutti i vincoli di progettazione hanno due elementi chiave:
-
what objects this constraint applies to e
-
how those objects are to be constrained
Se il vincolo della room viene definito in un'area della scheda priva di componenti, il criterio Object Match (the objects this constraint applies to) viene impostato per impostazione predefinita su False, il che significa che questo vincolo non si applica ad alcun oggetto. Modificarlo secondo necessità.
La definizione della room appena creata. Si noti che l'ambito di applicazione della regola è False, il che significa che non si applica ad alcun oggetto.
Vincolare una classe di componenti
Un modo comune di utilizzare un vincolo di room consiste nel definire la posizione di una classe di componenti, vincolandola a un'area specifica della scheda.
La classe di componenti Encoder è vincolata all'interno della room denominata Room-Encoder, sul layer superiore della scheda.
L'immagine sopra mostra come la classe di componenti Encoder sia vincolata within alla room Room-Encoder, sul Top side della scheda nel PCB Rules and Constraints Editor (sostanzialmente come nel Constraint Manager Una volta assegnati a una room, i componenti si spostano insieme a essa. Per spostare una room senza spostare i componenti, disabilitare temporaneamente la regola Room Definition associata.
Scopri di più sul vincolo di progettazione Room Definition.
L'editor PCB include numerosi strumenti potenti per lavorare con le room; per maggiori informazioni, consulta la sezione Lavorare con le room di questa pagina.
Oltre a costituire un vincolo di progettazione a sé stante (Room Definition), una room può anche essere utilizzata come oggetto per limitare l'ambito di applicazione di un altro vincolo di progettazione a un'area della scheda, ad esempio larghezza, distanza di isolamento o stile dei via. Questo argomento è trattato nella sezione Definire i vincoli all'interno di una room di questa pagina.
Creazione durante la sincronizzazione del progetto dallo schema al PCB
Durante il trasferimento del progetto dallo schema al PCB, è possibile creare una room contenente i componenti di ciascun foglio schematico. In un progetto gerarchico multilivello questa opzione può essere poco utile, ma in un progetto piatto di grandi dimensioni, disporre di una room per ogni foglio può facilitare il posizionamento dei componenti sulla scheda.
La scheda Class Generation della finestra di dialogo Project Options include opzioni per generare room per ciascun foglio del progetto Se l'opzione Generate Rooms è selezionata, all'esecuzione del comando Design » Update verrà creata una room per quel foglio e le verrà assegnata una classe contenente tutti i componenti del foglio. Si noti che i componenti di ciascun foglio vengono aggiunti a una classe di componenti, quindi l'opzione Generate Rooms richiede che sia abilitata anche la corrispondente opzione Component Class.
Nel PCB, ogni vincolo di room viene creato con l'ambito di applicazione InComponentClass('<SheetSymbolDesignator>'). Se il foglio non contiene componenti, non verrà creata alcuna room. Quando lo schema viene trasferito inizialmente al PCB, i componenti di ciascuna classe vengono disposti in fila, quindi viene creata una room attorno a tale classe, come mostrato nell'immagine seguente.
Deselezionare le caselle Generate Rooms nella finestra di dialogo Project Options se non sono necessarie room generate automaticamente.
Il PCB dopo la sincronizzazione iniziale del progetto: per ogni foglio è stata creata una room, alla quale è stata assegnata la classe di componenti del foglio.
Scopri di più sulla generazione automatica di room, classi di componenti e classi di net dal progetto schematico.
Per ulteriori informazioni sulla sincronizzazione del progetto, consulta la pagina Mantenere sincronizzati gli schemi e il PCB.
Da piste e archi selezionati
Un oggetto room può essere definito utilizzando un contorno chiuso composto da oggetti pista e/o arco selezionati. A tale scopo, selezionare tutte le primitive pista e arco che costituiscono il contorno chiuso nell'area di progettazione e scegliere il comando Tools » Convert » Create Room from Selected Primitives dai menu principali. La presentazione seguente illustra i passaggi necessari.
|
Sono state posizionate piste su un layer meccanico per definire lo spazio della scheda disponibile per i componenti Encoder. Eseguire il comando Tools » Convert » Create Room from Selected Primitives per creare una Room Definition della stessa forma. Viene visualizzata la finestra di dialogo Edit Room Definition, che consente di definire i parametri del vincolo. A questa room viene assegnata la classe di componenti Per modificare la forma della room, fare clic per selezionarla, quindi eseguire il comando Design » Rooms » Edit Polygonal Verticies, e fare clic su un vertice o su un bordo per modificarne la forma. |
Modificare una room
La forma X-Y della room e la sua posizione sulla scheda possono essere modificate interattivamente. Si noti che esistono due procedure diverse per modificare interattivamente una room: tramite il rettangolo di selezione (descritto nella sezione Modificare le dimensioni e la posizione) oppure tramite i vertici di modifica della forma (descritti nella sezione Modificare la forma).
Oltre ad accedere ai comandi tramite il sottomenu Design » Rooms, è possibile accedere ai comandi contestuali delle room facendo clic con il pulsante destro del mouse su una room posizionata e selezionando il sottomenu Room Actions.
Fare clic con il pulsante destro del mouse su una room per accedere ai comandi specifici.
Modificare le dimensioni e la posizione
Facendo clic una volta su una room per selezionarla, diventano disponibili le seguenti maniglie di modifica, indipendentemente dal fatto che la room sia stata originariamente posizionata come rettangolare o poligonale:
Le maniglie di modifica vengono visualizzate quando fai clic per selezionare una room.
Modificare le dimensioni della room
-
Trascinando le maniglie agli angoli (A), la room viene ridimensionata contemporaneamente in orizzontale e in verticale.
-
Trascinando una maniglia su un bordo (B), l'oggetto viene ridimensionato in quella direzione (in orizzontale o in verticale).
-
Durante il trascinamento, la room può essere ruotata o ribaltata premendo:
-
Spacebar per ruotare l'oggetto in senso antiorario oppure Shift+Spacebar per ruotarlo in senso orario. La rotazione avviene in base al valore del passo di rotazione definito nella pagina PCB Editor - General della finestra di dialogo Preferences.
-
X o Y per ribaltare l'oggetto lungo l'asse X o Y.
-
L per ribaltare l'oggetto sull'altro lato della scheda. Se alla room sono associati dei componenti, questi verranno ribaltati insieme alla room.
-
Spostare una room
Fai clic su una room e trascinala per spostarla in una nuova posizione. Un oggetto room può essere spostato anche utilizzando il comando Design » Rooms » Move Room dai menu principali oppure il comando Room Actions » Move Room dal menu contestuale della room. Dopo aver avviato il comando, il cursore assume la forma di un mirino e si attiva la modalità di spostamento delle room: fai clic sulla room da spostare.
Quando fai clic su una room per spostarla:
-
La room si aggancia al cursore. Il punto di aggancio della room dipende dall'impostazione corrente di Object Snap Options ; il cursore si aggancia al più vicino tra i punti di aggancio abilitati (pad del componente, riferimento del componente o vertice della room).
-
Sposta la room nella posizione desiderata, quindi fai clic o premi Enter per posizionarla.
-
Continua a spostare altre room oppure fai clic con il pulsante destro del mouse o premi Esc per uscire.
-
Se nella room da spostare sono presenti componenti, durante lo spostamento puoi visualizzare le guide dinamiche di allineamento verdi premendo i tasti Shift o Ctrl. Usa Shift per mantenere l'aggancio alla griglia attiva; usa Ctrl per disabilitare temporaneamente la griglia e allinearti a un oggetto esistente fuori griglia.
-
Se la room contiene oggetti senza net e/o oggetti bloccati, si apre la finestra di dialogo Room containing No Net/Locked Objects. Usa questa finestra per stabilire se spostare o meno questi oggetti insieme alla room, quindi fai clic su OK. Affinché questa finestra venga visualizzata, l'opzione Ask when moving rooms containing No Net/Locked Objects deve essere abilitata nella pagina PCB Editor - General della finestra di dialogo Preferences

La finestra di dialogo Room containing No Net / Locked Objects
Finestra di dialogo Room contenente oggetti senza net / bloccati |
|
| No Net Objects | Abilita questa opzione per spostare gli oggetti senza net insieme alla room. |
| Locked Objects | Abilita questa opzione per spostare gli oggetti bloccati insieme alla room. |
| Don't ask me about moving room's locked/no net objects until next PCB session (use currently selected settings) | Abilita questa opzione per salvare le impostazioni selezionate e continuare a utilizzarle per il resto della sessione PCB. La finestra di dialogo non verrà più visualizzata fino all'avvio di una nuova sessione. |
Modificare la forma
La forma del contorno di una room si modifica eseguendo il comando Edit Polygonal Room Vertices. Il comando è accessibile dal sottomenu Design » Rooms oppure dal sottomenu contestuale Room Actions, disponibile facendo clic con il pulsante destro del mouse.
Quando esegui il comando, vengono visualizzate le maniglie di modifica del contorno della forma poligonale della room; puoi quindi:
-
Fare clic su una maniglia A, quindi spostare il cursore per spostare quel vertice. Fai nuovamente clic nella nuova posizione per posizionare il vertice.
-
Durante lo spostamento di una maniglia A, premi il tasto Delete sulla tastiera per rimuovere quel vertice dalla room.
-
Fare clic su B oppure lungo un bordo (tra le maniglie), quindi spostare il cursore per far scorrere quel bordo. Premi Shift+Spacebar durante lo spostamento del bordo per scorrere le modalità di comportamento del bordo disponibili (scorrimento, interruzione, incurvamento).
-
Ctrl+Click B o Ctrl+Click lungo un bordo, quindi spostare il cursore per aggiungere un vertice a quel bordo e spostarlo. Fai nuovamente clic nella nuova posizione per posizionare il vertice. In pratica, il nuovo vertice diventa un vertice A e vengono aggiunti nuovi vertici B tra questo e i vertici A originali.
-
Per accedere a una maniglia fuori griglia, tieni premuto il tasto Ctrl per disabilitare temporaneamente l'aggancio alla griglia.
-
Continua a modificare la forma della room secondo necessità oppure fai clic con il pulsante destro del mouse o premi Esc per terminare. La visualizzazione della room si aggiorna in base alla nuova forma del contorno.
Questo comando può essere utilizzato indipendentemente dal fatto che la room di destinazione sia bloccata o meno.
Suddividere una room
Sono disponibili comandi per slice graficamente un oggetto room posizionato in due o più room separate. Il processo di suddivisione è simile al posizionamento di una linea e include le stesse modalità di gestione degli angoli (infatti, la larghezza dell'oggetto di taglio corrisponde alla larghezza predefinita corrente delle linee). Nota che gli oggetti utilizzati per visualizzare il percorso di taglio non sono oggetti che vengono posizionati: servono solo a mostrare il percorso di taglio e vengono rimossi al termine del processo di suddivisione. Inoltre, non è necessario iniziare il taglio esattamente sul bordo di una room: è più semplice iniziare leggermente al di fuori della room e terminare anch'esso leggermente all'esterno.
Sono disponibili due comandi di suddivisione. La procedura per definire il percorso di suddivisione è la stessa per entrambi; la differenza riguarda il modo in cui gestiscono i componenti presenti nella room da suddividere. Le differenze tra i comandi sono illustrate dopo la descrizione della procedura di suddivisione.
|
Fare clic con il pulsante destro del mouse su una room per accedere ai comandi Slice nel menu Room Actions. Sono stati definiti due percorsi di suddivisione utilizzando la procedura descritta di seguito. Sono state create tre room. |
Procedura di suddivisione
Dopo aver avviato un comando Slice:
-
Il cursore assume la forma di un mirino e viene richiesto di selezionare un punto iniziale per il percorso di suddivisione.
-
Posizionare il cursore appena all'esterno della room da suddividere, quindi fare clic o premere Enter. A questo punto si è in modalità di suddivisione (essenzialmente una modalità di posizionamento di linee).
-
Spostare il cursore all'interno della room per definire il primo segmento del percorso, quindi fare clic o premere Enter per fissarne l'estremità.
-
Continuare a spostare il cursore e a fare clic, definendo una serie di vertici che determinano la forma del percorso di suddivisione.
-
Dopo aver posizionato l'ultimo vertice (appena all'esterno della room), fare clic con il pulsante destro del mouse o premere Esc per completare il posizionamento del percorso.
-
A questo punto è possibile iniziare un altro percorso di suddivisione della room, oppure fare clic con il pulsante destro del mouse o premere Esc per uscire dalla modalità di suddivisione.
-
Si aprirà una finestra di conferma che indica in quante room verrà suddivisa la room originale. Fare clic su Yes per confermare le suddivisioni effettuate oppure su No per annullarle. Le nuove room risultanti verranno aggiornate di conseguenza e verranno create e associate le relative regole Room Definition.
-
Durante la suddivisione, premere:
-
Shift+Spacebar per scorrere le modalità degli angoli.
-
Spacebar per invertire la direzione dell'angolo.
-
Ogni segmento del percorso di suddivisione richiede un punto iniziale e uno finale.
-
Se la modalità di posizionamento del percorso di suddivisione include un angolo, premere la scorciatoia 1 per alternare il posizionamento di un segmento per clic a quello di due segmenti per clic.
-
Backspace per rimuovere l'ultimo segmento posizionato.
-
Riadattamento di una room esistente
Un altro approccio per modificare la forma di una room esistente consiste nel richiedere al software di riadattare il contorno della room alla classe di componenti assegnata. Il sottomenu Room Actions accessibile con il pulsante destro del mouse e il sottomenu Design » Rooms includono entrambi i tre comandi Wrap Room, come mostrato nella presentazione.
|
Se si modifica il posizionamento dei componenti all'interno di una room, utilizzare uno dei tre comandi Wrap per aggiornare la forma della room. Il comando Wrap Non-Orthogonal posiziona i bordi della room in modo da unire i punti estremi dei contorni dei componenti. Il comando Wrap Orthogonal posiziona bordi verticali e orizzontali della room attorno ai contorni dei componenti. Il comando Wrap Rectangular posiziona la più piccola room rettangolare che racchiude i contorni dei componenti. |
Modifica nel pannello Properties
La room è un oggetto particolare, in quanto rappresenta sia un oggetto sia un vincolo di progettazione.
Modifica tramite il pannello Properties
Le proprietà della room, incluse la posizione e la forma nello spazio di modifica, possono essere modificate nel pannello Properties quando la room è selezionata. Il pannello può essere visualizzato tramite il pulsante Panels in basso a destra nello spazio di progettazione oppure tramite il comando View » Panels » Properties.
Il pannello Properties può essere utilizzato per modificare le proprietà grafiche di una room.
| Name | Il nome attuale della room (e della regola Room Definition associata). Può essere modificato secondo necessità. Oltre a facilitare l'identificazione di ciascuna room, il nome può essere utilizzato per individuare una room specifica in una regola di progettazione. |
| (X/Y) (due campi) | La posizione X e Y attuale del primo vertice della room, rispetto all'origine corrente. Modificare il valore nel campo per cambiare la posizione della room rispetto all'origine corrente. Il valore può essere inserito in unità metriche o imperiali; includere le unità quando si inserisce un valore espresso in unità diverse da quelle predefinite. Le unità predefinite (metriche o imperiali) sono visualizzate nella barra di stato e impostate nella sezione Other del pannello Properties (quando non sono selezionati oggetti nello spazio di progettazione). Questi valori possono essere modificati solo se l'opzione X/Y è sbloccata ( è visualizzata l'icona |
Vertici del contorno |
|
| Vertices Grid | Elenca tutti i vertici attualmente definiti per la room, nell'ordine in cui sono stati definiti durante il posizionamento della room. I vertici consecutivi sono collegati da segmenti rettilinei. Se si preferisce un collegamento ad arco, inserire un valore per il parametro Arc Angle desiderato. Il valore viene inserito nel campo associato al vertice iniziale e l'arco si estende da questo vertice al vertice successivo nell'elenco. Fare clic con il pulsante destro del mouse per Copy / Paste o Import / Export to CSV. |
| Index | L'indice assegnato al vertice (non modificabile, basato sull'ordine di posizionamento durante la definizione della room). |
| X | La coordinata X (orizzontale) del vertice. Fare clic per modificarla. |
| Y | La coordinata Y (verticale) del vertice. Fare clic per modificarla. |
| Arc Angle (Neg = CW) | L'angolo dell'arco tracciato per collegare questo vertice al successivo. Per impostazione predefinita, i collegamenti sono segmenti rettilinei e questo campo rimane vuoto. Fare clic per modificarlo, quindi inserire l'angolo dell'arco desiderato. Un valore positivo genera un arco in senso antiorario. Per tracciare un arco in senso orario, inserire un valore negativo. |
Lavorare con le room
Il software include diverse funzionalità che aiutano a gestire le room e gli oggetti al loro interno. Sono disponibili comandi per disporre le room secondo uno schema a griglia, spostarle sulla griglia di snap corrente e, per un progetto che include sezioni circuitali ripetute, copiare il posizionamento e il routing da una room all'altra.
È inoltre possibile utilizzare una room per limitare l'applicazione di altri vincoli di progettazione a un'area della scheda, richiedendo ad esempio che, all'interno di questa room, le net siano sbrogliate con larghezza e clearance specifiche, oppure che le coppie differenziali siano sbrogliate con un profilo di impedenza specifico.
Un mixer a 8 canali: il primo canale di ingresso è stato posizionato e sbrogliato, quindi replicato sugli altri sette canali di ingresso utilizzando il comando Copy Room Format.
Definizione dei vincoli all'interno di una room
Oltre a vincolare gli oggetti all'interno o all'esterno di una room (come descritto nella sezione Vincolo di progettazione per la definizione delle room), una room può essere utilizzata anche per delimitare l'area di applicazione di altri vincoli di progettazione. Ad esempio, il vincolo sulla larghezza di routing potrebbe richiedere che le piste sotto un BGA siano realizzate con larghezze diverse, oppure il vincolo di clearance elettrica potrebbe richiedere distanze diverse in un'area specifica della scheda.
La larghezza di routing e le clearance vengono regolate automaticamente all'interno della room, in base alle impostazioni di Room Definition.
Questo risultato si ottiene aggiungendo i vincoli Routing Width ed Electrical Clearance mostrati nella presentazione seguente.
In Constraint Manager
Quando si aggiunge un vincolo di room nella vista All Rules di Constraint Manager, l'oggetto room diventa disponibile anche nella vista Physical. Questa vista consente di definire rapidamente i vincoli basati sull'area da applicare all'interno della room, tra cui: larghezza di routing, clearance elettrica, stile dei via di routing, proprietà delle coppie differenziali, restringimento delle piste e stile di connessione dei poligoni. La presentazione seguente mostra i vincoli per la scheda nel video precedente.
|
All'interno di questa room, tutti gli oggetti di routing devono avere una larghezza compresa nell'intervallo specificato. All'interno di questa room, tutti gli oggetti di routing devono mantenere almeno questa clearance dagli oggetti appartenenti ad altre net. All'interno di questa room, tutti gli oggetti di routing devono rispettare almeno questa clearance elettrica. All'interno di questa room, tutte le coppie differenziali devono essere sbrogliate utilizzando il profilo di impedenza |
In PCB Rules and Constraint Editor
Per ottenere lo stesso risultato in PCB Rules and Constraint Editor, creare una query che definisca l'area della room. Gli oggetti nella room possono essere individuati in due modi: selezionando gli oggetti che si trovano interamente all'interno della room (utilizzando la parola chiave WithinRoom), oppure selezionando gli oggetti che toccano la room (utilizzando la parola chiave TouchesRoom). La presentazione seguente illustra gli stessi vincoli di larghezza di routing, clearance elettrica, stile dei via di routing e proprietà delle coppie differenziali mostrati nella Constraint Manager presentazione precedente.
Disposizione delle room selezionate
Per disporre le room selezionate nello spazio di progettazione, è possibile utilizzare il comando Design » Rooms » Arrange Rooms. Selezionare le room desiderate, quindi eseguire il comando per aprire la finestra di dialogo Arrange Rooms.
La finestra di dialogo Arrange Rooms.
Specificare come disporre le room e in quale ordine posizionarle. È inoltre possibile specificare la posizione iniziale, inserendo le coordinate X-Y nella finestra di dialogo oppure facendo clic nell'area di lavoro, nonché la distanza tra room adiacenti. Dopo aver fatto clic su OK, le room selezionate verranno spostate nelle posizioni stabilite.
Colonne/Righe |
|
| Columns | Il numero di colonne utilizzate per disporre le room. Modificare questo campo secondo necessità. |
| Rows | Il numero di righe utilizzate per disporre le room. Modificare questo campo secondo necessità. Se il numero di room supera la capacità della disposizione personalizzata di righe e colonne, verranno aggiunte altre righe in alto. |
Ordina per |
|
| SortBy | Visualizza l'ordinamento scelto, ovvero i criteri utilizzati per distinguere la prima room dalla successiva. Le opzioni disponibili sono descritte di seguito. |
| Channel Name | Ordina le room in ordine alfanumerico, in base al nome del canale. Ulteriori informazioni sulla progettazione multicanale. |
| Room Area | Ordina le room in base alla loro area. |
| Room Component Count | Ordina le room in base al numero di componenti che contengono. |
| Room Width | Ordina le room in base alla loro dimensione X (orizzontale). |
| Room Height | Ordina le room in base alla loro dimensione Y (verticale). |
| Sort in Ascending order | Abilita questa opzione per ordinare le room in ordine crescente (dalla più piccola alla più grande), secondo i criteri SortBy correnti. Se questa opzione è disabilitata, l'ordine è decrescente (dalla più grande alla più piccola). |
Posizione |
|
| Origin X | Definisce la posizione X (orizzontale) da cui inizierà il posizionamento delle room. Modifica questo campo per cambiare la coordinata X, che può essere definita in mm o mil. Per specificare l'unità quando inserisci un numero, aggiungi il suffisso mm o mil al valore. Le unità predefinite (metriche o imperiali) sono determinate dall'impostazione Units nel pannello Proprietà e vengono utilizzate se non viene specificata alcuna unità. |
| Origin Y | Definisce la posizione Y (verticale) da cui inizierà il posizionamento delle room. Modifica questo campo per cambiare la coordinata Y, che può essere definita in mm o mil. Per specificare l'unità quando inserisci un numero, aggiungi il suffisso mm o mil al valore. Le unità predefinite (metriche o imperiali) sono determinate dall'impostazione Units nel pannello Proprietà e vengono utilizzate se non viene specificata alcuna unità. |
| Select Origin Using Mouse | Se abilitata, viene richiesto di impostare manualmente l'origine per la disposizione delle room. L'opzione deve essere disabilitata per poter modificare Origin X e Origin Y. |
| X-Spacing | Definisce la distanza X (orizzontale) da lasciare tra room adiacenti. |
| Y-Spacing | Definisce la distanza Y (verticale) da lasciare tra room adiacenti. |
| Auto Spacing | Se abilitata, le room vengono disposte con la stessa spaziatura X (orizzontale) e Y (verticale). L'opzione deve essere disabilitata per poter modificare X-Spacing e Y-Spacing. |
| Place On Grid | Abilita questa opzione per forzare l'allineamento delle room alla griglia di aggancio corrente del PCB. |
Spostamento delle room sulla griglia
Per spostare ciascuna delle room selezionate sul punto più vicino della griglia di aggancio corrente, utilizza il comando Design » Rooms » Move Rooms to Grid. Dopo aver avviato il comando, si apre una finestra di conferma che chiede se desideri spostare anche gli oggetti insieme alle room selezionate. Fai clic su Yes per spostare le room e gli oggetti contenuti sul punto più vicino della griglia di aggancio, oppure fai clic su No per spostare solo le room.
Copia dei formati delle room
Una delle funzionalità più potenti delle room è la possibilità di copiare la forma, il posizionamento e lo sbroglio di una room in altre room che contengono un insieme identico di componenti. Il comando è particolarmente utile durante il layout di un progetto multicanale, poiché consente di propagare il posizionamento e lo sbroglio realizzati in un canale a tutti gli altri canali.
Per copiare il formato di una room in altre room:
-
Fai clic su Design » Rooms » Copy Room Formats nei menu principali.
-
La barra di stato richiederà di scegliere una room di origine. Posiziona il cursore sulla room di origine e fai clic oppure premi Enter.
-
La barra di stato richiederà di scegliere una room di destinazione. Posiziona il cursore sulla room in cui desideri copiare la formattazione e fai clic oppure premi Enter. Se intendi applicare la formattazione a più room, questo secondo clic può essere effettuato su una qualsiasi delle room.
-
Si apre la finestra di dialogo Confirm Channel Format Copy. Utilizza le opzioni per definire la copia del formato desiderata. Per impostazione predefinita, la copia del formato verrà applicata dalla Source Room scelta alla Destination Room scelta. Per copiare dalla room di origine a ciascuna delle room nella classe di canali rilevata, abilita l'opzione Apply to Specified Channels e verifica che le caselle di controllo Copy necessarie siano selezionate per le room di destinazione.
-
Fai clic su OK nella finestra di dialogo per aggiornare le room di destinazione.
-
Puoi continuare a selezionare altre room di destinazione oppure fare clic con il pulsante destro del mouse per terminare.
Room |
|
| Source Room | Il nome della room di origine (che rappresenta il canale dello schema), di cui verranno copiati il posizionamento dei componenti e lo sbroglio. |
| Destination Room | Questo campo contiene il nome della room di destinazione (che rappresenta il canale dello schema), a cui verranno applicati il posizionamento e lo sbroglio copiati. Se il progetto è multicanale e i canali di origine e di destinazione appartengono alla stessa classe di canali, la copia del formato verrà applicata ai canali abilitati nell'area Channel Class della finestra di dialogo Tieni presente che il canale di origine (room) e il canale di destinazione (room) devono appartenere alla stessa classe di canali per poter copiare la formattazione di un canale di origine (room) in altri canali (room). |
Opzioni |
|
| Copy Component Placement | Copia il posizionamento dei componenti della room di origine nelle room di destinazione. |
| Copy Designator and Comment Formatting | Copia il formato dei designatori e dei commenti della room di origine nella room di destinazione. |
| Copy Routed Nets | Copia il layout dello sbroglio (piste/archi e via utilizzati per sbrogliare le net) della room di origine nella room di destinazione. |
| Copy Room Size/Shape | Copia la forma della room di origine e applicala alla room di destinazione. Se Copy Room Orientation è abilitata nella finestra di dialogo, la forma della room di destinazione verrà modificata rispetto al suo punto iniziale (in basso a sinistra), ovvero il punto in basso a sinistra della room di destinazione rimarrà invariato. |
| Copy Room Orientation | Copia l'orientamento della room. Altium Designer rileva l'orientamento delle room (tramite l'angolo di rotazione del componente con il maggior numero di pin o, se più componenti hanno lo stesso numero massimo di pin, del componente con l'area maggiore) e lo utilizza per ruotare la room di destinazione. |
| Copy Selected Objects Only | Copia la formattazione degli oggetti selezionati della room di origine nella room di destinazione. |
Opzioni per gli oggetti a contatto |
|
| Copy All Objects Touching the Room | Includi gli oggetti (diversi da componenti, piste/archi di routing e vie) completamente o parzialmente racchiusi nella room. Questa opzione deve essere abilitata per copiare da una room a un'altra sia gli oggetti con una net assegnata sia quelli senza net, come regioni, poligoni e aree di keepout. |
| Exclude NoNet Objects | Escludi gli oggetti a cui non è assegnata una net. |
Solo completamente racchiusi / Racchiusi e a contatto |
|
| Fully Enclosed Objects Only | Se l'opzione Copy All Objects Touching the Room è abilitata, abilita questa opzione per copiare solo gli oggetti completamente racchiusi. |
| Enclosed & Touching Objects | Se l'opzione Copy All Objects Touching the Room è abilitata, abilita questa opzione per copiare sia gli oggetti racchiusi sia quelli a contatto con il bordo. |
Corrispondenza dei componenti tra canali |
|
| Match Components by Channel Offsets | A ogni componente di un canale ripetuto viene assegnato un offset di canale durante il trasferimento del progetto dallo schema al PCB; utilizza l'offset di canale per identificare lo stesso componente in ciascun canale. |
| Match Components by Source Designator | In alternativa, utilizza il designatore di origine (dello schema) per identificare i componenti corrispondenti in ciascun canale. |
Rimuovi le connessioni interessate |
|
| Whole connections | Dopo aver elaborato la copia del formato del canale, il software deve sapere come rimuovere le connessioni interessate. Se si sceglie questa opzione, vengono rimosse le connessioni interessate sia all'interno sia all'esterno della room. |
| Touching parts of connections only | Se si sceglie questa opzione, vengono rimosse solo le connessioni interessate a contatto con la room. |
| Contained parts of connections only | Se si sceglie questa opzione, vengono rimosse solo le connessioni interessate all'interno della room. |
Classe di canali |
|
| Channel Class | Quando un progetto multicanale viene trasferito dallo schema al PCB, i circuiti ripetuti (canali) vengono identificati come una classe di canali nella finestra di dialogo Object Class Explorer dell'editor PCB Questa classe di canali viene utilizzata per identificare i canali a cui applicare la copia del formato. Se la sezione Channel Class della finestra di dialogo è vuota, verifica che la classe di canali sia definita correttamente nella finestra di dialogo Object Class Explorer (Design » Classes). Se non viene identificata alcuna classe di canali, il comando di copia viene applicato solo dalla room di origine alla room di destinazione. |
| Channel Members | Questo elenco contiene i canali, ciascuno identificato dal nome della propria room. Se la room di origine fa parte di una classe di canali definita, vengono elencati la classe e tutti i suoi membri. Vengono visualizzati il layer (il lato della scheda su cui è stata posizionata la room) e il numero di componenti in ciascun canale. Ogni canale include una casella di controllo che consente di stabilire se applicare la copia del formato a quel canale; la casella diventa accessibile se l'opzione Apply To Specified Channel è abilitata. |
| Apply To Specified Channel | Per impostazione predefinita, il formato viene copiato da Source Room a tutti i canali della classe di canali a cui appartiene la room di origine (canale). Quando questa opzione è abilitata, la casella di controllo Copy di ciascun canale diventa disponibile, consentendo di selezionare i canali della classe a cui applicare l'azione di copia del formato. |
Nascondere le room
Le room all'interno di un determinato documento possono essere visualizzate, nascoste o visualizzate in modalità bozza globalmente utilizzando le opzioni nella scheda View Options del pannello Configurazione della vista.
Regola il cursore Visibilità oggetti per le room per attenuarne la visualizzazione o nasconderle nell'area di modifica.
).

).
)
).
).
).




)
).








).