PCBにおける接続性を理解する
概略
- ラッツネストとは何か、コネクションラインがネットの接続関係をどのように表すか、ネットトポロジーがコネクションラインの配置にどのように影響するかを学べます。
- 複雑なPCBレイアウト上で、個々のネットやネットのグループをすばやく見つけ、ハイライト表示、フィルタリング、詳細確認を行う方法がわかります。
- PCBパネルでネットやネットクラスを参照する方法と、そこで確認できる接続情報や長さ情報の概要を把握できます。
PCBエディターでは、ネット内のノード間の接続は、ポイントツーポイントの接続ラインで表され、これらを総称してラッツネストと呼びます。 回路図から設計を転送すると(Design » Update PCB)、コンポーネントがPCB設計スペースに配置され、接続ラインが細い実線で表示されます。
各ネット内では、接続ラインによってそのネットのすべてのノードが結ばれます。接続のパターン、つまり接続順序をNet Topologyと呼びます。これについては後述します。

ネット内のノードは、適用されるRouting Topologyルールに従って接続ラインで結ばれます(デフォルトはShortest)。

この設計では、GNDネットと5Vネットの接続ラインに異なる色が使用されています。
接続ラインは、コンポーネント配置時の便利なガイドとなるだけでなく、インタラクティブ配線や自動配線でも役立ちます。
PCBエディターには、設計スペース内のすべてのオブジェクトの位置を常時監視するネットアナライザーが搭載されており、ネットに属するオブジェクトが編集されると(移動も含む)、接続ラインが更新されます。たとえば、コンポーネントを移動すると、適用されるデザインルールで定義されたトポロジーを維持するよう接続が更新されるため、そのコンポーネントから延びる各接続の接続先が、あるパッドから別のパッドへ切り替わることがあります。下の動画では、GNDネットを例にこの動作を示しています。 このネットのトポロジーはShortestです。

抵抗を移動すると、接続全体の長さが最短になるようにGNDの接続ラインが自動的に組み替えられ、接続先が切り替わる様子に注目してください。
基板上でネットを見つける
未配線の基板は、無数の接続ラインが基板全体で交差しているため、扱いにくく感じられることがあります。配線を進めるうえで有効なのは、重要なコンポーネントやクリティカルなネットを簡単に見つけられる回路図を起点にする方法です。回路図のコンポーネントやネットから直接クロスセレクトやクロスプローブを実行し、PCB上の対応する項目をハイライトできます。詳しくは、回路図と基板を連携させた作業を参照してください。
PCBエディターの便利な機能の1つに、設計スペース内のオブジェクトをマスク表示または淡色表示にする機能があります。このフィルタリング機能は、フィルター条件に一致するオブジェクト以外をすべて目立たなくします。下の画像では、単一のネットが選択されており、フィルター条件に一致しないすべてのオブジェクトをDimにするよう、フィルタリングシステムが設定されています。
この機能を試すには、PCBパネルをNetsモードに設定します。基板上のネットの一覧が表示されます。下の画像のように、ドロップダウンでフィルターモードをDimまたはMaskに設定し、SelectとZoomのオプションを有効にします。
パネル内のネット名をクリックすると、設計スペースの表示が変わり、そのネットのノードが収まるようにズームされます。また、そのネットのパッドと接続ライン以外はすべて目立たなくなり、基板のほかの部分から対象のネットだけを浮かび上がらせることができます。ワークスペース内をクリックしてもフィルターは維持され、選択したネットが明瞭に表示されたままになるため、確認や配線が容易になります。

フィルター機能を使用すると、ネットやネットクラスを見つけやすくなります。
PCBパネル上部のClearボタンをクリックすると、フィルターが解除され、設計スペース全体が通常の明るさに戻ります(または、ショートカットShift+Cを押します)。
個々のネットに加えて、パネルのNet Classesセクションではネットクラスを対象にフィルタリングすることもできます(クラスが定義されている場合)。また、複数のネットを対話的に選択することもできます(Ctrl を押しながらPCBパネル内のネット名をクリックします)。
ネットの参照
PCBパネルの Netsモードでは、3つの主要領域が、現在のPCB設計のネット階層を反映した表示に変わります(上から順に)。
- Net Classes:基板で定義されているもの。
- クラスに属する個々のNets 。
- ネット内の個々のPrimitives(パッド、ビア、トラック、フィル)。
ネットクラス
パネルの上部領域(Net Classes)でネットまたはネット項目のエントリを右クリックし、表示されたメニューから Properties を選択すると(またはエントリを直接ダブルクリックすると)、 Edit Net Classダイアログが開きます。このダイアログでは、クラスに属するネットの確認や編集、クラス名の変更、クラスの追加を行えます。
メインメニューのDesign » Netlistサブメニュー、または選択したネットオブジェクトの右クリックメニューにある Net Actions サブメニューの以下のコマンドでも、ネットクラスを管理できます。
- Create NetClass from Selected Nets - 設計スペース内で選択した2つ以上のネットから、新しいネットクラスを作成するコマンドです。 コマンドを実行すると、Object Class Nameダイアログが開きます。ここで、新しいネットクラスの名前を指定します。OKをクリックするとネットクラスが作成され、選択したネットがメンバーとして追加されます。
- Add Selected Net(s) to NetClass - 選択した1つ以上のネットを、既存のネットクラスに追加するコマンドです。 コマンドを実行すると、Choose Net Classダイアログが開きます。このダイアログには、既存のすべてのネットクラスが一覧表示されます。対象のクラスを選択してOKをクリックすると、選択したネットがそのクラスのメンバーとして追加されます。
- Remove Selected Net(s) From NetClass - 選択した1つ以上のネットを、既存のネットクラスから削除するコマンドです。 コマンドを実行すると、Choose Net Classダイアログが開きます。このダイアログには、既存のすべてのネットクラスが一覧表示されます。対象のクラスを選択してOKをクリックすると、選択したネットがそのクラスのメンバーから削除されます。

Choose Net Classダイアログ
ネット
パネルの中央の領域には、上の領域で選択したネットクラスに属するネットが表示されます。
デフォルトでは、各ネットについて次の情報が表示されます。
-
- この機能には、次の2つの役割があります。
- Color background - ネットに割り当てられた色です。この色は、ネットの接続線に常に適用されます。また、ネットカラー表示のオーバーライド機能を使用して、そのネットの配線にも適用できます。ダブルクリックすると、このネットの色を編集できます。右クリックすると、現在選択されているすべてのネットの色を編集できます。
-
checkbox - チェックを入れると、このネットの配線に色が適用されます(ネットカラー表示のオーバーライド機能が有効になります)。右クリックすると、現在選択されているすべてのネットの表示オーバーライド機能を有効または無効にできます。F5を押すと、設計スペースでネットカラー表示のオーバーライドを有効または無効にできます。
► 詳しくは、ネットカラーのオーバーライド - 配線済みネットをネットカラーで表示するを参照してください。
-
Name - ネットの名前です。
-
Node Count - このネット内のパッドの総数です。
-
Routed Length - 配線を構成する配置済みのトラックおよびアークセグメントの長さと、ビアを通過する垂直方向の距離の合計です(下記の注記を参照)。配線長の計算では、重なり合うトラックセグメントやパッド内の配線の蛇行は補正されません。
-
Signal Length - ノード間の総距離を正確に計算した値です。配置済みオブジェクトを解析し、積み重なったオブジェクトや重なり合うオブジェクト、およびパッド内で蛇行する経路を補正します。ビアの長さも含まれます。ネットの配線が完了していない場合は、接続線のマンハッタン長(X + Y)も含まれます。
信号長の計算には、次の事項が適用されます。
-
パッド内の重なりや蛇行を補正します。
-
トラックやアーク以外のオブジェクト(リージョンやフィルなど)で作成された配線経路にも対応します。
-
ビアを通過する垂直方向の距離を含みます(下記の注記を参照)。
-
このネットのTotal Pin/Package Lengthを含みます。
-
このネットのUnrouted (Manhattan)の長さを含みます。
-
適用されるLength/Matched Lengthデザインルールに違反している場合、信号長の背景色で示されます。信号長が短すぎる場合は黄色、長すぎる場合は赤色で表示されます。
► LengthおよびMatched Lengthデザインルールの適用方法について詳しくは、配線長のチューニングを参照してください。
-
信号はポイントツーポイントの実体です。このため、パネルのNetsモードで信号長が表示されるのは、ノードが2つのネットのみです(ノード数がそれ以外のネットには
0と表示されます)。ノードが3つ以上あるネットの信号長を計算するには、xSignalsを定義してください。► PCB - xSignalsを参照してください。
► xSignalsについて詳しくは、xSignalsによる高速信号経路の定義を参照してください。
-
-
Total Pin/Package Length - そのネット内のすべてのパッドのPin Package Length値の合計です。この値はPCBパッドのプロパティとして定義され、回路図のピンでも指定できます。
-
Unrouted (Manhattan) - すべての未配線区間の垂直方向と水平方向の距離の合計(X+Y)です。
この領域で右クリックし、Columns サブメニューを使用すると、次の列を追加できます。
-
Min/Max - 適用されるLengthおよびMatched Lengthデザインルールの設定です。適用されるルールが定義されていない場合は、内部のデフォルト値である
Min=0milとMax=99999milが使用されます。► LengthおよびMatched Lengthデザインルールから最小値と最大値の設定がどのように求められるかについて詳しくは、配線長のチューニングを参照してください。
- Estimated Length - Routed Lengthに、未配線区間の接続線の長さを加えた値です。未配線部分にはManhattan の長さを使用せず、ポイント間の直線距離を使用します。
- Delay - 信号がその配線に沿って伝搬するのにかかる時間です。
Nets 領域で特定のネットの項目をダブルクリックするか、ネットの項目を右クリックしてコンテキストメニューからProperties コマンドを選択すると、Edit Netダイアログが開き、ネットのプロパティを変更できます。
Edit Netダイアログのオプションとコントロール
プロパティ
- Net Name - 必要に応じて、ネットの名前を変更します。
- Connection Color - クリックするとChoose Colorダイアログが開き、指定したネットの接続線の色を選択できます。ネットカラーのオーバーライド機能が有効な場合(F5を押す)、このネットカラーを配線済みネットにも適用できます。
- Hide Connections - 有効にすると、接続線を非表示にします。
- Hide Jumpers - 有効にすると、ジャンパーまたは配線済みセグメント間の短い接続を非表示にします。
- Remove Loops - 有効にすると、このネットに含まれる冗長なループを自動的に削除します。
他のネットのピン
PCB上のすべてのピンの一覧です。現在ネットに割り当てられているピンには、そのネット名が括弧内に表示されます。編集中のネットに追加するピンを選択します。ShiftおよびCtrlを使用します。 キーを使用して複数のピンを選択します。コントロールボタンを使用して選択したピンを現在のネットリストに移動するか、右クリックしてコンテキストメニューから選択したピンをリストから削除します。
ボタン
-
- すべてのPins in Other NetsをPins in This Netに追加します。
-
- 選択したPins in Other NetsをPins in This Netに追加します。 ShiftキーとCtrlキーを使用して複数のピンを選択します。
-
- すべてのPins in This NetをPins in Other Netsに移動します。
-
- 選択したPins in This NetをPins in Other Netsに移動します。 ShiftキーとCtrlキーを使用して複数のピンを選択します。
ピンをPins in Other NetsリストからPins in This Net リストに移動した後、移動したピンを右クリックしてRemove Oneコマンドを選択すると、Pins in Other Netsリストに戻すことができます。
このネット内のピン
このネット内のすべてのピンが表示されます。このネットから削除するピンを選択します。ShiftキーとCtrlキーを使用して複数のピンを選択します。コントロールボタンを使用して選択したピンを現在のネットリストから移動するか、右クリックしてコンテキストメニューから選択したピンを削除します。
現在のインタラクティブ配線設定
グリッド
グリッド領域には、インタラクティブ配線の現在の設定が表示されます。
- Track Width - 現在のインタラクティブ配線設定のトラック幅フィールドが表示されます。このフィールドは編集可能で、好みや設計要件に合わせて変更できます。
- Name - Current Routing、Layer Stack Reference、Absolute Layerが表示されます。
- Index - インデックス番号が表示されます。
図
- Via Hole Size - ネットに保存されている、現在のビア穴径のユーザー指定値を表します。このダイアログでは、現在のインタラクティブ配線設定の値を変更できます。値がゼロの場合、ユーザー指定値はこのダイアログから取得されず、この基板で最後に使用された値が使用されます。
- Via Diameter - このネットに保存されている、現在のビア径のユーザー指定値を表します。このダイアログでは、現在のインタラクティブ配線設定の値を変更できます。値がゼロの場合、ユーザー指定値はこのダイアログから取得されず、この基板で最後に使用された値が使用されます。
- All Widths - ネットに保存されている現在のユーザー指定値を表す、現在の配線とそのレイヤー参照値です。現在のインタラクティブ配線設定の値を変更できます。値がゼロの場合、ユーザー指定値はこのダイアログから取得されず、この基板で最後に使用された値が使用されます。
- Layers in Layer-Stack only - 有効にすると、レイヤースタック内のレイヤーにのみビアパラメーターを適用します。
プリミティブ
パネル下部のPrimitives領域に各ネットアイテムの種類が表示されるかどうかは、Nets領域またはPrimitives領域から開く右クリックメニューで、それぞれに対応するオプションが有効になっているかどうかによって決まります。

ネットまたはネットアイテムのエントリーを右クリックして、含めるアイテムを選択します。
Primitives リストの右クリックコンテキストメニューには、選択した2つのアイテム間にxSignalを作成するオプションもあります。詳細については、PCB - xSignalsを参照してください。
接続線の表示の管理
Related page: PCBの表示
接続線は、部品の配置や向きの調整を支援し、配線時のガイドとなる便利なものです。ただし、接続線が多数あると表示が煩雑になることもあります。そのため、PCBエディターには、設計者が接続線の表示を管理できるよう、以下の機能が用意されています。
接続線の色の変更
設計を回路図からPCBワークスペースに転送すると、デフォルトのレイヤー設定と色設定が適用されます。この処理の一環として、すべての接続線に、表示設定パネル(ショートカット:L)のLayers & ColorsタブにあるSystem Colorsセクションで定義された、デフォルトのConnection Linesの色が割り当てられます。表示設定は2Dおよび3Dワークスペースの両方で使用でき、保存して再適用することもできます(View ConfigurationパネルのView Optionsタブ)。
配線中に重要なネットを目立たせる簡単な方法は、その接続線の色を変更することです。これを行うには、PCBパネルでネット名をダブルクリックしてEdit Netダイアログを開き、接続線の色を編集します(パネルをNetsモードに設定してください)。
また、1つor複数のネットの色を変更するには、まずPCBパネルで対象のネットを選択し、選択したネットを右クリックしてChange Net Colorコマンドを選択します。

PCBパネルで選択したネットを右クリックすると、接続線の色を変更できます。
レイヤーの色を使用した接続線の表示
ネットごとに接続線の色を割り当てるだけでなく、接続線の始点と終点があるレイヤーの色を使用して接続線を表示することもできます。接続線が、あるレイヤー上のオブジェクトから別のレイヤー上のオブジェクトにつながる場合、始点では最初のオブジェクトがあるレイヤーの色で表示され、終点のレイヤー上のオブジェクトに近づくにつれて、そのレイヤーの色へと徐々に変化します(下図参照)。
この機能は、配線中の接続が到達すべきレイヤーを示すため、多層基板の配線時に役立ちます。色の変化は、異なるレイヤー間をつなぐ接続にのみ適用されます。接続線の始点と終点が同じレイヤー上にある場合は、割り当てられたネットの色が維持されます。
レイヤーの色を使用する機能を利用するには、以下に示すように、View ConfigurationsパネルのView OptionsタブでUse Layer Colors for Connection Drawingオプションを有効にします。

接続線は、始点と終点のレイヤーの色を使用して表示できます。右の画像では、接続線の表示方法がわかるように、いくつかのネットで配線セグメントを削除しています。
単層モードでの接続線の表示
多層基板は視覚的な情報量が多く、状況を把握しにくい場合があります。そのような場合は、Shift+S ショートカットを押すことで、有効なレイヤーの表示からシングルレイヤーモードへ簡単に切り替えられます。
通常、この操作を行うと、現在のレイヤーを始点にも終点にもしていない接続線も、関連性がないとみなされて非表示になります。接続線を常に表示するには、下図のように、View Configurations パネルの View Options タブで All Connections in Single Layer Mode オプションを有効にします。

シングルレイヤーモードでの接続線の表示を制御します。
接続線の非表示/表示
PCB パネルでネットをフィルタリングする代わりに、1本、複数、またはすべての接続線を完全に非表示にできます。View » Connections サブメニューには、接続線の表示を制御するコマンドが用意されています。作業中に N ショートカットキーを押して、これらのコマンドにアクセスすることもできます。 これらのコマンドでは、次の操作を行えます。
ネットトポロジー
ネット内のノードを相互に接続するパターンや順序を、ネットトポロジーと呼びます。ネットトポロジーは、適用される Routing Topology デザインルールによって制御されます。デフォルトのトポロジーは Shortest です。Shortest では、ネット全体の接続長が最短になるパターンで、ネット内のノードが相互に接続されます。コンポーネントの移動中もこの全体の長さが監視され、最短の状態を維持するように接続線のパターンが動的に変化します。上のアニメーションでは、移動中のコンポーネントの下部から下方向に伸びる線が、移動に伴って切り替わる様子を確認できます。これは、接続されているパッドのいずれかが、同じネット内の別のパッドに近づくたびに発生します。
Routing Topology デザインルールを使用した定義済みトポロジーの適用
Routing Topology デザインルールを追加して、ネット(またはネットクラス)に別のトポロジーを設定できます。以下の図では、左側にデフォルトのトポロジールールを適用した状態を、右側に同じネットへ新しい配線トポロジーである Starburst を適用した状態を示しています。Starburst トポロジーでは、Electrical Type が Source に設定されたパッドを中心に、接続が放射状に広がります(すべてのパッドのデフォルトのタイプは Load です)。

デフォルトのトポロジーでは、全体の接続長が最短になるように接続線が配置されます。Starburst トポロジーでは、すべての接続線が Source パッドから放射状に広がります。
カスタムトポロジーの適用
個々のネット内で、2つのノード間の接続を From-To と呼びます。個々のピン間レベルで接続線の経路を制御するには、ネット内で From-To を手動で定義します。これにより、カスタムのネットトポロジーを作成できます。
From-To を定義するには、PCB パネルを From-To Editor モードに設定します。パネル内で2つの Nodes on Net を選択し、Add From To ボタンをクリックすると、From-To が定義されます。設計スペース内で From-To を明確に識別できるように、From-To は実線ではなく破線で表示されます。

2つのパッド間に From-To が定義されています。From-To の線が実線ではなく破線で表示されていることに注目してください。
PCB パネルの From-To Editor モードは、3つのセクションに分かれています。
- Nets
- Nodes選択したネットの
- From-Tos on Net
ネットの項目をクリックすると、そのネット上のすべてのノードがパネルの中央領域に読み込まれます。 ネットの項目をダブルクリックすると、Edit Net ダイアログが開き、所属するノードなど、ネットのプロパティを編集できます。
From-To の追加
選択したネット内の2つのノード間にユーザー定義の From-To を追加するには、パネルの Nodes on Net 領域で2つのノードを選択し、Add From To ボタンをクリックします。
新しく追加した From-To は、パネルの From-To on Net 領域に一覧表示され、設計スペースでは2つのノード間の点線として表示されます。

ネット上に新しい From-To が作成されました。

デザインスペース内のユーザー定義From-To。
From-Toを削除するには、パネルのFrom-To on Net領域で該当するエントリを選択し、Removeボタンをクリックします。
定義済みトポロジーの選択
ネットのトポロジーとは、ピン間接続の配置やパターンのことです。デフォルトでは、各ネットのピン間接続は、全体の接続長が最短になるように配置されます。
ネットにトポロジーを適用する理由はさまざまです。信号の反射を最小限に抑える必要がある高速設計では、ネットをデイジーチェーントポロジーで構成します。グランドネットでは、すべての配線が共通の点に戻るように、スタートポロジーを適用することがあります。ネット内のノードペアに専用のFrom-Toを作成することも、用意されている定義済みの配線トポロジーに基づいて、ネットのFrom-Toを生成することもできます。
以下のトポロジーを使用できます。パネルのFrom-To on Net領域にあるGenerateボタンをクリックしてアクセスします。
- Shortest - ネット内のすべてのノードを、全体の接続長が最短になるように接続します。
-
Daisy Simple - すべてのノードを順番に数珠つなぎに接続します。接続順序は、全体の長さが最短になるように計算されます。ソースパッドと終端パッドが指定されている場合は、それらの間に他のすべてのパッドを、可能な限り短い長さで数珠つなぎに接続します。複数のソース(または終端)が指定されている場合は、それぞれの端で数珠つなぎに接続されます。
-
Daisy Balanced - すべての負荷を均等なチェーンに分割します。チェーンの総数は終端の数と同じです。これらのチェーンは、スター状にソースへ接続されます。複数のソースノードは数珠つなぎに接続されます。
-
Daisy Mid-Driven - ソースノードをデイジーチェーンの中央に配置し、負荷を均等に分割してソースの両側に数珠つなぎに接続します。両端に1つずつ、計2つの終端が必要です。複数のソースノードは中央で数珠つなぎに接続されます。終端の数がちょうど2つでない場合は、Daisy-Simpleトポロジーが使用されます。
- Starburst - 各ノードをソースノードに直接接続します。終端がある場合は、各負荷ノードの後に接続されます。複数のソースノードは、Daisy Balancedトポロジーと同様に数珠つなぎに接続されます。
パッドは、PropertiesパネルのPadモードでElectrical Typeフィールドの設定を変更することにより、Source(ソース)、Terminator(終端)、Load(負荷)として定義できます。Nodes on Net領域でパッドのエントリをダブルクリックすると、PropertiesパネルのPadモードにアクセスできます。

PropertiesパネルのPadモードで、パッドのElectrical TypeをSourceに設定。
パッドの電気的タイプをSourceまたはTerminatorに変更すると、識別用の「[S]」または「[T]」がデザインスペース内に表示されます。
注意事項
-
システムが生成した接続線は、独立したオブジェクトとしてデザインスペースに表示されるわけではありません。From-Toに関連付けられたピン間接続線のみが表示され、インタラクティブ配線や自動配線のガイドとして使用されます。
-
ユーザー定義From-Toは、デザインスペース内に点線で表示されます。この点線は、FromToの追加時に表示されるピン間接続線とは別のものです。ユーザー定義From-Toの線は、関連付けられたピン間接続線の始点と終点を制御します。具体例で説明します。論理的に接続された2つのコンポーネントのピン間に、ユーザー定義From-Toを追加したとします。接続線も追加され、表示されます(PCBパネルはNetsモードに設定)。
-
配線に使用されるピン間接続線に重なっているため、別個に存在するユーザー定義From-Toの線は見えません。しかし、接続の配線を開始すると、2本の線がそれぞれ独立していることがわかります。
-
ここで配線を中断すると、ネットアナライザーが必要なトポロジーを維持するために接続線を追加します。この線は点線(Broken Net Marker)で表示され、ユーザー定義FromToの追加によって指定されたトポロジーを維持するには、この2点間を配線する必要があることを示します。
-
ネットの一部にのみユーザー定義From-Toを指定した場合、PCBエディターは残りのピン間接続(システム生成From-To)をShortestトポロジーに設定します。
-
ネットオブジェクトを移動した場合やネットの一部を手動で配線した場合などに、接続性アナライザーがデザインスペース内の接続線をどのように扱うかは、From-Toの種類によって決まります。
- システム生成From-To - ネットのデフォルトトポロジー(Shortest)を維持するため、ネットアナライザーによる再最適化の一環として、必要に応じて接続線を移動できます。
- ユーザー定義From-To - 定義済みトポロジーの選択によって作成されたFrom-Toでない場合、その接続線はネットアナライザーによる再最適化の対象になりません。From-Toが定義済みネットトポロジー(Shortest以外)の一部である場合は、選択したトポロジーが維持される限り、ネットアナライザーはその接続線を再最適化の対象に含めることができます。
-
From-Toを使用して定義したカスタムトポロジーの実装状態は、対応するネットに適用されたRouting Topology設計ルールのバッチデザインルールチェック(DRC)で確認できます。From-Toのパッド間に電気的接続があり、その最短経路に同じネットの他のパッドが1つ以上含まれている場合、違反として検出されます。
3つのパッド間に、パッド1からパッド2、およびパッド2からパッド3への2つのFrom-Toを作成しています。
From-Toの構成に従って配線しています。パッド1と2の間、およびパッド2と3の間に配線があり、Routing Topologyルールの違反は検出されません。
T字分岐の形で配線しています。From-Toの構成に対応する経路上に他のパッドがないため、Routing Topologyルールの違反は検出されません。
パッド1とパッド3の間、およびパッド2とパッド3の間を配線しています。パッド1とパッド2の間の経路上に別のパッド3があるため、この配線はFrom-Toの構成と一致しません。そのため、パッド1と2の間のFrom-Toについて、Routing Topologyルールの違反が検出されます。
Netlist Manager
メインメニューから Design » Netlist » Edit Nets コマンドを選択して開く Netlist Manager ダイアログには、基板のネットリストを効率的に管理するためのコントロールが用意されています。必要に応じてネットを追加、編集、削除できるほか、それらのネットに含まれるコンポーネントのピン(またはパッド)のプロパティも編集できます。このダイアログからは、PCB 上で接続された銅箔に基づくネットリストの作成や、PCB からのネットリストのエクスポートなど、その他のネットリスト管理ツールにもアクセスできます。
Netlist Manager ダイアログ
Netlist Manager ダイアログのオプションとコントロール
-
Nets In Board - ダイアログのこの領域には、基板に定義されているすべてのネットが名前で表示されます。リストの上にあるマスクフィールドを使用すると、内容をすばやく絞り込めます。
- Edit - クリックすると、Edit Net ダイアログが開き、現在選択されているネットのプロパティを表示および変更できます(リストで複数のネットが選択されている場合は、フォーカスされているネットが対象です。フォーカスされているネットは点線の枠で示されます)。
- Add - クリックすると、基板に新しいネットを追加できます。Edit Net ダイアログが開き、ネットのプロパティを定義できます。新しいネットの初期のデフォルト名は NewNet です。必要に応じて変更してください。
-
Delete - クリックすると、現在選択されているネットを基板から削除します。確認ダイアログが表示されるので、Yes をクリックして削除を続行します。
-
Pins In Focused Net - この領域には、現在選択またはフォーカスされているネットに関連付けられている、または属しているすべてのピン(コンポーネントのパッド)が表示されます。リストの各項目では、ピンの識別子が <ComponentDesignator>-<PinDesignator> の形式で表示されます。リストの上にあるマスクフィールドを使用すると、内容をすばやく絞り込めます。
- Edit - クリックすると、Pad ダイアログが開き、現在選択されているピン(パッド)のプロパティを表示および変更できます。
-
Menu - クリックすると、次のコマンドを含むメニューが開きます。
- Add Net - 基板に新しいネットを追加します。Edit Net ダイアログが開き、ネットのプロパティを定義できます。
- Delete Net - 現在選択されているネットを基板から削除します。確認ダイアログが表示されるので、Yes をクリックして削除を続行します。
-
Update Free Primitives From Component Pads - 配線プリミティブのネット名を、接続先のパッドのネット名に再同期します。コマンドを実行すると、フリープリミティブのネットをコンポーネントのパッドのネットに合わせて更新するかどうかを確認するダイアログが表示されます。Yesをクリックすると、各パッドを起点として接続された銅箔が選択され、各プリミティブのネット名がパッドのネット名と一致するように設定されます。
- Clear All Nets - 現在の設計ドキュメントからすべてのネットを消去し、PCB の内部ネットリストを空にします。元の回路図ドキュメントでネット情報を変更し、そのネットリスト情報と PCB を完全に再同期したい場合などに便利です。コマンドを実行すると、この操作によって PCB からすべてのネット情報が消去されることを知らせる確認ダイアログが表示されます。Yesをクリックすると、すべてのネット情報が削除されます。配線済みのトラックはそのまま残りますが、割り当ては No Net になります。未配線の論理接続はすべて削除されます。
- Export Netlist From PCB - 現在のドキュメントの PCB 内部ネットリストをファイルにエクスポートします。コマンドを実行すると、PCB からネットリストをエクスポートするかどうかを確認するダイアログが表示されます。Yesをクリックすると、PCB 設計ドキュメントと同じフォルダーにネットリスト(Exported <PCBDocumentName>.Net)が作成されます。
-
Create Netlist From Connected Copper - 現在の設計の配線による接続に基づいて、ネットリストファイルを作成します。コマンドを実行すると、PCB 上の銅箔からネットリストを生成するかどうかを確認するダイアログが表示されます。Yesをクリックすると、PCB 設計ドキュメントと同じフォルダーにネットリスト(Generated <PCBDocumentName>.Net)が作成され、メインの設計ウィンドウでアクティブドキュメントとして自動的に開きます。
Pad ダイアログのオプションとコントロール
パッドテンプレート
- Template - ドロップダウンからパッドテンプレートを選択します。
- Library - パッドテンプレートがリンクされているライブラリを表示します。また、そのライブラリからテンプレートのリンクを解除するオプションもあります。
位置
- X - 現在の原点を基準とした、パッド中心の現在の X 座標です。値を編集すると、原点に対するパッドの位置を変更できます。
- Y - 現在の原点を基準とした、パッド中心の現在のY座標です。値を編集すると、原点に対するパッドの位置を変更できます。
- Rotation - 現在のパッドの回転角度(度)です。編集すると、パッドの回転角度を変更できます。最小角度分解能は0.001°です。
穴情報
- Hole Size - パッドの現在の穴径です。この値は、製造時にパッドに開ける穴の直径(milまたはmm単位)を指定します。単一レイヤーのパッド(SMDパッドやエッジコネクタなど)では、自動的にゼロに設定されます。穴径は0~1000mil の範囲で設定でき、パッド領域より大きく設定することで、銅箔のない機械穴を定義できます。このフィールドの値を編集すると、パッドの穴径を変更できます。値はmmまたはmil単位で入力できます。
- Tolerance - 穴の公差属性を設定すると、基板のはめあいや許容限界の決定に役立ちます。設計の穴公差の最小値(-)と最大値(+)を指定します。
次のいずれかのオプションを選択して、穴の形状を指定します。
- Round - パッドの穴を円形(デフォルト)に指定します。
- Square - パッドの穴を正方形(打ち抜き穴)に指定します。
- Slot - パッドの穴を両端が丸い長穴に指定します。
- Plated - パッドの穴をめっきするかどうかを指定します。設計内にめっきありとめっきなしの両方のパッドが存在する場合、NCドリルファイルでは、めっきなしの穴にめっきありの穴とは異なる工具が使用されるように設定されます。
プロパティ
- Designator - 現在のパッドデジグネータです。パッドがコンポーネントの一部である場合、デジグネータは通常、対応するコンポーネントのピン番号に設定されます。デジグネータは最大20文字で、スペースは使用できません。フリーパッドにはデジグネータを設定することも、フィールドを空欄のままにすることもできます。デジグネータの先頭または末尾が数字の場合、パッドを連続して配置すると、その数字が自動的に増加します。このフィールドの値を編集すると、パッドデジグネータを変更できます。必要に応じて、同じコンポーネントフットプリント内の複数のパッドに同じデジグネータを使用することもできます。
-
Layer - パッドが現在割り当てられているレイヤーです。パッドは使用可能な任意のレイヤーに割り当てられます。すべての信号レイヤーにパッド形状を定義するには、Layerを
Multi-Layerに設定します。 - Net - パッドが現在割り当てられているネットです。フィールドをクリックし、ドロップダウンリストからネットを選択すると、ネットの割り当てを変更できます。パッドをどのネットにも接続しない場合は、No Netを選択します。Net プロパティは、PCBオブジェクトがルールに適合した位置に配置されているかどうかをデザインルールチェッカーが判定するために使用します。
- Electrical Type - このフィールドには、パッドの現在の電気的な属性が表示されます。この属性はコンポーネントのパッドにのみ適用され、これらのパッドの伝送線路特性を設定します。パッドは、負荷、ソース、または終端として指定できます。ソースおよび終端の設定は、ネットにデイジーチェーン配線トポロジーが必要な場合に使用されます。フィールドをクリックし、ドロップダウンリストから電気的タイプを変更します。
- Pin/Pkg Length - ピンパッケージ長は、PCB パネルに表示される Signal Length の計算に自動的に含まれます。選択したネット内のピンの Pin/Pkg Length の値を確認(または編集)するには、PCB パネルを Nets モードに設定します。
- Jumper ID - このパッドがジャンパーコンポーネントのフットプリントの一部であることを示すには、ゼロ以外の値(1~1000)を設定します。ジャンパーコンポーネントは、配線パターンではなくワイヤーリンクでパッド間を物理的に接続する片面PCBで使用できます。ジャンパーIDの値は、どのパッドを「接続済み」として扱うかをソフトウェアに指示します。ジャンパー接続を作成できるのは、同じコンポーネントフットプリント内のパッド間のみです。これらのパッドには、同じJumper IDの値と同じネットを割り当てる必要があります。また、コンポーネントのTypeをJumperに設定する必要があります。これらの条件が満たされると、PCBエディターでジャンパー接続が曲線の接続線として表示されます。
- Locked - 有効にすると、パッドをグラフィカルに編集できないように保護します。位置やサイズが重要なパッドはロックしてください。ロックされたプリミティブを編集しようとすると、ロックされていることが通知され、操作を続行するかどうかを確認するメッセージが表示されます。このオプションがオフの場合、確認なしでプリミティブを自由に編集できます。なお、Locked チェックボックスは、コンポーネントに属するパッドには効果がありません。コンポーネントがロックされていない場合、コンポーネントを移動するとパッドも移動します。この場合は、誤って移動しないようにコンポーネントをロックしてください。
テストポイント設定
この領域では、Fabricationおよび/またはAssemblyのテストポイントファイル生成用に、このパッドをテストポイントとして定義します。テストポイントとは、基板が正しく機能するかを確認するために、テストプローブをPCBに接触させる位置です。必要なテストポイントの種類とレイヤーのチェックボックスをオンにすることで、任意のパッドまたはビアをテストポイントに指定できます。指定すると、パッドまたはビアが自動的にロックされます。また、パッドがコンポーネントに属している場合は、そのコンポーネントもロックされます。移動が必要な場合は、パッド/ビア/コンポーネントのロックを一時的に解除できます。テストポイントの設定を無効にしても、パッド/ビア/コンポーネントのロックは自動的には解除されません。手動で解除する必要があります。
- Top - このオプションを有効にすると、このパッドがトップレイヤーのテストポイントとして定義されます。
- Bottom - このオプションを有効にすると、このパッドがボトムレイヤーのテストポイントとして定義されます。
サイズと形状
パッドの銅箔領域(ランド領域)は、XおよびYのサイズと形状の設定によって定義されます。
- Simple - シンプルパッドは、すべてのレイヤーでサイズと形状が同じパッドです。
-
Top-Middle-Bottom - Top-Middle-Bottom構成のパッドでは、トップレイヤー、すべての中間信号レイヤー、ボトムレイヤーそれぞれに、異なるXおよびYのサイズと形状を定義できます。
- X-Size - パッドの現在のX方向(水平方向)のサイズです。1~10000milの値を入力します。XとYのサイズは個別に設定でき、非対称のパッド形状を定義できます。
- Y-Size - パッドの現在のY方向(垂直方向)のサイズ。1~10000milの値を入力します。XとYのサイズは個別に設定でき、非対称のパッド形状を定義できます。
-
Shape - パッドの基本形状。基本的なパッド形状には、
Round、Rectangular、Octagonal、Rounded Rectangleがあります。XとYのサイズ設定を変更して基本形状を調整することで、非対称のパッド形状を作成できます。 -
Corner Radius - このオプションは、Shapeが
Rounded Rectangleに設定されている場合に使用できます。この値は、パッドの最短辺の半分に対する割合です。そのため、 0%は長方形のパッドに、100%は円形のパッドに相当します。 - Offset From Hole Center (X/Y) - パッド穴の中心からパッドのランド領域をオフセットする量を入力します。
-
Full Stack - レイヤーごとに(すべての信号レイヤーとプレーンを含む)、異なる穴サイズや直径を編集できます。
-
Edit Full Pad Layer Definitions - クリックすると、Pad Layer Editorダイアログが開きます。このダイアログには、パッド形状、サイズ、X/Y位置など、各レイヤーのパッド/ビア設定に関するコントロールが用意されています。このボタンを使用するには、Full Stackを選択する必要があります。
Options and Controls of the Pad Layer Editor Dialog
- Main Grid - パッドスタックは、スタックの各レイヤーにおけるパッドの形状とサイズに関する情報をまとめたものです。このグリッドの属性をクリックすると、スタックの現在のレイヤーの値を編集できます。パッドスタックのレイヤーは、 Layer Stack Manager(Design » Layer Stack Manager)に基づきます。
-
Attributes on Layer
- Shape - ドロップダウンリストからパッド形状を選択します:Round、Rectangular、Octagonal、Rounded Rectangle。
- X Size - クリックしてパッドのXサイズを指定します。
- Y Size - クリックしてパッドのYサイズを指定します。
- Corner Radius (%) - クリックしてパッドのコーナー半径を指定します。このフィールドは、Rounded Rectangleの場合のみ編集できます。
-
Layer Stack Reference
- Name - パッドレイヤーが参照するレイヤー。
- Index - レイヤーの相対インデックス。
-
Absolute Layer
- Name - デフォルトで定義されているレイヤー名。
- Index - すべてのレイヤー(非表示のレイヤーを含む)におけるパッドの絶対インデックス。
- Only show layers in layerstack - このオプションを有効にすると、レイヤースタック内のレイヤー(Layer Stack Managerに基づく)のみが表示されます。使用されているレイヤーを確認するには、 Layer Stack Manager (Design » Layer Stack Manager)を確認してください。 このオプションを無効にすると、使用可能なすべてのPCBレイヤーが表示されます。
-
ペーストマスク拡張
パッドと同じ形状のペーストマスク開口部が、ソフトウェアによって自動的に作成されます。この設定により、開口部をパッド自体より大きく(正の拡張値)、または小さく(負の拡張値)できます。 通常、ペーストマスクの開口部はパッドより小さくしますが、例外もあります。
- Expansion value from rules - このオプションを有効にすると、このパッドのペーストマスク拡張は、適用されるペーストマスク拡張デザインルールによって定義されます。
- Specify expansion value - このオプションを有効にすると、ルールをオーバーライドして、このパッドのペーストマスク拡張値を指定できます。
ソルダーマスク拡張
パッドと同じ形状のソルダーマスク開口部が、ソフトウェアによって自動的に作成されます。この設定により、開口部をパッド自体より大きく(正の拡張値)、または小さく(負の拡張値)できます。 通常、ソルダーマスクの開口部はパッドより大きくしますが、例外もあります。
- Expansion value from rules - このオプションを有効にすると、このパッドのソルダーマスク拡張は、適用されるソルダーマスク拡張デザインルールによって定義されます。
- Specify expansion value - このオプションを有効にすると、ルールをオーバーライドして、このパッドのソルダーマスク拡張値を指定できます。
- Solder Mask From The Hole Edge - このダイアログで拡張値を指定する場合、このオプションを有効にすると、パッドの端ではなく穴の端を基準にソルダーマスク拡張を定義することもできます。
- Force complete tenting on top - テンティングとは、to close offを意味します。このオプションを有効にすると、適用されるソルダーマスク拡張デザインルールの設定がオーバーライドされ、このパッドの上面ソルダーマスクレイヤーに開口部が作成されなくなります。このオプションを有効にすると、Expansion value from rulesおよび Specify expansion valueオプションは無視されます。
- Force complete tenting on bottom - テンティングとは、to close offを意味します。このオプションを有効にすると、適用されるソルダーマスク拡張デザインルールの設定がオーバーライドされ、このパッドの下面ソルダーマスクレイヤーに開口部が作成されなくなります。このオプションを有効にすると、Expansion value from rulesおよび Specify expansion valueオプションは無視されます。
ネットのレポート作成
アクティブなPCBドキュメントからネットリストステータスレポートを生成するには、メインメニューから Reports » Netlist Status コマンドを選択します。 このレポートには、配線済み基板のネットリストに関する詳細情報が表示されます。すべてのネットが一覧表示され、ネットごとに、配線に使用されているレイヤーと物理的な配線トラック長の合計が示されます。 コマンドを実行すると、レポート( Net Status - <PCBDocumentName>.html )が生成され、アクティブなドキュメントとして開きます。各ネットが一覧表示され、ネット名をクリックすると、PCBドキュメント上でそのネットがハイライト表示されます。物理的な配線トラック長のデータは、最初は基板設計自体に指定された測定単位で表示されます。レポートの Units フィールドを使用すると、必要に応じてヤード・ポンド法とメートル法の単位をすばやく切り替えられます。
)。









