トラックと円弧の操作
概略
- 基本的なコマンドとショートカットを使って、PCBエディターでトラックセグメントを配置、編集、移動、再配線する方法を学びます。
- ネット、レイヤー、コーナーモード、競合の解決方法、適用されるデザインルールに応じて、インタラクティブルーティングがどのように動作するかを理解します。
- 配線幅の決定方法と調整方法を確認し、環境設定やルールが使用可能な配線幅にどのように影響するかを学びます。
トラックの操作
トラックセグメント は、指定された幅を持つ直線です。トラックを使用して、PCB設計スペース内に直線を作成します。トラックは信号層に配置され、コンポーネントのパッド間を電気的に接続する配線を形成します。非電気層に配置されたトラックはラインと呼ばれ、コンポーネントの外形、説明情報、キープアウト境界などを作成する汎用の描画要素として使用されます。トラックは、寸法や座標などのグループ化された設計オブジェクトにも使用されます。

トラックオブジェクトは、配線や汎用の描画線として使用されます。上の画像には、配置済みのトラックセグメントが4つと、配置中のセグメントが1つあります。
トラックとラインは実際には同じオブジェクトですが、配置時のソフトウェアの動作が異なるため、それぞれ別のコマンドが用意されています。 Interactive Routingなどのトラック配置コマンドを実行すると、ソフトウェアはクリック位置を監視し、その位置にある既存のオブジェクト(パッドなど)のネット名を自動的に引き継ぎます。また、適用されるデザインルールを監視し、それらに従います。ライン配置コマンド(Place » Line)を実行した場合、このような監視動作は行われません。
トラックは、PCBエディターとPCBライブラリエディターの両方で配置できます。使用するコマンド(配線/トラック配置またはライン配置)にかかわらず、 基本的な配置動作は同じです。コマンドを起動すると、カーソルが十字形に変わり、トラック配置モードになります。配置は次の手順で行います。
- クリックするか Enter を押して、最初のトラックセグメントの始点を確定します。配線用の配置コマンドを実行している場合、既存のオブジェクト上をクリックして配置を開始すると、トラックはそのオブジェクトのネット名を引き継ぎます。配線時の幅は、適用される 配線幅 デザインルールによって決まります。ただし、特定のインタラクティブ配線オプションで上書きできます。詳細は後述します。
- カーソルを移動してトラックセグメントを定義し、クリックするか Enter を押して、この最初のセグメントの終点を確定します。この点は、次に接続されるセグメントの始点にもなります。
- 引き続きカーソルを移動し、クリックするか Enter を押して、一連の接続されたトラックセグメントを定義する頂点を順に確定します。
- 右クリックするか Esc を押して、現在の一連の接続されたトラックセグメントの配置を終了します。
配置中には、次の操作も行えます。
- テンキーの * キーを押して、使用可能な信号層を順に切り替えます。または、 Shift+Ctrl+Wheel Roll の組み合わせで配線層を切り替えることもできます。マウスホイールを1目盛り回すごとに、次(または前)の使用可能な信号層に移動します。
- テンキーの + および - キーを押して、設計内で現在表示されているすべての層を順方向または逆方向に切り替えます。
トラックセグメントの配置時には、5つのコーナーモードを使用できます。そのうち4つには、コーナー方向のサブモードもあります。配置中には、次の操作を行えます。
- Shift+Spacebar を押して、使用可能なコーナーモードを順に切り替えます。
- Spacebar を押して、2つのコーナー方向サブモードを切り替えます。
- いずれかの円弧コーナーモードでは、, または . キーを押し続けて、円弧を縮小または拡大します。Shift キーを同時に押すと、円弧のサイズ変更が速くなります。
- 1 ショートカットキーを押して、1回のクリックで1セグメントを配置するモード(下の最初の5つの画像)と、1回のクリックで2セグメントを配置するモード(下の最後の画像)を切り替えます。最初のモードでは、輪郭のみで表示されるトラックセグメントを先読みセグメントと呼びます。
- Backspace キーを押すと、最後の頂点を削除できます。



Shift+Spacebar を押して5つのコーナーモードを順に切り替え、Spacebar を押してコーナー方向を切り替えます。1 ショートカットを押すと、1セグメント配置と2セグメント配置を切り替えられます。
グラフィカルな編集方法では、設計スペース内で配置済みのトラックオブジェクトを直接選択し、そのサイズ、形状、位置を視覚的に変更できます。
トラックオブジェクトを選択すると、次の編集ハンドルが表示されます。
- A をクリックしてドラッグすると、トラックの端点を移動できます。
- B をクリックしてドラッグすると、トラックの形状を変更できます。
PCBエディターには、配線の接続構成を維持しながら基板上のトラックセグメントを移動するための高度なアルゴリズムが組み込まれています。このトラックセグメントのスライド操作は、まずクリックしてセグメントを選択し、専用のカーソルが表示されたらクリックしたままスライドさせるか、トラックセグメントを直接クリックしたままスライドさせることで、インタラクティブに実行できます。スライド動作は、Preferences ダイアログの PCB Editor - Interactive Routingページ にある Dragging オプションで設定できます。これらのオプションでは、トラックに移動アクションを割り当てることができます。これは、個々のトラックセグメントを自由に移動したい場合に便利です。

Preferencesで設定するドラッグオプションによって、トラックのスライド動作を制御できます。
これらのオプションで Move アクションを割り当てると、移動中にトラックセグメントを回転または反転できます。
インタラクティブ配線と適用されるデザインルール
インタラクティブ配線では、適用される電気および配線のデザインルールに従ってトラックセグメントが配置されるようにすることが、ソフトウェアのデフォルトの動作です。つまり、別のネットに属する既存のトラックセグメントに対してルール違反となる新しいトラックセグメントは配置できません。代わりに、デザインルールを満たすようにトラックセグメントの長さが制限されます。このインタラクティブ配線の動作は、Routing Conflict Resolution モードと呼ばれます。デフォルトのモードは Stop at First Obstacle です(現在のモードはステータスバーに表示されます)。Shift+R を押すと、使用可能なモードを順に切り替えられます。
applicable design rules という用語は、配置するオブジェクトに適用されるすべてのルールを意味します。デザインルールエンジンは、各ルールを適用するオブジェクトの範囲を厳密に指定する仕組みで動作します。配置中には、現在の配置状況に適用される最も優先度の高いルールを特定するため、デザインルールエンジンへの問い合わせが行われます。インタラクティブ配線中に適用されるルールには、次のものがあります。
- 電気的クリアランス
- 配線幅
- 配線ビアスタイル
下のアニメーションは、実際の配線操作を示しています。GNDネットは、定義済みの適用対象となる配線幅デザインルールに従って配線されています。+12Vネットに接続されたビアの上にカーソルを移動すると、適用される 電気的クリアランス制約 デザインルールを満たすように、配線の長さが自動的に制限されることに注目してください。

インタラクティブ配線中は、適用される配線幅およびクリアランスのデザインルールが自動的に守られます。
配線幅の決定方法
ルールエンジンが無効になっていない限り、ソフトウェアは、配線幅が適用対象のRouting Width設計ルールで許容される範囲内に必ず収まるように動作します。一般的には、ネットに対して一定範囲の配線幅を許容し、そのネットの電流容量要件を満たしながら、柔軟に配線を配置できるようにします。このため、Routing Width設計ルールには、PCB Rules and Constraints Editorで設定できるMin、Preferred、Maxがあります。これらを設定して配線幅に範囲を持たせることも、すべて同じ値にして特定の幅を指定することもできます。配線幅はインピーダンスに基づいて設定することもでき、信号層ごとに異なる範囲を指定することもできます。

新規PCBでは、デフォルトのRouting Width設計ルールがすべてのネットに適用されます。
配線を開始する際に最適な配線幅を選択できるよう、設計者向けにいくつかのオプションが用意されています。これらは、以下に示すように、PreferencesダイアログのPCB Editor — Interactive Routingページで設定します。

Interactive Routing Width Sourcesオプションによって、配線開始時に使用するサイズが決まります。
画像では、Track Width ModeがRule Preferredに設定されている点に注目してください。これは、パッドなどの既存のネットオブジェクトから配線を開始した場合に、この幅が使用されることを示しています。ただし、既存のトラックから配線を開始した場合は、Pickup Track Width From Existing RoutesオプションがTrack Width Modeより優先され、新しい配線幅が既存の幅に合わせられます。
設計者は、配線中にShift+Wショートカットを押して、別の幅を選択できるダイアログを開くことも、Tabを押してProperties panel を開き、新しいWidth 値を入力することもできます。選択または入力した値は、適用対象のルールで定義されているMinとMaxの設定値の間に収まる必要があります。範囲外の場合は、最も近い境界値に自動的に補正されます。
インタラクティブ配線のショートカット
配線中には、さまざまなショートカットを使用できます。たとえば、Shift+Rを押すと使用可能な競合解決モードを順に切り替えることができ、Backspaceを押すと最後に配置した頂点(コーナー)を削除できます。配線中にショートカットの一覧を表示するには、Shift+F1を押します。使用可能なインタラクティブ操作のショートカットメニューが表示されます。必要なショートカットを選択するか、Escを押してメニューを閉じ、ショートカットキーを使用してください。

インタラクティブ配線中にShift+F1を押すと、使用可能なインタラクティブ操作のショートカットメニューが表示されます
トラックの移動
Edit » MoveサブメニューおよびActive Barの移動コマンドメニューには、トラックの位置や形状を変更するためのコマンドがいくつか用意されています。
再配線
このコマンドを使用すると、基板上の既存のトラックを手動で再配線できます。コマンドを実行すると、カーソルが十字形に変わり、トラックを選択するよう求められます。目的のトラック上にカーソルを置き、クリックするかEnterを押します。この機能の動作は、PreferencesダイアログのPCB Editor - Interactive RoutingページでPreserve Angle When Draggingオプションが有効になっているかどうかによって異なります。
- Preserve Angle Dragging enabled - トラックが分割され、直交/斜めの接続を維持するために新しいセグメントが追加されます。カーソルを動かしてこのセグメントを目的の位置までスライドさせ、クリックして配置を確定します。この時点で右クリックするかEsc を押してください。そうしないと、新しいセグメントがさらに分割され、別のセグメントが追加されます。Shift+Rキーボードショートカットを使用すると、ドラッグ中の障害物の扱いを制御するオプション(Ignore Obstacles、Avoid Obstacles、Avoid Obstacles (Snap Grid))を順に切り替えられます。Avoid Obstaclesモードのいずれかが有効な場合は、ドラッグ中もルールが遵守されるため、ルール違反となる位置にセグメントをドラッグすることはできません。
- Preserve Angle Dragging disabled - トラックセグメントの両端が固定され、その間に新しいトラックセグメントを配置できるようになります。クリックするかEnterを押して、新しいトラックセグメントを配置します。再配線用の新しいトラックセグメントを引き続き配置するか、右クリックするかEscを押して停止します。
引き続き他のトラックを再配線するか、右クリックするかEscを押して終了します。
トラックの分割
このコマンドを使用すると、トラックセグメント内に頂点(分割点)を作成できます。コマンドを実行すると、カーソルが十字形に変わり、トラックを選択するよう求められます。目的のトラックセグメント上で、分割点を挿入したい位置にカーソルを置き、クリックするかEnterを押します。頂点が挿入され、元のセグメントが2つに分割されます。
頂点を目的の位置に移動し、クリックするかEnter を押して配置します。接続されているトラックセグメントの動作は、PreferencesダイアログのPCB Editor - Interactive RoutingページにあるPreserve Angle When Draggingオプションの設定によって決まります。
- Preserve Angle When Dragging 有効 - 隣接するトラックセグメントとの角度が保持され、配線スタイルが維持されます。
- Preserve Angle When Dragging 無効 - 2つのトラックセグメントが移動に合わせてラバーバンドのように伸縮し、既存の配線スタイルは維持されません。
引き続き他のトラックセグメントを分割するか、右クリックするかEscを押して終了します。
トラック端点のドラッグ
このコマンドを使用すると、配線済みのトラックセグメントの端点を手動で移動またはドラッグできます。コマンドを実行すると、カーソルが十字形に変わり、オブジェクトを選択するよう求められます。トラック上にカーソルを置き、クリックするかEnterを押します。カーソルが最も近いトラックセグメントの端点に移動し、その端点がカーソルに追従するようになります。トラックの端点を目的の位置に移動し、クリックするかEnterを押して配置を確定します。
- 選択したトラックセグメントの端点が、他のトラックセグメントに接続されていない頂点の場合は、その頂点を目的の位置に移動します。
- 選択したトラックセグメントの端点が、2本のトラックセグメントが接続されている頂点の場合は、頂点の移動に合わせて、接続されているトラックセグメントがラバーバンド動作で追従します。
- トラックセグメントの端点が部品のパッドに接続されている場合、端点を移動するとパッドとの接続が解除されます。端点を移動した後、PreferencesダイアログのPCB Editor – GeneralページでSmart Track Endsオプションが有効になっていれば、トラックの端点からパッドまでの論理接続線が表示されます。
- トラックセグメントの端点がフリーパッドに接続されている場合、パッドがカーソルに追従し、再配置できる状態になります。パッドに接続されているすべてのトラックも、ラバーバンド動作で追従します。
- トラックセグメントの端点がビアに接続されている場合、ビアがカーソルに追従し、再配置できる状態になります。ビアに接続されているすべてのトラックも、ラバーバンド動作で追従します。
続けて他のトラックの端点をドラッグするか、右クリックまたはEscを押して終了します。
トラックの移動/サイズ変更
このコマンドは、選択した複数のトラックセグメントの端点を移動し、セグメントのサイズを変更するために使用します。コマンドを実行すると、カーソルが十字に変わり、トラックの端点を選択するように求められます。トラックを移動/サイズ変更するには、次の手順に従います。
- 選択したセグメントのいずれかの端点にカーソルを合わせ、クリックするかEnterを押します。
- カーソルを移動すると、選択したすべてのトラックセグメントのサイズが、相互の元の距離と角度を維持しながら動的に変更されます。各セグメントのもう一方の端点は、既存の接続や位置を維持するようにラバーバンド動作で追従します。
- セグメントが目的の位置に来たら、クリックするかEnter を押して配置を確定し、移動モードを終了します。
- 操作をキャンセルするには、右クリックするかEscを押します。
セグメントの移動中は、次の追加操作を使用できます。
- Tab キーを押すと、選択した各トラックセグメントの端点にカーソルが順番に切り替わります。
- 移動中にAlt キーを押し続けると、最初に移動した方向に応じて、移動方向を制限できます。水平方向、垂直方向、45度方向に制限できます。
- Spacebar をすばやく2回押すと、すべてのトラックセグメントの端点を水平または垂直の一直線上に揃えられます。Spacebarを再びすばやく2回押すと、変更前のサイズに戻ります。
トラックの切断
Track Slicerツールを使用すると、1本または複数のトラックセグメントを簡単に2つに切断できます。現在の信号レイヤー、または表示されているすべての信号レイヤー上のトラックを切断できます。このツールを使用するには、メインメニューからEdit » Slice Tracksコマンドを選択します。
コマンドを実行すると、カーソルが十字に変わり、切断の開始位置を選択するように求められます。また、フィルターが適用され、ワークスペース内にはトラックオブジェクトのみが表示されます。Track Slicerの現在の設定に応じて、表示されているすべての信号レイヤー上のトラック、または現在の信号レイヤー上のトラックのみが表示されます。1本または複数のトラックを切断するには、次の手順に従います。
- カーソルを配置し、クリックするかEnterを押して、切断の開始点を固定します。
- 切断したいトラックの位置を横切るようにカーソルを移動します。スライサーの軌跡が線で表示され、切断予定箇所も視覚的に示されます。
- クリックするかEnterを押して、スライサーの軌跡の終点を固定します。
- 続けて他のトラックセグメントを切断するか、右クリックまたはEscを押して切断モードを終了します。
切断の開始点を指定した後、「切断線」を移動している間は、次の追加操作を使用できます。
- Bキーを押すと、現在の信号レイヤー上のトラックのみを切断するか、表示されているすべての信号レイヤー上のトラックを切断するかを切り替えられます。
- Spacebarを押すと、切断角度を45度刻み、または任意の角度に切り替えられます。
- Nキーを押すと、スライサーの刃の位置が左、右、中央の順に切り替わります。
- /キーを押すと、切断されたすべてのトラックを選択できます。
- 「,」キーを押すと、スライサーの左側にある切断されたトラックを選択できます。
- 「.」キーを押すと、スライサーの右側にある切断されたトラックを選択できます。
- Mキーを押すと、切断されたトラックを選択しない状態にできます。
-
Tabキーを押すとSlicer Propertiesダイアログが開き、Track Slicerのプロパティをその場で変更できます。

Slicer Propertiesダイアログ
トラックを面取りした経路に変換する
90 度の配線コーナーの面取りは、マイクロ波周波数の配線でコーナーに起因する反射を低減するための手法です。円弧を使用することもできますが、その半径は配線幅の少なくとも 3 倍にする必要があります。面取り(マイタリングとも呼ばれます)は、コーナーの外側の頂点を切り落とす代替手法です。Altium Designer のトラックオブジェクトは端部が丸いため、面取りされたコーナーの作成には使用できません。面取りされたコーナーを作成するため、選択したトラックセグメントはリージョンオブジェクトに置き換えられます。
面取りするすべてのトラックセグメントを選択し、メインメニューから Tools » Convert » Convert Selected Tracks to Chamfered Path コマンドを選択します。Convert Tracks to Chamfered Path ダイアログが開きます。このダイアログで面取りを設定し、OK をクリックします。選択したトラックセグメントの各ペア(対象となる 90 度の角度を持つもの)は面取りされたコーナーに置き換えられ、各ペアの元のトラックセグメントは単一のソリッド(銅箔)リージョンオブジェクトに変換されます。

選択したトラックは、各直角コーナーで指定した量だけ面取りされます。
ダイアログの以下のオプションを使用して、面取りを設定します。
- Chamfer - 外側のコーナーを切り落とす、つまり面取りする量を、既存のコーナーの対角距離に対する割合で指定します。
- Inside Chamfer - 内側のコーナーに追加する材料の量を、既存のコーナーの対角距離に対する割合で指定します。
How big should the Chamfer be?
マイター率とは、面取り前の曲がり部分の内側と外側のコーナーを結ぶ対角線に対して、切り取られる部分が占める割合です。
幅広いマイクロストリップ形状における最適なマイターは、Douville と James によって実験的に求められています。彼らは、最適なマイター率をよく近似する式として、次の式を示しています。
条件は
で、基板の比誘電率は
です。
この式は
にまったく依存しません。Douville と James が実際に検証結果を示しているパラメーターの範囲は、
および
です。彼らの報告によると、マイター率がこの式で得られる値から元の
の 4% 以内であれば、VSWR は 1.1 未満(すなわち反射は −26 dB 未満)になります。
が最小値の 0.25 のとき、マイター率は 98.4% となり、ストリップはほぼ切断される状態になります。
トラックのプロパティ
ネット情報
この領域には、トラックが属するネットの情報と、そのネットがメンバーである場合は差動ペアや xSignal の情報が表示されます。該当する場合はクラス情報も表示されます。Delay、Length、Max Current、Resistance の値も表示されます。
ネット情報の詳細については、PCB の配置と編集のテクニックページを参照してください。
位置
-
(X/Y)
- X (最初のフィールド)– 現在の設計スペースの原点を基準とした、トラックの基準点の現在の X(水平)座標です。編集すると、トラックの X 位置を変更できます。値はメートル単位系またはヤード・ポンド単位系で入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も指定してください。
- Y (2 番目のフィールド)– 現在の原点を基準とした、トラックの基準点の現在の Y(垂直)座標です。編集すると、トラックの Y 位置を変更できます。値はメートル単位系またはヤード・ポンド単位系で入力できます。現在のデフォルトとは異なる単位で値を入力する場合は、単位も指定してください。
プロパティ
- Component – このフィールドは、選択したトラックが PCB コンポーネントの構成要素である場合にのみ PCB エディターに表示され、親 PCB コンポーネントのデジグネーターを示します。クリック可能な Component リンクを選択すると、親コンポーネントの Properties パネルの Component モードが開きます。
-
Net – トラックのネットを選択します。ドロップダウンリストには、アクティブな基板設計のすべてのネットが表示されます。すでにネットに接続されている既存のオブジェクトと同じ位置からオブジェクトの配置を開始すると、新しいオブジェクトの Net プロパティには、そのネットが自動的に割り当てられます。トラックがどのネットにも接続されていないことを指定するには、No Net を選択します。プリミティブの Net プロパティは、デザインルールチェッカーが PCB オブジェクトの配置がルールに適合しているかどうかを判断するために使用します。また、Assign Net アイコン(
)をクリックして設計スペース内のオブジェクトを選択することもできます。そのオブジェクトのネットが、選択したトラックに割り当てられます。
- Layer – ドロップダウンを使用して、トラックが配置されているレイヤーを選択します。
- Width – トラックの現在の幅が表示されます。このフィールドを編集すると、トラック幅を 0.001mil~10000mil の範囲で変更できます。
- Start (X/Y) – 現在の原点を基準とした、トラックの始点の現在の X/Y 座標が表示されます。
- End (X/Y) – 現在の原点を基準とした、トラックの終点の現在の X/Y 座標が表示されます。
-
Length – トラックの現在の長さが表示されます。このフィールドを編集すると、トラックの長さを 0.001mil~10000mil の範囲で変更できます。
ペーストマスク拡張
- Rule/Manual – ペーストマスク拡張の設定を選択します。配線のペーストマスク拡張に、適用される Paste Mask Expansion デザインルールで定義された値を使用するには、Ruleを選択します。適用されるデザインルールをオーバーライドして、配線のペーストマスク拡張値を指定するには、 Manualを選択します。その後、入力を有効にして、希望する寸法を入力できます。
ソルダーマスク拡張
- Rule/Manual – ソルダーマスク拡張の設定を選択します。配線のソルダーマスク拡張に、適用される Solder Mask Expansion デザインルールで定義された値を使用するには、Ruleを選択します。適用されるデザインルールをオーバーライドして、配線のソルダーマスク拡張値を指定するには、 Manualを選択します。その後、入力を有効にして、希望する寸法を入力できます。
円弧の操作
円弧はプリミティブな設計オブジェクトです。基本的には円形の配線セグメントであり、任意のレイヤーに配置できます。円弧はPCBレイアウトでさまざまな用途に使用できます。たとえば、オーバーレイレイヤーで部品の外形を定義したり、メカニカルレイヤーで基板外形や切り抜きの縁などを示したりする際に使用できます。また、インタラクティブ配線中に曲線の経路を作成することもできます。円弧は開いた形状にすることも、閉じて円を作成することもできます(後者は完全円弧と呼ばれることがあります)。

配置された2つの円弧。左は完全円弧、右は編集のために選択された円弧です。
円弧はPCBエディターとPCBライブラリエディターの両方で配置できます。円弧には4つの配置モード(中心、端点、任意角度、完全円)があります。円弧の配置手順は、選択した配置方法によって異なります。
-
Place arc by center – この方法では、円弧の中心を始点として円弧オブジェクトを配置できます。
コマンドを実行すると、カーソルが十字形に変わり、円弧の配置モードになります。次の手順で配置します。
- クリックするかEnterを押して、円弧の中心点を確定します。
- カーソルを動かして円弧の半径を調整し、 クリックするかEnterを押して確定します。
- カーソルを動かして円弧の始点を調整し、 クリックするかEnterを押して確定します。
- カーソルを動かして円弧の終点の位置を変更し、 クリックするかEnterを押して確定し、円弧の配置を完了します。
- 続けて円弧を配置するか、 右クリックするかEscを押して配置モードを終了します。
-
Place arc by edge – この方法では、円弧の端点を始点として円弧オブジェクトを配置できます。円弧の角度は90°に固定されます。
コマンドを実行すると、カーソルが十字形に変わり、円弧の配置モードになります。次の手順で配置します。
- クリックするかEnterを押して、円弧の始点を確定します。
- カーソルを動かして円弧の終点の位置を変更し、 クリックするかEnterを押して確定し、円弧の配置を完了します。
- 続けて円弧を配置するか、 右クリックするかEscを押して配置モードを終了します。
-
Place arc by edge (any angle) – この方法では、円弧の端点を始点として円弧オブジェクトを配置できます。円弧の角度は任意の値に設定できます。
コマンドを実行すると、カーソルが十字形に変わり、円弧の配置モードになります。次の手順で配置します。
- クリックするかEnterを押して、円弧の始点を確定します。
- カーソルを動かして円弧の半径を調整し、 クリックするかEnterを押して中心点を確定します。
- カーソルを動かして円弧の終点の位置を変更し、 クリックするかEnterを押して確定し、円弧の配置を完了します。
- 続けて円弧を配置するか、 右クリックするかEscを押して配置モードを終了します。
-
Place full circle arc – この方法では、360°の円弧(完全円)を配置できます。
コマンドを実行すると、カーソルが十字形に変わり、円弧の配置モードになります。次の手順で配置します。
- クリックするかEnterを押して、円弧の中心点を確定します。
- カーソルを動かして円弧の半径を調整し、 クリックするかEnterを押して確定し、円弧の配置を完了します。
- 続けて円弧を配置するか、 右クリックするかEscを押して配置モードを終了します。
配置中には、次の操作も実行できます。
- 完全円弧を除くすべての方法で、円弧の終点を確定する前にSpacebarを押すと、 円弧が反対方向に描画されます。
- Lキーを押すと、円弧を基板の反対側に反転できます。ただし、この操作は円弧の始点または中心点を確定する前にのみ実行できます。
- テンキーの+キーと-キーを押すか、 Shift+Ctrl+Wheelrollショートカットを使用すると、 設計内の表示されているすべてのレイヤーを順方向または逆方向に切り替えて、配置レイヤーをすばやく変更できます。
グラフィカルな編集方法では、デザインスペース内で配置済みの円弧オブジェクトを直接選択し、そのサイズ、形状、位置を視覚的に変更できます。
円弧オブジェクトを選択すると、次の編集ハンドルが使用できます。

選択された円弧
- Aをクリックしてドラッグすると、半径を調整できます。
- Bをクリックしてドラッグすると、端点(開始角度と終了角度)を調整できます。
-
円弧上の編集ハンドル以外の場所をクリックし、 ドラッグして位置を変更します。または、円弧の中心点をクリックしてドラッグします。ドラッグ中は、円弧を回転または反転できます。
- Spacebarを押すと円弧が反時計回りに、Shift+Spacebarを押すと時計回りに回転します。回転は、PreferencesダイアログのPCB Editor – Generalページで定義されたRotation Stepの値に従います。
- XキーまたはYキーを押すと、円弧がX軸またはY軸に対して反転します。
円弧のプロパティ
ネット情報
この領域には、円弧が属するネットに関する情報が表示されます。また、そのネットが差動ペアやxSignalのメンバーである場合は、それらの情報も表示されます。該当する場合はクラス情報も表示されます。Delay、Length、Max Current、Resistanceの値も表示されます。
ネット情報の詳細については、PCBの配置と編集のテクニックページを参照してください。
位置
-
(X/Y)
- X (1番目のフィールド)- このフィールドには、現在の原点を基準とした円弧の中心の現在のX座標が表示されます。 フィールドの値を編集すると、現在の原点に対する円弧の位置を変更できます。 値はメートル単位系またはヤード・ポンド単位系のどちらでも入力できます。現在の既定の単位と異なる単位で値を入力する場合は、単位を付けてください。 既定の単位(メートル単位系またはヤード・ポンド単位系)は、Board モード(デザインスペースでオブジェクトが選択されていないときにアクセス可能)の Properties パネルの Other 領域にある Units 設定によって決まり、単位が指定されていない場合に使用されます。
- Y (2番目のフィールド)- このフィールドには、現在の原点を基準とした円弧の中心の現在のY座標が表示されます。フィールドの値を編集すると、現在の原点に対する円弧の位置を変更できます。 値はメートル単位系またはヤード・ポンド単位系のどちらでも入力できます。現在の既定の単位と異なる単位で値を入力する場合は、単位を付けてください。 既定の単位(メートル単位系またはヤード・ポンド単位系)は、Board モード(デザインスペースでオブジェクトが選択されていないときにアクセス可能)の Properties パネルの Other 領域にある Units 設定によって決まり、単位が指定されていない場合に使用されます。
プロパティ
- Component – このフィールドは、選択した円弧がPCBコンポーネントの構成要素である場合にのみPCBエディターに表示され、親PCBコンポーネントのデジグネーターを示します。クリック可能な Componentリンクを選択すると、親コンポーネントのPropertiesパネルのComponentモードが開きます。
-
Net – 円弧のネットを選択します。ドロップダウンリストには、アクティブな基板設計のすべてのネットが表示されます。すでにネットに接続されている既存のオブジェクトと同じ位置からオブジェクトの配置を開始すると、新しいオブジェクトの Net プロパティには、そのネットが自動的に割り当てられます。円弧をどのネットにも接続しない場合は、 No Net を選択します。プリミティブの Netプロパティは、PCBオブジェクトが適切に配置されているかどうかを判定するために、デザインルールチェッカーで使用されます。また、Assign Netアイコン(
)をクリックしてデザインスペース内のオブジェクトを選択することもできます。そのオブジェクトのネットが、選択した円弧に割り当てられます。
- Layer - このフィールドには、円弧が現在割り当てられているレイヤーが表示されます。円弧は使用可能な任意のレイヤーに割り当てることができます。割り当てるレイヤーを変更するには、フィールドをクリックし、ドロップダウンリストからレイヤーを選択します。
- Width - このフィールドには、円弧の線幅が表示されます。必要に応じて別の幅の値を入力します。
- Radius - このフィールドには、中心点から円弧の線の中心までを測定した半径が表示されます。必要に応じて別の半径の値を入力します。
- Start Angle - このフィールドには、第1象限(平面幾何学)のX軸を基準に測定した円弧の開始角度が表示されます。必要に応じて別の開始角度を入力します。
- End Angle - このフィールドには、円弧の終了角度が表示されます。必要に応じて別の終了角度を入力します。
- Propagation Delay - このフィールドには、その配線に沿って信号が伝搬するのにかかる時間が表示されます。
ペーストマスク拡張
- Rule - 円弧のペーストマスク拡張を、適用されるPaste Mask Expansionデザインルールで定義された値に従わせる場合に選択します。このオプションを選択すると、対応する拡張値のフィールドは無効になります。
- Manual - 適用されるデザインルールを上書きし、下のフィールドで円弧のペーストマスク拡張値を指定する場合に選択します。
ソルダーマスク拡張
- Rule - 円弧のソルダーマスク拡張を、適用されるSolder Mask Expansionデザインルールで定義された値に従わせる場合に、このチェックボックスをオンにします。このオプションを選択すると、対応する拡張値のフィールドは無効になります。
- Manual - 適用されるデザインルールを上書きし、下のフィールドで円弧のソルダーマスク拡張値を指定する場合に、このチェックボックスをオンにします。
選択したオブジェクトをトラックと円弧で囲む
メインメニューの Tools » Outline Selected Objects コマンドを使用すると、デザイン内で選択したフリープリミティブの周囲に、トラックと円弧による輪郭を配置できます。この機能は、輪郭をグラウンドに接続して重要なネットを電気的に分離したい場合に、特に便利です。 コマンドを実行すると、オブジェクトがトラックや円弧で囲まれます。輪郭を構成するトラック/円弧は、幅8milで配置され、 Net プロパティは No Netに設定されます。
デザインのClearance、Width、Short-Circuitデザインルールが適用されるため、クリアランス違反はデザインルールチェッカーによって検出されます。
矩形の操作
矩形は任意のレイヤーに配置できます。さまざまなサイズの矩形を組み合わせて不規則な形状の領域を覆うことができ、トラックや円弧のセグメントと組み合わせることもできます。
矩形は非電気レイヤーにも配置できます。たとえば、Keep-Outレイヤーに矩形を配置すると、自動配線の「進入禁止」領域を指定できます。Power Plane、Solder Mask、Paste Maskレイヤーに矩形を配置すると、そのレイヤーに空白領域を作成できます。

配置された矩形
PCBエディターとPCBライブラリエディターの両方で、次の方法により矩形を配置できます。
- PCBエディター - 次の方法でアクセスできます:
- メインメニューからPlace » Rectangle を選択します。
-
デザインスペース上部にある Active Bar のドロップダウンで、Rectangle ボタン(
)をクリックします。(Active Barボタンを長押しすると、関連する他のコマンドにアクセスできます。使用したコマンドは、Active Barのそのセクションで最上位の項目になります。)
- デザインスペース内で右クリックし、コンテキストメニューから Place » Rectangle をクリックします。
-
PCBライブラリエディター - 次の方法でアクセスできます:
- メインメニューからPlace » Rectangle を選択します。
-
デザインスペース上部にある Active Bar のドロップダウンで、Rectangle ボタン(
)をクリックします。(Active Barボタンを長押しすると、関連する他のコマンドにアクセスできます。使用したコマンドは、Active Barのそのセクションで最上位の項目になります。)
- デザインスペース内で右クリックし、コンテキストメニューからPlace » Rectangle を選択します。
コマンドを実行すると、カーソルが十字形に変わり、長方形の配置モードになります。次の手順で配置します:
- クリックするかEnterを押して、長方形の最初の角を固定します。
- カーソルを動かして長方形のサイズを調整し、クリックするかEnterを押して対角の角を固定し、長方形の配置を完了します。
- 続けて長方形を配置するか、右クリックまたはEscを押して配置モードを終了します。
配置中には、次の操作も行えます:
-
Tab キーを押すと配置が一時停止し、Properties パネルの 長方形モードにアクセスして、その場でプロパティを変更できます。配置を再開するには、デザインスペースに重ねて表示される一時停止ボタン(
)をクリックします。
- スペースバーを押すと、各種のコーナーモードが順に切り替わります。直角のコーナーには Rectangle 、丸みのあるコーナーには Fillet 、斜めに面取りしたコーナーにはChamferを選択します。
- テンキーの+キーと-キーを押すと、デザイン内の表示されているすべてのレイヤーを順方向または逆方向に切り替え、配置レイヤーをすばやく変更できます。
- Alt キーを押したままにすると、最初に動かした方向に応じて、移動方向を水平軸または垂直軸に制限できます。
グラフィカル編集では、デザインスペース内で配置済みの長方形オブジェクトを直接選択し、サイズ、形状、位置を視覚的に変更できます。
長方形オブジェクトを選択すると、次の編集ハンドルが使用できます。
選択された長方形
- 角(A)をクリックしてドラッグすると、長方形の縦横のサイズを同時に変更できます。
- 辺の中央(B)をクリックしてドラッグすると、長方形の縦または横のサイズを個別に変更できます。
-
編集ハンドル以外の長方形上の任意の場所をクリックしてドラッグすると、位置を変更できます。ドラッグ中に、長方形を回転または反転できます:
- Spacebarを押すと長方形が反時計回りに、Shift+Spacebarを押すと時計回りに回転します。回転は、PreferencesダイアログのPCBエディター – 一般ページで定義されているRotation Step の値に従います。
- XキーまたはYキーを押すと、長方形をX軸またはY軸に沿って反転できます。
長方形のプロパティ

PropertiesパネルのRectangleモード。
位置
-
(X/Y)
- X (最初のフィールド)- 現在のデザインスペースの原点を基準とした、長方形の基準点の現在のX(水平)座標です。編集すると長方形のX位置を変更できます。値はメートル法またはヤード・ポンド法のどちらでも入力できます。現在のデフォルトと異なる単位で値を入力する場合は、単位を含めてください。
- Y (2番目のフィールド)- 現在の原点を基準とした、長方形の基準点の現在のY(垂直)座標です。編集するとフィルのY位置を変更できます。値はメートル法またはヤード・ポンド法のどちらでも入力できます。現在のデフォルトと異なる単位で値を入力する場合は、単位を含めてください。
- Rotation - ゼロ( 3 o'clock 水平)から反時計回りに測定した、長方形の回転角度(度単位)です。編集すると長方形の回転を変更できます。角度の最小分解能は0.001°です。
プロパティ
-
Corner Mode - ドロップダウンで、長方形のコーナーモードを次のオプションから選択します:
- Rectangle - 配置する長方形のコーナーを直角にします。
- Fillet - 配置する長方形のコーナーに丸みを付けます。
- Chamfer - 配置する長方形のコーナーを斜めに面取りします。
- Track Width - 現在のトラック幅を表示します。このフィールドを編集すると、0.001mil~10000milの範囲でトラック幅を変更できます。
- Fillet/Chamfer Size - Corner ModeドロップダウンでFillet またはChamfer が選択されている場合、または配置中にフィレットモードか面取りモードを選択した場合にのみ使用できます。
- Layer - 長方形が現在割り当てられているレイヤーです。長方形は、使用可能な任意のレイヤーに割り当てられます。ドロップダウンで別のレイヤーを選択します。
- Width - 選択した長方形の幅(X軸方向)を表示します。
- Height - 選択した長方形の高さ(Y軸方向)を表示します。
-
- このアイコンをクリックすると、長方形の現在のXとYの比率が維持されます。


