콘텐츠 생성 및 편집

Item은 연결된 워크스페이스 내에서 직접 생성되며, Item을 제조하거나 표현하는 데 필요한 모든 데이터는 해당 워크스페이스에 Item 번호와 연결되어 저장됩니다. 콘텐츠 유형에 따라 Item을 수동으로 생성하거나 저장/업로드/릴리스 과정의 일부로 자동 생성할 수 있습니다. 모든 콘텐츠 유형은 Altium Designer의 Explorer Panel을 통해 생성할 수 있습니다. 컴포넌트 작업 시에는 Components Panel을 통해서도 생성할 수 있습니다.

콘텐츠는 워크스페이스 내에서 폴더의 트리 구조로 정리되며, 이는 PC에서 파일을 정리하는 데 사용하는 폴더 트리와 유사합니다. 워크스페이스에 폴더를 추가하려면 Explorer Panel의 Server Folders Region에서 마우스 오른쪽 버튼을 클릭합니다.

Item은 연결된 워크스페이스에 생성됩니다. Altium Designer 내에서 Explorer Panel은 워크스페이스에 대한 전체 인터페이스를 제공합니다.
Item은 연결된 워크스페이스에 생성됩니다. Altium Designer 내에서 Explorer Panel은 워크스페이스에 대한 전체 인터페이스를 제공합니다.

Item 생성하기

필요한 폴더를 정의한 후에는 워크스페이스에 콘텐츠를 생성할 수 있습니다. Item을 생성하려면 적절한 폴더를 선택한 다음, Panel의 Item Grid Region에서 마우스 오른쪽 버튼을 클릭하고 Create Item 하위 메뉴에서 명령 중 하나를 선택합니다. 또는 폴더가 비어 있는 경우, Region 중앙의 Add an item 컨트롤을 사용하여 메뉴에 접근할 수 있습니다.

컨텍스트 메뉴에는 현재 활성화된 폴더 유형과 연결된 콘텐츠 유형이 표시됩니다. 생성하려는 콘텐츠 유형이 목록에 없으면 Other Item Type 명령을 선택합니다. 폴더에는 어떤 유형의 콘텐츠든 생성할 수 있다는 점을 기억하세요. 폴더 유형은 시각적인 구분을 위한 것일 뿐입니다. 콘텐츠는 나중에 언제든지 폴더 간에 이동할 수 있습니다.

Explorer Panel의 Item Grid Region에서 마우스 오른쪽 버튼을 클릭하면 콘텐츠 생성 관련 명령에 접근할 수 있습니다.
Explorer Panel의 Item Grid Region에서 마우스 오른쪽 버튼을 클릭하면 콘텐츠 생성 관련 명령에 접근할 수 있습니다.

Create New Item 대화 상자가 나타나며, Item을 완전히 정의하는 데 필요한 모든 컨트롤을 제공합니다.

새 Item 생성 대화 상자에서 새 Item의 세부 정보를 지정합니다.
새 Item 생성 대화 상자에서 새 Item의 세부 정보를 지정합니다.

많은 콘텐츠 유형에서는 생성 후 해당 설계 문서를 편집하고 해당 콘텐츠의 초기 리비전으로 릴리스할 수 있습니다. 이렇게 하려면 Create New Item 대화 상자 하단의 Open for editing after creation 옵션을 활성화합니다(이 옵션은 Default로 활성화되어 있습니다). Item이 생성되고 관련 임시 Editor가 열리므로 해당 Item의 데이터를 바로 생성할 수 있습니다. 특정 콘텐츠 유형의 작업 방법에 대한 자세한 내용은 표에 제공된 링크를 통해 해당 전용 페이지를 참조하세요.

Item에서 마우스 오른쪽 버튼을 클릭한 다음 컨텍스트 메뉴에서 Properties을 선택하면 Create New Item 대화 상자의 변형된 형태에 접근할 수 있습니다. Item이 Planned State인 경우, 필요에 따라 Item의 속성을 변경할 수 있는 Edit Item 대화 상자가 열립니다. Item이 저장된 상태인 경우, Item 속성을 읽기 전용으로 표시하는 View Item Properties 대화 상자가 열립니다.
Item 정의의 일부로 이름과 설명을 추가하는 것이 좋습니다. 이 정보는 워크스페이스를 검색할 때 사용되며, Item이 제공하는 내용을 빠르게 파악할 수 있게 해줍니다.

워크스페이스는 Item 없이 워크스페이스 컴포넌트를 생성하는 기능을 지원합니다. 이는 Item이 생성되지 않는다는 의미가 아니라, 컴포넌트 Editor 인스턴스에 직접 접근하여 필요한 컴포넌트를 추가하고 저장하기 전에 컴포넌트 템플릿의 세부 정보를 적용할 수 있다는 의미입니다. 실제 컴포넌트 Item과 예정된 리비전은 릴리스 준비 과정에서 생성됩니다. 마우스 오른쪽 버튼 클릭 메뉴에서 Create Item » Component 명령을 사용하면 이 모드로 바로 진입합니다.

새 워크스페이스 컴포넌트를 생성할 때 Create New Item 대화 상자를 표시하려면 Create Item » Other Item Type 명령을 사용합니다. 이 경우 워크스페이스 컴포넌트의 Planned 리비전이 먼저 생성됩니다. 아직 정의하거나 워크스페이스에 저장하지 않은 새 컴포넌트를 보려면 Show only latest 옵션을 비활성화하거나(Explorer 패널 상단의 버튼을 클릭하여 여는 메뉴에서 사용 가능), 폴더 보기를 Components View에서 Classic View로 전환합니다(동일한 메뉴에서 사용 가능). 단, Item이 먼저 생성되므로 템플릿의 정보(즉, 명명 체계, 리비전 체계 및 수명 주기 정의)는 적용되지 않습니다. 컴포넌트 Item이 이미 생성되어 있기 때문입니다.

Item ID에 대한 참고 사항...

콘텐츠가 생성되는 상위 폴더에서 중요한 요소는 해당 폴더에 적용되는 Item Naming Scheme입니다. 이는 해당 폴더에서 생성되는 각 Item의 고유 ID 형식을 정의합니다. 폴더 수준에서 Item 명명 체계를 정의하면 올바른 ID 명명 체계를 준수하면서 해당 폴더 내에 콘텐츠를 빠르게 생성할 수 있습니다. 특히 타겟 워크스페이스 내에서 직접 수동으로 생성한 기존 Item으로 릴리스하는 대신, Item을 필요에 따라 자동으로 즉시 생성하는 경우에 유용합니다.

폴더 유형 또는 콘텐츠 유형의 약식 코드를 사용하는 여러 기본 예제 체계가 제공됩니다(코드 목록은 이 문서 앞부분의 표 참조). 기본 명명 체계를 사용하면 소프트웨어가 전체 워크스페이스와 기존 콘텐츠의 식별자를 검색한 후, 해당 체계에 따라 사용 가능한 다음 고유 ID를 자동으로 할당합니다.

필드에 직접 입력하여 폴더에 대한 사용자 지정 체계를 정의할 수도 있습니다. 이때 가변 부분은 중괄호로 묶어야 합니다(예: DraftsmanDOC-TMP-{0000} 또는 DraftsmanSHEET-TMP-{0000}). 상위 폴더에 적용되는 Item 명명 체계는 언제든지 변경할 수 있습니다. 변경된 체계는 이후 해당 폴더에서 새로 생성되는 모든 Item에 적용됩니다. 또한 상위 폴더에 정의된 체계는 그 아래의 하위 폴더에 자동으로 상속됩니다.

또는 Item의 이름을 수동으로 완전히 제어해야 하는 경우 [NO ITEM NAMING SCHEME] 항목을 선택합니다. 그러면 Item을 생성할 때 고유 식별자를 정의해야 합니다. 시스템에서는 중복된 식별자를 가진 Item을 생성할 수 없으므로, 식별자를 수동으로 할당하려면 어떤 식별자가 이미 사용되었는지 알고 있어야 합니다.

상위 폴더의 Item 명명 체계는 해당 폴더 내에서 생성되는 각 Item의 고유 ID에 적용됩니다.
상위 폴더의 Item 명명 체계는 해당 폴더 내에서 생성되는 각 Item의 고유 ID에 적용됩니다.

폴더 수준의 Item Naming Scheme 설정과 관계없이, Item 수준에서 자동으로 결정된 ID를 자유롭게 재정의할 수 있습니다. 필요에 따라 Create New Item 대화 상자에서 해당 ID를 수정합니다.

Item ID 체계 선택

Item에 사용할 수 있는 이름/번호 지정 체계는 무수히 많으며, 문서의 이미지에 표시된 체계는 예시일 뿐입니다. 어떤 번호 지정 체계가 가장 좋은지에 대한 다양한 논의를 찾아볼 수 있습니다. 일반적으로 전문가들은 짧고, 별도의 의미를 담지 않으며, 숫자만 사용하는 번호 지정 체계가 가장 좋다는 데 동의합니다. 별도의 의미를 담지 않는다는 것은 번호 지정 체계에 제품 범주, 하위 범주, 위치 등의 정보를 포함하지 않는다는 뜻입니다. 각 새 Item에는 단순히 순서에 따라 다음 번호가 부여됩니다.

식별자가 길수록 사람이 Item ID를 기록하거나 기억해 낼 때 오류를 범할 가능성이 커지므로 길이가 중요합니다. 경험과 학술 연구에 따르면 문자 수가 늘어날수록 데이터 입력 오류가 증가합니다. 사람이 쉽고 정확하게 기억해 낼 수 있는 최적의 길이는 7자리로 알려져 있습니다. 특정 길이를 넘어서면 오류 발생률이 점점 더 빠르게 증가하며, 15자에서는 오류 확률이 거의 100%에 이릅니다.

조직에서 Item ID에 식별 의미를 담는 것이 중요하다면 복합 식별자가 해답이 될 수 있습니다. 이 경우 영문자와 숫자로 구성된 간단한 품목 접두어 코드를 사용하는 것이 좋습니다. 예를 들어 ID D-820-0001를 살펴보겠습니다. 여기서 코드의 D는 설계를 나타내어, 이 Item이 설계에 사용된다는 의미를 담을 수 있습니다. 그다음 3자리에서 첫 번째 자리는 주변 장치 보드와 같은 제품 범주를 나타내고, 두 번째와 세 번째 자리는 베어 보드(1X) 또는 조립품(2X 이상)을 나타내는 데 사용할 수 있습니다. Item ID의 마지막 4자리는 별도의 의미 없이 순서대로 부여되는 단순한 번호입니다.

워크스페이스 Item의 초기 리비전 ID 설정

로컬 설계 방식에서 워크스페이스 기반 방식으로 전환하려면 기존 데이터를 워크스페이스로 마이그레이션해야 합니다. 이러한 데이터는 이미 여러 차례의 변경을 거쳤으며, 조직 전체에서 통용되는 리비전 번호가 할당되어 있을 수 있습니다. 예를 들어 Magno-Synthetic Digitizer 보드의 rev.3이 이미 출하되었고, 개선 사항은 rev.4에서 제공될 예정일 수 있습니다. 워크스페이스로 릴리스할 때 초기 리비전이 1부터 다시 시작된다면, 조직 내부뿐만 아니라 더욱 중요한 고객들에게도 상당한 혼란을 줄 수 있습니다. 고객들은 현재 사용 중인 rev.3보다 이후 버전을 기대하기 때문입니다!

이를 위해 Altium Designer는 워크스페이스에서 새로 생성한 Item의 초기 리비전 ID를 수동으로 설정하는 기능을 제공합니다.

Item의 첫 번째 예정 리비전 ID는 Item을 생성한 후부터 해당 초기 리비전으로 데이터를 릴리스하기 전까지(즉, 아직 Planned 상태인 동안) 언제든지 변경할 수 있습니다.

초기 리비전 ID 설정

평소와 같이 워크스페이스에서 필요한 새 Item을 생성합니다. 생성 후 Item을 마우스 오른쪽 버튼으로 클릭하고 Properties를 선택하여 Edit Item 대화 상자를 엽니다. 대화 상자의 Advanced 영역을 확장한 다음, Revision ID 필드 오른쪽에 있는 버튼을 클릭합니다. Set Initial revision Id values 대화 상자가 나타나면 요구 사항에 맞게 ID를 설정할 수 있습니다. 선택한 리비전 명명 체계에 따라 ID의 각 수준을 수정할 수 있는 필드가 필요에 맞게 제공됩니다.

Explorer Panel에서 프로젝트 관련 Item(PCB 제작 데이터, PCB 조립 데이터, PCB 프로젝트 설계)에 액세스하려면 프로젝트를 Classic View에서 보고 있는지 확인하세요. Project View에서 수동으로 전환해야 할 수도 있습니다. 관련 명령은 Panel 오른쪽 상단의 버튼 메뉴에서 사용할 수 있습니다.
새로 생성한 관리형 프로젝트의 프로젝트 관련 Item(PCB 제작 데이터, PCB 조립 데이터, PCB 프로젝트 설계)을 빠르게 생성하려면 Project Releaser를 실행하세요(Projects Panel에서 프로젝트를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Project Releaser 명령을 선택). 관련 Item은 준비 단계에서 생성됩니다. 단, 초기 리비전의 ID를 설정할 수 있도록 프로젝트를 릴리스하지는 마세요.

ID의 각 레벨을 설정하세요(사용 중인 리비전 명명 체계에 따라 적용).
ID의 각 레벨을 설정하세요(사용 중인 리비전 명명 체계에 따라 적용).

Project Releaser를 사용하여 설계를 릴리스하는 과정에서도 초기 리비전을 정의할 수 있습니다. 타겟 리비전 Entry 옆의 링크에 연결된 컨텍스트 메뉴에서 Custom Entry를 사용할 수 있습니다(릴리스 프로세스의 초기 Configure Server Release 단계). 이 명령을 사용하여 Custom Revision ID 대화 상자를 열면, 생성된 데이터를 릴리스할 타겟 Item의 리비전을 수동으로 지정할 수 있습니다. 자세한 내용은 설계를 워크스페이스에 릴리스할 때 타겟 리비전 제어하기를 참조하세요.

워크스페이스에서 직접 콘텐츠 생성 및 편집

연결된 워크스페이스는 Altium Designer에서 사용하는 모든 유형의 설계 데이터를 중앙에서 저장하고 관리할 수 있는 유연하고 안전한 방법을 제공합니다. Schematic 모델부터 컴포넌트까지, 관리형 Schematic 시트부터 완성된 PCB 설계까지, 워크스페이스는 전자 설계 데이터를 저장하고 관리하는 이상적인 방법을 제공합니다.

워크스페이스의 강력한 기능 중 하나는 Direct Editing 지원입니다. '직접 편집'이란 정확히 무엇을 의미할까요? 워크스페이스에서 모델, 컴포넌트 또는 관리형 시트를 마우스 오른쪽 버튼으로 클릭하고 Edit를 선택할 수 있다는 뜻입니다. 그러면 Altium Designer의 임시 Editor에서 편집할 수 있도록 파일이 열립니다. 편집을 마친 후에는 워크스페이스에 다시 저장하기만 하면 됩니다. 방금 편집한 파일은 신경 쓰지 않아도 됩니다. 편집 내용이 워크스페이스에 안전하게 저장되었으므로 더 이상 필요하지 않은 파일은 삭제되고 임시 Editor 인스턴스도 닫힙니다.

직접 편집을 사용하면 별도로 버전 관리되는 소스 데이터에 얽매일 필요가 없습니다. 워크스페이스에서 직접 가져온 최신 소스를 임시 Editor에 로드하여 지원되는 Item 유형을 간편하게 편집할 수 있습니다. 편집이 완료되면 해당 엔티티가 Parent Item의 다음 예정 리비전에 릴리스(또는 재릴리스)되고 임시 Editor가 닫힙니다. 하드 드라이브에 파일을 보관할 필요도, 올바른 소스나 최신 소스로 작업하고 있는지 고민할 필요도, 별도의 버전 관리 소프트웨어를 유지할 필요도 없습니다. 워크스페이스가 높은 무결성을 보장하면서 이 모든 작업을 처리하므로 데이터를 훨씬 빠르게 변경할 수 있습니다.

소스 파일을 직접 관리하면서 생성하는 방식도 계속 사용할 수 있지만, 직접 편집이 제공하는 자유로움 덕분에 이러한 관리 부담을 없앨 수 있습니다. 워크스페이스가 설계 데이터의 소스이자 타겟이 되므로, 두 세트의 데이터를 관리하는 번거로움 없이 안전한 최신 소스에 액세스하고 편집할 수 있습니다.

직접 편집이 지원되는 콘텐츠 유형

다음 워크스페이스 콘텐츠 유형에서 직접 편집이 지원됩니다.

Item의 초기 리비전 편집

Explorer Panel에서 지원되는 콘텐츠 유형의 Item을 생성할 때, 생성 후 연결된 데이터 엔티티를 편집하여 해당 Item의 초기 리비전에 릴리스할 수 있습니다. 따라서 워크스페이스 외부에서 소스 데이터를 생성한 뒤 릴리스하는 대신, 직접 편집을 통해 빈 Item이 생성되는 순간부터 소스 작업을 시작할 수 있습니다. 편집이 완료되면 해당 엔티티가 Parent Item의 초기 예정 리비전에 릴리스되고 임시 Editor가 닫힙니다.

이 기능을 사용하려면 Item 생성 대화 상자 하단에 있는 Open for editing after creation 옵션을 활성화하세요. 이 기능의 유용성을 고려하여 해당 옵션은 Default로 활성화되어 있습니다. Item이 생성되면 관련 임시 Editor가 열리고, 해당 문서가 기본 설계 창의 활성 문서로 표시됩니다. 이 문서의 이름은 Item-리비전에 따라 <Item>-<Revision>.<DocumentExtension> 형식으로 지정됩니다.

예외는 컴포넌트 Item입니다. 이 유형의 새 Item을 생성하면 싱글 컴포넌트 Editor가 열리며, 컴포넌트 이름이 참조용으로 사용됩니다. 이름을 지정하지 않은 경우 이름이 정의될 때까지 Default New component 이름 지정 방식이 사용됩니다.

아래 이미지는 새 심볼 Item(SYM-001-0031)을 생성할 때 이 기능이 작동하는 모습을 보여 줍니다. 임시 Schematic 심볼 Editor가 열리고, 필요한 심볼을 정의할 수 있는 문서가 표시됩니다.

워크스페이스에서 직접 심볼 Item의 초기 리비전을 편집하는 예입니다. 임시 Schematic 심볼 Editor는 Schematic 심볼을 정의할 수 있는 문서를 제공합니다.
워크스페이스에서 직접 심볼 Item의 초기 리비전을 편집하는 예입니다. 임시 Schematic 심볼 Editor는 Schematic 심볼을 정의할 수 있는 문서를 제공합니다.

직접 편집 컨트롤

직접 편집 시 사용할 수 있는 관련 컨트롤은 세 가지이며, 빠른 실행 모음(기본 애플리케이션 창의 왼쪽 상단) 또는 활성 임시 Editor의 Standard 도구 모음(제공되는 경우)에서 바로 이용할 수 있습니다.

  • 클릭한 채 드래그하여 이동​ – Save Active Document. 이 버튼을 사용하여 문서의 변경 사항을 저장합니다. 워크스페이스에 최종 릴리스하기 전에 나중에 돌아와 추가로 변경하려는 경우, 현재 변경 사항을 저장할 수 있습니다.

  • / – Save to Server. 이 버튼을 사용하여 문서를 워크스페이스에 릴리스(실질적으로 저장 및 릴리스)하고, 타겟 Item의 최초(계획된) 리비전 또는 다음 리비전에 저장합니다. 리비전 생성 대화 상자(또는 리비전 편집 대화 상자)가 나타나며, 여기에서 이름과 설명을 변경하고 필요에 따라 릴리스 노트를 추가할 수 있습니다. 릴리스 후에는 문서와 Editor가 닫힙니다.

     
     
     
     
     
     
     
     
     
     

    해당되는 경우, 원한다면 저장 중인 Item의 현재 리비전과 관련된(해당 리비전을 참조하는) Parent Item의 리비전도 업데이트할 수 있습니다. 이는 기본적으로 활성화되어 있는 Update items related to <ItemRevision> 옵션으로 제어합니다. 이 옵션은 다음 경우에만 표시됩니다.

    • 컴포넌트 Item의 리비전에서 참조하는 도메인 모델(심볼, 풋프린트, 시뮬레이션 모델, 하네스 배선 모델)의 새 리비전을 생성하는 경우.

    • 컴포넌트 Item의 리비전에서 참조하는 컴포넌트 템플릿의 새 리비전을 생성하는 경우.

    • 풋프린트 모델 Item의 리비전에서 참조하는 3D 모델의 새 리비전을 생성하는 경우.

    관련된 모든 Parent Item이 해당 Item의 현재 리비전을 계속 사용하도록 하려면 이 옵션을 비활성화하세요. 그러면 해당 Item 자체만 저장됩니다.

    편집한 컴포넌트 또는 도메인 모델(심볼, 풋프린트, 시뮬레이션 모델, 하네스 배선 모델)을 워크스페이스에 저장할 때 현재 수명 주기 상태를 유지할 수 있습니다. 다시 저장할 때 Edit Revision / Create Revision 대화 상자에서 제공되는 Preserve lifecycle state (not recommended) 옵션으로 이를 제어할 수 있습니다. 이 옵션을 활성화하면 새 리비전이 이전 리비전의 수명 주기 상태로 자동 설정됩니다. 이 기능은 Allow to skip lifecycle state change for new revisions 작업 권한이 부여된 사용자가 이용할 수 있습니다(워크스페이스의 전역 작업 권한 설정에 대해 자세히 알아보기).

    편집 중인 문서를 워크스페이스에 저장하려면 Projects Panel의 문서 Entry 옆에 있는 Save to Server 컨트롤을 사용할 수도 있습니다.

  • / – Discard Local Changes. 편집을 취소하려면 이 버튼을 사용하십시오. 편집을 지원하기 위한 용도로만 사용되는 임시 파일이 삭제되고, Projects Panel에서 해당 Entry가 제거되며, 타겟 Item에는 아무것도 릴리스되지 않습니다.

    직접 편집 세션에 사용되는 해당 임시 파일을 이용하면 한 번의 편집 세션에서 업데이트 프로세스를 완료할 필요가 없습니다. 원하는 경우 작업을 저장하고 파일을 닫을 수 있습니다. Altium Designer는 이 파일이 특수한 파일임을 인식하므로 Projects Panel의 <SourceWorkspaceName> 폴더에 보관합니다. 따라서 준비가 되었을 때 파일을 다시 열어 업데이트 및 재릴리스 프로세스를 완료할 수 있습니다.

이 컨트롤은 Projects Panel의 문서 Entry를 마우스 오른쪽 버튼으로 클릭하면 표시되는 메뉴에서도 명령으로 사용할 수 있습니다. 많은 Editor에서는 기본 File 메뉴에서도 Save(단축키: Ctrl+S), Save to Server(단축키: Ctrl+Alt+S), Discard Local Changes 명령으로 이 컨트롤을 사용할 수 있습니다.

프로젝트 템플릿 Item의 리비전에서는 Save, Save to Server, Discard Local Changes 명령을 Projects Panel에서만 사용할 수 있습니다. Item 리비전의 Entry를 마우스 오른쪽 버튼으로 클릭하여 해당 컨텍스트 메뉴를 여십시오.

Item의 기존 리비전 편집

언제든지 워크스페이스에서 지원되는 콘텐츠 유형의 Item 리비전으로 돌아가(Explorer Panel을 통해) 직접 편집할 수 있습니다. 리비전을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Edit 명령을 선택하십시오. 임시 Editor가 다시 열리고, 해당 리비전에 포함된 문서가 편집할 수 있도록 열립니다. 필요한 사항을 변경한 다음 문서 릴리스를 Item의 다음 리비전으로 Commit하십시오.

Item 자체의 최상위 Entry를 마우스 오른쪽 버튼으로 클릭하면 해당 Item의 최신 리비전이 편집됩니다.

기존 Draftsman 문서 템플릿의 직접 편집을 시작하는 명령에 접근하는 예.
기존 Draftsman 문서 템플릿의 직접 편집을 시작하는 명령에 접근하는 예.

임시 파일의 동작

워크스페이스 데이터를 편집하려면 Altium Designer에서 편집할 대상이 생성되어야 합니다. 이를 위해 임시 파일이 생성됩니다. 예를 들어, 심볼 Item을 마우스 오른쪽 버튼으로 클릭하고 Edit을 선택하면 임시 SchLib 파일이 생성되어 Altium Designer에서 열립니다. 작업을 마치고 Save to Server을 수행하면 워크스페이스 데이터가 업데이트되는 즉시 이 파일이 삭제됩니다.

그러나 파일을 릴리스하지 않고 대신 Save 및 Close을 수행하면 해당 파일은 Projects Panel에 남아 있습니다. 이는 한 번의 편집 세션에서 업데이트 프로세스를 완료할 필요가 없도록 하기 위한 것입니다. 원하는 경우 작업을 저장하고 파일을 닫을 수 있습니다. Altium Designer는 이 파일이 특수한 파일임을 인식하므로 Projects Panel의 <WorkspaceName> Entry 아래에 보관합니다(예: /) 준비가 되었을 때 다시 열어 업데이트 및 재릴리스 과정을 완료할 수 있습니다.

임시 문서는 계속 액세스할 수 있으므로 한 번의 편집 세션에서 모든 변경을 완료할 필요가 없습니다.
임시 문서는 계속 액세스할 수 있으므로 한 번의 편집 세션에서 모든 변경을 완료할 필요가 없습니다.

도중에 마음이 바뀌어 더 이상 편집하지 않으려면, Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Discard Local Changes 명령을 선택하여 임시 파일을 닫으면 됩니다.

컴포넌트 Panel에서 컴포넌트 직접 편집

일상적인 컴포넌트 관리 작업에서는 컴포넌트 Panel에서 직접 편집할 수 있습니다. 해당 콘텐츠 유형을 다룰 때는 Explorer Panel보다 이 Panel을 더 자주 사용하게 됩니다. 필요한 컴포넌트를 찾아 선택한 다음 마우스 오른쪽 버튼을 클릭하고 컨텍스트 메뉴에서 Edit 명령을 선택합니다. 컴포넌트 Editor의 임시 인스턴스가 Single Component Editing 모드로 열리며, 필요에 따라 변경할 수 있습니다.

선택한 여러 컴포넌트를 편집하면 선택한 모든 컴포넌트가 포함된 컴포넌트 Editor 인스턴스 하나가 Batch Component Editing 모드로 열립니다.

Components Panel에서 직접 편집하는 예.
Components Panel에서 직접 편집하는 예.

컴포넌트 Editor에서 모델 직접 편집

컴포넌트 Editor의 Single Component Editing 모드에서 컴포넌트를 편집할 때는 직접 편집 방식으로 연결된 도메인 모델을 편집할 수 있습니다. 컴포넌트가 현재 사용(참조) 중인 모델을 수정하려면 해당 모델 미리보기의 오른쪽 상단에 있는  컨트롤을 클릭합니다. 해당 모델 유형의 임시 Editor가 열리며, 필요에 따라 모델을 변경할 수 있습니다. 준비가 되면 Editor를 저장하고 닫기만 하면 됩니다. 수정된 모델이 Models Region에 다시 연결되어 표시됩니다. 컴포넌트를 릴리스하면 수정된 모델도 자동으로 워크스페이스에 릴리스되어 해당 Parent Item의 다음 리비전에 저장됩니다.

여러 컴포넌트에서 모델을 참조하고 있다면 이를 알리고 다양한 선택지를 제공하는 대화 상자가 나타납니다. 변경 사항이 현재 컴포넌트에만 적용되도록 모델의 복사본을 만들거나(복제), 공유 모델을 계속 편집하고 이를 참조하는 다른 컴포넌트는 나중에 업데이트할 수 있습니다. 또는 편집 과정을 취소할 수도 있습니다.

컴포넌트 Editor의 Single Component Editing 모드에서 직접 편집 중인 컴포넌트가 참조하는 기존 모델을 직접 편집하는 예.
컴포넌트 Editor의 Single Component Editing 모드에서 직접 편집 중인 컴포넌트가 참조하는 기존 모델을 직접 편집하는 예.

컴포넌트 Editor의 Batch Component Editing 모드에서 컴포넌트를 편집할 때도 연결된 도메인 모델에 직접 편집 방식을 적용할 수 있습니다. Editor의 Model Links Region에서 모델 Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Edit 명령을 선택합니다.

도메인 모델 저장 시 Parent 컴포넌트 업데이트

 
 
 
 
 

워크스페이스 도메인 모델(Schematic 심볼, 풋프린트 모델, 시뮬레이션 모델, 하네스 배선 모델 또는 하네스 엔터티 모델)을 변경한 후 해당 변경 사항을 모델의 새 리비전으로 저장하는 순간, 이 모델을 사용하는 모든 워크스페이스 컴포넌트는 여전히 이전 리비전을 사용하므로 사실상 오래된 상태가 됩니다. 대부분의 경우 해당 모델 링크를 사용 가능한 최신 리비전으로 업데이트하여 이러한 워크스페이스 컴포넌트를 다시 저장해야 할 것입니다. 이 과정을 간소화하기 위해 워크스페이스는 Altium Designer와 연동하여, 직접 편집 기능으로 워크스페이스 모델을 수정한 후 다시 저장할 때 Parent 컴포넌트를 업데이트할 수 있도록 지원합니다.

Parent 컴포넌트를 업데이트하는 옵션은 수정된 워크스페이스 모델을 타겟 워크스페이스에 다시 저장할 때 나타나는 Create Revision 대화 상자에서 찾을 수 있습니다. 이 옵션(Update items related to <ModelItemRevision>)은 Default로 활성화되어 있습니다.

 
 
 
 
 
  • <ModelItemRevision>은 모델의 현재 리비전, 즉 Parent 워크스페이스 컴포넌트가 현재 사용하는 리비전입니다. 워크스페이스 모델 자체를 저장하면 이 리비전은 자연스럽게 이전 리비전이 되어 더 이상 최신 리비전이 아니게 됩니다.

  • 모든 Parent 컴포넌트가 워크스페이스 모델의 현재 리비전을 계속 사용하도록 하려면 이 옵션을 비활성화합니다. 그러면 모델 자체만 저장됩니다.

다시 저장하는 워크스페이스 모델(이 경우 심볼)을 참조하는 워크스페이스 컴포넌트의 업데이트 옵션에 액세스하는 예.
다시 저장하는 워크스페이스 모델(이 경우 심볼)을 참조하는 워크스페이스 컴포넌트의 업데이트 옵션에 액세스하는 예.

Create Revision 대화 상자에서 OK을 클릭하면 수정된 모델이 워크스페이스에 다시 저장되고, 연결된 임시 Editor가 닫힙니다. 해당 워크스페이스 모델을 참조하는 모든 워크스페이스 컴포넌트는 새 리비전을 사용하도록 자동으로 다시 저장됩니다(각 컴포넌트의 다음 리비전이 자동으로 생성되고 저장됩니다).

Item의 새 리비전에 데이터 업로드

대부분의 콘텐츠 유형은 해당 데이터 파일을 업로드하여 새 리비전을 생성할 수 있습니다.

다음 콘텐츠 유형은 이 방식으로 새 리비전을 생성할 수 없습니다: 컴포넌트, 재사용 블록, Schematic 스니펫, PCB 스니펫.

Item의 새 리비전에 데이터를 업로드하는 방법은 두 가지입니다.

업로드 메뉴

Explorer Panel에서 원하는 Item을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Upload 명령을 선택하여 파일을 업로드할 수 있습니다. Create New Revision 대화 상자가 나타나면 필요에 따라 이름과 설명을 변경하고 릴리스 노트를 추가할 수 있습니다. 대화 상자의 Sources Region을 사용하여 필요한 파일을 불러오세요. Windows 탐색기에서 파일을 이 Region으로 끌어다 놓으면 됩니다. 또는 버튼을 클릭하면 Add Files 대화 상자(표준 Windows 파일 열기 대화 상자)가 나타납니다. 이 대화 상자에서 필요한 파일을 찾아 여세요.

Item에 예정된 리비전이 없으면 업로드 과정에서 다음 예정 리비전이 즉시 생성되며, 해당 리비전에 업로드됩니다.

업로드 예시입니다. 이 예에서는 타겟 3D 모델 Item에 업로드할 3D 모델 파일을 수동으로 지정합니다.
업로드 예시입니다. 이 예에서는 타겟 3D 모델 Item에 업로드할 3D 모델 파일을 수동으로 지정합니다.

원하는 파일을 끌어다 놓거나, 파일을 선택하고 Open 버튼을 클릭하면 Sources Region에 해당 파일의 Entry가 나타납니다.

바이너리 파일과 같이 하나의 리비전에 여러 파일을 업로드할 수 있는 콘텐츠 유형의 경우, 선택한 파일이 대화 상자의 Sources Region에 추가되어 표시됩니다. 목록 내용을 조정해야 한다면 필요에 따라 파일을 추가하거나 파일을 선택하여 제거하세요( 버튼 클릭). Sources 영역에서는 표준 다중 선택 방식(Ctrl+Click, Shift+Click, 클릭 후 드래그)을 사용하여 여러 파일을 선택할 수 있습니다.

OK 버튼을 클릭하여 업로드를 진행하세요. 콘텐츠 유형에 따라 업로드한 파일에 관한 정보가 Explorer Panel에서 Item 리비전의 Details 및/또는 Preview 상세 보기 탭에 표시됩니다.

Explorer Panel에서 저장된 Item 리비전을 확인하세요(여기서는 3D 모델 Item을 예로 보여줍니다). 그래픽 표현을 확인하려면 Preview 상세 보기 탭으로 전환하세요(해당하는 경우).
Explorer Panel에서 저장된 Item 리비전을 확인하세요(여기서는 3D 모델 Item을 예로 보여줍니다). 그래픽 표현을 확인하려면 Preview 상세 보기 탭으로 전환하세요(해당하는 경우).

Windows 탐색기에서 끌어다 놓기

Windows 탐색기의 원본 폴더에서 관련 데이터 파일을 선택한 후 Explorer Panel의 원하는 타겟 Item으로 끌어다 놓아 업로드할 수도 있습니다. Create New Revision 대화 상자가 나타나고, 끌어다 놓은 파일이 Sources Region에 표시됩니다. 필요에 따라 Release Notes을 추가한 후 OK 버튼을 클릭하세요.

일부 콘텐츠 유형에서는 Name(확장자를 포함한 파일 이름이며, 여러 파일인 경우 각 Entry가 세미콜론으로 구분됨) 및 Description(Uploaded from <FileNameandPath>, Size <FileSize>, Created on <FileCreationDate> 형식이며, 여러 파일인 경우 각 Entry가 세미콜론으로 구분됨)을 수정해야 합니다. 여러 파일을 지원하는 콘텐츠 유형에서 파일을 추가해야 한다면  버튼을 클릭하여 파일을 찾거나, Sources 영역으로 파일을 끌어다 놓으면 됩니다. 파일을 제거하려면 목록에서 해당 파일을 선택한 후  버튼을 클릭하세요.

끌어다 놓기 방식으로 업로드하는 모습입니다. 여기서는 3D 모델을 예로 보여줍니다.
끌어다 놓기 방식으로 업로드하는 모습입니다. 여기서는 3D 모델을 예로 보여줍니다.

기존 Item에 예정된 리비전이 없으면 업로드 과정에서 다음 예정 리비전이 즉시 생성되며, 해당 리비전에 업로드됩니다. 데이터 파일을 기존 Item이 아닌 위치에 끌어다 놓으면 새 Item이 생성됩니다. 새 Item 생성 대화 상자가 나타납니다. 이름 및 설명 필드는 미리 채워집니다. 콘텐츠 유형에 따라 다음과 같이 설정될 수 있습니다.
  • Item의 Name은 파일 이름이 됩니다. Description은 확장자를 포함한 파일 이름이 됩니다.
  • Item의 Name은 확장자를 포함한 파일 이름이 됩니다(여러 파일인 경우 각 Entry는 세미콜론으로 구분됩니다). Description은 Uploaded from <FileNameandPath>, Size <FileSize>, Created on <FileCreationDate> 형식이 됩니다(여러 파일인 경우 각 Entry는 세미콜론으로 구분됩니다).

필요에 따라 이 값을 변경하세요.

Item ID은 폴더 수준에서 정의된 Item 명명 규칙을 따릅니다. 폴더에 명명 규칙이 정의되어 있지 않으면 $CONTENT_TYPE_CODE-{000000} 규칙을 따릅니다.

데이터 파일을 하나만 저장할 수 있는 콘텐츠 유형의 경우, 둘 이상의 데이터 파일을 끌어다 놓으려고 하면 Release Manager 대화 상자가 자동으로 실행됩니다. 이 대화 상자를 사용하여 여러 파일의 업로드를 완료하세요.

워크스페이스 콘텐츠 복제

Explorer Panel에서는 다양한 워크스페이스 Item을 복제할 수 있습니다. 따라서 필요한 컴포넌트, 도메인 모델, Schematic 시트 또는 템플릿을 처음부터 만드는 대신 간단히 복제할 수 있습니다. 직접 편집을 사용하면 원본 Item 리비전의 소스 데이터 복사본을 간편하게 수정하고, 변경 결과를 동일한 유형의 새 Item의 최초 리비전으로 릴리스할 수 있습니다. 작업을 빠르게 완료할 수 있으므로, 처음부터 새로 시작하지 않고도 워크스페이스 콘텐츠를 신속하게 확장할 수 있습니다.

복제할 수 있는 콘텐츠 유형은 다음과 같습니다.

  • 컴포넌트
  • 풋프린트
  • 심볼
  • 시뮬레이션 모델
  • 컴포넌트 템플릿
  • 관리형 Schematic 시트
  • Schematic 템플릿
  • 프로젝트 템플릿
  • Draftsman 문서 템플릿
  • Draftsman 시트 템플릿
  • 레이어 스택
  • OutputJob

지원되는 콘텐츠 유형을 복제하는 명령은 Explorer Panel에서 다음과 같은 방법으로 실행할 수 있습니다.

  • 원본 Item-리비전의 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Operations » Clone 명령을 선택합니다.
  • 원본 Item-리비전의 항목을 선택하고 Ctrl+D 키보드 단축키를 사용합니다.

Clone 명령은 Explorer Panel에서 해당 Item-리비전이 표시되는 모든 위치에서 사용할 수 있으며, 여기에는 다음 위치가 포함됩니다.

  • 폴더 내 기본 Item 목록.
  • Children 상세 보기 탭(관리형 Schematic 시트 Item을 볼 때).
  • Where-used 상세 보기 탭(컴포넌트 Item, 심볼 Item, 풋프린트 Item, 시뮬레이션 모델 Item, 컴포넌트 템플릿 Item 또는 Schematic 템플릿 Item을 볼 때).
  • Preview 상세 보기 탭(컴포넌트 Item, 관리형 Schematic 시트 Item 또는 Schematic 템플릿 Item을 볼 때).
특정 폴더의 기본 Item 목록을 탐색할 때 Item의 최상위 항목에서 Clone 명령을 실행하면 해당 Item의 최신 리비전을 복제할 수 있습니다.
AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents