굽힘선 정의 - 고급 모드

개요

이 문서에서는 Altium Designer의 고급 Rigid-Flex 모드에서 벤딩 라인이 작동하는 방식을 설명합니다. 특히 이 모드가 표준 Rigid-Flex 모드와 어떻게 다르고, 이러한 차이가 Flex Region 정의와 보드 접기에 어떤 영향을 미치는지 중점적으로 살펴봅니다. PCB에 사용 중인 Rigid-Flex 모드를 확인하고, 보드 계획 모드에서 벤딩 라인을 배치 및 조정하며, 속성을 편집하고, 3D에서 보드를 접었을 때 굽힘이 표시되는 방식을 제어하는 방법을 알아봅니다. 더 복잡한 Rigid-Flex 설계에서 굽힘 위치, 각도, 반경, 접기 순서를 정의하는 데 실질적인 지침이 필요하다면 이 문서가 도움이 될 것입니다. 계속 읽고 Rigid-Flex 작업을 더욱 정밀하고 예측 가능하게 수행해 보세요.

- 표준 Rigid-Flex 모드와 고급 Rigid-Flex 모드의 차이, 특히 고급 모드에서 Split 라인 객체를 사용하지 않는 이유를 이해합니다.
- 보드 계획 모드에서 벤딩 라인을 배치, 이동, 제거하고 위치를 정밀하게 지정하는 기본 작업 절차를 알아봅니다.
- 각도, 반경, 스택 Region 할당, 접기 순서 등 3D에서 굽힘 동작을 제어하는 벤딩 라인 속성을 살펴봅니다.
AI로 더 깊이 알아보기:

Altium의 PCB 설계 소프트웨어에서는 두 가지 Rigid-Flex 설계 모드를 사용할 수 있습니다. Rigid-Flex라고 하는 기존 모드 또는 표준 모드는 간단한 Rigid-Flex 설계를 지원합니다. Flex 영역이 겹치는 경우처럼 설계의 Rigid-Flex 요구 사항이 더 복잡하다면 Advanced Rigid-Flex 모드(Rigid-Flex 2.0이라고도 함)가 필요합니다. 모드는 Layer Stack Manager의 Tools 메뉴에서 선택합니다.

두 모드의 근본적인 차이는 기존 모드에서는 Split 라인을 배치하여 보드 형상을 별도의 보드 영역으로 나누며, 이 Split 라인이 한 보드 영역이 끝나고 다른 보드 영역이 시작되는 위치를 정의하는 객체로 남는다는 점입니다. Advanced 모드에서는 각 보드 영역을 개별적으로 배치하며, 큰 영역을 분할하면 두 개의 별도 영역 객체가 됩니다. Advanced 모드에서는 Split 라인의 존재가 아니라 인접한 보드 영역의 가장자리가 두 영역이 만나는 위치를 정의합니다. 이러한 차이로 인해 보드가 Advanced Rigid-Flex 모드일 때는 Split 라인 객체가 존재하지 않습니다.

► Rigid-Flex PCB 설계에 대해 자세히 알아보기

View 메뉴에는 기억하기 쉬운 단축키가 지정된 세 가지 PCB 편집기 작업 모드가 있어 다음 모드 간에 빠르게 전환할 수 있습니다.

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

2D 보기 모드와 3D 보기 모드 간에 전환할 때는 기본적으로 각 보기 모드의 확대/축소 및 방향 설정이 별도로 유지됩니다. 전환할 때 보드의 동일한 위치와 방향을 보려면 2 또는 3 대신 Ctrl+Alt+2 또는 Ctrl+Alt+3를 누르세요.

방금 연 PCB가 표준 Rigid-Flex 모드를 사용하는지, Advanced Rigid-Flex 모드를 사용하는지 궁금하신가요?

Layer Stack Manager를 열어 확인할 수 있습니다. 또는 Board Planning Mode(1 단축키)로 전환한 후 Active Bar를 살펴보세요.

표준 Rigid-Flex 모드
Advanced Rigid-Flex 모드

Flex 보드가 구부러지는 방식을 정의하려면 하나 이상의 벤딩 라인을 배치합니다. 벤딩 라인은 Flex 영역 표면에서 구부러질 위치를 정의합니다. 또한 굽힘 각도와 반경도 정의합니다. 구부러지는 보드 표면의 띠 모양 부분은 주황색으로 표시되며, 그 폭은 굽힘 각도와 반경으로 계산됩니다(벤딩 라인 속성에 대해 자세히 알아보기). 벤딩 라인은 PCB 편집기가 Board Planning Mode 상태일 때 배치하고 편집합니다(View » Board Planning Mode 또는 1 단축키 누름).


유연한 영역 위에 벤딩 라인을 배치하고 보드가 180도 접히도록 구성합니다. 이 동영상은 Advanced Rigid-Flex 모드에서 벤딩 라인을 배치하는 방법을 보여줍니다.

벤딩 라인 배치

벤딩 라인을 배치하려면 다음을 수행합니다.

  1. View » Board Planning Mode를 선택하거나 1 단축키를 눌러 Board Planning Mode로 전환합니다.
  2. Place » Define Bending Line 명령을 선택하거나 Active Bar에서  버튼을 클릭합니다.
  3. 벤딩 라인은 필요한 Board Region 위에 배치되며, 해당 영역에 부착되지는 않습니다(벤딩 라인은 Stack Regions 속성을 통해 하나 이상의 Board Region과 연결됩니다). Board Region의 가장자리 근처를 클릭하여 벤딩 라인의 시작 위치를 정의합니다.
  4. 커서를 원하는 끝 위치로 이동하고 클릭하여 벤딩 라인을 배치합니다. 벤딩 라인의 한쪽 끝 이상이 적용 대상 Board Region의 경계에 닿거나 경계를 가로질러야 합니다.
  5. 벤딩 라인 배치 모드가 유지되므로 필요한 경우 다른 벤딩 라인을 배치할 수 있습니다. 더 이상 배치하지 않으려면 마우스 오른쪽 버튼을 클릭하거나 Esc를 눌러 벤딩 라인 배치 모드를 종료합니다.

선택한 벤딩 라인의 속성은 Properties 패널에서 편집할 수 있습니다. 벤딩 라인이 영역 위에 있으므로 벤딩 라인을 클릭할 때 그 아래의 영역이 대신 선택될 수 있습니다. 커서를 움직이지 않고 다시 클릭하면 Board Region 대신 벤딩 라인이 선택됩니다.

선택한 벤딩 라인의 속성이 Properties 패널에 표시됩니다.
선택한 벤딩 라인의 속성이 Properties 패널에 표시됩니다.

  • 벤딩 라인의 시작점이나 끝점을 Board Region의 가장자리에 정확하게 맞출 필요는 없습니다. 소프트웨어가 벤딩 라인을 자동으로 연장하거나 줄여 영역의 한쪽 가장자리에서 반대쪽 가장자리까지 이어지도록 정의합니다.
  • Properties 패널의 Stack Regions 섹션에서 올바른 Board Region이 활성화되어 있는지 확인하세요.

벤딩 라인 이동

기존 벤딩 라인의 위치를 수정하려면 다음을 수행합니다.

  1. View » Board Planning Mode 을 선택하거나 1 단축키를 눌러 Board Planning Mode로 전환합니다.
  2. 벤딩 라인의 양 끝 중 한쪽 꼭짓점을 클릭한 채로 원하는 위치로 드래그한 다음 마우스 버튼을 놓습니다. 커서의 이동은 현재 커서 스냅 설정에 따라 제한됩니다. 작업 중에 Ctrl+E를 누르면 설정을 변경할 수 있습니다.
  3. 벤딩 라인의 새 위치에 따라 굽힘 위치가 다시 정의됩니다.

벤딩 라인의 꼭짓점을 선택하고 드래그하여 보드에서 벤딩 라인의 위치를 변경합니다. 커서의 이동은 현재 커서 스냅 설정에 따라 제한됩니다.
벤딩 라인의 꼭짓점을 선택하고 드래그하여 보드에서 벤딩 라인의 위치를 변경합니다. 커서의 이동은 현재 커서 스냅 설정에 따라 제한됩니다.

벤딩 라인의 정밀한 위치 지정

벤딩 라인의 핸들을 이동하면 현재 스냅 설정에 따라 핸들이 스냅됩니다. 이동 중에 Ctrl+E를 누르면 아래 이미지와 같이 스냅 설정 대화형 제어 패널이 나타납니다. 설정을 변경한 후 Esc를 눌러 설정을 적용하고 패널을 닫습니다.

벤딩 라인은 스냅 그리드 및 워크스페이스 가이드뿐만 아니라 기계 레이어의 선과 같은 기존 설계 객체에도 스냅할 수 있습니다. 아래 이미지는 기계 레이어에 있는 선의 끝 꼭짓점에 벤딩 라인 핸들을 배치하는 모습을 보여줍니다. 이동 중에는 현재 Hotspot Snap 설정(상태 표시줄에 표시됨)이 적용됩니다. 기계 레이어가 활성 설계 레이어가 아니라면 이러한 스냅 동작이 작동하도록 Hotspot Snap을 All Layers로 설정해야 합니다. 작업 중에 Shift+E 단축키를 누르면 사용 가능한 Hotspot Snap 설정 모드를 순환하여 전환할 수 있습니다.

벤딩 라인의 핸들이 기계 레이어에 배치된 트랙의 꼭짓점에 스냅되는 모습입니다.
벤딩 라인의 핸들이 기계 레이어에 배치된 트랙의 꼭짓점에 스냅되는 모습입니다.

벤딩 라인 제거

벤딩 라인을 제거하려면 다음을 수행합니다.

  1. View » Board Planning Mode을 선택하거나 1 단축키를 눌러 Board Planning Mode로 전환합니다.
  2. 벤딩 라인의 꼭짓점 중 하나를 클릭한 채로 유지하여 벤딩 라인을 선택한 다음 Delete 키를 누릅니다.

벤딩 라인 속성 구성

Properties 패널에서 벤딩 라인의 속성을 편집하려면 다음을 수행합니다.

  1. Board Planning Mode로 전환합니다(1 누름).
  2. 벤딩 라인의 주황색 띠 내부에서 아무 곳이나 클릭하여 선택합니다.
  3. 벤딩 라인은 Properties 패널에서 편집할 수 있습니다.

보드가 3D 모드로 표시될 때 정의된 굽힘을 적용할 수 있습니다. 5 단축키를 누르면 보드가 접힙니다. 3D Locked 체크박스가 선택된 리지드 Board Region은 3D 표시 모드에서 물리적 기준면(Z = 0)이 됩니다. 보드가 예상대로 접히지 않으면 올바른 리지드 영역에서 3D Locked 체크박스가 선택되어 있는지 확인하세요. 다른 Board Region에서 이 옵션을 활성화하기 전에 기존 Board Region에서 선택을 해제할 필요는 없습니다.

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents