Importing Existing Libraries to Your Connected Workspace
W skrócie
- Dowiedz się, jak uruchomić narzędzie Library Importer i wybrać tryb prosty lub zaawansowany.
- Poznaj obsługiwane biblioteki i dane komponentów, które można importować, a także najważniejsze ograniczenia.
- Zapoznaj się z podglądem importu, klasyfikacją komponentów, ustawieniami parametrów i raportami, które ułatwiają weryfikację i dopracowanie importu.
Altium Designer, we współpracy z połączoną przestrzenią roboczą, zapewnia usprawniony i wysoce zautomatyzowany proces szybkiego importowania istniejących bibliotek do tej przestrzeni. Interfejs tego procesu — Library Importer — oferuje rozwiązanie obsługiwane jednym kliknięciem, które automatycznie analizuje wybrane biblioteki i importuje je do przestrzeni roboczej, z którą aktualnie nawiązano połączenie.
Library Importer obsługuje wszystkie typy bibliotek związanych ze starszymi metodami zarządzania komponentami (SchLib, PcbLib, IntLib, DbLib, SVNDbLib). Jest to dedykowane rozwiązanie umożliwiające szybkie tworzenie firmowej biblioteki komponentów w przestrzeni roboczej, aby można było korzystać z jej licznych zalet: wysokiej integralności danych, scentralizowanego przechowywania i zarządzania, łatwego ponownego wykorzystania projektów oraz informacji o łańcuchu dostaw dostępnych w czasie rzeczywistym.
Library Importer oferuje minimalistyczny tryb interfejsu Simple, w którym wybrane biblioteki komponentów oparte na bazach danych i plikach są importowane do komponentów przestrzeni roboczej w jednym kroku. Importer automatycznie zajmuje się przy tym klasyfikacją typów, docelowym folderem źródłowym, uwzględnianiem parametrów i typami ich wartości oraz przesyłaniem wszystkich istotnych danych. Interfejs jest również dostępny w trybie Advanced, który zapewnia pełny podgląd proponowanego importu bibliotek oraz dostęp do powiązanych danych i ustawień. Choć domyślnie import wymaga tylko jednego kliknięcia, importer oferuje również zaawansowane opcje konfiguracji w panelu Properties, umożliwiające dokładniejszą kontrolę nad przebiegiem importu.
Co jest importowane?
Do komponentów przestrzeni roboczej importowane są wszystkie informacje znajdujące się w oryginalnej bibliotece źródłowej, w tym wszystkie powiązane modele dziedzinowe (symbole schematowe, obudowy PCB, modele symulacyjne), informacje parametryczne, przypisane warianty doboru części, pliki kart katalogowych itp. W razie potrzeby tworzone są również szablony komponentów, które można następnie dopracować i wykorzystać podczas kolejnych importów bibliotek.
Jeśli oryginalne komponenty mają zdefiniowanych wiele obudów PCB, Library Importer przeniesie te modele i zachowa aktualną obudowę domyślną. Jeśli pracujesz wyłącznie z bibliotekami PCB — zajmujesz się tylko projektowaniem płytek PCB — Library Importer umożliwia importowanie samych tych bibliotek. Można go również przełączyć w tryb importu wyłącznie modeli, w którym określone typy modeli są importowane z bibliotek zintegrowanych lub bazodanowych. Biblioteki zawierające wiele typów komponentów (biblioteki monolityczne) także są automatycznie wykrywane i przetwarzane.
Choć proces importowania bibliotek musi obsługiwać biblioteki źródłowe oparte na bazach danych i plikach, które mogą korzystać z różnych standardów formatowania, jego zautomatyzowane mechanizmy analizy wykrywają typy komponentów w bibliotece źródłowej (rezystor, kondensator itp.), a także nazwy parametrów i typy ich wartości (wolty, omy itp.). System przeprowadza szereg kontroli, na przykład sprawdza, czy identyfikatory wynikowych komponentów biblioteki w przestrzeni roboczej nie powtarzają się, czy nie są tworzone zduplikowane modele lub szablony komponentów oraz czy w razie potrzeby obiekty te są ponownie wykorzystywane przez komponenty poprzez odpowiednie powiązania. Jeśli pojawią się problemy, system je sygnalizuje i podaje sugestie dotyczące ich rozwiązania, aby jak najszybciej i jak najsprawniej przywrócić prawidłowy przebieg importu.
Można importować następujące typy bibliotek:
-
Biblioteka schematowa (
*.SchLib). -
Biblioteka obudów PCB (
*.PcbLib). -
Biblioteka zintegrowana (
*.IntLib) -
Biblioteka bazodanowa (
*.DbLib). -
Biblioteka bazodanowa SVN (
*.SVNDbLib).
Dostęp do narzędzia Library Importer
Library Importer jest dostępny po połączeniu z przestrzenią roboczą. Aby uzyskać dostęp do importera w trybie Simple:
-
W panelu Components wybierz opcję Import Library z menu
. Jeśli w kolumnie Categories panelu (lub w górnym menu rozwijanym, gdy panel jest w trybie kompaktowym) jest aktualnie wybrana biblioteka bazodanowa lub plikowa, Library Importer otworzy się dla tej biblioteki. Gdy wybrany jest typ komponentu biblioteki w przestrzeni roboczej, otworzy się standardowe okno dialogowe systemu Windows Open, umożliwiające odnalezienie i wybranie pliku biblioteki do zaimportowania.
-
Kliknij prawym przyciskiem myszy plik biblioteki w panelu Projects i wybierz Import Library z menu kontekstowego.
-
Wybierz Tools » Import Library w edytorze symboli schematowych lub obudów PCB, gdy otwarty jest lokalny plik biblioteki.
-
Wybierz File » Import Library lub Tools » Import Library w edytorze bibliotek bazodanowych.
-
W oknie dialogowym Libraries Preferences wybierz pozycję biblioteki na karcie Installed, a następnie kliknij element sterujący Import.
-
Przeciągnij plik biblioteki z folderu systemu Windows i upuść go w panelu Explorer.
Tryb prosty umożliwia natychmiastowe zaimportowanie wybranej biblioteki lub otwarcie narzędzia Library Importer w trybie pełnego interfejsu graficznego

Library Importer otwarty w trybie importu jednym kliknięciem Simple.
Aby bezpośrednio otworzyć Library Importer w trybie interfejsu Advanced, wybierz File » Library Importer z menu głównego.

Library Importer otwarty w trybie pełnego interfejsu Advanced również obsługuje importowanie jednym kliknięciem.
Tryb prosty
Tryb prosty narzędzia Library Importer wstępnie konfiguruje wszystkie aspekty procesu importu na podstawie analizy biblioteki źródłowej i połączonej przestrzeni roboczej. Okno dialogowe Library Importer przedstawia następnie podsumowanie struktury importu, w tym łączną liczbę elementów każdego typu. Import biblioteki jest wykonywany w jednym kroku za pomocą polecenia
.
Ten prosty tryb interfejsu sprawdza się w przypadku większości popularnych formatów bibliotek źródłowych, które zazwyczaj zawierają typowe komponenty (rezystory, kondensatory, układy scalone itp.) i ustandaryzowane wartości parametrów. Podczas wstępnej analizy system rozpoznaje typ komponentów w bibliotece na podstawie oznacznika lub słów kluczowych parametrów (LD?, LED itp.), a następnie wyszukuje odpowiedni szablon komponentu w docelowej przestrzeni roboczej (LED). Szablon ten jest stosowany podczas importu tych komponentów i określa ustawienia importu, takie jak folder docelowy (Components/LED), mapowanie parametrów, jednostki wartości parametrów itd. Odpowiednie szablony są dostępne w przestrzeni roboczej, jeśli podczas aktywacji przestrzeni roboczej Altium 365 lub instalacji Altium On-Prem Enterprise Server wybrano opcję dołączenia przykładowych danych.
Wyniki importu biblioteki, w postaci nowo utworzonych komponentów w przestrzeni roboczej, można zobaczyć w panelach Explorer i Components. Zaimportowane komponenty zawierają wszystkie modele, parametry zinterpretowane zgodnie z zastosowanymi szablonami komponentów, warianty doboru części na podstawie danych źródłowych łączy do dostawców oraz wszelkie łącza lub pliki referencyjne.
Ważne informacje dotyczące procesu importu bibliotek:
-
Biblioteki monolityczne (zawierające wiele typów komponentów) są automatycznie dzielone na podgrupy, z których każda reprezentuje typ komponentu występujący w danej bibliotece. Grupy są przetwarzane jako oddzielne biblioteki.
-
Biblioteka źródłowa z nierozpoznanym (niewykrytym) typem komponentu zostanie zaimportowana bez interpretacji, jako komponenty o nieprzypisanym typie w folderze
Components/Uncategorizedprzestrzeni roboczej. Przed uruchomieniem importu można rozwiązać ten problem, stosując mapowanie oznaczeń lub grupowanie parametrów w trybie Advanced (pełny interfejs użytkownika). Można też przeprowadzić import, a następnie zmodyfikować ustawienia i folder komponentu w panelu Explorer. - Proces importu bibliotek obejmuje etap automatycznej walidacji komponentów. Komponenty, które wywołają błąd walidacji, zostaną pominięte.
- Jeśli w importowanej bibliotece źródłowej zostaną wykryte zduplikowane modele, zaimportowany zostanie tylko jeden z nich i zostanie on powiązany z utworzonymi komponentami w docelowej przestrzeni roboczej. U góry okna dialogowego Library Importer pojawi się odpowiednie powiadomienie.
-
Wszelkie błędy napotkane podczas procesu można przejrzeć w Importing Report, dostępnym po naciśnięciu przycisku
po zakończeniu importu.
Tryb zaawansowany
Pełny graficzny interfejs importera bibliotek jest wyświetlany w trybie Advanced, który zapewnia szczegółową kontrolę nad zarządzaniem bibliotekami, typami komponentów i ich parametrami. W połączeniu z panelem Properties umożliwia dostosowanie importu bibliotek komponentów do przestrzeni roboczej do konkretnych potrzeb. Ustawienia importera można zapisywać i przywracać poprzez eksportowanie/importowanie plików konfiguracyjnych.
Tryb zaawansowany jest włączany po otwarciu importera bibliotek za pomocą polecenia File » Library Importer lub po wybraniu przycisku
w trybie prostym. Biblioteki dodaje się do sekcji SOURCE LIBRARIES importera (jeśli nie została jeszcze wypełniona), przeciągając i upuszczając plik biblioteki w tym obszarze, klikając prawym przyciskiem myszy <All Libraries> i wybierając Add Library z menu kontekstowego lub wybierając przycisk
.
Sekcja Import Preview zawiera listę grup typów komponentów rozpoznanych w bibliotekach źródłowych — jako Types lub proponowane Folder Structure — oraz tabelaryczny widok parametrów tych komponentów (Components). Wartości parametrów w tabeli można edytować na bieżąco, bez konieczności otwierania i edytowania biblioteki źródłowej. Dolny obszar Details zawiera dodatkowe informacje pochodzące z aktualnie zaznaczonego komponentu — warianty doboru części, modele i karty katalogowe.
Niezależnie od szczegółowych opcji i danych prezentowanych w interfejsie, widoku zaawansowanego importera można używać tak samo jak widoku prostego — wystarczy kliknąć przycisk
, aby uruchomić proces importu bez dodatkowej ingerencji. Podobnie jak w widoku prostym, importer analizuje bibliotekę, określa typ zawartych w niej komponentów i stosuje odpowiedni szablon komponentu. Szablon określa z kolei folder docelowy w przestrzeni roboczej, stosowane schematy nazewnictwa i definicje cyklu życia oraz mapowanie i interpretację parametrów.
Biblioteki monolityczne
Biblioteki źródłowe zawierające wiele typów komponentów są wykrywane przez procedury analityczne importera i dzielone na grupy podbibliotek, które można przetwarzać jako oddzielne biblioteki poszczególnych typów. Wykrywanie typu komponentu opiera się na oznaczeniach komponentów źródłowych (R?, C? itd.), a także na słowach kluczowych (Resistor, Res itd.) zawartych w pozostałych głównych parametrach komponentów (opis, identyfikator itd.).
W poniższym przykładzie biblioteka źródłowa (ProjectABC.IntLib) została automatycznie „podzielona” według wykrytych typów komponentów (kondensatory, rezystory itd.). Można je wybrać w kolumnie Folder Structure (lub w kolumnie Types), aby wyświetlić należące do nich komponenty w tabeli Components.
Sposób wyświetlania listy Components można zmienić na kilka sposobów:
-
Kliknij nagłówek kolumny, aby posortować listę według danego parametru, a następnie kliknij go ponownie, aby odwrócić kolejność.
-
W menu kontekstowym nagłówka, dostępnym po kliknięciu prawym przyciskiem myszy:
-
Wybierz Clear Sorting, aby przywrócić domyślną kolejność listy (rosnąco według kolumny Name).
-
Wybierz Best Fit, aby dopasować szerokość danej kolumny do jej zawartości.
-
Wybierz Select Best Fit All Columns, aby dopasować szerokość wszystkich dostępnych kolumn do ich zawartości.
-
Wybierz Select Columns, aby otworzyć okno dialogowe Select Columns, w którym można włączać i wyłączać kolumny parametrów oraz zmieniać ich kolejność na liście.
-
-
Kliknij ikonę filtra w nagłówku, aby ograniczyć listę do dostępnej wartości parametru w kolumnie, wartości pustych lub niepustych albo ustawienia filtra Custom. Zastosowany filtr jest wyświetlany u dołu listy, gdzie można go włączyć lub wyłączyć (za pomocą powiązanego pola wyboru), zmodyfikować w Filter Editor lub usunąć. Wybranie All za pomocą ikony filtra w nagłówku również spowoduje usunięcie zastosowanego filtra.
Komponenty bez kategorii
Jeśli jedna z podgrup biblioteki nosi nazwę Uncategorized (i jest wyświetlana jako Uncategorized w sekcji Types lub Folder Structure oraz towarzyszy jej
ikona), oznacza to, że importer nie mógł wykryć i przypisać typu tej grupie komponentów — typ komponentu jest w praktyce ustawiony na None. W tym przypadku nierozpoznane komponenty (układy scalone inwerterów logicznych) używają nierozpoznanego prefiksu oznaczenia (U?), a ich parametry nie zawierają rozpoznawanych słów kluczowych, takich jak IC, logic itp.
Ten problem można rozwiązać, ręcznie mapując oznaczenia używane dla tych komponentów na żądany typ komponentu w oknie dialogowym Library Splitting, dostępnym po kliknięciu przycisku
— dostępnego po wybraniu biblioteki źródłowej (ProjectABC.IntLib). Okno dialogowe Library Splitting z wartościami domyślnymi udostępnia opcje definiowania niestandardowego grupowania bibliotek dla nieskategoryzowanych komponentów na podstawie mapowania oznaczeń według typów komponentów oraz podziału według parametrów.
Po wybraniu opcji Map Designators w tym oknie dialogowym wybierz z listy rozwijanej Component Type typ komponentu odpowiedni dla nieskategoryzowanych komponentów (lista zawiera wszystkie dostępne typy komponentów). Potwierdź ukończone mapowanie typu na oznaczenia (typu komponentu Logic na oznaczenia U?) przyciskiem
.
Po określeniu typu komponentu za pomocą zastosowanego mapowania importer użyje odpowiedniego szablonu komponentu (Logic) do skonfigurowania importu biblioteki zgodnie z ustawieniami szablonu (folder, nazewnictwo itp.).
Pamiętaj, że dzięki elastycznym ustawieniom narzędzia Library Importer można zaimportować nowy (nieskategoryzowany) typ biblioteki komponentów wraz z całą infrastrukturą niezbędną do przyszłych importów tego typu biblioteki. Po wybraniu odpowiedniej konfiguracji importu — nowego typu komponentu, szablonu komponentu, folderu docelowego, mapowania parametrów i typów jednostek wartości parametrów — przy kolejnym imporcie tego typu biblioteki wystarczy wybrać wcześniej zdefiniowany typ komponentu. Wybrany typ komponentu określi wówczas wszystkie pozostałe aspekty importu.
Wykluczanie z importu
Z importu można również wykluczyć określone typy komponentów. Aby wykluczyć typ komponentu, kliknij go prawym przyciskiem myszy na liście Types, a następnie wybierz Exclude from Importer z menu kontekstowego — w razie potrzeby zmień sposób wyświetlania kolumn z Folder Structure na Types
Wykluczony typ komponentu będzie wyszarzony na liście Types. Aby wyświetlić wykluczone komponenty w tabeli, kliknij Show Excluded Component (n), gdzie n oznacza liczbę wykluczonych komponentów.
Uwzględnianie w imporcie
Jeśli typ komponentu został wykluczony z importu za pomocą opisanego powyżej polecenia Exclude from Importer i jednak chcesz go uwzględnić, kliknij prawym przyciskiem myszy wyszarzony typ komponentu na liście Types (lub Folder Structure), a następnie wybierz Include to Importer z menu kontekstowego. Typ komponentu ponownie pojawi się na liście Types, co oznacza, że nie jest już wykluczony.
Błędy i ostrzeżenia walidacji
Komponenty, które nie zostaną poprawnie zaimportowane do przestrzeni roboczej lub nie zostaną zaimportowane w ogóle, są oznaczane znacznikami ostrzeżeń lub błędów w zaawansowanym interfejsie użytkownika po uruchomieniu narzędzia Library Importer lub przeprowadzeniu walidacji importu Walidacja sprawdza również, czy ścieżki folderów przestrzeni roboczej nie są puste, czy nie występują konflikty parametrów systemowych oraz czy nie ma zduplikowanych modeli. Błąd krytyczny blokuje import.
Podczas próby wykonania importu panel Messages zostaje wypełniony wykrytymi naruszeniami, a okno dialogowe umożliwia przerwanie importu lub kontynuowanie go z bieżącą konfiguracją. W tym drugim przypadku nieprawidłowe komponenty nie zostaną zaimportowane lub proces importu zakończy się niepowodzeniem.
W przypadku anulowania importu lub ręcznego uruchomienia walidacji wszystkie komponenty, które nie przejdą kontroli importu, zostają oznaczone ikonami błędów/ostrzeżeń, a dodatkowe informacje pojawiają się w dolnym obszarze Details. Ikony w kolumnie podglądu Status wskazują konkretne pozycje komponentów naruszające sprawdzane reguły importu.
Poniżej wymieniono dostępne, wbudowane kontrole walidacyjne.
Opis komponentu jest zbyt długi
Report mode:
Podsumowanie
To naruszenie występuje, gdy opis komponentu przeznaczonego do importu ma więcej niż 256 znaków.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
<ComponentName> description more then 256 characters.
gdzie:
-
ComponentNameto nazwa komponentu, którego dotyczy naruszenie.
Zalecany sposób rozwiązania
Edytuj opis komponentu w bibliotece źródłowej tak, aby nie przekraczał limitu długości.
Błędy szablonu komponentu
Report mode:
Podsumowanie
To naruszenie występuje, gdy w szablonie komponentu zastosowanym do komponentów przeznaczonych do importu znajduje się błąd.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Component template has errors: <Descripion>
gdzie:
-
Descripionto opis błędu szablonu komponentu.
Zalecany sposób rozwiązania
Na podstawie opisu błędu znajdź i popraw błąd w bibliotece źródłowej lub konfiguracji importu biblioteki.
Zduplikowany identyfikator HRID komponentu
Report mode:
Podsumowanie
To naruszenie występuje, gdy identyfikatory elementów komponentów przeznaczonych do importu są takie same.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
<ComponentName1> component HRID is duplicated with <ComponentName2> component HRID.
gdzie:
-
ComponentName1iComponentName2to nazwy komponentów, których dotyczy naruszenie.
Zalecany sposób rozwiązania
W obszarze Parameter Mapping panelu Properties upewnij się, że parametr ID jest mapowany na parametr biblioteki źródłowej, który ma unikatowe wartości dla komponentów, których dotyczy naruszenie. Możesz również ustawić mapowanie tego parametru na <Auto> — w takim przypadku identyfikatory elementów komponentów zostaną ustawione automatycznie na podstawie Naming Scheme określonego w obszarze Component panelu (na karcie Advanced).
Alternatywnie upewnij się, że parametr wybrany jako identyfikator elementu ma unikatowe wartości dla każdego komponentu powodującego naruszenie w bibliotece źródłowej.
Powielona geometria modeli
Report mode:
Podsumowanie
To naruszenie występuje, gdy komponenty przeznaczone do zaimportowania mają w bibliotekach źródłowych modele symboli o takiej samej geometrii.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
<SymbolModelName1> model has the same geometry as <SymbolModelName2> in your source library. Imported components will be linked to <SymbolModelName2>
gdzie:
-
SymbolModelName1iSymbolModelName2to nazwy modeli symboli powodujących naruszenie.
Pusty identyfikator HRID komponentu
Report mode:
Podsumowanie
To naruszenie występuje, gdy identyfikator elementu komponentu przeznaczonego do zaimportowania jest pusty.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
<ComponentName> component HRID is empty.
gdzie:
-
ComponentNameto nazwa komponentu powodującego naruszenie.
Zalecane rozwiązanie
W obszarze Parameter Mapping panelu Properties upewnij się, że parametr ID jest mapowany na parametr biblioteki źródłowej, który ma wartość dla komponentu powodującego naruszenie. Możesz również ustawić mapowanie tego parametru na <Auto> — w takim przypadku identyfikator elementu komponentu zostanie ustawiony automatycznie na podstawie Naming Scheme określonego w obszarze Component panelu (na karcie Advanced).
Alternatywnie upewnij się, że wybrany parametr ma wartość w bibliotece źródłowej.
Pusta definicja cyklu życia w ustawieniach encji
Report mode:
Podsumowanie
To naruszenie występuje, gdy biblioteka źródłowa zawiera dane, których typ nie jest przypisany do definicji cyklu życia.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
<ContentType> entity settings in library <LibraryName>.<LibraryType> have empty Lifecycle Definition.
gdzie:
-
ContentTypeto typ danych (np. komponent lub symbol), który nie jest przypisany do definicji cyklu życia. -
LibraryNameto nazwa biblioteki źródłowej zawierającej dane, których typ nie jest przypisany do definicji cyklu życia. -
LibraryTypeto nazwa grupy podbibliotek zawierającej dane, których typ nie jest przypisany do definicji cyklu życia.
Zalecane rozwiązanie
Upewnij się, że dla typu danych powodującego naruszenie wybrano definicję cyklu życia z listy rozwijanej Lifecycle Definition w panelu Properties (na karcie Advanced). Jeśli na liście rozwijanej są dostępne pozycje, upewnij się, że typ danych powodujący naruszenie jest przypisany do definicji cyklu życia. Więcej informacji znajdziesz na stronie Definiowanie definicji cyklu życia dla obszaru roboczego.
Pusty schemat nazewnictwa rewizji w ustawieniach encji
Report mode:
Podsumowanie
To naruszenie występuje, gdy biblioteka źródłowa zawiera dane, których typ nie jest przypisany do schematu nazewnictwa rewizji.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
<ContentType> entity settings in library <LibraryName>.<LibraryType> have empty Revision Naming Scheme.
gdzie:
-
ContentTypeto typ danych (np. komponent lub symbol), który nie jest przypisany do schematu nazewnictwa rewizji. -
LibraryNameto nazwa biblioteki źródłowej zawierającej dane, których typ nie jest przypisany do schematu nazewnictwa rewizji. -
LibraryTypeto nazwa grupy podbibliotek zawierającej dane, których typ nie jest przypisany do schematu nazewnictwa rewizji.
Zalecane rozwiązanie
Upewnij się, że dla typu danych powodującego naruszenie wybrano definicję cyklu życia z listy rozwijanej Schemat nazewnictwa rewizji w panelu Properties (na karcie Advanced). Jeśli na liście rozwijanej są dostępne pozycje, upewnij się, że typ danych powodujący naruszenie jest przypisany do schematu nazewnictwa rewizji. Więcej informacji znajdziesz na stronie Definiowanie schematów nazewnictwa rewizji dla obszaru roboczego.
Folder nie istnieje
Report mode:
Podsumowanie
To naruszenie występuje, gdy folder, do którego mają zostać zaimportowane dane, nie istnieje w połączonym obszarze roboczym.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Folder '<FolderPath>' does not exist
gdzie:
-
FolderPathto ścieżka do folderu docelowego, który nie istnieje w połączonym obszarze roboczym.
Zalecane rozwiązanie
W panelu Properties wskaż folder docelowy, klikając przycisk
po prawej stronie pola Folder dla danych, które zostaną zapisane w obszarze roboczym. W otwartym oknie dialogowym Choose Folder odszukaj i wybierz istniejący folder lub utwórz nowy.
Nie znaleziono obudowy PCB w dostępnych bibliotekach
Report mode:
Podsumowanie
To naruszenie występuje, gdy komponent ma powiązaną obudowę PCB, której nie można znaleźć w dostępnych bibliotekach.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Footprint <FootprintName> is not found in available libraries. Any referenced footprints can only be found if the relevant PcbLib(s) are either installed, or are added to the Library Importer directly.
gdzie:
-
FootprintNameto nazwa brakującej obudowy PCB.
Zalecane rozwiązanie
Dodaj biblioteki zawierające powiązane obudowy PCB do narzędzia Library Importer. W tym celu kliknij element sterujący Choose a Library w obszarze Details, gdy w obszarze Components zaznaczony jest komponent powodujący to naruszenie.
Alternatywnie upewnij się, że biblioteki zawierające obudowy PCB powiązane z komponentami przeznaczonymi do zaimportowania są zainstalowane (więcej informacji o zainstalowanych bibliotekach znajdziesz na stronie Wyszukiwanie komponentów w bibliotekach bazodanowych i plikowych) lub edytuj powiązanie z obudową PCB w bibliotece źródłowej.
Więcej informacji znajdziesz w sekcji Import biblioteki schematowej.
Nieprawidłowe mapowanie parametrów
Report mode:
Podsumowanie
To naruszenie występuje, gdy w konfiguracji mapowania parametrów występuje błąd.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Parameter mapping in library <LibraryName>.<LibraryType> has error: <Descripion>
gdzie:
-
LibraryNameto nazwa biblioteki źródłowej, w której znajduje się komponent z nieprawidłowym mapowaniem parametrów. -
LibraryTypeto nazwa grupy podbibliotek, w której znajduje się komponent z nieprawidłowym mapowaniem parametrów. -
Descripionto opis naruszenia reguł mapowania parametrów.
Zalecany sposób rozwiązania
W obszarze Parameter Mapping panelu Properties znajdź parametry oznaczone ikoną
i odpowiednio zaktualizuj mapowanie. Możesz też usunąć wpisy mapowania zawierające błędy.
Element o tym identyfikatorze HRID został już wydany
Report mode:
Podsumowanie
To naruszenie występuje, gdy identyfikator elementu komponentu przeznaczonego do zaimportowania jest taki sam jak identyfikator elementu, który już istnieje w docelowej przestrzeni roboczej.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Item with HRID <ItemID> already released.
gdzie:
-
ItemIDto identyfikator używany przez element w przestrzeni roboczej.
Zalecany sposób rozwiązania
W obszarze Parameter Mapping panelu Properties upewnij się, że parametr ID jest mapowany na parametr biblioteki źródłowej o unikatowej wartości. Możesz również ustawić mapowanie tego parametru na <Auto> – w takim przypadku identyfikator elementu komponentu zostanie ustawiony automatycznie na podstawie Naming Scheme określonego w obszarze Component panelu (na karcie Advanced). W takim przypadku upewnij się, że Naming Scheme jest skonfigurowany tak, aby generował unikatowe identyfikatory elementów.
Możesz też upewnić się, że parametr wybrany jako identyfikator elementu ma unikatową wartość w bibliotece źródłowej.
Nie znaleziono definicji cyklu życia do importowania arkuszy danych
Report mode:
Podsumowanie
To naruszenie występuje, gdy biblioteka źródłowa zawiera komponenty z powiązanymi arkuszami danych, a typ zawartości Datasheet nie jest przypisany do definicji cyklu życia.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Lifecycle Definition to import <LibraryName>.<LibraryType> library datasheets is not found.
gdzie:
-
LibraryNameto nazwa biblioteki źródłowej, której komponenty zawierają arkusze danych. -
LibraryTypeto nazwa grupy podbibliotek, której komponenty zawierają arkusze danych.
Zalecany sposób rozwiązania
Upewnij się, że typ zawartości Datasheet jest przypisany do definicji cyklu życia. Więcej informacji znajdziesz na stronie Definiowanie definicji cyklu życia dla przestrzeni roboczej.
Możesz też wyłączyć import plików arkuszy danych, zmieniając opcję Migrate w obszarze Datasheet panelu Properties (na karcie Advanced).
Opis modelu jest zbyt długi
Report mode:
Podsumowanie
To naruszenie występuje, gdy opis modelu komponentu zawiera więcej niż 256 znaków.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Description of Model '<ModelName>' of component '<ComponentName>' more then 256 characters.
gdzie:
-
ModelNameto nazwa modelu powodującego naruszenie. -
ComponentNameto nazwa komponentu zawierającego model powodujący naruszenie.
Zalecany sposób rozwiązania
Edytuj opis modelu w bibliotece źródłowej tak, aby nie przekraczał limitu długości.
Wartość wymaganego parametru jest pusta
Report mode:
Podsumowanie
To naruszenie występuje, gdy powiązany szablon komponentu zawiera parametr oznaczony jako wymagany, a parametr ten nie ma wartości w bibliotece źródłowej.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
<ParameterName> required parameter value in component <ComponentName> is empty.
gdzie:
-
ParameterNameto nazwa parametru powodującego naruszenie. -
ComponentNameto nazwa komponentu zawierającego parametr powodujący naruszenie.
Zalecany sposób rozwiązania
Dodaj wartość parametru powodującego naruszenie w bibliotece źródłowej lub bezpośrednio w obszarze tabeli narzędzia Library Importer. Możesz też edytować mapowanie parametrów w obszarze Parameter Mapping panelu Properties (na karcie General), tak aby wymagany parametr był mapowany na parametr biblioteki źródłowej, który ma wartość.
Nie znaleziono schematu nazewnictwa rewizji do importowania arkuszy danych
Report mode:
Podsumowanie
To naruszenie występuje, gdy biblioteka źródłowa zawiera komponenty z powiązanymi arkuszami danych, a typ zawartości Datasheet nie jest przypisany do schematu nazewnictwa rewizji.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Revision Naming Scheme to import <LibraryName>.<LibraryType> library datasheets is not found.
gdzie:
-
LibraryNameto nazwa biblioteki źródłowej, której komponenty zawierają arkusze danych. -
LibraryTypeto nazwa grupy podbibliotek, której komponenty zawierają arkusze danych.
Zalecany sposób rozwiązania
Upewnij się, że typ zawartości Datasheet jest przypisany do schematu nazewnictwa rewizji. Więcej informacji znajdziesz na stronie Definiowanie schematów nazewnictwa rewizji dla przestrzeni roboczej.
Możesz też wyłączyć import plików arkuszy danych, zmieniając opcję Migrate w obszarze Datasheet panelu Properties (na karcie Advanced).
Nie znaleziono pliku modelu symulacyjnego
Report mode:
Podsumowanie
To naruszenie występuje, gdy komponent ma powiązany model symulacyjny, którego nie można znaleźć pod wskazaną ścieżką.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Simulation model file <Path> is not found.
gdzie:
-
Pathto wskazana ścieżka do modelu symulacyjnego.
Zalecany sposób rozwiązania
Upewnij się, że model symulacyjny znajduje się pod wskazaną ścieżką. Możesz też zaktualizować ścieżkę do modelu w bibliotece źródłowej.
Nazwa symbolu nie może być pusta
Report mode:
Podsumowanie
To naruszenie występuje, gdy komponent nie ma powiązanego symbolu.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Symbol name cannot be empty.
Zalecany sposób rozwiązania
Upewnij się, że powiązanie z symbolem jest poprawnie zdefiniowane dla komponentu w bibliotece źródłowej.
Nie masz uprawnień do modyfikowania folderu
Report mode:
Podsumowanie
To naruszenie występuje, gdy nie masz uprawnień do zapisu w folderze docelowym w połączonym obszarze roboczym.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
You do not have access right to modify folder <FolderPath>.
gdzie:
-
FolderPathto ścieżka do folderu docelowego w połączonym obszarze roboczym, do którego nie masz uprawnień do edycji.
Zalecany sposób rozwiązania
Poproś administratora obszaru roboczego o nadanie Ci uprawnień do zapisu w tym folderze (więcej informacji znajdziesz na stronie Kontrolowanie dostępu do zawartości obszaru roboczego).
Możesz też użyć panelu Properties, aby wybrać inny folder, do którego masz uprawnienia do zapisu. Kliknij przycisk
po prawej stronie pola Folder dla zawartości, która zostanie zapisana w obszarze roboczym, a następnie w otwartym oknie dialogowym Choose Folder przejdź do istniejącego folderu i wybierz go lub utwórz nowy folder.
Kontrole definiowane przez użytkownika konfiguruje się w sekcji Import Checks panelu Properties. Użyj menu rozwijanego Report Mode, aby wybrać inny poziom raportowania dla powiązanego typu naruszenia. Kontrole te wymieniono poniżej.
Komponent jest zduplikowany na podstawie parametru
Default report mode:
Podsumowanie
To naruszenie występuje, gdy komponent z bibliotek źródłowych przeznaczonych do zaimportowania ma wartość parametru oznaczonego jako unikatowy, a komponent w docelowym obszarze roboczym ma taką samą wartość tego parametru. Więcej informacji znajdziesz w sekcji Wykrywanie duplikatów.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Component <ComponentName> is duplicated with components by parameter <ParameterName> (<ParameterValue>):
- Server components: <WorkspaceComponentList>
gdzie:
-
ComponentNameto nazwa komponentu, którego dotyczy naruszenie. -
ParameterNameto nazwa parametru oznaczonego jako unikatowy. -
ParameterValueto wartość parametru oznaczonego jako unikatowy. -
WorkspaceComponentListto lista identyfikatorów elementów i ich rewizji (Item-Revision ID) komponentów w docelowym obszarze roboczym, które mają zduplikowane wartości parametrów oznaczonych jako unikatowe.
Zalecany sposób rozwiązania
Sprawdź parametry komponentu w bibliotece źródłowej przeznaczonej do zaimportowania i upewnij się, że na liście rozwijanej Unique Field na karcie Advanced panelu Properties jako unikatowy wybrano właściwy parametr.
Jeśli komponent przeznaczony do zaimportowania jest taki sam jak komponent znajdujący się już w docelowym obszarze roboczym, można wykluczyć go z migracji — dowiedz się więcej.
Komponent jest zduplikowany na podstawie doboru części
Default report mode:
Podsumowanie
To naruszenie występuje, gdy docelowy obszar roboczy zawiera komponent z taką samą dobraną częścią jak komponent w bibliotekach źródłowych przeznaczonych do zaimportowania. Więcej informacji znajdziesz w sekcji Wykrywanie duplikatów.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Component <ComponentName> is duplicated with components by Part Choices:
- Server components: <WorkspaceComponentList> (<Manufacturer> <PartNumber>)
gdzie:
-
ComponentNameto nazwa komponentu, którego dotyczy naruszenie. -
WorkspaceComponentListto lista identyfikatorów elementów i ich rewizji (Item-Revision ID) komponentów w docelowym obszarze roboczym, które mają taką samą dobraną część jak komponent w bibliotece źródłowej przeznaczonej do zaimportowania. -
Manufacturerto parametr producenta zduplikowanej dobranej części. -
PartNumberto parametr numeru katalogowego zduplikowanej dobranej części.
Zalecany sposób rozwiązania
Sprawdź parametry komponentu w bibliotece źródłowej przeznaczonej do zaimportowania i upewnij się, że mapowania parametrów doboru części (wymienione w sekcji Part Choices Mapping na karcie General panelu Properties) są prawidłowe.
Jeśli komponent przeznaczony do zaimportowania jest taki sam jak komponent znajdujący się już w docelowym obszarze roboczym, można wykluczyć go z migracji — dowiedz się więcej.
Szablon komponentu jest zduplikowany
Ta kontrola nie jest obecnie wykonywana przez funkcję walidacji importera bibliotek.
Typ komponentu jest niezdefiniowany
Default report mode:
Podsumowanie
To naruszenie występuje, gdy istnieje komponent bez kategorii, czyli komponent bez przypisanego typu.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
<ComponentName> component type is undefined.
gdzie:
-
ComponentNameto nazwa komponentu, którego dotyczy naruszenie.
Zalecany sposób rozwiązania
Przypisz typ komponentowi bez kategorii. Więcej informacji znajdziesz w sekcji Komponenty bez kategorii.
Nie znaleziono karty katalogowej
Default report mode:
Podsumowanie
To naruszenie występuje, gdy nie można znaleźć karty katalogowej pod łączem zdefiniowanym w komponencie w bibliotece źródłowej.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Datasheet <Path> is not found.
gdzie:
-
Pathto ścieżka do karty katalogowej zdefiniowana w komponencie w bibliotece źródłowej.
Zalecany sposób rozwiązania
Odszukaj brakujący plik karty katalogowej i przywróć go do oczekiwanej lokalizacji. Możesz też wyłączyć import plików kart katalogowych, zmieniając opcję Migrate w sekcji Datasheet panelu Properties (na karcie Advanced).
Import mapowania wyprowadzeń nie jest obsługiwany
Default report mode:
Podsumowanie
To naruszenie występuje, gdy komponent w bibliotece źródłowej ma niestandardowe mapowanie wyprowadzeń.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Import for <ComponentName> component pin mapping is not supported.
gdzie:
-
ComponentNameto nazwa komponentu, którego dotyczy naruszenie.
Zalecany sposób rozwiązania
Po zaimportowaniu możesz sprawdzić mapowanie wyprowadzeń i skonfigurować je zgodnie z potrzebami podczas edycji komponentu w edytorze komponentów w trybie edycji pojedynczego komponentu — dowiedz się więcej.
Nieprawidłowa wartość parametru
Default report mode:
Podsumowanie
To naruszenie występuje, gdy wartości parametru komponentu nie można zinterpretować jako prawidłowej wartości określonego typu jednostki.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
<ParameterName> parameter value <ParameterValue> in component <ComponentName> cannot be converted to unit of type <UnitType>.
gdzie:
-
ParameterNameto nazwa parametru komponentu, którego dotyczy naruszenie. -
ParameterValueto wartość parametru komponentu, którego dotyczy naruszenie. -
ComponentNameto nazwa komponentu zawierającego parametr, którego dotyczy naruszenie. -
UnitTypeto jednostki miary aktualnie ustawione dla parametru, którego dotyczy naruszenie.
Zalecany sposób rozwiązania
Zmień nieprawidłową wartość parametru w obszarze tabeli narzędzia Library Importer na wartość w zgodnym formacie. Możesz też zmienić jednostkę mapowanego parametru Type, określoną przez zastosowany szablon komponentu, na nieinterpretowaną Text w obszarze Parameter Mapping panelu Properties (na karcie General), gdy wybrana jest biblioteka źródłowa.
Nieprawidłowe mapowanie wariantu części
Default report mode:
Podsumowanie
To naruszenie występuje, gdy w konfiguracji mapowania wariantów części znajduje się błąd.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
Part Choice mapping in library <LibraryName>.<LibraryType> has error: <Descripion>
gdzie:
-
LibraryNameto nazwa biblioteki źródłowej, w której znaleziono komponent z nieprawidłowym mapowaniem wariantu części. -
LibraryTypeto nazwa grupy podbibliotek, w której znaleziono komponent z nieprawidłowym mapowaniem wariantu części. -
Descripionto opis naruszenia dotyczącego mapowania wariantu części.
Zalecane rozwiązanie
W obszarze Part Choices Mapping panelu Properties znajdź parametry oznaczone ikoną
i odpowiednio zaktualizuj mapowanie. Możesz też usunąć wpisy mapowania zawierające błędy.
Nazwa parametru jest taka sama jak nazwa parametru systemowego
Default report mode:
Podsumowanie
To naruszenie występuje, gdy komponent w bibliotece źródłowej zawiera parametr o takiej samej nazwie jak parametr systemowy. Są to następujące parametry:
-
AncestorItemRevisionGUID -
Cat -
ComponentType -
ContentType -
ContentTypeGUID -
CreatedAt -
CreatedBy -
CreatedByGUID -
DynamicData -
Folder -
FolderGuid -
Hrid -
Id -
ItemDescription -
ItemGUID -
ItemHRID -
LatestRevision -
LifeCycle -
LifecycleStateGUID -
ModifiedBy -
ReleaseDate -
ReleaseDateNum -
ReleaseNote -
RevisionId -
RevisionNamingSchemeGUID -
SourceGUID -
SourceVaultGUID -
Text -
Updated -
UpdatedByGUID
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
'<ParameterName>' is system parameter
gdzie:
-
ParameterNameto nazwa nieprawidłowego parametru komponentu.
Zalecane rozwiązanie
Usuń wpis mapowania nieprawidłowego parametru z obszaru Parameter Mapping panelu Properties (na karcie General). Możesz też usunąć nieprawidłowy parametr z komponentu w bibliotece źródłowej lub zmienić jego nazwę.
Parametry symulacji są pomijane
Default report mode:
Podsumowanie
To naruszenie występuje, gdy komponent w bibliotece źródłowej ma powiązany model symulacyjny.
Powiadomienie
W panelu Messages wyświetlane jest powiadomienie w następującym formacie:
<ComponentName> component simulation parameters are skipped (<SimulationParameterList>).
gdzie:
-
ComponentNameto nazwa komponentu w bibliotece źródłowej, którego dotyczy problem. -
SimulationParameterListto rozdzielona przecinkami lista parametrów symulacji, które zostaną pominięte podczas importu.
Zalecane rozwiązanie
Po imporcie możesz odpowiednio skonfigurować powiązanie z modelem symulacyjnym podczas edycji komponentu w edytorze komponentów w trybie edycji pojedynczego komponentu — dowiedz się więcej.
Rozwiązywanie błędów i ostrzeżeń
Błędy parametrów, takie jak w pokazanym tutaj przykładzie, w którym wartości Forward Voltage komponentu nie można zinterpretować jako prawidłowego napięcia, można rozwiązać na następujące sposoby:
-
Edytując nieprawidłową wartość parametru — znajdź odpowiednią komórkę i zmień jej zawartość na wartość w zgodnym formacie.
-
Zmieniając jednostkę mapowanego parametru Type, określoną przez zastosowany szablon komponentu, z
Voltagena nieinterpretowanąText— wybierz bibliotekę źródłową w interfejsie importera, a następnie zmieńForward VoltageType na liście w panelu Properties Parameter Mapping (na karcie General). -
Usuwając komponent z procesu importu — kliknij jego wpis prawym przyciskiem myszy i wybierz opcję Exclude from Importer.
Błąd brakującego pliku, taki jak pokazany tutaj błąd nieodnalezionego pliku karty katalogowej, można rozwiązać na następujące sposoby:
- Odnajdując brakujący plik i przywracając go w oczekiwanej lokalizacji — jest to najbardziej oczywiste rozwiązanie.
- Wyłączając import plików kart katalogowych — zmień opcję Migrate w sekcji panelu Properties Datasheet (na karcie Advanced).
- Wykluczając komponent z procesu importu biblioteki — jak opisano powyżej.
Użyj pola Search (w prawym górnym rogu), aby znaleźć konkretne wpisy komponentów. Wyszukiwanie filtruje listę pozycji według pasujących wartości parametrów dla aktualnie wybranego typu komponentu — wybierz All w sekcji Types (Folder Structure), aby wyszukiwanie obejmowało wszystkie komponenty w dostępnych bibliotekach źródłowych.
Import biblioteki schematów
Jeśli podczas próby importu biblioteki schematów wystąpi błąd „nie znaleziono modelu” (taki jak Footprint <footprint name> not found in available libraries), oznacza to, że narzędzie Library Importer nie może odnaleźć modeli powiązanych z komponentami w pliku SCHLIB.
W trybie prostym takie błędy są wyświetlane w opartym na HTML raporcie Importing Report, dostępnym za pomocą przycisku
, który pojawia się po uruchomieniu importu. W trybie zaawansowanym błędy są sygnalizowane ikonami stanu w głównym interfejsie oraz wpisami w panelu Messages — następuje to podczas sprawdzania poprawności lub próby importu biblioteki
Brakujące footprinty są prawidłowo wykrywane podczas sprawdzania poprawności, które udostępnia również opcję Choose a Library w raporcie błędów (w menu rozwijanym Details). Jeśli wykryto brak footprintów dla więcej niż jednego komponentu, okno dialogowe Apply PcbLib Selection umożliwia użycie wskazanej biblioteki PcbLib dla tego przypadku lub dla wszystkich komponentów z brakującymi footprintami.
Innym sposobem rozwiązania tego problemu (lub jego uniknięcia) jest zapewnienie dostępności wymaganych plików bibliotek modeli w Altium Designer. Biblioteki instaluje się na stronie Data Management – File-based Libraries w oknie dialogowym Preferences.
Jeśli nie chcesz instalować wielu bibliotek modeli, możesz zamiast tego umieścić je w domyślnej ścieżce bibliotek oprogramowania (lub zmienić tę ścieżkę) i sprawdzić, czy dla komponentów biblioteki schematów określono bibliotekę źródłową modeli:
- Umieść bibliotekę modeli w lokalizacji należącej do domyślnej ścieżki wyszukiwania oprogramowania. Dodaj bibliotekę modeli, na przykład odpowiednią bibliotekę PCB, do lokalizacji określonej przez domyślną ścieżkę bibliotek systemu. Aby sprawdzić tę lokalizację, zobacz wpis Library Path na stronie System – Default Locations w oknie dialogowym Preferences. Jeśli plik biblioteki został dodany lub skopiowany do tej lokalizacji, może być konieczne ponowne uruchomienie Altium Designer, aby zmiana została uwzględniona.
-
Określ nazwę docelowej biblioteki modeli dla komponentów biblioteki schematów. Aby narzędzie Library Importer mogło rozpoznać bibliotekę modeli powiązaną z komponentem biblioteki schematów, podaj jej nazwę w bibliotecznym oknie dialogowym PCB Model.
Wykrywanie duplikatów
Importer bibliotek zawiera również mechanizmy zapobiegające tworzeniu zduplikowanych komponentów w docelowej przestrzeni roboczej. Podczas walidacji parametry identyfikacyjne komponentów oraz wybrane części (Part Choices) z biblioteki źródłowej są porównywane z parametrami i wybranymi częściami komponentów w docelowej przestrzeni roboczej oraz w bibliotekach źródłowych przeznaczonych do importu. Przy domyślnych ustawieniach importera etap walidacji zgłasza komunikat Warning po wykryciu takiego samego wpisu Name lub Part Choices komponentu (wskazującego na potencjalny duplikat). Wyświetlany komunikat ostrzeżenia lub błędu zawiera typ naruszenia reguły unikatowości (parametr lub wybrana część), nazwę komponentu bibliotecznego naruszającego tę regułę oraz identyfikator komponentu, z którym występuje konflikt.

Dwa potencjalne duplikaty wykryte podczas walidacji: Name komponentu (górny obraz) lub jego Part Choice (dolny obraz) występują już w komponentach przestrzeni roboczej.
Parę nazwa–wartość parametru używaną do wykrywania duplikatów określa się w obszarze Duplicates Detection panelu Properties, na karcie Advanced. Za pomocą menu rozwijanego Unique Field (domyślnie ustawionego na Name) wybierz jeden z parametrów dostępnych w bibliotece źródłowej. Ten wybór jest szczególnie przydatny w konfiguracjach bibliotek firmowych korzystających z własnego pola identyfikacyjnego powiązanego z szerszym systemem przedsiębiorstwa.

Naruszenie reguły unikatowości wykryte w sytuacji, gdy wartość określonego parametru (ERP-REF) jest taka sama dla komponentu biblioteki lokalnej i komponentu w przestrzeni roboczej.
Można ustawić inny typ oznaczenia stanu dla naruszeń reguły unikatowości, wybierając alternatywną opcję Report Mode w obszarze Import Checks na karcie General panelu Properties.
Wykrywanie duplikatów obejmuje również modele symboli komponentów. Jeśli komponenty przeznaczone do importu mają w bibliotekach źródłowych modele symboli o takiej samej geometrii, zaimportowany zostanie tylko jeden z tych modeli.
Biblioteki z jednym modelem
Automatyczne wykrywanie duplikatów jest również wykorzystywane do przetwarzania bibliotek źródłowych, które używają wspólnego modelu symbolu dla wszystkich komponentów. Takie biblioteki zazwyczaj zawierają komponenty jednego typu, różniące się wykonaniem i wartościami, na przykład rezystory w określonym typie obudowy, dla których symbol jest standardową reprezentacją graficzną.
Importer bibliotek wykrywa użycie jednego wspólnego modelu i konfiguruje import tak, aby przenieść jeden model symbolu stosowany do wszystkich importowanych komponentów — zamiast odpowiadającego każdemu komponentowi symbolu o indywidualnej nazwie. Importowany symbol przyjmuje nazwę jednego z symboli przeznaczonych do importu, a wszystkie parametry komponentów pozostają bez zmian.
Zaimportowany symbol biblioteczny (który ma nazwę ogólną i puste pole Description) można edytować zgodnie z potrzebami. W panelu Components użyj opcji Edit z menu kontekstowego, aby uruchomić tę operację. W trakcie tego procesu wybierz opcję Update items related to <symbol ID> w oknie dialogowym Create Revisions for Item, aby zaimportowane komponenty korzystały z nowej rewizji symbolu.
Importowanie tylko modeli
Importer bibliotek można przełączyć w specjalny tryb importu Models Only, który wykrywa i przetwarza modele komponentów dostępne w bibliotece źródłowej.
W trybie Models Only proces analizy importera wykrywa wszystkie modele symboli, footprintów i modele symulacyjne dostępne w bibliotece źródłowej (IntLib, SchLib, PcbLib itd.), a następnie importuje je do przestrzeni roboczej przy użyciu domyślnych lokalizacji, schematów nazewnictwa i definicji cyklu życia systemu.
Po przełączeniu importera bibliotek w tryb zaawansowany lub otwarciu go w tym trybie (File » Library Importer) dostępne są pełne szczegóły proponowanego importu modeli. Obszar Import Preview pokazuje Folder Structure, które będą używane w docelowej przestrzeni roboczej. Ustawienia domyślne można zmienić w polu Folder dla każdego typu modelu w panelu Properties. Stosowane schematy nazewnictwa i definicję cyklu życia dla każdego modelu można wybrać spośród typów dostępnych w systemie (patrz panel Properties poniżej).
W razie potrzeby import modeli komponentów do przestrzeni roboczej można ograniczyć według typu, wyłączając (lub włączając) określone typy modeli w panelu Properties za pomocą odpowiadających im przycisków
.
Po skonfigurowaniu importera bibliotek wybierz przycisk
, aby zakończyć import wymienionych modeli komponentów. Wyniki można sprawdzić w pliku dziennika importu, dostępnym z poziomu okna postępu Library Importer , lub przeglądając zaimportowane modele w panelu Components.
Importowanie tylko komponentów
Podobnie jak w opisanym powyżej trybie importu Models Only, importer bibliotek można przełączyć w specjalny tryb importu Components Only, który umożliwia importowanie komponentów dostępnych w bibliotece źródłowej bez powiązanych z nimi modeli.
W trybie Components Only proces analizy importera wykrywa wszystkie komponenty, parametry i wybrane części (Part Choices) w bibliotece źródłowej, a następnie importuje te komponenty do przestrzeni roboczej przy użyciu domyślnej lokalizacji, schematu nazewnictwa i definicji cyklu życia systemu.
Po przełączeniu narzędzia Library Importer w tryb zaawansowany lub otwarciu go w tym trybie (File » Library Importer) dostępne są pełne szczegóły proponowanego importu komponentów. Folder docelowy, schematy nazewnictwa i definicję cyklu życia można wybrać spośród dostępnych typów systemowych (patrz panel Properties poniżej).
Po skonfigurowaniu narzędzia Library Importer wybierz przycisk
, aby zakończyć import wymienionych komponentów. W przestrzeni roboczej zostaną utworzone wyłącznie elementy komponentów, bez powiązanych modeli. Wyniki można sprawdzić w pliku dziennika importu, dostępnym w oknie postępu Library Importer , lub przeglądając zaimportowane komponenty w panelu Components.
Panel Properties
Ustawienia powiązanego z narzędziem Library Importer panelu Properties zapewniają zaawansowaną kontrolę nad konfiguracją importu wybranej biblioteki (lub grupy podbibliotek). Panel można otworzyć w trybie zaawansowanym narzędzia Library Importer, wybierając opcję Properties z menu przycisku
(w prawym dolnym rogu obszaru projektowego), klikając przycisk
w prawym górnym rogu widoku Library Importer lub klikając przycisk
obok pozycji <All Libraries> albo określonej kategorii na liście Source Libraries.
Ustawienia opcji panelu są określane przez domyślne ustawienia systemowe lub ustawienia z zastosowanego szablonu komponentu, który z kolei jest dobierany na podstawie wykrytego typu komponentów biblioteki — w pokazanym przykładzie jest to LED. Użytkownik może również edytować te ustawienia, aby dostosować proces importu do swoich potrzeb, a następnie przywrócić je za pomocą łącza Reset to Default (w prawym górnym rogu).
Karta General panelu zawiera następujące sekcje:
-
General:
-
Component Type — typ komponentu wykryty przez importer dla wybranej biblioteki oraz, w powiązaniu z nim, stosowany szablon (patrz Component Template poniżej). Aby zastąpić to ustawienie, edytuj pole, co spowoduje utworzenie nowego typu komponentu, lub wybierz inny typ z menu rozwijanego (albo za pomocą przycisku — jest to kolejny sposób rozwiązania problemu komponentu bez kategorii. Wybierz opcję
[LibraryName], aby jako typ ustawić nazwę wybranej biblioteki. -
Component Template — szablon komponentu z przestrzeni roboczej, który zostanie zastosowany do importowanych komponentów, a w powiązaniu z nim — ustawienie ich typu komponentu. Aby zastąpić to ustawienie, wybierz inny szablon z menu rozwijanego (lub za pomocą przycisku Ustaw tę opcję na
[Create new], aby automatycznie utworzyć szablon na podstawie parametrów biblioteki źródłowej i bieżących ustawień narzędzia Library Importer, lub wybierz [No Template], aby nie stosować ani nie tworzyć szablonu.
-
Component Type — typ komponentu wykryty przez importer dla wybranej biblioteki oraz, w powiązaniu z nim, stosowany szablon (patrz Component Template poniżej). Aby zastąpić to ustawienie, edytuj pole, co spowoduje utworzenie nowego typu komponentu, lub wybierz inny typ z menu rozwijanego (albo za pomocą przycisku — jest to kolejny sposób rozwiązania problemu komponentu bez kategorii. Wybierz opcję
-
Parameter Mapping — mapowanie parametrów biblioteki na parametry zastosowanego szablonu komponentu (lub ustawienia domyślne, gdy szablon nie jest dostępny), a także typ wartości każdego parametru (tekst lub typ uwzględniający jednostki). Użyj opcji menu rozwijanego w kolumnie Source Library Parameter, aby zmienić mapowanie, oraz opcji menu w kolumnie Type, aby zastąpić istniejące ustawienie określone przez szablon lub ustawienia domyślne. Wybierz opcję
<Skip>, aby pominąć parametr. Każdy parametr, który nie został automatycznie dopasowany do parametru biblioteki źródłowej (system ustawił go na<Skip>), można ręcznie przypisać do odpowiedniego parametru szablonu — na przykład parametr źródłowyROHSmożna dopasować do parametruRoHS Compliantzdefiniowanego w szablonie przestrzeni roboczej. Nazwy parametrów można edytować, a zestawy parametrów można dodawać, edytować i usuwać. Podstawowe parametry komponentu (ID,Name,Description) można przypisać ponownie, ale poza tym są one tylko do odczytu. -
Part Choice Mapping — lista parametrów części producenta lub łączy do dostawców rozpoznanych przez importer, które posłużą do utworzenia wpisów Part Choices dla importowanych komponentów. Użyj opcji menu rozwijanego, aby zmienić mapowanie albo dodać lub usunąć zestawy mapowań. Pamiętaj, że domyślnie parametry części producenta i łączy do dostawców nie są uwzględniane w procesie importu (są pomijane). Jeśli komponent biblioteczny zawiera wiele łączy do dostawców, do utworzenia wpisów w polu Part Choices używane jest główne odniesienie do dostawcy (
Supplier 1/Supplier Part Number 1). -
Import Checks — przeglądanie lub ustawianie reakcji importera w postaci błędu/ostrzeżenia na naruszenia reguł walidacji importu. Użyj menu rozwijanego Report Mode, aby zmienić reakcję i ikonę dla wpisu Violation Type. Pamiętaj, że wybranie trybu raportowania
Fatal Errorspowoduje zablokowanie procesu importu po wykryciu tego naruszenia.
Karta Advanced panelu udostępnia ustawienia wszystkich obiektów danych importera, określone przez domyślne ustawienia systemowe lub zastosowany szablon komponentu. Obejmują one modele komponentów, pliki dokumentacji technicznej oraz wszelkie tworzone szablony komponentów. Z wyjątkiem opcji Datasheet (przełącznika włączania/wyłączania) ustawienia każdego importowanego obiektu obejmują:
- Folder — folder docelowy w przestrzeni roboczej dla importowanego obiektu, który można edytować ręcznie (na przykład w celu utworzenia nowego folderu docelowego) lub wybrać za pomocą przycisku przeglądania
- Naming Scheme — specyfikacja nazewnictwa obiektu w przestrzeni roboczej, określona przez szablon komponentu lub, w przypadku braku aktywnego szablonu, schemat ustawiony dla folderu docelowego (albo wprowadzony ręcznie). Użyj menu rozwijanego, aby wybrać jeden z dostępnych schematów nazewnictwa. Pamiętaj, że zmianie ścieżki folderu docelowego (Folder) może towarzyszyć zmiana zastosowanego schematu nazewnictwa, określonego przez sam folder lub zastosowany/powiązany szablon komponentu.
- Revision Naming Scheme — schemat nazewnictwa rewizji obiektu w przestrzeni roboczej, określony przez zastosowany szablon lub wybrany z menu rozwijanego danej pozycji. Dostępne będą wyłącznie schematy włączone w systemie.
- Lifecycle Definition – system cyklu życia używany dla obiektu, określony przez zastosowany szablon lub wybrany z menu rozwijanego danego wpisu. Dostępne do wyboru będą tylko definicje włączone w systemie.
Eksport i import konfiguracji
Narzędzie Library Importer umożliwia wyeksportowanie szczegółowego pliku tekstowego zawierającego bieżącą konfigurację, w tym wszystkie konfigurowalne ustawienia importu, takie jak ścieżki docelowe, mapowanie parametrów, schemat nazewnictwa, definicje cyklu życia, docelowe typy komponentów itd.
Plik konfiguracji narzędzia Library Importer jest zapisywany za pomocą polecenia File » Export » Importer Config jako plik typu *.lmcfg i można go w dowolnym momencie wczytać za pomocą opcji menu File » Import » Importer Config .
Możliwość przywrócenia konfiguracji jest szczególnie przydatna, gdy źródłowa baza danych lub biblioteka plikowa została zaktualizowana i zmiany te trzeba zaimportować do przestrzeni roboczej. Jeśli konfigurację wyeksportowano podczas pierwszego importu biblioteki, przywrócona (zaimportowana) konfiguracja odtworzy dokładnie te same ustawienia, które były wówczas używane, co gwarantuje spójny schemat przesyłania danych dla tej biblioteki (lub bibliotek).

























