Pesquisar e Colocar Componentes

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

O coração de qualquer projeto eletrônico são os componentes. O componente que você finalmente solda na placa precisa ser representado, ou modelado, em cada domínio de projeto como um símbolo no esquemático, como um modelo SPICE no simulador, como um footprint na placa e como um modelo 3D STEP no arquivo que você entrega ao projetista mecânico.

Saiba mais sobre Building & Maintaining Your Components and Libraries.

O painel Components do Altium Designer oferece uma interface poderosa que você pode usar para interagir com todos os seus componentes — tanto do Workspace quanto fora do Workspace. Você pode procurar o componente necessário especificando a categoria e usando o modo de pesquisa simples ao inserir uma consulta (nome completo ou parcial do componente, valor etc.) no campo de pesquisa. Além disso, o painel fornece um recurso de pesquisa paramétrica (facetada) baseada em filtros para especificar parâmetros de componentes de destino para os componentes do seu Workspace. O painel também oferece opções para editar um componente do Workspace por meio do Component Editor in its Single Component Editing mode, visualizar o componente em seu Workspace de origem e executar funções de gerenciamento de componentes, como criação e clonagem de componentes ou edição de Part Choices e do Type do componente selecionado. Um componente pode ser colocado no esquemático arrastando-o ou usando o comando Place  no menu de clique com o botão direito do componente.

E, embora você possa, é claro, criar seus próprios componentes, o Altium Designer fornece um poderoso Manufacturer Part Search panel que pode ser usado para pesquisar peças reais fabricadas. Se você tiver um Workspace, poderá salvar essas peças nesse Workspace e então acessá-las por meio do painel Components. Esse processo envolve criar um novo componente no Workspace — usando o Component Editor em seu modo Single Component Editing — e salvá-lo no seu Workspace.

O painel Components fornece acesso direto aos Workspace components disponíveis e aos componentes de biblioteca database e file-based no Altium Designer.

O painel obtém componentes de um connected Workspace e de quaisquer bibliotecas abertas ou instaladas. O painel oferece detalhes completos do componente selecionado (Parameters, Models, Part Choices, dados de fornecedor etc.), comparação de componentes e, para componentes do Workspace, um recurso de pesquisa paramétrica baseada em filtros para especificar parâmetros de componentes de destino.

O painel Components em seu modo normal

O painel Components em seu modo compacto

 

O painel Components usa a funcionalidade e a visualização básicas do mecanismo de pesquisa aplicadas no Manufacturer Part Search panel. Enquanto o painel Manufacturer Part Search aproveita o serviço Altium Parts Provider e se concentra em pesquisas de dados de fabricantes e fornecedores de componentes, o painel Components é preenchido com componentes prontos para posicionamento provenientes do seu connected Workspace e de fontes de biblioteca baseadas em banco de dados e em arquivos.

Para componentes do Workspace, apenas a revisão mais recente de cada componente é apresentada no painel.
Embora grande parte da funcionalidade para trabalhar com componentes esteja disponível por meio do painel Components, você também pode usar o Explorer panel — essencialmente, o primeiro fornece um subconjunto da funcionalidade disponível no segundo, com foco no gerenciamento de componentes. Haverá alguns recursos relacionados aos próprios componentes que ainda só podem ser executados por meio do painel Explorer (adicionar datasheets sem editar, alterar estados, exclusão em massa de componentes e modelos etc.), mas isso tende a ser mais para casos atípicos, casos de borda ou como parte de atividades de administração/estruturação do Workspace. Lembre-se de que o componente é apenas um tipo de conteúdo — o painel Explorer realmente se destaca para toda a gama de tipos de conteúdo suportados por um Workspace. Por exemplo, a criação e o gerenciamento de templates de componentes — uma entidade bastante relevante para componentes — só podem ser realizados no painel Explorer (a menos que os templates sejam criados no momento da importação da biblioteca usando o Library Importer).

Acesso ao painel Components

Para abrir o painel Components, selecione View » Panels » Components nos menus principais ou a opção Components no menu do botão no canto inferior direito da tela principal. Usando uma configuração de design responsivo, o layout do painel se adaptará dinamicamente entre o modo normal em tela cheia () e o modo compacto (), no qual as opções Categories/Filters são recolhidas em menus.

De dentro de um documento esquemático, use o atalho de teclado P, P para abrir o painel Components. Você também pode usar o comando Place » Part nos menus principais, o comando Place » Part no menu de clique com o botão direito da área de projeto do editor esquemático ou o botão Part () na Active Bar.

De dentro de um documento PCB, use o atalho de teclado P, C para abrir o painel Components. Você também pode usar o comando Place » Component nos menus principais, o comando Place » Component no menu de clique com o botão direito da área de projeto do editor PCB ou o comando Component () na Active Bar.

No primeiro lançamento do painel Components na sessão atual do Altium Designer, os seguintes controles estarão disponíveis quando conectado a um Workspace:

  • Use Existing Components – clique para navegar pelo tipo de componente atualmente selecionado na lista suspensa superior do painel.

  • Delete Existing Components – clique para abrir a caixa de diálogo Delete Existing Components, seguida pela página Data Cleanup do seu Settings do Workspace, onde você pode selecionar os tipos de conteúdo a serem removidos.

  • Import Library – clique para abrir a caixa de diálogo padrão do Windows Open e então selecionar uma biblioteca baseada em banco de dados ou em arquivo salva em sua pasta local ou de rede. Após abrir um arquivo de biblioteca, o Library Importer in its Simple mode será iniciado com a biblioteca selecionada carregada.

  • Create Component – clique para abrir a caixa de diálogo Create New Component dialog, seguida pelo Component Editor em Single Component Editing mode pronto para definir um novo componente.

O painel Categories (ou o menu suspenso no modo compacto) lista todos os componentes disponíveis do Workspace sob a entrada de categoria All e quaisquer bibliotecas disponíveis. Quando o painel está em seu modo normal, clique no ícone de lista Categories ou no ícone « para recolher ou expandir a exibição da coluna e use o botão (canto superior direito) para alternar a visibilidade do painel Details do componente. Ao percorrer o painel Categories, os atalhos de teclado Up/Down e PgUp/PgDn podem ser usados para navegar pela lista. Os atalhos de teclado Left/Right podem ser usados para abrir e fechar os ramos individuais.

O agrupamento Categories para componentes do Workspace é derivado dos parâmetros Component Type associados a cada componente. Por exemplo, se o Component Type de um componente tiver sido especificado como Resistor, então esse componente será listado na categoria Resistor no painel Components (independentemente da pasta do workspace em que ele reside).

Para especificar ou alterar o tipo de um componente on-the-fly, clique com o botão direito em sua entrada e selecione a opção Operations » Change Component Type no menu de contexto para abrir a caixa de diálogo Choose component type dialog.

O parâmetro Type de um componente é estabelecido:

Os Component Types são gerenciados (criados/editados/removidos) na página Data Management – Component Types page da caixa de diálogo Preferences. O botão Templates da caixa de diálogo abre a caixa de diálogo Edit Templates, onde o Component Template associado a cada Component Type pode ser especificado ou alterado.

NOTE: O Category em que um componente é listado é definido por seu parâmetro Component Type e não está relacionado à pasta do Workspace em que ele reside. Portanto, se você mover um componente para uma pasta diferente por meio do Explorer panel, essa alteração não será refletida no painel Components.

Menu de operações

As opções do menu de operações fornecem a você a capacidade de definir preferências de bibliotecas baseadas em arquivo, realizar pesquisas e especificar se a coleção de modelos de componentes está visível. Para acessar essas opções, selecione o botão de menu de operações no canto superior direito do painel.

  • Create Component – selecione para abrir a caixa de diálogo Create new component, seguida pelo Component Editor em Single Component Editing mode, pronto para definir um novo componente.
  • Import Library – selecione para abrir a caixa de diálogo padrão do Windows Open e selecionar uma biblioteca baseada em banco de dados ou em arquivo salva em sua pasta local ou de rede. Após abrir um arquivo de biblioteca, o Library Importer in its Simple mode será iniciado com a biblioteca selecionada carregada.
  • Clean-up Library – selecione para abrir a caixa de diálogo Delete Existing Components, seguida pela página Data Cleanup do seu Settings do Workspace, onde você pode selecionar os tipos de conteúdo a serem removidos.
  • Models – selecione para incluir entradas de coleção de modelos de biblioteca na listagem Categories. As entradas adicionais nesse modo de navegação incluem coleções de modelos de Symbol, Footprint e Simulation provenientes do Workspace conectado, e também bibliotecas de footprints PCB instaladas (*.PcbLib).
  • File-based Libraries Preferences – selecione para abrir a caixa de diálogo Available File-based Libraries, onde você pode visualizar controles para adicionar bibliotecas baseadas em banco de dados e em arquivo ao projeto atual ou remover bibliotecas dele, instalar bibliotecas e especificar caminhos de pesquisa de bibliotecas. Consulte a seção Managing Available Database and File-based Libraries da página Searching for Components in File-based & Database Libraries para saber mais.
  • File-based Library Search – selecione para abrir a caixa de diálogo File-based Libraries Search, onde você pode pesquisar um componente quando não sabe qual biblioteca baseada em banco de dados ou em arquivo o contém, ou mesmo se ele está disponível. Consulte a seção Searching for Components in Database and File-based Libraries da página Searching for Components in File-based & Database Libraries para saber mais.
  • Refresh – clique para atualizar rapidamente o painel. A seleção atual de componente será salva.

Lista de componentes

Na própria grade de listagem de componentes, o conteúdo incluído na lista é gerenciado por:

  • Definir a ordem de classificação da listagem de componentes — clique no cabeçalho de uma coluna para classificar a listagem de componentes pelos dados dessa coluna. Clique no cabeçalho novamente para inverter a ordem de classificação.

  • Definir a ordem das colunas exibidas — arraste e solte o cabeçalho de uma coluna em uma nova posição.

  • Especificar quais colunas de parâmetros são mostradas — clique com o botão direito em um cabeçalho de coluna e escolha Select Columns para abrir a caixa de diálogo Select Columns, por meio da qual você pode controlar a visibilidade de uma coluna de parâmetro e mover sua ordem posicional.

    A caixa de diálogo Select columns
    A caixa de diálogo Select columns

    • A caixa de diálogo lista todas as colunas possíveis que podem ser exibidas no painel Components. Quando um item exibe , essa coluna será exibida no painel Components . Quando um item exibe , essa coluna não not será exibida no painel Components. Clique nos símbolos para alternar a função mostrar/ocultar.

    • Você também pode controlar a exibição de todas as colunas clicando no ícone / na barra de cabeçalho das colunas. Quando algumas colunas estiverem visíveis e outras ocultas, o ícone  será mostrado.

    • Passe o cursor sobre a barra de cabeçalho da segunda coluna e clique no ícone  para abrir uma lista suspensa na qual você pode escolher a coluna a ser exibida.

    • Use os botões  /  para mover o item selecionado para cima ou para baixo na lista. Apenas itens definidos como visíveis () podem ser movidos. Isso determina a ordem em que as colunas aparecerão no painel Components.

  • Agrupar a lista por dados de coluna — clique com o botão direito em um cabeçalho de coluna, selecione a opção Enable Columns Grouping e então arraste um cabeçalho de coluna (por exemplo, Footprint) para o espaço de agrupamento na parte superior da lista. As entradas da lista serão reunidas sob cada parâmetro exclusivo (por exemplo, tipo de footprint) da coluna de agrupamento especificada.

    Ao usar Grouping para agrupar componentes na listagem, há um limite de 10.000 entradas que podem ser acomodadas.

  • Filtrar a listagem por uma entrada específica de coluna — selecione em um cabeçalho de coluna para exibir uma lista de suas entradas de parâmetros exclusivas e então selecione uma entrada para restringir os componentes listados àqueles que incluem o parâmetro especificado (por exemplo, um código de tipo de footprint). Selecione a opção All para redefinir o filtro. Selecione (Custom) para abrir a caixa de diálogo Filter Editor a fim de refinar ainda mais a filtragem na coluna selecionada.

Exibindo colunas

Há várias maneiras de exibir o conteúdo dentro do painel Components. Ao clicar com o botão direito nos nomes de cada coluna (Name, Description, Footprint), você pode selecionar entre as seguintes opções, dependendo de como deseja exibir os componentes:

  • Best Fit – mescla o conteúdo das colunas Name e Descriptions para que fiquem posicionadas próximas, sem espaço excessivo entre cada coluna.

  • Best Fit All Columns – mescla o conteúdo de todas as colunas para que fiquem posicionadas próximas, sem espaço excessivo entre cada coluna.

  • Clear Sorting – usado para desfazer a classificação das colunas.

  • Enable Columns Grouping – permite arrastar cabeçalhos de coluna por uma coluna específica, permitindo alterar a ordem das colunas Name, Description e Footprint.

  • Select Columns – abre a caixa de diálogo Select Columns, que permite selecionar outras colunas que você gostaria que estivessem visíveis nesta seção.

  • Apply Column Visibility to Child Categories – nos casos em que a categoria selecionada tenha uma categoria filha, use este comando para garantir a possibilidade de propagar as configurações de visibilidade de colunas das categorias pai para as categorias filhas. Este comando está disponível somente quando existe uma categoria filha.

Pesquisa e funções de componentes

Pesquisando componentes

Para pesquisar componentes disponíveis no painel Components, digite uma expressão no campo Search e/ou use as seleções Categories e Filters do painel para restringir a listagem de componentes às suas necessidades específicas. Os filtros são suportados apenas para Workspace components e, assim como no Manufacturer Part Search panel, o painel Components oferece suporte a filtros de pesquisa sensíveis a unidades (texto para número). A funcionalidade de pesquisa prioriza os resultados de acordo com os critérios de pesquisa inseridos.

A função Search permite selecionar e então editar ou adicionar a uma string Search ativa.

Clique na string de pesquisa “ativa” para inseri-la no campo Search. Você pode reutilizar ou editar essa pesquisa no campo Search.

O campo Search também oferece suporte a pesquisa com curingas, indicados por um asterisco (*) na string.

A caixa de diálogo Find Similar Components, acessada ao clicar com o botão direito em um componente listado e selecionar Find Similar Components, oferece a possibilidade de definir preferências de pesquisa com base no componente selecionado.

Os resultados finais da pesquisa dependerão do tipo de componente selecionado, seja ele do Workspace ou fora do Workspace, e do status da sua conexão com o Workspace. Por exemplo, componentes do Workspace frequentemente exibirão mais parâmetros do que um componente fora do Workspace. Para reunir especificamente componentes e parâmetros que sejam iguais ou diferentes do selecionado, os menus suspensos podem ser usados para selecionar as opções Same, Any ou Different.

Posicionando componentes

Um componente selecionado é colocado em um esquemático arrastando e soltando, selecionando Place em seu menu de contexto acessado com o botão direito, usando o botão no painel Details, clicando duas vezes na entrada do componente desejado ou usando a tecla de atalho Enter.

Para colocar um componente a partir do painel, você pode:

  • Clicar no botão Place no painel Component Details — o cursor se move automaticamente para dentro dos limites da folha esquemática e o componente aparece flutuando no cursor; posicione-o e clique para colocá-lo. Após colocar um componente, outra instância do mesmo componente aparecerá no cursor; clique com o botão direito para sair do modo de posicionamento.

    Components panel, placing from component details pane

  • Clique com o botão direito no componente e selecione Place no menu de contexto. O componente aparece flutuando no cursor; posicione-o e clique para colocá-lo. Observe que, se o painel estiver flutuando sobre a área de projeto, ele ficará translúcido para permitir que você veja o esquemático e posicione o componente. Após colocar um componente, outra instância do mesmo componente aparecerá no cursor; clique com o botão direito para sair do modo de posicionamento.

  • Click, Hold&Drag – clique e arraste o componente da região de grade do painel para uma folha esquemática. Este modo exige que o cursor permaneça pressionado; o componente é inserido quando o cursor é solto. Após inserir o componente, você pode selecionar outro componente ou outro comando.

    Arrastar e soltar insere uma única instância do componente. Se você precisar inserir várias instâncias, use o comando/botão Place, ou clique duas vezes na entrada do componente.

Inserir um componente é realmente muito simples. Mas, antes de fazer qualquer coisa, primeiro certifique-se de que a folha esquemática (ou documento PCB) que receberá o componente esteja aberta no Altium Designer e seja o documento ativo. Se houver documentos abertos em várias janelas, certifique-se também de que a janela que contém esse documento esquemático ativo esteja em foco.

Ao trabalhar com o Altium Designer em várias janelas, se o painel Components ou o painel Explorer estiver acoplado, em qualquer modo, a uma janela que não contenha o esquemático de destino, o comando Place permanecerá esmaecido. Isso ocorre porque clicar dentro de um painel acoplado coloca em foco a janela à qual esse painel está anexado. Com o painel flutuante, no entanto, a janela necessária do Altium pode ficar em foco (aquela com o esquemático de destino ativo), e essa janela manterá o foco ao trabalhar dentro do painel.

Inserindo um Componente de Múltiplas Partes

Se o componente que está sendo inserido tiver várias partes, a parte selecionada sob a imagem de visualização do símbolo na região Models do painel será inserida inicialmente.

Depois que uma parte de um componente de múltiplas partes for inserida, ela poderá ser alterada para outra parte desse componente usando a lista suspensa Part no painel Properties quando a parte estiver selecionada, ou poderá ser alternada para a próxima parte disponível usando o comando Edit » Increment Part Number nos menus principais ou o comando Part Actions » Increment Part Number no menu de clique com o botão direito da parte.

O Altium Designer oferece suporte à apresentação de um componente de múltiplas partes como um único símbolo (todas as subpartes) ou vários símbolos (um para cada subparte individual), usando apenas um único componente por meio dos modos de exibição Normal e Alternativo definidos (Show example).

  • Se um componente de múltiplas partes tiver subpartes vazias em seu modo de exibição (normal ou alternativo), essas subpartes serão omitidas durante a inserção (Show example).

  • Se um componente de múltiplas partes tiver primitivas definidas em apenas uma subparte, o sufixo do designador ficará oculto quando essa subparte for inserida em uma folha esquemática (Show example).

  • Quando uma subparte não tiver primitivas para o modo de exibição atualmente selecionado ou um modo de exibição não tiver primitivas para a subparte atualmente selecionada, a entrada correspondente na lista suspensa Part de Mode no painel Properties do componente ficará esmaecida (). Quando essa entrada for selecionada na lista suspensa, ícones de aviso serão exibidos ().

  • Uma violação Unused sub-part in component não ocorrerá ao executar uma validação do projeto se um componente tiver subpartes sem primitivas e essas subpartes não forem inseridas no esquemático.

Filtragem entre Componentes

Ao visualizar componentes do Workspace, o painel Filters é preenchido por opções de filtro selecionadas com base na pesquisa atual e nos parâmetros disponíveis. A filtragem paramétrica dos componentes listados oferece opções adicionais para localizar um componente específico ou um tipo de componente. Abra o painel Filters pelo botão acima do painel Categories. No modo compacto do painel, clique no botão para destacar o Filters como uma extensão do painel.

Observe que os filtros são compatíveis apenas com componentes do Workspace. Use o campo Filter Search dentro do painel para localizar um filtro de parâmetro específico.

Javascript ID: Pnl_Components_Filter
  • A capacidade de pesquisa paramétrica do Filters do painel depende de dados adequados de parâmetros de componentes sendo enviados do Workspace que hospeda os componentes do Workspace. Como resultado, a funcionalidade Filter pode estar desabilitada quando o software estiver conectado a um produto de servidor Altium mais antigo. Para habilitar o Filter para versões anteriores do servidor, habilite a opção ComponentSearch.LegacyAFS.Filters na caixa de diálogo Advanced Settings dialog.

  • Observe que, para que um parâmetro apareça no painel Filters, pelo menos dois valores diferentes para esse parâmetro devem ser usados por componentes na categoria selecionada. Observe também que apenas um máximo de 100 dos parâmetros mais populares (aqueles usados por mais componentes no Workspace conectado, em todos os tipos de componente) são mostrados no painel Filters. Os seguintes parâmetros (ou aqueles que começam com os seguintes nomes) são sempre mostrados no topo do painel: Power, Value, Resistance, Res, Capacitance, Case, Package, Tolerance, RoHS, Lead.

As opções do Filters do painel podem ser ajustadas às suas necessidades selecionando tipos de parâmetros específicos como Favorites, que então passam para o topo da lista da Categoria de componente atual. Passe o cursor à direita do nome de um filtro de parâmetro e clique no ícone para definir o filtro como Favorito. As configurações de filtro favorito se aplicam a Categorias de componente individuais e são salvas para elas.

Para componentes do Workspace, o menu de clique com o botão direito oferece opções para editar o componente por meio do Component Editor (Edit) e executar funções de gerenciamento de componentes, como criação e clonagem de componentes, ou edição de Part Choices e Type do componente selecionado (Operations).

 
 
 
 
 

As opções de informações adicionais no painel Details do componente incluem: visualizar uma imagem do modelo, visualizar folhas de dados online (References), informações ao vivo de Supplier (Part Choices), ver onde a peça foi usada em projetos do Workspace, folhas gerenciadas e blocos de reutilização (Where Used) e, por meio do menu de clique com o botão direito, a capacidade de copiar dados de parâmetros do componente selecionados ou todos eles (detalhes técnicos) em formato delimitado por tabulação, além de redefinir os parâmetros marcados como favoritos para os cinco parâmetros padrão.

Ao navegar pelos componentes em um Altium 365 Workspace conectado e caso sejam encontrados quaisquer problemas relacionados à integridade do componente selecionado, uma indicação disso será apresentada pelo ícone (para erros) ou (para erros fatais) na linha Component issues acima da lista de parâmetros do componente. O número à direita do ícone indica o número de problemas encontrados. Clique na seta para baixo à direita do número para ver as descrições curtas dos problemas.

Um exemplo de problemas de integridade de biblioteca encontrados.
Um exemplo de problemas de integridade de biblioteca encontrados.

A integridade da biblioteca do seu Workspace pode ser explorada com mais detalhes por meio da página do painel Library Health acessível pela interface do navegador do Altium 365 Workspace. Consulte Library Health Dashboard para saber mais.

Você pode usar o recurso de filtragem personalizada para refinar ainda mais a filtragem no painel Components. ​​​​​​

O recurso está disponível ao:

  1. clicar no ícone de filtro () no cabeçalho para exibir a lista suspensa Filter,

  2. que suporta filtragem selecionando um Filter Value (o padrão), ou configurando um Filter Rule definido pelo usuário. Se você selecionar um valor da lista, ele será convertido automaticamente em uma expressão (que pode então ser editada).

  3. Se você selecionar Filter Rules para definir seu próprio filtro, então escolherá um operador na primeira lista suspensa, depois selecionará ou inserirá um valor de filtro na segunda lista suspensa.

  4. O filtro atual é exibido abaixo da lista de resultados; clique no botão para abrir a caixa de diálogo Filter Editor e editar seu filtro.

Onde Usado

Selecione um componente do Workspace no painel Components para visualizar informações sobre onde a revisão mais recente dele está sendo usada atualmente na região Where Used. A região fornece informações de filtro rápido para:

  • Projects – os projetos do Workspace nos quais o componente foi usado. As informações são only apresentadas assim que o projeto for salvo no Workspace.

  • Managed Sheets – as folhas esquemáticas gerenciadas nas quais o componente foi usado. 

  • Reuse Blocks – os Reuse Blocks armazenados como parte da biblioteca de um Workspace conectado.

Observe que as abas só serão exibidas se existir uma entidade no Workspace que use o componente selecionado.

Se um componente for usado não em todas as variantes de projeto de um projeto do Workspace, a entrada do projeto na região Where Used mostrará o número de variantes nas quais o componente é usado e o número total de variantes desse projeto, bem como a lista de variantes nas quais o componente é usado ().

Cache de Dados do Componente

Ao usar o painel Components, os dados dos componentes do Workspace são armazenados em cache na máquina local a partir do Workspace. Isso fornece um modo de acesso offline para componentes do Workspace quando o Altium Designer não está conectado ao Workspace e, portanto, permite a navegação e inserção normais de componentes etc.

No primeiro lançamento do painel Components na sessão atual do Altium Designer, será exibido um aviso no painel quando estiver no modo offline, junto com controles para continuar usando os dados de componentes em cache ou limpar o cache.

Clique em Use Cached Data para usar os componentes em cache. Essa condição será indicada pelo texto de aviso Offline mode – cached data is being used na barra inferior do painel de lista de componentes do painel. Observe que Filters não estão habilitados nesse modo.

O cache acumula dados de componentes ao longo do tempo e pode ser limpo a qualquer momento (para todos os Workspaces) usando a opção Clear Cache disponível em Known Servers na página Data Management – Servers page da caixa de diálogo Preferences.

O comportamento de cache apresentará apenas componentes em cache do(s) Workspace(s) atualmente conectado(s), como Altium 365 Workspace, o que significa que determinados dados em cache podem ficar desabilitados. Esse comportamento pode ser gerenciado na página Data Management – Servers da caixa de diálogo Preferences.

Lista de Part Choices

Edite a Part Choices List associada a um componente do Workspace selecionando a opção Operations » Create/Edit Part Choices no menu de clique com o botão direito da entrada.

Use o botão Edit Part Choices da caixa de diálogo a seguir para abrir a caixa de diálogo Add Part Choices, que pesquisará automaticamente fabricantes de peças pelo parâmetro Name do componente selecionado. Desmarque o termo de pesquisa predefinido para pesquisar alternativas manualmente. Funcionalmente, a caixa de diálogo é uma versão modal do painel Manufacturer Part Search panel.

A lista de Part Choice pode ser classificada selecionando um nível apropriado de ícone de estrela, e a lista será reordenada automaticamente com a opção do fabricante mais bem classificada no topo.

As Part Choices acompanham o componente onde quer que seus dados sejam aplicados, como em um projeto esquemático, documento BOM, relatório de saída e assim por diante.

Quando um componente é selecionado no painel Components, sua lista de part choices pode ser vista na região Part Choices do painel Details. Informações básicas (estoque, preço unitário mediano e ciclo de vida do fabricante) sobre a part choice relacionada também estão disponíveis na parte superior do painel Details. A faixa colorida associada indica a adequação fundamental da peça para uso com base em seu estado de Lifecycle deduzido – por exemplo, um componente sinalizado como Obsolete (vermelho) não é recomendado em comparação com um classificado como Volume Production (verde). Passe o cursor sobre uma faixa colorida para ver seu estado de Manufacturer Lifecycle.

Se você usar a funcionalidade de integração do Silicon Expert ou Z2 Data, dados e controles adicionais poderão estar disponíveis na parte superior do painel Details. Consulte as páginas Pulling Part Data from SiliconExpert e Pulling Part Data from Z2Data para saber mais.

Se você tiver o recurso Part Choice Revision Control habilitado para seu Workspace, selecionar a opção Operations » Create/Edit Part Choices abrirá o Component Editor (em seu modo Single Component Editing ou Batch Component Editing) em vez da caixa de diálogo Edit Part Choices. Aplique quaisquer alterações necessárias às part choices e salve o(s) componente(s) de volta no Workspace na(s) próxima(s) revisão(ões) do componente.

Menu de Clique com o Botão Direito do Painel Components

O menu pop-up de clique com o botão direito do painel fornece os seguintes comandos:

  • Place [ComponentName/FootprintName/SimulationModelName] – use para inserir o componente ou modelo de simulação atualmente selecionado no documento esquemático ativo ou a footprint atualmente selecionada no documento PCB ativo.

  • Find Similar Components – use para abrir a caixa de diálogo Find Similar Components dialog para configurar critérios de pesquisa e encontrar componentes semelhantes ao componente selecionado.

  • Navigate to [ComponentName] – use para abrir o componente de Workspace escolhido no painel Explorer panel, onde você pode acessar informações detalhadas do Item e gerenciar as configurações de revisão e ciclo de vida dos Items, bem como detalhes de uso e da cadeia de suprimentos, entre outras opções.

  • Edit – clique para editar o(s) componente(s) do Workspace selecionado(s) por meio do Component Editor (em seu modo Single Component Editing ou Batch Component Editing) ou o modelo de domínio selecionado (símbolo, footprint ou modelo de simulação) em seu editor. Se o tipo de componente atual for diferente do template que está sendo usado no momento, a caixa de diálogo Change component type será aberta (). Use a caixa de diálogo para alterar o tipo de componente do componente selecionado.

  • Create – clique para abrir a caixa de diálogo Create new component para selecionar o tipo de componente ao adicionar um novo componente.

  • Delete – clique para excluir o(s) componente(s) selecionado(s) do seu Workspace conectado.

  • Operations – use para acessar um menu suspenso de funções adicionais para componentes do Workspace, conforme descrito abaixo.

    • Submit Request – use para acessar as definições de processo ativas de solicitação de peças. Se nenhuma definição de processo ativa estiver disponível para o tema de processo Part Requests, o botão Submit Request ficará esmaecido (indisponível). Talvez seja necessário sair do Workspace e entrar novamente ou reiniciar o Altium Designer para atualizar.

    • Download – use para baixar o(s) componente(s) selecionado(s) para uma Integrated Library compilada compactada (*.IntLib), com seu pacote de biblioteca de origem (*.LibPkg) e arquivos de biblioteca. Selecione várias entradas de componente para baixar esses componentes em uma única sessão.

    • Make a copy – clique para copiar o componente selecionado. O editor de componentes é aberto no modo Single Component Editor.

    • Change Component Type – use para abrir a caixa de diálogo Choose component type (), a partir da qual você pode alterar o tipo do componente atual para um dos outros tipos definidos existentes na lista. A caixa de diálogo exibe informações sobre qualquer template de componente associado a um tipo de componente e a pasta dentro do Workspace conectado na qual componentes desse tipo podem ser encontrados/salvos. Clique em botão para gerenciar a lista de Tipos de Componente disponíveis na página Gerenciamento de Dados – Tipos de Componente da caixa de diálogo Preferences

    • Change State – use para alterar o estado de revisão do(s) componente(s) selecionado(s). Após usar o comando, a caixa de diálogo Batch state change dialog é aberta, permitindo alterar o estado de revisão do(s) componente(s).

    • Create/Edit Part Choices – use para acessar a caixa de diálogo Edit Part Choices, onde você pode criar ou editar a lista de escolhas de peças associada ao componente do Workspace.

      Se o recurso Part Choice Revision Control estiver habilitado para o seu Workspace, selecionar este comando abrirá o Editor de Componentes em seu modo Single Component Editing ou Batch Component Editing.
    • Full Item History – use para acessar uma visualização detalhada do componente atualmente selecionado, aberta como uma nova exibição em guia no Altium Designer. A Item View fornece uma visualização altamente detalhada do histórico de Revisão e Ciclo de Vida de um Item específico, além de mostrar todos os elementos que compõem esse Item. A visualização também inclui uma Linha do Tempo. Use a Linha do Tempo para examinar a hora e a data exatas de qualquer alteração feita no nível de Revisão ou no Estado do Ciclo de Vida desse Item e quem fez a alteração.

     

  • Refresh – clique para atualizar rapidamente o painel. A seleção atual de componentes será salva.

Recurso de Comparação de Componentes

O recurso Compare permite comparar os parâmetros de dois componentes (peças) selecionados. Esse recurso é acessado selecionando dois componentes na região da grade com o ícone habilitado (azul). A região Selected Component Details é aberta à direita da região da grade. A região superior (região 1 na imagem abaixo) exibe uma imagem, o nome, a descrição e o preço dos componentes selecionados lado a lado. Clique no botão Datasheet para abrir a folha de dados do fabricante (se disponível) do componente associado. Clique no botão Place para posicionar o componente no espaço de projeto. O componente aparecerá flutuando no espaço de projeto; clique para posicioná-lo no local desejado. Você pode continuar posicionando componentes adicionais ou clicar com o botão direito ou Esc para sair do modo de posicionamento e retornar ao painel Components.

A região inferior (região 2 na imagem abaixo) exibe uma visualização lado a lado dos parâmetros dos componentes, com as diferenças destacadas em texto vermelho para facilitar a comparação.

O recurso Compare também está disponível quando o painel Components está no modo compacto, embora funcione de forma um pouco diferente. Esse recurso é acessado selecionando dois componentes na região da grade. A região Selected Component Details é aberta abaixo da região da grade. A região superior exibe o nome, o preço e a visualização dos parâmetros dos componentes, com as diferenças destacadas em texto vermelho para facilitar a comparação. A região inferior exibe uma visualização lado a lado de Symbols e Models dos componentes.

O recurso e a funcionalidade Compare também estão disponíveis no painel Manufacturer Part Search panel.

Editando Símbolos e Footprints de Componentes

O símbolo e o footprint de um determinado componente podem ser ocultados na seção Models da janela Details, acessada clicando em Info button no canto superior direito. Depois de ocultados, o símbolo e o footprint serão substituídos por links clicáveis que restauram os itens ocultos à visualização original. Também está incluída a capacidade de dimensionar o tamanho dos modelos exibidos. Tanto para os símbolos quanto para os footprints, clique e arraste o perímetro inferior da área do modelo para redimensionar a imagem.

Observe que a capacidade de ocultar e redimensionar as visualizações do modelo também está disponível na janela Details do painel Manufacturer Part Search panel.

Para um arquivo de Biblioteca Esquemática (*.SchLib) sendo visualizado no painel Components, o símbolo e o footprint do componente selecionado podem ser editados usando o botão na parte inferior direita da visualização do modelo.

A capacidade de editar um footprint fica disponível ao acessar Components, desde que footprints válidos e vinculados já estejam presentes.

Caixas de Diálogo de Seleção de Componentes

O mecanismo de busca e a visualização usados no painel Components também são aplicados em outros aplicativos do Altium Designer onde uma escolha de componente é feita. A funcionalidade de busca de componentes está incluída nessas caixas de diálogo (modais), juntamente com um botão de confirmação OK e pequenas variações nos comandos de ação disponíveis. A caixa de diálogo normalmente é chamada de Component Search.

Acessando e Posicionando Componentes Genéricos

Este recurso está em Open Beta e disponível quando a opção ComponentSearch.GenericComponents está habilitada na caixa de diálogo Advanced Settings dialog.

Para agilizar o processo de elaboração dos estágios iniciais de um projeto, o conceito de componentes Generic Components padronizados e básicos está disponível. Componentes genéricos podem ser rapidamente posicionados em um projeto sem a necessidade de localizar e escolher uma peça específica de fabricante entre as fontes de componentes disponíveis. Os componentes genéricos destinam-se a servir como marcadores temporários que são facilmente substituídos por um componente adequado posteriormente no processo de projeto – eles também podem ser considerados componentes virtuais ou paramétricos.

Para saber mais sobre a criação de componentes genéricos, consulte a página Criando Componentes Genéricos .

Quando o Altium Designer está conectado a um Workspace, os Componentes Genéricos disponíveis podem ser acessados a partir do painel onde são exibidos quando a opção All é selecionada na janela Categories – ou no menu suspenso superior quando o painel está em modo compacto. Clique no botão dentro de um bloco de Componente Genérico para anexar o componente ao cursor para posicionamento no documento esquemático ativo. Quando o componente é posicionado em um esquemático, os primitivos de pino, linha e borda do símbolo – efetivamente seu contorno – ficam coloridos em vermelho para indicar que um componente genérico está sendo usado. Selecionar o próprio bloco no painel Components abrirá essa categoria de tipo de componente no painel.

Posicionando um componente genérico a partir do painel Components
Posicionando um componente genérico a partir do painel Components

Como os Componentes Genéricos não devem ser usados em um projeto final, eles causarão uma violação ERC – Generic Component – quando posicionados em um esquemático. O nível dessa violação – um Fatal Error por padrão – é determinado na seção Violations Associated with Components das configurações de Error Reporting settings na caixa de diálogo Project Options (Project » Project Options).

Selecione um Componente Genérico posicionado para acessar suas propriedades no painel Properties panel, que fornece apenas as configurações e parâmetros relevantes para esse tipo de componente. Os parâmetros disponíveis são determinados pelo Component Template relacionado (Resistors no exemplo mostrado aqui). Os valores dos parâmetros podem ser inseridos manualmente ou selecionados em uma lista de menu suspenso que oferece valores provenientes de todos os componentes disponíveis desse tipo.

Javascript ID: GenericComponents_Parameters

Especificando parâmetros de um componente genérico – selecionando valores de parâmetro nos menus suspensos.

Especificando parâmetros de um componente genérico – o resultado.

Suporte para Componentes Jumper

Jumpers, também chamados de wire links, permitem substituir o roteamento por um componente Jumper, o que muitas vezes é um elemento essencial para projetar com sucesso uma placa de face simples. O Altium Designer oferece suporte ao uso de componentes jumper por meio de um tipo especial de componente Jumper.

Embora você possa começar posicionando os footprints de Jumper diretamente na PCB, um fluxo de trabalho recomendado começa no esquemático. Para saber mais, consulte a página Working with Jumper Components.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Conteúdo