Definição de linhas de dobra - Modo avançado

Num relance

Este artigo explica como funcionam as linhas de dobra no modo Rigid-Flex Avançado do Altium Designer, com foco nas diferenças em relação ao modo rígido-flexível padrão e em como elas afetam a definição das regiões flexíveis e o dobramento da placa. Você verá como identificar qual modo rígido-flexível uma PCB está usando, posicionar e ajustar linhas de dobra no Modo de Planejamento da Placa, editar suas propriedades e controlar como as dobras são exibidas quando a placa é dobrada em 3D. Se você está trabalhando em um projeto rígido-flexível mais complexo e precisa de orientações práticas para definir a posição, o ângulo, o raio e a ordem das dobras, este artigo ajudará você a avançar com confiança. Continue lendo para tornar seu fluxo de trabalho com placas rígido-flexíveis mais preciso e previsível.

- Entenda a diferença entre o modo rígido-flexível padrão e o modo Rigid-Flex Avançado, especialmente por que o modo avançado não usa objetos de linha de divisão.
- Aprenda o fluxo de trabalho básico para posicionar, mover, remover e localizar com precisão as linhas de dobra no Modo de Planejamento da Placa.
- Veja quais propriedades das linhas de dobra controlam o comportamento das dobras em 3D, incluindo ângulo, raio, atribuição à região de empilhamento e ordem de dobramento.
Aprofunde-se com a IA:

Há dois modos de projeto rígido-flexível disponíveis no software de projeto de PCB da Altium. O modo original, ou padrão, chamado Rigid-Flex, oferece suporte a projetos rígido-flexíveis simples. Se o seu projeto tiver requisitos rígido-flexíveis mais complexos, como regiões flexíveis sobrepostas, será necessário usar o modo Advanced Rigid-Flex (também conhecido como rigid-flex 2.0). O modo é escolhido no menu Tools do Gerenciador de Empilhamento de Camadas.

A diferença fundamental entre os modos é que, no modo original, o formato da placa é dividido em regiões separadas por meio da inserção de uma Linha de Divisão, que permanece como um objeto que define onde uma região da placa termina e outra começa. No modo Avançado, cada região da placa é inserida separadamente ou, se uma região maior for recortada, ela se torna dois objetos de região separados. No modo Avançado, as bordas das regiões adjacentes da placa definem onde essas duas regiões se encontram, e não a presença de uma Linha de Divisão. Devido a essa diferença, não há objeto de Linha de Divisão quando a placa está no modo Advanced Rigid-Flex.

► Saiba mais sobre Como projetar uma PCB rígido-flexível

O menu View tem três modos de trabalho do editor de PCB com atalhos fáceis de lembrar, permitindo alternar rapidamente entre:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

O comportamento padrão ao alternar entre os modos de visualização 2D e 3D é manter configurações separadas de zoom e orientação para cada modo de visualização. Se quiser ver a mesma posição e orientação da placa ao alternar, pressione Ctrl+Alt+2 ou Ctrl+Alt+3, em vez de 2 ou 3.

Você acabou de abrir uma PCB e está se perguntando se ela usa o modo rígido-flexível padrão ou o modo rígido-flexível avançado?

Você pode abrir o Gerenciador de Empilhamento de Camadas para verificar. Como alternativa, alterne para o Modo de Planejamento da Placa (atalho 1) e observe a Barra Ativa:

Modo Rigid-Flex padrão
Modo Advanced Rigid-Flex

Para definir como uma placa flexível deve se dobrar, insira uma ou mais Linhas de Dobra. A Linha de Dobra define onde, na superfície da região flexível, a dobra deve ocorrer. A Linha de Dobra também define o ângulo e o raio da dobra. A largura da faixa da superfície da placa que está sendo dobrada é exibida em laranja; essa largura é calculada a partir do ângulo e do raio da dobra (saiba mais sobre as propriedades da linha de dobra). As Linhas de Dobra são inseridas e editadas com o editor de PCB em Board Planning Mode (View » Board Planning Mode, ou pressione o atalho 1).


Uma Linha de Dobra é inserida sobre a região flexível e configurada para que a placa possa se dobrar em 180 graus. Este vídeo demonstra a inserção de uma Linha de Dobra no modo Advanced Rigid-Flex.

Como inserir uma Linha de Dobra

Para inserir uma Linha de Dobra:

  1. Selecione View » Board Planning Mode ou pressione o atalho 1 para entrar em Board Planning Mode.
  2. Selecione o comando Place » Define Bending Line ou clique no botão  na Barra Ativa.
  3. Uma Linha de Dobra é inserida sobre a Região da Placa desejada, mas não fica vinculada a ela (as Linhas de Dobra são associadas a uma ou mais Regiões da Placa pela propriedade Stack Regions). Clique perto da borda da Região da Placa para definir a posição inicial da Linha de Dobra.
  4. Mova o cursor até a posição final desejada e clique para inserir a Linha de Dobra. Observe que pelo menos uma extremidade da Linha de Dobra deve tocar ou cruzar o limite da Região da Placa à qual ela se aplica.
  5. Você permanece no modo de inserção de Linha de Dobra, pronto para inserir outra Linha de Dobra, se necessário. Caso contrário, clique com o botão direito do mouse ou pressione Esc para sair do modo de inserção de Linha de Dobra.

As propriedades de uma Linha de Dobra selecionada podem ser editadas no painel Properties. Como a Linha de Dobra fica sobre uma região, pode acontecer de a região abaixo dela ser selecionada quando você clicar na Linha de Dobra. Sem mover o cursor, clique uma segunda vez para selecionar a Linha de Dobra em vez da Região da Placa.

As propriedades da Linha de Dobra selecionada são exibidas no painel Propriedades.
As propriedades da Linha de Dobra selecionada são exibidas no painel Propriedades.

  • Não é essencial que a Linha de Dobra comece ou termine exatamente na borda da Região da Placa; o software estenderá ou encurtará automaticamente a Linha de Dobra para que ela seja definida de uma borda da região à outra.
  • Certifique-se de que a Região da Placa correta esteja habilitada na seção Stack Regions do painel Properties.

Como mover uma Linha de Dobra

Para modificar a posição de uma Linha de Dobra existente:

  1. Selecione View » Board Planning Mode (ou pressione o atalho 1) para entrar em Board Planning Mode.
  2. Clique e mantenha pressionado o vértice em uma das extremidades da Linha de Dobra; em seguida, arraste esse vértice até a posição desejada e solte o botão do mouse. O cursor ficará restrito às configurações atuais de ajuste do cursor; pressione Ctrl+E para alterar as configurações enquanto trabalha.
  3. A posição da dobra será redefinida pela nova posição da Linha de Dobra.

Selecione e arraste um vértice da Linha de Dobra para alterar sua posição na placa — o cursor ficará restrito às configurações atuais de ajuste do cursor.
Selecione e arraste um vértice da Linha de Dobra para alterar sua posição na placa — o cursor ficará restrito às configurações atuais de ajuste do cursor.

Como posicionar uma Linha de Dobra com precisão

Quando a alça de uma Linha de Dobra é movida, ela se ajusta de acordo com as configurações atuais de ajuste. Pressione Ctrl+E durante a movimentação para abrir o painel de controle interativo das configurações de ajuste, conforme mostrado na imagem abaixo. Pressione Esc após alterar as configurações para aplicá-las e fechar o painel.

Além de se ajustar à grade de ajuste e às guias da área de trabalho, a Linha de Dobra também pode se ajustar a objetos de projeto existentes, como linhas em uma camada mecânica. A imagem abaixo mostra uma alça de Linha de Dobra sendo posicionada no vértice final de uma linha em uma camada mecânica. Observe que a configuração atual de Ajuste a Pontos de Referência se aplica durante a movimentação (exibida na barra de status). Se a camada mecânica não for a camada de projeto ativa, o Ajuste a Pontos de Referência deverá ser configurado como All Layers para que esse comportamento de ajuste funcione. Pressione o atalho Shift+E para alternar a configuração de Ajuste a Pontos de Referência entre os modos disponíveis enquanto trabalha.

A alça de uma Linha de Dobra está sendo ajustada ao vértice de uma trilha inserida em uma camada mecânica.
A alça de uma Linha de Dobra está sendo ajustada ao vértice de uma trilha inserida em uma camada mecânica.

Como remover uma Linha de Dobra

Para remover uma Linha de Dobra:

  1. Selecione View » Board Planning Mode (ou pressione o atalho 1) para entrar em Board Planning Mode.
  2. Clique e mantenha pressionado um de seus vértices para selecionar a Linha de Dobra; em seguida, pressione a tecla Delete.

Como configurar as propriedades da Linha de Dobra

Para editar as propriedades de uma Linha de Dobra no painel Properties:

  1. Alterne para Board Planning Mode (pressione 1).
  2. Clique em qualquer ponto dentro da faixa laranja da Linha de Dobra para selecioná-la.
  3. A Linha de Dobra pode ser editada no painel Properties.

As dobras definidas podem ser aplicadas quando a placa é exibida no modo 3D; pressione o atalho 5 para dobrar a placa. A Região da Placa rígida que estiver com a caixa de seleção 3D Locked marcada será a referência física de base para o modo de exibição 3D (onde Z = 0). Se a placa não se dobrar conforme o esperado, verifique se a região rígida correta está com a caixa de seleção 3D Locked marcada. Observe que não é necessário desmarcar a opção em uma Região da Placa antes de ativá-la em outra.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents