Planejamento de regiões rígidas e flexíveis - Modo avançado
Num relance
- Você aprenderá a diferença entre o modo Rígido-Flexível Padrão e o modo Rígido-Flexível Avançado, e como isso muda a maneira como as regiões da placa são criadas e definidas.
- Você verá como posicionar e editar Regiões da Placa no Modo de Planejamento da Placa, incluindo a atribuição de nomes e empilhamentos de camadas e o uso de guias e do ajuste por atração para obter precisão.
- Você conhecerá atalhos, modos de posicionamento e configurações de propriedades úteis que ajudam a trabalhar com mais eficiência em layouts complexos de PCBs rígido-flexíveis.
Como inserir uma Região da Placa
Uma Região da Placa é um objeto poligonal inserido usando as técnicas padrão de inserção de objetos poligonais. O formato da placa deve ser definido com precisão, por isso é importante que as regiões que compõem a placa sejam criadas exatamente conforme necessário. O vídeo abaixo demonstra a criação de Regiões da Placa alinhando suas bordas com guias do espaço de projeto previamente posicionadas. A vantagem dessa técnica é que a posição das guias do espaço de projeto pode ser definida com precisão editando suas coordenadas no painel Properties.
Guias predefinidas do espaço de trabalho são usadas como referência para a inserção das Regiões da Placa.
As Regiões da Placa são inseridas e modificadas em Board Planning Mode:
- Selecione View » Board Planning Mode (ou pressione o atalho 1) para entrar em Board Planning Mode. A Região da Placa existente por padrão será exibida como um retângulo verde.
-
Selecione Place » Board Region para inserir uma nova região (ou clique no botão
na Active Bar).
- Posicione o cursor e clique para fixar o vértice inicial da Região da Placa. A Região da Placa é um objeto poligonal, como uma Região ou um Polígono, e segue o mesmo processo de inserção (e edição).
- Mova o cursor para posicionar o segundo vértice. O comportamento padrão é inserir 2 bordas a cada clique, com um formato de canto definido pelo usuário entre elas; pressione Spacebar para alternar a direção do canto. Consulte a seção Placement Modes abaixo para obter mais detalhes sobre como alterar os modos de canto.
- Continue movendo o mouse e clicando para inserir vértices, criando as bordas necessárias para definir o formato geral da Região da Placa.
- Após inserir o último vértice, clique com o botão direito do mouse ou pressione Esc para fechar e concluir a definição do formato da placa. Não é necessário fechar manualmente o formato da placa, pois o software o completará automaticamente conectando o último ponto inserido ao ponto inicial.
- Cada Região da Placa recebe um nome para identificá-la de forma exclusiva. Insira um nome adequado no campo Name no modo Região da Placa do painel Propriedades (a Região da Placa deve estar selecionada no espaço de projeto para que suas propriedades sejam exibidas no painel).
-
Cada Região da Placa deve ter um empilhamento de camadas atribuído. Quando uma nova Região da Placa é criada, ela recebe o empilhamento de camadas padrão, chamado
Board Layer Stack. Atribua o empilhamento de camadas necessário no modo Board Region do painel Properties. Os empilhamentos de camadas são definidos e nomeados no Gerenciador de Empilhamento de Camadas. - Se a PCB final exigir várias Regiões da Placa, continue definindo regiões adicionais.
Além disso, você pode pressionar a tecla Tab para pausar a inserção e acessar o modo Região da Placa do Properties painel, onde suas propriedades podem ser alteradas durante a operação. Clique no botão de pausa sobreposto ao espaço de projeto para retomar a inserção.
Placement Modes
Ao redefinir o formato da placa, há cinco modos de canto disponíveis, quatro dos quais também têm submodos de direção do canto. Durante a redefinição:
- Pressione Shift+Spacebar para alternar entre os cinco modos de canto disponíveis.
- Pressione Spacebar para alternar entre os dois submodos de direção do canto.
-
Quando estiver em qualquer um dos modos de canto em arco, mantenha pressionada a
para reduzir ou a tecla
para ampliar o arco. Mantenha a tecla Shift pressionada enquanto pressiona para acelerar o redimensionamento do arco.
- Pressione a tecla de atalho 1 para alternar entre posicionar duas arestas por clique ou uma aresta por clique. No segundo modo, a aresta tracejada é chamada de segmento de antecipação (como mostrado na última imagem do conjunto abaixo).
- Pressione a tecla Backspace para remover o último vértice.



Pressione Shift+Spacebar para percorrer os cinco modos de canto disponíveis; pressione o atalho 1 para alternar o posicionamento entre duas arestas ou uma aresta.
Propriedades da região da placa

O modo Board Region do painel Properties.
Ações
Estes controles são usados para adicionar ou remover o coverlay da região da placa atual. Para habilitar os botões Add e Remove Coverlay , a região da placa deve ter uma pilha de camadas atribuída com a opção Is Flex habilitada e com camadas de coverlay incluídas em seu conjunto de camadas.
- Add Coverlay - Adiciona polígonos de coverlay criados automaticamente à região da placa selecionada.
- Remove Coverlay - Remove polígonos de coverlay criados automaticamente e definidos manualmente da região da placa selecionada.
Localização
- (X/Y) - as coordenadas X e Y do primeiro vértice posicionado quando a região da placa foi criada, em relação à origem atual do espaço de projeto. Edite para alterar a posição X ou Y da região da placa. Os valores podem ser inseridos no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as unidades padrão atuais.
Propriedades
- Name - nome definido pelo usuário para esta região da placa. Nomear cada região da placa é útil quando há várias regiões no projeto.
- Layer Stack - especifica qual pilha de camadas está atribuída a esta região da placa. A lista suspensa incluirá todas as pilhas de camadas (subpilhas) definidas no Gerenciador de pilhas de camadas.
- Color - clique para abrir uma paleta de cores e definir/alterar a cor das regiões da placa selecionadas. Observe que as alterações de cor são aplicadas a todas as regiões da placa que compartilham a pilha de camadas usada pela região da placa selecionada.
- Priority - o valor de Prioridade é usado para determinar qual região da placa é renderizada por último. Use-o ao projetar uma placa com uma região flexível dentro de um recorte em uma região rígida: a região flexível deve ter um valor de Prioridade maior que o da região rígida ao redor (e o recorte da placa deve contornar a região flexível dentro do recorte).
- 3D Locked - marque esta caixa para manter esta região da placa fixa ao dobrar a placa no modo de visualização 3D. Apenas uma região rígida da placa pode ser bloqueada.
Vértices do contorno
Esta região é usada para modificar os vértices individuais do objeto de região da placa atualmente selecionado. Você pode modificar as posições dos vértices existentes, adicionar novos vértices ou removê-los conforme necessário. É possível definir conexões em arco entre os vértices e também exportar informações dos vértices para um arquivo no formato CSV e importá-las dele (por meio do menu de contexto).
-
Vertices Grid - lista todos os vértices atualmente definidos para a região da placa em termos de:
- Index - o índice atribuído ao vértice (não editável).
- X - a coordenada X (horizontal) do vértice. Clique para editar.
- Y - a coordenada Y (vertical) do vértice. Clique para editar.
-
Arc Angle (Neg = CW) - o ângulo de um arco desenhado para conectar este vértice ao próximo. Por padrão, as conexões são arestas em linha reta e este campo permanece em branco. Clique para editar e insira o ângulo do arco desejado. Um valor positivo resultará em um arco desenhado no sentido anti-horário. Para desenhar um arco no sentido horário, insira um valor negativo.
-
Add - clique para adicionar um novo vértice. O novo vértice será adicionado abaixo da entrada de vértice atualmente em foco e terá inicialmente as mesmas coordenadas X,Y dessa entrada. Clique em
para remover o vértice atualmente selecionado.
Criar uma região da placa a partir de um corpo 3D
As regiões da placa também podem ser criadas a partir de objetos de corpo 3D usando o comando Create Board Region from 3D Body no modo 3D. O procedimento é o seguinte:
- Certifique-se de que está visualizando a placa em 3D (caso contrário, use o atalho de teclado 3 para mudar rapidamente para esse modo).
- Escolha o comando Design » Board Shape » Create Board Region from 3D body nos menus principais.
- Posicione o cursor sobre o modelo 3D que deseja usar para gerar a região da placa para a PCB e clique ou pressione Enter. O modelo ficará transparente.
- Mova o cursor sobre o modelo 3D para localizar uma face. Quando uma superfície plana for encontrada sob o cursor, ela ficará opaca com uma borda azul fina.
- Quando a face apropriada for encontrada, clique ou pressione Enter - a nova região da placa será criada (substituindo a região da placa definida anteriormente no espaço de projeto).
- A caixa de diálogo Board Outline Creation Successful será exibida confirmando a criação bem-sucedida. Essa caixa de diálogo permite ocultar a peça do modelo e excluí-la da verificação DRC. Ela também oferece opções para modificar a altura do modelo para alinhar a face à superfície superior, à superfície inferior ou não alterar a posição.
Criar uma região de recorte da placa
Para criar um recorte interno na placa, posicione uma região de recorte da placa (Place » Define Board Cutout, ou clique no botão
em Active Bar). Um recorte da placa também é um objeto poligonal e, portanto, tem o mesmo processo de posicionamento da própria região da placa. As imagens abaixo mostram uma região da placa com dois recortes, que se tornam aberturas na placa quando ela é fabricada.
Um recorte posicionado em uma região da placa se torna uma abertura na placa acabada.
Dividir o contorno da placa em regiões
Você pode dividir uma região da placa existente em duas regiões fazendo um corte nela. Isso é feito quando o editor de PCB está em Board Planning Mode.
A placa foi dividida em três Regiões da Placa usando o comando Dividir Região.
Para dividir uma Região da Placa:
- Selecione View » Board Planning Mode (ou pressione o atalho 1) para entrar em Board Planning Mode.
-
Selecione Design » Slice Board Region (ou clique no botão
na Barra Ativa) para entrar no modo Dividir Região da Placa.
- Ao selecionar o comando, você entra no modo de divisão, que é semelhante ao modo de posicionamento de trilhas. Começando fora da região a ser dividida, clique para fixar uma série de vértices que definem a linha de divisão. Ao definir a divisão, pressione Shift+Spacebar para alternar entre os modos de canto; pressione Spacebar para alternar entre os modos de canto Inicial e Final e use a tecla Backspace para remover o último canto posicionado. Posicione o final da linha de divisão além da borda da Região da Placa. Quando terminar de definir a divisão, clique com o botão direito do mouse ou pressione Esc para encerrar o comando.
-
Uma caixa de diálogo de confirmação é aberta, informando o número de polígonos (regiões) que serão divididos pela sua ação e o número de polígonos (regiões) que serão criados. Clique em Yes para confirmar a criação.
Criar Regiões da Placa a partir de objetos selecionados
Dependendo do formato da sua placa, pode ser mais eficiente construir seu formato criando várias Regiões da Placa. Conforme mencionado acima, as regiões podem ser posicionadas interativamente ou criadas traçando um contorno definido por objetos de trilha e arco. O vídeo abaixo demonstra a definição de três Regiões da Placa a partir de objetos selecionados. No vídeo, observe que o mesmo objeto é usado para definir as bordas adjacentes onde as regiões se tocam, garantindo que essas regiões sejam posicionadas com exatidão.
Uma abordagem comum é definir o contorno das regiões usando trilhas e arcos e, em seguida, criar as Regiões da Placa a partir dos contornos selecionados.
Converter entre primitivas de desenho 2D e objetos de definição da placa
Uma abordagem comum para definir o Formato da Placa e as Regiões da Placa necessárias nesse formato é importar um desenho de um software de CAD mecânico. Por exemplo, você pode importar detalhes mecânicos de um arquivo DWG, obtendo um conjunto de linhas (trilhas) em uma camada mecânica que definem: o formato da placa, as regiões dentro desse formato e, para um projeto rígido-flexível, linhas que definem a localização das linhas de dobra nas regiões flexíveis.
O software inclui vários comandos para ajudar a criar objetos de definição da placa (Região, Recorte, Linha de Dobra) a partir de primitivas de desenho 2D, além de comandos correspondentes para converter objetos de definição da placa de volta em primitivas de desenho.
Observações:
- Os comandos para ambas as direções estão disponíveis no submenu Tools » Convert do modo View correspondente (exceto o comando Criar Região da Placa a partir de Objetos Selecionados, que está no submenu Design » Board Shape).
-
Para converter primitivas de desenho 2D em objetos de definição da placa, altere a visualização para 2D Layout Mode.
- As primitivas devem ser selecionadas antes de executar o comando.
- As primitivas devem formar uma figura fechada para criar uma Região ou um Recorte. Consulte a caixa de aviso abaixo para saber mais sobre os requisitos dessa figura.
-
Para converter objetos de definição da placa em objetos de desenho 2D, altere a visualização para Board Planning Mode.
- Esses comandos não exigem que os objetos sejam selecionados previamente, mas atuarão no objeto selecionado se já houver um.
- Se houver várias Regiões da Placa, a Região desaparecerá quando for decomposta em primitivas. Se houver apenas uma Região da Placa, as primitivas serão criadas e a Região da Placa escolhida permanecerá (sempre deve haver uma Região da Placa).
- Os objetos de desenho 2D são criados na camada mecânica Formato da Placa. Se não houver uma camada desse Tipo de Camada na placa, uma camada mecânica será adicionada com seu Tipo de Camada definido como Formato da Placa. Saiba mais sobre Camadas Mecânicas e Tipos de Camada.
- Embora não exista um comando específico para reagrupar um objeto decomposto, você pode usar o comando Undo para fazer isso.
Modificar as Regiões da Placa
Quando a PCB é configurada para usar o modo rígido-flexível padrão, o local onde duas regiões adjacentes se encontram é definido por uma linha divisória azul móvel. Essa abordagem não é usada no modo rígido-flexível avançado; em vez disso, cada região é uma forma poligonal fechada e independente. Por ser uma forma poligonal, cada região pode ser ajustada conforme necessário usando as técnicas padrão de edição de formas poligonais. Observe que nem todos os comandos de edição de polígonos estão disponíveis para modificar uma Região da Placa, incluindo os comandos de adição e subtração de polígonos.
Pontos a lembrar sobre a edição de um objeto poligonal:
- Ao clicar e arrastar um vértice ou uma borda do polígono, há três modos de alteração de forma disponíveis: deslizamento, quebra e curvatura. Pressione Shift+Spacebar para alternar entre os modos enquanto arrasta. O modo atual é exibido na barra de status e no visor Heads-Up.
- O comportamento de ajuste do cursor é controlado pelas configurações atuais de ajuste do cursor, que incluem a Grade de Ajuste atual, os Objetos para Ajuste disponíveis, a presença de Guias da Área de Trabalho e as configurações de Ajuste aos Eixos. Use esses recursos para obter a forma desejada. Saiba mais em Entender o comportamento de ajuste.
Atribuir um empilhamento de camadas e editar o nome da Região da Placa
Related page: Definir o empilhamento de camadas
Quando uma nova placa é criada, ela possui uma única região, chamada Default Layer Stack Region. A essa região será atribuído o empilhamento de camadas padrão chamado Board Layer Stack.
Ao dividir o contorno de uma placa em várias regiões, cada nova região também recebe o empilhamento de camadas padrão. Depois que os empilhamentos de camadas necessários forem definidos no Gerenciador de empilhamento de camadas, será possível atribuir um empilhamento a cada região e também dar a ela um nome significativo.
Para atribuir um empilhamento de camadas e nomear uma região:
- Selecione View » Board Planning Mode ou pressione o atalho 1 para entrar no Board Planning Mode.
- Clique na aba Multi-Layer na parte inferior da área de trabalho para torná-la a camada ativa (se a aba da camada não estiver visível, pressione L para abrir o painel Configuração de visualização e habilitá-la).
- Clique duas vezes na região da placa para abrir a caixa de diálogo Board Region, ou clique uma vez na região da placa e abra o painel Properties. Se a região não for selecionada e a caixa de diálogo não abrir, certifique-se de que o Filtro de seleção não esteja excluindo regiões.
- Atribua o empilhamento de camadas selecionando o empilhamento desejado na lista suspensa Layer stack.
- Edite o Name conforme necessário.

O nome da região da placa e o empilhamento de camadas atribuído são exibidos no centro geométrico dessa região. (Flex) também é exibido quando o empilhamento atribuído está configurado como flexível.