Pesquisar e Colocar Componentes

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Num relance

Este artigo explica como o painel Components do Altium Designer ajuda você a encontrar, analisar, gerenciar e posicionar componentes do seu Workspace, bem como de bibliotecas baseadas em bancos de dados e arquivos. Ele destaca as diferentes opções de pesquisa disponíveis, incluindo navegação por categorias, pesquisa direta por consultas e filtragem paramétrica de componentes do Workspace, além de mostrar como o painel se conecta a ferramentas relacionadas, como o painel Manufacturer Part Search, o editor de componentes e o painel Explorer. Você também verá como abrir o painel a partir de documentos de esquemático e de PCB, como as categorias de componentes são determinadas e quais operações e controles de exibição estão disponíveis para otimizar seu fluxo de trabalho. Se você busca uma maneira mais simples de encontrar os componentes certos e posicioná-los com eficiência em seus projetos, este artigo vai ajudar. Continue lendo.

- Aprenda a pesquisar componentes no painel Components usando categorias, consultas de pesquisa e filtros baseados em parâmetros.
- Entenda de onde vêm os componentes, incluindo fontes do Workspace, bibliotecas baseadas em arquivos, bibliotecas de bancos de dados e resultados do painel Manufacturer Part Search.
- Veja como posicionar componentes e usar os principais recursos do painel para visualizar detalhes, editar componentes, gerenciar bibliotecas e organizar a lista de componentes.
Aprofunde-se com a IA:

Os componentes são o coração de qualquer projeto eletrônico. O componente que você acaba soldando na placa precisa ser representado, ou modelado, em cada domínio do projeto como um símbolo no esquemático, como um modelo SPICE no simulador, como um footprint na placa e como um modelo 3D STEP no arquivo que você entrega ao projetista mecânico.

Saiba mais sobre Como criar e manter seus componentes e bibliotecas.

O painel Components do Altium Designer oferece uma interface poderosa que você pode usar para interagir com todos os seus componentes — tanto os do Workspace quanto os externos a ele. Você pode pesquisar o componente desejado especificando a categoria e usando o modo de pesquisa simples, inserindo uma consulta (nome completo ou parcial do componente, valor etc.) no campo de pesquisa. Além disso, o painel oferece um recurso de pesquisa paramétrica (facetada) baseada em filtros para especificar os parâmetros desejados dos componentes do seu Workspace. O painel também oferece opções para editar um componente do Workspace por meio do Editor de Componentes no modo de edição de componente único, visualizar o componente em seu Workspace de origem e executar funções de gerenciamento de componentes, como criar e clonar componentes ou editar as opções de peças e o tipo do componente selecionado. Um componente pode ser posicionado no esquemático arrastando-o ou usando o comando Place  no menu de contexto do componente.

E, embora você possa, é claro, criar seus próprios componentes, o Altium Designer oferece um poderoso painel de pesquisa de peças de fabricantes que pode ser usado para pesquisar peças reais disponíveis no mercado. Se você tiver um Workspace, poderá salvar essas peças nele e acessá-las pelo painel Components. Esse processo envolve criar um novo componente do Workspace — usando o Editor de Componentes no modo de edição de componente único — e salvá-lo no seu Workspace.

O painel Components oferece acesso direto aos componentes do Workspace e aos componentes de bibliotecas de banco de dados e baseadas em arquivos disponíveis no Altium Designer.

O painel obtém componentes de um Workspace conectado e de quaisquer bibliotecas abertas ou instaladas. O painel oferece detalhes completos do componente selecionado (parâmetros, modelos, opções de peças, dados de fornecedores etc.), comparação de componentes e, para componentes do Workspace, um recurso de pesquisa paramétrica baseada em filtros para especificar os parâmetros desejados dos componentes.

O painel Components no modo normal

O painel Components no modo compacto

 

O painel Components usa a funcionalidade básica do mecanismo de pesquisa e a visualização aplicadas no painel de pesquisa de peças de fabricantes. Enquanto o painel Manufacturer Part Search utiliza o serviço Altium Parts Provider e se concentra em pesquisas de dados de fabricantes e fornecedores de componentes, o painel Components é preenchido com componentes prontos para posicionamento provenientes do seu Workspace conectado e de bibliotecas de banco de dados e baseadas em arquivos.

Para componentes do Workspace, apenas a revisão mais recente de cada componente é apresentada no painel.
Embora grande parte das funcionalidades para trabalhar com componentes esteja disponível pelo painel Components, você também pode usar o painel Explorer — basicamente, o primeiro oferece um subconjunto das funcionalidades disponíveis no segundo, com foco no gerenciamento de componentes. Algumas operações relacionadas aos próprios componentes ainda só podem ser realizadas pelo painel Explorer (adicionar folhas de dados sem editar, alterar estados, excluir componentes e modelos em massa etc.), mas elas se aplicam mais a situações atípicas, casos excepcionais ou atividades de administração e estruturação do Workspace. Lembre-se de que o componente é apenas um tipo de conteúdo — o painel Explorer mostra todo o seu potencial ao lidar com toda a variedade de tipos de conteúdo compatíveis com um Workspace. Por exemplo, a criação e o gerenciamento de templates de componentes — entidades bastante relevantes para os componentes — só podem ser realizados no painel Explorer (a menos que os templates sejam criados durante a importação de bibliotecas usando o Importador de Bibliotecas).

Acesso ao painel de componentes

Para abrir o painel Components, selecione View » Panels » Components nos menus principais ou a opção Components no menu do botão , no canto inferior direito da tela principal. Com uma configuração de design responsivo, o layout do painel se adapta dinamicamente entre o modo normal em tela cheia () e o modo compacto (), no qual as opções de categorias/filtros são recolhidas em menus.

Em um documento esquemático, use o atalho de teclado P, P para abrir o painel Components. Você também pode usar o comando Place » Part nos menus principais, o comando Place » Part no menu de contexto da área de projeto do editor de esquemáticos ou o botão Part () na Active Bar.

Em um documento de PCB, use o atalho de teclado P, C para abrir o painel Components. Você também pode usar o comando Place » Component nos menus principais, o comando Place » Component no menu de contexto da área de projeto do editor de PCB ou o comando Component () na Active Bar.

Na primeira abertura do painel Components na sessão atual do Altium Designer, os seguintes controles ficam disponíveis quando há conexão com um Workspace:

  • Use Existing Components – clique para navegar pelo tipo de componente selecionado na lista suspensa superior do painel.

  • Delete Existing Components – clique para abrir a caixa de diálogo Delete Existing Components e, em seguida, a página Data Cleanup do Settings do seu Workspace, onde você pode selecionar os tipos de conteúdo a serem removidos.

  • Import Library – clique para abrir a caixa de diálogo padrão Open do Windows e selecione uma biblioteca de banco de dados ou baseada em arquivos salva em uma pasta local ou de rede. Após abrir um arquivo de biblioteca, o Importador de Bibliotecas no modo simples será iniciado com a biblioteca selecionada carregada.

  • Create Component – clique para abrir a caixa de diálogo Criar novo componente e, em seguida, o Editor de Componentes no modo de edição de componente único, pronto para definir um novo componente.

A seção Categories do painel (ou o menu suspenso no modo compacto) lista todos os componentes disponíveis do Workspace na entrada da categoria All e todas as bibliotecas disponíveis. Quando o painel estiver no modo normal, clique no ícone de lista Categories ou no ícone « para recolher ou expandir a exibição da coluna e use o botão (no canto superior direito) para alternar a visibilidade da seção Details do componente. Ao navegar pela seção Categories, os atalhos de teclado Up/Down e PgUp/PgDn podem ser usados para percorrer a lista. Os atalhos de teclado Left/Right podem ser usados para expandir e recolher as ramificações individuais.

O agrupamento Categories dos componentes do Workspace é derivado dos parâmetros Component Type associados a cada componente. Por exemplo, se o Component Type de um componente tiver sido especificado como Resistor, esse componente será listado na categoria Resistor do painel Components (independentemente da pasta do Workspace em que esteja).

Para especificar ou alterar o tipo de um componente diretamente, clique com o botão direito na respectiva entrada e selecione a opção Operations » Change Component Type no menu de contexto para abrir a caixa de diálogo Escolher tipo de componente.

O parâmetro Tipo de um componente é definido:

Os Tipos de Componentes são gerenciados (criados/editados/removidos) na página Gerenciamento de Dados – Tipos de Componentes da caixa de diálogo Preferences. O botão Templates dessa caixa de diálogo abre a caixa de diálogo Edit Templates, na qual é possível especificar ou alterar o Modelo de Componente associado a cada Tipo de Componente.

NOTE: A Category em que um componente é listado é definida pelo seu parâmetro Tipo de Componente e não está relacionada à pasta do Workspace em que ele está. Portanto, se você mover um componente para outra pasta pelo painel Explorer, essa alteração não será refletida no painel Components.

Menu de operações

As opções do menu de operações permitem definir preferências para bibliotecas baseadas em arquivos, realizar pesquisas e especificar se as coleções de modelos de componentes ficam visíveis. Para acessar essas opções, selecione o botão do menu de operações no canto superior direito do painel.

  • Create Component – selecione para abrir a caixa de diálogo Create new component e, em seguida, o Editor de Componentes no modo de Edição de Componente Único, pronto para definir um novo componente.
  • Import Library – selecione para abrir a caixa de diálogo padrão Open do Windows e selecionar uma biblioteca de banco de dados ou baseada em arquivos salva em uma pasta local ou de rede. Após abrir um arquivo de biblioteca, o Importador de Bibliotecas no modo Simples será iniciado com a biblioteca selecionada carregada.
  • Clean-up Library – selecione para abrir a caixa de diálogo Delete Existing Components e, em seguida, a página Data Cleanup do Settings do seu Workspace, na qual você pode selecionar os tipos de conteúdo a serem removidos.
  • Models – selecione para incluir entradas de coleções de modelos de biblioteca na listagem Categories. As entradas adicionais nesse modo de navegação incluem coleções de modelos de símbolos, footprints e simulação provenientes do Workspace conectado, bem como bibliotecas de footprints de PCB instaladas (*.PcbLib).
  • File-based Libraries Preferences – selecione para abrir a caixa de diálogo Available File-based Libraries, na qual você pode acessar controles para adicionar bibliotecas de banco de dados e baseadas em arquivos ao projeto atual ou remover bibliotecas dele, instalar bibliotecas e especificar caminhos de pesquisa de bibliotecas. Consulte a seção Gerenciamento de bibliotecas de banco de dados e baseadas em arquivos disponíveis da página Pesquisa de componentes em bibliotecas baseadas em arquivos e de banco de dados para saber mais.
  • File-based Library Search – selecione para abrir a caixa de diálogo File-based Libraries Search, na qual você pode pesquisar um componente quando não souber qual biblioteca de banco de dados ou baseada em arquivos o contém, ou mesmo se ele está disponível. Consulte a seção Pesquisa de componentes em bibliotecas de banco de dados e baseadas em arquivos da página Pesquisa de componentes em bibliotecas baseadas em arquivos e de banco de dados para saber mais.
  • Refresh – clique para atualizar rapidamente o painel. A seleção atual de componentes será mantida.

Lista de componentes

Na própria grade de listagem de componentes, o conteúdo incluído na lista é gerenciado das seguintes maneiras:

  • Definição da ordem de classificação da listagem de componentes – clique no cabeçalho de uma coluna para classificar a listagem de componentes pelos dados dessa coluna. Clique novamente no cabeçalho para inverter a ordem de classificação.

  • Definição da ordem das colunas exibidas – arraste e solte o cabeçalho de uma coluna em uma nova posição.

  • Especificação das colunas de parâmetros exibidas – clique com o botão direito no cabeçalho de uma coluna e escolha Select Columns para abrir a caixa de diálogo Select Columns, na qual você pode controlar a visibilidade de uma coluna de parâmetros e alterar sua posição.

    A caixa de diálogo Select columns
    A caixa de diálogo Select columns

    • A caixa de diálogo lista todas as colunas que podem ser exibidas no painel Components. Quando um item exibe , essa coluna será exibida no painel Components . Quando um item exibe , essa coluna not será exibida no painel Components. Clique nos símbolos para alternar entre mostrar e ocultar.

    • Você também pode controlar a exibição de todas as colunas clicando no ícone / na barra de cabeçalhos das colunas. Quando algumas colunas estão visíveis e outras estão ocultas, o ícone  é exibido.

    • Passe o cursor sobre a barra de cabeçalho da segunda coluna e clique no ícone  para abrir um menu suspenso no qual você pode escolher a coluna a ser exibida.

    • Use os botões  /  para mover o item selecionado para cima ou para baixo na lista. Somente os itens definidos como visíveis () podem ser movidos. Isso determina a ordem em que as colunas aparecerão no painel Components.

  • Agrupamento da lista pelos dados de uma coluna – clique com o botão direito no cabeçalho de uma coluna, selecione a opção Enable Columns Grouping e arraste um cabeçalho de coluna (por exemplo, Footprint) para a área de agrupamento na parte superior da lista. As entradas da lista serão agrupadas sob cada valor exclusivo do parâmetro (por exemplo, tipo de footprint) da coluna de agrupamento especificada.

    Ao usar Grouping para agrupar componentes na listagem, há um limite de 10.000 entradas.

  • Filtragem da listagem por uma entrada específica de coluna – selecione no cabeçalho de uma coluna para exibir uma lista dos valores exclusivos de seus parâmetros e, em seguida, selecione uma entrada para restringir os componentes listados àqueles que incluem o parâmetro especificado (por exemplo, um código de tipo de footprint). Selecione a opção All para redefinir o filtro. Selecione (Custom) para abrir a caixa de diálogo Filter Editor e refinar ainda mais a filtragem na coluna selecionada.

Exibição de colunas

Há várias maneiras de exibir o conteúdo do painel Components. Ao clicar com o botão direito nos nomes de cada coluna (Nome, Descrição, Footprint), você pode selecionar uma das opções a seguir, dependendo de como deseja exibir os componentes:

  • Best Fit – aproxima o conteúdo das colunas Name e Descriptions, sem espaço excedente entre elas.

  • Best Fit All Columns – aproxima o conteúdo de todas as colunas, sem espaço excedente entre elas.

  • Clear Sorting – usado para desfazer a classificação das colunas.

  • Enable Columns Grouping – permite arrastar os cabeçalhos das colunas por uma coluna específica, permitindo alterar a ordem das colunas Name, Description e Footprint.

  • Select Columns – abre a caixa de diálogo Select Columns, que permite selecionar outras colunas que você deseja exibir nesta seção.

  • Apply Column Visibility to Child Categories – nos casos em que a categoria selecionada tem uma categoria filha, use este comando para permitir a propagação das configurações de visibilidade das colunas das categorias pai para as categorias filhas. Este comando só está disponível quando existe uma categoria filha.

Pesquisa de componentes e funções

Pesquisa de componentes

Para pesquisar componentes disponíveis no painel Components, insira uma expressão no campo Search e/ou use as seleções Categories e Filters do painel para restringir a lista de componentes às suas necessidades específicas. Os filtros são compatíveis apenas com componentes do Workspace e, assim como no painel Manufacturer Part Search, o painel Components oferece suporte a filtros de pesquisa que reconhecem unidades (conversão de texto em número). A funcionalidade de pesquisa prioriza os resultados de acordo com os critérios de pesquisa inseridos.

A função Search permite selecionar e, em seguida, editar ou adicionar conteúdo a uma string Search ativa.

Clique na string de pesquisa “ativa” para inseri-la no campo Search. Você pode reutilizar ou editar essa pesquisa no campo Search.

O campo Search também permite pesquisas com curingas, representados por um asterisco (*) na string.

A caixa de diálogo Find Similar Components, acessada clicando com o botão direito do mouse em um componente listado e selecionando Find Similar Components, permite definir preferências de pesquisa com base no componente selecionado.

Os resultados finais da pesquisa dependerão do tipo de componente selecionado, seja ele um componente do Workspace ou não, e do status da sua conexão com o Workspace. Por exemplo, os componentes do Workspace geralmente exibem mais parâmetros do que os componentes que não pertencem ao Workspace. Para reunir especificamente componentes e parâmetros iguais ou diferentes dos do componente selecionado, use as listas suspensas para selecionar as opções Same, Any ou Different.

Posicionamento de componentes

Um componente selecionado é posicionado em um esquemático arrastando e soltando, selecionando Place no menu de contexto do botão direito do mouse, usando o botão no painel Details, clicando duas vezes na entrada do componente desejado ou usando a tecla de atalho Enter.

Para posicionar um componente a partir do painel, você pode:

  • Clicar no botão Place no painel Component Details – o cursor se move automaticamente para dentro dos limites da folha do esquemático e o componente aparece flutuando no cursor; posicione-o e clique para inseri-lo. Após posicionar um componente, outra instância do mesmo componente aparecerá no cursor; clique com o botão direito do mouse para sair do modo de posicionamento.

    Components panel, placing from component details pane

  • Clicar com o botão direito do mouse no componente e selecionar Place no menu de contexto. O componente aparece flutuando no cursor; posicione-o e clique para inseri-lo. Observe que, se o painel estiver flutuando sobre a área de projeto, ele ficará esmaecido para permitir que você veja o esquemático e posicione o componente. Após posicionar um componente, outra instância do mesmo componente aparecerá no cursor; clique com o botão direito do mouse para sair do modo de posicionamento.

  • Click, Hold&Drag – clique e arraste o componente da região da grade do painel para uma folha do esquemático. Este modo exige que o botão do mouse seja mantido pressionado; o componente é posicionado quando o botão é solto. Após posicionar o componente, você pode selecionar outro componente ou outro comando.

    Arrastar e soltar posiciona uma única instância do componente. Se precisar posicionar várias instâncias, use o comando/botão Place ou clique duas vezes na entrada do componente.

Posicionar um componente é realmente muito simples. Mas, antes de fazer qualquer coisa, certifique-se de que a folha do esquemático (ou o documento PCB) que receberá o componente esteja aberta no Altium Designer e seja o documento ativo. Se houver documentos abertos em várias janelas, certifique-se também de que a janela que contém esse documento esquemático ativo esteja em foco.

Ao trabalhar com o Altium Designer em várias janelas, se o painel Components ou o painel Explorer estiver acoplado, em qualquer modo, a uma janela que não contenha o esquemático de destino, o comando Place permanecerá desabilitado. Isso ocorre porque clicar em um painel acoplado transfere o foco para a janela à qual esse painel está vinculado. Com o painel flutuante, porém, é possível colocar em foco a janela desejada do Altium (aquela com o esquemático de destino ativo), e essa janela manterá o foco enquanto você trabalhar no painel.

Posicionamento de um componente com várias partes

Se o componente a ser posicionado tiver várias partes, a parte selecionada abaixo da imagem de pré-visualização do símbolo na região Models do painel será posicionada inicialmente.

Depois que uma parte de um componente com várias partes for posicionada, ela poderá ser alterada para outra parte desse componente usando a lista suspensa Part no painel Properties quando a parte estiver selecionada, ou poderá ser substituída pela próxima parte disponível usando o comando Edit » Increment Part Number nos menus principais ou o comando Part Actions » Increment Part Number no menu do botão direito do mouse da parte.

O Altium Designer permite apresentar um componente multipartes como um único símbolo (todas as subpartes) ou vários símbolos (um para cada subparte individual), usando apenas um único componente por meio dos modos de exibição Normal e Alternativo definidos (Mostrar exemplo).

  • Se um componente multipartes tiver subpartes vazias em seu modo de exibição (normal ou alternativo), essas subpartes serão omitidas durante o posicionamento (Mostrar exemplo).

  • Se um componente multipartes tiver primitivas definidas em apenas uma subparte, o sufixo do designador será ocultado quando essa subparte for posicionada em uma folha de esquemático (Mostrar exemplo).

  • Quando uma subparte não tiver primitivas para o modo de exibição selecionado ou um modo de exibição não tiver primitivas para a subparte selecionada, a entrada correspondente na lista suspensa Part de Mode no painel Properties do componente ficará esmaecida (). Quando essa entrada for selecionada na lista suspensa, ícones de aviso serão exibidos ().

  • Uma violação de Subparte não utilizada no componente não ocorrerá ao executar uma validação do projeto se um componente tiver subpartes sem primitivas e essas subpartes não estiverem posicionadas no esquemático.

Filtragem de componentes

Ao visualizar componentes do Workspace, o painel Filters é preenchido com opções de filtro selecionadas com base na pesquisa atual e nos parâmetros disponíveis. A filtragem paramétrica dos componentes listados oferece mais opções para localizar um componente específico ou um tipo de componente. Abra o painel Filters pelo botão acima do painel Categories. No modo compacto do painel, clique no botão para abrir Filters como uma extensão do painel.

Observe que os filtros são compatíveis apenas com componentes do Workspace. Use o campo Filtro Search no painel para encontrar um filtro de parâmetro específico.

Javascript ID: Pnl_Components_Filter
  • O recurso de pesquisa paramétrica do Filters do painel depende do envio de dados adequados de parâmetros dos componentes pelo Workspace que hospeda os componentes do Workspace. Como resultado, a funcionalidade de filtro pode ficar desabilitada quando o software estiver conectado a um produto de servidor Altium mais antigo. Para habilitar o filtro em versões anteriores do servidor, habilite a opção ComponentSearch.LegacyAFS.Filters na caixa de diálogo Configurações avançadas.

  • Observe que, para um parâmetro aparecer no painel Filters, pelo menos dois valores diferentes desse parâmetro devem ser usados pelos componentes da categoria selecionada. Observe também que apenas os 100 parâmetros mais populares, no máximo (aqueles usados por mais componentes no Workspace conectado, considerando todos os tipos de componentes), são exibidos no painel Filters. Os seguintes parâmetros (ou aqueles que começam com os seguintes nomes) são sempre exibidos na parte superior do painel: Power, Value, Resistance, Res, Capacitance, Case, Package, Tolerance, RoHS, Lead.

As opções Filters do painel podem ser adaptadas às suas necessidades selecionando tipos específicos de parâmetros como Favorites, que passam para o topo da lista da categoria de componentes atual. Passe o cursor à direita do nome de um filtro de parâmetro e clique no ícone para definir o filtro como favorito. As configurações de filtros favoritos são aplicadas e salvas individualmente para cada categoria de componentes.

Para componentes do Workspace, o menu de contexto oferece opções para editar o componente por meio do Editor de componentes (Edit) e executar funções de gerenciamento de componentes, como criação e clonagem de componentes ou edição das opções de peças e do tipo do componente selecionado (Operations).

 
 
 
 
 

As opções de informações adicionais no painel Details do componente incluem: visualizar uma imagem do modelo, visualizar folhas de dados on-line (References), informações de fornecedores em tempo real (Part Choices), ver onde a peça foi utilizada em projetos do Workspace, folhas gerenciadas e blocos de reutilização (Where Used) e, por meio do menu de contexto, copiar os dados de parâmetros selecionados ou de todos os parâmetros do componente (detalhes técnicos) em um formato delimitado por tabulações e redefinir os parâmetros marcados como favoritos para os cinco parâmetros padrão.

Ao navegar pelos componentes em um Altium 365 Workspace conectado, se forem encontrados problemas relacionados à integridade do componente selecionado, eles serão indicados pelo ícone (para erros) ou (para erros fatais) na linha Component issues acima da lista de parâmetros do componente. O número à direita do ícone indica a quantidade de problemas encontrados. Clique na seta para baixo à direita do número para ver breves descrições dos problemas.

Um exemplo de problemas de integridade encontrados na biblioteca.
Um exemplo de problemas de integridade encontrados na biblioteca.

A integridade da biblioteca do seu Workspace pode ser analisada com mais detalhes na página do painel Integridade da Biblioteca, acessível pela interface do Altium 365 Workspace no navegador. Consulte Painel de Integridade da Biblioteca para saber mais.

Você pode usar o recurso de filtragem personalizada para refinar ainda mais a filtragem no painel Components. ​​​​​​

O recurso está disponível ao:

  1. clicar no ícone de filtro () no cabeçalho para exibir o menu suspenso Filtro,

  2. que permite filtrar selecionando um Filter Value (o padrão) ou configurando um Filter Rule definido pelo usuário. Se você selecionar um valor da lista, ele será automaticamente convertido em uma expressão (que poderá ser editada posteriormente).

  3. Se você selecionar Filter Rules para definir seu próprio filtro, escolha um operador no primeiro menu suspenso,

  4. e, em seguida, selecione ou insira um valor de filtro no segundo menu suspenso.

  5. O filtro atual é exibido abaixo da lista de resultados; clique no botão para abrir a caixa de diálogo Filter Editor e editar seu filtro.

Onde é usado

Selecione um componente do Workspace no painel Components para visualizar informações sobre onde sua revisão mais recente está sendo usada atualmente na região Where Used. A região fornece informações de filtragem rápida para:

  • Projects – os projetos do Workspace nos quais o componente foi usado. As informações são only apresentadas depois que o projeto é salvo no Workspace.

  • Managed Sheets – as folhas de esquemático gerenciadas nas quais o componente foi usado. 

  • Reuse Blocks – os blocos de reutilização armazenados como parte da biblioteca de um Workspace conectado.

Observe que as abas só serão exibidas se houver uma entidade no Workspace que use o componente selecionado.

Se um componente não for usado em todas as variantes de projeto de um projeto do Workspace, a entrada do projeto na região Where Used mostrará o número de variantes nas quais o componente é usado e o número total de variantes desse projeto, bem como a lista de variantes nas quais o componente é usado ().

Armazenamento em cache dos dados dos componentes

Ao usar o painel Components, os dados dos componentes do Workspace são armazenados em cache na máquina local a partir do Workspace. Isso oferece um modo de acesso offline aos componentes do Workspace quando o Altium Designer não está conectado ao Workspace, permitindo navegar pelos componentes e posicioná-los normalmente, entre outras ações.

Na primeira abertura do painel Components na sessão atual do Altium Designer, um aviso será exibido no painel quando estiver no modo offline, junto com controles para continuar usando os dados de componentes armazenados em cache ou para limpar o cache.

Clique em Use Cached Data para usar os componentes armazenados em cache. Essa condição será indicada pelo texto de aviso Offline mode – cached data is being used na barra inferior da área de lista de componentes do painel. Observe que Filters não ficam habilitados nesse modo.

O cache acumula dados de componentes ao longo do tempo e pode ser limpo a qualquer momento (para todos os Workspaces) usando a opção Clear Cache, disponível em Known Servers na página Gerenciamento de dados – Servidores da caixa de diálogo Preferences.

O comportamento do cache faz com que sejam apresentados apenas componentes armazenados em cache dos Workspaces atualmente conectados, como o Altium 365 Workspace, o que significa que determinados dados armazenados em cache podem ficar desabilitados. Esse comportamento pode ser gerenciado na página Data Management – Servers da caixa de diálogo Preferences.

Lista de opções de peças

Edite a Lista de opções de peças associada a um componente do Workspace selecionando a opção Operations » Create/Edit Part Choices no menu de contexto da entrada.

Use o botão da caixa de diálogo Edit Part Choices exibida em seguida para abrir a caixa de diálogo Add Part Choices, que pesquisará automaticamente peças de fabricantes pelo parâmetro Name do componente selecionado. Desmarque o termo de pesquisa predefinido para pesquisar alternativas manualmente. Funcionalmente, a caixa de diálogo é uma versão modal do painel Pesquisa de peças de fabricantes.

A lista de opções de peças pode ser classificada selecionando o nível apropriado no ícone de estrelas; a lista será reordenada automaticamente, com a opção de fabricante mais bem classificada no topo.

As opções de peças acompanham o componente onde quer que seus dados sejam aplicados, como em um projeto de esquemático, documento de BOM, relatório de saída e assim por diante.

Quando um componente é selecionado no painel Components, sua lista de opções de peças pode ser vista na região Part Choices da área Details. Informações básicas (estoque, preço unitário mediano e ciclo de vida do fabricante) sobre a opção de peça relacionada também estão disponíveis na parte superior da área Details. A faixa colorida associada indica a adequação básica da peça para uso com base em seu estado de ciclo de vida deduzido — por exemplo, um componente sinalizado como Obsolete (vermelho) é menos recomendado do que um classificado como Volume Production (verde). Passe o cursor sobre uma faixa colorida para ver seu estado de ciclo de vida do fabricante.

Se você usar a funcionalidade de integração com o SiliconExpert ou o Z2Data, dados e controles adicionais poderão estar disponíveis na parte superior do painel Details. Consulte as páginas Obtendo dados de peças do SiliconExpert e Obtendo dados de peças do Z2Data para saber mais.

Se o recurso Controle de revisão das opções de peças estiver habilitado no seu Workspace, selecionar a opção Operations » Create/Edit Part Choices abrirá o Editor de componentes (no modo Edição de componente único ou Edição de componentes em lote) em vez da caixa de diálogo Edit Part Choices. Aplique as alterações necessárias às opções de peças e salve os componentes de volta no Workspace, nas próximas revisões dos componentes.

Menu de contexto do painel Componentes

O menu de contexto do painel oferece os seguintes comandos:

 
 
 
 
 
  • Place [ComponentName/FootprintName/SimulationModelName] – use para posicionar o componente ou modelo de simulação selecionado no documento de esquemático ativo, ou o footprint selecionado no documento de PCB ativo.

  • Find Similar Components – use para abrir a caixa de diálogo Localizar componentes semelhantes e configurar os critérios de pesquisa para encontrar componentes semelhantes ao componente selecionado.

  • Navigate to [ComponentName] – use para abrir o componente escolhido do Workspace no painel Explorer, onde você pode acessar informações detalhadas do item e gerenciar as configurações de revisão e ciclo de vida dos itens, além de consultar onde são usados e detalhes da cadeia de suprimentos, entre outras opções.

  • Edit – clique para editar os componentes selecionados do Workspace no Editor de componentes (no modo Edição de componente único ou Edição de componentes em lote) ou o modelo de domínio selecionado (símbolo, footprint ou modelo de simulação) em seu respectivo editor. Se o tipo de componente atual for diferente do modelo que está sendo usado, a caixa de diálogo Change component type será aberta (). Use a caixa de diálogo para alterar o tipo do componente selecionado.

  • Create – clique para abrir a caixa de diálogo Create new component e selecionar o tipo de componente ao adicionar um novo componente.

  • Delete – clique para excluir os componentes selecionados do Workspace ao qual você está conectado.

  • Operations – use para acessar um menu suspenso com funções adicionais para componentes do Workspace, conforme descrito abaixo.

    • Submit Request – use para acessar as definições de processo de solicitação de peças ativas. Se não houver definições de processo ativas disponíveis para o tema de processo Solicitações de peças, o botão Submit Request ficará esmaecido (indisponível). Talvez seja necessário sair do Workspace e entrar novamente ou reiniciar o Altium Designer para atualizar.

    • Download – use para baixar os componentes selecionados como uma Biblioteca integrada compilada e compactada em ZIP (*.IntLib), com seu pacote de bibliotecas de origem (*.LibPkg) e arquivos de biblioteca. Selecione várias entradas de componentes para baixar esses componentes em uma única sessão.

    • Make a copy – clique para copiar o componente selecionado. O editor de componentes será aberto no modo Single Component Editor.

    • Change Component Type – use para abrir a caixa de diálogo Choose component type (), na qual você pode alterar o tipo do componente atual para um dos outros tipos já definidos na lista. A caixa de diálogo exibe informações sobre qualquer modelo de componente associado a um tipo de componente e a pasta no Workspace conectado na qual os componentes desse tipo podem ser encontrados/salvos. Clique no botão  para gerenciar a lista de tipos de componentes disponíveis na página Gerenciamento de dados – Tipos de componentes da caixa de diálogo Preferences.

    • Change State – use para alterar o estado da revisão dos componentes selecionados. Após usar o comando, a caixa de diálogo Alteração de estado em lote será aberta, permitindo alterar o estado da revisão dos componentes.

    • Create/Edit Part Choices – use para acessar a caixa de diálogo Edit Part Choices, na qual você pode criar ou editar a lista de opções de peças associada ao componente do Workspace.

      Se o recurso Controle de revisão das opções de peças estiver habilitado no seu Workspace, selecionar este comando abrirá o Editor de componentes no modo Edição de componente único ou Edição de componentes em lote.
    • Full Item History – use para acessar uma visualização detalhada do componente selecionado, aberta como uma nova aba no Altium Designer. A Visualização do item fornece uma visão altamente detalhada do histórico de revisões e do ciclo de vida de um item específico, além de mostrar todos os elementos que compõem esse item. A visualização também inclui uma linha do tempo. Use a linha do tempo para consultar a data e a hora exatas de qualquer alteração feita no nível de revisão ou no estado do ciclo de vida desse item, bem como quem fez a alteração.

  • Refresh – clique para atualizar rapidamente o painel. A seleção atual de componentes será mantida.

Recurso de comparação de componentes

O recurso Compare permite comparar os parâmetros de dois componentes (peças) selecionados. Esse recurso é acessado selecionando dois componentes na região da grade com o ícone habilitado (azul). A região Selected Component Details é aberta à direita da região da grade. A região superior (região 1 na imagem abaixo) exibe uma imagem, o nome, a descrição e o preço dos componentes selecionados lado a lado. Clique no botão Datasheet para abrir a folha de dados do fabricante (se disponível) do componente associado. Clique no botão Place para posicionar o componente na área de projeto. O componente aparecerá flutuando na área de projeto; clique para posicioná-lo no local desejado. Você pode continuar posicionando componentes adicionais ou clicar com o botão direito do mouse ou pressionar Esc para sair do modo de posicionamento e retornar ao painel Components.

A região inferior (região 2 na imagem abaixo) exibe uma visualização lado a lado dos parâmetros dos componentes, com as diferenças destacadas em vermelho para facilitar a comparação.

O recurso Compare também está disponível quando o painel Components está no modo compacto, embora funcione de maneira um pouco diferente. Esse recurso é acessado selecionando dois componentes na região da grade. A região Selected Component Details é aberta abaixo da região da grade. A região superior exibe o nome, o preço e uma visualização dos parâmetros dos componentes, com as diferenças destacadas em vermelho para facilitar a comparação. A região inferior exibe uma visualização lado a lado de Symbols e Models dos componentes.

O recurso Compare e suas funcionalidades também estão disponíveis no painel Pesquisa de peças de fabricantes.

Edição de símbolos e footprints de componentes

O símbolo e o footprint de um determinado componente podem ser ocultados na seção Models do painel Details, acessado clicando em Info button no canto superior direito. Depois de ocultados, o símbolo e o footprint serão substituídos por links clicáveis que restauram a visualização original dos itens ocultos. Também é possível ajustar o tamanho dos modelos exibidos. Tanto para símbolos quanto para footprints, clique e arraste a borda inferior da área do modelo para redimensionar a imagem.

Observe que a opção de ocultar e redimensionar as visualizações dos modelos também está disponível no painel Details do painel Pesquisa de peças de fabricantes.

Para um arquivo de Biblioteca de esquemáticos (*.SchLib) que esteja sendo explorado no painel Components, o símbolo e o footprint do componente selecionado podem ser editados usando o botão no canto inferior direito da pré-visualização do modelo.

A opção de editar um footprint fica disponível ao acessar Components, desde que footprints válidos e vinculados já estejam presentes.

Caixas de diálogo de seleção de componentes

O mecanismo de pesquisa e a visualização usados no painel Components também são aplicados em outras aplicações do Altium Designer nas quais é feita a escolha de um componente. A funcionalidade de pesquisa de componentes está incluída nessas caixas de diálogo (modais), juntamente com um botão de confirmação OK e pequenas variações nos comandos de ação disponíveis. A caixa de diálogo normalmente é chamada de Component Search.

Acessar e posicionar componentes genéricos

Este recurso está em Beta aberto e disponível quando a opção ComponentSearch.GenericComponents está habilitada na caixa de diálogo Configurações avançadas.

Para agilizar o processo de elaboração das etapas iniciais de um projeto, está disponível o conceito de Generic Components básicos e padronizados. Os componentes genéricos podem ser posicionados rapidamente em um projeto, sem a necessidade de localizar e escolher uma peça específica de um fabricante nas fontes de componentes disponíveis. Os componentes genéricos destinam-se a atuar como elementos provisórios que podem ser facilmente substituídos por um componente adequado posteriormente no processo de projeto – eles também podem ser considerados componentes virtuais ou paramétricos.

Para saber mais sobre a criação de componentes genéricos, consulte a página Criar componentes genéricos.

Quando o Altium Designer está conectado a um Workspace, os componentes genéricos disponíveis podem ser acessados no painel, onde são exibidos quando a opção All é selecionada na área Categories – ou no menu suspenso superior quando o painel está no modo compacto. Clique no botão no bloco de um componente genérico para anexar o componente ao cursor e posicioná-lo no documento esquemático ativo. Quando o componente é posicionado em um esquemático, as primitivas de pinos, linhas e bordas do símbolo – efetivamente, seu contorno – são exibidas em vermelho para indicar que um componente genérico está sendo usado. Selecionar o próprio bloco no painel Components abrirá a categoria desse tipo de componente no painel.

Posicionar um componente genérico a partir do painel Components
Posicionar um componente genérico a partir do painel Components

Como os componentes genéricos não devem ser usados em um projeto final, eles causarão uma violação de ERC – Componente genérico – quando posicionados em um esquemático. O nível dessa violação – Fatal Error por padrão – é determinado na seção Violações associadas a componentes das configurações de relatório de erros na caixa de diálogo Project Options (Project » Project Options).

Selecione um componente genérico posicionado para acessar suas propriedades no painel Propriedades, que fornece apenas as configurações e os parâmetros relevantes para esse tipo de componente. Os parâmetros disponíveis são determinados pelo modelo de componente relacionado (Resistors no exemplo mostrado aqui). Os valores dos parâmetros podem ser inseridos manualmente ou selecionados em uma lista suspensa que oferece valores provenientes de todos os componentes disponíveis desse tipo.

Especificar parâmetros de um componente genérico – selecionar valores de parâmetros nas listas suspensas.

Especificar parâmetros de um componente genérico – o resultado.

 

Suporte a componentes jumper

Jumpers, também chamados de pontes de fio, permitem substituir o roteamento por um componente jumper, que costuma ser um elemento essencial para projetar com sucesso uma placa de face simples. O Altium Designer oferece suporte ao uso de componentes jumper por meio de um tipo especial de componente, Jumper.

Embora você possa começar posicionando os footprints dos jumpers diretamente na PCB, o fluxo de trabalho sugerido começa no esquemático. Para saber mais, consulte a página Trabalhar com componentes jumper.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents