Управление 3D-видом
Altium Essentials: PCB Introduction
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Краткий обзор
- Изучите сочетания клавиш и действия мышью для масштабирования, панорамирования, вращения и изменения ориентации печатной платы в режиме 3D Layout.
- Узнайте, как Altium Designer сохраняет и восстанавливает параметры вида при переключении между 2D и 3D и как изменить поведение по умолчанию.
- Ознакомьтесь с настройками 3D-отображения на панели View Configuration, включая проекцию, цвета, масштабирование толщины платы и видимость 3D-тел.
Редактор печатных плат представляет собой полноценное трехмерное пространство проектирования, в котором можно легко переключаться между двумерным и трехмерным режимами отображения. На этой странице описаны возможности редактора печатных плат для управления отображением платы в режиме 3D Layout.
Чтобы переключиться в трехмерный режим отображения, выберите команду View » 3D Layout Mode в главном меню, используйте сочетание клавиш 3 или переведите параметр 3D в области General Settings на вкладке View Options панели View Configuration в состояние On. Нажмите сочетание клавиш 2, чтобы вернуться в двумерный режим отображения.
Навигация по печатной плате в 3D
В режиме 3D Layout редактора печатных плат можно плавно изменять масштаб вида, вращать его и даже перемещаться внутри платы, используя различные комбинации клавиш и действий мышью. В видео ниже показаны эти приемы управления видом.
Используйте клавиши клавиатуры в сочетании с правой кнопкой мыши, чтобы изменять ориентацию 3D-вида.
Используйте следующие комбинации клавиш и действий мышью:
Вращение
| Отображение сферы направлений | Hold Shift key down При удержании клавиши Shift в текущей позиции курсора появляется сфера направлений (как показано в анимации выше). Модель вращается вокруг центра сферы, поэтому перед нажатием Shift установите курсор в точку, которая станет центром вращения. Затем используйте следующие элементы управления для вращения платы: |
| Shift + Right-drag mouse | Нажмите и удерживайте Shift, чтобы отобразить сферу, перемещайте мышь для подсветки и выбора нужного элемента управления на сфере, затем нажмите правую кнопку мыши и выполните действие Shift + Right-drag mouse:
|
| Numeric keypad | Нажимайте следующие клавиши цифровой клавиатуры:
|
Изменение ориентации вида
| Main keyboard |
|
| Numeric keypad |
|
Управление видом при переключении между режимами 2D и 3D
При нажатии сочетаний клавиш 2 и 3 для переключения между режимами 2D и 3D по умолчанию в каждом режиме сохраняется последнее использованное состояние вида. Это означает, что если в режиме 2D отображалась вся плата, а затем вы переключились в режим 3D и увеличили масштаб, то при возврате в режим 2D снова будет показана вся плата. При необходимости это поведение можно изменить, удерживая сочетание клавиш Ctrl+Alt при нажатии 2 или 3.
|
Вся плата отображается в 2D Если переключиться в 3D, а затем увеличить масштаб, то при нажатии 2 для возврата в 2D будет восстановлено последнее состояние 2D-вида (вся плата). Вместо этого удерживайте Ctrl+Alt при нажатии 2, чтобы отобразить плату в 2D с последним использованным состоянием 3D-вида. |
Настройки конфигурации 3D-вида
Режимы отображения 2D и 3D настраиваются на панели View Configuration. Чтобы открыть панель, нажмите сочетание клавиш L, используйте кнопку Panels в правом нижнем углу окна программы или выберите пункт меню View » Panels » View Configuration.
При переключении в режим 3D Layout на вкладке View Options панели View Configuration становятся доступны дополнительные параметры управления отображением платы в 3D.
Вкладка View Options панели View Configuration содержит элементы управления, предназначенные для 3D-вида.
Общие настройки
Настройки 3D
| Board thickness (Scale) | Управляет масштабом 3D-вида по вертикали, облегчая различение слоев, например при проверке межслойных соединений внутреннего глухого переходного отверстия. Прозрачность каждого 3D-слоя задается ниже; перемещая ползунок к see through, можно изменить отображение объектов на определенном слое. Перетащите ползунок толщины, чтобы задать масштаб по вертикали в диапазоне от 1 до 100 фактических толщин платы. |
| Colors – Realistic / By Layer |
По умолчанию 3D-плата отображается с использованием цветов Realistic на основе Configuration, выбранного в разделе General Settings этой панели. Нажмите кнопку By Layer, чтобы отобразить 3D-вид с использованием текущих цветов, назначенных слоям в 2D. |
| Grid |
|
| Component transparency | Прозрачность 3D-компонентов настраивается в режиме 3D Models панели PCB. Выберите один или несколько компонентов, чтобы настроить их прозрачность |
Вид 3D-платы в разрезе
Вид в разрезе позволяет виртуально рассечь плату в выбранном месте и увидеть плату и компоненты в разрезе. Используйте его для осмотра небольших компонентов, расположенных под более крупным компонентом или механической деталью, либо для изучения прохождения глухих и скрытых переходных отверстий через слои платы. Вид в разрезе создается путем задания плоскостей, в которых часть печатной платы sliced или cut away, вдоль одной, двух или трех осей платы.
Функция просмотра в разрезе доступна в режиме 3D Layout редактора печатных плат. Чтобы включить вид в разрезе, выберите команду View » Toggle Section View; нажмите кнопку
на панели Active Bar; или используйте кнопки параметра Section View на вкладке Section View панели View Configuration, чтобы переключать отображение между Edit, On и Off.
|
Edit — режим просмотра печатной платы в разрезе. On — режим просмотра печатной платы в разрезе. Off — режим просмотра печатной платы в разрезе. |
Элементы управления видом в разрезе
| Section View Origin | Когда вид в разрезе включен, текущая точка начала координат обозначается манипулятором с тремя стрелками Объекты печатной платы, расположенные за точкой начала координат (в положительном пространстве вида в разрезе), отображаются, если для вида в разрезе выбран режим Edit или On. |
| Edit | В режиме Edit плоскости сечения отображаются в рабочей области; каждая плоскость обозначается цветной полупрозрачной поверхностью, расходящейся от начала координат вида в разрезе. Положение каждой плоскости сечения можно изменить, перетаскивая соответствующую цветную стрелку манипулятора вида в разрезе. Также можно включать и отключать отдельные плоскости сечения и настраивать их направление и цвет с помощью элементов управления в нижней части панели. |
| On | Разрез применяется, а плоскости сечения скрываются. |
| Off | В этом режиме разрез не применяется. |
| Invert Cutout | По умолчанию скрывается все, что находится в отрицательном пространстве текущего вида в разрезе, то есть отображаются только объекты в его положительном пространстве. Если включен параметр Invert Cutout, это поведение меняется на противоположное: отображаются объекты в отрицательном пространстве, а объекты в положительном пространстве скрываются. |
| Plane controls | В нижней части панели расположены элементы управления плоскостями: 1) используйте флажки, чтобы включить или отключить определенную секущую плоскость, 2) щелкните образец цвета, чтобы настроить цвет этой плоскости, и 3) щелкните стрелку направления, чтобы задать направление применения плоскости |
Формирование выходных данных в 3D
На основе печатной платы можно сформировать различные виды выходных данных в 3D. В таблице ниже приведены доступные виды выходных данных, а также способы их настройки и формирования.

Снимок экрана 3D-вида, сделанный в редакторе печатных плат с разрешением 300 dpi, а затем уменьшенный в графическом редакторе до максимального размера изображения, поддерживаемого редактором этой веб-документации.
Доступные выходные данные в 3D
Тип выходных данных |
Источник |
Примечания |
| Screen capture | Редактор печатных плат | Когда редактор находится в режиме 3D-компоновки, нажмите Ctrl+C, чтобы сделать снимок экрана текущего вида. Откроется диалоговое окно 3D Snapshot Resolution, в котором выберите нужное значение Render Resolution и нажмите OK, чтобы скопировать изображение в буфер обмена Windows. Затем вставьте его в удобный вам редактор растровых изображений. |
| Export as an image | Редактор печатных плат | Выберите команду File » Export » PCB 3D Print. После выбора места сохранения файла изображения откроется диалоговое окно PCB 3D Print Settings, в котором можно задать разрешение рендеринга, вид платы и формат изображения. |
| PCB 3D Print | OutputJob | Настраивается в диалоговом окне настроек 3D-печати печатной платы. В OutputJob назначьте для выходных данных контейнер New PDF или отправьте их непосредственно на принтер. Перед формированием выходных данных расположите плату нужным образом, затем нажмите кнопки Take Current Camera Position и Take Current View Configuration, чтобы распечатать вид, отображаемый на экране. Также можно создать файл изображения, назначив для задания OutputJob контейнер вывода со структурой папок. |
| PCB 3D Video | OutputJob | Настраивается в диалоговом окне PCB 3D Video. В OutputJob назначьте для выходных данных контейнер New Video. Выходные данные могут быть представлены в различных видеоформатах. Для их формирования сначала необходимо создать 3D-видеоролик печатной платы на панели PCB 3D Movie Editor. Подробнее см. на странице Подготовка 3D-видеоролика печатной платы. |
| PDF 3D | Примечания / редактор печатных плат | Настраивается в диалоговом окне PDF3D. В OutputJob назначьте для выходных данных New Folder Structure. Для поддержки движения в 3D требуется Adobe Acrobat версии 9 или новее. Выходные данные также могут включать ключевые кадры 3D-видеоролика печатной платы, если он был создан. Подробнее см. на странице Подготовка файла PDF3D. |
| Mechanical data | Редактор печатных плат | Готовую плату также можно экспортировать в различные форматы механических данных (при необходимости — в согнутом состоянии для жестко-гибкой платы) для последующей загрузки в систему механического проектирования MCAD. Подробнее об импорте и экспорте в механических форматах. |
).
).
).


).


).
).