Bao gồm Chi tiết Thiết kế
Sơ lược
- Tìm hiểu những thông tin tài liệu PCB có thể được bổ sung trong trình biên tập PCB hoặc trình biên tập thư viện PCB, cũng như cách sử dụng các lớp cơ khí để sắp xếp chúng.
- Khám phá nội dung của Bảng cấu trúc lớp và Bảng lỗ khoan, vị trí có thể đặt các bảng này, cũng như cách chúng cập nhật hoặc phản ánh thiết kế bo mạch hiện tại.
- Nắm được các tùy chọn chính về đặt, di chuyển, thay đổi kích thước và thuộc tính để kiểm soát cách các thành phần tài liệu này hiển thị trong đầu ra PCB.
Nhiều đầu ra mà bạn tạo sẽ cần thêm các chi tiết bổ sung. Ví dụ, bản vẽ sản xuất sẽ cần kích thước, bản vẽ lắp ráp có thể cần hình phóng to của một khu vực cụ thể trên bo mạch, còn bản vẽ chế tạo sẽ cần Bảng cấu trúc lớp và Bảng lỗ khoan. Bạn có thể thêm các loại chi tiết này trong trình biên tập PCB hoặc trong trình biên tập thư viện PCB.
Các lớp bản vẽ đa dụng
Trong trình biên tập PCB, các chi tiết như kích thước và hướng dẫn chế tạo, lắp ráp được thêm trên các lớp cơ khí. Phần mềm hỗ trợ số lượng không giới hạn các lớp cơ khí đa dụng, được bật trong bảng View Configuration. Bạn có thể đặt tên cho các lớp này theo nhu cầu (nhấp chuột phải vào tên rồi chọn Edit Layer), đồng thời đưa chúng vào bản in và các đầu ra chế tạo theo lớp.
Bảng cấu trúc lớp

Bạn có thể đặt Bảng cấu trúc lớp trên tài liệu PCB bên cạnh chính thiết kế đó. Bảng này cung cấp thông tin tóm tắt chi tiết về các cấu trúc xếp lớp của bo mạch và cách phân bổ các nhóm lớp.
Bảng cấu trúc lớp là một đối tượng đồ họa dạng bảng, mô tả các lớp, vật liệu, độ dày và hằng số điện môi được sử dụng trong thiết kế PCB hiện tại. Bảng được đặt bên cạnh thiết kế bo mạch trong không gian thiết kế, đồng thời bao gồm phần chú giải đồ họa và sơ đồ thể hiện cấu trúc lớp được sử dụng trong từng vùng của bo mạch. Bảng cấu trúc lớp phản ánh các cấu hình lớp được xác định thông qua Layer Stack Manager và là một thành phần tài liệu quan trọng đối với các thiết kế có cấu trúc xếp lớp phức tạp, chẳng hạn như thiết kế mạch cứng-dẻo.
Bảng cấu trúc lớp có sẵn trong trình biên tập PCB khi chế độ xem không gian thiết kế được đặt thành chế độ 2D thông thường (phím tắt 2). Sau khi khởi chạy lệnh đặt Bảng cấu trúc lớp (Place » Layer Stack Table), con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ vào chế độ đặt Bảng cấu trúc lớp. Thực hiện theo trình tự sau để đặt bảng:
- Nhấp để đặt bảng.
- Trình biên tập vẫn ở chế độ đặt Bảng cấu trúc lớp, sẵn sàng đặt thêm bảng nếu cần. Nếu không, hãy nhấp chuột phải hoặc nhấn Esc để thoát chế độ đặt.
Các thao tác bổ sung có thể thực hiện trong quá trình đặt, khi bảng cấu trúc lớp vẫn đang di chuyển theo con trỏ và trước khi điểm tâm của bảng được cố định bao gồm:
- Nhấn phím Alt để giới hạn hướng di chuyển theo trục ngang hoặc trục dọc, tùy thuộc vào hướng di chuyển ban đầu.
- Nhấn Spacebar để xoay bảng cấu trúc lớp ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Mỗi lần xoay một góc 90°.
Để di chuyển Bảng cấu trúc lớp, hãy nhấp, giữ và kéo bảng đến vị trí mong muốn.

Chọn và kéo để thay đổi vị trí Bảng cấu trúc lớp.
Thuộc tính Bảng cấu trúc lớp

Chế độ Layer Stack Table của bảng Properties.
Vị trí
-
(X/Y)
- X (trường thứ nhất) - tọa độ X (ngang) hiện tại của điểm tham chiếu của đối tượng, so với gốc tọa độ hiện tại của không gian thiết kế. Chỉnh sửa để thay đổi vị trí X của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm theo đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Y (trường thứ hai) - tọa độ Y (dọc) hiện tại của điểm tham chiếu của đối tượng, so với gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của đối tượng. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm theo đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Rotation - góc xoay của đối tượng (tính bằng độ), đo ngược chiều kim đồng hồ từ góc 0 (phương ngang 3 o'clock). Chỉnh sửa để thay đổi góc xoay của đối tượng. Độ phân giải góc nhỏ nhất là 0,001°.
Thuộc tính
- Layer - lớp hiện được gán cho bảng. Sử dụng danh sách thả xuống để chọn một lớp khác.
- Alignment - sử dụng danh sách thả xuống để chọn cách căn chỉnh mong muốn.
-
Units - sử dụng danh sách thả xuống để chọn
Metric (mm)hoặcImperial (mil). - Show Board Map - bật để hiển thị đường bao bo mạch, thể hiện cách các cấu trúc lớp khác nhau được phân bổ cho các vùng trên bo mạch. Sử dụng thanh trượt để thay đổi tỷ lệ đường bao bo mạch được hiển thị.
- Show Total Board Thickness - bật để hiển thị tổng độ dày bo mạch bên dưới phần lưới trong bảng cấu trúc lớp.
- Line Width - chỉ định độ rộng nét chữ trong bảng. Line Width ảnh hưởng đến độ dày nét chữ.
- Text Height - chiều cao hiện tại của các ký tự văn bản. Chỉ định chiều cao chữ trong bảng. Text Height cũng ảnh hưởng đến kích thước bảng. Nếu tăng chiều cao chữ, bảng sẽ tự động mở rộng.
Loại phông chữ
-
TrueType - sử dụng trường này để chọn phông chữ TrueType cần dùng. Danh sách thả xuống Font chứa các phông chữ TrueType và OpenType (tập mở rộng của TrueType) có trong thư mục
\Windows\Fonts. Lưu ý rằng danh sách chỉ bao gồm các phông chữ gốc được phát hiện (và có tên duy nhất). Sử dụng các tùy chọn B (bold) và I (Italic) để nhấn mạnh văn bản. -
Stroke
-
Font - sử dụng trường này để chọn phông chữ nét cần dùng. Các tùy chọn gồm:
-
Default- một phông chữ vectơ đơn giản, hỗ trợ vẽ bằng bút và quang vẽ vectơ. -
Serif- một phông chữ phức tạp hơn, làm chậm quá trình tạo dữ liệu đầu ra dạng vectơ, chẳng hạn như Gerber. -
Sans Serif- một phông chữ phức tạp hơn, làm chậm quá trình tạo dữ liệu đầu ra dạng vectơ, chẳng hạn như Gerber.
-
-
Font - sử dụng trường này để chọn phông chữ nét cần dùng. Các tùy chọn gồm:
-
Stroke Width - hiển thị độ rộng nét hiện tại.
Cột
Sử dụng vùng này để chỉ định những cột bạn muốn hiển thị trong bảng xếp chồng lớp, cách căn chỉnh văn bản trong từng cột và độ rộng tổng thể của cột.
- Caption - tiêu đề cột sẽ được hiển thị.
- Align - nhấp vào ô căn chỉnh ứng với tiêu đề bạn muốn căn chỉnh. Bạn có thể nhấp liên tiếp để chuyển lần lượt qua các tùy chọn căn chỉnh (trái, giữa và phải). Mỗi lần nhấp vào trường căn chỉnh sẽ thay đổi cách căn chỉnh văn bản của cột đó trong bảng.
-
Width - nhấp vào trường này để chỉnh sửa độ rộng của cột có tiêu đề được chọn. Khi
Autođược chỉ định, hệ thống sẽ tự động điều chỉnh độ rộng cột theo văn bản được nhập trong cột đó. Bạn có thể nhập độ rộng mong muốn nếu cần. - Add - sử dụng danh sách thả xuống để thêm một cột vào bảng xếp chồng lớp từ các tùy chọn có sẵn. Trong danh sách thả xuống, nhấp vào tiêu đề bạn muốn hiển thị trong bảng.
- Up - nhấp để di chuyển cột có tiêu đề được chọn sang trái một cột trong bảng. Nhấn nút Up nhiều lần để di chuyển cột được chọn thêm nhiều cột sang trái.
- Down - nhấp để di chuyển cột có tiêu đề được chọn sang phải một cột trong bảng. Nhấn nút Down nhiều lần để di chuyển cột được chọn thêm nhiều cột sang phải.
-
- nhấp để xóa tiêu đề được chọn khỏi bảng. Một thông báo xác nhận sẽ xuất hiện trong bảng, hỏi bạn có muốn xóa mục được chọn hay không. Nhấp vào Yes nếu bạn muốn xóa; No nếu không.
Bảng lỗ khoan

Bảng lỗ khoan cung cấp thông tin tổng hợp được cập nhật trực tiếp về tất cả các lỗ khoan trên bo mạch
Bảng lỗ khoan (còn được gọi là bảng bản vẽ khoan hoặc bảng chú giải bản vẽ khoan) là một thành phần tiêu chuẩn cần có để sản xuất bo mạch in. Bảng lỗ khoan liệt kê kích thước và số lượng lỗ cho từng mũi khoan được sử dụng trên bo mạch. Mỗi kích thước mũi khoan có thể được biểu diễn bằng một ký hiệu, một chữ cái hoặc kích thước lỗ thực tế. Khi bản vẽ khoan được tạo cho bo mạch, mỗi vị trí khoan thực tế đều được đánh dấu bằng một ký hiệu. Bảng lỗ khoan được cập nhật theo thời gian thực, nghĩa là khi các đối tượng có lỗ như pad và via được đặt vào hoặc xóa khỏi thiết kế PCB, bảng sẽ cập nhật.
Bảng lỗ khoan chỉ có thể được đặt trong trình biên tập PCB. Sau khi khởi chạy lệnh, một bảng lỗ khoan sẽ xuất hiện gắn với con trỏ. Đưa bảng đến vị trí phù hợp bên ngoài bo mạch, sau đó nhấp chuột hoặc nhấn Enter để đặt bảng.
Các thao tác bổ sung có thể thực hiện trong quá trình đặt, khi bảng lỗ khoan vẫn đang đi theo con trỏ và chưa được cố định gồm:
- Nhấn phím Tab để tạm dừng việc đặt và truy cập chế độ Bảng lỗ khoan của bảng Properties , nơi bạn có thể thay đổi các thuộc tính ngay trong quá trình đặt. Nhấp vào nút tạm dừng hiển thị đè để tiếp tục đặt.
- Nhấn phím Alt để giới hạn hướng di chuyển theo trục ngang hoặc trục dọc tùy theo hướng di chuyển ban đầu.
Di chuyển bảng lỗ khoan
Nhấp và giữ tại vị trí bất kỳ trong bảng lỗ khoan rồi di chuyển bảng đến vị trí mong muốn trong không gian thiết kế của trình biên tập PCB.
Thay đổi kích thước bảng lỗ khoan bằng thao tác tương tác
Bảng lỗ khoan được tự động xác định kích thước dựa trên thiết lập Text Height đã chỉ định, cũng như số lượng kích thước lỗ khác nhau (hàng) và số cột đã định nghĩa. Để thay đổi kích thước bảng bằng thao tác tương tác, nhấp một lần để chọn bảng, sau đó nhấp và giữ một đỉnh góc rồi di chuyển để thay đổi kích thước theo yêu cầu. Lưu ý rằng việc thay đổi kích thước bảng bằng thao tác tương tác cũng sẽ làm tăng/giảm kích thước phông chữ.
Chuyển đổi cặp lớp để xem trước bằng thao tác tương tác
Khi bo mạch có các cặp lớp, cặp lớp được hiển thị do tùy chọn Layers Pairs trong chế độ Drill Table của bảng Properties điều khiển.
Cặp lớp đã chọn này cũng có thể được chuyển đổi bằng:
-
Menu chuột phải của trình biên tập PCB - nhấp chuột phải vào bảng lỗ khoan rồi chọn cặp lớp cần thiết trong menu con Drill Table như hình bên dưới.

Nhấp chuột phải vào bảng lỗ khoan để chuyển sang hiển thị một cặp lớp khác -
Menu chọn cặp lớp được truy cập qua thẻ lớp ở cuối không gian thiết kế như hình bên dưới.
Thuộc tính bảng lỗ khoan

Chế độ Drill Table của bảng Properties
Thao tác
Refresh – nhấp vào nút để cập nhật bảng lỗ khoan bằng dữ liệu ký hiệu lỗ khoan hiện tại từ PCB.
Vị trí
-
(X/Y) – tọa độ X và Y hiện tại của điểm tham chiếu của Bảng khoan. Điểm tham chiếu là góc dưới bên trái nếu Alignment =
Bottom, hoặc góc trên bên trái nếu Alignment =Top. - Rotation – góc xoay của Bảng khoan, tính bằng độ.
Thuộc tính
-
Layer Pairs – bảng khoan hỗ trợ các bo mạch nhiều lớp sử dụng phương pháp khoan theo cặp lớp. Sử dụng danh sách thả xuống để chọn một cặp lớp được xác định trên tab Via Types của Layer Stack Manager hoặc một trong các tùy chọn sau:
- All Layer Pairs (Composite table) – hiển thị thông tin cho tất cả các cặp lớp.
-
All Layer Pairs (Separate tables) – hiển thị thông tin cho từng cặp lớp trong một bảng riêng.
- Top - Bottom – chỉ hiển thị các lỗ xuyên.
- Counterhole Bottom – chỉ hiển thị các lỗ khoét bậc/khoét côn ở mặt dưới của PCB.
- Counterhole Top – chỉ hiển thị các lỗ khoét bậc/khoét côn ở mặt trên của PCB.
- Text Height – hiển thị chiều cao văn bản.
Loại phông chữ
-
TrueType – chọn để sử dụng các phông chữ có trên máy tính của bạn (trong thư mục \Windows\Fonts). Phông chữ TrueType hỗ trợ đầy đủ Unicode. Theo mặc định, phần mềm liên kết đến phông chữ TrueType được sử dụng (phông chữ không được lưu trong tệp PCB), nghĩa là mỗi máy tính mà thiết kế được chuyển đến đều phải có cùng phông chữ đó. Ngoài ra, bạn có thể nhúng các phông chữ TrueType được sử dụng vào tệp PCB bằng các tùy chọn trên trang PCB Editor – True Type Fonts của hộp thoại Preferences, tại đây bạn cũng có thể chọn một Substitution Font để sử dụng khi phông chữ không được nhúng không có sẵn.
- Font – sử dụng danh sách thả xuống để chọn phông chữ TrueType mong muốn. Sử dụng B để in đậm hoặc I để in nghiêng văn bản.
-
Stroke
-
Font – sử dụng danh sách thả xuống để chọn phông chữ nét mong muốn. Các lựa chọn gồm:
-
Default– phông chữ vectơ đơn giản được thiết kế để vẽ bằng bút và vẽ quang vectơ. -
Sans Serif -
Serif
-
- Stroke Width – hiển thị độ rộng nét.
-
Font – sử dụng danh sách thả xuống để chọn phông chữ nét mong muốn. Các lựa chọn gồm:
- Show Footer – bật/tắt hiển thị chân bảng.
- Alignment – bảng có thể được tạo từ dưới lên (Bottom) hoặc từ trên xuống (Top). Sử dụng cài đặt này để cho phép thay đổi kích thước bảng mà không ảnh hưởng đến các đối tượng xung quanh trong không gian thiết kế.
- Table Border Width – độ rộng của các đường dùng để tạo đường viền bảng.
-
Drill Symbols – nhấp để mở hộp thoại Drill Symbols, trong đó bạn có thể gán ký hiệu/chữ cái cho các kích thước lỗ.
Các tùy chọn và điều khiển trong hộp thoại Ký hiệu khoan
Grid Area
Vùng lưới hiển thị thông tin chi tiết về việc ánh xạ ký hiệu với kích thước lỗ. Bạn có thể tùy chỉnh bằng cách nhấp và kéo tiêu đề cột để thay đổi thứ tự các cột, cũng như nhấp chuột phải vào tiêu đề cột rồi chọn/bỏ chọn hộp kiểm để hiện/ẩn cột.
Grouping
Nhấp vào nút Grouping để thiết lập các thuộc tính được dùng nhằm kiểm soát việc gán ký hiệu cho các đối tượng khoan (lỗ). Ban đầu, các lỗ được nhóm theo kích thước, sau đó được gán các ký hiệu riêng khi bật một tùy chọn phân nhóm giúp phân biệt chúng. Ví dụ: thiết kế có thể bao gồm một pad tròn có lỗ 1 mm và một pad vuông khác cũng có lỗ 1 mm. Nếu Pad Shape không được bật trong Grouping, chúng sẽ được gán cùng một ký hiệu. Nhưng nếu Pad Shape được bật trong Grouping, chúng sẽ được gán các ký hiệu riêng.
Graphic Symbol
Mỗi vị trí lỗ có thể được biểu diễn bằng một ký hiệu, một chữ cái hoặc một chuỗi thể hiện kích thước lỗ thực tế. Các tùy chọn sau kiểm soát kiểu và kích thước ký hiệu:
-
Symbol - chọn để sử dụng một ký hiệu tại mỗi vị trí lỗ. Phần mềm bao gồm 15 kiểu ký hiệu được xác định sẵn như minh họa trong hình bên dưới. Nếu có hơn 15 kích thước lỗ, các chữ cái sẽ được tự động gán.
- Character - chọn để sử dụng một chữ cái tại mỗi vị trí lỗ.
- Symbol Size - chiều cao của ký hiệu/chữ cái hiển thị trên lớp Drill Drawing. Lưu ý rằng cài đặt này áp dụng cho tất cả các ký hiệu/chữ cái được sử dụng trên bản vẽ khoan.
Draw Symbols
Các tùy chọn sau kiểm soát kiểu ký hiệu khoan và thời điểm hiển thị:
- Show Symbols - hiển thị một ký hiệu tại mỗi vị trí lỗ.
- Show Hole Size - hiển thị kích thước khoan thực tế tại mỗi vị trí lỗ dưới dạng giá trị số.
- Show Drill Symbols - theo mặc định, các ký hiệu khoan không được hiển thị trên lớp Drill Drawing. Bật tùy chọn này để hiển thị các ký hiệu khoan.
-
-
– nhấp để làm mới bảng mỗi khi có thay đổi thiết kế ảnh hưởng đến bảng khoan. Lưu ý rằng bảng được tự động cập nhật trong quá trình tạo đầu ra.
Đơn vị
-
Primary Units – sử dụng danh sách thả xuống để đặt đơn vị chính là
Metric (mm)hoặcImperial (mil). -
Dual Units – sử dụng danh sách thả xuống để đặt đơn vị phụ là
Metric (mm)hoặcImperial (mil). Sử dụng
hoặc
để xác định các đơn vị này được hiển thị hay ẩn (tương ứng) trong không gian thiết kế.
Độ chính xác
- Primary Precision – sử dụng danh sách thả xuống để đặt độ chính xác cần thiết (số chữ số sau dấu thập phân).
- Dual Precision – sử dụng danh sách thả xuống để đặt độ chính xác cho đơn vị phụ (số chữ số sau dấu thập phân).
Cột
- Grid – hiển thị tất cả tiêu đề cột (Caption) trong bảng lỗ khoan, thiết lập Align dùng để định vị lại nội dung trong lưới, Width và Order mà thông tin trong mỗi cột được hiển thị. Để chuyển từ thứ tự tăng dần sang giảm dần và ngược lại, nhấp vào cột Order để mở menu thả xuống rồi chọn thứ tự mong muốn: Asc – tăng dần hoặc Dsc – giảm dần.
-
Edit Columns – nhấp để mở hộp thoại Columns, cho phép thêm cột mới vào bảng lỗ khoan hoặc chỉnh sửa các cột hiện có.
Hộp thoại hiển thị tất cả các cột hiện có cùng với dữ liệu liên quan (chỉ đọc). Sử dụng các nút sau bên dưới lưới để lựa chọn và điều chỉnh dữ liệu sẽ hiển thị trong bảng:
- Add Column - dùng để thêm cột mới vào bảng lỗ khoan. Nhấp để mở menu các cột có sẵn. Các cột đã được sử dụng hoặc không khả dụng sẽ bị làm mờ trong menu. Lệnh này cũng có trong menu chuột phải.
- Remove Column - nhấp để xóa (các) cột đã chọn. Lưu ý rằng không có hộp thoại xác nhận; cột sẽ bị xóa ngay khi nhấp vào nút. Lệnh này cũng có trong menu chuột phải.
- Change Header - nhấp để mở hộp thoại Thay đổi tiêu đề cột, trong đó bạn có thể thay đổi tiêu đề của cột đã chọn. Lệnh này (có tên Change column header) cũng có trong menu chuột phải.
Các lệnh bổ sung sau có trong menu ngữ cảnh khi nhấp chuột phải:
-
Text Alignment - dùng để căn chỉnh văn bản trong cột đã chọn. Các lựa chọn bao gồm:
Left,CentervàRight. -
Set column width - dùng để thiết lập độ rộng của cột đã chọn. Các lựa chọn bao gồm:
Autosize(mặc định) vàManual. Nhấp vàoManualđể mở hộp thoại Thiết lập độ rộng cột, trong đó bạn có thể nhập độ rộng mong muốn.
Khung nhìn thiết kế

Đặt một Khung nhìn thiết kế để hiển thị một vùng cụ thể của bo mạch. Ví dụ này đã được phóng to lên 200%.
Đối tượng Khung nhìn thiết kế PCB là ảnh chụp đồ họa của một vùng hình chữ nhật bất kỳ trên bo mạch hiện tại hoặc một bo mạch khác. Có thể đặt đối tượng này ở bất kỳ đâu trong không gian thiết kế và thay đổi tỷ lệ đến kích thước bất kỳ.
Chỉ có thể đặt Khung nhìn thiết kế trong Trình biên tập PCB. Sau khi khởi chạy lệnh đặt Khung nhìn thiết kế (Place » Design View), một khung nhìn thiết kế sẽ xuất hiện gắn với con trỏ. Di chuyển khung nhìn thiết kế đến vị trí phù hợp rồi nhấp chuột hoặc nhấn Enter để đặt.
Các thao tác bổ sung có thể thực hiện trong quá trình đặt, khi khung nhìn thiết kế vẫn đang di chuyển theo con trỏ và chưa được cố định bao gồm:
- Nhấn phím Alt để giới hạn hướng di chuyển theo trục ngang hoặc trục dọc, tùy theo hướng di chuyển ban đầu.
Sau khi đặt khung nhìn thiết kế, bạn có thể xác định cách hiển thị các lớp mong muốn bằng các bước sau:
- Chọn Khung nhìn thiết kế trong không gian thiết kế, mở bảng Thuộc tính bằng cách nhấp đúp hoặc nhấp chuột phải rồi chọn Properties từ menu ngữ cảnh.
- Sử dụng nút Define trong bảng Properties để xác định vùng quan tâm một cách tương tác.
-
Trong phần Layers của bảng Properties , nhấp (bật/tắt) biểu tượng
để bật hiển thị các lớp mong muốn. Khi được bật trong bảng Properties , (các) lớp mong muốn sẽ hiển thị biểu tượng
.
Khung nhìn thiết kế được đưa vào bản in và đầu ra PDF. Khung nhìn thiết kế giữ nguyên các thiết lập hiển thị lớp riêng trong đầu ra, cho phép hiển thị theo yêu cầu trong bản in/PDF. Lưu ý rằng các đối tượng cơ bản trên những lớp được sử dụng trong Khung nhìn thiết kế vẫn tuân theo thiết lập hiển thị được xác định cho lớp đó trong hộp thoại In. Ví dụ: nếu lớp Top Overlay được hiển thị trong Khung nhìn thiết kế và được cấu hình để hiển thị các đường mạch ở chế độ Draft cho đầu ra đó trong Output Job, thì các đường mạch Top Overlay trong Khung nhìn thiết kế cũng sẽ hiển thị ở chế độ Draft.
Sau khi đặt Khung nhìn thiết kế trong không gian thiết kế, bạn có thể tương tác để điều chỉnh vị trí, tỷ lệ, kích thước và vùng hiển thị của khung nhìn.
- Change the position – Click+Drag đối tượng Khung nhìn thiết kế đến vị trí mới trong không gian thiết kế PCB.
- Adjusting the Scale – nhấp một lần để chọn Khung nhìn thiết kế rồi Click+Drag tại một nút điều chỉnh ở góc để phóng to (kéo ra ngoài) hoặc thu nhỏ (kéo vào trong) Khung nhìn thiết kế.
- Adjusting the View Size – nhấp một lần để chọn Khung nhìn thiết kế rồi Ctrl+Click+Drag tại một nút điều chỉnh ở góc để thay đổi kích thước Khung nhìn thiết kế.
- Changing the Focus – Ctrl+Click+Drag ở bất kỳ đâu bên trong Khung nhìn thiết kế để dịch chuyển vùng đang xem trong cửa sổ Khung nhìn thiết kế.

Ctrl+Click+Drag để dịch chuyển và điều chỉnh vùng đang được xem trong Khung nhìn thiết kế.
Thuộc tính Khung nhìn thiết kế

Chế độ Design View của bảng Properties.
Vị trí
- (X/Y) - tọa độ X và Y hiện tại của điểm tham chiếu Khung nhìn thiết kế.
Thuộc tính
- This document - chọn để chỉ định các thuộc tính cho tài liệu hiện đang hoạt động.
-
Specify document - chọn để chỉ định các thuộc tính cho một tài liệu khác. Khi được chọn, nhấp vào
trong trường Document rồi duyệt tìm tài liệu mong muốn.
-
Document - nhấp vào
để tìm và chọn tài liệu mong muốn khi Specify document được chọn.
- Mirrored - nhấp để bật hình ảnh lật (đối xứng gương) của vùng bo mạch trong Khung nhìn thiết kế.
- Scale - nhấp để xác định kích thước đối tượng theo hệ số nhân.
- Title - nhập tiêu đề của Khung nhìn thiết kế.
- Text Height - nhập chiều cao chữ tiêu đề của Khung nhìn thiết kế.
- Font - sử dụng menu thả xuống để chọn phông chữ mong muốn cho tiêu đề. Sử dụng ô màu để mở bộ chọn màu cho văn bản tiêu đề. Lưu ý rằng màu chữ phải tương phản với màu nền của không gian thiết kế để dễ nhìn.
- Define - nhấp để quay lại không gian thiết kế với con trỏ hình chữ thập, sau đó nhấp và kéo để xác định vùng hình chữ nhật của khung nhìn.
Các lớp
Vùng này cung cấp danh sách tất cả các lớp của bo mạch, cho phép cấu hình để hiển thị các lớp cụ thể trong Khung nhìn thiết kế.
-
Name - tên của lớp. Sử dụng
hoặc
để lần lượt hiển thị hoặc ẩn lớp được liệt kê trong Chế độ xem thiết kế.
- Type - loại lớp.
Đối tượng OLE

Một chuỗi đối tượng OLE đã được đặt – hình ảnh, các ô bảng tính và văn bản tài liệu Word (từ trên xuống dưới)
Công nghệ Liên kết và Nhúng Đối tượng (OLE) trong trình chỉnh sửa PCB cho phép nhúng dữ liệu do các ứng dụng OLE trên Windows cung cấp vào thiết kế PCB, đồng thời duy trì liên kết với ứng dụng nguồn. Trong nhiều trường hợp, điều này cho phép chỉnh sửa dữ liệu PCB đã nhúng ngay trong ứng dụng đã tạo ra dữ liệu đó.
Các đối tượng OLE thường được đặt trong tài liệu PCB bao gồm tài liệu Excel, tài liệu Word hoặc các đối tượng đồ họa từ một ứng dụng hình ảnh hỗ trợ OLE phù hợp. Các loại tệp được hỗ trợ bao gồm những định dạng phổ biến như bảng tính CSV và XLS, tài liệu văn bản DOC và RTF, cùng tệp hình ảnh BMP.
Có thể đặt/nhúng các đối tượng OLE trong Trình chỉnh sửa PCB. Sau khi khởi chạy lệnh Place » Object From File, chọn tệp mong muốn từ hộp thoại Choose File, rồi nhấp để đặt đối tượng vào không gian thiết kế.
Tính năng Dán thông minh của Altium cũng cho phép sao chép một vùng chọn trong ứng dụng OLE và dán (Edit » Paste) vào tài liệu PCB dưới dạng đối tượng OLE. Có thể sử dụng tùy chọn dán văn bản (Edit » Paste Text) để tách các thành phần văn bản từ đối tượng OLE nếu cần. Các thành phần này sẽ được đặt dưới dạng đối tượng văn bản PCB.
Sau khi đặt, có thể thay đổi kích thước theo tỷ lệ của các đối tượng được nhúng bằng cách nhấp, giữ và kéo các điểm điều khiển của vùng chọn. Với các đối tượng dựa trên văn bản như tài liệu Word và Excel, kích thước và độ dày nét của văn bản được nhúng sẽ tự động điều chỉnh theo kích thước mới.
- Cũng có thể chuyển đổi một Đối tượng OLE thành một tập hợp các đối tượng cơ bản độc lập bằng lệnh Tools » Convert » Explode OLE Object to Free Primitives. Thao tác này sẽ tách đối tượng thành các đối tượng Vùng và/hoặc Văn bản phù hợp.
- Tùy chọn chuyển đổi thành các đối tượng cơ bản độc lập cũng được cung cấp nếu không tìm thấy ứng dụng OLE tương ứng khi bạn cố chỉnh sửa một Đối tượng OLE.
Thuộc tính đối tượng OLE

Chế độ OLE Object của bảng Properties.
Vị trí
- (X/Y) - tọa độ X (ngang) và tọa độ Y (dọc) hiện tại của điểm tham chiếu của đối tượng so với gốc tọa độ hiện tại của không gian thiết kế. Chỉnh sửa để thay đổi vị trí của đối tượng.
- Rotation - góc xoay của đối tượng (tính bằng độ), được đo ngược chiều kim đồng hồ từ góc không (phương ngang 3 o'clock). Chỉnh sửa để thay đổi góc xoay của đối tượng. Độ phân giải góc tối thiểu là 0,001°.
Thuộc tính
- Layer - lớp hiện đang được gán cho đối tượng. Sử dụng danh sách thả xuống để chọn một lớp khác.
- Edit Data - nhấp để mở đối tượng (trong ứng dụng liên kết) và thực hiện các chỉnh sửa cần thiết. Sau khi chỉnh sửa và đóng ứng dụng liên kết, trong bảng Thuộc tính, nhấp Save để lưu các chỉnh sửa hoặc Cancel.
Kích thước
Các trình chỉnh sửa PCB và Thư viện PCB cung cấp nhiều công cụ ghi kích thước để đáp ứng các yêu cầu thiết kế khác nhau.
| Đối tượng ghi kích thước | Mô tả |
|---|---|
| Angular Dimension | Cho phép ghi kích thước góc. |
| Baseline Dimension | Cho phép ghi kích thước khoảng cách tuyến tính của một tập hợp điểm tham chiếu so với một điểm tham chiếu gốc duy nhất. Điểm được chọn đầu tiên là 'gốc'. Tất cả các điểm tiếp theo đều được tham chiếu đến điểm đầu tiên này. Do đó, giá trị kích thước trong mỗi trường hợp là khoảng cách giữa từng điểm tham chiếu và 'gốc', được đo theo đơn vị mặc định. Các đối tượng tham chiếu có thể là đường mạch, cung tròn, pad, via, văn bản, vùng tô, đa giác hoặc linh kiện. |
| Center Dimension | Cho phép đánh dấu tâm của cung tròn hoặc đường tròn. |
| Leader Dimension | Cho phép gắn nhãn cho một đối tượng, điểm hoặc vùng. Có ba kiểu đường dẫn chú thích: Tự động, Tròn và Vuông, tương ứng với việc văn bản nhãn được bao trong hình tròn, hình vuông hoặc không có khung bao. Đầu chỉ có thể là mũi tên hoặc dấu chấm. |
| Linear Dimension | Cho phép ghi kích thước khoảng cách tuyến tính. Giá trị kích thước là khoảng cách giữa dấu mốc bắt đầu và kết thúc (các điểm tham chiếu do người dùng chọn), được đo theo đơn vị mặc định. Các tham chiếu có thể là đối tượng (đường mạch, cung tròn, pad, via, văn bản, vùng tô, đa giác hoặc linh kiện) hoặc các điểm trong không gian trống. |
| Linear Diameter Dimension | Cho phép ghi kích thước đường kính của cung tròn hoặc đường tròn thay vì bán kính. Kích thước có thể được đặt ở bên trong hoặc bên ngoài. |
| Ordinate Dimension | Cho phép ghi kích thước khoảng cách tuyến tính của một tập hợp đối tượng so với một đối tượng tham chiếu duy nhất. Đối tượng được chọn đầu tiên là 'gốc'. Tất cả các đối tượng tiếp theo đều được tham chiếu đến đối tượng đầu tiên này. Do đó, giá trị kích thước trong mỗi trường hợp là khoảng cách giữa từng đối tượng tham chiếu và 'gốc', được đo theo đơn vị mặc định. Các đối tượng tham chiếu có thể là đường mạch, cung tròn, pad, via, văn bản, vùng tô, đa giác hoặc linh kiện. |
| Radial Dimension | Cho phép ghi kích thước bán kính của cung tròn hoặc đường tròn. Kích thước có thể được đặt ở bên trong hoặc bên ngoài. |
| Radial Diameter Dimension | Cho phép ghi kích thước đường kính của cung tròn hoặc đường tròn thay vì bán kính. Kích thước có thể được đặt ở bên trong hoặc bên ngoài so với chu vi của cung tròn/đường tròn. |
| Standard Dimension | Đặt thông tin kích thước trên lớp PCB hiện tại. Giá trị kích thước là khoảng cách giữa dấu mốc bắt đầu và kết thúc, được đo theo đơn vị mặc định. |
Các đối tượng ghi kích thước có trong menu con Place » Dimension của các menu chính. Khi ghi kích thước cho một đối tượng, các điểm neo sẽ xuất hiện và được tô sáng để chỉ ra nơi có thể gắn kích thước. Thanh trạng thái hiển thị thông tin về những thao tác cần thực hiện ở từng bước trong suốt quá trình. Điểm gần con trỏ nhất sẽ là điểm được sử dụng và là nơi gắn kích thước nếu bạn nhấp chuột hoặc nhấn Enter.
Video bên dưới minh họa cách đặt một số kích thước.
Các thao tác bổ sung có thể thực hiện trong khi đặt bao gồm:
- Nhấn các phím + và - (trên bàn phím số) để lần lượt chuyển tiến và lùi qua tất cả các lớp đang hiển thị trong thiết kế – giúp thay đổi nhanh lớp đặt đối tượng.
- Khi đặt kích thước theo đường chuẩn, kích thước tâm, kích thước đường kính tuyến tính, kích thước tuyến tính hoặc kích thước tọa độ, nhấn Spacebar để xoay kích thước ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Góc xoay tuân theo giá trị của Rotation Step được xác định trên trang PCB Editor – General của hộp thoại Preferences.
- Khi đặt kích thước tiêu chuẩn, nhấn phím L để lật kích thước sang mặt còn lại của bo mạch – lưu ý rằng thao tác này chỉ thực hiện được trước khi cố định điểm đầu của kích thước.
Giá trị của kích thước (nếu có) tự động cập nhật khi điểm đầu hoặc điểm cuối của kích thước được di chuyển. Tương tự, nếu vị trí của đối tượng mà điểm tham chiếu của kích thước được cố định vào thay đổi, kích thước sẽ cập nhật và giãn/co để phản ánh thay đổi đó. Với kích thước dựa trên bán kính/đường kính, giá trị sẽ tự động cập nhật khi đường kính của cung tròn hoặc đường tròn tham chiếu thay đổi.
Khi các đối tượng tham chiếu mà đối tượng kích thước được gắn vào bị xóa, một hộp thoại sẽ mở ra để hỏi có xóa cả kích thước hay không. Nếu không bị xóa, kích thước vẫn nằm trong không gian thiết kế nhưng không còn liên kết tham chiếu.
Có thể di chuyển đối tượng kích thước theo các cách sau:
- Selecting both the dimension object and the dimensioned object(s). Có thể kéo toàn bộ đối tượng đến vị trí mới theo yêu cầu.
- Selecting a dimensioned object only. Nội dung kích thước chỉ di chuyển theo đối tượng trong mặt phẳng căn chỉnh của nó. Các đường gióng kích thước (hoặc mũi tên chỉ và đuôi đối với kích thước đường kính hướng tâm hoặc kích thước bán kính) sẽ giãn/co để duy trì mối quan hệ giữa kích thước và đối tượng được ghi kích thước. Với kích thước tâm hoặc kích thước đường dẫn, kích thước sẽ di chuyển cùng đối tượng. Đoạn của kích thước đường dẫn (giữa mũi tên/chấm và điểm gấp khúc đầu tiên được xác định) sẽ giãn/co để duy trì mối quan hệ giữa kích thước và đối tượng được ghi kích thước.
- Selecting the dimension object only. Cần lưu ý rằng không thể di chuyển riêng kích thước nếu kích thước đó đang liên kết tham chiếu với một đối tượng thiết kế. Để chỉ di chuyển kích thước, trước tiên phải tách kích thước khỏi các đối tượng mà nó đang ghi kích thước.
Khi chọn một đối tượng kích thước, các điểm điều khiển chỉnh sửa sẽ xuất hiện, cho phép bạn chỉnh sửa trực tiếp đối tượng kích thước đã đặt trong không gian thiết kế bằng cách thay đổi các thuộc tính như vị trí nội dung và các điểm tham chiếu bằng thao tác đồ họa. Ví dụ về các điểm điều khiển chỉnh sửa của một số loại kích thước được minh họa bên dưới.
|
Khi chọn một đối tượng kích thước tuyến tính, các điểm điều khiển chỉnh sửa sau sẽ xuất hiện:
Khi chọn một đối tượng kích thước góc, các điểm điều khiển chỉnh sửa sau sẽ xuất hiện:
Khi chọn một đối tượng kích thước bán kính, các điểm điều khiển chỉnh sửa sau sẽ xuất hiện:
Khi chọn một đối tượng kích thước tọa độ, các điểm điều khiển chỉnh sửa sau sẽ xuất hiện.
|
Các điểm điều khiển nằm trên (hoặc gần nhất với) các đối tượng được ghi kích thước (ví dụ: C và D đối với kích thước tuyến tính hoặc C & E và D & F đối với kích thước góc, như minh họa ở trên) cho phép xác định lại các tham chiếu – sau khi kích thước được tách khỏi một đối tượng tham chiếu, nó không còn liên kết tham chiếu và có thể được di chuyển để gắn vào một điểm hoặc đối tượng tham chiếu khác. Khi kéo bất kỳ điểm điều khiển chỉnh sửa nào của kích thước tuyến tính, kích thước tọa độ hoặc kích thước theo đường chuẩn không có liên kết tham chiếu, bạn có thể xoay kích thước đó.
Thuộc tính của đối tượng kích thước
Kích thước có nhiều tùy chọn cấu hình, cho phép tùy chỉnh linh hoạt mũi tên và nội dung. Mở bảng Properties cho một hoặc nhiều đối tượng kích thước đã chọn để chỉnh sửa thuộc tính của chúng.
| Thuộc tính | Áp dụng cho đối tượng | Mô tả |
|---|---|---|
Kiểu |
||
| Width | Tất cả, ngoại trừ kích thước tâm và kích thước tọa độ | Độ rộng hiện tại của đường kích thước. |
| Width (trong vùng Extension Line) | Kích thước góc Kích thước theo đường chuẩn Kích thước tuyến tính Kích thước đường kính tuyến tính Kích thước tọa độ |
Độ rộng hiện tại của các đường gióng kích thước. |
| Gap | Kích thước góc Kích thước theo đường chuẩn Kích thước đường dẫn Kích thước tuyến tính Kích thước đường kính tuyến tính Kích thước tọa độ |
|
| Offset | Kích thước góc Kích thước theo đường chuẩn Kích thước tuyến tính Kích thước đường kính tuyến tính |
Độ lệch hiện tại của đường mũi tên so với đường gióng kích thước. |
| Text Gap | Tất cả, ngoại trừ kích thước tâm và kích thước tiêu chuẩn |
|
| Leader Shape | Kích thước có đường dẫn | Sử dụng danh sách thả xuống để xác định hình dùng để bao quanh văn bản kích thước. Các tùy chọn có sẵn là Automatic, Round và Square. Nếu chọn Round hoặc Square, hãy nhập Size mong muốn. |
| Arrow Style | Kích thước có đường dẫn | Sử dụng danh sách thả xuống để chọn kiểu đường dẫn mong muốn. Các lựa chọn là Arrow hoặc Dot. Nhập Size mong muốn. |
| Height | Kích thước tiêu chuẩn | Chiều cao hiện tại của đường gióng. |
| Arrow Size | Kích thước góc Kích thước đường cơ sở Kích thước tuyến tính Kích thước đường kính tuyến tính Kích thước bán kính Kích thước đường kính hướng tâm |
Kích thước hiện tại của đầu mũi tên. Kích thước được đo bằng khoảng cách từ đỉnh mũi tên đến điểm cuối của các “chân” mũi tên. |
| Arrow Length | Kích thước góc Kích thước đường cơ sở Kích thước tuyến tính Kích thước đường kính tuyến tính Kích thước bán kính Kích thước đường kính hướng tâm |
Chiều dài hiện tại của mũi tên. Lưu ý rằng giá trị nhập vào trường này chỉ được áp dụng khi Arrow Position (trong vùng Properties ) được đặt thành Outside. |
Thuộc tính |
||
| Text | Kích thước có đường dẫn | Nhập văn bản mong muốn. |
| Layer | Tất cả | Lớp mà kích thước hiện được gán vào. Sử dụng danh sách thả xuống để chọn lớp mong muốn. Có thể gán kích thước vào bất kỳ lớp nào có sẵn. |
| Text Position | Tất cả, ngoại trừ kích thước tâm và kích thước tiêu chuẩn | Vị trí hiện tại của văn bản kích thước. Sử dụng danh sách thả xuống tương ứng để chọn một trong các tùy chọn sau (các tùy chọn có sẵn phụ thuộc vào loại đối tượng kích thước):
|
| Arrow Position | Kích thước góc Kích thước đường cơ sở Kích thước tuyến tính Kích thước đường kính tuyến tính Kích thước bán kính Kích thước đường kính hướng tâm |
Vị trí hiện tại của các mũi tên kích thước. Các tùy chọn có sẵn là:
|
| Angular Step | Kích thước đường kính hướng tâm | Thiết lập bước góc hiện tại cho kích thước. Đây là bước xoay được sử dụng khi đặt phần mũi tên của kích thước. Khi di chuyển mũi tên quanh đường tròn hoặc cung tròn trong lúc đặt kích thước, số lượng và vị trí các điểm có thể neo kích thước được xác định bởi giá trị bước góc này. |
| Text Height | Tất cả, ngoại trừ kích thước tâm | Chiều cao hiện tại của các ký tự trong văn bản kích thước. Chiều rộng ký tự dùng để hiển thị hoặc in văn bản được tự động điều chỉnh theo tỷ lệ với chiều cao này. Chiều cao tối thiểu 36mil (0.9mm) sẽ cho phép văn bản được vẽ quang học rõ ràng, dễ đọc. |
| Rotation | Kích thước tâm Kích thước tuyến tính Kích thước đường kính tuyến tính Kích thước tọa độ |
Góc căn chỉnh của kích thước, tính bằng độ theo chiều ngược kim đồng hồ so với phương ngang. |
| Size | Kích thước tâm | Chiều dài hiện tại của các đường chữ thập của kích thước (hoặc đường kính của đường tròn bao quanh). |
| Font Type | Tất cả, ngoại trừ kích thước tâm |
|
Đơn vị |
||
| Primary Units | Kích thước góc Kích thước theo đường cơ sở Kích thước tuyến tính Kích thước đường kính tuyến tính Kích thước tọa độ Kích thước bán kính Kích thước đường kính hướng tâm |
Đơn vị hiện được chọn để tính toán và hiển thị giá trị kích thước.
|
| Value Precision | Kích thước góc Kích thước theo đường cơ sở Kích thước tuyến tính Kích thước đường kính tuyến tính Kích thước tọa độ Kích thước bán kính Kích thước đường kính hướng tâm |
Thiết lập hiện tại cho số chữ số thập phân ở bên phải dấu thập phân khi hiển thị kích thước. |
Giá trị |
||
| Format | Tất cả, ngoại trừ Kích thước tâm và Kích thước đường dẫn |
Thiết lập hiện tại cho định dạng văn bản kích thước. Sử dụng danh sách thả xuống tương ứng để thay đổi định dạng theo yêu cầu. Các tùy chọn được liệt kê sẽ phụ thuộc vào Unit đã chọn và được hiển thị dựa trên giá trị thực tế của kích thước hiện tại. Nhìn chung, các tùy chọn khả dụng là (tập hợp các tùy chọn khả dụng phụ thuộc vào loại đối tượng kích thước):
|
| Prefix | Kích thước góc Kích thước theo đường cơ sở Kích thước tuyến tính Kích thước đường kính tuyến tính Kích thước tọa độ Kích thước bán kính Kích thước đường kính hướng tâm |
Tiền tố của giá trị kích thước. Đối với Kích thước đường kính tuyến tính hoặc Kích thước đường kính hướng tâm, trường này được cố định bằng ký tự ø. |
| Suffix | Kích thước góc Kích thước theo đường cơ sở Kích thước tuyến tính Kích thước đường kính tuyến tính Kích thước tọa độ Kích thước bán kính Kích thước đường kính hướng tâm |
Hậu tố của giá trị kích thước. |
| Sample | Tất cả, ngoại trừ Kích thước tâm và Kích thước đường dẫn |
Trường này hiển thị mẫu văn bản kích thước theo Format đã chỉ định và mọi Prefix và/hoặc Suffixđã xác định. |
| Start point (X/Y) | Kích thước tiêu chuẩn | Điểm bắt đầu của kích thước theo X (giá trị thứ nhất) và Y (giá trị thứ hai). |
| End point (X/Y) | Kích thước tiêu chuẩn | Điểm kết thúc của kích thước theo X (giá trị thứ nhất) và Y (giá trị thứ hai). |
Chuyển đổi kích thước thành các đối tượng cơ bản
Kích thước là các đối tượng thiết kế dạng nhóm, nghĩa là chúng được cấu thành từ một hoặc nhiều chuỗi văn bản và đoạn đường mạch. Có thể chuyển đổi một kích thước thành các đối tượng cơ bản cấu thành nó bằng lệnh Tools » Convert » Explode Dimension to Free Primitives.


