创建和编辑内容

条目直接在已连接的工作区中创建,制造或表示条目所需的所有数据随后都会存储在该工作区中,并与相应的条目编号关联。根据内容类型,条目可以手动创建 ,也可以在保存、上传或发布过程中自动创建。所有内容类型都可以在 Altium Designer 中通过 Explorer 面板创建。处理元件时,也可以通过 Components 面板创建。

内容在工作区中以树状文件夹结构组织,类似于 PC 上用于组织文件的文件夹树。要向工作区添加文件夹,请在 Explorer 面板的 Server Folders 区域中右键单击。

条目在已连接的工作区中创建。在 Altium Designer 中,Explorer 面板提供了访问工作区的完整界面。
条目在已连接的工作区中创建。在 Altium Designer 中,Explorer 面板提供了访问工作区的完整界面。

创建条目

定义好所需的文件夹后,即可在工作区中创建内容。要创建条目,请选择相应的文件夹,然后在面板的条目网格区域中右键单击,并从 Create Item 子菜单中选择一条命令。或者,如果文件夹为空,可使用该区域中央的 Add an item 控件访问菜单。

右键菜单会显示与当前文件夹类型关联的内容类型。如果未列出您要创建的内容类型,请选择 Other Item Type 命令。请记住,您可以在文件夹中创建任何类型的内容,文件夹类型仅用于视觉区分。您随时可以在以后将内容移动到其他文件夹。

在 Explorer 面板的条目网格区域中右键单击,即可访问与内容创建相关的命令。
在 Explorer 面板的条目网格区域中右键单击,即可访问与内容创建相关的命令。

随后将显示 Create New Item 对话框,其中提供了完整定义条目所需的所有控件。

在 创建新条目 对话框中指定新条目的详细信息。
在 创建新条目 对话框中指定新条目的详细信息。

对于许多内容类型,您可以在创建内容后编辑相应的设计文档,并将其发布到该内容的初始修订版。为此,请启用 Create New Item 对话框底部的 Open for editing after creation 选项(默认已启用)。条目将被创建,同时相应的临时编辑器将打开,供您为该条目创建数据。有关处理特定内容类型的更多信息,请阅读其专属页面,相关链接见表格。

您可以右键单击条目,然后从右键菜单中选择 Properties ,以访问 Create New Item 对话框的另一种形式。如果条目处于 Planned State,则会打开 Edit Item 对话框,您可以在其中按需更改条目的属性。如果条目处于已保存状态,则会打开 View Item Properties 对话框,以只读方式显示条目属性。
建议在条目的定义中添加名称和描述。搜索工作区时会用到这些信息,便于快速识别条目 提供的内容。

工作区支持以不预先创建条目的方式创建工作区元件。这并不意味着不会创建条目,而是直接打开元件编辑器实例,以便在添加并保存所需元件之前应用元件模板的详细设置。实际的元件条目(及其计划修订版)会在发布准备过程中创建。使用右键菜单中的 Create Item » Component 命令可直接进入此模式。

要在创建新的工作区元件时打开 Create New Item 对话框,请使用 Create Item » Other Item Type 命令。在这种情况下,会先创建工作区元件的 Planned 修订版。要查看新创建但尚未定义并保存到工作区的元件,可禁用 Show only latest 选项(点击 Explorer 面板顶部的 按钮所打开的菜单中提供此选项),或将文件夹视图从 Components View 切换为 Classic View(同一菜单中提供此选项)。但请注意,由于条目已预先创建,因此不会应用模板中的信息(即命名方案、修订版方案和生命周期定义),因为元件条目此时已经存在。

关于条目 ID...

用于创建内容的父文件夹有一项重要设置,即其采用的 Item Naming Scheme。它定义了在该文件夹中创建的每个条目的唯一 ID 格式。 在文件夹级别定义条目命名方案后,即可在该文件夹中快速创建内容,同时遵循正确的 ID 命名方案。当条目在操作过程中自动即时创建,而不是发布到已在目标工作区中手动创建的现有条目时,这一点尤为重要。

系统提供了若干默认示例方案,使用文件夹类型或内容类型的简写代码(代码列表请参阅本文前面的表格)。使用默认命名方案时,软件会扫描整个工作区及现有内容的标识符,然后根据该方案自动分配下一个可用的唯一 ID。

也可以在字段中输入自定义方案,为文件夹定义命名规则,但需确保可变部分用花括号括起来(例如 DraftsmanDOC-TMP-{0000} 或 DraftsmanSHEET-TMP-{0000})。父文件夹采用的条目命名方案可随时更改。修改后的方案将应用于此后在该文件夹中创建的所有新条目。此外,为父文件夹定义的方案会自动由其下级子文件夹继承。

或者,如果需要完全手动控制条目的命名,请选择 [NO ITEM NAMING SCHEME] 项。随后,必须在创建条目时为其定义唯一标识符。请注意,系统不允许创建标识符重复的条目,因此手动分配标识符时,需要了解哪些标识符已被使用。

父文件夹的条目命名方案会应用于该文件夹中创建的每个条目的唯一 ID。
父文件夹的条目命名方案会应用于该文件夹中创建的每个条目的唯一 ID。

无论文件夹级别的 Item Naming Scheme 如何设置,您都可以在条目级别覆盖任何自动确定的 ID。可根据需要通过 Create New Item 对话框修改这些 ID。

选择条目 ID 方案

条目可采用的命名或编号方案有无数种,文档图片中显示的方案仅为示例。关于哪种编号方案最合适,有许多讨论可供参考。通常,专家一致认为,简短、不含特定含义的纯数字编号方案是最佳选择。不含特定含义是指编号方案不编码任何信息,例如产品类别、子类别、位置等;每个新条目只是依次获得序列中的下一个编号。

标识符的长度很重要,因为标识符越长,人们在记录或回忆条目 ID 时出错的可能性就越大。经验和学术研究表明,数据输入错误会随字符数量的增加而增多。一般认为,七位数字最容易被人准确、可靠地记住。超过一定长度后,错误率的增长速度会越来越快——达到 15 个字符时,出错概率接近 100%。

如果您的组织需要通过条目 ID 表示条目的身份信息,那么组合式标识符可能是合适的选择。在这种情况下,建议使用简单的字母/数字物料前缀代码。例如,以 ID D-820-0001 为例。其中的 D 可以代表设计,表示这是用于设计的条目。接下来的三位数字中,第一位可表示产品类别,例如外围板;第二位和第三位可用于表示裸板(1X)或装配件(2X 及以上)。条目 ID 的最后四位数字则是简单、不含特定含义、按顺序递增的编号。

设置工作区条目初始修订版的 ID

从本地设计模式转向工作区设计模式,需要将现有数据迁移到工作区。这些数据可能已经历多次迭代,并采用了组织内部认可的修订版编号。例如,某块 Magno-Synthetic Digitizer 电路板的第 3 修订版可能已经交付,而改进内容将于第 4 修订版中提供。发布到工作区时,如果初始修订版又从 1 开始,至少会造成混淆——不仅会影响组织内部,更重要的是会影响客户群体(他们期待的是比当前第 3 修订版更新的版本!)。

为此,Altium Designer 支持手动设置工作区中新建条目的初始修订版 ID。

条目创建后,只要尚未向其初始修订版发布数据(即仍处于 Planned 状态),就可以随时更改条目第一个计划修订版的 ID。

设置初始修订版的 ID

按常规方式在工作区中创建所需的新条目。创建完成后,右键点击该条目并选择 Properties,打开 Edit Item 对话框。展开对话框中的 Advanced 区域,然后点击 Revision ID 字段右侧的 按钮。此时会显示 Set Initial revision Id values 对话框,您可在其中根据需要设置 ID。系统会根据所选的修订版命名方案提供相应字段,以便修改 ID 的各个层级。

要在 Explorer 面板中访问项目相关条目(PCB 制造数据、PCB 装配数据、PCB 项目设计),请确保您正在项目的 Classic View 中查看该项目。您可能需要从 Project View 手动切换过来——相关命令位于面板右上角 按钮的关联菜单中。
要快速获取新建托管项目的项目相关条目(PCB 制造数据、PCB 装配数据、PCB 项目设计),请运行 Project Releaser(在 Projects 面板 中右键单击项目,然后从上下文菜单中选择 Project Releaser 命令)。相关条目将在准备阶段创建。但请注意不要发布项目,以便您能够设置初始修订版的 ID。

设置 ID 的各个层级(根据所采用的修订版命名方案设置适用的层级)。
设置 ID 的各个层级(根据所采用的修订版命名方案设置适用的层级)。

通过 Project Releaser 发布设计时,也可以在此过程中定义初始修订版。在发布流程的初始 Configure Server Release 阶段,目标修订版条目旁边链接的上下文菜单中提供了 Custom 菜单项。使用此命令可打开 Custom Revision ID 对话框,在其中可以手动指定目标条目的修订版,生成的数据将发布到该修订版中。了解有关 将设计发布到工作区时控制目标修订版的更多信息。

直接通过工作区创建和编辑内容

您连接的工作区提供了一种灵活且安全的方法,可集中存储和管理 Altium Designer 中使用的所有类型的设计数据。从原理图模型到元器件,从托管原理图图纸到完成的 PCB 设计,工作区为存储和管理电子设计数据提供了理想的方式。

工作区的一项强大功能是支持 Direct Editing。“直接编辑”究竟是什么意思?它意味着您可以在工作区中右键单击模型、元器件,甚至托管图纸,然后选择 Edit。此时,文件会在 Altium Designer 的临时编辑器中打开,供您编辑。完成后,只需将其保存回工作区即可。至于刚才编辑的文件,您无需操心:由于您的编辑内容已安全地保存回工作区,该文件不再需要,因此会被删除,临时编辑器实例也会关闭。

直接编辑让您摆脱单独对源数据进行版本控制的束缚。您只需使用临时编辑器,即可编辑受支持的条目类型;编辑器会直接从工作区加载最新的源数据。编辑完成后,该实体会发布(或重新发布)到其父条目的后续计划修订版中,临时编辑器随即关闭。硬盘上不会留下文件,您不必怀疑自己使用的源数据是否正确或是否为最新版本,也无需维护单独的版本控制软件。工作区会以高度可靠的方式处理这一切,大幅加快数据更改的速度。

虽然您仍然可以创建由自己管理的源文件,但直接编辑所提供的自由,可以说让您不再需要考虑这一因素。工作区既是设计数据的来源,也是其存储目标,让您能够访问和编辑安全的(而且是最新的!)源数据,无需为管理两套数据而烦恼。

支持直接编辑的内容类型

以下工作区内容类型支持直接编辑:

编辑条目的初始修订版

在 Explorer 面板 中创建受支持内容类型的条目时,您可以选择在创建后编辑关联的数据实体,并将其发布到该条目的初始修订版中。因此,您无需在工作区外部创建源数据后再将其发布,而是可以借助直接编辑功能,在空条目创建后立即开始处理源数据。编辑完成后,该实体会发布到其父条目的初始计划修订版中,临时编辑器随即关闭。

要使用此功能,请启用 创建条目对话框底部的 Open for editing after creation 选项。考虑到此功能的实用性,该选项默认启用。条目创建后,相关临时编辑器将打开,并在主设计窗口中将相关文档显示为活动文档。该文档将根据条目及其修订版命名,格式为:<Item>-<Revision>.<DocumentExtension>。

元器件条目是一个例外:创建此类型的新条目时,将打开单元器件编辑器,并使用元器件名称作为标识。如果尚未指定名称,则会使用默认的 New component 命名,直到定义名称为止。

下图展示了创建新符号条目(SYM-001-0031)时此功能的实际应用。临时原理图符号编辑器会打开,并提供一个文档,供您按需定义符号。

直接从工作区编辑符号条目初始修订版的示例——临时原理图符号编辑器提供了用于定义原理图符号的文档。
直接从工作区编辑符号条目初始修订版的示例——临时原理图符号编辑器提供了用于定义原理图符号的文档。

直接编辑控件

直接编辑时,有三个相关控件,可从快速访问栏(位于主应用程序窗口左上角)或当前临时编辑器的 Standard 工具栏(如有)中直接访问:

  • 单击并拖动以移动​ – Save Active Document。使用此按钮可保存对文档所做的任何更改。如果您希望稍后返回继续修改,再最终发布到工作区,可先保存当前更改。

  • / – Save to Server。使用此按钮可将文档发布(实际上是保存并发布)到工作区,并将其存储在目标条目的初始(计划)修订版或下一个修订版中。此时将显示创建修订版对话框(或编辑修订版对话框),您可以在其中更改名称和描述,并根据需要添加发布说明。发布后,文档和编辑器将关闭。

     
     
     
     
     
     
     
     
     
     

    在适用且需要的情况下,还可以更新与正在保存的条目的当前修订版相关(引用该修订版)的父条目修订版。 此行为由默认启用的 Update items related to <ItemRevision> 选项控制。请注意,此选项仅在以下情况下显示:

    • 为元件条目修订版所引用的领域模型(符号、封装、仿真模型、线束接线模型)创建新修订版。

    • 为元件条目修订版所引用的元件模板创建新修订版。

    • 为封装模型条目修订版所引用的 3D 模型创建新修订版。

    如果您希望所有相关父条目继续使用该条目的当前修订版,请禁用此选项。这样只会保存条目本身。

    将编辑后的元件或领域模型(符号、封装、仿真模型、线束接线模型)保存到工作区时,您可以保留其 当前生命周期状态。 重新保存时,可通过 Edit Revision / Create Revision 对话框中的 Preserve lifecycle state (not recommended) 选项进行控制。启用此选项后,新修订版将自动设置为上一修订版的生命周期状态。 获分配 Allow to skip lifecycle state change for new revisions 操作权限的用户可以使用此功能(详细了解为工作区设置全局操作权限)。

    要将正在编辑的文档保存到工作区,也可以 使用 Projects 面板中文档条目旁的 Save to Server 控件。

  • / – Discard Local Changes。如果希望取消编辑,请使用此按钮。临时文件(仅用于方便编辑)将被删除,其条目也会从 Projects 面板中移除,并且不会向目标条目发布任何内容。

    使用适用于直接编辑会话的临时文件时,无需在一次编辑会话中完成更新过程;您可以根据需要保存工作并关闭文件。Altium Designer 能够识别这是一个特殊文件,因此会将其保留在 Projects 面板中的 <SourceWorkspaceName> 文件夹内,以便您准备好后重新打开,完成更新和重新发布过程。

这些控件 也可以作为命令,从 Projects 面板中文档条目的右键菜单中访问。对于许多编辑器,还可以从主 File 菜单中以命令形式使用这些控件:Save(快捷键:Ctrl+S)、Save to Server(快捷键:Ctrl+Alt+S)和 Discard Local Changes 。

对于项目模板条目的修订版,Save、Save to Server 和 Discard Local Changes 命令只能从 Projects 面板中访问。右键单击条目修订版对应的条目,即可打开相关上下文菜单。

编辑条目的现有修订版

在任何阶段,您都可以返回工作区中受支持内容类型条目的任意修订版 (通过 Explorer 面板),并直接进行编辑。右键单击该修订版,然后从上下文菜单中选择 Edit 命令。临时编辑器将再次打开,并打开该修订版中包含的文档供您编辑。根据需要进行更改,然后提交发布,将文档发布到该条目的下一个修订版。

右键单击条目本身的顶层条目,将编辑该条目的最新修订版。

访问用于启动直接编辑现有 Draftsman 文档模板的命令的示例。
访问用于启动直接编辑现有 Draftsman 文档模板的命令的示例。

临时文件的行为

要编辑工作区数据,必须先创建可供您在 Altium Designer 中编辑的内容。因此,系统会创建临时文件。例如,当您右键单击符号条目并选择 Edit 时,系统会创建一个临时 SchLib 文件,并在 Altium Designer 中打开它。完成编辑并执行 Save to Server 后,工作区数据一经更新,此文件就会被删除。

但是,如果您不发布文件,而是对文件执行 Save 和 Close,它将保留在 Projects 面板中。这样做是为了让您不必在一次编辑会话中完成更新过程——您可以根据需要保存工作并关闭文件。Altium Designer 能够识别这是一个特殊文件,因此会将其保留在 Projects 面板中的 <WorkspaceName> 条目下(例如, /),以便在准备好后重新打开它,完成更新和重新发布流程。

临时文档仍可访问,因此您不必在一次编辑会话中完成所有更改。
临时文档仍可访问,因此您不必在一次编辑会话中完成所有更改。

如果您中途改变主意,不再想进行编辑,只需右键单击某个条目,然后从上下文菜单中选择 Discard Local Changes 命令,即可关闭临时文件。

从 Components 面板直接编辑元件

在日常元件管理中,您可以从 Components 面板进行直接编辑——对于这一特定内容类型,您往往会更多地使用此面板,而不是 Explorer 面板。浏览并找到所需元件,选中它,然后右键单击并从上下文菜单中选择 Edit 命令。元件编辑器将以 Single Component Editing 模式打开一个临时实例,供您根据需要进行更改。

如果您编辑多个选定的元件,元件编辑器将以 Batch Component Editing 模式打开一个实例,其中包含所有选定的元件。

从 Components 面板直接编辑的示例。
从 Components 面板直接编辑的示例。

从元件编辑器直接编辑模型

使用处于 Single Component Editing 模式的元件编辑器编辑元件时,您可以通过直接编辑方式编辑链接的领域模型。要修改元件当前使用(引用)的模型,请单击其预览右上角的  控件。该模型类型对应的临时编辑器将打开,供您根据需要更改模型。完成后,只需保存并关闭编辑器,修改后的模型就会重新链接到 Models 区域中。发布元件时,修改后的模型也会自动发布到工作区,保存为其父条目的下一个修订版。

如果该模型被多个元件引用,将出现一个对话框,提醒您这一情况并提供多种选择。您可以创建模型的副本(克隆模型),使更改仅影响当前元件;也可以继续编辑此共享模型,稍后再更新引用它的其他元件。或者,您可以直接取消编辑流程。

使用处于 Single Component Editing 模式的元件编辑器,直接编辑现有模型的示例;该模型由一个正在被直接编辑的元件引用。
使用处于 Single Component Editing 模式的元件编辑器,直接编辑现有模型的示例;该模型由一个正在被直接编辑的元件引用。

使用处于 Batch Component Editing 模式的元件编辑器编辑元件时,也可以对链接的领域模型采用直接编辑方式。右键单击编辑器 Model Links 区域中的模型条目,然后从上下文菜单中选择 Edit 命令。

保存领域模型时更新父元件

 
 
 
 
 

当您更改工作区领域模型(无论是原理图符号、封装模型、仿真模型、线束接线模型还是线束实体模型)并将更改保存为模型的新修订版时,所有使用该模型的工作区元件实际上都会变为过时状态,因为它们仍在使用先前的修订版。大多数情况下,您自然会希望重新保存这些工作区元件,并更新相应的模型链接,以使用最新的可用修订版。为了简化此流程,工作区与 Altium Designer 配合使用,可在您通过直接编辑功能修改工作区模型并重新保存时,更新其父元件。

将修改后的工作区模型保存回目标工作区时,会出现 Create Revision 对话框,其中提供了更新父元件的选项 。此选项——Update items related to <ModelItemRevision>——默认启用。

 
 
 
 
 
  • <ModelItemRevision> 是模型的当前修订版,即任何父工作区元件当前使用的修订版。保存工作区模型本身后,此修订版自然会成为先前(较早)的修订版,不再是最新版本。

  • 如果您希望所有父元件继续使用工作区模型的当前修订版,请禁用此选项。这样就只会保存模型本身。

访问用于更新工作区元件的选项,这些元件引用了正在重新保存的工作区模型(此例中为符号)。
访问用于更新工作区元件的选项,这些元件引用了正在重新保存的工作区模型(此例中为符号)。

在 Create Revision 对话框中单击 OK 后,修改后的模型将保存回工作区,其关联的临时编辑器也会关闭。所有引用该工作区模型的工作区元件都会自动重新保存,以使用模型的新修订版(系统会自动创建每个元件的下一修订版并执行保存)。

将数据上传到条目的新修订版

大多数内容类型都支持通过上传相应的数据文件来创建新修订版。

以下内容类型不支持使用此方法创建新修订版:元件、复用块、原理图片段、PCB 片段。

可以通过以下几种方式将数据上传到条目的新修订版。

上传菜单

要上传文件,可以在 Explorer 面板中右键单击所需条目,然后从上下文菜单中选择 Upload 命令。此时将显示 Create New Revision 对话框,您可以在其中根据需要更改名称、描述,并添加发布说明。使用对话框的 Sources 区域加载所需文件。您可以将文件从 Windows 资源管理器拖放到该区域。也可以单击 按钮,此时将显示 Add Files 对话框(标准的 Windows 打开文件对话框)。使用该对话框浏览并打开所需文件。

如果条目没有计划修订版,文件将上传到下一个计划修订版,该修订版会在上传过程中即时创建。

上传示例。此处手动指定要上传到目标 3D 模型条目的 3D 模型文件。
上传示例。此处手动指定要上传到目标 3D 模型条目的 3D 模型文件。

拖入所需文件,或选择文件并单击 Open 按钮后,Sources 区域中将显示该文件的条目。

对于支持将多个文件上传到同一修订版的内容类型(例如二进制文件),所选文件将添加到对话框的 Sources 区域并列出。如果需要调整列表内容,可根据需要添加其他文件,或选择并移除文件(单击 按钮)。Sources 区域支持使用标准多选方式(Ctrl+Click、Shift+Click 以及单击并拖动)选择多个文件。

单击 OK 按钮继续上传。根据内容类型,上传文件的相关信息将显示在 Explorer 面板中该条目修订版的 Details 和/或 Preview 视图选项卡上。

返回 Explorer 面板,浏览已保存的条目修订版(此处显示的是 3D 模型条目)。切换到 Preview 视图选项卡,可查看其图形表示(如适用)。
返回 Explorer 面板,浏览已保存的条目修订版(此处显示的是 3D 模型条目)。切换到 Preview 视图选项卡,可查看其图形表示(如适用)。

从 Windows 资源管理器拖放

您也可以从 Windows 资源管理器的源文件夹中拖动所选文件,并将其放到 Explorer 面板中所需的目标条目上,以此上传相关数据文件。此时将显示 Create New Revision 对话框,拖入的文件会列在 Sources 区域中。根据需要添加 Release Notes,然后单击 OK 按钮。

对于某些内容类型,您需要修改 Name(其值为包含扩展名的文件名;如果有多个文件,各项以分号分隔)和 Description(其格式为 Uploaded from <FileNameandPath>, Size <FileSize>, Created on <FileCreationDate>;如果有多个文件,各项以分号分隔)。对于支持多个文件的内容类型,如果需要添加其他文件,可以单击 按钮并浏览选择文件,或将文件拖放到 Sources 区域。如果需要移除文件,请在列表中选择文件,然后单击 按钮。

使用拖放方式上传,此处以 3D 模型为例。
使用拖放方式上传,此处以 3D 模型为例。

如果现有条目没有计划修订版,文件将上传到下一个计划修订版,该修订版会在上传过程中即时创建。如果将拖动的数据文件放在现有条目以外的位置,系统将创建一个新条目。此时将显示创建新条目对话框。名称和描述字段将预先填入内容。根据内容类型,可能采用以下方式:
  • 条目的 Name 将为文件名。Description 将为文件名(含扩展名)。
  • 条目的 Name 将为包含扩展名的文件名(如果有多个文件,各项以分号分隔)。Description 的格式将为 Uploaded from <FileNameandPath>, Size <FileSize>, Created on <FileCreationDate>(如果有多个文件,各项以分号分隔)。

请根据需要修改这些内容。

Item ID 将遵循在文件夹级别定义的条目命名方案。如果文件夹未定义命名方案,则将遵循 $CONTENT_TYPE_CODE-{000000} 方案。

对于仅支持存储单个数据文件的内容类型,如果您尝试拖放多个数据文件,发布管理器对话框将自动启动。使用此对话框完成多个文件的上传。

克隆工作区内容

Explorer 面板支持克隆多种工作区条目。因此,您无需从头创建所需的元件、领域模型、原理图图纸或模板,只需将其克隆即可。直接编辑可简化对原始条目修订版源数据副本的修改过程,并将修改结果发布为同类型新条目的初始修订版。整个过程快速高效,让您无需从零开始,即可迅速扩充工作区内容。

以下内容类型可以克隆:

  • 元件
  • 封装
  • 符号
  • 仿真模型
  • 元件模板
  • 受管原理图图纸
  • 原理图模板
  • 项目模板
  • Draftsman 文档模板
  • Draftsman 图纸模板
  • 层叠
  • OutputJob

可通过以下方式从 Explorer 面板访问用于克隆受支持内容类型的命令:

  • 右键单击源条目修订版的条目,然后从上下文菜单中选择 Operations » Clone 命令。
  • 选择源条目修订版的条目,然后使用 Ctrl+D 键盘快捷键。

在 Explorer 面板中,凡是显示适用条目修订版的位置,都可以使用 Clone 命令,包括:

  • 文件夹内的主条目列表。
  • Children 视图选项卡(查看受管原理图图纸条目时)。
  • Where-used 视图选项卡(查看元件条目、符号条目、封装条目、仿真模型条目、元件模板条目或原理图模板条目时)。
  • Preview 视图选项卡(查看元件条目、受管原理图图纸条目或原理图模板条目时)。
浏览特定文件夹中的主条目列表时,可从某个条目的顶层条目访问 Clone 命令,以克隆该条目的最新修订版。
AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents