创建和编辑内容

条目直接在已连接的工作区中创建,制造/表示条目所需的所有数据随后都会按该条目编号存储在该工作区中。根据内容类型,条目可以手动创建,也可以在保存/上传/发布过程中自动创建。所有内容类型都可以通过 Altium Designer 中的 Explorer 面板创建。处理元器件时,也可以通过 Components 面板进行创建。

工作区中的内容以树状文件夹结构组织,与 PC 上用于组织文件的文件夹树非常相似。要向工作区添加文件夹,请右键单击 Explorer 面板的 Server Folders 区域。

条目在已连接的工作区中创建。在 Altium Designer 中,Explorer 面板提供了访问工作区的完整界面。
条目在已连接的工作区中创建。在 Altium Designer 中,Explorer 面板提供了访问工作区的完整界面。

创建条目

定义好所需的文件夹后,即可在工作区中创建内容。要创建条目,请选择相应的文件夹,然后右键单击面板的条目网格区域,并从 Create Item 子菜单中选择一个命令。或者,如果文件夹为空,可以使用该区域中央的 Add an item 控件访问菜单。

右键菜单会列出与当前文件夹类型关联的内容类型。如果未列出您要创建的内容类型,请选择 Other Item Type 命令。请记住,您可以在文件夹中创建任何类型的内容,文件夹类型仅起视觉区分作用。您随时可以在以后将内容移动到其他文件夹。

右键单击 Explorer 面板的条目网格区域,即可访问与内容创建相关的命令。
右键单击 Explorer 面板的条目网格区域,即可访问与内容创建相关的命令。

随后将显示 Create New Item 对话框,其中提供了完整定义条目所需的所有控件。

在 创建新条目对话框中指定新条目的详细信息。
在 创建新条目对话框中指定新条目的详细信息。

对于许多内容类型,您可以在创建后编辑相应的设计文档,并将其发布到该内容的初始修订版。为此,请启用 Create New Item 对话框底部的 Open for editing after creation 选项(默认已启用)。条目将被创建,相关的临时编辑器也会打开,供您为该条目创建数据。有关处理特定内容类型的更多信息,请阅读其专门页面,相关链接见表格。

您可以右键单击条目,然后从右键菜单中选择 Properties,以访问 Create New Item 对话框的另一种形式。如果条目处于 Planned State,则会打开 Edit Item 对话框,您可以根据需要在其中更改条目的属性。如果条目处于已保存状态,则会打开 View Item Properties 对话框,以只读方式显示条目属性。
建议在定义条目时添加名称和描述。这些信息可用于搜索工作区,并帮助您快速了解条目 提供的内容。

工作区支持以不预先创建条目的方式创建工作区元件。这并不意味着不会创建条目,而是直接打开元件编辑器实例,以便在添加并保存所需元件之前应用元件模板的详细信息。实际的元件条目(及其计划修订版)会在发布准备过程中创建。使用右键菜单中的 Create Item » Component 命令可直接进入此模式。

要在创建新工作区元件时显示 Create New Item 对话框,请使用 Create Item » Other Item Type 命令。在这种情况下,会先创建工作区元件的 Planned 修订版。要查看新创建但尚未定义并保存到工作区的元件,可以禁用 Show only latest 选项(点击 Explorer 面板顶部的 按钮,在打开的菜单中找到该选项),也可以将文件夹视图从 Components View 切换为 Classic View(同样可在该菜单中设置)。但请注意,由于条目是预先创建的,因此不会应用模板中的信息(即命名方案、修订版方案和生命周期定义),因为元件条目已经存在。

关于条目 ID 的说明……

创建内容时,其所在父文件夹的一个重要属性是所采用的 Item Naming Scheme。它定义了在该文件夹中创建的每个条目的唯一 ID 格式。 通过在文件夹级别定义条目命名方案,可以在该文件夹中快速创建内容,同时遵循正确的 ID 命名方案。尤其是在自动“即时”创建条目,而不是发布到已在目标工作区中手动创建的现有条目时,这一点尤为有用。

系统提供了几种默认示例方案,使用文件夹类型或内容类型的简写代码(代码列表请参阅本文前面的表格)。使用默认命名方案时,软件会扫描整个工作区及现有内容的标识符,然后根据该方案自动分配下一个可用的唯一 ID。

您也可以在字段中输入自定义方案来为文件夹定义命名方案,但需确保将可变部分括在花括号中(例如 DraftsmanDOC-TMP-{0000} 或 DraftsmanSHEET-TMP-{0000})。父文件夹采用的条目命名方案可随时更改。修改后的方案将应用于随后在该文件夹中创建的所有新条目。此外,为父文件夹定义的方案会自动由其下级子文件夹继承。

或者,如果需要完全手动控制条目的命名,请选择 [NO ITEM NAMING SCHEME] 条目。随后,必须在创建条目时为其定义唯一标识符。请注意,系统不允许创建标识符重复的条目,因此手动分配标识符时,需要了解哪些标识符已被使用。

父文件夹的条目命名方案会应用于在该文件夹中创建的每个条目的唯一 ID。
父文件夹的条目命名方案会应用于在该文件夹中创建的每个条目的唯一 ID。

无论文件夹级别的 Item Naming Scheme 如何设置,您都可以在条目级别覆盖自动确定的 ID。可根据需要,通过 Create New Item 对话框修改这些 ID。

选择条目 ID 方案

条目可使用的命名或编号方案有无数种,文档图片中展示的方案仅为示例。关于哪种编号方案最佳,有许多讨论可供参考。通常,专家一致认为,简短、无含义的纯数字编号方案最为理想。“无含义”是指编号方案中不编码任何信息,例如产品类别、子类别、位置等;每个新条目只需按顺序分配下一个编号。

标识符的长度非常重要,因为标识符越长,人工记录或回忆条目 ID 时出错的可能性就越大。经验和学术研究表明,数据输入错误会随着字符数量的增加而增多。就便于人们准确记忆而言,七位数字被认为是一个神奇的长度。超过一定长度后,错误率会加速上升——达到 15 个字符时,出错概率接近 100%。

如果您的组织需要通过条目 ID 体现条目的身份信息,那么可以考虑使用组合式标识符。在这种情况下,建议采用简单的字母/数字物料类别前缀代码。例如,考虑 ID D-820-0001。其中,代码中的 D 可以表示设计,说明这是一个用于设计的条目。在接下来的 3 位数字中,第一位可以表示产品类别,例如外围板;该三位数字组中的第二位和第三位可用于表示裸板(1X)或组装板(2X 及以上)。条目 ID 的最后四位数字则是一个简单、无含义、按顺序递增的编号。

设置工作区条目初始修订版的 ID

从本地设计模式转向工作区设计模式,需要将现有数据迁移到工作区。这些数据很可能已经历多次迭代,并分配了整个组织认可的修订版编号。例如,Magno-Synthetic Digitizer 板的修订版 3 可能早已交付,而改进内容计划在修订版 4 中提供。在发布到工作区时,如果初始修订版又从 1 开始,显然会造成混淆——不仅会影响组织内部,更重要的是会影响客户群体(他们期望获得比当前修订版 3 更新的版本!)。

为此,Altium Designer 支持为工作区中新创建条目的初始修订版手动设置 ID。

创建条目后,在数据发布到初始修订版之前(即该修订版仍处于 Planned 状态时),可以随时更改条目首个计划修订版的 ID。

设置初始修订版的 ID

按常规方式在工作区中创建所需的新条目。创建后,右键点击该条目并选择 Properties,打开 Edit Item 对话框。展开对话框中的 Advanced 区域,然后点击 Revision ID 字段右侧的 按钮。此时将显示 Set Initial revision Id values 对话框,您可以在其中根据需要设置 ID。系统会根据所选的修订版命名方案,提供相应字段,以便修改 ID 的各个层级。

要在 Explorer 面板中访问与项目相关的条目(PCB 制造数据、PCB 装配数据、PCB 项目设计),请确保您正在项目的 Classic View 中查看该项目。您可能需要从 Project View 手动切换过来——相关命令位于面板右上角 按钮的关联菜单中。
要快速获取新建受管项目的相关条目(PCB 制造数据、PCB 装配数据、PCB 项目设计),请运行 项目发布器(在 Projects 面板中右键单击该项目,然后从上下文菜单中选择 Project Releaser 命令)。相关条目将在准备阶段创建。不过,请勿发布项目,以便您设置初始修订版的 ID。

设置 ID 的各个层级(根据所用的修订版命名方案设置适用的层级)。
设置 ID 的各个层级(根据所用的修订版命名方案设置适用的层级)。

也可以在使用 Project Releaser 发布设计时定义初始修订版。在发布流程的初始 Configure Server Release 阶段,目标修订版条目旁链接的上下文菜单中提供了 Custom 选项。使用此命令可打开 Custom Revision ID 对话框,在其中手动指定目标条目的修订版,生成的数据将发布到该修订版中。了解有关 将设计发布到工作区时控制目标修订版的更多信息。

直接通过工作区创建和编辑内容

您所连接的工作区提供了一种灵活、安全的方式,用于集中存储和管理 Altium Designer 中使用的各类设计数据。从原理图模型到元器件,从受管原理图图纸到完整的 PCB 设计,工作区为您的电子设计数据提供了理想的存储和管理方式。

工作区的一项强大功能是支持 Direct Editing。“直接编辑”究竟是什么意思?它意味着您可以在工作区中右键单击模型、元器件,甚至受管图纸,然后选择 Edit。此时,一个文件会在 Altium Designer 的临时编辑器中打开,供您编辑;完成后,只需将其保存回工作区即可。至于刚刚编辑的文件,您无需操心:由于编辑内容已安全地存回工作区,该文件不再需要,因此会被删除,临时编辑器实例也会关闭。

直接编辑让您摆脱了单独维护受版本控制的源数据的束缚。您只需使用临时编辑器,即可编辑受支持的条目类型,编辑器会直接从工作区加载最新的源数据。编辑完成后,该实体将发布(或重新发布)到其父条目的后续计划修订版中,随后临时编辑器关闭。硬盘上不会留下文件,您无需疑虑自己使用的是否为正确或最新的源数据,也无需维护单独的版本控制软件。工作区会可靠地处理这一切,并大幅加快数据更改的速度。

虽然您仍然可以创建自行管理的源文件,但可以说,直接编辑所提供的自由让您不必再考虑这一因素。工作区同时成为设计数据的来源和目标,使您能够访问和编辑安全的(而且是最新的!)源数据,而不必为管理两套数据而烦恼。

支持直接编辑的内容类型

以下工作区内容类型支持直接编辑:

编辑条目的初始修订版

在 Explorer 面板中创建受支持内容类型的条目时,您可以选择在创建后编辑关联的数据实体,并将其发布到该条目的初始修订版中。因此,您无需在工作区外部创建源数据后再将其发布,而是可以借助直接编辑功能,从空条目创建完成的那一刻起直接处理源数据。编辑完成后,该实体将发布到其父条目的初始计划修订版中,随后临时编辑器关闭。

要使用此功能,请启用 创建条目对话框底部的 Open for editing after creation 选项。考虑到此功能的实用性,该选项默认启用。条目创建后,相应的临时编辑器将打开,相关文档会作为活动文档显示在主设计窗口中。此文档将按“条目-修订版”命名,格式为:<Item>-<Revision>.<DocumentExtension>。

元器件条目是个例外:创建此类型的新条目时,将打开单元器件编辑器,并使用元器件名称作为标识。如果尚未指定名称,则会使用默认的 New component 命名,直到定义名称为止。

下图展示了创建新符号条目(SYM-001-0031)时的操作情形。临时原理图符号编辑器随即打开,提供一个文档,供您根据需要定义符号。

直接从工作区编辑符号条目初始修订版的示例——临时原理图符号编辑器提供了用于定义原理图符号的文档。
直接从工作区编辑符号条目初始修订版的示例——临时原理图符号编辑器提供了用于定义原理图符号的文档。

直接编辑控件

直接编辑时,有三个相关控件可供使用,可从快速访问栏(主应用程序窗口的左上角)或当前临时编辑器的 Standard 工具栏(如果提供)轻松访问:

  • 单击并拖动以移动​ – Save Active Document。使用此按钮可保存对文档所做的任何更改。如果您希望稍后返回继续修改,最后再发布到工作区,可以先保存当前更改。

  • / – Save to Server。使用此按钮可将文档发布(实际上是保存并发布)到工作区,将其存储在目标条目的初始(计划)修订版或下一修订版中。此时将显示创建修订版对话框(或编辑修订版对话框),您可以在其中更改名称和描述,并根据需要添加发布说明。发布后,文档和编辑器将关闭。

     
     
     
     
     

    在适用且有需要的情况下,还可以更新与正在保存的条目的当前修订版相关(引用该修订版)的父条目修订版。这由默认启用的 Update items related to <ItemRevision> 选项控制。请注意,此选项仅在以下情况下显示:

    • 为元件条目修订版所引用的领域模型(原理图符号、封装、仿真模型、线束接线模型)创建新修订版。

    • 为元件条目修订版所引用的元件模板创建新修订版。

    • 为封装模型条目修订版所引用的 3D 模型创建新修订版。

    如果您希望所有相关父条目继续使用该条目的当前修订版,请禁用此选项。这样将仅保存该条目本身。

    将编辑后的元件保存到工作区时,您可以保留其当前生命周期状态。重新保存时,可通过 Edit Revision 对话框中的 Preserve lifecycle state (not recommended) 选项进行控制。启用此选项后,新修订版将自动设为上一修订版的生命周期状态。

    此外,将编辑后的领域模型(原理图符号、封装、仿真模型、线束接线模型)保存到 Altium 平台上的工作区时,您可以为引用该模型的相关工作区元件保留当前生命周期状态。重新保存时,可通过 Create Revision 对话框中的 Preserve lifecycle state (not recommended) 选项进行控制。模型本身的当前生命周期状态不会保留。

    获分配 Allow to skip lifecycle state change for new revisions 操作权限的用户可以使用此功能(了解有关设置工作区全局操作权限的更多信息)。

    要将正在编辑的文档保存到工作区,您也可以使用项目面板中文档条目旁的 Save to Server 控件。

  • / – Discard Local Changes。如果您希望取消编辑,请使用此按钮。临时文件(仅用于辅助编辑)将被删除,其条目也会从 Projects 面板中移除,且不会向目标条目发布任何内容。

    使用相应的临时文件进行直接编辑时,不必在一次编辑会话中完成更新过程;您可以根据需要保存工作并关闭文件。Altium Designer 能识别出这是一个特殊文件,因此会将其保留在 Projects 面板中的 <SourceWorkspaceName> 文件夹内,以便您准备好后重新打开,完成更新和重新发布过程。

这些控件也可以作为命令,从 Projects 面板中文档条目的右键菜单中访问。对于许多编辑器,也可以从主 File 菜单中使用这些控件对应的命令:Save(快捷键:Ctrl+S)、Save to Server(快捷键:Ctrl+Alt+S)和 Discard Local Changes。

对于项目模板条目的修订版,只能从 Projects 面板访问 Save、Save to Server 和 Discard Local Changes 命令。右键单击条目修订版对应的条目,即可访问相关上下文菜单。

编辑条目的现有修订版

在任何阶段,您都可以返回 Workspace 中受支持内容类型的任意条目修订版 (通过 Explorer 面板),并直接进行编辑。右键单击该修订版,然后从上下文菜单中选择 Edit 命令。临时编辑器将再次打开,其中包含该修订版中的文档,供您编辑。根据需要进行更改,然后提交发布文档,将其保存为该条目的下一个修订版。

右键单击条目本身的顶层条目,将编辑该条目的最新修订版。

访问命令以启动对现有 Draftsman 文档模板的直接编辑的示例。
访问命令以启动对现有 Draftsman 文档模板的直接编辑的示例。

临时文件的行为

要编辑 Workspace 数据,必须先创建可在 Altium Designer 中编辑的内容。为此,系统会创建临时文件。例如,当您右键单击符号条目并选择 Edit 时,系统会创建一个临时 SchLib 文件,并在 Altium Designer 中打开它。当您完成编辑并执行 Save to Server 后,Workspace 数据一经更新,该文件就会被删除。

但是,如果您不发布该文件,而是对其执行 Save 和 Close,它将保留在 Projects 面板中。这样,您就不必在一次编辑会话中完成整个更新过程——您可以保存工作,并按需关闭文件。Altium Designer 会识别出这是一个特殊文件,因此会将其保留在 Projects 面板的 <WorkspaceName> 条目下(例如, /),以便您准备好后重新打开它,完成更新和重新发布过程。

临时文档会保持可访问状态,因此您不必在一次编辑会话中完成所有更改。
临时文档会保持可访问状态,因此您不必在一次编辑会话中完成所有更改。

如果您在某个时候改变主意,不再想进行编辑,只需右键单击相应条目,然后从上下文菜单中选择 Discard Local Changes 命令,即可关闭临时文件。

从 Components 面板直接编辑元器件

在日常元器件管理中,您可以从 Components 面板进行直接编辑。对于这一特定内容类型,您通常会更多地使用此面板,而不是 Explorer 面板。浏览并找到所需元器件,将其选中,然后右键单击并从上下文菜单中选择 Edit 命令。系统将打开一个处于 Single Component Editing 模式的元器件编辑器临时实例,供您根据需要进行更改。

如果您编辑多个选定的元器件,系统将打开一个处于 Batch Component Editing 模式的元器件编辑器实例,其中包含所有选定的元器件。

从 Components 面板直接编辑的示例。
从 Components 面板直接编辑的示例。

从元器件编辑器直接编辑模型

使用处于 Single Component Editing 模式的元器件编辑器编辑元器件时,您可以通过直接编辑方式来编辑所链接的领域模型。要修改元器件当前使用(引用)的模型,请单击其预览右上角的  控件。系统将打开与该模型类型对应的临时编辑器,供您根据需要修改模型。完成后,只需保存并关闭编辑器,修改后的模型就会重新显示在 Models 区域中,并保持链接状态。发布元器件时,修改后的模型也会自动发布到 Workspace,成为其所属条目的下一个修订版。

如果该模型被多个元器件引用,系统会显示一个对话框,提醒您这一情况,并提供多种选择。您可以创建模型的副本(克隆模型),使更改仅影响当前元器件;也可以继续编辑此共享模型,稍后再更新引用它的其他元器件。此外,您也可以直接取消编辑过程。

使用处于 Single Component Editing 模式的元器件编辑器,直接编辑正在被某个元器件引用的现有模型的示例;该元器件本身也正在进行直接编辑。
使用处于 Single Component Editing 模式的元器件编辑器,直接编辑正在被某个元器件引用的现有模型的示例;该元器件本身也正在进行直接编辑。

使用处于 Batch Component Editing 模式的元器件编辑器编辑元器件时,也可以通过直接编辑方式来编辑所链接的领域模型。右键单击编辑器 Model Links 区域中的模型条目,然后从上下文菜单中选择 Edit 命令。

保存领域模型时更新父元器件

 
 
 
 
 

当您修改 Workspace 领域模型时——无论是原理图符号、封装模型、仿真模型、线束接线模型还是线束实体模型——一旦将更改保存为模型的新修订版,所有使用该模型的 Workspace 元器件实际上都会变为过时状态,因为它们仍在使用之前的修订版。在大多数情况下,您无疑会希望重新保存这些 Workspace 元器件,并更新相应的模型链接,以使用最新的可用修订版。为了简化这一过程,Workspace 与 Altium Designer 协同工作,支持在通过直接编辑功能修改 Workspace 模型后,重新保存该模型时更新父元器件。

将修改后的 Workspace 模型保存回目标 Workspace 时,会显示 Create Revision 对话框,其中提供了更新父元器件的选项 。此选项(Update items related to <ModelItemRevision>)默认处于启用状态。

  • <ModelItemRevision> 是模型的当前修订版,也就是所有父级 Workspace 元器件当前使用的修订版。保存 Workspace 模型本身后,该修订版自然就会成为之前的(较早的)修订版,而不再是最新修订版。

  • 如果希望所有父元件继续使用工作区模型的当前修订版,请禁用此选项。这样将仅保存模型本身。

  • 将编辑后的模型保存到 Altium 平台上的工作区时,您可以保留引用该模型的工作区元件的当前生命周期状态。为此,请在 Create Revision 对话框中启用 Preserve lifecycle state (not recommended) 选项。模型本身的当前生命周期状态不会保留。此功能适用于已获分配 Allow to skip lifecycle state change for new revisions 操作权限的用户(了解有关设置工作区全局操作权限的更多信息)。

访问用于更新工作区元件的选项,这些元件引用了正在重新保存的工作区模型(本例中为符号)。
访问用于更新工作区元件的选项,这些元件引用了正在重新保存的工作区模型(本例中为符号)。

在 Create Revision 对话框中单击 OK 后,修改后的模型将保存回工作区,其关联的临时编辑器也将关闭。所有引用该工作区模型的工作区元件都将自动重新保存,以使用模型的新修订版(系统会自动创建每个元件的下一个修订版并执行保存)。

将数据上传到条目的新修订版

大多数内容类型都支持通过上传相应的数据文件来创建新修订版。

以下内容类型不支持通过此方法创建新修订版:元件、复用块、原理图片段、PCB 片段。

可以通过以下几种方式将数据上传到条目的新修订版。

上传菜单

要上传文件,可在 Explorer 面板中右键单击所需条目,然后从右键菜单中选择 Upload 命令。随后将显示 Create New Revision 对话框,您可以在其中根据需要更改名称、描述并添加发布说明。使用对话框的 Sources 区域加载所需文件。您可以将文件从 Windows 资源管理器拖放到该区域。也可以单击 按钮,打开 Add Files 对话框(标准的 Windows 文件打开对话框)。使用此对话框浏览并打开所需文件。

如果条目没有计划修订版,则会上传到下一个计划修订版,该修订版将在上传过程中即时创建。

上传示例。本例中,手动指定要上传到目标 3D 模型条目的 3D 模型文件。
上传示例。本例中,手动指定要上传到目标 3D 模型条目的 3D 模型文件。

拖入所需文件,或选择文件并单击 Open 按钮后,Sources 区域中将显示该文件的条目。

对于支持将多个文件上传到同一修订版的内容类型(例如二进制文件),所选文件将被添加并列出在对话框的 Sources 区域中。如果需要调整列表内容,可根据需要添加其他文件,或选择并移除文件(单击 按钮)。Sources 区域支持使用标准多选方式(Ctrl+Click、Shift+Click 以及单击并拖动)选择多个文件。

单击 OK 按钮继续上传。根据内容类型,已上传文件的相关信息将显示在 Explorer 面板中该条目修订版的 Details 和/或 Preview 视图选项卡上。

返回 Explorer 面板,浏览已保存的条目修订版(此处显示的是 3D 模型条目)。切换到 Preview 视图选项卡可查看其图形表示(如适用)。
返回 Explorer 面板,浏览已保存的条目修订版(此处显示的是 3D 模型条目)。切换到 Preview 视图选项卡可查看其图形表示(如适用)。

从 Windows 资源管理器拖放

您也可以将选定的相关数据文件从 Windows 资源管理器中的源文件夹拖放到 Explorer 面板中所需的目标条目上,以此上传文件。随后将显示 Create New Revision 对话框,拖入的文件会列在 Sources 区域中。根据需要添加 Release Notes,然后单击 OK 按钮。

对于某些内容类型,您需要修改 Name(其值为包含扩展名的文件名;对于多个文件,各项以分号分隔)和 Description(其格式为 Uploaded from <FileNameandPath>, Size <FileSize>, Created on <FileCreationDate>;对于多个文件,各项以分号分隔)。对于支持多个文件的内容类型,如果需要添加其他文件,可以单击 按钮并浏览选择文件,也可以将文件拖放到 Sources 区域中。如果需要移除文件,请在列表中选择文件并单击 按钮。

使用拖放方式上传,此处以 3D 模型为例。
使用拖放方式上传,此处以 3D 模型为例。

如果现有条目没有计划修订版,则会上传到下一个计划修订版,该修订版将在上传过程中即时创建。如果将拖动的数据文件放到现有条目以外的位置,则会创建一个新条目。随后将显示创建新条目对话框。名称和描述字段将预先填充。根据内容类型,填充方式可能如下:
  • 条目的 Name 将为文件名。Description 将为文件名(含扩展名)。
  • 条目的 Name 将为包含扩展名的文件名(对于多个文件,各项以分号分隔)。Description 的格式将为 Uploaded from <FileNameandPath>, Size <FileSize>, Created on <FileCreationDate>(对于多个文件,各项以分号分隔)。

根据需要更改这些值。

Item ID 将遵循文件夹级别定义的条目命名方案。如果文件夹未定义命名方案,则将遵循 $CONTENT_TYPE_CODE-{000000} 方案。

对于仅支持存储单个数据文件的内容类型,如果尝试拖放多个数据文件,系统将自动启动发布管理器对话框。使用此对话框完成多个文件的上传。

克隆工作区内容

Explorer 面板支持克隆多种工作区条目。因此,您无需从头创建所需的元件、领域模型、原理图图纸或模板,只需克隆即可。直接编辑功能可让您轻松对原始条目修订版的源数据副本进行所需修改,并将修改结果发布为同一类型新条目的初始修订版。整个过程高效快捷,让您无需从空白开始,即可快速扩充工作区内容。

可以克隆以下内容类型:

  • 元件
  • 封装
  • 符号
  • 仿真模型
  • 元件模板
  • 受管原理图图纸
  • 原理图模板
  • 项目模板
  • Draftsman 文档模板
  • Draftsman 图纸模板
  • 层叠
  • 输出作业

可通过以下方式从 Explorer 面板访问用于克隆受支持内容类型的命令:

  • 右键单击源条目修订版对应的条目,然后从快捷菜单中选择 Operations » Clone 命令。
  • 选择源条目修订版对应的条目,然后使用 Ctrl+D 键盘快捷键。

在 Explorer 面板中,只要显示了适用的条目修订版,就可以使用 Clone 命令,包括以下位置:

  • 文件夹中的主条目列表。
  • Children 视图选项卡(查看受管原理图图纸条目时)。
  • Where-used 视图选项卡(查看元件条目、符号条目、封装条目、仿真模型条目、元件模板条目或原理图模板条目时)。
  • Preview 视图选项卡(查看元件条目、受管原理图图纸条目或原理图模板条目时)。
浏览特定文件夹中的主条目列表时,可从某个条目的顶层条目访问 Clone 命令,以克隆该条目的最新修订版。
AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents