创建和编辑内容
条目直接在已连接的工作区中创建,制造/表示条目所需的所有数据随后都会按该条目编号存储在该工作区中。根据内容类型,条目可以手动创建,也可以在保存/上传/发布过程中自动创建。所有内容类型都可以通过 Altium Designer 中的 Explorer 面板创建。处理元器件时,也可以通过 Components 面板进行创建。

条目在已连接的工作区中创建。在 Altium Designer 中,Explorer 面板提供了访问工作区的完整界面。
创建条目
定义好所需的文件夹后,即可在工作区中创建内容。要创建条目,请选择相应的文件夹,然后右键单击面板的条目网格区域,并从 Create Item 子菜单中选择一个命令。或者,如果文件夹为空,可以使用该区域中央的 Add an item 控件访问菜单。

右键单击 Explorer 面板的条目网格区域,即可访问与内容创建相关的命令。
随后将显示 Create New Item 对话框,其中提供了完整定义条目所需的所有控件。
“创建新条目”对话框的选项和控件
- Name – 输入新条目的名称。
- Description – 使用此字段输入有意义的描述,说明此条目所表示的内容。
- Item ID – 此条目的唯一 ID。此 ID 的默认格式由父文件夹所采用的 Item Naming Scheme 定义。条目发布后,条目 ID 无法更改。
- Content Type – 此字段列出内容类型。可以从下拉菜单中选择其他内容类型。
- Share Item – 单击以打开 共享设置 对话框,您可以在其中指定此新条目的权限。
-
Advanced – 单击以打开此对话框的高级版本,访问更多选项。
-
Folder – 存储此条目的工作区文件夹。单击
打开 Choose Folder 对话框,以选择或创建其他文件夹。
-
Ancestor Revision – 用于创建此条目或从中创建分支的先前修订版。单击
打开对话框,以浏览并选择现有修订版。 单击 Clear 移除当前的 Ancestor Revision。
-
Revision Naming Scheme – 此字段决定分配修订版 ID 时采用的方案。使用下拉列表从工作区当前定义的方案中选择。方案在 编辑修订版命名方案对话框中定义,单击字段右侧的
即可访问该对话框。由于方案是在条目级别选择的,因此可以对不同条目应用不同方案。条目发布后,所选的 Revision Naming Scheme 无法更改。
- Revision ID – 根据所选修订版命名方案确定的条目修订版。此字段为只读。
-
Lifecycle Definition – 此字段决定使用哪个生命周期定义来描述条目修订版随时间可能经历的状态转换。使用下拉列表从工作区当前定义的生命周期定义中选择。这些定义在 编辑生命周期定义对话框中设置,单击字段右侧的
即可访问该对话框。由于生命周期定义是在条目级别选择的,因此可以对不同条目应用不同定义。条目发布后,所选的 Lifecycle Definition 无法更改。右侧字段显示“修订版 ID”字段中指定的此条目修订版的状态。此字段为只读,新创建的条目始终会设置为 Planned。 - Share Revision – 单击以打开 共享设置对话框,您可以在其中指定此新条目修订版的权限。
-
Folder – 存储此条目的工作区文件夹。单击
-
Open for editing after creation – 启用后,单击 OK 即可打开新条目。这样,您就可以在创建后编辑关联的数据实体,并将其发布到该条目的初始修订版。因此,您无需在工作区之外创建源数据后再进行发布,而是可以借助直接编辑功能,从创建空条目的那一刻起就直接开始处理源数据。编辑完成后,该实体将发布到其父条目的初始计划修订版中,临时编辑器随之关闭。
对于许多内容类型,您可以在创建后编辑相应的设计文档,并将其发布到该内容的初始修订版。为此,请启用 Create New Item 对话框底部的 Open for editing after creation 选项(默认已启用)。条目将被创建,相关的临时编辑器也会打开,供您为该条目创建数据。有关处理特定内容类型的更多信息,请阅读其专门页面,相关链接见表格。
关于条目 ID 的说明……
创建内容时,其所在父文件夹的一个重要属性是所采用的 Item Naming Scheme。它定义了在该文件夹中创建的每个条目的唯一 ID 格式。 通过在文件夹级别定义条目命名方案,可以在该文件夹中快速创建内容,同时遵循正确的 ID 命名方案。尤其是在自动“即时”创建条目,而不是发布到已在目标工作区中手动创建的现有条目时,这一点尤为有用。
系统提供了几种默认示例方案,使用文件夹类型或内容类型的简写代码(代码列表请参阅本文前面的表格)。使用默认命名方案时,软件会扫描整个工作区及现有内容的标识符,然后根据该方案自动分配下一个可用的唯一 ID。
或者,如果需要完全手动控制条目的命名,请选择 [NO ITEM NAMING SCHEME] 条目。随后,必须在创建条目时为其定义唯一标识符。请注意,系统不允许创建标识符重复的条目,因此手动分配标识符时,需要了解哪些标识符已被使用。

父文件夹的条目命名方案会应用于在该文件夹中创建的每个条目的唯一 ID。
无论文件夹级别的 Item Naming Scheme 如何设置,您都可以在条目级别覆盖自动确定的 ID。可根据需要,通过 Create New Item 对话框修改这些 ID。
选择条目 ID 方案
条目可使用的命名或编号方案有无数种,文档图片中展示的方案仅为示例。关于哪种编号方案最佳,有许多讨论可供参考。通常,专家一致认为,简短、无含义的纯数字编号方案最为理想。“无含义”是指编号方案中不编码任何信息,例如产品类别、子类别、位置等;每个新条目只需按顺序分配下一个编号。
标识符的长度非常重要,因为标识符越长,人工记录或回忆条目 ID 时出错的可能性就越大。经验和学术研究表明,数据输入错误会随着字符数量的增加而增多。就便于人们准确记忆而言,七位数字被认为是一个神奇的长度。超过一定长度后,错误率会加速上升——达到 15 个字符时,出错概率接近 100%。
如果您的组织需要通过条目 ID 体现条目的身份信息,那么可以考虑使用组合式标识符。在这种情况下,建议采用简单的字母/数字物料类别前缀代码。例如,考虑 ID D-820-0001。其中,代码中的 D 可以表示设计,说明这是一个用于设计的条目。在接下来的 3 位数字中,第一位可以表示产品类别,例如外围板;该三位数字组中的第二位和第三位可用于表示裸板(1X)或组装板(2X 及以上)。条目 ID 的最后四位数字则是一个简单、无含义、按顺序递增的编号。
设置工作区条目初始修订版的 ID
从本地设计模式转向工作区设计模式,需要将现有数据迁移到工作区。这些数据很可能已经历多次迭代,并分配了整个组织认可的修订版编号。例如,Magno-Synthetic Digitizer 板的修订版 3 可能早已交付,而改进内容计划在修订版 4 中提供。在发布到工作区时,如果初始修订版又从 1 开始,显然会造成混淆——不仅会影响组织内部,更重要的是会影响客户群体(他们期望获得比当前修订版 3 更新的版本!)。
为此,Altium Designer 支持为工作区中新创建条目的初始修订版手动设置 ID。
设置初始修订版的 ID
按常规方式在工作区中创建所需的新条目。创建后,右键点击该条目并选择 Properties,打开 Edit Item 对话框。展开对话框中的 Advanced 区域,然后点击 Revision ID 字段右侧的
按钮。此时将显示 Set Initial revision Id values 对话框,您可以在其中根据需要设置 ID。系统会根据所选的修订版命名方案,提供相应字段,以便修改 ID 的各个层级。

设置 ID 的各个层级(根据所用的修订版命名方案设置适用的层级)。
直接通过工作区创建和编辑内容
您所连接的工作区提供了一种灵活、安全的方式,用于集中存储和管理 Altium Designer 中使用的各类设计数据。从原理图模型到元器件,从受管原理图图纸到完整的 PCB 设计,工作区为您的电子设计数据提供了理想的存储和管理方式。
工作区的一项强大功能是支持 Direct Editing。“直接编辑”究竟是什么意思?它意味着您可以在工作区中右键单击模型、元器件,甚至受管图纸,然后选择 Edit。此时,一个文件会在 Altium Designer 的临时编辑器中打开,供您编辑;完成后,只需将其保存回工作区即可。至于刚刚编辑的文件,您无需操心:由于编辑内容已安全地存回工作区,该文件不再需要,因此会被删除,临时编辑器实例也会关闭。
直接编辑让您摆脱了单独维护受版本控制的源数据的束缚。您只需使用临时编辑器,即可编辑受支持的条目类型,编辑器会直接从工作区加载最新的源数据。编辑完成后,该实体将发布(或重新发布)到其父条目的后续计划修订版中,随后临时编辑器关闭。硬盘上不会留下文件,您无需疑虑自己使用的是否为正确或最新的源数据,也无需维护单独的版本控制软件。工作区会可靠地处理这一切,并大幅加快数据更改的速度。
支持直接编辑的内容类型
以下工作区内容类型支持直接编辑:
编辑条目的初始修订版
在 Explorer 面板中创建受支持内容类型的条目时,您可以选择在创建后编辑关联的数据实体,并将其发布到该条目的初始修订版中。因此,您无需在工作区外部创建源数据后再将其发布,而是可以借助直接编辑功能,从空条目创建完成的那一刻起直接处理源数据。编辑完成后,该实体将发布到其父条目的初始计划修订版中,随后临时编辑器关闭。
要使用此功能,请启用 创建条目对话框底部的 Open for editing after creation 选项。考虑到此功能的实用性,该选项默认启用。条目创建后,相应的临时编辑器将打开,相关文档会作为活动文档显示在主设计窗口中。此文档将按“条目-修订版”命名,格式为:<Item>-<Revision>.<DocumentExtension>。
下图展示了创建新符号条目(SYM-001-0031)时的操作情形。临时原理图符号编辑器随即打开,提供一个文档,供您根据需要定义符号。

直接从工作区编辑符号条目初始修订版的示例——临时原理图符号编辑器提供了用于定义原理图符号的文档。
直接编辑控件
直接编辑时,有三个相关控件可供使用,可从快速访问栏(主应用程序窗口的左上角)或当前临时编辑器的 Standard 工具栏(如果提供)轻松访问:
-
– Save Active Document。使用此按钮可保存对文档所做的任何更改。如果您希望稍后返回继续修改,最后再发布到工作区,可以先保存当前更改。
-
/
– Save to Server。使用此按钮可将文档发布(实际上是保存并发布)到工作区,将其存储在目标条目的初始(计划)修订版或下一修订版中。此时将显示创建修订版对话框(或编辑修订版对话框),您可以在其中更改名称和描述,并根据需要添加发布说明。发布后,文档和编辑器将关闭。
-
/
– Discard Local Changes。如果您希望取消编辑,请使用此按钮。临时文件(仅用于辅助编辑)将被删除,其条目也会从 Projects 面板中移除,且不会向目标条目发布任何内容。
这些控件也可以作为命令,从 Projects 面板中文档条目的右键菜单中访问。对于许多编辑器,也可以从主 File 菜单中使用这些控件对应的命令:Save(快捷键:Ctrl+S)、Save to Server(快捷键:Ctrl+Alt+S)和 Discard Local Changes。
编辑条目的现有修订版
在任何阶段,您都可以返回 Workspace 中受支持内容类型的任意条目修订版 (通过 Explorer 面板),并直接进行编辑。右键单击该修订版,然后从上下文菜单中选择 Edit 命令。临时编辑器将再次打开,其中包含该修订版中的文档,供您编辑。根据需要进行更改,然后提交发布文档,将其保存为该条目的下一个修订版。

访问命令以启动对现有 Draftsman 文档模板的直接编辑的示例。
临时文件的行为
要编辑 Workspace 数据,必须先创建可在 Altium Designer 中编辑的内容。为此,系统会创建临时文件。例如,当您右键单击符号条目并选择 Edit 时,系统会创建一个临时 SchLib 文件,并在 Altium Designer 中打开它。当您完成编辑并执行 Save to Server 后,Workspace 数据一经更新,该文件就会被删除。
但是,如果您不发布该文件,而是对其执行 Save 和 Close,它将保留在 Projects 面板中。这样,您就不必在一次编辑会话中完成整个更新过程——您可以保存工作,并按需关闭文件。Altium Designer 会识别出这是一个特殊文件,因此会将其保留在 Projects 面板的 <WorkspaceName> 条目下(例如,
/
),以便您准备好后重新打开它,完成更新和重新发布过程。

临时文档会保持可访问状态,因此您不必在一次编辑会话中完成所有更改。
从 Components 面板直接编辑元器件
在日常元器件管理中,您可以从 Components 面板进行直接编辑。对于这一特定内容类型,您通常会更多地使用此面板,而不是 Explorer 面板。浏览并找到所需元器件,将其选中,然后右键单击并从上下文菜单中选择 Edit 命令。系统将打开一个处于 Single Component Editing 模式的元器件编辑器临时实例,供您根据需要进行更改。
从元器件编辑器直接编辑模型
使用处于 Single Component Editing 模式的元器件编辑器编辑元器件时,您可以通过直接编辑方式来编辑所链接的领域模型。要修改元器件当前使用(引用)的模型,请单击其预览右上角的
控件。系统将打开与该模型类型对应的临时编辑器,供您根据需要修改模型。完成后,只需保存并关闭编辑器,修改后的模型就会重新显示在 Models 区域中,并保持链接状态。发布元器件时,修改后的模型也会自动发布到 Workspace,成为其所属条目的下一个修订版。

使用处于 Single Component Editing 模式的元器件编辑器,直接编辑正在被某个元器件引用的现有模型的示例;该元器件本身也正在进行直接编辑。
保存领域模型时更新父元器件
当您修改 Workspace 领域模型时——无论是原理图符号、封装模型、仿真模型、线束接线模型还是线束实体模型——一旦将更改保存为模型的新修订版,所有使用该模型的 Workspace 元器件实际上都会变为过时状态,因为它们仍在使用之前的修订版。在大多数情况下,您无疑会希望重新保存这些 Workspace 元器件,并更新相应的模型链接,以使用最新的可用修订版。为了简化这一过程,Workspace 与 Altium Designer 协同工作,支持在通过直接编辑功能修改 Workspace 模型后,重新保存该模型时更新父元器件。
将修改后的 Workspace 模型保存回目标 Workspace 时,会显示 Create Revision 对话框,其中提供了更新父元器件的选项 。此选项(Update items related to <ModelItemRevision>)默认处于启用状态。

访问用于更新工作区元件的选项,这些元件引用了正在重新保存的工作区模型(本例中为符号)。
在 Create Revision 对话框中单击 OK 后,修改后的模型将保存回工作区,其关联的临时编辑器也将关闭。所有引用该工作区模型的工作区元件都将自动重新保存,以使用模型的新修订版(系统会自动创建每个元件的下一个修订版并执行保存)。
将数据上传到条目的新修订版
大多数内容类型都支持通过上传相应的数据文件来创建新修订版。
可以通过以下几种方式将数据上传到条目的新修订版。
上传菜单
要上传文件,可在 Explorer 面板中右键单击所需条目,然后从右键菜单中选择 Upload 命令。随后将显示 Create New Revision 对话框,您可以在其中根据需要更改名称、描述并添加发布说明。使用对话框的 Sources 区域加载所需文件。您可以将文件从 Windows 资源管理器拖放到该区域。也可以单击
按钮,打开 Add Files 对话框(标准的 Windows 文件打开对话框)。使用此对话框浏览并打开所需文件。

上传示例。本例中,手动指定要上传到目标 3D 模型条目的 3D 模型文件。
拖入所需文件,或选择文件并单击 Open 按钮后,Sources 区域中将显示该文件的条目。
单击 OK 按钮继续上传。根据内容类型,已上传文件的相关信息将显示在 Explorer 面板中该条目修订版的 Details 和/或 Preview 视图选项卡上。

返回 Explorer 面板,浏览已保存的条目修订版(此处显示的是 3D 模型条目)。切换到 Preview 视图选项卡可查看其图形表示(如适用)。
从 Windows 资源管理器拖放
您也可以将选定的相关数据文件从 Windows 资源管理器中的源文件夹拖放到 Explorer 面板中所需的目标条目上,以此上传文件。随后将显示 Create New Revision 对话框,拖入的文件会列在 Sources 区域中。根据需要添加 Release Notes,然后单击 OK 按钮。
克隆工作区内容
Explorer 面板支持克隆多种工作区条目。因此,您无需从头创建所需的元件、领域模型、原理图图纸或模板,只需克隆即可。直接编辑功能可让您轻松对原始条目修订版的源数据副本进行所需修改,并将修改结果发布为同一类型新条目的初始修订版。整个过程高效快捷,让您无需从空白开始,即可快速扩充工作区内容。
可以克隆以下内容类型:
- 元件
- 封装
- 符号
- 仿真模型
- 元件模板
- 受管原理图图纸
- 原理图模板
- 项目模板
- Draftsman 文档模板
- Draftsman 图纸模板
- 层叠
- 输出作业
可通过以下方式从 Explorer 面板访问用于克隆受支持内容类型的命令:
- 右键单击源条目修订版对应的条目,然后从快捷菜单中选择 Operations » Clone 命令。
- 选择源条目修订版对应的条目,然后使用 Ctrl+D 键盘快捷键。
在 Explorer 面板中,只要显示了适用的条目修订版,就可以使用 Clone 命令,包括以下位置:
- 文件夹中的主条目列表。
- Children 视图选项卡(查看受管原理图图纸条目时)。
- Where-used 视图选项卡(查看元件条目、符号条目、封装条目、仿真模型条目、元件模板条目或原理图模板条目时)。
- Preview 视图选项卡(查看元件条目、受管原理图图纸条目或原理图模板条目时)。
克隆流程
找到所需的源条目修订版并启动 Clone 命令后,操作流程如下:
- 启动直接编辑会话,在关联的临时编辑器中打开所选条目修订版中存储的源文档副本。对于项目模板条目修订版,项目的临时可编辑副本将在 Projects 面板中打开,以供编辑。
- 根据需要进行更改。
- 将文档保存到本地。
-
单击 Quick Access Bar 上的
按钮,将文档保存到工作区(快捷键 Ctrl+Alt+S)。对于项目模板,请在 Projects 面板中右键单击项目条目,然后从快捷菜单中选择 Save to Server 命令。 或者,使用 Projects 面板中文档条目旁的 Save to Server 控件。此时将显示 “创建新条目”对话框。默认情况下,克隆条目将采用与原始条目相同的修订版命名方案和生命周期定义方案,并创建在同一文件夹中。如有需要,可以更改这些属性。请务必为新条目指定 Name 和 Description。
- 按需设置条目属性后,单击 OK。系统将创建新条目及其初始修订版,发布文档,并关闭临时编辑器。返回 Explorer 面板即可浏览克隆结果。


按钮并浏览选择文件,也可以将文件拖放到 Sources 区域中。如果需要移除文件,请在列表中选择文件并单击 