处理挤压、球形和圆柱形 3D 体
概览
- 了解拉伸体、圆柱体和球体这三类 3D 实体对象的区别,以及各自的定义和放置方法。
- 了解如何使用“属性”面板和命令执行期间的快捷键来控制形状尺寸、外观和放置行为。
- 掌握如何使用“元件实体管理器”根据现有封装形状生成和管理 3D 实体,包括针对单个元件的选项和批量更新选项。
虽然建议通过放置通用 3D 模型来使用 3D 实体对象,因为这样可以在 PCB 上准确、详细地呈现元件,并在 PCB 编辑器中进行更准确的 3D 碰撞检测,但 3D 实体对象也可用于放置拉伸、球形和圆柱形的 3D 实体。可放置的简单 3D 实体对象有三种:
| Extruded | 在 X-Y 平面(俯视图)中,拉伸对象以交互方式定义,与 PCB 编辑器中其他多边形对象的定义方式相同。随后,软件根据 Properties 面板的 3D Body 模式中定义的 Overall Height 和 Standoff Height 属性以及 Body Projection 选项,沿 Z 轴向上(或向下)拉伸该对象。您还可以将纹理文件(例如徽标)应用到拉伸 3D 实体对象的表面。 |
| Cylindrical | 此形状的属性在 Properties 面板的 3D Body 模式中定义。 |
| Spherical | 此形状的属性在 Properties 面板的 3D Body 模式中定义。 |
放置拉伸、球形或圆柱形 3D 实体对象
直接放置
在 PCB 编辑器和 PCB 封装编辑器中,均可通过以下方式放置拉伸、球形和圆柱形 3D 实体对象:
- 从主菜单中选择 Place » Extruded 3D Body 命令。
-
在 Active Bar 上找到并使用“拉伸 3D 实体”命令(
)。
要放置拉伸、球形或圆柱形 3D 实体对象:
- 启动命令后,光标将变为十字形,并进入默认放置模式,即放置拉伸 3D 实体对象。
-
按 Tab 暂停放置,并显示处于 3D 实体模式的 Properties 面板。设计空间中将出现暂停按钮浮层(
),表示您可以访问 Properties 面板中的字段。
- 在 Properties 面板的 Identifier 字段中输入 3D 实体的名称。此项为可选项;放置多个 3D 实体时,标识符有助于区分这些实体,也可根据需要在设计规则中用于指定此 3D 实体。
-
选择所需的 Board Side;通常将其设置为
Top。在 PCB 库编辑器中,封装是针对电路板顶面构建的;如有需要,可在 PCB 设计过程中将其翻转到底面。 - 选择要放置 3D 实体的机械 Layer。元件类型的机械层应与另一个机械层配对,以便在将元件从电路板顶面翻转到底面时,其机械细节(例如 3D 实体)能够移至配对的机械层。机械层在 视图配置面板的 Layers and Colors 选项卡中配对。有关更多信息,请参阅该面板的说明页面。
- 从可用形状中选择 3D Model Type:Extruded、Cylinder 或 Sphere。
-
每种形状都必须先定义尺寸才能放置。如果所选形状为:
- Extruded——则定义 Overall Height。
- Cylinder——定义 Height 和 Radius。
- Sphere——定义 Radius。
- 在面板的 Display 区域中,单击 Color 按钮设置颜色,并根据需要调整 Opacity。
-
完成编辑后,单击暂停按钮浮层,返回设计空间。
-
如果形状为 Cylinder 或 Sphere:
- 光标将在设计空间中移动,并附带一个矩形;单击即可放置 3D 实体。
- 右键单击或按 Esc 结束 3D 实体对象的放置。
-
如果形状为 Extruded,光标将进入就绪状态,以便定义拉伸 3D 实体的多边形底面形状:
- 单击以定义第一个顶点。
- 移动光标,准备放置第二个顶点。默认情况下,每次单击会放置两条边,并在两条边之间形成用户定义的拐角形状。有关更多信息,请参阅下文的拉伸 3D 实体放置模式部分。
- 继续移动鼠标并单击,以放置更多顶点。
- 放置最后一个顶点后,右键单击或按 Esc 闭合并完成 3D 实体的放置。无需手动闭合 3D 实体,软件会自动连接起点与最后放置的点,完成该形状。
-
如果形状为 Cylinder 或 Sphere:
拉伸 3D 实体放置模式
放置拉伸 3D 实体时,有五种可用的拐角模式,其中四种还包含拐角方向子模式。在放置过程中:
- 按 Shift+Spacebar 循环切换五种可用的拐角模式。
- 按 Spacebar 在两种拐角方向子模式之间切换。
-
在任一圆弧拐角模式下,按住
或
键可缩小或增大圆弧。同时按住 Shift 键可加快圆弧尺寸的调整速度。
- 按 1 快捷键,在 每次单击放置两条边和 每次单击放置一条边之间切换。在第二种模式下,虚线边称为 look-ahead segment。
- 按 Backspace 键可移除最后一个顶点。

拉伸 3D 实体对象;请注意 2D 和 3D 视图中显示的参考点。
从闭合形状创建
为了加快使用 3D 实体构建元件外形的过程,软件可以根据封装中检测到的闭合形状创建一系列拉伸式 3D 实体对象。如果元件具有不规则形状,且该形状已体现在封装的元件丝印图形中,此功能会很有帮助。您还可以在封装的机械层上添加其他对象,然后利用这些对象创建更多 3D 实体对象, 例如创建引脚。
下图展示了一个 TO-92 晶体管封装。其中,绘制在顶层丝印层上的轮廓用于在所选的 3D 实体层对(在对话框中称为 Registration Layer)上定义晶体管主体。此外,还在一个机械层上创建了三个小正方形(每个正方形由四条线组成),用于在 所选的 3D 实体层对上定义元件引脚,具体设置如下方的对话框图所示。
要根据封装中的形状创建 3D 实体对象,请运行 Tools » Manage 3D Bodies for Current Component 命令,随后将打开 Component Body Manager 对话框。 通过此对话框,您可以查看元件当前使用了哪些 3D 实体,以及哪些尚未使用。您可以根据需要向元件添加实体或从中移除实体。实体可分为三种不同类型:
- 手动放置的 3D 实体(在其描述中称为 Component Body)。
- 软件根据边界矩形自动创建的矩形形状。
- 软件根据设计图元自动创建的闭合多边形形状。
您还可以修改实体的其他属性,例如高度、实体投影、定位层、颜色和不透明度。 请注意,Body State 列显示将使用四个形状来创建 3D 实体对象。
按要求定义好元件的 3D 实体后,点击 Close 按钮即可应用更改。
使用此对话框时的注意事项:
- 检测算法会提供以下两种形状之一:根据边界矩形创建的矩形形状,或沿图元所构成轮廓生成的多边形形状(如果走线/圆弧的端点重合,则沿其中心线描绘)。
- 要根据已有对象创建 3D 实体,请点击 Body State 列中的蓝色文本。
- Overall Height 默认采用封装的 Properties 面板中定义的 Height。
- 对于向下穿过电路板的元件引脚,请将 Body Projection 设置为 Bottom Side。
- 点击对话框中的 Close 按钮时,会创建 3D 实体对象。如果当前显示已设置为 3D 模式,您可能需要刷新显示(End 快捷键)、切换到 2D 后再切回 3D,或者在 View Configurations 面板的 View Options 选项卡中将 Show 3D Bodies 选项在 Off 和 On 之间切换,才能看到新对象。
- 要编辑 PCB 封装编辑器中当前打开的活动 PCB 封装库内所有元件的 3D 实体, 请从主菜单中选择 Tools » Manage 3D Bodies for Library 命令。
- 要在 PCB 编辑器中使用此对话框编辑 3D 实体,可以从主菜单中选择 Tools » Manage 3D Bodies for Components on Board 命令,或右键点击元件并从上下文菜单中选择 元件操作 » 管理 3D 实体 。
-
使用 Tools » Manage 3D Bodies for Components on Board 命令(在 PCB 编辑器中)或 Tools » Manage 3D Bodies for Library 命令(在 PCB 封装编辑器中)打开此对话框时,对话框顶部会显示 Components 区域。此区域列出活动库中的每个元件封装(在实际设计中,此处会列出电路板上的所有元件)。每个条目都会显示位号(仅在设计端可用)、封装名称、高度和源库信息。
此外,还会显示一个额外的 Batch Update 选项卡。 此选项卡可用于快速为所有元件或选定元件批量添加 3D 实体对象。您可以定义用于检测和创建 3D 实体的搜索条件,以及用于定义 3D 实体属性的条件。按要求定义好批处理的所有选项后,点击 Execute Batch Update 按钮。系统将对参与处理的每个元件执行搜索;检测到并创建 3D 实体形状后,将按照所定义的属性条件把该实体添加到元件中。在此模式下,更改会在执行批量更新时应用。
- 此对话框可让您在同一位置管理元件的所有 3D 实体,无需为每个 3D 实体单独打开 Properties 面板。
元件实体管理器对话框的选项和控件

Component Body Manager 对话框(后方)和 元件的元件实体管理器对话框(前方)
元件
对话框顶部区域列出活动库中的每个元件封装(在实际设计中,此处会列出电路板上的所有元件)。每个条目都会显示位号(仅在设计端可用)、封装名称、高度和源库信息。
交互式选项卡

Component Body Manager 对话框的 Interactive 选项卡
此对话框的 Component Body Manager 版本包含两个选项卡:Interactive 选项卡和 Batch Update 选项卡。Interactive 选项卡可让您轻松查看所选元件的信息,包括元件实体和所选实体的预览。
现有及潜在的元件实体
-
Existing and Potential Component Bodies - 此区域 列出元件正在使用或可能使用的所有现有元件实体(3D 实体)。每个元件实体都按以下信息列出:
-
Description - 描述实体的创建方式。它可以是手动放置的 3D 实体(在其描述中称为 Component Body)、根据边界矩形创建的矩形形状,或根据设计图元创建的闭合多边形形状。每个实体的描述(无论是手动放置还是自动创建)还会包含其所在的机械层(或用于创建该实体的对象所在的机械层)及其面积。矩形实体和多边形实体通过
和
区分图标分别表示。
- Body State - 表示该实体是否用于元件中(In Component <ComponentDesignator>)或未使用(Not In Component <ComponentDesignator>)。单击该条目可根据需要切换状态。
- Standoff Height - 从板表面到拉伸实体底面的距离。对于必须向下穿过 PCB 的拉伸实体,请使用负值。
- Overall Height - 从板表面到拉伸实体顶面的距离。
- Body Projection - 3D 实体从电路板的哪一侧伸出。使用该字段的下拉列表选择 Top Side 或 Bottom Side(向上伸出或向下伸出)。如果翻转元件时将 3D 实体对象翻转到电路板的另一侧,此设置会自动更改。
- Registration Layer - 3D 实体所在的机械层。使用该字段的下拉列表从当前所有已启用的机械层中进行选择。如果所选机械层已配对,那么当实体随元件翻转到电路板的另一侧时,它也会移至配对的机械层。
- Body 3D Color - 3D 实体当前使用的颜色。单击色块可打开标准 Choose Color 对话框,根据需要指定其他颜色。
- Body 3D Opacity - 3D 实体当前的透明度。使用该字段的下拉列表选择 Solid (完全不透明)、Hide (使实体不可见)、25% Opacity、50% Opacity 或 75% Opacity。
-
Description - 描述实体的创建方式。它可以是手动放置的 3D 实体(在其描述中称为 Component Body)、根据边界矩形创建的矩形形状,或根据设计图元创建的闭合多边形形状。每个实体的描述(无论是手动放置还是自动创建)还会包含其所在的机械层(或用于创建该实体的对象所在的机械层)及其面积。矩形实体和多边形实体通过
- Component bodies in: <ComponentDesignator> - 显示元件的 2D 封装,以及叠加显示的 3D 实体,这些实体的 Body State 当前设置为 In Component <ComponentDesignator>。此预览是动态的,会随着实体的包含或排除而变化。
- Selected Body - 显示上方列表中当前选中的实体。窗口的标题区域也会显示该实体的描述。
批量更新选项卡

Component Body Manager 对话框的 Batch Update 选项卡
Batch Update 选项卡提供了一项功能,可快速将 3D 实体对象添加到库中的所有或选定封装,或设计中所有或选定的已放置封装。
网格区域
使用此区域定义用于检测和创建 3D 实体的搜索条件,以及定义 3D 实体的属性,例如 Projection side(也称为实体投影)、Registration Layer、Standoff Height、Overall Height 和 3D Body Color。
列表中的每个条目都指定了不同的图层搜索范围,用于检测和创建可能的 3D 实体形状。每项搜索均可通过 Enabled 列中的选项单独启用。可以启用多项搜索,但请注意,每项成功的搜索都会添加一个 3D 实体。通常,应根据封装图元或元件外形信息的常用放置位置,启用对某个特定图层或图层组的搜索。默认情况下,将搜索 All Layers。
Detection Method 字段可用于控制每个 3D 实体形状的定义方式:
- Bounding Rectangle - 使用封装的外接矩形。
- Closed Shapes - 使用由元件封装图元构成的多边形闭合形状。
- Both (Prefer Closed Shapes) - 根据封装图元检测外接矩形或多边形闭合形状。如果两者均被检测到,则使用多边形闭合形状。
Prefer component height if not 0 选项列可用于控制是否将元件封装定义的高度属性用作 3D 实体的 Overall Height。启用此选项后,对于每个定义了大于零的高度属性的元件,该高度将设为所添加 3D 实体的 Overall Height,其 Standoff Height 将设为零。
Body 3-D Color 指定渲染 3D 实体所用的颜色。单击颜色可在 Choose Color 对话框中更改颜色。
选项
- Apply Only To Selected Components - 如果只想将 3D 实体条件应用于一组选定的封装,请启用此选项。确保已在对话框顶部区域选中这些元件(使用标准的 Ctrl+Click 和 Shift+Click 功能进行多选)。如果禁用此选项,批量添加过程将应用于库中的所有封装(或电路板上的所有元件)。
- Delete Existing Bodies In Components - 启用此选项可移除批处理目标封装中当前定义的所有 3D 实体。使用选项卡右下角的预览窗口,可根据当前选中的元件封装和当前选中(且已启用)的搜索条目,查看所添加 3D 实体的外观。根据需要定义好批处理的所有选项后,单击 Execute Batch Update 按钮。系统将对批处理中包含的每个封装执行搜索;检测并创建出 3D 实体形状后,将按照已定义的属性条件将该实体添加到封装中。
批量操作预览
用于预览不同图层中定义的 3D 实体。
其他控件
- Execute Batch Update - 单击可对批处理中包含的每个封装执行更新;检测并创建出 3D 实体形状后,将按照已定义的属性条件将该实体添加到封装中。
从选定图元创建
除了以交互方式放置 3D 实体外,还可以从一组构成闭合形状的现有走线、圆弧和实心区域对象创建 3D 实体。当模型较简单时,这是一种非常合适的方法。要从现有闭合形状定义 3D 实体:
- 选择构成闭合形状的所有图元。
- 单击 Tools » Convert » Create 3D Body From selected primitives。
无论所选走线位于哪个图层,都会根据这些图元构成的闭合边界在顶层创建 3D 实体。这意味着您可以在机械层上定义形状。请注意,区域创建后,原先选中的图元仍会保留,并保持选中状态。3D 实体的边界沿边界走线对象的中心线生成,且该 3D 实体不会被选中。
由于 Create 3D Body From selected primitives 算法使用所选对象的中心线,因此相接对象的终点和起点必须完全重合(位于相同的 X、Y 坐标)。否则,将出现 Confirm 对话框,指出算法失败的位置,并允许您指示算法尝试改用对象的边缘来定义 3D 实体。只要所选对象之间略有重叠,此选项就应能创建一个 3D 实体,其边缘沿所选对象的外边缘生成。
图形化编辑
图形化编辑方式允许您直接在设计空间中选择已放置的 3D 实体对象,并以图形化方式更改其大小、形状或位置。
对于拉伸型 3D 实体,单击对象即可将其选中并进入编辑模式。3D 实体对象的外形由一系列边定义:每条边的两端各有一个端点顶点,以白色实心方块表示(下图中的 A);中间有一个中心顶点,以白色空心方块表示(下图中的 B)。每个端点顶点表示两条边的交汇位置。
您可以使用标准的多边形形状编辑技巧来编辑形状。
编辑多边形对象时,有三种可用的编辑模式:Slide/Miter、Incurvate(圆弧)和 Move。按下 Shift+Spacebar 可在这三种模式之间循环切换,从而 while dragging a vertex or an edge 更改当前模式。
- Slide/Miter – 单击并按住边或中心顶点可滑动该边;单击并按住端点顶点可对拐角进行斜切。
- Incurvate – 单击并按住边或中心顶点可将该边弯曲为圆弧;单击并按住端点顶点可将拐角变为圆弧(圆弧斜切)。
- Move – 单击并按住边或中心顶点可将该边拆分为两条边;单击并按住端点顶点可自由移动该拐角。
编辑过程中,您还可以:
- Ctrl+click and hold 在边上远离编辑控制点的任意位置 执行此操作,以插入新顶点。
- 要移除顶点,请单击并按住该顶点, 然后按 Delete 键。
-
单击 3D 实体上远离编辑控制点的任意位置, 然后拖动以重新定位。拖动时,可以旋转或镜像 3D 实体:
- 按 Spacebar 可逆时针旋转 3D 实体,按 Shift+Spacebar 可顺时针旋转。Rotation Step 的大小在 Preferences 对话框的 PCB 编辑器 – 常规页面中定义。
- 按 X 或 Y 键可沿 X 轴或 Y 轴镜像 3D 实体。
转换为 STEP
可将选中的 拉伸型/圆柱形/球形 3D 实体对象转换为 STEP 模型。STEP 模型会自动嵌入设计文件。要转换独立的 3D 实体对象,请在设计空间中将其选中,然后右键单击并从上下文菜单中选择 Convert To STEP 命令。如果未选中对象或选中了多个对象,该命令将不可用。对象转换为 STEP 后,将无法再在设计空间中调整其大小。

如果需要绕 X 轴或 Y 轴旋转拉伸型对象,请将其转换为 STEP。
拉伸型、球形或圆柱形 3D 实体对象的参考点
拉伸型、球形或圆柱形 3D 实体对象具有参考点 或原点。
- 对于圆柱形和球形对象,参考点是对象在 X-Y 平面上的圆形轮廓的中心点。
- 对于拉伸型对象,从上方观察时,参考点位于 X 长度/2、Y 长度/2 处。
- Properties 面板中的 X/Y Location 显示的就是此参考点在设计空间中的位置。

拉伸型、球形和圆柱形 3D 实体对象都有参考点,如图所示。请注意,参考点的指示线较短, 因此可能不会延伸到对象之外。
为拉伸型 3D 实体添加纹理
拉伸型对象还可以在最上表面叠加图像, 使电路板在 3D 视图中更加逼真。添加 Texture File 后,它会自动拉伸以覆盖 3D 实体的整个上表面,如下图所示。 请注意,纹理文件链接到库文件或电路板文件。
支持的纹理文件格式包括:*.bmp;*.dds;*.dib;*.hdr;*.jpg;*.pfm;*.png;*.ppm;以及 *.tga。

可以为拉伸型 3D 实体对象添加纹理或徽标。
您可以在 Properties 面板的 3D Body 模式中,通过更改 Center 位置、Size 和 Rotation 设置来进行调整。
当编辑器处于 3D 布局模式时,您还可以从主菜单中选择 Tools » 3D Body Placement » Move Texture Location 命令,修改与所选拉伸型 3D 模型关联的纹理对象的位置。 启动命令后,光标将变为蓝色圆锥(表示 3D 选择模式),系统会提示您选择一个已关联纹理的拉伸型 3D 实体。将光标移到所需的 3D 实体上,然后单击 或按 Enter。再次单击 或按 Enter ,通过纹理最近的角点将其“拾取”。将纹理移动到所需位置,然后单击 或按 Enter 完成放置。在移动过程中,当纹理仍附着在光标上时,可以执行对象移动的标准附加操作(Spacebar/Shift+Spacebar 用于旋转,X 或 Y 用于镜像,方向键用于微调纹理位置)。
另外,您也可以使用鼠标单击并拖动,移动选中的拉伸型 3D 实体中的纹理。



