Suchen nach und Platzieren von Komponenten

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Auf einen Blick

Dieser Artikel erläutert, wie Sie mit dem Bedienfeld „Components“ in Altium Designer Bauteile aus Ihrem Workspace sowie aus Datenbank- und dateibasierten Bibliotheken finden, prüfen, verwalten und platzieren können. Er stellt die verschiedenen Suchmöglichkeiten vor, darunter das Durchsuchen von Kategorien, die direkte Suche mit Suchabfragen und die parametrische Filterung von Workspace-Bauteilen. Außerdem zeigt er, wie das Bedienfeld mit verwandten Werkzeugen wie dem Bedienfeld „Manufacturer Part Search“, dem Bauteileditor und dem Bedienfeld „Explorer“ zusammenarbeitet. Sie erfahren auch, wie Sie das Bedienfeld aus Schaltplan- und PCB-Dokumenten öffnen, wie Bauteilkategorien bestimmt werden und welche Funktionen und Anzeigeoptionen Ihnen helfen, Ihren Arbeitsablauf zu optimieren. Wenn Sie die passenden Bauteile gezielter finden und effizient in Ihren Designs platzieren möchten, lesen Sie weiter.

- Erfahren Sie, wie Sie im Bedienfeld „Components“ mithilfe von Kategorien, Suchabfragen und parameterbasierten Filtern nach Bauteilen suchen.
- Lernen Sie die verschiedenen Bauteilquellen kennen, darunter Workspace-Quellen, dateibasierte Bibliotheken, Datenbankbibliotheken und Ergebnisse aus dem Bedienfeld „Manufacturer Part Search“.
- Erfahren Sie, wie Sie Bauteile platzieren und wichtige Funktionen des Bedienfelds nutzen, um Details anzuzeigen, Bauteile zu bearbeiten, Bibliotheken zu verwalten und die Bauteilliste zu organisieren.
Mit KI tiefer einsteigen:

Das Herzstück jedes Elektronikdesigns sind die Bauteile. Das Bauteil, das Sie letztendlich auf die Leiterplatte löten, muss in jeder Designdomäne dargestellt bzw. modelliert werden: als Symbol im Schaltplan, als SPICE-Modell im Simulator, als Footprint auf der Leiterplatte und als 3D-STEP-Modell in der Datei, die Sie an den Mechanikentwickler übergeben.

Erfahren Sie mehr über das Erstellen und Pflegen Ihrer Bauteile und Bibliotheken.

Das Components-Panel von Altium Designer bietet eine leistungsstarke Benutzeroberfläche für die Arbeit mit all Ihren Bauteilen – sowohl aus einem Workspace als auch aus anderen Quellen. Sie können nach dem benötigten Bauteil suchen, indem Sie die Kategorie festlegen und im einfachen Suchmodus eine Suchanfrage (einen vollständigen oder teilweisen Bauteilnamen, einen Wert usw.) in das Suchfeld eingeben. Darüber hinaus bietet das Panel eine filterbasierte parametrische (facettierte) Suche, mit der Sie die gewünschten Bauteilparameter für Ihre Workspace-Bauteile festlegen können. Das Panel bietet außerdem Optionen, um ein Workspace-Bauteil im Component Editor im Modus zur Bearbeitung einzelner Bauteile zu bearbeiten, das Bauteil in seinem Quell-Workspace anzuzeigen und Funktionen zur Bauteilverwaltung auszuführen. Dazu gehören das Erstellen und Klonen von Bauteilen sowie das Bearbeiten der Bauteilauswahl und des Typs des ausgewählten Bauteils. Ein Bauteil lässt sich durch Ziehen oder mit dem Befehl Place aus seinem Kontextmenü im Schaltplan platzieren.

Sie können natürlich eigene Bauteile erstellen. Altium Designer bietet jedoch auch ein leistungsstarkes Manufacturer Part Search-Panel, mit dem Sie nach tatsächlich hergestellten Bauteilen suchen können. Wenn Sie über einen Workspace verfügen, können Sie diese Bauteile darin speichern und anschließend über das Components-Panel darauf zugreifen. Bei diesem Vorgang wird mit dem Component Editor im Modus zur Bearbeitung einzelner Bauteile ein neues Workspace-Bauteil erstellt und in Ihrem Workspace gespeichert.

Das Components-Panel bietet direkten Zugriff auf verfügbare Workspace-Bauteile sowie auf Bauteile aus datenbankbasierten und dateibasierten Bibliotheken in Altium Designer.

Das Panel bezieht Bauteile aus einem verbundenen Workspace sowie aus allen geöffneten oder installierten Bibliotheken. Es bietet umfassende Details zum ausgewählten Bauteil (Parameter, Modelle, Bauteilauswahl, Lieferantendaten usw.), einen Bauteilvergleich und für Workspace-Bauteile eine filterbasierte parametrische Suche zur Festlegung der gewünschten Bauteilparameter.

Das Components-Panel im normalen Modus

Das Components-Panel im kompakten Modus

 

Das Components-Panel verwendet die grundlegende Suchmaschinenfunktionalität und Ansicht des Manufacturer Part Search-Panels. Während das Manufacturer Part Search-Panel den Altium Parts Provider-Dienst nutzt und sich auf die Suche nach Bauteilhersteller- und Lieferantendaten konzentriert, enthält das Components-Panel platzierungsfertige Bauteile aus Ihrem verbundenen Workspace sowie aus datenbank- und dateibasierten Bibliotheksquellen.

Bei Workspace-Bauteilen wird im Panel nur die jeweils neueste Revision angezeigt.
Obwohl viele Funktionen für die Arbeit mit Bauteilen über das Components-Panel verfügbar sind, können Sie auch das Explorer-Panel verwenden. Im Wesentlichen bietet ersteres eine auf die Bauteilverwaltung ausgerichtete Teilmenge der Funktionen des letzteren. Einige Funktionen für die Bauteile selbst lassen sich weiterhin nur über das Explorer-Panel ausführen (Hinzufügen von Datenblättern ohne Bearbeitung, Ändern von Zuständen, gleichzeitiges Löschen mehrerer Bauteile und Modelle usw.). Diese sind jedoch eher für untypische Sonderfälle oder für administrative Aufgaben bzw. die Strukturierung des Workspace gedacht. Denken Sie daran, dass Bauteile nur einen Inhaltstyp darstellen – das Explorer-Panel entfaltet seine Stärken bei der gesamten Bandbreite der von einem Workspace unterstützten Inhaltstypen. Beispielsweise können Bauteilvorlagen – die für Bauteile von großer Bedeutung sind – ausschließlich im Explorer-Panel erstellt und verwaltet werden (es sei denn, die Vorlagen werden beim Bibliotheksimport mit dem Library Importer erstellt).

Zugriff auf das Components-Panel

Um das Components-Panel zu öffnen, wählen Sie View » Panels » Components in den Hauptmenüs oder die Option Components im Menü der Schaltfläche unten rechts im Hauptfenster. Dank eines responsiven Designs passt sich das Panel-Layout dynamisch zwischen dem normalen Modus in voller Größe () und dem kompakten Modus () an, in dem die Optionen für Kategorien/Filter zu Menüs zusammengefasst werden.

Verwenden Sie in einem Schaltplandokument die Tastenkombination P, P, um das Components-Panel zu öffnen. Sie können auch den Befehl Place » Part aus den Hauptmenüs, den Befehl Place » Part aus dem Kontextmenü des Designbereichs im Schaltplaneditor oder die Schaltfläche Part () auf der Active Bar verwenden.

Verwenden Sie in einem PCB-Dokument die Tastenkombination P, C, um das Components-Panel zu öffnen. Sie können auch den Befehl Place » Component aus den Hauptmenüs, den Befehl Place » Component aus dem Kontextmenü des Designbereichs im PCB-Editor oder den Befehl Component () auf der Active Bar verwenden.

Beim ersten Öffnen des Components-Panels in der aktuellen Altium Designer-Sitzung sind bei bestehender Verbindung mit einem Workspace die folgenden Bedienelemente verfügbar:

  • Use Existing Components – Klicken Sie hier, um den Bauteiltyp zu durchsuchen, der aktuell in der oberen Dropdown-Liste des Panels ausgewählt ist.

  • Delete Existing Components – Klicken Sie hier, um den Dialog Delete Existing Components und anschließend die Seite Data Cleanup der Settings Ihres Workspace zu öffnen. Dort können Sie die zu entfernenden Inhaltstypen auswählen.

  • Import Library – Klicken Sie hier, um den Windows-Standarddialog Open zu öffnen, und wählen Sie anschließend eine datenbank- oder dateibasierte Bibliothek aus, die in einem lokalen Ordner oder Netzwerkordner gespeichert ist. Nach dem Öffnen einer Bibliotheksdatei wird der Library Importer im einfachen Modus mit der ausgewählten Bibliothek gestartet.

  • Create Component – Klicken Sie hier, um den Dialog Create New Component und anschließend den Component Editor im Modus zur Bearbeitung einzelner Bauteile zu öffnen, in dem Sie ein neues Bauteil definieren können.

Der Bereich Categories des Panels (bzw. das Dropdown-Menü im kompakten Modus) listet alle verfügbaren Workspace-Bauteile unter dem Kategorieeintrag All sowie alle verfügbaren Bibliotheken auf. Wenn sich das Panel im normalen Modus befindet, klicken Sie auf das Listensymbol Categories oder auf das Symbol «, um die Spaltenanzeige ein- oder auszuklappen. Mit der Schaltfläche (oben rechts) können Sie den Bauteilbereich Details ein- oder ausblenden. Beim Durchsuchen des Bereichs Categories können Sie mit den Tastenkombinationen Up/Down und PgUp/PgDn durch die Liste navigieren. Mit den Tastenkombinationen Left/Right lassen sich die einzelnen Zweige auf- und zuklappen.

Die Categories-Gruppierung für Workspace-Komponenten wird aus den Component Type-Parametern abgeleitet, die den einzelnen Komponenten zugeordnet sind. Wenn beispielsweise Component Type für eine Komponente als Resistor festgelegt wurde, wird diese Komponente im Components-Panel unter der Kategorie Resistor aufgeführt (unabhängig davon, in welchem Workspace-Ordner sie sich befindet).

Um den Typ einer Komponente direkt festzulegen oder zu ändern, klicken Sie mit der rechten Maustaste auf ihren Eintrag und wählen Sie im Kontextmenü die Option Operations » Change Component Type, um den Dialog zur Auswahl des Komponententyps zu öffnen.

Der Parameter „Type“ einer Komponente wird festgelegt:

Komponententypen werden auf der Seite „Data Management – Component Types“ des Dialogs Preferences verwaltet (erstellt/bearbeitet/entfernt). Die Schaltfläche Templates des Dialogs öffnet den Dialog Edit Templates, in dem die jedem Komponententyp zugeordnete Komponentenvorlage festgelegt oder geändert werden kann.

NOTE: Unter welchem Category eine Komponente aufgeführt wird, hängt von ihrem Parameter „Component Type“ ab und steht nicht in Zusammenhang mit dem Workspace-Ordner, in dem sie sich befindet. Wenn Sie eine Komponente über das Explorer-Panel in einen anderen Ordner verschieben, wird diese Änderung daher nicht im Components-Panel widergespiegelt.

Aktionsmenü

Mit den Optionen des Aktionsmenüs können Sie Einstellungen für dateibasierte Bibliotheken festlegen, Suchvorgänge durchführen und bestimmen, ob Komponentenmodellsammlungen sichtbar sind. Um auf diese Optionen zuzugreifen, klicken Sie oben rechts im Panel auf die Schaltfläche für das Aktionsmenü.

  • Create Component – Öffnet den Dialog Create new component und anschließend den Komponenteneditor im Einzelkomponenten-Bearbeitungsmodus, in dem Sie eine neue Komponente definieren können.
  • Import Library – Öffnet den Windows-Standarddialog Open, in dem Sie eine Datenbankbibliothek oder eine dateibasierte Bibliothek auswählen können, die in einem lokalen Ordner oder Netzwerkordner gespeichert ist. Nach dem Öffnen einer Bibliotheksdatei wird der Library Importer im einfachen Modus gestartet und die ausgewählte Bibliothek geladen.
  • Clean-up Library – Öffnet den Dialog Delete Existing Components und anschließend die Seite Data Cleanup der Settings Ihres Workspace, auf der Sie die zu entfernenden Inhaltstypen auswählen können.
  • Models – Nimmt Einträge aus Bibliotheksmodellsammlungen in die Categories-Liste auf. Die zusätzlichen Einträge in diesem Ansichtsmodus umfassen Sammlungen von Symbolen, Footprints und Simulationsmodellen aus dem verbundenen Workspace sowie installierte PCB-Footprint-Bibliotheken (*.PcbLib).
  • File-based Libraries Preferences – Öffnet den Dialog Available File-based Libraries. Dort stehen Ihnen Steuerelemente zur Verfügung, um Datenbankbibliotheken und dateibasierte Bibliotheken zum aktuellen Projekt hinzuzufügen oder daraus zu entfernen, Bibliotheken zu installieren und Suchpfade für Bibliotheken festzulegen. Weitere Informationen finden Sie im Abschnitt Verwalten verfügbarer Datenbankbibliotheken und dateibasierter Bibliotheken auf der Seite Suchen nach Komponenten in dateibasierten Bibliotheken und Datenbankbibliotheken.
  • File-based Library Search – Öffnet den Dialog File-based Libraries Search, in dem Sie nach einer Komponente suchen können, wenn Sie nicht wissen, in welcher Datenbankbibliothek oder dateibasierten Bibliothek sie enthalten ist oder ob sie überhaupt verfügbar ist. Weitere Informationen finden Sie im Abschnitt Suchen nach Komponenten in Datenbankbibliotheken und dateibasierten Bibliotheken auf der Seite Suchen nach Komponenten in dateibasierten Bibliotheken und Datenbankbibliotheken.
  • Refresh – Aktualisiert das Panel schnell. Die aktuelle Komponentenauswahl bleibt erhalten.

Komponentenliste

Innerhalb der Komponententabelle können Sie die Darstellung der Liste wie folgt anpassen:

  • Sortierreihenfolge der Komponentenliste festlegen – Klicken Sie auf eine Spaltenüberschrift, um die Komponentenliste nach den Daten dieser Spalte zu sortieren. Klicken Sie erneut auf die Überschrift, um die Sortierreihenfolge umzukehren.

  • Reihenfolge der angezeigten Spalten festlegen – Ziehen Sie eine Spaltenüberschrift per Drag-and-drop an eine neue Position.

  • Anzuzeigende Parameterspalten festlegen – Klicken Sie mit der rechten Maustaste auf eine Spaltenüberschrift und wählen Sie Select Columns, um den Dialog Select Columns zu öffnen. Darin können Sie die Sichtbarkeit einer Parameterspalte steuern und ihre Position ändern.

    Der Dialog Select columns
    Der Dialog Select columns

    • Der Dialog listet alle Spalten auf, die im Components-Panel angezeigt werden können. Wenn bei einem Eintrag  angezeigt wird, wird die entsprechende Spalte im Components -Panel angezeigt. Wenn bei einem Eintrag  angezeigt wird, wird die entsprechende Spalte im Components-Panel not angezeigt. Klicken Sie auf die Symbole, um zwischen Ein- und Ausblenden umzuschalten.

    • Sie können die Anzeige aller Spalten auch steuern, indem Sie auf das Symbol / in der Spaltenkopfzeile klicken. Wenn einige Spalten sichtbar und andere ausgeblendet sind, wird das Symbol  angezeigt.

    • Bewegen Sie den Mauszeiger über die Kopfzeile der zweiten Spalte und klicken Sie auf das Symbol , um eine Dropdown-Liste zu öffnen, in der Sie die anzuzeigende Spalte auswählen können.

    • Verwenden Sie die Schaltflächen  / , um den ausgewählten Eintrag in der Liste nach oben oder unten zu verschieben. Nur Einträge, die auf sichtbar () gesetzt sind, können verschoben werden. Dadurch wird die Reihenfolge festgelegt, in der die Spalten im Components-Panel angezeigt werden.

  • Liste nach Spaltendaten gruppieren – Klicken Sie mit der rechten Maustaste auf eine Spaltenüberschrift, wählen Sie die Option Enable Columns Grouping und ziehen Sie dann eine Spaltenüberschrift (z. B. Footprint) in den Gruppierungsbereich oberhalb der Liste. Die Listeneinträge werden nach den einzelnen Parameterwerten (z. B. Footprint-Typ) der ausgewählten Gruppierungsspalte zusammengefasst.

    Wenn Sie Grouping verwenden, um Komponenten in der Liste zusammenzufassen, können maximal 10.000 Einträge berücksichtigt werden.

  • Liste nach einem bestimmten Spalteneintrag filtern – Wählen Sie in einer Spaltenüberschrift, um eine Liste der darin vorkommenden eindeutigen Parameterwerte anzuzeigen. Wählen Sie dann einen Eintrag aus, um die angezeigten Komponenten auf diejenigen zu beschränken, die den angegebenen Parameterwert enthalten (z. B. einen Footprint-Typcode). Wählen Sie die Option All, um den Filter zurückzusetzen. Wählen Sie (Custom), um den Dialog Filter Editor zu öffnen und die Filterung in der ausgewählten Spalte weiter zu verfeinern.

Spalten anzeigen

Sie können die Inhalte im Components-Panel auf verschiedene Weise anzeigen. Wenn Sie mit der rechten Maustaste auf eine der Spaltenüberschriften (Name, Description, Footprint) klicken, stehen Ihnen je nach gewünschter Darstellung der Komponenten folgende Optionen zur Verfügung:

  • Best Fit – Passt die Spalten Name und Descriptions so an, dass ihre Inhalte dicht beieinanderliegen und kein überflüssiger Abstand zwischen den Spalten bleibt.

  • Best Fit All Columns – Passt alle Spalten so an, dass ihre Inhalte dicht beieinanderliegen und kein überflüssiger Abstand zwischen den Spalten bleibt.

  • Clear Sorting – Hebt die Sortierung der Spalten auf.

  • Enable Columns Grouping – ermöglicht es Ihnen, Spaltenüberschriften an eine bestimmte Spaltenposition zu ziehen und so die Reihenfolge der Spalten Name, Description und Footprint zu ändern.

  • Select Columns – öffnet den Dialog Select Columns, in dem Sie weitere Spalten auswählen können, die in diesem Bereich angezeigt werden sollen.

  • Apply Column Visibility to Child Categories – wenn die ausgewählte Kategorie eine Unterkategorie besitzt, können Sie mit diesem Befehl die Einstellungen zur Spaltensichtbarkeit von übergeordneten Kategorien auf Unterkategorien übertragen. Dieser Befehl ist nur verfügbar, wenn eine Unterkategorie vorhanden ist.

Bauteilsuche und Funktionen

Nach Bauteilen suchen

Um im Panel Components nach verfügbaren Bauteilen zu suchen, geben Sie einen Suchbegriff in das Feld Search ein und/oder verwenden Sie die Auswahlmöglichkeiten Categories und Filters des Panels, um die Bauteilliste auf Ihre spezifischen Anforderungen einzugrenzen. Filter werden nur für Workspace-Bauteile unterstützt. Wie das Panel Manufacturer Part Search unterstützt auch das Panel Components einheitenberücksichtigende Suchfilter (Text zu Zahl). Die Suchfunktion priorisiert die Ergebnisse entsprechend den eingegebenen Suchkriterien.

Mit der Funktion Search können Sie eine aktive Search-Suchzeichenfolge auswählen und anschließend bearbeiten oder ergänzen.

Klicken Sie auf die „aktive“ Suchzeichenfolge, um sie in das Feld Search zu übernehmen. Im Feld Search können Sie diese Suche erneut verwenden oder bearbeiten.

Das Feld Search unterstützt auch die Suche mit Platzhaltern, die durch ein Sternchen (*) in der Zeichenfolge gekennzeichnet werden.

Der Dialog Find Similar Components, den Sie durch einen Rechtsklick auf ein aufgelistetes Bauteil und die anschließende Auswahl von Find Similar Components öffnen, bietet die Möglichkeit, Sucheinstellungen auf Grundlage des ausgewählten Bauteils festzulegen.

Die endgültigen Suchergebnisse hängen vom ausgewählten Bauteiltyp – Workspace- oder Nicht-Workspace-Bauteile – sowie vom Verbindungsstatus zu Ihrem Workspace ab. Beispielsweise werden für Workspace-Bauteile häufig mehr Parameter angezeigt als für Nicht-Workspace-Bauteile. Um gezielt Bauteile und Parameter zu finden, die mit denen des ausgewählten Bauteils übereinstimmen oder sich davon unterscheiden, können Sie in den Dropdown-Listen die Optionen Same, Any oder Different auswählen.

Bauteile platzieren

Ein ausgewähltes Bauteil wird auf einem Schaltplan platziert, indem Sie es per Drag-and-drop ziehen, Place aus seinem Rechtsklick-Kontextmenü auswählen, die Schaltfläche im Bereich Details verwenden, auf den Eintrag des gewünschten Bauteils doppelklicken oder die Tastenkombination Enter verwenden.

Um ein Bauteil aus dem Panel zu platzieren, haben Sie folgende Möglichkeiten:

  • Klicken Sie im Bereich Component Details auf die Schaltfläche Place – der Cursor bewegt sich automatisch in den Bereich des Schaltplanblatts, und das Bauteil hängt am Cursor. Positionieren Sie es und klicken Sie, um es zu platzieren. Nach dem Platzieren eines Bauteils erscheint ein weiteres Exemplar desselben Bauteils am Cursor. Klicken Sie mit der rechten Maustaste, um den Platzierungsmodus zu verlassen.

    Components panel, placing from component details pane

  • Klicken Sie mit der rechten Maustaste auf das Bauteil und wählen Sie im Kontextmenü Place aus. Das Bauteil hängt am Cursor. Positionieren Sie es und klicken Sie, um es zu platzieren. Wenn das Panel frei schwebend über dem Designbereich liegt, wird es ausgeblendet, damit Sie den Schaltplan sehen und das Bauteil platzieren können. Nach dem Platzieren eines Bauteils erscheint ein weiteres Exemplar desselben Bauteils am Cursor. Klicken Sie mit der rechten Maustaste, um den Platzierungsmodus zu verlassen.

  • Click, Hold&Drag – klicken Sie auf das Bauteil im Tabellenbereich des Panels und ziehen Sie es auf ein Schaltplanblatt. In diesem Modus müssen Sie die Maustaste gedrückt halten. Das Bauteil wird platziert, sobald Sie die Maustaste loslassen. Nach dem Platzieren des Bauteils können Sie ein anderes Bauteil oder einen anderen Befehl auswählen.

    Per Drag-and-drop wird ein einzelnes Exemplar des Bauteils platziert. Wenn Sie mehrere Exemplare platzieren müssen, verwenden Sie den Befehl bzw. die Schaltfläche Place oder doppelklicken Sie auf den Bauteileintrag.

Das Platzieren eines Bauteils ist wirklich denkbar einfach. Bevor Sie jedoch beginnen, stellen Sie sicher, dass das Schaltplanblatt (oder PCB-Dokument), auf dem das Bauteil platziert werden soll, in Altium Designer geöffnet und das aktive Dokument ist. Wenn Dokumente in mehreren Fenstern geöffnet sind, stellen Sie außerdem sicher, dass das Fenster mit dem aktiven Schaltplandokument den Fokus hat.

Wenn Sie mit Altium Designer in mehreren Fenstern arbeiten und das Panel Components oder das Panel Explorer in einem beliebigen Modus an ein Fenster angedockt ist, das den Zielschaltplan nicht enthält, bleibt der Befehl Place ausgegraut. Das liegt daran, dass ein Klick in ein angedocktes Panel den Fokus auf das Fenster setzt, an das dieses Panel angedockt ist. Wenn das Panel hingegen frei schwebt, kann das gewünschte Altium-Fenster (das Fenster mit dem aktiven Zielschaltplan) fokussiert werden. Dieses Fenster behält dann den Fokus, während Sie im Panel arbeiten.

Ein mehrteiliges Bauteil platzieren

Wenn das zu platzierende Bauteil aus mehreren Teilbauteilen besteht, wird zunächst das Teilbauteil platziert, das unter dem Symbolvorschaubild im Bereich Models des Panels ausgewählt ist.

Nachdem ein Teilbauteil eines mehrteiligen Bauteils platziert wurde, kann es bei ausgewähltem Teilbauteil über die Dropdown-Liste Part im Panel Properties in ein anderes Teilbauteil dieses Bauteils geändert werden. Alternativ können Sie mit dem Befehl Edit » Increment Part Number aus den Hauptmenüs oder dem Befehl Part Actions » Increment Part Number aus dem Rechtsklick-Menü des Teilbauteils zum nächsten verfügbaren Teilbauteil wechseln.

Altium Designer unterstützt die Darstellung eines mehrteiligen Bauteils entweder als einzelnes Symbol (alle Teilkomponenten) oder als mehrere Symbole (eines für jede einzelne Teilkomponente). Hierfür wird nur ein einziges Bauteil mit definierten normalen und alternativen Darstellungsmodi verwendet (Beispiel anzeigen).

  • Wenn ein mehrteiliges Bauteil in seinem Darstellungsmodus (normal oder alternativ) leere Teilkomponenten aufweist, werden diese bei der Platzierung ausgelassen (Beispiel anzeigen).

  • Wenn bei einem mehrteiligen Bauteil nur in einer Teilkomponente Grundelemente definiert sind, wird das Suffix des Bezeichners ausgeblendet, wenn diese Teilkomponente auf einem Schaltplanblatt platziert wird (Beispiel anzeigen).

  • Wenn eine Teilkomponente für den aktuell ausgewählten Darstellungsmodus keine Grundelemente aufweist oder ein Darstellungsmodus für die aktuell ausgewählte Teilkomponente keine Grundelemente aufweist, wird der entsprechende Eintrag in der Dropdown-Liste Part von Mode im Panel Properties des Bauteils ausgegraut (). Wenn ein solcher Eintrag in der Dropdown-Liste ausgewählt wird, werden Warnsymbole angezeigt ().

  • Bei der Designvalidierung tritt kein Verstoß vom Typ Nicht verwendete Teilkomponente im Bauteil auf, wenn ein Bauteil Teilkomponenten ohne Grundelemente aufweist und diese Teilkomponenten nicht im Schaltplan platziert sind.

Bauteile filtern

Bei der Anzeige von Workspace-Bauteilen wird der Bereich Filters mit ausgewählten Filteroptionen auf Grundlage der aktuellen Suche und der verfügbaren Parameter gefüllt. Die parametrische Filterung der aufgelisteten Bauteile bietet weitere Möglichkeiten, ein bestimmtes Bauteil oder einen bestimmten Bauteiltyp zu finden. Öffnen Sie den Bereich Filters über die Schaltfläche oberhalb des Bereichs Categories. Klicken Sie im Kompaktmodus des Panels auf die Schaltfläche , um Filters als Panel-Erweiterung auszuklappen.

Beachten Sie, dass Filter nur für Workspace-Bauteile unterstützt werden. Verwenden Sie das Feld „Filter“ Search innerhalb des Bereichs, um einen bestimmten Parameterfilter zu finden.

Javascript ID: Pnl_Components_Filter
  • Die parametrische Suchfunktion von Filters im Panel setzt voraus, dass geeignete Bauteilparameterdaten vom Workspace übertragen werden, der die Workspace-Bauteile bereitstellt. Daher kann die Filterfunktion deaktiviert sein, wenn die Software mit einem älteren Altium-Serverprodukt verbunden ist. Um den Filter für frühere Serverversionen zu aktivieren, aktivieren Sie die Option ComponentSearch.LegacyAFS.Filters im Dialogfeld Erweiterte Einstellungen.

  • Beachten Sie, dass ein Parameter nur dann im Bereich Filters angezeigt wird, wenn Bauteile in der ausgewählten Kategorie mindestens zwei unterschiedliche Werte für diesen Parameter verwenden. Beachten Sie außerdem, dass im Bereich Filters maximal die 100 am häufigsten verwendeten Parameter angezeigt werden (diejenigen, die über alle Bauteiltypen hinweg von den meisten Bauteilen im verbundenen Workspace verwendet werden). Die folgenden Parameter (oder Parameter, deren Namen mit den folgenden Bezeichnungen beginnen) werden immer oben im Bereich angezeigt: Power, Value, Resistance, Res, Capacitance, Case, Package, Tolerance, RoHS, Lead.

Die Optionen Filters des Panels lassen sich an Ihre Anforderungen anpassen, indem Sie bestimmte Parametertypen als Favorites auswählen. Diese werden dann für die aktuelle Bauteilkategorie an den Anfang der Liste verschoben. Bewegen Sie den Mauszeiger rechts neben den Namen eines Parameterfilters und klicken Sie auf das Symbol , um den Filter als Favoriten festzulegen. Die Einstellungen für bevorzugte Filter gelten jeweils für einzelne Bauteilkategorien und werden für diese gespeichert.

Für Workspace-Bauteile bietet das Kontextmenü Optionen zum Bearbeiten des Bauteils im Bauteileditor (Edit) sowie für Bauteilverwaltungsfunktionen, etwa das Erstellen und Klonen von Bauteilen oder das Bearbeiten der Bauteilauswahl und des Typs des ausgewählten Bauteils (Operations).

 
 
 
 
 

Zu den weiteren Informationsoptionen im Bereich Details des Bauteils gehören: das Anzeigen eines Modellbilds, das Anzeigen von Online-Datenblättern (References), aktuelle Lieferanteninformationen (Part Choices) sowie das Anzeigen der Verwendung des Bauteils in Workspace-Projekten, verwalteten Schaltplanblättern und Wiederverwendungsblöcken (Where Used). Darüber hinaus können Sie über das Kontextmenü ausgewählte oder alle Bauteilparameterdaten (technische Details) in einem tabulatorgetrennten Format kopieren und die als Favoriten markierten Parameter auf die fünf Standardparameter zurücksetzen.

Wenn Sie die Bauteile in einem verbundenen Altium 365 Workspace durchsuchen und Probleme hinsichtlich des Zustands des ausgewählten Bauteils festgestellt werden, wird dies durch das Symbol (für Fehler) oder (für schwerwiegende Fehler) in der Zeile Component issues oberhalb der Bauteilparameterliste angezeigt. Die Zahl rechts neben dem Symbol gibt die Anzahl der gefundenen Probleme an. Klicken Sie auf den Abwärtspfeil rechts neben der Zahl, um Kurzbeschreibungen der Probleme anzuzeigen.

Ein Beispiel für gefundene Probleme mit dem Bibliothekszustand.
Ein Beispiel für gefundene Probleme mit dem Bibliothekszustand.

Den Zustand Ihrer Workspace-Bibliothek können Sie auf der Dashboard-Seite „Bibliothekszustand“ genauer untersuchen, die über die Browseroberfläche des Altium 365 Workspace zugänglich ist. Weitere Informationen finden Sie unter Dashboard „Bibliothekszustand“.

Mit der benutzerdefinierten Filterfunktion können Sie die Filterung im Panel Components weiter verfeinern. ​​​​​​

Die Funktion ist wie folgt zugänglich:

  1. Klicken Sie auf das Filtersymbol () in der Kopfzeile, um die Dropdown-Liste „Filter“ anzuzeigen.

  2. Diese unterstützt die Filterung durch Auswahl eines Filter Value (Standard) oder durch Konfiguration eines benutzerdefinierten Filter Rule. Wenn Sie einen Wert aus der Liste auswählen, wird dieser automatisch in einen Ausdruck umgewandelt, den Sie anschließend bearbeiten können.

  3. Wenn Sie Filter Rules auswählen, um einen eigenen Filter zu definieren, wählen Sie zunächst einen Operator aus der ersten Dropdown-Liste aus.

  4. Wählen Sie anschließend einen Filterwert in der zweiten Dropdown-Liste aus oder geben Sie einen ein.

  5. Der aktuelle Filter wird unterhalb der Ergebnisliste angezeigt. Klicken Sie auf die Schaltfläche , um den Dialog Filter Editor zu öffnen und Ihren Filter zu bearbeiten.

Verwendungsnachweis

Wählen Sie im Panel Components ein Workspace-Bauteil aus, um im Bereich Where Used Informationen dazu anzuzeigen, wo dessen neueste Revision derzeit verwendet wird. Der Bereich bietet Schnellfilterinformationen für:

  • Projects – die Workspace-Projekte, in denen das Bauteil verwendet wurde. Informationen werden only angezeigt, sobald das Projekt im Workspace gespeichert wurde.

  • Managed Sheets – die verwalteten Schaltplanblätter, auf denen das Bauteil verwendet wurde. 

  • Reuse Blocks – die Wiederverwendungsblöcke, die als Teil der Bibliothek eines verbundenen Workspace gespeichert sind.

Beachten Sie, dass die Registerkarten nur angezeigt werden, wenn im Workspace ein Element vorhanden ist, das das ausgewählte Bauteil verwendet.

Wenn ein Bauteil nicht in allen Designvarianten eines Workspace-Projekts verwendet wird, zeigt der Eintrag des Projekts im Bereich Where Used die Anzahl der Varianten, in denen das Bauteil verwendet wird, und die Gesamtzahl der Varianten dieses Projekts sowie die Liste der Varianten, in denen das Bauteil verwendet wird ().

Zwischenspeicherung von Bauteildaten

Bei Verwendung des Panels Components werden die Daten der Workspace-Bauteile aus dem Workspace auf dem lokalen Rechner zwischengespeichert. Dies ermöglicht den Offline-Zugriff auf Workspace-Bauteile, wenn Altium Designer nicht mit dem Workspace verbunden ist, sodass Bauteile wie gewohnt durchsucht, platziert usw. werden können.

Beim ersten Öffnen des Components-Panels in der aktuellen Altium Designer-Sitzung wird im Offline-Modus eine Warnung im Panel angezeigt. Außerdem stehen Bedienelemente zur Verfügung, um die zwischengespeicherten Bauteildaten weiterzuverwenden oder den Cache zu leeren.

Klicken Sie auf Use Cached Data, um die zwischengespeicherten Bauteile zu verwenden. Dieser Zustand wird durch den Warntext Offline mode – cached data is being used in der unteren Leiste des Bauteillistenbereichs des Panels angezeigt. Beachten Sie, dass Filters in diesem Modus nicht aktiviert sind.

Im Cache sammeln sich im Laufe der Zeit Bauteildaten an. Er kann jederzeit (für alle Workspaces) über die Option Clear Cache geleert werden, die unter Known Servers auf der Seite „Datenverwaltung – Server“ des Dialogs Preferences verfügbar ist.

Es werden nur zwischengespeicherte Bauteile aus den aktuell verbundenen Workspaces angezeigt, beispielsweise einem Altium 365 Workspace. Daher sind bestimmte zwischengespeicherte Daten möglicherweise deaktiviert. Dieses Verhalten lässt sich auf der Seite Data Management – Servers des Dialogs Preferences steuern.

Bauteilauswahlliste

Bearbeiten Sie die einem Workspace-Bauteil zugeordnete Bauteilauswahlliste, indem Sie im Kontextmenü des Eintrags die Option Operations » Create/Edit Part Choices auswählen.

Klicken Sie im daraufhin angezeigten Dialog Edit Part Choices auf die Schaltfläche , um den Dialog Add Part Choices zu öffnen. Dieser sucht anhand des Parameters Name des ausgewählten Bauteils automatisch nach Bauteilherstellern. Heben Sie die Auswahl des vordefinierten Suchbegriffs auf, um manuell nach Alternativen zu suchen. Funktional entspricht der Dialog einer modalen Version des Panels „Herstellerbauteilsuche“.

Die Bauteilauswahlliste kann durch Auswahl einer entsprechenden Sternebewertung priorisiert werden. Die Liste wird automatisch neu sortiert, wobei die am höchsten bewertete Herstelleroption oben steht.

Die Bauteilauswahl wird überall dort mit dem Bauteil übernommen, wo dessen Daten verwendet werden, beispielsweise in einem Schaltplanentwurf, einem Stücklistendokument, einem Ausgabebericht usw.

Wenn im Panel Components ein Bauteil ausgewählt ist, wird dessen Bauteilauswahlliste im Bereich Part Choices des Teilfensters Details angezeigt. Grundlegende Informationen (Lagerbestand, mittlerer Stückpreis und Hersteller-Lebenszyklusstatus) zur jeweiligen Bauteilauswahl sind auch oben im Teilfenster Details verfügbar. Der zugehörige Farbstreifen zeigt anhand des abgeleiteten Lebenszyklusstatus die grundsätzliche Eignung des Bauteils für den Einsatz an. Beispielsweise ist ein als Obsolete (rot) gekennzeichnetes Bauteil gegenüber einem als Volume Production (grün) eingestuften Bauteil nicht zu empfehlen. Bewegen Sie den Mauszeiger über einen Farbstreifen, um den Hersteller-Lebenszyklusstatus anzuzeigen.

Wenn Sie die Integrationsfunktionen von SiliconExpert oder Z2Data nutzen, stehen im oberen Bereich des Details-Panels möglicherweise zusätzliche Daten und Bedienelemente zur Verfügung. Weitere Informationen finden Sie auf den Seiten Bauteildaten aus SiliconExpert abrufen und Bauteildaten aus Z2Data abrufen.

Wenn die Funktion Revisionskontrolle für die Bauteilauswahl für Ihren Workspace aktiviert ist, wird bei Auswahl der Option Operations » Create/Edit Part Choices anstelle des Dialogs Edit Part Choices der Bauteil-Editor geöffnet (im Modus Einzelbauteilbearbeitung oder Stapelbearbeitung von Bauteilen). Nehmen Sie alle erforderlichen Änderungen an der Bauteilauswahl vor und speichern Sie die Bauteile als jeweils nächste Bauteilrevision im Workspace.

Kontextmenü des Components-Panels

Das per Rechtsklick aufrufbare Kontextmenü des Panels bietet die folgenden Befehle:

 
 
 
 
 
  • Place [ComponentName/FootprintName/SimulationModelName] – platziert das aktuell ausgewählte Bauteil oder Simulationsmodell im aktiven Schaltplandokument bzw. den aktuell ausgewählten Footprint im aktiven PCB-Dokument.

  • Find Similar Components – öffnet den Dialog „Ähnliche Bauteile suchen“, in dem Sie Suchkriterien festlegen können, um Bauteile zu finden, die dem ausgewählten Bauteil ähneln.

  • Navigate to [ComponentName] – öffnet das ausgewählte Workspace-Bauteil im Explorer-Panel. Dort können Sie unter anderem auf detaillierte Elementinformationen zugreifen, Revisions- und Lebenszykluseinstellungen für die Elemente verwalten sowie Verwendungsnachweise und Lieferkettendetails einsehen.

  • Edit – bearbeitet die ausgewählten Workspace-Bauteile im Bauteil-Editor (im Modus Einzelbauteilbearbeitung oder Stapelbearbeitung von Bauteilen) bzw. das ausgewählte Domänenmodell (Symbol, Footprint oder Simulationsmodell) im zugehörigen Editor. Wenn sich der aktuelle Bauteiltyp von dem der derzeit verwendeten Vorlage unterscheidet, wird der Dialog Change component type geöffnet (). Verwenden Sie diesen Dialog, um den Bauteiltyp des ausgewählten Bauteils zu ändern.

  • Create – öffnet den Dialog Create new component, in dem Sie beim Hinzufügen eines neuen Bauteils den Bauteiltyp auswählen können.

  • Delete – löscht die ausgewählten Bauteile aus Ihrem verbundenen Workspace.

  • Operations – öffnet ein Dropdown-Menü mit zusätzlichen Funktionen für Workspace-Bauteile, die im Folgenden beschrieben werden.

    • Submit Request – ermöglicht den Zugriff auf die aktiven Prozessdefinitionen für Bauteilanfragen. Wenn für das Prozessthema „Bauteilanfragen“ keine aktiven Prozessdefinitionen verfügbar sind, ist die Schaltfläche Submit Request ausgegraut (nicht verfügbar). Zur Aktualisierung müssen Sie sich gegebenenfalls vom Workspace abmelden und erneut anmelden oder Altium Designer neu starten.

    • Download – lädt die ausgewählten Bauteile als kompilierte, in einer ZIP-Datei gepackte integrierte Bibliothek (*.IntLib) einschließlich des Quellbibliothekspakets (*.LibPkg) und der Bibliotheksdateien herunter. Wählen Sie mehrere Bauteileinträge aus, um diese Bauteile in einem einzigen Vorgang herunterzuladen.

    • Make a copy – kopiert das ausgewählte Bauteil. Der Bauteil-Editor wird im Modus Single Component Editor geöffnet.

    • Change Component Type – öffnet den Dialog Choose component type (), in dem Sie den Typ des aktuellen Bauteils in einen der anderen bereits definierten Typen in der Liste ändern können. Der Dialog zeigt Informationen zu einer gegebenenfalls mit dem Bauteiltyp verknüpften Bauteilvorlage sowie zu dem Ordner im verbundenen Workspace an, in dem Bauteile dieses Typs zu finden sind bzw. gespeichert werden können. Klicken Sie auf die Schaltfläche , um die Liste der verfügbaren Bauteiltypen auf der Seite Datenverwaltung – Bauteiltypen des Dialogs Preferences zu verwalten.

    • Change State – ändert den Revisionsstatus der ausgewählten Bauteile. Nach dem Ausführen des Befehls wird der Dialog zur Stapeländerung des Status geöffnet, in dem Sie den Revisionsstatus der Bauteile ändern können.

    • Create/Edit Part Choices – öffnet den Dialog Edit Part Choices, in dem Sie die mit dem Workspace-Bauteil verknüpfte Bauteilauswahlliste erstellen oder bearbeiten können.

      Wenn die Funktion Revisionskontrolle für die Bauteilauswahl für Ihren Workspace aktiviert ist, wird bei Auswahl dieses Befehls der Bauteil-Editor im Modus Einzelbauteilbearbeitung oder Stapelbearbeitung von Bauteilen geöffnet.
    • Full Item History – öffnet eine Detailansicht des aktuell ausgewählten Bauteils als neue Registerkarte in Altium Designer. Die Elementansicht bietet eine sehr detaillierte Darstellung des Revisions- und Lebenszyklusverlaufs eines bestimmten Elements und zeigt außerdem alle Bestandteile dieses Elements an. Die Ansicht enthält auch eine Zeitleiste. Mithilfe der Zeitleiste können Sie das genaue Datum und die Uhrzeit jeder Änderung an der Revisionsstufe oder am Lebenszyklusstatus dieses Elements sowie die Person ermitteln, die die Änderung vorgenommen hat.

  • Refresh – aktualisiert das Panel schnell. Die aktuelle Bauteilauswahl bleibt erhalten.

Bauteilvergleichsfunktion

Mit der Funktion Compare können Sie die Parameter zweier ausgewählter Bauteile vergleichen. Um diese Funktion aufzurufen, wählen Sie bei aktiviertem (blauem) Symbol zwei Bauteile im Tabellenbereich aus. Der Bereich Selected Component Details wird rechts neben dem Tabellenbereich geöffnet. Im oberen Bereich (Bereich 1 in der Abbildung unten) werden ein Bild, der Name, die Beschreibung und der Preis der ausgewählten Bauteile nebeneinander angezeigt. Klicken Sie auf die Schaltfläche Datasheet, um das Datenblatt des Herstellers für das zugehörige Bauteil zu öffnen (sofern verfügbar). Klicken Sie auf die Schaltfläche Place, um das Bauteil im Designbereich zu platzieren. Das Bauteil hängt im Designbereich am Mauszeiger; klicken Sie, um es an der gewünschten Position zu platzieren. Sie können weitere Bauteile platzieren oder mit einem Rechtsklick bzw. mit Esc den Platzierungsmodus verlassen und zum Panel Components zurückkehren.

Der untere Bereich (Bereich 2 in der Abbildung unten) zeigt die Parameter der Bauteile nebeneinander an. Unterschiede werden zum einfachen Vergleichen in roter Schrift hervorgehoben.

Die Funktion Compare ist auch verfügbar, wenn sich das Panel Components im Kompaktmodus befindet, funktioniert dort jedoch etwas anders. Um diese Funktion aufzurufen, wählen Sie zwei Bauteile im Tabellenbereich aus. Der Bereich Selected Component Details wird unterhalb des Tabellenbereichs geöffnet. Der obere Bereich zeigt den Namen, den Preis und eine Ansicht der Bauteilparameter an. Unterschiede werden zum einfachen Vergleichen in roter Schrift hervorgehoben. Der untere Bereich zeigt Symbols und Models der Bauteile nebeneinander an.

Die Funktion Compare und die zugehörigen Funktionen stehen auch im Panel „Herstellerbauteilsuche“ zur Verfügung.

Bauteilsymbole und Footprints bearbeiten

Das Symbol und der Footprint eines Bauteils können im Abschnitt Models des Bereichs Details ausgeblendet werden. Diesen rufen Sie auf, indem Sie oben rechts auf Info button klicken. Nach dem Ausblenden werden Symbol und Footprint durch anklickbare Links ersetzt, mit denen Sie die ursprüngliche Ansicht der ausgeblendeten Elemente wiederherstellen können. Auch die Größe der angezeigten Modelle lässt sich anpassen. Sowohl bei Symbolen als auch bei Footprints können Sie die Bildgröße ändern, indem Sie auf den unteren Rand des Modellbereichs klicken und ihn ziehen.

Beachten Sie, dass die Modellansichten auch im Bereich Details des Panels „Herstellerbauteilsuche“ ausgeblendet und in der Größe angepasst werden können.

Wenn Sie eine Schaltplanbibliotheksdatei (*.SchLib) im Panel Components durchsuchen, können Sie das Symbol und den Footprint des ausgewählten Bauteils über die Schaltfläche unten rechts in der Modellvorschau bearbeiten.

Die Bearbeitung eines Footprints ist beim Zugriff auf Components verfügbar, sofern bereits gültige und verknüpfte Footprints vorhanden sind.

Dialoge zur Bauteilauswahl

Die Suchmaschine und die Ansicht des Components-Panels werden auch in anderen Anwendungen von Altium Designer verwendet, in denen Bauteile ausgewählt werden. Die Bauteilsuche ist in diesen (modalen) Dialogen enthalten, zusammen mit einer OK-Bestätigungsschaltfläche und geringfügigen Unterschieden bei den verfügbaren Befehlen. Der Dialog heißt in der Regel Component Search.

  • ActiveBOM-Dokument – die Bauteilsuchansicht wird verwendet, wenn ein Workspace-Bauteil durch ein alternatives Bauteil ersetzt wird. Klicken Sie mit der rechten Maustaste auf einen aufgelisteten Bauteileintrag und wählen Sie im Kontextmenü Change [component name], um den Dialog Bauteil ersetzen zu öffnen.
  • Item Manager – die Bauteilsuchansicht wird verwendet, wenn Sie manuell ein Workspace-Bauteil auswählen, um das aktuelle Bauteil zu ersetzen. Klicken Sie mit der rechten Maustaste auf einen aufgelisteten Bauteileintrag und wählen Sie im Kontextmenü Choose manually, um den Dialog „Bauteil ersetzen“ zu öffnen.
  • Variantenverwaltung – die Bauteilsuchansicht wird verwendet, wenn Sie ein alternatives Bauteil für eine Projektvariante auswählen. Wählen Sie als Bauteilvariation ein alternatives Bauteil und anschließend Choose im Dialog „Bauteilvariation bearbeiten“, um den Dialog „Bauteil ersetzen“ zu öffnen.

Auf generische Bauteile zugreifen und diese platzieren

Diese Funktion befindet sich in der offenen Betaphase und ist verfügbar, wenn die Option ComponentSearch.GenericComponents im Dialog „Erweiterte Einstellungen“ aktiviert ist.

Um das Layouten in den frühen Entwurfsphasen zu beschleunigen, steht das Konzept standardisierter, grundlegender Generic Components zur Verfügung. Generische Bauteile lassen sich schnell in einem Design platzieren, ohne dass ein bestimmtes Herstellerbauteil aus den verfügbaren Bauteilquellen gesucht und ausgewählt werden muss. Generische Bauteile sind als Platzhalter gedacht, die später im Entwicklungsprozess einfach durch ein geeignetes Bauteil ersetzt werden können – sie können auch als virtuelle oder parametrische Bauteile betrachtet werden.

Weitere Informationen zur Erstellung generischer Bauteile finden Sie auf der Seite Generische Bauteile erstellen.

Wenn Altium Designer mit einem Workspace verbunden ist, können Sie über das Panel auf die verfügbaren generischen Bauteile zugreifen. Diese werden angezeigt, wenn im Bereich Categories die Option All ausgewählt ist – oder über das obere Dropdown-Menü, wenn sich das Panel im Kompaktmodus befindet. Klicken Sie innerhalb der Kachel eines generischen Bauteils auf die Schaltfläche , um das Bauteil zur Platzierung im aktiven Schaltplandokument an den Cursor zu hängen. Wenn das Bauteil in einem Schaltplan platziert wird, werden die Pin-, Linien- und Rahmenprimitive des Symbols – also im Wesentlichen seine Umrisse – rot dargestellt, um die Verwendung eines generischen Bauteils anzuzeigen. Wenn Sie im Components-Panel die Kachel selbst auswählen, wird die Kategorie dieses Bauteiltyps im Panel geöffnet.

Platzieren eines generischen Bauteils über das Components-Panel
Platzieren eines generischen Bauteils über das Components-Panel

Da generische Bauteile nicht im fertigen Design verwendet werden dürfen, verursachen sie beim Platzieren in einem Schaltplan einen ERC-Verstoß – Generisches Bauteil. Der Schweregrad dieses Verstoßes – standardmäßig Fatal Error – wird im Abschnitt Bauteilbezogene Verstöße der Einstellungen für die Fehlerberichterstattung im Dialog Project Options (Project » Project Options) festgelegt.

Wählen Sie ein platziertes generisches Bauteil aus, um im Eigenschaften-Panel auf seine Eigenschaften zuzugreifen. Dort werden nur die für diesen Bauteiltyp relevanten Einstellungen und Parameter bereitgestellt. Die verfügbaren Parameter werden durch die zugehörige Bauteilvorlage bestimmt (Resistors im hier gezeigten Beispiel). Parameterwerte können manuell eingegeben oder aus einer Dropdown-Liste ausgewählt werden, die Werte aus allen verfügbaren Bauteilen dieses Typs anbietet.

Festlegen der Parameter eines generischen Bauteils – Auswahl der Parameterwerte aus den Dropdown-Listen.

Festlegen der Parameter eines generischen Bauteils – das Ergebnis.

 

Unterstützung für Jumper-Bauteile

Jumper, auch als Drahtbrücken bezeichnet, ermöglichen es, Leiterbahnverbindungen durch ein Jumper-Bauteil zu ersetzen. Dies ist häufig eine wesentliche Voraussetzung für den erfolgreichen Entwurf einer einseitigen Leiterplatte. Altium Designer unterstützt die Verwendung von Jumper-Bauteilen über den speziellen Bauteiltyp Jumper.

Sie können zwar zunächst die Jumper-Footprints direkt auf der Leiterplatte platzieren, der empfohlene Arbeitsablauf beginnt jedoch im Schaltplan. Weitere Informationen finden Sie auf der Seite Arbeiten mit Jumper-Bauteilen.

AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents