Travailler avec des keepouts spécifiques à un objet sur une carte
En un coup d'œil
- Comprenez ce que sont les zones d’exclusion spécifiques aux objets, comment elles se comportent dans Altium Designer et où les utiliser lors de la conception d’un PCB.
- Découvrez comment configurer les zones d’exclusion pour ne restreindre que certains types d’objets et bénéficier ainsi d’un contrôle plus souple sur le routage, le placement du cuivre et le comportement des vias.
- Découvrez les bases du placement et de la modification des objets d’exclusion, notamment sous forme de pistes et d’arcs, dans l’éditeur PCB et l’éditeur de bibliothèques PCB.
Une Keepout dans la conception de PCB est une zone ou un périmètre défini par l’utilisateur dans le circuit, que les objets en cuivre ne peuvent pas chevaucher. Généralement utilisée pour délimiter la zone exploitée par les opérations de placement automatique du cuivre, telles que les remplissages de polygones et le routage interactif, une zone d’exclusion constitue également un emplacement interdit lors du placement manuel d’objets en cuivre.
Définis comme des zones interdites lors de la conception du circuit, les objets d’exclusion utilisent les règles de contrainte d’espacement existantes pour contrôler le routage et détecter les violations de placement. Toutefois, contrairement aux autres objets placés, ils ne peuvent pas être affectés à un net et n’apparaissent pas dans les fichiers de sortie générés ni dans les impressions. Dans sa forme la plus simple, une zone d’exclusion agit comme un objet « obstacle » qui empêche les autres objets en cuivre de chevaucher sa surface, conformément à la règle globale d’espacement. Les objets d’exclusion peuvent être placés sur la couche Keep-out Layer (où ils s’appliquent à toutes les couches de signal) ou sur une couche de signal (où ils s’appliquent uniquement aux objets de cette couche).
Altium Designer permet de créer et d’utiliser des zones d’exclusion grâce à sa prise en charge des Object Specific Keepouts. Les objets d’exclusion placés peuvent être configurés pour spécifier les types d’objets auxquels ils s’appliquent, tels que les pistes, les zones de cuivre, les vias et les pastilles, ce qui améliore considérablement la souplesse et l’efficacité des zones d’exclusion.

Objets d’exclusion de différents types placés dans une conception de PCB.
Dans l’éditeur de PCB et l’éditeur de bibliothèques PCB, les objets d’exclusion sont affichés avec des hachures croisées. Les objets d’exclusion placés sur la couche Keep-Out Layer (c’est-à-dire ceux qui s’appliquent à toutes les couches de signal) sont affichés dans la couleur de cette couche, tandis que les zones d’exclusion placées sur une couche de signal spécifique (c’est-à-dire celles qui s’appliquent uniquement à cette couche) apparaissent dans la couleur de cette couche de signal.
Les zones d’exclusion sont idéales pour définir des régions de la carte où le routage est interdit (telles que les zones électriquement sensibles ou à haute tension), des emplacements spécifiques où le cuivre est exposé, comme les repères fiduciaires et les points de test, ou des zones présentant des contraintes mécaniques (telles que les trous de fixation ou les coins d’un PCB). Le caractère configurable des zones d’exclusion spécifiques aux objets permet également de les placer sur d’autres objets lorsque des Keepout Restrictions spécifiques ont été attribuées. Lorsqu’elle est configurée pour restreindre uniquement les vias, par exemple, une zone d’exclusion peut être placée sur des régions de cuivre existantes (telles qu’un remplissage de polygone) pour contrôler l’étendue de la couture de vias automatique.
Les zones d’exclusion spécifiques aux objets peuvent être placées dans l’éditeur de PCB et l’éditeur de bibliothèques PCB.
Pour plus d’informations sur le placement et la modification des objets d’exclusion de PCB, consultez les sections dépliables ci-dessous :
Piste d’exclusion
Une piste est un objet de conception primitif. Outre la piste standard utilisée pour les tâches de conception, un second type de piste est disponible, appelé piste d’exclusion. Une piste d’exclusion peut être placée comme objet d’exclusion spécifique à une couche ou comme zone d’exclusion applicable à toutes les couches, pour servir, par exemple, de barrière au placement ou au routage. La différence entre une piste standard et une piste d’exclusion est que les remplissages de type exclusion spécifiques à une couche ne sont pas inclus dans les fichiers de sortie générés, tels que Gerber ou ODB++. Une région d’exclusion se reconnaît à son contour affiché dans la couleur des zones d’exclusion.
Après le lancement de la commande de placement d’une piste d’exclusion, le curseur prend la forme d’un réticule et vous passez en mode de placement de piste d’exclusion. Le placement s’effectue selon la séquence d’actions suivante :
- Cliquez ou appuyez sur Enter pour fixer le point de départ du premier segment de piste d’exclusion.
- Déplacez le curseur pour définir le segment de piste d’exclusion, puis cliquez ou appuyez sur Enter pour fixer le point d’arrivée de ce premier segment, qui est également le point de départ du segment connecté suivant.
- Continuez à positionner le curseur, puis cliquez ou appuyez sur Enter pour fixer une série de sommets définissant la série de segments de piste d’exclusion connectés.
- Faites un clic droit ou appuyez sur Esc pour terminer la série actuelle de segments de piste d’exclusion connectés.
Les actions supplémentaires pouvant être effectuées pendant le placement sont les suivantes :
- Appuyez sur la touche * du pavé numérique pour parcourir les couches de signal disponibles. Vous pouvez également utiliser la combinaison Shift+Ctrl+Wheel Roll pour parcourir les couches de routage ; chaque cran de la molette de la souris permet de passer à la couche de signal disponible suivante (ou précédente).
- Appuyez sur les touches + et - du pavé numérique pour parcourir dans un sens ou dans l’autre toutes les couches actuellement visibles dans la conception.
Lors du placement des segments de piste d’exclusion, cinq modes de coin sont disponibles, dont quatre proposent également des sous-modes de direction du coin. Pendant le placement :
- Appuyez sur Shift+Spacebar pour parcourir les cinq modes de coin disponibles.
- Appuyez sur Spacebar pour basculer entre les deux sous-modes de direction du coin.
- Dans l’un des modes de coin en arc, maintenez la touche , ou . enfoncée pour réduire ou agrandir l’arc. Maintenez la touche Shift enfoncée en même temps pour accélérer le redimensionnement de l’arc.
- Appuyez sur le raccourci clavier 1 pour basculer entre le placement d’un segment par clic et celui de deux segments par clic. Dans le premier mode, le segment de piste évidé est appelé segment d’anticipation.
- Appuyez sur la touche Backspace pour supprimer le dernier sommet.
La méthode de modification graphique permet de sélectionner une piste d’exclusion placée directement dans l’espace de conception et de modifier graphiquement sa taille, sa forme ou son emplacement.
Lorsqu’une piste d’exclusion est sélectionnée, les poignées de modification suivantes sont disponibles :
- Cliquez sur les poignées d’extrémité pour repositionner les extrémités de la piste.
- Cliquez sur la poignée centrale et faites-la glisser pour modifier la forme de la piste.
Propriétés de la piste d’exclusion

Le mode Keepout - Track du panneau Properties.
Emplacement
-
(X/Y)
- X (premier champ) - la coordonnée X (horizontale) actuelle du point de référence de la piste d’exclusion par rapport à l’origine actuelle. Modifiez cette valeur pour changer la position X de la piste d’exclusion. La valeur peut être saisie en unités métriques ou impériales ; indiquez les unités lorsque vous saisissez une valeur dont les unités diffèrent de celles définies par défaut.
- Y (deuxième champ) - la coordonnée Y (verticale) actuelle du point de référence de la piste d’exclusion par rapport à l’origine actuelle. Modifiez cette valeur pour changer la position Y de la piste d’exclusion. La valeur peut être saisie en unités métriques ou impériales ; indiquez les unités lorsque vous saisissez une valeur dont les unités diffèrent de celles définies par défaut.
Propriétés
- Component – ce champ n’apparaît dans l’éditeur de PCB que lorsque la piste d’exclusion sélectionnée fait partie d’un composant PCB et affiche le repère du composant PCB parent. Sélectionnez l’élément cliquable Component lien pour ouvrir le mode Composant du panneau Propriétés pour le composant parent.
- Restricted for Layer - utilisez la liste déroulante pour sélectionner la couche soumise aux restrictions.
- Width - affiche la largeur actuelle de la piste d’exclusion. Modifiez ce champ pour changer la largeur de la piste d’exclusion dans la plage de 0,001 mil à 10000 mil.
- Start (X/Y) - affiche les coordonnées X/Y actuelles du point de départ de la piste d’exclusion par rapport à l’origine actuelle.
- End (X/Y) - affiche les coordonnées X/Y actuelles du point d’arrivée de la piste d’exclusion, par rapport à l’origine actuelle.
- Length - affiche la longueur actuelle de la piste d’exclusion. Modifiez ce champ pour changer la longueur de la piste d’exclusion dans la plage de 0,001 mil à 10000 mil.
Restrictions d’exclusion
Utilisez cette zone pour sélectionner les types d’objets auxquels s’appliqueront les restrictions de la zone d’exclusion. Si vous désélectionnez un type d’objet, la zone d’exclusion autorisera les objets de ce type à y pénétrer en n’appliquant pas la règle d’espacement correspondante. Les choix disponibles sont les suivants :
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Arc d’exclusion

Deux arcs d’exclusion sur la couche inférieure : à gauche, un arc d’exclusion formant un cercle complet ; à droite, un arc d’exclusion sélectionné pour être modifié.
Un arc d’exclusion est un objet de conception primitif. Il s’agit essentiellement d’un segment de piste circulaire qui peut être placé sur n’importe quelle couche. Outre l’arc standard utilisé pour des tâches de conception telles que la définition du contour d’un composant ou le routage courbe, il existe un second type d’arc, appelé arc d’exclusion. Un arc d’exclusion peut être placé sur une couche de signal pour créer une barrière ou une zone interdite propre à cette couche. Il peut également être placé sur la couche Keepout, auquel cas il s’applique à toutes les couches de signal. La différence entre un arc standard et un arc d’exclusion est que les arcs d’exclusion propres à une couche ne sont pas inclus dans les fichiers de sortie générés, tels que Gerber ou ODB++. Un arc d’exclusion se reconnaît à son contour dans la couleur de la couche Keepout.
La façon dont un arc est placé dépend de la méthode de placement que vous avez choisie. Quatre méthodes de placement d’arc sont disponibles :
- Place arc by center – cette méthode permet de placer un objet arc en utilisant son centre comme point de départ.
- Place arc by edge – cette méthode permet de placer un objet arc en utilisant son bord comme point de départ. L’angle de l’arc est fixé à 90°.
- Place arc by edge (any angle) – cette méthode permet de placer un objet arc en utilisant son bord comme point de départ. L’angle de l’arc peut prendre n’importe quelle valeur.
- Place full circle arc – cette méthode permet de placer un arc de 360° (cercle complet).
Placing a Keepout Arc Starting at the Center
Après le lancement de la commande, le curseur prend la forme d’une croix et vous passez en mode de placement d’arc d’exclusion. Le placement s’effectue selon la séquence d’actions suivante :
- Cliquez ou appuyez sur Enter pour fixer le centre de l’arc d’exclusion.
- Déplacez le curseur pour ajuster le rayon de l’arc d’exclusion, puis cliquez ou appuyez sur Enter pour le définir.
- Déplacez le curseur pour ajuster le point de départ de l’arc d’exclusion, puis cliquez ou appuyez sur Enter pour le fixer.
- Déplacez le curseur pour modifier la position du point d’arrivée de l’arc d’exclusion, puis cliquez ou appuyez sur Enter pour le fixer et terminer le placement de l’arc d’exclusion.
- Continuez à placer d’autres arcs d’exclusion, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
Placing a Keepout Arc Starting at the Edge
Après le lancement de la commande, le curseur prend la forme d’une croix et vous passez en mode de placement d’arc d’exclusion. Le placement s’effectue selon la séquence d’actions suivante :
- Cliquez ou appuyez sur Enter pour fixer le point de départ de l’arc d’exclusion.
- Déplacez le curseur pour modifier la position du point d’arrivée de l’arc d’exclusion, puis cliquez ou appuyez sur Enter pour le fixer et terminer le placement de l’arc d’exclusion.
- Continuez à placer d’autres arcs d’exclusion, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
Placing a Keepout Arc Starting at the Edge (any angle)
Après le lancement de la commande, le curseur prend la forme d’une croix et vous passez en mode de placement d’arc d’exclusion. Le placement s’effectue selon la séquence d’actions suivante :
- Cliquez ou appuyez sur Enter pour fixer le point de départ de l’arc d’exclusion.
- Déplacez le curseur pour ajuster le rayon de l’arc d’exclusion, puis cliquez ou appuyez sur Enter pour fixer son centre.
- Déplacez le curseur pour modifier la position du point d’arrivée de l’arc d’exclusion, puis cliquez ou appuyez sur Enter pour le fixer et terminer le placement de l’arc d’exclusion.
- Continuez à placer d’autres arcs d’exclusion, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
Placing a Full Circle Keepout Arc
Après le lancement de la commande, le curseur prend la forme d’une croix et vous passez en mode de placement d’arc d’exclusion. Le placement s’effectue selon la séquence d’actions suivante :
- Cliquez ou appuyez sur Enter pour fixer le centre de l’arc d’exclusion.
- Déplacez le curseur pour ajuster le rayon de l’arc d’exclusion, puis cliquez ou appuyez sur Enter pour le définir et terminer le placement de l’arc d’exclusion.
- Continuez à placer d’autres arcs d’exclusion, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
Pour toutes les méthodes (à l’exception des arcs formant un cercle complet), appuyez sur Spacebar avant de définir le point d’arrivée de l’arc d’exclusion pour tracer l’arc dans le sens opposé.
La méthode de modification graphique permet de sélectionner un objet arc placé directement dans l’espace de conception et de modifier graphiquement sa taille, sa forme ou sa position.
Lorsqu’un objet arc d’exclusion est sélectionné, les poignées de modification suivantes sont disponibles :

Un arc d’exclusion sélectionné
- Cliquez sur A et faites glisser pour ajuster le rayon.
- Cliquez sur B et faites glisser pour ajuster les extrémités (angles de départ et d’arrivée).
-
Cliquez n’importe où sur l’arc, à l’écart des poignées de modification, puis faites glisser pour le repositionner. Vous pouvez également cliquer sur le centre de l’arc et le faire glisser. Pendant le déplacement, vous pouvez faire pivoter l’arc ou lui appliquer une symétrie :
- Appuyez sur Spacebar pour faire pivoter l’arc dans le sens antihoraire ou sur Shift+Spacebar pour le faire pivoter dans le sens horaire. La rotation s’effectue selon la valeur de Rotation Step définie sur la page PCB Editor – General de la boîte de dialogue Preferences.
- Appuyez sur les touches X ou Y pour appliquer une symétrie à l’arc selon l’axe X ou l’axe Y, respectivement.
Propriétés de l’arc d’exclusion

Le mode Keepout - Arc du panneau Properties.
Emplacement
-
(X/Y)
- X (premier champ) - la coordonnée X (horizontale) actuelle du point de référence de l’arc d’exclusion, par rapport à l’origine actuelle de l’espace de conception. Modifiez cette valeur pour changer la position X de l’arc d’exclusion. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités lorsque vous saisissez une valeur dont les unités ne correspondent pas à celles utilisées par défaut.
- Y (deuxième champ) - la coordonnée Y (verticale) actuelle du point de référence de l’arc d’exclusion, par rapport à l’origine actuelle. Modifiez cette valeur pour changer la position Y de l’arc d’exclusion. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités lorsque vous saisissez une valeur dont les unités ne correspondent pas à celles utilisées par défaut.
Propriétés
- Component – ce champ s’affiche dans l’éditeur de PCB uniquement lorsque l’arc d’exclusion sélectionné fait partie d’un composant PCB, et indique le repère du composant PCB parent. Cliquez sur le lien Component pour ouvrir le mode Component du panneau Properties pour le composant parent.
- Restricted Layer - ce champ affiche la couche soumise aux restrictions à laquelle l’arc d’exclusion est actuellement affecté. Pour changer de couche, cliquez sur le champ et sélectionnez une couche dans la liste déroulante.
- Width - ce champ affiche la largeur du trait de l’arc d’exclusion. Saisissez une autre valeur de largeur si nécessaire.
- Radius - ce champ affiche le rayon de l’arc, mesuré du point central au centre du trait de l’arc d’exclusion. Saisissez une autre valeur de rayon si nécessaire.
- Start Angle - ce champ affiche l’angle de départ de l’arc d’exclusion, mesuré à partir de l’axe X dans le premier quadrant (géométrie plane). Saisissez une autre valeur d’angle de départ si nécessaire.
- End Angle - ce champ affiche l’angle de fin de l’arc d’exclusion. Saisissez une autre valeur d’angle de fin si nécessaire.
Restrictions d’exclusion
Utilisez cette section pour sélectionner les types d’objets auxquels la zone d’exclusion imposera des restrictions. Si vous désélectionnez un type d’objet, la zone d’exclusion autorisera les empiètements de ce type d’objet (qui ne sera donc pas exclu) en n’appliquant pas la règle d’espacement correspondante. Les choix comprennent :
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Région d’exclusion

Une région d’exclusion
Une région d’exclusion est un objet de conception primitif. Outre la région standard utilisée pour les tâches de conception, il existe un second type de région, appelé région d’exclusion. Une région d’exclusion peut être placée comme objet d’exclusion propre à une couche ou comme zone d’exclusion applicable à toutes les couches, afin de servir, par exemple, de barrière au placement ou au routage. La différence entre une région standard et une région d’exclusion est que les remplissages de type exclusion propres à une couche ne sont pas inclus dans les fichiers de sortie générés, tels que les fichiers Gerber ou ODB++. Une région d’exclusion se reconnaît à son contour affiché dans la couleur Keepout.
Après avoir lancé la commande de placement d’une région d’exclusion (Place » Keepout » Solid Region), le curseur prend la forme d’un réticule et vous passez en mode de placement de région d’exclusion. Le placement s’effectue selon la séquence d’actions suivante :
- Positionnez le curseur, puis cliquez pour fixer le sommet de départ de la région d’exclusion.
- Déplacez le curseur pour préparer le placement du deuxième sommet. Par défaut, chaque clic place deux arêtes, reliées par une forme d’angle définie par l’utilisateur.
- Continuez à déplacer la souris et à cliquer pour placer d’autres sommets.
- Après avoir placé le dernier sommet, faites un clic droit ou appuyez sur Esc pour fermer la région d’exclusion et terminer son placement. Il n’est pas nécessaire de fermer manuellement la région, car le logiciel complète automatiquement la forme en reliant le point de départ au dernier point placé.
- Continuez à placer d’autres régions d’exclusion, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
La méthode de modification graphique vous permet de sélectionner un objet placé directement dans l’espace de conception et de modifier graphiquement sa taille, sa forme ou son emplacement.

Une région d’exclusion sélectionnée
Move Region Vertices
Les régions d’exclusion comportent deux types de points, ou « poignées », permettant de modifier leur forme.
- Full Handles - situées aux angles de la région d’exclusion.
- Empty Handles - situées au centre des segments créés par les poignées pleines.
La forme d’une région d’exclusion existante peut être modifiée en déplaçant ces poignées, ou sommets, situés à chaque angle ou au centre de chaque arête.
Pour modifier la forme de la région d’exclusion :
-
Cliquez et sélectionnez une région d’exclusion pour mettre en surbrillance ses sommets et transformer le curseur en réticule.
- Click sur une poignée pleine pour déplacer cet angle.
- Click le long d’une arête pour déplacer l’arête entière.
- Click sur une poignée vide pour déplacer tout le côté (pour une piste ou un arc).
- Ctrl+Click sur une poignée vide pour diviser cette arête en deux. Ctrl ne doit être maintenu qu’au début du déplacement. Les raccourcis clavier Shift+Spacebar peuvent ensuite être utilisés pour faire défiler les modes (arc, biseau et angle libre).
- Si le mode de placement « angle libre » crée des sommets indésirables, ou pour supprimer des sommets superflus en général, cliquez sur Ctrl et saisissez la poignée pleine centrale. Une icône X apparaît sur la poignée ; en faisant glisser l’arête, vous réduisez à un seul le nombre de sommets sur cette arête.
Modify Region Border
Outre la modification des sommets, vous pouvez également utiliser la commande Modify Region Border pour modifier facilement la forme des polygones. Cette commande est exécutée en faisant un clic droit sur le polygone souhaité, puis en sélectionnant Polygon Actions » Modify Polygon Border. Une fois la commande lancée, le curseur prend la forme d’un réticule. Chaque clic ajoute un nouveau sommet. Comme lors du placement d’une région d’exclusion, les raccourcis Shift+Spacebar peuvent être utilisés pour modifier la forme des angles.
Propriétés de la région d’exclusion

Le mode Keepout - Region du panneau Properties.
Propriétés
- Component – ce champ s’affiche dans l’éditeur de PCB uniquement lorsque la région d’exclusion sélectionnée fait partie d’un composant PCB et indique le repère du composant PCB parent. Cliquez sur le lien Component pour ouvrir le mode Component du panneau Properties pour le composant parent.
- Restricted for Layer - utilisez la liste déroulante pour sélectionner la couche sur laquelle se trouve la région d’exclusion.
- Arc Approximation - saisissez l’écart maximal par rapport à un arc parfait.
- Area - la surface totale de l’objet placé.
- Locked (panneau Properties uniquement) - activez cette option pour verrouiller la région d’exclusion.
Sommets du contour
Cette zone permet de modifier les différents sommets de l’objet région actuellement sélectionné. Vous pouvez modifier la position des sommets existants, ajouter de nouveaux sommets ou en supprimer selon les besoins. Vous pouvez définir des liaisons en arc entre les sommets, ainsi qu’exporter et importer les informations relatives aux sommets au format CSV.
-
Vertices Grid - répertorie tous les sommets actuellement définis pour la région avec les informations suivantes :
- Index - l’indice attribué au sommet (non modifiable).
- X - la coordonnée X (horizontale) du sommet. Cliquez pour la modifier.
- Y - la coordonnée Y (verticale) du sommet. Cliquez pour la modifier.
- Arc Angle (Neg = CW) - l’angle de l’arc tracé pour relier ce sommet au suivant. Par défaut, les liaisons sont des segments de droite et ce champ reste vide. Cliquez pour le modifier, puis saisissez l’angle d’arc souhaité. Une valeur positive produit un arc tracé dans le sens antihoraire. Pour tracer un arc dans le sens horaire, saisissez une valeur négative.
-
Add - cliquez pour ajouter un nouveau sommet. Le nouveau sommet sera ajouté sous le sommet actuellement actif et aura initialement les mêmes coordonnées X,Y que celui-ci. Cliquez sur
pour supprimer le sommet actuellement sélectionné.
Restrictions de la zone d’exclusion
Utilisez cette zone pour sélectionner les types d’objets auxquels s’appliquera la zone d’exclusion. Si vous désélectionnez un type d’objet, la zone d’exclusion autorisera les objets de ce type à y pénétrer (ils ne seront pas exclus) en n’appliquant pas la règle d’espacement correspondante. Les choix disponibles sont les suivants :
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Remplissage d’exclusion
Un remplissage d’exclusion est un objet de conception primitif qui peut être placé sur n’importe quelle couche. Outre le remplissage standard utilisé pour des tâches de conception telles que la définition du contour d’un composant, il existe un second type de remplissage, appelé remplissage d’exclusion. Un remplissage d’exclusion peut être placé comme objet d’exclusion propre à une couche ou comme zone d’exclusion applicable à toutes les couches, afin de servir, par exemple, de barrière au placement ou au routage. La différence entre un remplissage standard et un remplissage d’exclusion est que les remplissages d’exclusion propres à une couche ne sont pas inclus dans les fichiers de sortie générés, tels que Gerber ou ODB++. Un remplissage d’exclusion se reconnaît à son contour affiché dans la couleur des zones d’exclusion.
Après le lancement de la commande de placement d’un remplissage d’exclusion, le curseur prend la forme d’une croix et vous passez en mode de placement de remplissage d’exclusion. Le placement s’effectue selon la séquence suivante :
- Cliquez ou appuyez sur Enter pour fixer le premier coin du remplissage d’exclusion.
- Déplacez le curseur pour ajuster la taille du remplissage d’exclusion, puis cliquez ou appuyez sur Enter pour fixer le coin diagonalement opposé et terminer le placement du remplissage d’exclusion.
- Continuez à placer d’autres remplissages d’exclusion ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
La méthode de modification graphique vous permet de sélectionner un objet placé directement dans l’espace de conception et de modifier graphiquement sa taille, sa forme ou sa position.
Lorsqu’un objet de remplissage d’exclusion est sélectionné, les poignées de modification suivantes sont disponibles :

Un remplissage d’exclusion sélectionné
- Cliquez sur les poignées d’angle, maintenez le bouton enfoncé et faites-les glisser pour redimensionner le remplissage d’exclusion simultanément dans les directions verticale et horizontale.
- Cliquez sur les poignées latérales, supérieure et inférieure, maintenez le bouton enfoncé et faites-les glisser pour redimensionner le remplissage d’exclusion séparément dans les directions verticale et horizontale.
- Cliquez sur la poignée centrale, maintenez le bouton enfoncé et faites-la glisser pour faire pivoter le remplissage d’exclusion autour de son centre.
-
Cliquez n’importe où sur le remplissage d’exclusion, à l’écart des poignées de modification, puis maintenez le bouton enfoncé et faites glisser l’objet pour le repositionner. Pendant le déplacement, vous pouvez faire pivoter le remplissage d’exclusion ou lui appliquer une symétrie :
- Appuyez sur Spacebar pour faire pivoter le remplissage d’exclusion dans le sens antihoraire ou sur Shift+Spacebar pour le faire pivoter dans le sens horaire. La rotation s’effectue selon la valeur de Rotation Step définie sur la page PCB Editor – General de la boîte de dialogue Preferences.
- Appuyez sur les touches X ou Y pour appliquer une symétrie au remplissage d’exclusion selon l’axe X ou Y.
Propriétés du remplissage d’exclusion

Le mode Keepout - Fill du panneau Properties.
Position
-
(X/Y)
- X (premier champ) - la coordonnée X (horizontale) actuelle du point de référence du remplissage d’exclusion, par rapport à l’origine actuelle de l’espace de conception. Modifiez-la pour changer la position X du remplissage d’exclusion. La valeur peut être saisie en unités métriques ou impériales ; indiquez les unités si celles de la valeur saisie diffèrent des unités par défaut.
- Y (deuxième champ) - la coordonnée Y (verticale) actuelle du point de référence du remplissage d’exclusion, par rapport à l’origine actuelle. Modifiez-la pour changer la position Y du remplissage d’exclusion. La valeur peut être saisie en unités métriques ou impériales ; indiquez les unités si celles de la valeur saisie diffèrent des unités par défaut.
- Rotation - l’angle de rotation du remplissage d’exclusion (en degrés), mesuré dans le sens antihoraire à partir de zéro (l’horizontale 3 o'clock). Modifiez-le pour changer la rotation du remplissage d’exclusion. La résolution angulaire minimale est de 0,001°.
Propriétés
- Component – ce champ s’affiche dans l’éditeur de PCB uniquement lorsque le remplissage d’exclusion sélectionné fait partie d’un composant PCB et indique le repère du composant PCB parent. Cliquez sur le lien Component pour ouvrir le mode Component du panneau Properties pour le composant parent.
- Restricted for Layer - utilisez la liste déroulante pour sélectionner la couche soumise aux restrictions.
- Area - indique la surface de l’objet placé.
- Length - affiche la longueur actuelle du remplissage d’exclusion. Modifiez ce champ pour définir une longueur comprise entre 0,001 mil et 10 000 mil.
- Width - affiche la largeur actuelle du remplissage d’exclusion. Modifiez ce champ pour définir une largeur comprise entre 0,001 mil et 10 000 mil.
Restrictions des zones d’exclusion
Utilisez cette section pour sélectionner les types d’objets auxquels s’appliquent les restrictions de la zone d’exclusion. Si vous désélectionnez un type d’objet, la zone d’exclusion autorisera les objets de ce type à empiéter sur son espace (ils ne seront pas exclus) en n’appliquant pas la règle d’espacement correspondante. Les choix comprennent :
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Placement des zones d’exclusion
Une zone d’exclusion se place dans l’espace de conception de l’éditeur à partir du menu Place » Keepout. Le type de zone d’exclusion choisi (piste, remplissage, région ou arc) est placé sur la couche actuellement active. Sélectionnez les propriétés de la zone d’exclusion pour modifier ses caractéristiques physiques, sa couche ou les restrictions par type d’objet. Les propriétés Keepout correspondantes sont :
- Restricted for Layer – définit la couche de la zone d’exclusion, et donc la couche du circuit imprimé sur laquelle les objets en cuivre seront soumis aux restrictions (exclus). Pour une zone d’exclusion sur toutes les couches, sélectionnez Keep-Out Layer.
- Keepout Restrictions – détermine les types d’objets auxquels s’appliquent les restrictions de la zone d’exclusion. Si vous désélectionnez un type d’objet, la zone d’exclusion autorisera les objets de ce type à empiéter sur son espace (ils ne seront pas exclus), en n’appliquant pas la règle d’espacement correspondante.
Dans l’image ci-dessous, les deux remplissages d’exclusion présentent des restrictions différentes concernant les couches et les objets. Ces restrictions permettent au remplissage d’exclusion de la couche supérieure (à gauche) d’accepter une pastille traversante (TH) tout en excluant tous les autres types d’objets, et à celui de la couche d’exclusion (à droite) d’accepter uniquement les pistes.

Exemple de deux remplissages d’exclusion placés sur différentes couches d’un circuit imprimé et configurés pour restreindre le placement de différents types d’objets.
La souplesse intrinsèque des zones d’exclusion permet de les utiliser pour de nombreuses tâches de contrôle du routage des circuits imprimés. Puisqu’elles peuvent être superposées, affectées à n’importe quelle couche de signal (supérieure ou inférieure, par exemple) et configurées pour exclure des objets spécifiques, elles permettent notamment de contrôler précisément la couture de vias et les remplissages polygonaux.
Contrôle des remplissages polygonaux
Dans l’exemple de circuit imprimé présenté ci-dessous, des remplissages d’exclusion ont été ajoutés autour des pastilles multicouches dans une région susceptible d’être soumise à une tension élevée. Cette région doit disposer d’une isolation électrique suffisante par rapport aux futurs remplissages polygonaux reliés à la masse. Les remplissages d’exclusion sont affectés à la couche supérieure et configurés pour exclure uniquement les objets en cuivre : ils excluent donc les remplissages polygonaux, les remplissages et les régions, tout en acceptant les pistes et les pastilles existantes, etc. – autrement dit, la règle de violation d’espacement ne s’appliquera qu’aux objets classés comme « cuivre ».

Remplissages d’exclusion placés sur la couche d’exclusion et configurés pour s’appliquer uniquement aux objets en cuivre.
La disposition des zones d’exclusion ci-dessus obligera les remplissages polygonaux placés sur les couches de signal (ici, les couches supérieure et inférieure) à éviter les trois zones d’exclusion. Cependant, le pads de la couche supérieure associé à la zone concernée ne bénéficiera pas d’un espacement suffisant par rapport au remplissage de la couche supérieure.
Dans ce cas, des zones d’exclusion supplémentaires peuvent être ajoutées à la couche supérieure afin que son remplissage polygonal reste à une distance suffisante de toutes les pastilles concernées. Dans l’image ci-dessous, deux autres remplissages d’exclusion ont été ajoutés à la couche supérieure, affichée ici en mode monocouche pour plus de clarté. Notez que la zone d’exclusion représentée aurait pu être créée à partir d’une seule région, plutôt que de deux remplissages superposés.

Remplissages d’exclusion placés sur la couche supérieure et configurés pour s’appliquer uniquement aux objets en cuivre.
Lorsque les remplissages polygonaux seront ajoutés au circuit, l’ensemble des zones d’exclusion les contraindra à former un contour d’espacement différent sur chaque couche autour de la région. Notez que, dans cet exemple, l’espacement associé aux zones d’exclusion est supérieur à celui des objets ordinaires en raison d’une règle d’espacement des zones d’exclusion personnalisée (voir ci-dessous).

Les remplissages polygonaux évitent les objets d’exclusion placés.
L’influence de l’ensemble des zones d’exclusion sur les remplissages polygonaux apparaît clairement lorsque le circuit est affiché en mode 3D monocouche, comme ci-dessous : couche supérieure à gauche et couche inférieure à droite.

La couche supérieure (à gauche) et la couche inférieure (à droite) du circuit imprimé affichées en mode 3D monocouche.
Contrôle de la couture de vias
L’application de formes d’exclusion configurées pour exclure les vias sur des surfaces de cuivre multicouches permet de contrôler l’étendue de la couture automatique de vias (Tools » Via Stitching/Shielding). Ces formes peuvent être affectées à toutes les couches ou à l’une des couches des surfaces de cuivre, afin d’exclure les vias reliant ces couches.
Dans l’exemple ci-dessous, des formes d’exclusion ont été ajoutées dans les coins supérieur gauche et inférieur gauche du circuit. Elles sont configurées pour exclure les vias, ce qui empêchera la couture automatique de vias de placer des vias à l’intérieur de ces périmètres.

Régions d’exclusion configurées pour s’appliquer uniquement aux vias.
En plus d’éviter les pistes, pastilles et vias existants, comme c’est normalement le cas, la couture de vias évite également les formes d’exclusion conformément à la règle d’espacement applicable.

Le circuit imprimé après l’ajout de la couture de vias.
Zones d’exclusion dans les composants
Les zones d’exclusion sont ajoutées aux empreintes des composants dans l’éditeur de bibliothèques PCB selon la même méthode que dans l’espace de conception de l’éditeur PCB.
La zone d’exclusion ajoutée à l’empreinte du composant ci-dessous est configurée pour exclure tous les objets, mais autoriser les pistes. Elle permet ainsi les connexions des nets dans un circuit utilisant ce composant, tout en empêchant le placement d’autres types d’objets à proximité.

Des objets d’exclusion peuvent également être ajoutés aux empreintes des composants dans l’éditeur de bibliothèques PCB.
Utilisation des zones d’exclusion
La mise en œuvre des zones d’exclusion spécifiques aux objets dans Altium Designer se retrouve dans toutes les fonctions associées. Elle est notamment compatible avec les requêtes (et donc les règles de conception), le panneau PCB List, ainsi qu’avec les documents de conception PCB importés ou anciens.
Règle d’espacement des zones d’exclusion
Comme pour les autres primitives, la règle d’espacement électrique actuelle détermine les contraintes d’espacement des zones d’exclusion – voir Design » Rules. Si une contrainte d’espacement différente est nécessaire pour les zones d’exclusion, créez une règle spécifique en appliquant la vérification d’attribut IsKeepOut sous forme de requête personnalisée.
Assurez-vous que la règle personnalisée d’espacement des zones d’exclusion (Keepout) a une priorité supérieure à celle de la règle d’espacement existante (globale). Dans l’exemple ci-dessous, une règle a été créée pour les zones d’exclusion (Clearance_Keepout) avec une distance d’espacement deux fois supérieure à celle de la règle d’espacement de base (Clearance). Comme le montre l’extrait du routage de la carte, la piste routée entre les deux pastilles contourne la zone d’exclusion (à droite) avec une marge plus importante que celle appliquée à la région de la couche supérieure (à gauche).

Une règle d’espacement supplémentaire peut être créée pour les objets d’exclusion.
Convertir des objets primitifs en objets d’exclusion
Les objets primitifs existants sur les couches de signal peuvent être convertis en objets d’exclusion sur la même couche, à l’aide de la commande Convertir les primitives en objets d’exclusion (Tools » Convert » Convert Selected Primitives to Keepout).

Un objet primitif peut être converti en un objet d’exclusion équivalent (et inversement).
Accès via les panneaux
Les zones d’exclusion spécifiques à certains types d’objets dans une conception de carte sont accessibles via les panneaux Liste PCB et Filtre PCB.
Le panneau PCB Filter permet d’utiliser le mot-clé de requête IsKeepOut pour localiser et, si nécessaire, sélectionner les objets d’exclusion dans la conception.

Le panneau PCB Filter permet de localiser les objets d’exclusion dans la conception.
Le panneau PCB List permet de répertorier, de sélectionner et de modifier les objets d’exclusion du type sélectionné, par exemple les remplissages d’exclusion, comme le montre l’image du panneau Liste ci-dessous. Un remplissage standard sur la couche supérieure (le dernier de la liste) est également présenté à titre de comparaison. Si all les remplissages (ou d’autres types d’objets, tels que les régions) présents dans la conception sont définis comme objets d’exclusion, le panneau PCB List inclut l’ensemble des attributs de restriction des objets d’exclusion.

Le panneau PCB List permet de répertorier, de sélectionner et de modifier les objets d’exclusion du type sélectionné.
Importer des conceptions de PCB
Altium Designer peut importer des fichiers de conception provenant d’un large éventail d’autres outils de conception grâce aux fonctions de conversion automatisée de l’Assistant d’importation (File » Import Wizard). Les objets de type exclusion présents dans les fichiers de conception de PCB issus d’autres outils, dont certains sont spécifiques à des types d’objets, sont convertis par l’assistant, lorsque cela est possible, en zones d’exclusion spécifiques à ces types d’objets.
Le processus de conversion des zones d’exclusion de l’assistant est compatible avec les conceptions de cartes provenant de systèmes ECAD courants, tels que Mentor® Graphics Pads™ et Cadence® Allegro™. Les zones d’exclusion sont également interprétées correctement lors de l’exportation au format IDF.

