Utilisation des pièces sur un PCB
En un coup d'œil
- Vous apprendrez ce qu’est une room sur un PCB et comment elle permet de contrôler le placement des objets et les exigences de conception dans une zone définie de la carte.
- Vous découvrirez les principales méthodes de création de rooms dans l’éditeur PCB, notamment le placement interactif, la création à partir de composants sélectionnés et la création au moyen de contraintes de conception.
- Vous comprendrez comment les objets room et les contraintes Room Definition fonctionnent ensemble dans Altium Designer, notamment dans le PCB Rules and Constraints Editor et le Constraint Manager.
Résumé
Une room est une zone définie sur l'une des couches de surface du PCB. Elle permet de définir des exigences de conception dans cette zone de la carte, telles que : these components must be in this area, ou route these nets this width, ou encore use routing vias of this size.
Une room se place comme les autres objets polygonaux, sous forme rectangulaire ou polygonale.
Outre sa présence sous forme de zone X-Y nommée sur la carte, chaque room devient automatiquement une contrainte de conception nommée de type Room Definition Les paramètres de la contrainte Room Definition définissent : les objects auxquels la room s'applique, si ces objets doivent être maintenus inside or outside de la room, ainsi que la layer sur laquelle la room s'applique.
Au-delà de la simple exigence de keep these objects in (or out) spécifiée directement par la contrainte Room Definition, la room peut également servir à définir une zone de la carte dans laquelle d'autres contraintes de conception s'appliquent. Par exemple, le routage sous un BGA peut nécessiter une largeur spécifique , ou le routage des paires différentielles sous un BGA peut nécessiter l'application d'un profil d'impédance spécifique
Disponibilité
Les rooms peuvent uniquement être placées ou créées dans l'éditeur PCB. Utilisez les méthodes suivantes pour créer des rooms :
-
Sélectionnez la commande souhaitée dans le sous-menu Design » Rooms , puis définissez interactivement la forme de la room (si vous avez sélectionné une commande Place) ou créez automatiquement la room (si vous avez sélectionné une commande Create).
-
Ajoutez une nouvelle contrainte de conception Room Definition, modifiez cette nouvelle contrainte de room, puis cliquez sur le bouton Define pour définir interactivement la forme de la room polygonale.
-
Créez une room à partir d'un contour fermé (sélectionné) constitué d'un ensemble de pistes et d'arcs, à l'aide de la commande Tools » Convert » Create Room from Selected Primitives.
-
Créez automatiquement des rooms lors de la synchronisation de la conception entre le schéma et le PCB. En savoir plus sur les rooms générées automatiquement (et sur la façon de les désactiver).
Création d'une room
La procédure de création d'une room dans le document PCB dépend du fait que vous placez ou créez la room de manière interactive, ainsi que de la méthode de placement ou de création choisie.
Différentes techniques permettent de placer ou de créer une room.
Placement interactif d'une room
Les rooms rectangulaires ou polygonales peuvent être placées sur les couches supérieure ou inférieure de la conception. Notez que, même si elles peuvent être placées quelle que soit la couche active, la couche à laquelle elles s'appliquent est définie dans la contrainte de conception Room Definition.
Room rectangulaire
Après le lancement de la commande Design » Rooms » Place Rectangular Room, le curseur prend la forme d'un réticule et vous passez en mode de placement de room. Pour effectuer le placement, procédez comme suit :
-
Cliquez ou appuyez sur Enter pour fixer le premier coin de la room.
-
Pour modifier à la volée les propriétés de la contrainte Room Definition associée, appuyez sur la touche Tab pendant le placement.
-
Déplacez le curseur pour ajuster la taille de la room, puis cliquez ou appuyez sur Enter pour fixer le coin diagonalement opposé et terminer le placement de la room.
-
Continuez à placer d'autres rooms, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
Room polygonale
Après le lancement de la commande Design » Rooms » Place Polygonal Room, le curseur prend la forme d'un réticule et vous passez en mode de placement de room. Pour effectuer le placement, procédez comme suit :
-
Positionnez le curseur, puis cliquez pour fixer le point de départ de la room.
-
Positionnez le curseur, puis cliquez pour fixer une série de sommets définissant la forme polygonale de la room.
-
Après avoir placé le dernier sommet, faites un clic droit ou appuyez sur Esc pour terminer le placement de la room. Il n'est pas nécessaire de fermer le polygone, car le logiciel complète automatiquement la forme en reliant le point de départ au dernier point placé.
-
Continuez à placer d'autres rooms polygonales, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
À partir des composants sélectionnés
Si les composants sont déjà positionnés sur la carte et que vous souhaitez créer une nouvelle room adaptée à leur placement, utilisez l'une des trois commandes Create xxx Room from selected components. Ces commandes permettent de créer automatiquement des rooms non orthogonales, orthogonales ou rectangulaires à partir des composants actuellement sélectionnés dans l'espace de conception. Dans tous les cas, la méthode de création est la même :
-
Sélectionnez tous les composants pour lesquels vous souhaitez créer la room. Pour sélectionner les composants du PCB depuis le schéma, exécutez la commande Tools » Cross Select Mode, puis sélectionnez les composants sur le schéma.
-
Dans l'éditeur PCB, lancez la commande de création appropriée (Design » Rooms » Create xxx Room from selected components). Une classe de composants contenant les composants sélectionnés est automatiquement créée (sauf si une telle classe existe déjà).
-
Le type de chambre choisi est alors créé, et la règle de conception Room Definition de cette chambre est automatiquement associée à la classe de composants créée.
-
La chambre sera dimensionnée de manière à englober tous les composants de la sélection, en fonction des rectangles de sélection des composants.
-
Si vous cliquez sur cette chambre et la faites glisser pour la déplacer, tous les composants de la classe de composants associée se déplaceront également.
Une chambre orthogonale est créée à partir des composants du PCB sélectionnés depuis le schéma.
En ajoutant une contrainte de conception Room Definition
Une nouvelle chambre peut également être créée en définissant une nouvelle contrainte dans le PCB Rule and Constraints Editor ou le Constraint Manager.
Quelle approche est utilisée pour définir les contraintes de conception ?
Altium Designer prend en charge deux approches distinctes pour définir les contraintes de conception : le gestionnaire de contraintes et l’ éditeur de règles et de contraintes PCB.
Le PCB Rule and Constraints Editor est l’interface initialement développée pour définir les contraintes dans l’éditeur PCB. Si le PCB Rule and Constraints Editor est utilisé, le concepteur définit : what objects the constraint (rule) applies to, et how those objects are to be constrained. Cette approche est puissante, car elle permet au concepteur de cibler précisément les objets auxquels il souhaite appliquer des contraintes ; elle peut s’appliquer à tout (par exemple, à tous les nets) ou cibler un objet précis de la carte (une pastille donnée). Cette méthode flexible de ciblage des objets de conception repose sur un moteur de règles piloté par un langage de requête.
Le Constraint Manager adopte une approche centrée sur les objets pour définir les contraintes. Le concepteur travaille du point de vue des objets et applique les différentes contraintes électriques et physiques nécessaires à la conception dans une interface de type tableur. Les objets sont mis en surbrillance dans l’éditeur graphique lorsqu’ils sont sélectionnés dans le Constraint Manager. Cela permet au concepteur de configurer et d’examiner facilement toutes les exigences relatives à un objet, par exemple : cette classe de nets doit être routée avec cette largeur, cet espacement, ce via de routage et ce style de connexion aux polygones. Vous pouvez également exiger que cette classe de nets soit routée sur certaines couches, avec des impédances données. Cette vue centrée sur les objets n’est pas possible dans le PCB Rule and Constraints Editor. Au final, le logiciel convertit les contraintes centrées sur les objets dans le même format de règles que celui défini dans le PCB Rule and Constraints Editor. Passez à la vue All Rules après avoir ouvert les contraintes depuis l’éditeur PCB pour les consulter.
Cette page de documentation présente des images des contraintes telles qu’elles sont définies dans la boîte de dialogue PCB Rule and Constraints Editor et dans le Constraint Manager. Notez que les termes constraint et rule sont utilisés de manière interchangeable.
Ajout d’une nouvelle contrainte de conception Room Definition
Dans l’éditeur de règles et de contraintes PCB
Pour chaque chambre placée ou créée, une contrainte de conception Room Definition associée est automatiquement créée. La réciproque est également vraie : si vous ajoutez une nouvelle règle de ce type, l’objet chambre correspondant apparaît dans l’espace de conception. Notez que cela s’applique aussi à la suppression : si vous supprimez une chambre dans l’éditeur graphique, la contrainte est automatiquement supprimée ; si vous supprimez la contrainte de conception, l’objet graphique est supprimé.
Si la contrainte de chambre est définie depuis le PCB Rules and Constraint Editor, un objet chambre par défaut de 5 pouces sur 5 pouces est créé, à 1 pouce de l’origine absolue (en bas à gauche de l’espace d’édition). Notez que le repère d’origine affiche l’origine relative définie par l’utilisateur, qui peut être positionnée n’importe où dans l’espace d’édition.
Lorsqu’une nouvelle contrainte de chambre est ajoutée, une chambre par défaut est définie dans l’espace d’édition.
Une fois la contrainte ajoutée, vous pouvez revenir à l’espace d’édition et modifier graphiquement la chambre. Vous pouvez également, depuis le PCB Rules and Constraints Editor, modifier la contrainte de chambre, puis cliquer sur le bouton Define pour en définir la forme de manière interactive. Comme une chambre définit une zone sur la carte, il est plus courant de placer la chambre de manière interactive et de laisser la contrainte de conception se créer automatiquement.
Pour en savoir plus sur l’ajout d’une nouvelle contrainte dans l’éditeur de règles et de contraintes PCB.
Dans le gestionnaire de contraintes
Pour créer une nouvelle contrainte de confinement (chambre) dans le Constraint Manager:, passez à la vue All Rules, sélectionnez Room Definition dans la catégorie Placement, puis faites un clic droit dans la liste des règles avancées et sélectionnez Add Advanced Rule dans le menu contextuel, comme illustré ci-dessous.
Une nouvelle contrainte de chambre peut être ajoutée dans le gestionnaire de contraintes.
À ce stade, l’objet chambre n’existe pas dans l’espace d’édition graphique. Vous devez maintenant cliquer sur le bouton Define (ce qui vous fait passer à l’éditeur PCB) et définir la forme de la chambre. Une fois cette opération effectuée, la contrainte de chambre et l’objet chambre existent tous deux, et les contraintes peuvent être enregistrées.
-
Si la contrainte de chambre doit servir à imposer que des objets restent à l’intérieur (ou à l’extérieur) de cette zone de la carte, l’étape suivante consiste à configurer le Object Match et les autres paramètres de contrainte au bas du Constraint Manager. Poursuivez votre lecture pour en savoir plus.
-
Si la contrainte de chambre doit servir à définir une zone dans un autre type de contrainte, comme la largeur de routage, consultez la section Définition de contraintes à l’intérieur d’une chambre pour en savoir plus.
Pour en savoir plus sur l’ajout d’une nouvelle contrainte dans le gestionnaire de contraintes.
Qu’est-ce qu’une contrainte de chambre ?
Comme indiqué précédemment, une chambre est une zone définie sur l’une des couches de surface du PCB, qui sert à définir les exigences de conception dans cette zone de la carte.
Toutes les contraintes de conception comportent deux éléments clés :
-
what objects this constraint applies to , et
-
how those objects are to be constrained
Si la contrainte de chambre est définie dans une zone de la carte ne contenant aucun composant, le critère Object Match (the objects this constraint applies to) prend par défaut la valeur False, ce qui signifie que cette contrainte ne s’applique à aucun objet. Modifiez ce critère selon vos besoins.
La définition de chambre nouvellement créée. Notez que la portée de la règle est définie sur False, ce qui signifie qu’elle ne s’applique à aucun objet.
Contraindre une classe de composants
Une utilisation courante d’une contrainte de zone consiste à définir l’emplacement d’une classe de composants, en limitant cette classe à une partie précise du circuit imprimé.
La classe de composants Encoder est confinée dans la zone appelée Room-Encoder, sur la couche supérieure du circuit imprimé.
L’image ci-dessus montre comment la classe de composants Encoder est confinée within la zone Room-Encoder, sur la Top side du circuit imprimé dans le PCB Rules and Constraints Editor (essentiellement comme dans le Constraint Manager Une fois les composants affectés à une zone, ils se déplacent avec elle. Pour déplacer une zone sans déplacer les composants, désactivez temporairement la règle de définition de zone associée.
En savoir plus sur la contrainte de conception Définition de zone.
L’éditeur de circuits imprimés propose plusieurs outils puissants pour travailler avec les zones. Pour en savoir plus, consultez la section Utilisation des zones de cette page.
En plus de constituer une contrainte de conception à part entière (Définition de zone), une zone peut également servir d’objet pour limiter la portée d’une autre contrainte de conception à une partie du circuit imprimé, par exemple une contrainte de largeur, d’espacement ou de style de via. Ce sujet est abordé dans la section Définition de contraintes au sein d’une zone de cette page.
Création lors de la synchronisation du schéma avec le circuit imprimé
Lors du transfert de la conception du schéma vers le circuit imprimé, vous pouvez créer une zone contenant les composants de chaque feuille de schéma. Dans une conception hiérarchique à plusieurs niveaux, cela peut présenter peu d’intérêt, mais dans une grande conception à plat, disposer d’une zone pour chaque feuille peut faciliter le positionnement des composants sur le circuit imprimé.
L’onglet Génération des classes de la boîte de dialogue Project Options comprend des options permettant de générer des zones pour chaque feuille de la conception Si l’option Generate Rooms est cochée, une zone est créée pour cette feuille et une classe regroupant tous les composants de cette feuille est affectée à cette zone lors de l’exécution de la commande Design » Update. Notez que les composants de chaque feuille sont ajoutés à une classe de composants ; l’option Generate Rooms nécessite donc que l’option Component Class correspondante soit également activée.
Dans le circuit imprimé, chaque contrainte de zone est créée avec la portée InComponentClass('<SheetSymbolDesignator>'). Aucune zone n’est créée si la feuille ne contient aucun composant. Lors du transfert initial du schéma vers le circuit imprimé, les composants de chaque classe sont disposés en ligne, puis une zone est créée autour de cette classe de composants, comme illustré ci-dessous.
Décochez les cases Generate Rooms dans la boîte de dialogue Project Options si les zones générées automatiquement ne sont pas nécessaires.
Le circuit imprimé après la synchronisation initiale de la conception : une zone a été créée pour chaque feuille, et la classe de composants de cette feuille lui a été affectée.
En savoir plus sur la génération automatique de zones, de classes de composants et de classes de nets à partir du projet schématique.
Pour en savoir plus sur la synchronisation de la conception, consultez la page Maintenir la synchronisation des schémas et du circuit imprimé .
À partir de pistes et d’arcs sélectionnés
Un objet zone peut être défini à l’aide d’un contour fermé constitué d’objets piste et/ou arc sélectionnés. Pour ce faire, sélectionnez toutes les primitives de piste et d’arc constituant le contour fermé dans l’espace de conception, puis choisissez la commande Tools » Convert » Create Room from Selected Primitives dans les menus principaux. Le diaporama ci-dessous présente les étapes à suivre.
|
Des pistes ont été placées sur une couche mécanique pour définir l’espace disponible sur le circuit imprimé pour les composants Encoder. Exécutez la commande Tools » Convert » Create Room from Selected Primitives pour créer une définition de zone de même forme. La boîte de dialogue Edit Room Definition s’affiche pour permettre de définir les paramètres de la contrainte. La classe de composants Pour modifier la forme de la zone, cliquez dessus pour la sélectionner, puis exécutez la commande Design » Rooms » Edit Polygonal Verticies, et cliquez sur un sommet ou un bord pour remodeler la zone. |
Modification d’une zone
La forme de la zone dans le plan X-Y et son emplacement sur le circuit imprimé peuvent être modifiés de manière interactive. Notez qu’il existe deux méthodes distinctes pour modifier une zone de manière interactive : à partir de son rectangle de sélection (décrite dans la section Modification de la taille et de l’emplacement) ou à partir de ses sommets de modification de forme (décrite dans la section Modification de la forme).
Outre l’accès aux commandes via le sous-menu Design » Rooms, vous pouvez également accéder aux commandes contextuelles de zone en faisant un clic droit sur une zone placée et en sélectionnant le sous-menu Room Actions.
Faites un clic droit sur une zone pour accéder aux commandes qui lui sont propres.
Modification de la taille et de l’emplacement
Lorsque vous cliquez une fois sur une zone pour la sélectionner, les poignées de modification suivantes deviennent disponibles, que la zone ait été initialement placée sous forme rectangulaire ou polygonale :
Des poignées de modification apparaissent lorsque vous cliquez pour sélectionner une chambre.
Modification de la taille de la chambre
-
Faire glisser les poignées d’angle (A) redimensionne la chambre simultanément à l’horizontale et à la verticale.
-
Faire glisser une poignée de bord (B) redimensionne l’objet dans cette direction (horizontalement ou verticalement).
-
Pendant le déplacement, vous pouvez faire pivoter ou retourner la chambre en appuyant sur :
-
Spacebar pour faire pivoter l’objet dans le sens antihoraire ou sur Shift+Spacebar pour une rotation dans le sens horaire. La rotation s’effectue selon la valeur du pas de rotation définie sur la page PCB Editor - General de la boîte de dialogue Preferences.
-
X ou Y pour retourner l’objet selon l’axe X ou Y.
-
L pour retourner l’objet sur l’autre face de la carte. Si des composants sont associés à la chambre, ils seront retournés avec elle.
-
Déplacement d’une chambre
Cliquez sur une chambre et faites-la glisser pour la déplacer vers un nouvel emplacement. Une chambre peut également être déplacée à l’aide de la commande Design » Rooms » Move Room des menus principaux ou de la commande Room Actions » Move Room du menu contextuel de la chambre. Après le lancement de la commande, le curseur prend la forme d’un réticule et vous passez en mode de déplacement des chambres : cliquez sur la chambre pour la déplacer.
Lorsque vous cliquez sur une chambre pour la déplacer :
-
La chambre s’attache au curseur. Son point de saisie dépend du réglage actuel de Object Snap Options , le curseur s’accrochant au point d’accrochage activé le plus proche (pastille de composant, point de référence de composant ou sommet de chambre).
-
Déplacez la chambre à la position souhaitée, puis cliquez ou appuyez sur Enter pour la placer.
-
Continuez à déplacer d’autres chambres, ou faites un clic droit ou appuyez sur Esc pour quitter.
-
Si la chambre déplacée contient des composants, des guides d’alignement dynamiques verts peuvent être affichés pendant le déplacement en appuyant sur les touches Shift ou Ctrl. Utilisez Shift pour conserver l’accrochage à la grille active, ou Ctrl pour désactiver temporairement la grille et vous aligner sur un objet existant situé hors grille.
-
Si la chambre contient des objets sans net et/ou des objets verrouillés, la boîte de dialogue Room containing No Net/Locked Objects s’ouvre. Utilisez-la pour déterminer si ces objets doivent être déplacés avec la chambre, puis cliquez sur OK. Pour que cette boîte de dialogue s’affiche, l’option Ask when moving rooms containing No Net/Locked Objects doit être activée sur la page PCB Editor - General de la boîte de dialogue Preferences

La boîte de dialogue Room containing No Net / Locked Objects
Boîte de dialogue Chambre contenant des objets sans net / verrouillés |
|
| No Net Objects | Activez cette option pour déplacer les objets sans net avec la chambre. |
| Locked Objects | Activez cette option pour déplacer les objets verrouillés avec la chambre. |
| Don't ask me about moving room's locked/no net objects until next PCB session (use currently selected settings) | Activez cette option pour enregistrer les paramètres sélectionnés et les utiliser pendant le reste de votre session PCB. La boîte de dialogue ne s’ouvrira plus avant le démarrage d’une nouvelle session. |
Modification de la forme
La forme du contour d’une chambre se modifie en exécutant la commande Edit Polygonal Room Vertices. Cette commande est accessible depuis le sous-menu Design » Rooms ou le sous-menu contextuel Room Actions accessible par clic droit.
Lorsque vous exécutez la commande, les poignées de modification du contour polygonal de la chambre s’affichent. Vous pouvez alors :
-
Cliquer sur une poignée A, puis déplacer le curseur pour déplacer ce sommet. Cliquer à nouveau au nouvel emplacement pour positionner le sommet.
-
Pendant le déplacement d’une poignée A, appuyer sur la touche Delete du clavier pour supprimer ce sommet de la chambre.
-
Cliquer sur B ou sur un bord (entre les poignées), puis déplacer le curseur pour faire glisser ce bord. Appuyer sur Shift+Spacebar pendant le déplacement du bord pour parcourir les modes de comportement des bords disponibles (glissement, cassure, incurvation).
-
Ctrl+Click B ou Ctrl+Click sur un bord, puis déplacer le curseur pour ajouter un sommet à ce bord et le déplacer. Cliquer à nouveau au nouvel emplacement pour positionner le sommet. Le nouveau sommet devient alors un sommet A, et de nouveaux sommets B sont ajoutés entre celui-ci et les sommets A d’origine.
-
Pour accéder à une poignée située hors grille, maintenir la touche Ctrl enfoncée afin de désactiver temporairement l’accrochage à la grille.
-
Continuer à modifier la forme de la chambre selon les besoins, ou faire un clic droit ou appuyer sur Esc pour terminer. L’affichage de la chambre est mis à jour en fonction de la nouvelle forme du contour.
Cette commande peut être utilisée que la chambre cible soit verrouillée ou non.
Découpage d’une chambre
Des commandes permettent de slice graphiquement une chambre placée en deux chambres distinctes ou plus. Le processus de découpage est similaire au placement d’une ligne et propose les mêmes modes d’angle (la largeur de l’objet de découpage correspond d’ailleurs à la largeur de ligne par défaut actuelle). Notez que les objets utilisés pour afficher le tracé de découpe ne sont pas des objets en cours de placement : ils servent uniquement à visualiser le tracé et sont supprimés une fois le découpage terminé. Il n’est pas non plus nécessaire de commencer le découpage exactement sur le bord d’une chambre ; il est plus simple de commencer légèrement à l’extérieur de celle-ci et de terminer également légèrement à l’extérieur.
Deux commandes de découpe sont disponibles. La définition du tracé de découpe est identique pour les deux ; elles diffèrent par leur traitement des composants présents dans la room à découper. Ces différences sont expliquées après la description du processus de découpe.
|
Faites un clic droit sur une room pour accéder aux commandes Slice dans le menu Room Actions. Deux découpes ont été définies selon le processus décrit ci-dessous. Trois rooms ont été créées. |
Processus de découpe
Après avoir lancé une commande Slice :
-
Le curseur prend la forme d'un réticule et vous êtes invité à sélectionner un point de départ pour la découpe.
-
Placez le curseur juste à l'extérieur de la room à découper, puis cliquez ou appuyez sur Enter. Vous êtes maintenant en mode découpe (qui correspond essentiellement au mode de placement de lignes).
-
Déplacez le curseur à l'intérieur de la room pour définir le premier segment de découpe, puis cliquez ou appuyez sur Enter pour fixer l'extrémité de ce segment.
-
Continuez à déplacer le curseur et à cliquer pour définir une série de sommets qui déterminent la forme de la découpe.
-
Après avoir placé le dernier sommet (juste à l'extérieur de la room), faites un clic droit ou appuyez sur Esc pour terminer le placement de cette découpe.
-
Vous pouvez alors commencer une autre découpe de la room, ou faire un clic droit ou appuyer sur Esc pour quitter le mode découpe.
-
Une boîte de dialogue de confirmation s'ouvre et indique le nombre de rooms résultant de la division de la room d'origine. Cliquez sur Yes pour valider les découpes effectuées, ou sur No pour les annuler. Les nouveaux objets room obtenus sont mis à jour en conséquence, et les règles de définition de room correspondantes sont créées et associées.
-
Pendant la découpe, appuyez sur :
-
Shift+Spacebar pour parcourir les modes de coin.
-
Spacebar pour inverser l'orientation du coin.
-
Chaque segment de découpe nécessite un point de départ et un point d'arrivée.
-
Si le mode de placement de la découpe inclut un coin, utilisez le raccourci 1 pour basculer entre le placement d'un segment par clic et de deux segments par clic.
-
Backspace pour supprimer le dernier segment de découpe placé.
-
Réajustement du contour d'une room existante
Une autre façon de modifier la forme d'une room existante consiste à demander au logiciel de réajuster son contour autour de la classe de composants qui lui est affectée. Le sous-menu contextuel Room Actions et le sous-menu Design » Rooms proposent tous deux les trois commandes de réajustement du contour de room, comme illustré dans le diaporama.
|
Si vous modifiez le placement des composants dans une room, utilisez l'une des trois commandes Wrap pour mettre à jour sa forme. La commande Wrap Non-Orthogonal place les bords de la room de façon à relier les points extrêmes des contours des composants. La commande Wrap Orthogonal place des bords de room verticaux et horizontaux autour des contours des composants. La commande Wrap Rectangular crée la plus petite room rectangulaire englobant les contours des composants. |
Modification dans le panneau Properties
L'objet room a la particularité d'être à la fois un objet et une contrainte de conception.
Modification via le panneau Properties
Les propriétés de l'objet room, notamment sa position et sa forme dans l'espace d'édition, peuvent être modifiées dans le panneau Properties lorsque la room est sélectionnée. Ce panneau peut être affiché à l'aide du bouton Panels situé en bas à droite de l'espace de conception, ou de la commande View » Panels » Properties.
Le panneau Properties permet de modifier les propriétés graphiques d'une room.
| Name | Nom actuel de la room (et de la règle de définition de room associée). Il peut être modifié selon les besoins. En plus de faciliter l'identification de chaque room, ce nom peut être utilisé pour cibler une room précise dans une règle de conception. |
| (X/Y) (deux champs) | La position actuelle en X et Y du premier sommet de la room, par rapport à l’origine actuelle. Modifiez la valeur du champ pour changer la position de la room par rapport à l’origine actuelle. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités si elles diffèrent des unités par défaut actuelles. Les unités par défaut (métriques ou impériales) sont affichées dans la barre d’état et définies dans la zone Other du panneau Properties (lorsqu’aucun objet n’est sélectionné dans l’espace de conception). Ces valeurs ne peuvent être modifiées que si l’option X/Y est déverrouillée (l’icône |
Sommets du contour |
|
| Vertices Grid | Répertorie tous les sommets actuellement définis pour la room, dans l’ordre dans lequel ils ont été définis lors du placement de celle-ci. Des segments de droite relient chaque sommet au suivant. Si vous préférez une liaison en arc, saisissez une valeur pour le paramètre Arc Angle souhaité. La saisie s’effectue dans le champ associé au sommet de départ, l’arc reliant ce sommet au sommet suivant dans la liste. Faites un clic droit pour Copy / Paste ou Import / Export to CSV. |
| Index | L’indice attribué au sommet (non modifiable, basé sur l’ordre de placement des sommets lors de la définition de la room). |
| X | La coordonnée X (horizontale) du sommet. Cliquez pour la modifier. |
| Y | La coordonnée Y (verticale) du sommet. Cliquez pour la modifier. |
| Arc Angle (Neg = CW) | L’angle de l’arc tracé pour relier ce sommet au suivant. Par défaut, les liaisons sont des segments de droite et ce champ reste vide. Cliquez pour le modifier, puis saisissez l’angle d’arc souhaité. Une valeur positive produit un arc tracé dans le sens antihoraire. Pour tracer un arc dans le sens horaire, saisissez une valeur négative. |
Travailler avec les rooms
Le logiciel propose plusieurs fonctionnalités pour vous aider à travailler avec les rooms et les objets qu’elles contiennent. Il comprend notamment des commandes permettant de disposer les rooms en grille, de déplacer les rooms sur la grille d’accrochage actuelle et, pour une conception comportant des sections de circuit répétées, de copier le placement et le routage d’une room à une autre.
Vous pouvez également utiliser une room pour limiter l’application d’autres contraintes de conception à une zone de la carte, en exigeant par exemple que, dans cette room, les nets soient routés avec une largeur et un espacement spécifiques, ou que les paires différentielles soient routées selon un profil d’impédance spécifique.
Un mélangeur à 8 canaux : le premier canal d’entrée a été placé et routé, puis reproduit sur les sept autres canaux d’entrée à l’aide de la commande Copy Room Format.
Définir des contraintes dans une room
Outre le fait d’imposer aux objets de se trouver à l’intérieur ou à l’extérieur d’une room (comme indiqué dans la section Contrainte de conception de définition de room), une room peut également servir à limiter la zone d’application d’autres contraintes de conception. Par exemple, la contrainte de largeur de routage peut imposer des largeurs différentes pour le routage sous un BGA, ou la contrainte d’isolement électrique peut imposer des espacements différents dans une zone spécifique de la carte.
La largeur de routage et les espacements sont automatiquement ajustés dans la room, conformément aux paramètres de définition de la room.
Pour cela, ajoutez les contraintes de largeur de routage et d’isolement électrique présentées dans le diaporama ci-dessous.
Dans le Constraint Manager
Lorsqu’une contrainte de room est ajoutée dans la vue All Rules du Constraint Manager, l’objet room devient également disponible dans la vue Physical. Cette vue vous permet de définir rapidement les contraintes par zone à appliquer dans la room, notamment la largeur de routage, l’isolement électrique, le style des vias de routage, les propriétés des paires différentielles, le rétrécissement des pistes et le style de connexion aux polygones. Le diaporama ci-dessous présente les contraintes de la carte illustrée dans la vidéo ci-dessus.
|
Dans cette room, la largeur de tous les objets de routage doit se situer dans la plage spécifiée. Dans cette room, tous les objets de routage doivent respecter au moins cet espacement par rapport aux objets appartenant à d’autres nets. Dans cette room, tous les objets de routage doivent respecter au moins cette distance d’isolement électrique. Dans cette room, toutes les paires différentielles doivent être routées selon le profil d’impédance |
Dans le PCB Rules and Constraint Editor
Pour obtenir le même résultat dans le PCB Rules and Constraint Editor, créez une requête qui définit la zone de la room. Les objets présents dans la room peuvent être détectés de deux façons : en ciblant ceux qui se trouvent entièrement à l’intérieur de la room (avec le mot-clé WithinRoom), ou ceux qui touchent la room (avec le mot-clé TouchesRoom). Le diaporama ci-dessous présente les mêmes paramètres de largeur de routage, d’isolement électrique, de style de vias de routage et de propriétés des paires différentielles que le Constraint Manager diaporama précédent.
Disposer les rooms sélectionnées
Pour disposer les rooms sélectionnées dans l’espace de conception, utilisez la commande Design » Rooms » Arrange Rooms. Sélectionnez les rooms souhaitées, puis lancez la commande pour ouvrir la boîte de dialogue Arrange Rooms.
La boîte de dialogue Arrange Rooms.
Indiquez comment vous souhaitez disposer les rooms et dans quel ordre elles doivent être placées. Vous pouvez également spécifier la position de départ, soit en saisissant les coordonnées X-Y dans la boîte de dialogue, soit en cliquant dans l’espace de travail, ainsi que l’espacement entre les rooms adjacentes. Après avoir cliqué sur OK, les rooms sélectionnées seront déplacées aux emplacements définis.
Colonnes/Lignes |
|
| Columns | Le nombre de colonnes utilisées pour placer les rooms. Modifiez ce champ selon vos besoins. |
| Rows | Le nombre de lignes utilisées pour placer les rooms. Modifiez ce champ selon vos besoins. Si la disposition personnalisée en lignes et colonnes ne permet pas de contenir toutes les rooms, des lignes supplémentaires seront ajoutées en haut. |
Trier par |
|
| SortBy | Affiche l’ordre de tri choisi, c’est-à-dire les critères utilisés pour déterminer l’ordre des rooms. Les options disponibles sont détaillées ci-dessous. |
| Channel Name | Trie les rooms par ordre alphanumérique, selon le nom de leur canal. En savoir plus sur la conception multicanal. |
| Room Area | Trie les rooms selon leur superficie. |
| Room Component Count | Trier les chambres en fonction du nombre de composants qu’elles contiennent. |
| Room Width | Trier les chambres selon leur dimension X (horizontale). |
| Room Height | Trier les chambres selon leur dimension Y (verticale). |
| Sort in Ascending order | Activez cette option pour trier les chambres par ordre croissant (de la plus petite à la plus grande), selon les critères SortBy actuels. Si cette option est désactivée, le tri s’effectue par ordre décroissant (de la plus grande à la plus petite). |
Position |
|
| Origin X | Définit la position X (horizontale) à partir de laquelle le placement des chambres commencera. Modifiez ce champ pour changer la coordonnée X, qui peut être définie en mm ou en mils. Pour préciser l’unité lors de la saisie d’un nombre, ajoutez le suffixe mm ou mil à la valeur. Les unités par défaut (métriques ou impériales) sont déterminées par le paramètre Units du panneau Propriétés et sont utilisées si aucune unité n’est précisée. |
| Origin Y | Définit la position Y (verticale) à partir de laquelle le placement des chambres commencera. Modifiez ce champ pour changer la coordonnée Y, qui peut être définie en mm ou en mils. Pour préciser l’unité lors de la saisie d’un nombre, ajoutez le suffixe mm ou mil à la valeur. Les unités par défaut (métriques ou impériales) sont déterminées par le paramètre Units du panneau Propriétés et sont utilisées si aucune unité n’est précisée. |
| Select Origin Using Mouse | Si cette option est activée, vous êtes invité à définir manuellement l’origine de la disposition des chambres. L’option doit être désactivée pour pouvoir modifier Origin X et Origin Y. |
| X-Spacing | Définit la distance X (horizontale) à laisser entre les chambres adjacentes. |
| Y-Spacing | Définit la distance Y (verticale) à laisser entre les chambres adjacentes. |
| Auto Spacing | Si cette option est activée, les chambres sont disposées avec un espacement identique selon X (horizontal) et Y (vertical). L’option doit être désactivée pour pouvoir modifier X-Spacing et Y-Spacing. |
| Place On Grid | Activez cette option pour forcer l’alignement des chambres sur la grille d’accrochage actuelle du PCB. |
Déplacement des chambres sur la grille
Pour déplacer chacune des chambres sélectionnées vers le point le plus proche sur la grille d’accrochage actuelle, utilisez la commande Design » Rooms » Move Rooms to Grid. Après le lancement de la commande, une boîte de dialogue de confirmation s’ouvre pour vous demander si vous souhaitez déplacer les objets avec les chambres sélectionnées. Cliquez sur Yes pour déplacer les chambres et les objets qu’elles contiennent vers le point le plus proche sur la grille d’accrochage, ou cliquez sur No pour déplacer uniquement les chambres.
Copie des formats de chambre
L’une des fonctionnalités les plus puissantes des chambres est la possibilité de copier la forme, le placement et le routage d’une chambre vers d’autres chambres contenant un ensemble identique de composants. Cette commande est particulièrement utile lors de l’implantation d’une conception multicanal : elle permet de propager le placement et le routage réalisés dans un canal à tous les autres canaux.
Pour copier le format d’une chambre vers d’autres chambres :
-
Cliquez sur Design » Rooms » Copy Room Formats dans les menus principaux.
-
La barre d’état vous invite à choisir une chambre source. Placez le curseur sur la chambre source et cliquez ou appuyez sur Enter.
-
La barre d’état vous invite à choisir une chambre de destination. Placez le curseur sur la chambre à laquelle vous souhaitez appliquer le format, puis cliquez ou appuyez sur Enter. Si vous prévoyez d’appliquer le format à plusieurs chambres, ce deuxième clic peut être effectué sur n’importe laquelle d’entre elles.
-
La boîte de dialogue Confirm Channel Format Copy s’ouvre. Utilisez les options pour définir les éléments de format à copier. Par défaut, le format est copié depuis la Source Room choisie vers la Destination Room choisie. Pour copier le format de la chambre source vers chacune des chambres de la classe de canaux détectée, activez l’option Apply to Specified Channels et vérifiez que les cases Copy requises sont cochées pour les chambres cibles.
-
Cliquez sur OK dans la boîte de dialogue pour mettre à jour les chambres de destination.
-
Vous pouvez continuer à sélectionner d’autres chambres de destination, ou faire un clic droit pour terminer.
Chambres |
|
| Source Room | Nom de la chambre source (représentant le canal du schéma), dont le placement et le routage des composants seront copiés. |
| Destination Room | Ce champ contient le nom de la chambre de destination (représentant le canal du schéma), à laquelle le placement et le routage copiés seront appliqués. Si le projet est une conception multicanal et que les canaux source et de destination appartiennent à la même classe de canaux, la copie du format sera appliquée aux canaux activés dans la zone Channel Class de la boîte de dialogue Notez que le canal source (chambre) et le canal de destination (chambre) doivent appartenir à la même classe de canaux si vous souhaitez copier le format d’un canal source (chambre) vers d’autres canaux (chambres). |
Options |
|
| Copy Component Placement | Copier le placement des composants de la chambre source vers les chambres de destination. |
| Copy Designator and Comment Formatting | Copier le format des désignateurs et des commentaires de la chambre source vers la chambre de destination. |
| Copy Routed Nets | Copier le routage (pistes/arcs et vias utilisés pour router les nets) de la chambre source vers la chambre de destination. |
| Copy Room Size/Shape | Copier la forme de la chambre source et l’appliquer à la chambre de destination. Si l’option Copy Room Orientation est activée dans la boîte de dialogue, la forme de la chambre de destination sera modifiée par rapport à son point de départ (en bas à gauche) ; autrement dit, le point inférieur gauche de la chambre de destination restera inchangé. |
| Copy Room Orientation | Copier l’orientation de la chambre. Altium Designer détecte l’orientation des chambres (d’après l’angle de rotation du composant ayant le plus grand nombre de broches ou, si plusieurs composants ont ce même nombre maximal de broches, du composant ayant la plus grande surface) et l’utilise pour faire pivoter la chambre de destination. |
| Copy Selected Objects Only | Copier le format des objets sélectionnés de la chambre source vers la chambre de destination. |
Options relatives aux objets en contact |
|
| Copy All Objects Touching the Room | Inclure les objets (autres que les composants, les pistes/arcs de routage et les vias) entièrement ou partiellement contenus dans la room. Cette option doit être activée pour copier d’une room à une autre les objets avec ou sans net, tels que les régions, les polygones et les zones d’exclusion. |
| Exclude NoNet Objects | Exclure les objets auxquels aucun net n’est affecté. |
Entièrement contenus uniquement / Contenus et en contact |
|
| Fully Enclosed Objects Only | Si l’option Copy All Objects Touching the Room est activée, activez cette option pour copier uniquement les objets entièrement contenus. |
| Enclosed & Touching Objects | Si l’option Copy All Objects Touching the Room est activée, activez cette option pour copier à la fois les objets contenus et ceux en contact avec la room. |
Correspondance des composants entre canaux |
|
| Match Components by Channel Offsets | Un décalage de canal est attribué à chaque composant d’un canal répété lors du transfert du schéma vers le PCB. Utilisez ce décalage de canal pour identifier le même composant dans chaque canal. |
| Match Components by Source Designator | Vous pouvez également utiliser le repère source (du schéma) pour identifier les composants correspondants dans chaque canal. |
Supprimer les connexions concernées |
|
| Whole connections | Une fois la copie du format de canal effectuée, le logiciel doit savoir comment supprimer les connexions concernées. Si cette option est sélectionnée, les connexions concernées à l’intérieur et à l’extérieur de la room sont supprimées. |
| Touching parts of connections only | Si cette option est sélectionnée, seules les connexions concernées en contact avec la room sont supprimées. |
| Contained parts of connections only | Si cette option est sélectionnée, seules les connexions concernées à l’intérieur de la room sont supprimées. |
Classe de canaux |
|
| Channel Class | Lorsqu’une conception multicanal est transférée du schéma vers le PCB, les circuits répétés (canaux) sont identifiés en tant que classe de canaux dans la boîte de dialogue Object Class Explorer de l’éditeur PCB Cette classe de canaux permet d’identifier les canaux auxquels la copie du format doit être appliquée. Si la zone Channel Class de la boîte de dialogue est vide, vérifiez que la classe de canaux est correctement définie dans la boîte de dialogue Object Class Explorer (Design » Classes). Si aucune classe de canaux n’est identifiée, la commande de copie s’applique uniquement de la room source à la room de destination. |
| Channel Members | Cette liste contient les canaux, chacun étant identifié par le nom de sa room. Si la room source fait partie d’une classe de canaux définie, cette classe et tous ses membres sont répertoriés. La couche (face de la carte sur laquelle la room a été placée) et le nombre de composants de chaque canal sont affichés. Chaque canal comporte une case à cocher permettant de déterminer si la copie du format doit lui être appliquée. Cette case devient accessible lorsque l’option Apply To Specified Channel est activée. |
| Apply To Specified Channel | Par défaut, le format est copié depuis Source Room vers tous les canaux de la classe de canaux à laquelle appartient la room source (canal). Lorsque cette option est activée, la case à cocher Copy de chaque canal devient accessible, ce qui permet de sélectionner les canaux de la classe auxquels appliquer la copie du format. |
Masquage des rooms
Les rooms d’un document donné peuvent être affichées, masquées ou affichées en mode brouillon de manière globale à l’aide des options de l’onglet View Options du panneau Configuration de l’affichage.
Ajustez le curseur de visibilité des objets pour les rooms afin de les estomper ou de les masquer dans l’espace d’édition.
).

).
)
).
).
).




)
).








).