Travailler avec les pistes et les arcs
En un coup d'œil
- Apprenez à placer, modifier, déplacer et rerouter des segments de piste dans l’éditeur de PCB à l’aide des commandes et raccourcis essentiels.
- Comprenez comment le routage interactif réagit aux nets, aux couches, aux modes de changement de direction, à la résolution des conflits et aux règles de conception applicables.
- Découvrez comment la largeur de routage est déterminée et ajustée, notamment comment les préférences et les règles influencent les largeurs que vous pouvez utiliser.
Utilisation des pistes
Un segment de piste est une ligne droite de largeur définie. Utilisez les pistes pour tracer une ligne droite dans l’espace de conception du PCB. Les pistes sont placées sur une couche de signal pour former les interconnexions électriques, ou le routage, entre les pastilles des composants. Les pistes placées sur une couche non électrique sont appelées lignes et servent d’éléments de dessin polyvalents pour créer des contours de composants, des informations explicatives, des limites de zones interdites, etc. Les pistes sont également utilisées dans des objets de conception groupés, tels que les cotes et les coordonnées.

Les objets piste servent au routage et au tracé de lignes à usage général. L’image ci-dessus montre quatre segments de piste déjà placés et un autre en cours de placement.
Bien que les pistes et les lignes soient en réalité le même objet, la différence réside dans le comportement du logiciel lors de leur placement, ce qui explique l’existence de commandes distinctes. Lorsqu’une commande de placement de piste est exécutée, telle que Interactive Routing, le logiciel surveille l’emplacement du clic et adopte automatiquement le nom du net d’un objet existant (tel qu’une pastille) situé à cet emplacement. Il surveille et respecte également toutes les règles de conception applicables. Lorsqu’une commande de placement de ligne est exécutée (Place » Line), ces comportements de surveillance ne sont pas activés.
Les pistes peuvent être placées dans l’éditeur de PCB et dans l’éditeur de bibliothèques PCB. Quelle que soit la commande utilisée (routage/placement de piste ou placement de ligne), le comportement de base reste le même. Après le lancement de la commande, le curseur prend la forme d’un réticule et vous passez en mode de placement de piste. Le placement s’effectue selon la séquence d’actions suivante :
- Cliquez ou appuyez sur Enter pour fixer le point de départ du premier segment de piste. Si une commande de placement de type routage est active et que vous cliquez sur un objet existant pour commencer le placement, la piste adopte le nom du net de cet objet. Pour le routage, la largeur est déterminée par la règle de conception Largeur de routage applicable ; certaines options de routage interactif permettent de la remplacer et sont décrites plus en détail ci-dessous.
- Déplacez le curseur pour définir le segment de piste, puis cliquez ou appuyez sur Enter pour fixer le point d’arrivée de ce premier segment, qui est également le point de départ du segment connecté suivant.
- Continuez à positionner le curseur, puis cliquez ou appuyez sur Enter pour fixer une série de sommets définissant les segments de piste connectés.
- Faites un clic droit ou appuyez sur Esc pour terminer la série actuelle de segments de piste connectés.
Les actions supplémentaires suivantes peuvent être effectuées pendant le placement :
- Appuyez sur la touche * du pavé numérique pour parcourir les couches de signal disponibles. Vous pouvez également utiliser la combinaison Shift+Ctrl+Wheel Roll pour parcourir les couches de routage ; chaque cran de la molette de la souris permet de passer à la couche de signal disponible suivante (ou précédente).
- Appuyez sur les touches + et - du pavé numérique pour parcourir, vers l’avant et vers l’arrière, toutes les couches actuellement visibles dans la conception.
Lors du placement des segments de piste, cinq modes d’angle sont disponibles, dont quatre proposent également des sous-modes de direction d’angle. Pendant le placement :
- Appuyez sur Shift+Spacebar pour parcourir les modes d’angle disponibles.
- Appuyez sur Spacebar pour basculer entre les deux sous-modes de direction d’angle.
- Dans l’un des modes d’angle en arc, maintenez la touche , ou . enfoncée pour réduire ou agrandir l’arc. Maintenez également la touche Shift enfoncée pour accélérer le redimensionnement de l’arc.
- Appuyez sur le raccourci clavier 1 pour basculer entre le placement d’un segment par clic (illustré dans les cinq premières images ci-dessous) et de deux segments par clic (illustré dans la dernière image ci-dessous). Dans le premier mode, le segment de piste représenté en contour est appelé segment d’anticipation.
- Appuyez sur la touche Backspace pour supprimer le dernier sommet.



Appuyez sur Shift+Spacebar pour parcourir les cinq modes d’angle disponibles, sur Spacebar pour inverser la direction de l’angle et sur le raccourci 1 pour basculer entre le placement d’un ou de deux segments.
La méthode d’édition graphique permet de sélectionner directement un objet piste placé dans l’espace de conception et de modifier graphiquement sa taille, sa forme ou sa position.
Lorsqu’un objet piste est sélectionné, les poignées d’édition suivantes sont disponibles :
- Cliquez et faites glisser A pour repositionner les extrémités de la piste.
- Cliquez et faites glisser B pour modifier la forme de la piste.
L’éditeur de PCB intègre des algorithmes sophistiqués permettant de déplacer les segments de piste sur la carte tout en préservant l’organisation du routage. Ce glissement des segments de piste peut être effectué de manière interactive soit en cliquant d’abord pour sélectionner le segment, puis en maintenant le bouton de la souris enfoncé lorsque le curseur spécial apparaît pour faire glisser le segment, soit en cliquant directement sur un segment de piste et en maintenant le bouton enfoncé pour le faire glisser. Le comportement de glissement peut être configuré à l’aide des options Dragging de la page Éditeur de PCB - Routage interactif de la boîte de dialogue Preferences. Ces options permettent d’attribuer l’action Déplacer à une piste, ce qui est utile si vous souhaitez déplacer librement un segment de piste individuel.

Contrôlez le comportement de glissement des pistes à l’aide des options de déplacement définies dans les préférences.
Si l’action Move est attribuée au moyen de ces options, le segment de piste peut être pivoté ou retourné par symétrie pendant le déplacement.
Routage interactif et règles de conception applicables
Pendant le routage interactif, le logiciel veille par défaut à ce que les segments de piste soient placés conformément aux règles de conception électriques et de routage applicables. Cela signifie que le logiciel ne permet pas de placer un nouveau segment de piste qui enfreindrait les règles vis-à-vis d’un segment existant appartenant à un autre net ; il tronque plutôt le segment pour respecter les règles de conception. Ce comportement de routage interactif est appelé mode Routing Conflict Resolution. Le mode par défaut est Stop at First Obstacle (le mode actuel est affiché dans la barre d’état). Appuyez sur Shift+R pour parcourir les modes disponibles.
Le terme applicable design rules désigne toutes les règles qui s’appliquent à l’objet en cours de placement. Le moteur de règles de conception repose sur un système dans lequel vous définissez précisément les objets auxquels chaque règle doit s’appliquer. Pendant le placement, le moteur de règles de conception est interrogé pour déterminer la règle de priorité la plus élevée qui s’applique à la situation actuelle. Les règles applicables pendant le routage interactif comprennent :
- Espacement électrique
- Largeur de routage
- Style des vias de routage
L’animation ci-dessous illustre le routage en action. Le net GND est routé conformément à une règle de conception de largeur de routage définie et applicable. Notez que lorsque le curseur passe au-dessus du via associé au net +12V, le tracé est automatiquement tronqué pour garantir le respect de la règle de conception Contrainte d’espacement électrique applicable.

Les règles de conception de largeur de routage et d’espacement applicables sont automatiquement respectées pendant le routage interactif.
Détermination de la largeur de routage
À moins que le moteur de règles ne soit désactivé, le logiciel veille toujours en priorité à ce que la largeur de routage reste dans la plage autorisée par la règle de conception de largeur de routage applicable. Une approche courante consiste à autoriser une plage de largeurs pour un net afin de faciliter le passage des pistes tout en respectant les exigences de capacité de transport de courant de ce net. À cette fin, la règle de conception de largeur de routage comporte les paramètres Min, Preferred et Max dans l’éditeur de règles et de contraintes du PCB. Ces paramètres peuvent être configurés pour autoriser une plage de largeurs ou définis à une même valeur pour imposer une largeur précise. La largeur peut également être définie en fonction de l’impédance et une plage différente peut être spécifiée pour chaque couche de signal.

La règle de conception de largeur de routage par défaut s’applique à tous les nets d’un nouveau PCB.
En tant que concepteur, vous disposez de plusieurs options pour sélectionner la largeur de routage la plus appropriée lorsque vous commencez le routage. Elles se configurent sur la page Éditeur PCB — Routage interactif de la boîte de dialogue Preferences, comme illustré ci-dessous.

Les options Interactive Routing Width Sources déterminent la largeur utilisée lorsque vous commencez un routage.
Notez que Track Width Mode est défini sur Rule Preferred dans l’image. Cela signifie que, lorsque le routage commence sur un objet existant du net, tel qu’une pastille, cette largeur est utilisée. Toutefois, si le routage commence sur une piste existante, l’option Pickup Track Width From Existing Routes prévaut sur Track Width Mode et définit la nouvelle largeur de manière à correspondre à la largeur existante.
En tant que concepteur, vous pouvez également utiliser le raccourci Shift+W pendant le routage pour accéder à une boîte de dialogue permettant de sélectionner une autre largeur, ou appuyer sur Tab pour ouvrir Properties panel et saisir une nouvelle valeur de Width . La valeur sélectionnée ou saisie doit être comprise entre les paramètres Min et Max définis dans la règle applicable. Dans le cas contraire, elle est automatiquement ramenée à la limite la plus proche.
Raccourcis de routage interactif
Plusieurs raccourcis sont disponibles pendant le routage. Par exemple, vous pouvez appuyer sur Shift+R pour parcourir les modes de résolution des conflits disponibles, ou sur Backspace pour supprimer le dernier sommet (angle) placé. Pour afficher la liste des raccourcis pendant le routage, appuyez sur Shift+F1. Un menu des raccourcis interactifs disponibles s’affiche ; sélectionnez le raccourci souhaité ou appuyez sur Esc pour fermer le menu et utiliser la combinaison de touches correspondante.

Pendant le routage interactif, appuyez sur Shift+F1 pour afficher un menu des raccourcis interactifs disponibles
Déplacement d’une piste
Le sous-menu Edit » Move et le menu des commandes de déplacement dans Active Bar comprennent plusieurs commandes permettant de modifier la position ou la forme d’une piste.
Rerouter
Cette commande permet de rerouter manuellement une piste existante sur la carte. Après le lancement de la commande, le curseur prend la forme d’un réticule et vous êtes invité à choisir une piste. Placez le curseur sur la piste souhaitée, puis cliquez ou appuyez sur Enter. Le fonctionnement de cette commande dépend de l’activation ou non de l’option Preserve Angle When Dragging sur la page Éditeur PCB - Routage interactif de la boîte de dialogue Preferences :
- Preserve Angle Dragging enabled - la piste est scindée et un nouveau segment est ajouté pour conserver les connexions orthogonales/diagonales. Déplacez le curseur pour faire glisser ce segment selon vos besoins, puis cliquez pour le placer. À ce stade, faites un clic droit ou appuyez sur Esc ; sinon, ce nouveau segment sera à son tour scindé par l’ajout d’un autre segment. Utilisez le raccourci clavier Shift+R pour parcourir les options qui déterminent la gestion des obstacles pendant le glissement (Ignore Obstacles, Avoid Obstacles ou Avoid Obstacles (Snap Grid)). Si l’un des modes d’évitement des obstacles est activé, les règles sont respectées pendant le glissement, ce qui vous empêche de déplacer un segment dans une position qui les enfreint.
- Preserve Angle Dragging disabled - les deux extrémités du segment de piste sont ancrées et vous pouvez alors tracer de nouveaux segments de piste entre elles. Cliquez ou appuyez sur Enter pour placer un nouveau segment de piste. Continuez à placer de nouveaux segments pour rerouter la piste ou faites un clic droit ou appuyez sur Esc pour arrêter.
Continuez à rerouter d’autres pistes ou faites un clic droit ou appuyez sur Esc pour quitter.
Scinder une piste
Cette commande permet de créer un sommet (ou une coupure) dans un segment de piste. Après le lancement de la commande, le curseur prend la forme d’un réticule et vous êtes invité à sélectionner une piste. Placez le curseur sur le segment de piste souhaité, à l’endroit précis où vous voulez insérer une coupure, puis cliquez ou appuyez sur Enter. Un sommet est inséré, divisant ainsi le segment d’origine en deux.
Déplacez le sommet à la position souhaitée, puis cliquez ou appuyez sur Enter pour le placer. Le comportement des segments de piste rattachés dépend du réglage de l’option Preserve Angle When Dragging sur la page Éditeur PCB - Routage interactif de la boîte de dialogue Preferences :
- Preserve Angle When Dragging activée - les angles avec les segments de piste adjacents sont conservés, ce qui préserve le style de routage.
- Preserve Angle When Dragging désactivée - les deux segments de piste se déforment comme un élastique pour suivre le déplacement, sans conserver le style de routage existant.
Continuez à scinder d’autres segments de piste ou faites un clic droit ou appuyez sur Esc pour quitter.
Faire glisser l’extrémité d’une piste
Cette commande permet de repositionner manuellement ou de faire glisser l’extrémité d’un segment de piste routé. Après le lancement de la commande, le curseur prend la forme d’un réticule et vous êtes invité à sélectionner un objet. Placez le curseur sur une piste, puis cliquez ou appuyez sur Enter. Le curseur se positionne sur l’extrémité du segment de piste la plus proche, et cette extrémité est rattachée au curseur. Déplacez l’extrémité de la piste à la position souhaitée, puis cliquez ou appuyez sur Enter pour la placer.
- Si l’extrémité du segment de piste choisi est un sommet auquel aucun autre segment de piste n’est connecté, déplacez ce sommet à la position souhaitée.
- Si l’extrémité du segment de piste choisi est un sommet auquel deux segments de piste sont connectés, les segments attachés se déformeront de manière élastique lors du déplacement du sommet.
- Si l’extrémité du segment de piste est connectée à une pastille de composant, son déplacement la dissociera de la pastille. Une fois l’extrémité repositionnée, une ligne de connexion logique s’affichera entre l’extrémité de la piste et la pastille, à condition que l’option Smart Track Ends soit activée sur la page Éditeur PCB – Général de la boîte de dialogue Preferences.
- Si l’extrémité du segment de piste est connectée à une pastille libre, cette dernière sera attachée au curseur pour être repositionnée. Toutes les pistes connectées à la pastille se déformeront de manière élastique en conséquence.
- Si l’extrémité du segment de piste est connectée à un via, ce dernier sera attaché au curseur pour être repositionné. Toutes les pistes connectées au via se déformeront de manière élastique en conséquence.
Continuez à faire glisser d’autres extrémités de piste ou faites un clic droit ou appuyez sur Esc pour quitter.
Déplacer / Redimensionner les pistes
Cette commande permet de déplacer les extrémités de plusieurs segments de piste sélectionnés, et donc de redimensionner ces segments. Après le lancement de la commande, le curseur prend la forme d’un réticule et vous êtes invité à choisir une extrémité de piste. Pour déplacer/redimensionner les pistes :
- Placez le curseur sur l’extrémité de l’un des segments de la sélection, puis cliquez ou appuyez sur Enter.
- Déplacez le curseur ; tous les segments de piste de la sélection se redimensionnent dynamiquement tout en conservant leurs distances et leurs angles relatifs d’origine. L’autre extrémité de chaque segment se déforme de manière élastique pour conserver sa connexion/position existante.
- Une fois les segments à l’emplacement souhaité, cliquez ou appuyez sur Enter pour valider le placement et quitter le mode de déplacement.
- Pour annuler l’opération, faites un clic droit ou appuyez sur Esc.
Lors du déplacement des segments, les commandes supplémentaires suivantes sont disponibles :
- Appuyez sur la touche Tab pour déplacer successivement le curseur sur l’extrémité de chaque segment de piste de la sélection.
- Maintenez la touche Alt enfoncée pendant le déplacement pour limiter celui-ci à une direction particulière, selon la direction initiale du déplacement. Les directions possibles sont horizontale, verticale et à 45 degrés.
- Appuyez deux fois sur Spacebar pour aligner rapidement toutes les extrémités des segments de piste horizontalement ou verticalement. Appuyez à nouveau deux fois rapidement sur Spacebar pour rétablir les dimensions précédentes.
Découper les pistes
L’outil de découpe de pistes permet de couper facilement un ou plusieurs segments de piste en deux, sur la couche de signal active ou sur toutes les couches de signal visibles. Pour accéder à cet outil, choisissez la commande Edit » Slice Tracks dans les menus principaux.
Après le lancement de la commande, le curseur prend la forme d’un réticule et vous êtes invité à choisir un point de départ pour la découpe. Un filtre est également appliqué pour n’afficher que les objets piste dans l’espace de travail. Il s’agit soit de toutes les pistes de toutes les couches de signal visibles, soit uniquement des pistes de la couche de signal active, selon la configuration actuelle de l’outil de découpe de pistes. Pour découper une ou plusieurs pistes :
- Placez le curseur, puis cliquez ou appuyez sur Enter pour fixer le point de départ de la découpe.
- Déplacez le curseur sur le point de la piste, ou des pistes, où vous souhaitez effectuer la découpe : la trajectoire de l’outil est représentée par une ligne, avec une indication visuelle des découpes prévues.
- Cliquez ou appuyez sur Enter pour fixer le point d’arrivée de la trajectoire de l’outil de découpe.
- Continuez à découper d’autres segments de piste, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de découpe.
Les actions supplémentaires disponibles après avoir choisi le point de départ de la découpe, et pendant le déplacement de la « ligne de découpe », sont les suivantes :
- Appuyez sur la touche B pour basculer entre la découpe des pistes de la couche de signal active uniquement et celle des pistes de toutes les couches de signal visibles.
- Appuyez sur Spacebar pour basculer entre un angle de découpe par incréments de 45 degrés et un angle libre.
- Appuyez sur la touche N pour faire défiler les positions de la lame de découpe : gauche, droite et milieu.
- Appuyez sur la touche / pour sélectionner toutes les pistes découpées.
- Appuyez sur la touche « , » pour sélectionner les pistes découpées à gauche de l’outil de découpe.
- Appuyez sur la touche « . » pour sélectionner les pistes découpées à droite de l’outil de découpe.
- Appuyez sur la touche M pour ne sélectionner aucune piste découpée.
-
Appuyez sur la touche Tab pour accéder à la boîte de dialogue Slicer Properties, dans laquelle les propriétés de l’outil de découpe de pistes peuvent être modifiées à la volée.

La boîte de dialogue Slicer Properties
Conversion des pistes en tracé chanfreiné
Le chanfreinage des angles de routage à 90 degrés est une technique utilisée pour réduire les réflexions provoquées par ces angles dans un routage aux fréquences micro-ondes. Des arcs peuvent être utilisés, mais leur rayon doit être au moins égal à trois fois la largeur de la piste. Le chanfreinage est une autre solution, qui consiste à couper la pointe extérieure de l’angle. Comme les objets piste d’Altium Designer ont des extrémités arrondies, ils ne peuvent pas être utilisés pour créer un angle chanfreiné. Pour créer cet angle, les segments de piste sélectionnés sont remplacés par des objets région.
Sélectionnez tous les segments de piste à chanfreiner, puis choisissez la commande Tools » Convert » Convert Selected Tracks to Chamfered Path dans les menus principaux. La boîte de dialogue Convert Tracks to Chamfered Path s’ouvre. Utilisez cette boîte de dialogue pour configurer le chanfrein, puis cliquez sur OK. Chaque paire de segments de piste sélectionnée (présentant un angle à 90 degrés à corriger) sera remplacée par un angle chanfreiné, et les segments de piste d’origine de chaque paire seront convertis en un seul objet région pleine (en cuivre).

Les pistes sélectionnées seront chanfreinées selon la valeur spécifiée à chaque angle droit.
Utilisez les options suivantes de la boîte de dialogue pour configurer le chanfrein :
- Chamfer - portion de l’angle extérieur à découper, ou à chanfreiner, exprimée en pourcentage de la distance diagonale existante de l’angle.
- Inside Chamfer - quantité de matière à ajouter à l’angle intérieur, exprimée en pourcentage de la distance diagonale existante de l’angle.
How big should the Chamfer be?
Le pourcentage de chanfrein correspond à la fraction supprimée de la diagonale reliant les angles intérieur et extérieur du coude non chanfreiné.
Le chanfrein optimal pour une large gamme de géométries de lignes microruban a été déterminé expérimentalement par Douville et James. Ils ont constaté qu’une bonne approximation du pourcentage de chanfrein optimal est donnée par
Sous réserve de
et avec la constante diélectrique du substrat
.
Cette formule est entièrement indépendante de
. La plage réelle des paramètres pour laquelle Douville et James fournissent des résultats expérimentaux est
et
. Ils indiquent un rapport d’ondes stationnaires en tension (VSWR) inférieur à 1,1 (c’est-à-dire un niveau de réflexion inférieur à −26 dB) pour tout pourcentage de chanfrein s’écartant de moins de 4 % (de la valeur initiale de de celui donné par la formule. Pour la valeur minimale de
de 0,25, le pourcentage de chanfrein est de 98,4 %, de sorte que le ruban est presque entièrement coupé.
Propriétés de la piste

Le mode Track du panneau Properties.
Informations sur le net
Cette zone fournit des informations sur le net auquel appartient la piste, ainsi que sur la paire différentielle et/ou le xSignal dont ce net fait éventuellement partie. Les informations de classe sont affichées le cas échéant. Les valeurs Delay, Length, Max Current et Resistance sont également fournies.
Consultez la page Techniques de placement et de modification de PCB pour en savoir plus sur les informations relatives aux nets.
Position
-
(X/Y)
- X (premier champ) – coordonnée X (horizontale) actuelle du point de référence de la piste par rapport à l’origine actuelle de l’espace de conception. Modifiez ce champ pour changer la position X de la piste. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités lorsque vous saisissez une valeur dans des unités autres que celles définies par défaut.
- Y (deuxième champ) – coordonnée Y (verticale) actuelle du point de référence de la piste par rapport à l’origine actuelle. Modifiez ce champ pour changer la position Y de la piste. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités lorsque vous saisissez une valeur dans des unités autres que celles définies par défaut.
Propriétés
- Component – ce champ est affiché dans l’éditeur de PCB uniquement lorsque la piste sélectionnée fait partie d’un composant PCB. Il indique le repère du composant PCB parent. Cliquez sur le lien Component pour ouvrir le mode Composant du panneau Propriétés pour le composant parent.
- Net – permet de choisir un net pour la piste. Tous les nets de la carte active figurent dans la liste déroulante. Notez que si le placement d’un objet commence à la même position qu’un objet existant déjà connecté à un net, la propriété Net du nouvel objet est automatiquement définie sur ce net. Sélectionnez No Net pour indiquer que la piste n’est connectée à aucun net. La propriété Net d’une primitive est utilisée par le vérificateur des règles de conception pour déterminer si le placement d’un objet PCB respecte les règles. Vous pouvez également cliquer sur l’icône Assign Net pour choisir un objet dans l’espace de conception : le net de cet objet sera affecté aux pistes sélectionnées.
- Layer – utilisez la liste déroulante pour sélectionner la couche sur laquelle se trouve la piste.
- Width – affiche la largeur actuelle de la piste. Modifiez ce champ pour changer la largeur de la piste dans la plage de 0,001 mil à 10 000 mil.
- Start (X/Y) – affiche les coordonnées X/Y actuelles du point de départ de la piste par rapport à l’origine actuelle.
- End (X/Y) – affiche les coordonnées X/Y actuelles du point d’arrivée de la piste par rapport à l’origine actuelle.
-
Length – affiche la longueur actuelle de la piste. Modifiez ce champ pour changer la longueur de la piste dans la plage de 0,001 mil à 10 000 mil.
Expansion du masque de pâte
- Rule/Manual – sélectionnez la configuration souhaitée pour l’expansion du masque de pâte. Sélectionnez Rule pour que l’expansion du masque de pâte de la piste suive la valeur définie dans la règle de conception Expansion du masque de pâte applicable. Sélectionnez Manual pour remplacer la règle de conception applicable et spécifier la valeur d’expansion du masque de pâte pour la piste. Vous pouvez ensuite activer le champ et saisir la dimension souhaitée.
Expansion du masque de soudure
- Rule/Manual – sélectionnez la configuration souhaitée pour l’expansion du masque de soudure. Sélectionnez Rule pour que l’expansion du masque de soudure de la piste suive la valeur définie dans la règle de conception Expansion du masque de soudure applicable. Sélectionnez Manual pour remplacer la règle de conception applicable et spécifier la valeur d’expansion du masque de soudure pour la piste. Vous pouvez ensuite activer le champ et saisir la dimension souhaitée.
Utilisation des arcs
Un arc est un objet de conception primitif. Il s’agit essentiellement d’un segment de piste circulaire qui peut être placé sur n’importe quelle couche. Les arcs peuvent avoir diverses utilisations dans la conception de PCB. Par exemple, ils peuvent servir à définir les contours des composants sur les couches de sérigraphie, ou à indiquer le contour de la carte, les bords des découpes, etc., sur une couche mécanique. Ils peuvent également servir à créer des tracés courbes lors du routage interactif. Les arcs peuvent être ouverts ou fermés pour former un cercle (souvent appelé arc de cercle complet).

Deux arcs placés : à gauche, un arc de cercle complet ; à droite, un arc sélectionné pour modification.
Les arcs peuvent être placés dans l’éditeur PCB et dans l’éditeur de bibliothèques PCB. Quatre modes de placement d’arc sont disponibles (Centre, Bord, Angle quelconque et Cercle complet). La manière dont un arc est placé dépend de la méthode de placement que vous avez choisi d’utiliser :
-
Place arc by center – cette méthode permet de placer un objet arc en utilisant son centre comme point de départ.
Après le lancement de la commande, le curseur prend la forme d’un réticule et vous passez en mode de placement d’arc. Le placement s’effectue en suivant cette séquence d’actions :
- Cliquez ou appuyez sur Enter pour fixer le centre de l’arc.
- Déplacez le curseur pour ajuster le rayon de l’arc, puis cliquez ou appuyez sur Enter pour le définir.
- Déplacez le curseur pour ajuster le point de départ de l’arc, puis cliquez ou appuyez sur Enter pour le fixer.
- Déplacez le curseur pour modifier la position du point d’arrivée de l’arc, puis cliquez ou appuyez sur Enter pour le fixer et terminer le placement de l’arc.
- Continuez à placer d’autres arcs, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
-
Place arc by edge – cette méthode permet de placer un objet arc en utilisant son bord comme point de départ. L’angle de l’arc est fixé à 90°.
Après le lancement de la commande, le curseur prend la forme d’un réticule et vous passez en mode de placement d’arc. Le placement s’effectue en suivant cette séquence d’actions :
- Cliquez ou appuyez sur Enter pour fixer le point de départ de l’arc.
- Déplacez le curseur pour modifier la position du point d’arrivée de l’arc, puis cliquez ou appuyez sur Enter pour le fixer et terminer le placement de l’arc.
- Continuez à placer d’autres arcs, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
-
Place arc by edge (any angle) – cette méthode permet de placer un objet arc en utilisant son bord comme point de départ. L’angle de l’arc peut prendre n’importe quelle valeur.
Après le lancement de la commande, le curseur prend la forme d’un réticule et vous passez en mode de placement d’arc. Le placement s’effectue en suivant cette séquence d’actions :
- Cliquez ou appuyez sur Enter pour fixer le point de départ de l’arc.
- Déplacez le curseur pour ajuster le rayon de l’arc, puis cliquez ou appuyez sur Enter pour fixer le centre.
- Déplacez le curseur pour modifier la position du point d’arrivée de l’arc, puis cliquez ou appuyez sur Enter pour le fixer et terminer le placement de l’arc.
- Continuez à placer d’autres arcs, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
-
Place full circle arc – cette méthode permet de placer un arc de 360° (cercle complet).
Après le lancement de la commande, le curseur prend la forme d’un réticule et vous passez en mode de placement d’arc. Le placement s’effectue en suivant cette séquence d’actions :
- Cliquez ou appuyez sur Enter pour fixer le centre de l’arc.
- Déplacez le curseur pour ajuster le rayon de l’arc, puis cliquez ou appuyez sur Enter pour le définir et terminer le placement de l’arc.
- Continuez à placer d’autres arcs, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
Les actions supplémentaires suivantes peuvent être effectuées pendant le placement :
- Pour toutes les méthodes (à l’exception des arcs de cercle complet), appuyez sur Spacebar avant de définir le point d’arrivée de l’arc pour tracer l’arc dans le sens opposé.
- Appuyez sur la touche L pour basculer l’arc sur l’autre face de la carte. Notez que cela n’est possible qu’avant de fixer le point de départ ou le centre de l’arc.
- Appuyez sur les touches + et - (du pavé numérique) ou utilisez les raccourcis Shift+Ctrl+Wheelroll pour parcourir toutes les couches visibles de la conception, dans un sens ou dans l’autre, afin de changer rapidement de couche de placement.
La méthode de modification graphique permet de sélectionner un objet arc placé directement dans l’espace de conception et de modifier graphiquement sa taille, sa forme ou sa position.
Lorsqu’un objet arc est sélectionné, les poignées de modification suivantes sont disponibles :

Un arc sélectionné
- Cliquez sur A et faites glisser pour ajuster le rayon.
- Cliquez sur B et faites glisser pour ajuster les extrémités (angles de départ et d’arrivée).
-
Cliquez n’importe où sur l’arc, à l’écart des poignées de modification, puis faites-le glisser pour le repositionner. Vous pouvez également cliquer sur le centre de l’arc et le faire glisser. Pendant le déplacement, vous pouvez faire pivoter l’arc ou lui appliquer une symétrie :
- Appuyez sur Spacebar pour faire pivoter l’arc dans le sens antihoraire ou sur Shift+Spacebar pour le faire pivoter dans le sens horaire. La rotation s’effectue selon la valeur de Rotation Step, définie sur la page Éditeur PCB – Général de la boîte de dialogue Preferences.
- Appuyez sur les touches X ou Y pour appliquer une symétrie à l’arc selon l’axe X ou Y.
Propriétés de l’arc
Informations sur le net
Cette zone fournit des informations sur le net auquel appartient l’arc, ainsi que sur la paire différentielle et/ou le xSignal dont ce net fait partie, le cas échéant. Les informations sur les classes sont affichées lorsqu’elles sont pertinentes. Les valeurs Delay, Length, Max Current et Resistance sont également indiquées.
Consultez la page Techniques de placement et de modification des PCB pour en savoir plus sur les informations relatives aux nets.
Position
-
(X/Y)
- X (premier champ) - ce champ indique la position X actuelle du centre de l’arc par rapport à l’origine actuelle. Modifiez la valeur de ce champ pour changer la position de l’arc par rapport à l’origine actuelle. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités lorsque vous saisissez une valeur dont les unités diffèrent de celles utilisées par défaut. Les unités par défaut (métriques ou impériales) sont déterminées par le paramètre Units dans la zone Other du panneau Properties en mode Board (accessible lorsqu’aucun objet n’est sélectionné dans l’espace de conception) et sont utilisées si aucune unité n’est précisée.
- Y (deuxième champ) - ce champ indique la position Y actuelle du centre de l’arc par rapport à l’origine actuelle. Modifiez la valeur de ce champ pour changer la position de l’arc par rapport à l’origine actuelle. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités lorsque vous saisissez une valeur dont les unités diffèrent de celles utilisées par défaut. Les unités par défaut (métriques ou impériales) sont déterminées par le paramètre Units dans la zone Other du panneau Properties en mode Board (accessible lorsqu’aucun objet n’est sélectionné dans l’espace de conception) et sont utilisées si aucune unité n’est précisée.
Propriétés
- Component – ce champ s’affiche dans l’éditeur PCB uniquement lorsque l’arc sélectionné fait partie d’un composant PCB et indique le repère du composant PCB parent. Cliquez sur le lien Component pour ouvrir le mode Composant du panneau Propriétés pour le composant parent.
- Net – permet de choisir un net pour l’arc. Tous les nets de la conception de carte active sont répertoriés dans la liste déroulante. Notez que si le placement d’un objet commence au même emplacement qu’un objet existant déjà connecté à un net, la propriété Net du nouvel objet est automatiquement définie sur ce net. Sélectionnez No Net pour indiquer que l’arc n’est connecté à aucun net. La propriété Net d’une primitive est utilisée par le vérificateur des règles de conception pour déterminer si un objet PCB est placé conformément aux règles. Vous pouvez également cliquer sur l’icône Assign Net pour choisir un objet dans l’espace de conception : le net de cet objet sera affecté aux arcs sélectionnés.
- Layer - ce champ indique la couche à laquelle l’arc est actuellement affecté. Les arcs peuvent être affectés à n’importe quelle couche disponible. Pour changer la couche affectée, cliquez sur le champ et sélectionnez une couche dans la liste déroulante.
- Width - ce champ indique la largeur du trait de l’arc. Saisissez une autre valeur de largeur si nécessaire.
- Radius - ce champ indique le rayon de l’arc, mesuré du point central au milieu du trait de l’arc. Saisissez une autre valeur de rayon si nécessaire.
- Start Angle - ce champ indique l’angle de départ de l’arc, mesuré à partir de l’axe X dans le premier quadrant (géométrie plane). Saisissez une autre valeur d’angle de départ si nécessaire.
- End Angle - ce champ indique l’angle de fin de l’arc. Saisissez une autre valeur d’angle de fin si nécessaire.
- Propagation Delay - ce champ indique le temps nécessaire à un signal pour se propager le long de ce tracé.
Expansion du masque de pâte
- Rule - sélectionnez cette option pour que l’expansion du masque de pâte de l’arc suive la valeur définie dans la règle de conception Expansion du masque de pâte applicable. Le champ de la valeur d’expansion associée sera désactivé si cette option est sélectionnée.
- Manual - sélectionnez cette option pour remplacer la règle de conception applicable et préciser la valeur d’expansion du masque de pâte pour l’arc dans le champ ci-dessous.
Expansion du masque de soudure
- Rule - cochez cette case pour que l’expansion du masque de soudure de l’arc suive la valeur définie dans la règle de conception Expansion du masque de soudure applicable. Le champ de la valeur d’expansion associée sera désactivé si cette option est sélectionnée.
- Manual - cochez cette case pour remplacer la règle de conception applicable et préciser la valeur d’expansion du masque de soudure pour l’arc dans le champ ci-dessous.
Création d’un contour autour des objets sélectionnés à l’aide de pistes et d’arcs
La commande Tools » Outline Selected Objects des menus principaux permet de placer un contour composé de pistes et d’arcs autour des primitives libres sélectionnées dans la conception. Cette fonctionnalité peut être particulièrement utile pour isoler électriquement des nets critiques en reliant le contour à la masse. Après le lancement de la commande, les objets sont entourés de pistes et/ou d’arcs. Les pistes et arcs du contour sont placés avec une largeur de 8 mil et leur propriété Net est définie sur No Net.
Les règles de conception relatives à l’espacement, à la largeur et aux courts-circuits sont respectées ; les violations d’espacement sont donc signalées par le vérificateur des règles de conception.
Utilisation des rectangles
Un rectangle peut être placé sur n’importe quelle couche. Des rectangles de différentes tailles peuvent être combinés pour couvrir des zones de forme irrégulière et peuvent également être combinés avec des segments de piste ou d’arc.
Les rectangles peuvent également être placés sur des couches non électriques. Par exemple, placez un rectangle sur la couche Keep-Out pour définir une zone interdite au routage automatique. Placez un rectangle sur une couche de plan d’alimentation, de masque de soudure ou de masque de pâte pour créer une ouverture dans cette couche.

Un rectangle placé
Les rectangles peuvent être placés dans l’éditeur PCB et dans l’éditeur de bibliothèques PCB de différentes manières :
- Éditeur PCB - les méthodes d’accès suivantes sont disponibles :
- Choisissez Place » Rectangle dans les menus principaux.
- Cliquez sur le bouton Rectangle dans le menu déroulant de Active Bar situé en haut de l’espace de conception. (Cliquez sur un bouton Active Bar et maintenez-le enfoncé pour accéder aux autres commandes associées. Une fois utilisée, une commande devient le premier élément de cette section de Active Bar.)
- Faites un clic droit dans l’espace de conception, puis cliquez sur Place » Rectangle dans le menu contextuel.
-
Éditeur de bibliothèques PCB - les méthodes d’accès suivantes sont disponibles :
- Choisissez Place » Rectangle dans les menus principaux.
- Cliquez sur le bouton Rectangle dans le menu déroulant de Active Bar situé en haut de l’espace de conception. (Cliquez sur un bouton Active Bar et maintenez-le enfoncé pour accéder aux autres commandes associées. Une fois utilisée, une commande devient le premier élément de cette section de Active Bar.)
- Faites un clic droit dans l’espace de conception, puis sélectionnez Place » Rectangle dans le menu contextuel.
Après le lancement de la commande, le curseur prend la forme d’une croix et vous passez en mode de placement de rectangles. Le placement s’effectue selon la séquence d’actions suivante :
- Cliquez ou appuyez sur Enter pour fixer le premier coin du rectangle.
- Déplacez le curseur pour ajuster la taille du rectangle, puis cliquez ou appuyez sur Enter pour fixer le coin diagonalement opposé et terminer le placement du rectangle.
- Continuez à placer d’autres rectangles, ou faites un clic droit ou appuyez sur Esc pour quitter le mode de placement.
Les actions supplémentaires suivantes sont disponibles pendant le placement :
- Appuyez sur la touche Tab pour suspendre le placement et accéder au mode Rectangle du panneau Properties , dans lequel vous pouvez modifier ses propriétés à la volée. Cliquez sur le bouton de pause superposé à l’espace de conception pour reprendre le placement.
- Appuyez sur la barre d’espace pour parcourir les différents modes de coins. Sélectionnez Rectangle pour des coins droits, Fillet pour des coins arrondis ou Chamfer pour des coins biseautés.
- Appuyez sur les touches + et - (du pavé numérique) pour parcourir dans les deux sens toutes les couches visibles de la conception afin de changer rapidement de couche de placement.
- Maintenez la touche Alt enfoncée pour contraindre le déplacement à l’axe horizontal ou vertical, selon la direction initiale du déplacement.
La méthode de modification graphique vous permet de sélectionner un objet rectangle placé directement dans l’espace de conception et de modifier graphiquement sa taille, sa forme ou sa position.
Lorsqu’un objet rectangle est sélectionné, les poignées de modification suivantes sont disponibles.
Un rectangle sélectionné
- Cliquez sur les coins (A) et faites-les glisser pour redimensionner le rectangle simultanément dans les directions verticale et horizontale.
- Cliquez sur les milieux des côtés (B) et faites-les glisser pour redimensionner le rectangle séparément dans les directions verticale et horizontale.
-
Cliquez n’importe où sur le rectangle, à l’écart des poignées de modification, et faites-le glisser pour le repositionner. Pendant le déplacement, vous pouvez faire pivoter le rectangle ou lui appliquer une symétrie :
- Appuyez sur Spacebar pour faire pivoter le rectangle dans le sens antihoraire ou sur Shift+Spacebar pour le faire pivoter dans le sens horaire. La rotation s’effectue selon la valeur de Rotation Step définie sur la page Éditeur PCB – Général de la boîte de dialogue Preferences.
- Appuyez sur les touches X ou Y pour appliquer au rectangle une symétrie selon l’axe X ou Y.
Propriétés du rectangle

Le mode Rectangle du panneau Properties.
Position
-
(X/Y)
- X (premier champ) - la coordonnée X (horizontale) actuelle du point de référence du rectangle, par rapport à l’origine actuelle de l’espace de conception. Modifiez ce champ pour changer la position X du rectangle. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités lorsque vous saisissez une valeur dont les unités diffèrent de celles définies par défaut.
- Y (deuxième champ) - la coordonnée Y (verticale) actuelle du point de référence du rectangle, par rapport à l’origine actuelle. Modifiez ce champ pour changer la position Y du remplissage. La valeur peut être saisie en unités métriques ou impériales ; précisez les unités lorsque vous saisissez une valeur dont les unités diffèrent de celles définies par défaut.
- Rotation - l’angle de rotation du rectangle (en degrés), mesuré dans le sens antihoraire à partir de zéro (l’horizontale 3 o'clock). Modifiez ce champ pour changer la rotation du rectangle. La résolution angulaire minimale est de 0,001°.
Propriétés
-
Corner Mode - utilisez le menu déroulant pour sélectionner le mode de coins souhaité pour le rectangle parmi les options suivantes :
- Rectangle - indique que le rectangle placé aura des coins droits.
- Fillet - indique que le rectangle placé aura des coins arrondis.
- Chamfer - indique que le rectangle placé aura des coins biseautés.
- Track Width - affiche la largeur actuelle de la piste. Modifiez ce champ pour changer la largeur de la piste dans la plage de 0,001 mil à 10 000 mil.
- Fillet/Chamfer Size - cette option est disponible uniquement lorsque Fillet ou Chamfer est sélectionné dans le menu déroulant Corner Mode, ou si le mode arrondi ou chanfrein a été choisi pendant le placement.
- Layer - la couche à laquelle le rectangle est actuellement affecté. Les rectangles peuvent être affectés à n’importe quelle couche disponible. Utilisez le menu déroulant pour sélectionner une autre couche.
- Width - affiche la largeur (selon l’axe X) du rectangle sélectionné.
- Height - affiche la hauteur (selon l’axe Y) du rectangle sélectionné.
-
- cliquez sur cette icône pour conserver le rapport X/Y actuel du rectangle.

