Definizione delle linee di piegatura - Modalità avanzata

A colpo d'occhio

Questo articolo spiega come funzionano le linee di piegatura nella modalità Rigid-Flex avanzata di Altium Designer, concentrandosi sulle differenze rispetto alla modalità rigid-flex standard e su come queste influiscono sulla definizione delle regioni flessibili e sulla piegatura della scheda. Scoprirai come identificare la modalità rigid-flex utilizzata da un PCB, posizionare e regolare le linee di piegatura nella modalità di pianificazione della scheda, modificarne le proprietà e controllare l'aspetto delle pieghe quando la scheda viene piegata in 3D. Se stai lavorando a un progetto rigid-flex più complesso e cerchi indicazioni pratiche per definire posizione, angolo, raggio e ordine delle pieghe, questo articolo ti aiuterà a procedere con sicurezza. Continua a leggere per rendere il tuo flusso di lavoro rigid-flex più preciso e prevedibile.

- Comprendi la differenza tra la modalità rigid-flex standard e quella avanzata, in particolare perché la modalità avanzata non utilizza oggetti linea di divisione.
- Apprendi il flusso di lavoro di base per inserire, spostare, rimuovere e posizionare con precisione le linee di piegatura nella modalità di pianificazione della scheda.
- Scopri quali proprietà delle linee di piegatura controllano il comportamento delle pieghe in 3D, tra cui angolo, raggio, assegnazione alla regione dello stack e ordine di piegatura.
Approfondisci con l'IA:

Nel software di progettazione PCB di Altium sono disponibili due modalità di progettazione rigido-flessibile. La modalità originale, o standard, denominata Rigid-Flex, supporta progetti rigido-flessibili semplici. Se il progetto presenta requisiti rigido-flessibili più complessi, come regioni flessibili sovrapposte, è necessario utilizzare la modalità Advanced Rigid-Flex (nota anche come rigid-flex 2.0). La modalità viene scelta nel menu Tools del Layer Stack Manager.

La differenza fondamentale tra le modalità è che, nella modalità originale, la sagoma della scheda viene suddivisa in regioni separate posizionando una linea di divisione, che rimane come oggetto a definire dove termina una regione della scheda e ne inizia un'altra. Nella modalità avanzata, ogni regione della scheda viene posizionata separatamente oppure, se una regione più grande viene suddivisa, si ottengono due oggetti regione separati. Nella modalità avanzata, sono i bordi delle regioni adiacenti della scheda a definire dove queste si incontrano, non la presenza di una linea di divisione. Per questa ragione, quando la scheda è in modalità Advanced Rigid-Flex, non è presente alcun oggetto linea di divisione.

► Scopri di più sulla progettazione di un PCB rigido-flessibile

Il menu View offre tre modalità di lavoro dell'editor PCB con scorciatoie facili da ricordare, che consentono di passare rapidamente da una modalità all'altra:

  • Board Planning Mode (1)
  • 2D Layout Mode (2)
  • 3D Layout Mode (3)

Per impostazione predefinita, passando tra le modalità di visualizzazione 2D e 3D, vengono mantenute impostazioni di zoom e orientamento separate per ciascuna modalità. Se desideri visualizzare la stessa posizione e lo stesso orientamento della scheda durante il passaggio, premi Ctrl+Alt+2 o Ctrl+Alt+3, anziché 2 o 3.

Hai appena aperto un PCB e ti chiedi se utilizza la modalità rigido-flessibile standard o quella avanzata?

Puoi aprire il Layer Stack Manager per verificarlo. In alternativa, passa alla modalità di pianificazione della scheda (scorciatoia 1) e osserva la barra attiva:

Modalità Rigid-Flex standard
Modalità Advanced Rigid-Flex

Per definire come deve piegarsi una scheda flessibile, posiziona una o più linee di piegatura. La linea di piegatura definisce il punto sulla superficie della regione flessibile in cui deve avvenire la piegatura. Definisce inoltre l'angolo e il raggio di piegatura. La larghezza della fascia di superficie della scheda sottoposta a piegatura è visualizzata in arancione e viene calcolata in base all'angolo e al raggio di piegatura (scopri di più sulle proprietà della linea di piegatura). Le linee di piegatura vengono posizionate e modificate con l'editor PCB in Board Planning Mode (View » Board Planning Mode, oppure premi la scorciatoia 1).


Una linea di piegatura viene posizionata sulla regione flessibile e configurata in modo che la scheda possa piegarsi di 180 gradi. Questo video mostra come posizionare una linea di piegatura nella modalità Advanced Rigid-Flex.

Posizionamento di una linea di piegatura

Per posizionare una linea di piegatura:

  1. Seleziona View » Board Planning Mode oppure premi la scorciatoia 1 per accedere a Board Planning Mode.
  2. Seleziona il comando Place » Define Bending Line oppure fai clic sul pulsante  nella barra attiva.
  3. Una linea di piegatura viene posizionata sulla regione della scheda desiderata, ma non si collega ad essa (le linee di piegatura vengono associate a una o più regioni della scheda tramite la proprietà Stack Regions). Fai clic vicino al bordo della regione della scheda per definire la posizione iniziale della linea di piegatura.
  4. Sposta il cursore nella posizione finale desiderata e fai clic per posizionare la linea di piegatura. Nota che almeno un'estremità della linea di piegatura deve toccare o attraversare il contorno della regione della scheda a cui si applica.
  5. Rimani nella modalità di posizionamento delle linee di piegatura, pronto a posizionarne un'altra, se necessario. In caso contrario, fai clic con il pulsante destro del mouse oppure premi Esc per uscire dalla modalità di posizionamento delle linee di piegatura.

Le proprietà di una linea di piegatura selezionata possono essere modificate nel pannello Properties. Poiché la linea di piegatura si trova sopra una regione, potresti notare che, facendo clic sulla linea di piegatura, viene selezionata invece la regione sottostante. Senza spostare il cursore, fai clic una seconda volta per selezionare la linea di piegatura anziché la regione della scheda.

Le proprietà della linea di piegatura selezionata vengono visualizzate nel pannello Proprietà.
Le proprietà della linea di piegatura selezionata vengono visualizzate nel pannello Proprietà.

  • Non è necessario che l'inizio o la fine della linea di piegatura si trovino esattamente sul bordo della regione della scheda: il software estende o accorcia automaticamente la linea di piegatura in modo che vada da un bordo all'altro della regione.
  • Assicurati che nella sezione Stack Regions del pannello Properties sia abilitata la regione della scheda corretta.

Spostamento di una linea di piegatura

Per modificare la posizione di una linea di piegatura esistente:

  1. Seleziona View » Board Planning Mode (oppure premi la scorciatoia 1) per accedere a Board Planning Mode.
  2. Fai clic e tieni premuto sul vertice a una delle estremità della linea di piegatura, quindi trascinalo nella posizione desiderata e rilascia il pulsante del mouse. Il cursore sarà vincolato alle impostazioni di aggancio correnti; premi Ctrl+E per modificarle durante l'operazione.
  3. La posizione della piegatura verrà ridefinita dalla nuova posizione della linea di piegatura.

Seleziona e trascina un vertice della linea di piegatura per modificarne la posizione sulla scheda: il cursore sarà vincolato alle impostazioni di aggancio correnti.
Seleziona e trascina un vertice della linea di piegatura per modificarne la posizione sulla scheda: il cursore sarà vincolato alle impostazioni di aggancio correnti.

Posizionamento preciso di una linea di piegatura

Quando si sposta la maniglia di una linea di piegatura, questa si aggancia in base alle impostazioni di aggancio correnti. Premi Ctrl+E durante lo spostamento per aprire il pannello di controllo interattivo delle impostazioni di aggancio, come mostrato nell'immagine seguente. Dopo aver modificato le impostazioni, premi Esc per applicarle e chiudere il pannello.

Oltre che alla griglia di aggancio e alle guide dell'area di lavoro, la linea di piegatura può essere agganciata anche a oggetti di progettazione esistenti, come le linee su un layer meccanico. L'immagine seguente mostra la maniglia di una linea di piegatura posizionata sul vertice finale di una linea su un layer meccanico. Nota che durante lo spostamento si applica l'impostazione corrente di aggancio ai punti notevoli (visualizzata nella barra di stato); se il layer meccanico non è il layer di progettazione attivo, l'aggancio ai punti notevoli deve essere configurato su All Layers affinché questo comportamento funzioni. Premi la scorciatoia Shift+E per passare ciclicamente tra le modalità disponibili dell'impostazione di aggancio ai punti notevoli durante l'operazione.

La maniglia di una linea di piegatura viene agganciata al vertice di una pista posizionata su un layer meccanico.
La maniglia di una linea di piegatura viene agganciata al vertice di una pista posizionata su un layer meccanico.

Rimozione di una linea di piegatura

Per rimuovere una linea di piegatura:

  1. Seleziona View » Board Planning Mode (oppure premi la scorciatoia 1) per accedere a Board Planning Mode.
  2. Fai clic e tieni premuto su uno dei vertici per selezionare la linea di piegatura, quindi premi il tasto Delete.

Configurazione delle proprietà della linea di piegatura

Per modificare le proprietà di una linea di piegatura nel pannello Properties:

  1. Passa a Board Planning Mode (premi 1).
  2. Fai clic in un punto qualsiasi all'interno della fascia arancione della linea di piegatura per selezionarla.
  3. La linea di piegatura può essere modificata nel pannello Properties.

Le piegature definite possono essere applicate quando la scheda è visualizzata in modalità 3D; premere la scorciatoia da tastiera 5 per piegare la scheda. La regione rigida della scheda con la casella di controllo 3D Locked selezionata costituisce il riferimento fisico di base per la modalità di visualizzazione 3D (dove Z = 0). Se la scheda non si piega come previsto, verificare che la casella di controllo 3D Locked sia selezionata per la regione rigida corretta. Non è necessario deselezionare l'opzione in una regione della scheda prima di abilitarla in un'altra.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents